%%ItemTitle%%

GrapeCity.Forguncy.SecurityProvider
GrapeCity.Forguncy.SecurityProvider Assembly
Namespaces
Namespace | Description
GrapeCity.Forguncy.SecurityProvider |
Send Feedback


%%ItemTitle%%

GrapeCity.Forguncy.SecurityProvider Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | ComboEditor | 表示组合框控件。
Class | Editor | 表示编辑控件的基类。
Class | Organization | 表示组织结构信息
Class | OrganizationMember | 表示成员信息
Class | Role | 表示角色信息
Class | SecurityProviderSettings | 表示安全提供程序的一个设置项。
Class | User | 表示用户信息
Class | UserInformations | 表示用户信息
Interfaces
 | Interface | Description
Interface | IOpenIdSecurityProvider | 实现IOpenIdSecurityProvider接口，可以提供OpenId认证的具体逻辑
Interface | ISecurityProvider | 实现ISecurityProvider，可以实现一个安全提供程序，提供第三方系统的认证逻辑
Interface | ISupportSettings | 实现ISupportSettings接口，可以为安全提供程序提供一些自定义配置，这些自定义配置会出现在安全提供程序的管理页面上
Enumerations
 | Enumeration | Description
Enumeration | AuthenticationType | 表示用户认证的类型。
Enumeration | UserInformationStorageMode | 表示从第三方应用获取的数据如何在活字格中保存。
See Also

Reference

GrapeCity.Forguncy.SecurityProvider Assembly


%%PageItemTitle%%

ComboEditor Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : ComboEditor Class
表示组合框控件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ComboEditor
   Inherits Editor
'Usage

Dim instance As ComboEditor
public class ComboEditor : Editor
public ref class ComboEditor : public Editor
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.Editor
GrapeCity.Forguncy.SecurityProvider.ComboEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditor Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

ComboEditor Class Members
Properties

GrapeCity.Forguncy.SecurityProvider Namespace : ComboEditor Class

The following tables list the members exposed by ComboEditor.

Public Constructors
 | Name | Description
Public Constructor | ComboEditor Constructor |
Top
Public Properties
 | Name | Description
Public Property | Items | 表示组合框控件的下拉子项。
Top
See Also

Reference

ComboEditor Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

ComboEditor Constructor

GrapeCity.Forguncy.SecurityProvider Namespace > ComboEditor Class : ComboEditor Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ComboEditor()
public ComboEditor()
public:
ComboEditor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditor Class
ComboEditor Members


%%PageItemTitle%% $$Properties$$

ComboEditor Class Properties

GrapeCity.Forguncy.SecurityProvider Namespace : ComboEditor Class

For a list of all members of this type, see ComboEditor members.

Public Properties
 | Name | Description
Public Property | Items | 表示组合框控件的下拉子项。
Top
See Also

Reference

ComboEditor Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Items Property

GrapeCity.Forguncy.SecurityProvider Namespace > ComboEditor Class : Items Property
表示组合框控件的下拉子项。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Items As List(Of String)
'Usage

Dim instance As ComboEditor
Dim value As List(Of String)

instance.Items = value

value = instance.Items
public List<string> Items {get; set;}
public:
property List<String^>^ Items {
   List<String^>^ get();
   void set (    List<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditor Class
ComboEditor Members


%%PageItemTitle%%

Editor Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : Editor Class
表示编辑控件的基类。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class Editor
'Usage

Dim instance As Editor
public abstract class Editor
public ref class Editor abstract
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.Editor
GrapeCity.Forguncy.SecurityProvider.ComboEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Editor Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

Editor Class Members

GrapeCity.Forguncy.SecurityProvider Namespace : Editor Class

The following tables list the members exposed by Editor.

See Also

Reference

Editor Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

Organization Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : Organization Class
表示组织结构信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Organization
'Usage

Dim instance As Organization
public class Organization
public ref class Organization
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.Organization

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Organization Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

Organization Class Members
Properties Methods

GrapeCity.Forguncy.SecurityProvider Namespace : Organization Class

The following tables list the members exposed by Organization.

Public Constructors
 | Name | Description
Public Constructor | Organization Constructor | 构造函数
Top
Public Properties
 | Name | Description
Public Property | Members | 获取组织的成员列表
Public Property | Name | 获取组织名称
Public Property | SubOrganizations | 获取组织的下级组织
Top
Public Methods
 | Name | Description
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

Organization Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

Organization Constructor

GrapeCity.Forguncy.SecurityProvider Namespace > Organization Class : Organization Constructor
构造函数
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Organization()
public Organization()
public:
Organization();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Organization Class
Organization Members


%%PageItemTitle%% $$Methods$$

Organization Class Methods

GrapeCity.Forguncy.SecurityProvider Namespace : Organization Class

For a list of all members of this type, see Organization members.

Public Methods
 | Name | Description
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

Organization Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

ToString Method (Organization)

GrapeCity.Forguncy.SecurityProvider Namespace > Organization Class : ToString Method
返回表示当前对象的字符串
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As Organization
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

当前对象的字符串
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Organization Class
Organization Members


%%PageItemTitle%% $$Properties$$

Organization Class Properties

GrapeCity.Forguncy.SecurityProvider Namespace : Organization Class

For a list of all members of this type, see Organization members.

Public Properties
 | Name | Description
Public Property | Members | 获取组织的成员列表
Public Property | Name | 获取组织名称
Public Property | SubOrganizations | 获取组织的下级组织
Top
See Also

Reference

Organization Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Members Property

GrapeCity.Forguncy.SecurityProvider Namespace > Organization Class : Members Property
获取组织的成员列表
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Members As HashSet(Of OrganizationMember)
'Usage

Dim instance As Organization
Dim value As HashSet(Of OrganizationMember)

value = instance.Members
public HashSet<OrganizationMember> Members {get;}
public:
property HashSet<OrganizationMember^>^ Members {
   HashSet<OrganizationMember^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Organization Class
Organization Members


%%ItemTitle%%

Name Property (Organization)

GrapeCity.Forguncy.SecurityProvider Namespace > Organization Class : Name Property
获取组织名称
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As Organization
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Organization Class
Organization Members


%%ItemTitle%%

SubOrganizations Property

GrapeCity.Forguncy.SecurityProvider Namespace > Organization Class : SubOrganizations Property
获取组织的下级组织
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property SubOrganizations As List(Of Organization)
'Usage

Dim instance As Organization
Dim value As List(Of Organization)

value = instance.SubOrganizations
public List<Organization> SubOrganizations {get;}
public:
property List<Organization^>^ SubOrganizations {
   List<Organization^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Organization Class
Organization Members


%%PageItemTitle%%

OrganizationMember Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : OrganizationMember Class
表示成员信息
Object Model
OrganizationMember ClassRole ClassUser Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class OrganizationMember
'Usage

Dim instance As OrganizationMember
public class OrganizationMember
public ref class OrganizationMember
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.OrganizationMember

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

OrganizationMember Class Members
Properties Methods

GrapeCity.Forguncy.SecurityProvider Namespace : OrganizationMember Class

The following tables list the members exposed by OrganizationMember.

Public Constructors
 | Name | Description
Public Constructor | OrganizationMember Constructor | 构造函数
Top
Public Properties
 | Name | Description
Public Property | IsLeader | 表示当前组织成员是否是当前组织的领导
Public Property | OrganizationRole | 表示当前组织成员在组织中的角色
Public Property | User | 获取组织成员表示的用户
Top
Public Methods
 | Name | Description
Public Method | Equals | 确定指定的对象是否等于当前对象。
Public Method | GetHashCode | 返回表示当前对象的哈希值
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

OrganizationMember Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

OrganizationMember Constructor

GrapeCity.Forguncy.SecurityProvider Namespace > OrganizationMember Class : OrganizationMember Constructor
构造函数
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OrganizationMember()
public OrganizationMember()
public:
OrganizationMember();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Class
OrganizationMember Members


%%PageItemTitle%% $$Methods$$

OrganizationMember Class Methods

GrapeCity.Forguncy.SecurityProvider Namespace : OrganizationMember Class

For a list of all members of this type, see OrganizationMember members.

Public Methods
 | Name | Description
Public Method | Equals | 确定指定的对象是否等于当前对象。
Public Method | GetHashCode | 返回表示当前对象的哈希值
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

OrganizationMember Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Equals Method (OrganizationMember)

GrapeCity.Forguncy.SecurityProvider Namespace > OrganizationMember Class : Equals Method
要与当前对象进行比较的对象。
确定指定的对象是否等于当前对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As OrganizationMember
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
要与当前对象进行比较的对象。

Return Value

如果指定的对象等于当前对象，则为 true，否则为 false。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Class
OrganizationMember Members


%%ItemTitle%%

GetHashCode Method (OrganizationMember)

GrapeCity.Forguncy.SecurityProvider Namespace > OrganizationMember Class : GetHashCode Method
返回表示当前对象的哈希值
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As OrganizationMember
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

当前对象的哈希代码。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Class
OrganizationMember Members


%%ItemTitle%%

ToString Method (OrganizationMember)

GrapeCity.Forguncy.SecurityProvider Namespace > OrganizationMember Class : ToString Method
返回表示当前对象的字符串
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As OrganizationMember
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

当前对象的字符串
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Class
OrganizationMember Members


%%PageItemTitle%% $$Properties$$

OrganizationMember Class Properties

GrapeCity.Forguncy.SecurityProvider Namespace : OrganizationMember Class

For a list of all members of this type, see OrganizationMember members.

Public Properties
 | Name | Description
Public Property | IsLeader | 表示当前组织成员是否是当前组织的领导
Public Property | OrganizationRole | 表示当前组织成员在组织中的角色
Public Property | User | 获取组织成员表示的用户
Top
See Also

Reference

OrganizationMember Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

IsLeader Property

GrapeCity.Forguncy.SecurityProvider Namespace > OrganizationMember Class : IsLeader Property
表示当前组织成员是否是当前组织的领导
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IsLeader As Boolean
'Usage

Dim instance As OrganizationMember
Dim value As Boolean

instance.IsLeader = value

value = instance.IsLeader
public bool IsLeader {get; set;}
public:
property bool IsLeader {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Class
OrganizationMember Members


%%ItemTitle%%

OrganizationRole Property

GrapeCity.Forguncy.SecurityProvider Namespace > OrganizationMember Class : OrganizationRole Property
表示当前组织成员在组织中的角色
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OrganizationRole As Role
'Usage

Dim instance As OrganizationMember
Dim value As Role

instance.OrganizationRole = value

value = instance.OrganizationRole
public Role OrganizationRole {get; set;}
public:
property Role^ OrganizationRole {
   Role^ get();
   void set (    Role^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Class
OrganizationMember Members


%%ItemTitle%%

User Property

GrapeCity.Forguncy.SecurityProvider Namespace > OrganizationMember Class : User Property
获取组织成员表示的用户
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property User As User
'Usage

Dim instance As OrganizationMember
Dim value As User

instance.User = value

value = instance.User
public User User {get; set;}
public:
property User^ User {
   User^ get();
   void set (    User^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrganizationMember Class
OrganizationMember Members


%%PageItemTitle%%

Role Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : Role Class
表示角色信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class Role
'Usage

Dim instance As Role
public class Role
public ref class Role
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.Role

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Role Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

Role Class Members
Properties Methods

GrapeCity.Forguncy.SecurityProvider Namespace : Role Class

The following tables list the members exposed by Role.

Public Constructors
 | Name | Description
Public Constructor | Role Constructor | 构造函数
Top
Public Properties
 | Name | Description
Public Property | Name | 获取角色名称
Public Property | Users |
Top
Public Methods
 | Name | Description
Public Method | Equals | 确定指定的对象是否等于当前对象。
Public Method | GetHashCode | 返回表示当前对象的哈希值
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

Role Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

Role Constructor

GrapeCity.Forguncy.SecurityProvider Namespace > Role Class : Role Constructor
构造函数
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Role()
public Role()
public:
Role();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Role Class
Role Members


%%PageItemTitle%% $$Methods$$

Role Class Methods

GrapeCity.Forguncy.SecurityProvider Namespace : Role Class

For a list of all members of this type, see Role members.

Public Methods
 | Name | Description
Public Method | Equals | 确定指定的对象是否等于当前对象。
Public Method | GetHashCode | 返回表示当前对象的哈希值
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

Role Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Equals Method (Role)

GrapeCity.Forguncy.SecurityProvider Namespace > Role Class : Equals Method
要与当前对象进行比较的对象。
确定指定的对象是否等于当前对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As Role
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
要与当前对象进行比较的对象。

Return Value

如果指定的对象等于当前对象，则为 true，否则为 false。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Role Class
Role Members


%%ItemTitle%%

GetHashCode Method (Role)

GrapeCity.Forguncy.SecurityProvider Namespace > Role Class : GetHashCode Method
返回表示当前对象的哈希值
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As Role
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

当前对象的哈希代码。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Role Class
Role Members


%%ItemTitle%%

ToString Method (Role)

GrapeCity.Forguncy.SecurityProvider Namespace > Role Class : ToString Method
返回表示当前对象的字符串
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As Role
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

当前对象的字符串
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Role Class
Role Members


%%PageItemTitle%% $$Properties$$

Role Class Properties

GrapeCity.Forguncy.SecurityProvider Namespace : Role Class

For a list of all members of this type, see Role members.

Public Properties
 | Name | Description
Public Property | Name | 获取角色名称
Public Property | Users |
Top
See Also

Reference

Role Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Name Property (Role)

GrapeCity.Forguncy.SecurityProvider Namespace > Role Class : Name Property
获取角色名称
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As Role
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Role Class
Role Members


%%ItemTitle%%

Users Property (Role)

GrapeCity.Forguncy.SecurityProvider Namespace > Role Class : Users Property
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Users As HashSet(Of User)
'Usage

Dim instance As Role
Dim value As HashSet(Of User)

value = instance.Users
public HashSet<User> Users {get;}
public:
property HashSet<User^>^ Users {
   HashSet<User^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Role Class
Role Members


%%PageItemTitle%%

SecurityProviderSettings Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : SecurityProviderSettings Class
表示安全提供程序的一个设置项。
Object Model
SecurityProviderSettings ClassEditor Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class SecurityProviderSettings
'Usage

Dim instance As SecurityProviderSettings
public class SecurityProviderSettings
public ref class SecurityProviderSettings
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.SecurityProviderSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SecurityProviderSettings Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

SecurityProviderSettings Class Members
Properties

GrapeCity.Forguncy.SecurityProvider Namespace : SecurityProviderSettings Class

The following tables list the members exposed by SecurityProviderSettings.

Public Constructors
 | Name | Description
Public Constructor | SecurityProviderSettings Constructor |
Top
Public Properties
 | Name | Description
Public Property | Description | 表示该设置的说明文字。
Public Property | DisplayName | 设置的显示名称。
Public Property | Editor | 表示该设置使用什么样的编辑控件来编辑。
Public Property | Name | 设置的名称。
Public Property | Value | 表示该设置的值。
Top
See Also

Reference

SecurityProviderSettings Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

SecurityProviderSettings Constructor

GrapeCity.Forguncy.SecurityProvider Namespace > SecurityProviderSettings Class : SecurityProviderSettings Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SecurityProviderSettings()
public SecurityProviderSettings()
public:
SecurityProviderSettings();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SecurityProviderSettings Class
SecurityProviderSettings Members


%%PageItemTitle%% $$Properties$$

SecurityProviderSettings Class Properties

GrapeCity.Forguncy.SecurityProvider Namespace : SecurityProviderSettings Class

For a list of all members of this type, see SecurityProviderSettings members.

Public Properties
 | Name | Description
Public Property | Description | 表示该设置的说明文字。
Public Property | DisplayName | 设置的显示名称。
Public Property | Editor | 表示该设置使用什么样的编辑控件来编辑。
Public Property | Name | 设置的名称。
Public Property | Value | 表示该设置的值。
Top
See Also

Reference

SecurityProviderSettings Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Description Property

GrapeCity.Forguncy.SecurityProvider Namespace > SecurityProviderSettings Class : Description Property
表示该设置的说明文字。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Description As String
'Usage

Dim instance As SecurityProviderSettings
Dim value As String

instance.Description = value

value = instance.Description
public string Description {get; set;}
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SecurityProviderSettings Class
SecurityProviderSettings Members


%%ItemTitle%%

DisplayName Property

GrapeCity.Forguncy.SecurityProvider Namespace > SecurityProviderSettings Class : DisplayName Property
设置的显示名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisplayName As String
'Usage

Dim instance As SecurityProviderSettings
Dim value As String

instance.DisplayName = value

value = instance.DisplayName
public string DisplayName {get; set;}
public:
property String^ DisplayName {
   String^ get();
   void set (    String^ value);
}
Remarks
如果该属性值为Null，活字格会使用Name属性的值作为显示名称。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SecurityProviderSettings Class
SecurityProviderSettings Members


%%ItemTitle%%

Editor Property

GrapeCity.Forguncy.SecurityProvider Namespace > SecurityProviderSettings Class : Editor Property
表示该设置使用什么样的编辑控件来编辑。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Editor As Editor
'Usage

Dim instance As SecurityProviderSettings
Dim value As Editor

instance.Editor = value

value = instance.Editor
public Editor Editor {get; set;}
public:
property Editor^ Editor {
   Editor^ get();
   void set (    Editor^ value);
}
Remarks
如果这个属性的值为空表示使用文本框编辑。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SecurityProviderSettings Class
SecurityProviderSettings Members


%%ItemTitle%%

Name Property (SecurityProviderSettings)

GrapeCity.Forguncy.SecurityProvider Namespace > SecurityProviderSettings Class : Name Property
设置的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As SecurityProviderSettings
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SecurityProviderSettings Class
SecurityProviderSettings Members


%%ItemTitle%%

Value Property

GrapeCity.Forguncy.SecurityProvider Namespace > SecurityProviderSettings Class : Value Property
表示该设置的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As SecurityProviderSettings
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SecurityProviderSettings Class
SecurityProviderSettings Members


%%PageItemTitle%%

User Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : User Class
表示用户信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class User
'Usage

Dim instance As User
public class User
public ref class User
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.User

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

User Class Members
Properties Methods

GrapeCity.Forguncy.SecurityProvider Namespace : User Class

The following tables list the members exposed by User.

Public Constructors
 | Name | Description
Public Constructor | User Constructor | 构造函数
Top
Public Properties
 | Name | Description
Public Property | Email | 表示用户的邮箱地址
Public Property | FullName | 表示用户显示名称
Public Property | Properties | 表示用户的自定义属性
Public Property | UserId | 表示用户Id
Top
Public Methods
 | Name | Description
Public Method | Equals | 确定指定的对象是否等于当前对象。
Public Method | GetHashCode | 返回表示当前对象的哈希值
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

User Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

User Constructor

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : User Constructor
构造函数
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New User()
public User()
public:
User();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%PageItemTitle%% $$Methods$$

User Class Methods

GrapeCity.Forguncy.SecurityProvider Namespace : User Class

For a list of all members of this type, see User members.

Public Methods
 | Name | Description
Public Method | Equals | 确定指定的对象是否等于当前对象。
Public Method | GetHashCode | 返回表示当前对象的哈希值
Public Method | ToString | 返回表示当前对象的字符串
Top
See Also

Reference

User Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Equals Method (User)

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : Equals Method
要与当前对象进行比较的对象。
确定指定的对象是否等于当前对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As User
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
要与当前对象进行比较的对象。

Return Value

如果指定的对象等于当前对象，则为 true，否则为 false。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%ItemTitle%%

GetHashCode Method (User)

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : GetHashCode Method
返回表示当前对象的哈希值
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As User
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

当前对象的哈希代码。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%ItemTitle%%

ToString Method (User)

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : ToString Method
返回表示当前对象的字符串
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As User
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

当前对象的字符串
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%PageItemTitle%% $$Properties$$

User Class Properties

GrapeCity.Forguncy.SecurityProvider Namespace : User Class

For a list of all members of this type, see User members.

Public Properties
 | Name | Description
Public Property | Email | 表示用户的邮箱地址
Public Property | FullName | 表示用户显示名称
Public Property | Properties | 表示用户的自定义属性
Public Property | UserId | 表示用户Id
Top
See Also

Reference

User Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Email Property

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : Email Property
表示用户的邮箱地址
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Email As String
'Usage

Dim instance As User
Dim value As String

instance.Email = value

value = instance.Email
public string Email {get; set;}
public:
property String^ Email {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%ItemTitle%%

FullName Property

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : FullName Property
表示用户显示名称
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FullName As String
'Usage

Dim instance As User
Dim value As String

instance.FullName = value

value = instance.FullName
public string FullName {get; set;}
public:
property String^ FullName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%ItemTitle%%

Properties Property

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : Properties Property
表示用户的自定义属性
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Properties As Dictionary(Of String,Object)
'Usage

Dim instance As User
Dim value As Dictionary(Of String,Object)

value = instance.Properties
public Dictionary<string,object> Properties {get;}
public:
property Dictionary<String^,Object^>^ Properties {
   Dictionary<String^,Object^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%ItemTitle%%

UserId Property

GrapeCity.Forguncy.SecurityProvider Namespace > User Class : UserId Property
表示用户Id
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UserId As String
'Usage

Dim instance As User
Dim value As String

instance.UserId = value

value = instance.UserId
public string UserId {get; set;}
public:
property String^ UserId {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

User Class
User Members


%%PageItemTitle%%

UserInformations Class
Members

GrapeCity.Forguncy.SecurityProvider Namespace : UserInformations Class
表示用户信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class UserInformations
'Usage

Dim instance As UserInformations
public class UserInformations
public ref class UserInformations
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.SecurityProvider.UserInformations

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInformations Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

UserInformations Class Members
Properties

GrapeCity.Forguncy.SecurityProvider Namespace : UserInformations Class

The following tables list the members exposed by UserInformations.

Public Constructors
 | Name | Description
Public Constructor | UserInformations Constructor | 构造函数
Top
Public Properties
 | Name | Description
Public Property | Organizations | 获取组织结构信息
Public Property | Roles | 获取角色信息
Public Property | Users | 获取用户信息
Top
See Also

Reference

UserInformations Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

UserInformations Constructor

GrapeCity.Forguncy.SecurityProvider Namespace > UserInformations Class : UserInformations Constructor
构造函数
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New UserInformations()
public UserInformations()
public:
UserInformations();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInformations Class
UserInformations Members


%%PageItemTitle%% $$Properties$$

UserInformations Class Properties

GrapeCity.Forguncy.SecurityProvider Namespace : UserInformations Class

For a list of all members of this type, see UserInformations members.

Public Properties
 | Name | Description
Public Property | Organizations | 获取组织结构信息
Public Property | Roles | 获取角色信息
Public Property | Users | 获取用户信息
Top
See Also

Reference

UserInformations Class
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Organizations Property

GrapeCity.Forguncy.SecurityProvider Namespace > UserInformations Class : Organizations Property
获取组织结构信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Organizations As List(Of Organization)
'Usage

Dim instance As UserInformations
Dim value As List(Of Organization)

value = instance.Organizations
public List<Organization> Organizations {get;}
public:
property List<Organization^>^ Organizations {
   List<Organization^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInformations Class
UserInformations Members


%%ItemTitle%%

Roles Property

GrapeCity.Forguncy.SecurityProvider Namespace > UserInformations Class : Roles Property
获取角色信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Roles As HashSet(Of Role)
'Usage

Dim instance As UserInformations
Dim value As HashSet(Of Role)

value = instance.Roles
public HashSet<Role> Roles {get;}
public:
property HashSet<Role^>^ Roles {
   HashSet<Role^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInformations Class
UserInformations Members


%%ItemTitle%%

Users Property (UserInformations)

GrapeCity.Forguncy.SecurityProvider Namespace > UserInformations Class : Users Property
获取用户信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Users As HashSet(Of User)
'Usage

Dim instance As UserInformations
Dim value As HashSet(Of User)

value = instance.Users
public HashSet<User> Users {get;}
public:
property HashSet<User^>^ Users {
   HashSet<User^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInformations Class
UserInformations Members


%%PageItemTitle%%

AuthenticationType Enumeration

GrapeCity.Forguncy.SecurityProvider Namespace : AuthenticationType Enumeration
表示用户认证的类型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum AuthenticationType
   Inherits System.Enum
'Usage

Dim instance As AuthenticationType
public enum AuthenticationType : System.Enum
public enum class AuthenticationType : public System.Enum
Members
Member | Description
OpenId | 表示OpenId(OAuth2)认证。
Unknown | 未知类型。
UserNameAndPassword | 表示通过用户名和密码认证。
WindowsAuthentication | 表示使用Windows域集成认证。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.SecurityProvider.AuthenticationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

UserInformationStorageMode Enumeration

GrapeCity.Forguncy.SecurityProvider Namespace : UserInformationStorageMode Enumeration
表示从第三方应用获取的数据如何在活字格中保存。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum UserInformationStorageMode
   Inherits System.Enum
'Usage

Dim instance As UserInformationStorageMode
public enum UserInformationStorageMode : System.Enum
public enum class UserInformationStorageMode : public System.Enum
Members
Member | Description
InForguncyDatabase | 在该模式下，用户首次登陆时，会把用户添加到活字格的用户数据库中。 管理员需要到活字格的用户数据库中为用户分配角色和组织信息。 如果用户已经被加入到活字格的用户数据库中，此时在第三方应用中删除该用户或者修改用户属性不会自动同步到活字格的数据库中
InMemoryCache | 在该模式下，活字格会在网站启动时从第三方应用获取全部用户信息，包括用户，用户属性，角色及组织结构信息。 并且缓存在网站的内存中，活字格应用会使用这些用户信息判断权限，工作流程等。 活字格会每间隔一定时间从第三方网站同步一次最新的用户数据（默认为20分钟），可以根据业务需要调整同步的间隔时间。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.SecurityProvider.UserInformationStorageMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%%

IOpenIdSecurityProvider Interface
Members

GrapeCity.Forguncy.SecurityProvider Namespace : IOpenIdSecurityProvider Interface
实现IOpenIdSecurityProvider接口，可以提供OpenId认证的具体逻辑
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IOpenIdSecurityProvider
'Usage

Dim instance As IOpenIdSecurityProvider
public interface IOpenIdSecurityProvider
public interface class IOpenIdSecurityProvider
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOpenIdSecurityProvider Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

IOpenIdSecurityProvider Interface Members
Methods

GrapeCity.Forguncy.SecurityProvider Namespace : IOpenIdSecurityProvider Interface

The following tables list the members exposed by IOpenIdSecurityProvider.

Public Methods
 | Name | Description
Method | GetRedirectUrl | 获取通重定向到OpenId服务器上的URL
Top
See Also

Reference

IOpenIdSecurityProvider Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Methods$$

IOpenIdSecurityProvider Interface Methods

GrapeCity.Forguncy.SecurityProvider Namespace : IOpenIdSecurityProvider Interface

For a list of all members of this type, see IOpenIdSecurityProvider members.

Public Methods
 | Name | Description
Method | GetRedirectUrl | 获取通重定向到OpenId服务器上的URL
Top
See Also

Reference

IOpenIdSecurityProvider Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

GetRedirectUrl Method

GrapeCity.Forguncy.SecurityProvider Namespace > IOpenIdSecurityProvider Interface : GetRedirectUrl Method
认证后跳转回活字格的URL
这个参数是用于做安全校验的，OpenId服务器的RedirectURL会需要这个参数，并在登录时原样返回，以便防止跨站攻击
访问应用的userAgent
获取通重定向到OpenId服务器上的URL
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetRedirectUrl( _
   ByVal redirect_uri As String, _
   ByVal state As String, _
   ByVal userAgent As String _
) As String
'Usage

Dim instance As IOpenIdSecurityProvider
Dim redirect_uri As String
Dim state As String
Dim userAgent As String
Dim value As String

value = instance.GetRedirectUrl(redirect_uri, state, userAgent)
string GetRedirectUrl(
   string redirect_uri,
   string state,
   string userAgent
)
String^ GetRedirectUrl(
   String^ redirect_uri,
   String^ state,
   String^ userAgent
)

Parameters

redirect_uri
认证后跳转回活字格的URL
state
这个参数是用于做安全校验的，OpenId服务器的RedirectURL会需要这个参数，并在登录时原样返回，以便防止跨站攻击
userAgent
访问应用的userAgent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IOpenIdSecurityProvider Interface
IOpenIdSecurityProvider Members


%%PageItemTitle%%

ISecurityProvider Interface
Members

GrapeCity.Forguncy.SecurityProvider Namespace : ISecurityProvider Interface
实现ISecurityProvider，可以实现一个安全提供程序，提供第三方系统的认证逻辑
Object Model
ISecurityProvider InterfaceUserInformations Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISecurityProvider
'Usage

Dim instance As ISecurityProvider
public interface ISecurityProvider
public interface class ISecurityProvider
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

ISecurityProvider Interface Members
Properties Methods

GrapeCity.Forguncy.SecurityProvider Namespace : ISecurityProvider Interface

The following tables list the members exposed by ISecurityProvider.

Public Properties
 | Name | Description
Property | AllowLogout | 是否允许用户执行登出操作
Property | AuthenticationType | 安全提供程序的验证类型
Property | Name | 安全提供程序的名称
Property | UserInformations | 获取第三方系统的全部用户信息
Property | UserInformationStorageMode | 表示如何存储第三方应用的用户信息
Top
Public Methods
 | Name | Description
Method | VerifyUser | 认证第三方系统用户是否有效
Top
See Also

Reference

ISecurityProvider Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Methods$$

ISecurityProvider Interface Methods

GrapeCity.Forguncy.SecurityProvider Namespace : ISecurityProvider Interface

For a list of all members of this type, see ISecurityProvider members.

Public Methods
 | Name | Description
Method | VerifyUser | 认证第三方系统用户是否有效
Top
See Also

Reference

ISecurityProvider Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

VerifyUser Method

GrapeCity.Forguncy.SecurityProvider Namespace > ISecurityProvider Interface : VerifyUser Method
表示认证用户所需要的属性 如果AuthenticationType是UserNameAndPassword，包含的属性有 "userName" 和 "password" 如果AuthenticationType是WindowsAuthentication， 这个方法不需要实现 如果AuthenticationType是OpenId，不同的网站需要认证的属性不同，通常是token，code，state等
认证第三方系统用户是否有效
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function VerifyUser( _
   ByVal properties As Dictionary(Of String,String) _
) As User
'Usage

Dim instance As ISecurityProvider
Dim properties As Dictionary(Of String,String)
Dim value As User

value = instance.VerifyUser(properties)
User VerifyUser(
   Dictionary<string,string> properties
)
User^ VerifyUser(
   Dictionary<String^,String^>^ properties
)

Parameters

properties
表示认证用户所需要的属性 如果AuthenticationType是UserNameAndPassword，包含的属性有 "userName" 和 "password" 如果AuthenticationType是WindowsAuthentication， 这个方法不需要实现 如果AuthenticationType是OpenId，不同的网站需要认证的属性不同，通常是token，code，state等

Return Value

如果验证成功，返回登录用户，否则返回空。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


%%PageItemTitle%% $$Properties$$

ISecurityProvider Interface Properties

GrapeCity.Forguncy.SecurityProvider Namespace : ISecurityProvider Interface

For a list of all members of this type, see ISecurityProvider members.

Public Properties
 | Name | Description
Property | AllowLogout | 是否允许用户执行登出操作
Property | AuthenticationType | 安全提供程序的验证类型
Property | Name | 安全提供程序的名称
Property | UserInformations | 获取第三方系统的全部用户信息
Property | UserInformationStorageMode | 表示如何存储第三方应用的用户信息
Top
See Also

Reference

ISecurityProvider Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

AllowLogout Property

GrapeCity.Forguncy.SecurityProvider Namespace > ISecurityProvider Interface : AllowLogout Property
是否允许用户执行登出操作
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AllowLogout As Boolean
'Usage

Dim instance As ISecurityProvider
Dim value As Boolean

value = instance.AllowLogout
bool AllowLogout {get;}
property bool AllowLogout {
   bool get();
}
Remarks
一般情况下，如果认证模式是密码认证，改属性的值应该为True，如果认证模式为Windows域认证，该属性值为False，如果认证模式是OpenId，该属性值有可能为True有可能为False
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


%%ItemTitle%%

AuthenticationType Property

GrapeCity.Forguncy.SecurityProvider Namespace > ISecurityProvider Interface : AuthenticationType Property
安全提供程序的验证类型
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AuthenticationType As AuthenticationType
'Usage

Dim instance As ISecurityProvider
Dim value As AuthenticationType

value = instance.AuthenticationType
AuthenticationType AuthenticationType {get;}
property AuthenticationType AuthenticationType {
   AuthenticationType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


%%ItemTitle%%

Name Property (ISecurityProvider)

GrapeCity.Forguncy.SecurityProvider Namespace > ISecurityProvider Interface : Name Property
安全提供程序的名称
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Name As String
'Usage

Dim instance As ISecurityProvider
Dim value As String

value = instance.Name
string Name {get;}
property String^ Name {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


%%ItemTitle%%

UserInformations Property

GrapeCity.Forguncy.SecurityProvider Namespace > ISecurityProvider Interface : UserInformations Property
获取第三方系统的全部用户信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property UserInformations As UserInformations
'Usage

Dim instance As ISecurityProvider
Dim value As UserInformations

value = instance.UserInformations
UserInformations UserInformations {get;}
property UserInformations^ UserInformations {
   UserInformations^ get();
}
Remarks
这个属性只有在UserInformationStorageMode属性的值为InMemoryCache时起作用
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


%%ItemTitle%%

UserInformationStorageMode Property

GrapeCity.Forguncy.SecurityProvider Namespace > ISecurityProvider Interface : UserInformationStorageMode Property
表示如何存储第三方应用的用户信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property UserInformationStorageMode As UserInformationStorageMode
'Usage

Dim instance As ISecurityProvider
Dim value As UserInformationStorageMode

value = instance.UserInformationStorageMode
UserInformationStorageMode UserInformationStorageMode {get;}
property UserInformationStorageMode UserInformationStorageMode {
   UserInformationStorageMode get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


%%PageItemTitle%%

ISupportSettings Interface
Members

GrapeCity.Forguncy.SecurityProvider Namespace : ISupportSettings Interface
实现ISupportSettings接口，可以为安全提供程序提供一些自定义配置，这些自定义配置会出现在安全提供程序的管理页面上
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISupportSettings
'Usage

Dim instance As ISupportSettings
public interface ISupportSettings
public interface class ISupportSettings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportSettings Members
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Members$$

ISupportSettings Interface Members
Properties Methods

GrapeCity.Forguncy.SecurityProvider Namespace : ISupportSettings Interface

The following tables list the members exposed by ISupportSettings.

Public Properties
 | Name | Description
Property | Settings | 设置列表
Top
Public Methods
 | Name | Description
Method | UpdateSetting | 更新设置
Top
See Also

Reference

ISupportSettings Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%PageItemTitle%% $$Methods$$

ISupportSettings Interface Methods

GrapeCity.Forguncy.SecurityProvider Namespace : ISupportSettings Interface

For a list of all members of this type, see ISupportSettings members.

Public Methods
 | Name | Description
Method | UpdateSetting | 更新设置
Top
See Also

Reference

ISupportSettings Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

UpdateSetting Method

GrapeCity.Forguncy.SecurityProvider Namespace > ISupportSettings Interface : UpdateSetting Method
要更新的设置列表，每一项的Key表示设置的名称，Value表示新值
更新设置
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub UpdateSetting( _
   ByVal dictionary As Dictionary(Of String,Object) _
)
'Usage

Dim instance As ISupportSettings
Dim dictionary As Dictionary(Of String,Object)

instance.UpdateSetting(dictionary)
void UpdateSetting(
   Dictionary<string,object> dictionary
)
void UpdateSetting(
   Dictionary<String^,Object^>^ dictionary
)

Parameters

dictionary
要更新的设置列表，每一项的Key表示设置的名称，Value表示新值
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportSettings Interface
ISupportSettings Members


%%PageItemTitle%% $$Properties$$

ISupportSettings Interface Properties

GrapeCity.Forguncy.SecurityProvider Namespace : ISupportSettings Interface

For a list of all members of this type, see ISupportSettings members.

Public Properties
 | Name | Description
Property | Settings | 设置列表
Top
See Also

Reference

ISupportSettings Interface
GrapeCity.Forguncy.SecurityProvider Namespace


%%ItemTitle%%

Settings Property

GrapeCity.Forguncy.SecurityProvider Namespace > ISupportSettings Interface : Settings Property
设置列表
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Settings As List(Of SecurityProviderSettings)
'Usage

Dim instance As ISupportSettings
Dim value As List(Of SecurityProviderSettings)

value = instance.Settings
List<SecurityProviderSettings> Settings {get;}
property List<SecurityProviderSettings^>^ Settings {
   List<SecurityProviderSettings^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportSettings Interface
ISupportSettings Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.SecurityProvider Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.SecurityProvider.Editor
GrapeCity.Forguncy.SecurityProvider.ComboEditor
GrapeCity.Forguncy.SecurityProvider.Organization
GrapeCity.Forguncy.SecurityProvider.OrganizationMember
GrapeCity.Forguncy.SecurityProvider.Role
GrapeCity.Forguncy.SecurityProvider.SecurityProviderSettings
GrapeCity.Forguncy.SecurityProvider.User
GrapeCity.Forguncy.SecurityProvider.UserInformations
See Also

Reference

GrapeCity.Forguncy.SecurityProvider Assembly