%%ItemTitle%%

Forguncy Help Document
Forguncy.Commands Assembly
Namespaces
Namespace | Description
GrapeCity.Forguncy.Commands |
Send Feedback


%%ItemTitle%%

GrapeCity.Forguncy.Commands Namespace (Forguncy.Commands)
Inheritance Hierarchy
Classes
 | Class | Description
Class | Command | 命令类型插件的父类定义。
Class | ExecuteResult | 命令的执行结果。
Class | ExportPageSettingBase | 导出页面相关设置。
Class | ExportPageToExcelSetting | 导出页面到Excel相关设置。
Class | ExportPageToPdfSetting | 导出页面到PDF相关设置。
Interfaces
 | Interface | Description
Interface | ICommandCellInfo | 命令单元格信息。详情参照。
Interface | ICommandExecutableInServerSide | 具有可独立执行能力的命令需要实现这个接口。 用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。
Interface | ICommandExecutableInServerSideAsync | 具有可独立执行能力的命令需要实现这个接口。 用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。
Interface | IContainSubCommands | 迭代当前命令的子命令，用于查找替换。
Interface | IExportHelper | 提供导出相关的方法。
Interface | ILog | 提供打印日志的方法。
Interface | IServerCommandExecuteContext | 当在服务器端执行实现了ICommandExecutableInServerSide接口的命令时，从服务器端传递的上下文信息。
Interface | ISubListCommand | 如果命令包含子命令(例如循环命令)，则需要实现该接口。
Interface | IUpdateDatabaseCommand | 提供更新数据库的方法。
Enumerations
 | Enumeration | Description
Enumeration | CommandScope | 活字格打开编辑命令窗口时会根据使用范围的不同显示不同的命令集合，该Flags枚举列出了以下几种范围。
Enumeration | LogLevel | 日志详细程度。
Enumeration | ProcessControl | 流程控制信息。
See Also

Reference

Forguncy.Commands Assembly


%%PageItemTitle%%

Command Class
Members Example

GrapeCity.Forguncy.Commands Namespace : Command Class
命令类型插件的父类定义。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<IconAttribute(pack://application:,,,/Forguncy;component/Images/EditingCommand16.png)>
Public MustInherit Class Command
'Usage

Dim instance As Command
[Icon(pack://application:,,,/Forguncy;component/Images/EditingCommand16.png)]
public abstract class Command
[Icon(pack://application:,,,/Forguncy;component/Images/EditingCommand16.png)]
public ref class Command abstract
Example
  • C#
public class MyPluginCommand : Command
{
    ...
}
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Commands.Command

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

Command Class Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : Command Class

The following tables list the members exposed by Command.

Public Properties
 | Name | Description
Public Property | Comments | 命令的注释。
Public Property | Disabled | 命令是否被禁用。
Top
Public Methods
 | Name | Description
Public Method | Clone | 克隆命令插件。
Public Method | ContainSubCommands | 指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
Public Method | GetCommandScope | 指定命令插件的使用范围。
Public Method | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
Public Method | InitDefaultPropertyValues | 初始化默认属性值。
Public Method | ToString | 命令插件的显示名称，默认与插件定义的类名一样。
Public Method | WillNavigateOrReload | 该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
Top
See Also

Reference

Command Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

Command Class Methods

GrapeCity.Forguncy.Commands Namespace : Command Class

For a list of all members of this type, see Command members.

Public Methods
 | Name | Description
Public Method | Clone | 克隆命令插件。
Public Method | ContainSubCommands | 指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
Public Method | GetCommandScope | 指定命令插件的使用范围。
Public Method | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
Public Method | InitDefaultPropertyValues | 初始化默认属性值。
Public Method | ToString | 命令插件的显示名称，默认与插件定义的类名一样。
Public Method | WillNavigateOrReload | 该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
Top
See Also

Reference

Command Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

Clone Method (Command)

GrapeCity.Forguncy.Commands Namespace > Command Class : Clone Method
克隆命令插件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function Clone() As Command
'Usage

Dim instance As Command
Dim value As Command

value = instance.Clone()
public virtual Command Clone()
public:
virtual Command^ Clone();

Return Value

返回克隆后的命令。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%ItemTitle%%

ContainSubCommands Method

GrapeCity.Forguncy.Commands Namespace > Command Class : ContainSubCommands Method
指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function ContainSubCommands() As Boolean
'Usage

Dim instance As Command
Dim value As Boolean

value = instance.ContainSubCommands()
public virtual bool ContainSubCommands()
public:
virtual bool ContainSubCommands();

Return Value

返回true表示包含子命令，否则不包含。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%ItemTitle%%

GetCommandScope Method

GrapeCity.Forguncy.Commands Namespace > Command Class : GetCommandScope Method
指定命令插件的使用范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetCommandScope() As CommandScope
'Usage

Dim instance As Command
Dim value As CommandScope

value = instance.GetCommandScope()
public virtual CommandScope GetCommandScope()
public:
virtual CommandScope GetCommandScope();

Return Value

返回命令的使用范围。
Example
示例请参照CommandScope
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%ItemTitle%%

GetDesignerPropertyVisible Method (Command)
Example

GrapeCity.Forguncy.Commands Namespace > Command Class : GetDesignerPropertyVisible Method
属性名
CommandScope
如果需要动态改变属性编辑器的可见性，可以重写该函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetDesignerPropertyVisible( _
   ByVal propertyName As String, _
   ByVal commandScope As CommandScope _
) As Boolean
'Usage

Dim instance As Command
Dim propertyName As String
Dim commandScope As CommandScope
Dim value As Boolean

value = instance.GetDesignerPropertyVisible(propertyName, commandScope)
public virtual bool GetDesignerPropertyVisible(
   string propertyName,
   CommandScope commandScope
)
public:
virtual bool GetDesignerPropertyVisible(
   String^ propertyName,
   CommandScope commandScope
)

Parameters

propertyName
属性名
commandScope
CommandScope

Return Value

返回True表示属性编辑器可见，否则不可见。
Example
  • C#
public class MenuCellType: CellType
{
    public Orientation Orientation { get; set; }

    public ExpandStyle DefaultExpandStyle { get; set; }

    public override bool GetDesignerPropertyVisible(string propertyName)
    {
        if (propertyName == "DefaultExpandStyle")
        {
            if (Orientation == MenuOrientation.Horizontal)  //如果是水平方向的菜单隐藏默认展开方式。
            {
                return false;
            }
            return true;
        }
        return base.GetDesignerPropertyVisible(propertyName);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%ItemTitle%%

InitDefaultPropertyValues Method (Command)
Example

GrapeCity.Forguncy.Commands Namespace > Command Class : InitDefaultPropertyValues Method
初始化默认属性值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub InitDefaultPropertyValues()
'Usage

Dim instance As Command

instance.InitDefaultPropertyValues()
public virtual void InitDefaultPropertyValues()
public:
virtual void InitDefaultPropertyValues();
Example
  • C#
public class CallStoredProcedureCommand : Command
{
    public List<string> AllowAcessRoleList { get; set; } = new List<string>();

    public override void InitDefaultPropertyValues()
    {
        AllowAcessRoleList = new List<string>() { DefaultRoleManager.FGC_LoginUser };
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%ItemTitle%%

ToString Method (Command)
Example

GrapeCity.Forguncy.Commands Namespace > Command Class : ToString Method
命令插件的显示名称，默认与插件定义的类名一样。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As Command
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override

Return Value

返回在命令列表中该命令插件的显示名称。
Example
  • C#
public class ShowMessageBoxCommand : Command
{
    public override string ToString()
    {
        return "消息框命令";
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%ItemTitle%%

WillNavigateOrReload Method

GrapeCity.Forguncy.Commands Namespace > Command Class : WillNavigateOrReload Method
该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function WillNavigateOrReload() As Boolean
'Usage

Dim instance As Command
Dim value As Boolean

value = instance.WillNavigateOrReload()
public virtual bool WillNavigateOrReload()
public:
virtual bool WillNavigateOrReload();

Return Value

返回true表示该命令插件后续的命令会停止执行，返回false表示该命令插件执行不会影响后续命令的执行。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%PageItemTitle%% $$Properties$$

Command Class Properties

GrapeCity.Forguncy.Commands Namespace : Command Class

For a list of all members of this type, see Command members.

Public Properties
 | Name | Description
Public Property | Comments | 命令的注释。
Public Property | Disabled | 命令是否被禁用。
Top
See Also

Reference

Command Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

Comments Property

GrapeCity.Forguncy.Commands Namespace > Command Class : Comments Property
命令的注释。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property Comments As String
'Usage

Dim instance As Command
Dim value As String

instance.Comments = value

value = instance.Comments
[DefaultValue()]
[Browsable(false)]
public string Comments {get; set;}
[DefaultValue()]
[Browsable(false)]
public:
property String^ Comments {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%ItemTitle%%

Disabled Property

GrapeCity.Forguncy.Commands Namespace > Command Class : Disabled Property
命令是否被禁用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property Disabled As Boolean
'Usage

Dim instance As Command
Dim value As Boolean

instance.Disabled = value

value = instance.Disabled
[DefaultValue()]
[Browsable(false)]
public bool Disabled {get; set;}
[DefaultValue()]
[Browsable(false)]
public:
property bool Disabled {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Command Class
Command Members


%%PageItemTitle%%

ExecuteResult Class
Members

GrapeCity.Forguncy.Commands Namespace : ExecuteResult Class
命令的执行结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ExecuteResult
'Usage

Dim instance As ExecuteResult
public class ExecuteResult
public ref class ExecuteResult
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Commands.ExecuteResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExecuteResult Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ExecuteResult Class Members
Properties

GrapeCity.Forguncy.Commands Namespace : ExecuteResult Class

The following tables list the members exposed by ExecuteResult.

Public Constructors
 | Name | Description
Public Constructor | ExecuteResult Constructor |
Top
Public Properties
 | Name | Description
Public Property | AllowWriteResultToResponse | 是否允许将命令执行结果写入响应信息。
Public Property | ErrCode | 返回码。
Public Property | Log | 服务端命令的执行日志。
Public Property | Message | 返回信息。
Public Property | ProcessControl | 执行该命令后的流程控制信息。
Top
See Also

Reference

ExecuteResult Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

ExecuteResult Constructor

GrapeCity.Forguncy.Commands Namespace > ExecuteResult Class : ExecuteResult Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ExecuteResult()
public ExecuteResult()
public:
ExecuteResult();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExecuteResult Class
ExecuteResult Members


%%PageItemTitle%% $$Properties$$

ExecuteResult Class Properties

GrapeCity.Forguncy.Commands Namespace : ExecuteResult Class

For a list of all members of this type, see ExecuteResult members.

Public Properties
 | Name | Description
Public Property | AllowWriteResultToResponse | 是否允许将命令执行结果写入响应信息。
Public Property | ErrCode | 返回码。
Public Property | Log | 服务端命令的执行日志。
Public Property | Message | 返回信息。
Public Property | ProcessControl | 执行该命令后的流程控制信息。
Top
See Also

Reference

ExecuteResult Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

AllowWriteResultToResponse Property

GrapeCity.Forguncy.Commands Namespace > ExecuteResult Class : AllowWriteResultToResponse Property
是否允许将命令执行结果写入响应信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property AllowWriteResultToResponse As Boolean
'Usage

Dim instance As ExecuteResult
Dim value As Boolean

instance.AllowWriteResultToResponse = value

value = instance.AllowWriteResultToResponse
[DefaultValue()]
public bool AllowWriteResultToResponse {get; set;}
[DefaultValue()]
public:
property bool AllowWriteResultToResponse {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExecuteResult Class
ExecuteResult Members


%%ItemTitle%%

ErrCode Property

GrapeCity.Forguncy.Commands Namespace > ExecuteResult Class : ErrCode Property
返回码。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property ErrCode As Integer
'Usage

Dim instance As ExecuteResult
Dim value As Integer

instance.ErrCode = value

value = instance.ErrCode
[DefaultValue()]
public int ErrCode {get; set;}
[DefaultValue()]
public:
property int ErrCode {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExecuteResult Class
ExecuteResult Members


%%ItemTitle%%

Log Property (ExecuteResult)

GrapeCity.Forguncy.Commands Namespace > ExecuteResult Class : Log Property
服务端命令的执行日志。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Log As String
'Usage

Dim instance As ExecuteResult
Dim value As String

instance.Log = value

value = instance.Log
[DefaultValue()]
public string Log {get; set;}
[DefaultValue()]
public:
property String^ Log {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExecuteResult Class
ExecuteResult Members


%%ItemTitle%%

Message Property (ExecuteResult)

GrapeCity.Forguncy.Commands Namespace > ExecuteResult Class : Message Property
返回信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Message As String
'Usage

Dim instance As ExecuteResult
Dim value As String

instance.Message = value

value = instance.Message
[DefaultValue()]
public string Message {get; set;}
[DefaultValue()]
public:
property String^ Message {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExecuteResult Class
ExecuteResult Members


%%ItemTitle%%

ProcessControl Property

GrapeCity.Forguncy.Commands Namespace > ExecuteResult Class : ProcessControl Property
执行该命令后的流程控制信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property ProcessControl As ProcessControl
'Usage

Dim instance As ExecuteResult
Dim value As ProcessControl

instance.ProcessControl = value

value = instance.ProcessControl
[DefaultValue()]
public ProcessControl ProcessControl {get; set;}
[DefaultValue()]
public:
property ProcessControl ProcessControl {
   ProcessControl get();
   void set (    ProcessControl value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExecuteResult Class
ExecuteResult Members


%%PageItemTitle%%

ExportPageSettingBase Class
Members

GrapeCity.Forguncy.Commands Namespace : ExportPageSettingBase Class
导出页面相关设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ExportPageSettingBase
'Usage

Dim instance As ExportPageSettingBase
public class ExportPageSettingBase
public ref class ExportPageSettingBase
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Commands.ExportPageSettingBase
GrapeCity.Forguncy.Commands.ExportPageToExcelSetting
GrapeCity.Forguncy.Commands.ExportPageToPdfSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageSettingBase Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ExportPageSettingBase Class Members
Properties

GrapeCity.Forguncy.Commands Namespace : ExportPageSettingBase Class

The following tables list the members exposed by ExportPageSettingBase.

Public Constructors
 | Name | Description
Public Constructor | ExportPageSettingBase Constructor |
Top
Public Properties
 | Name | Description
Public Property | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。
Public Property | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。
Public Property | PageName | 导出页面的名称。
Top
See Also

Reference

ExportPageSettingBase Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

ExportPageSettingBase Constructor

GrapeCity.Forguncy.Commands Namespace > ExportPageSettingBase Class : ExportPageSettingBase Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ExportPageSettingBase()
public ExportPageSettingBase()
public:
ExportPageSettingBase();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageSettingBase Class
ExportPageSettingBase Members


%%PageItemTitle%% $$Properties$$

ExportPageSettingBase Class Properties

GrapeCity.Forguncy.Commands Namespace : ExportPageSettingBase Class

For a list of all members of this type, see ExportPageSettingBase members.

Public Properties
 | Name | Description
Public Property | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。
Public Property | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。
Public Property | PageName | 导出页面的名称。
Top
See Also

Reference

ExportPageSettingBase Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

CellValueInfos Property

GrapeCity.Forguncy.Commands Namespace > ExportPageSettingBase Class : CellValueInfos Property
导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CellValueInfos As Dictionary(Of String,Object)
'Usage

Dim instance As ExportPageSettingBase
Dim value As Dictionary(Of String,Object)

instance.CellValueInfos = value

value = instance.CellValueInfos
public Dictionary<string,object> CellValueInfos {get; set;}
public:
property Dictionary<String^,Object^>^ CellValueInfos {
   Dictionary<String^,Object^>^ get();
   void set (    Dictionary<String^,Object^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageSettingBase Class
ExportPageSettingBase Members


%%ItemTitle%%

ListViewCurrentRowInfos Property

GrapeCity.Forguncy.Commands Namespace > ExportPageSettingBase Class : ListViewCurrentRowInfos Property
导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ListViewCurrentRowInfos As Dictionary(Of String,Object)
'Usage

Dim instance As ExportPageSettingBase
Dim value As Dictionary(Of String,Object)

instance.ListViewCurrentRowInfos = value

value = instance.ListViewCurrentRowInfos
public Dictionary<string,object> ListViewCurrentRowInfos {get; set;}
public:
property Dictionary<String^,Object^>^ ListViewCurrentRowInfos {
   Dictionary<String^,Object^>^ get();
   void set (    Dictionary<String^,Object^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageSettingBase Class
ExportPageSettingBase Members


%%ItemTitle%%

PageName Property (ExportPageSettingBase)

GrapeCity.Forguncy.Commands Namespace > ExportPageSettingBase Class : PageName Property
导出页面的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageName As String
'Usage

Dim instance As ExportPageSettingBase
Dim value As String

instance.PageName = value

value = instance.PageName
public string PageName {get; set;}
public:
property String^ PageName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageSettingBase Class
ExportPageSettingBase Members


%%PageItemTitle%%

ExportPageToExcelSetting Class
Members

GrapeCity.Forguncy.Commands Namespace : ExportPageToExcelSetting Class
导出页面到Excel相关设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ExportPageToExcelSetting
   Inherits ExportPageSettingBase
'Usage

Dim instance As ExportPageToExcelSetting
public class ExportPageToExcelSetting : ExportPageSettingBase
public ref class ExportPageToExcelSetting : public ExportPageSettingBase
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Commands.ExportPageSettingBase
GrapeCity.Forguncy.Commands.ExportPageToExcelSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageToExcelSetting Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ExportPageToExcelSetting Class Members
Properties

GrapeCity.Forguncy.Commands Namespace : ExportPageToExcelSetting Class

The following tables list the members exposed by ExportPageToExcelSetting.

Public Constructors
 | Name | Description
Public Constructor | ExportPageToExcelSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | ExportFormula | 是否导出formula。
Public Property | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | MultiSheetModel | 是否导出到多个工作表。
Public Property | PageName | 导出页面的名称。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Top
See Also

Reference

ExportPageToExcelSetting Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

ExportPageToExcelSetting Constructor

GrapeCity.Forguncy.Commands Namespace > ExportPageToExcelSetting Class : ExportPageToExcelSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ExportPageToExcelSetting()
public ExportPageToExcelSetting()
public:
ExportPageToExcelSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageToExcelSetting Class
ExportPageToExcelSetting Members


%%PageItemTitle%% $$Properties$$

ExportPageToExcelSetting Class Properties

GrapeCity.Forguncy.Commands Namespace : ExportPageToExcelSetting Class

For a list of all members of this type, see ExportPageToExcelSetting members.

Public Properties
 | Name | Description
Public Property | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | ExportFormula | 是否导出formula。
Public Property | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | MultiSheetModel | 是否导出到多个工作表。
Public Property | PageName | 导出页面的名称。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Top
See Also

Reference

ExportPageToExcelSetting Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

ExportFormula Property

GrapeCity.Forguncy.Commands Namespace > ExportPageToExcelSetting Class : ExportFormula Property
是否导出formula。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExportFormula As Boolean
'Usage

Dim instance As ExportPageToExcelSetting
Dim value As Boolean

instance.ExportFormula = value

value = instance.ExportFormula
public bool ExportFormula {get; set;}
public:
property bool ExportFormula {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageToExcelSetting Class
ExportPageToExcelSetting Members


%%ItemTitle%%

MultiSheetModel Property

GrapeCity.Forguncy.Commands Namespace > ExportPageToExcelSetting Class : MultiSheetModel Property
是否导出到多个工作表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property MultiSheetModel As Boolean
'Usage

Dim instance As ExportPageToExcelSetting
Dim value As Boolean

instance.MultiSheetModel = value

value = instance.MultiSheetModel
public bool MultiSheetModel {get; set;}
public:
property bool MultiSheetModel {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageToExcelSetting Class
ExportPageToExcelSetting Members


%%PageItemTitle%%

ExportPageToPdfSetting Class
Members

GrapeCity.Forguncy.Commands Namespace : ExportPageToPdfSetting Class
导出页面到PDF相关设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ExportPageToPdfSetting
   Inherits ExportPageSettingBase
'Usage

Dim instance As ExportPageToPdfSetting
public class ExportPageToPdfSetting : ExportPageSettingBase
public ref class ExportPageToPdfSetting : public ExportPageSettingBase
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Commands.ExportPageSettingBase
GrapeCity.Forguncy.Commands.ExportPageToPdfSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageToPdfSetting Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ExportPageToPdfSetting Class Members
Properties

GrapeCity.Forguncy.Commands Namespace : ExportPageToPdfSetting Class

The following tables list the members exposed by ExportPageToPdfSetting.

Public Constructors
 | Name | Description
Public Constructor | ExportPageToPdfSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | AutoFitRowHeight | 文字内容过多时，是否自动调整行高以确保显示所有文字。
Public Property | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | PageName | 导出页面的名称。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Top
See Also

Reference

ExportPageToPdfSetting Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

ExportPageToPdfSetting Constructor

GrapeCity.Forguncy.Commands Namespace > ExportPageToPdfSetting Class : ExportPageToPdfSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ExportPageToPdfSetting()
public ExportPageToPdfSetting()
public:
ExportPageToPdfSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageToPdfSetting Class
ExportPageToPdfSetting Members


%%PageItemTitle%% $$Properties$$

ExportPageToPdfSetting Class Properties

GrapeCity.Forguncy.Commands Namespace : ExportPageToPdfSetting Class

For a list of all members of this type, see ExportPageToPdfSetting members.

Public Properties
 | Name | Description
Public Property | AutoFitRowHeight | 文字内容过多时，是否自动调整行高以确保显示所有文字。
Public Property | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Public Property | PageName | 导出页面的名称。 (Inherited from GrapeCity.Forguncy.Commands.ExportPageSettingBase)
Top
See Also

Reference

ExportPageToPdfSetting Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

AutoFitRowHeight Property

GrapeCity.Forguncy.Commands Namespace > ExportPageToPdfSetting Class : AutoFitRowHeight Property
文字内容过多时，是否自动调整行高以确保显示所有文字。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property AutoFitRowHeight As Boolean
'Usage

Dim instance As ExportPageToPdfSetting
Dim value As Boolean

instance.AutoFitRowHeight = value

value = instance.AutoFitRowHeight
public bool AutoFitRowHeight {get; set;}
public:
property bool AutoFitRowHeight {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportPageToPdfSetting Class
ExportPageToPdfSetting Members


%%PageItemTitle%%

CommandScope Enumeration
Example Example

GrapeCity.Forguncy.Commands Namespace : CommandScope Enumeration
活字格打开编辑命令窗口时会根据使用范围的不同显示不同的命令集合，该Flags枚举列出了以下几种范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum CommandScope
   Inherits System.Enum
'Usage

Dim instance As CommandScope
[Flags()]
public enum CommandScope : System.Enum
[Flags()]
public enum class CommandScope : public System.Enum
Members
Member | Description
All | 所有集合。
Cell | 普通单元格中。
ExecutableInServer | 可以在服务端执行的命令
ListView | 表格中的单元格中。
NoneNotification | 非通知类。
Notification | 通知用命令。
PageLoad | 页面加载中。
ServerSide | 服务器命令
ShareCommand | 模板命令
TaskSchedule | 定时任务
Workflow | 工作流中。
Example
  • C#
public class DeleteRecordCommand : Command
{
    public override CommandScope GetCommandScope()
    {
        return CommandScope.ListView;
    }
}
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Commands.CommandScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

LogLevel Enumeration

GrapeCity.Forguncy.Commands Namespace : LogLevel Enumeration
日志详细程度。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum LogLevel
   Inherits System.Enum
'Usage

Dim instance As LogLevel
public enum LogLevel : System.Enum
public enum class LogLevel : public System.Enum
Members
Member | Description
Detail | 详细记录日志。
None | 无日志。
Normal | 普通等级。
Simple | 简单等级。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Commands.LogLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

ProcessControl Enumeration

GrapeCity.Forguncy.Commands Namespace : ProcessControl Enumeration
流程控制信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ProcessControl
   Inherits System.Enum
'Usage

Dim instance As ProcessControl
public enum ProcessControl : System.Enum
public enum class ProcessControl : public System.Enum
Members
Member | Description
BreakLoopAndContinue | 跳过当前循环并继续执行。
Continue | 继续执行。
Return | 返回。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Commands.ProcessControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

ICommandCellInfo Interface
Members

GrapeCity.Forguncy.Commands Namespace : ICommandCellInfo Interface
命令单元格信息。详情参照。
Object Model
ICommandCellInfo InterfaceIBindingInfo InterfaceIListViewInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICommandCellInfo
   Inherits GrapeCity.Forguncy.Plugin.ICellInfoBase
'Usage

Dim instance As ICommandCellInfo
public interface ICommandCellInfo : GrapeCity.Forguncy.Plugin.ICellInfoBase
public interface class ICommandCellInfo : public GrapeCity.Forguncy.Plugin.ICellInfoBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandCellInfo Members
GrapeCity.Forguncy.Commands Namespace
ICellInfoBase Interface


%%PageItemTitle%% $$Members$$

ICommandCellInfo Interface Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : ICommandCellInfo Interface

The following tables list the members exposed by ICommandCellInfo.

Public Properties
 | Name | Description
Property | BindingInfo | 单元格的数据绑定信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ColumnIndex | 获取单元格所在列的索引。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ListViewInfo | 单元格所在表格的信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | PageName | 单元格所在的页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | RowIndex | 获取单元格所在行的索引 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Top
Public Methods
 | Name | Description
Method | GetFormulaReferObject | 返回单元格对应的公式对象。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Top
See Also

Reference

ICommandCellInfo Interface
GrapeCity.Forguncy.Commands Namespace
ICellInfoBase Interface


%%PageItemTitle%%

ICommandExecutableInServerSide Interface
Members Example

GrapeCity.Forguncy.Commands Namespace : ICommandExecutableInServerSide Interface

具有可独立执行能力的命令需要实现这个接口。

用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICommandExecutableInServerSide
'Usage

Dim instance As ICommandExecutableInServerSide
public interface ICommandExecutableInServerSide
public interface class ICommandExecutableInServerSide
Example
  • C#
public classSendWeChatMessage : Command, ICommandExecutableInServerSide
{
    publicobjectUserId { get; set; }

    public objectPartyId { get; set; }

    public objectContent { get; set; }

    public string Execute(IServerCommandExecuteContext dataContext)
    {
        var api = newWeChat();return api.SendMessage(UserId?.ToString(), PartyId?.ToString(), dataContext.ReplaceKeyWord(Content?.ToString()));
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandExecutableInServerSide Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ICommandExecutableInServerSide Interface Members
Methods

GrapeCity.Forguncy.Commands Namespace : ICommandExecutableInServerSide Interface

The following tables list the members exposed by ICommandExecutableInServerSide.

Public Methods
 | Name | Description
Method | Execute | 命令执行方法。
Top
See Also

Reference

ICommandExecutableInServerSide Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

ICommandExecutableInServerSide Interface Methods

GrapeCity.Forguncy.Commands Namespace : ICommandExecutableInServerSide Interface

For a list of all members of this type, see ICommandExecutableInServerSide members.

Public Methods
 | Name | Description
Method | Execute | 命令执行方法。
Top
See Also

Reference

ICommandExecutableInServerSide Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

Execute Method

GrapeCity.Forguncy.Commands Namespace > ICommandExecutableInServerSide Interface : Execute Method
从服务器端传递给命令执行时的上下文信息。
命令执行方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function Execute( _
   ByVal dataContext As IServerCommandExecuteContext _
) As ExecuteResult
'Usage

Dim instance As ICommandExecutableInServerSide
Dim dataContext As IServerCommandExecuteContext
Dim value As ExecuteResult

value = instance.Execute(dataContext)
ExecuteResult Execute(
   IServerCommandExecuteContext dataContext
)
ExecuteResult^ Execute(
   IServerCommandExecuteContext^ dataContext
)

Parameters

dataContext
从服务器端传递给命令执行时的上下文信息。

Return Value

是否执行成功。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandExecutableInServerSide Interface
ICommandExecutableInServerSide Members


%%PageItemTitle%%

ICommandExecutableInServerSideAsync Interface
Members Example

GrapeCity.Forguncy.Commands Namespace : ICommandExecutableInServerSideAsync Interface

具有可独立执行能力的命令需要实现这个接口。

用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICommandExecutableInServerSideAsync
'Usage

Dim instance As ICommandExecutableInServerSideAsync
public interface ICommandExecutableInServerSideAsync
public interface class ICommandExecutableInServerSideAsync
Example
  • C#
public classSendWeChatMessage : Command, ICommandExecutableInServerSideAsync
{
    publicobjectUserId { get; set; }

    public objectPartyId { get; set; }

    public objectContent { get; set; }

    public async Task<string> Execute(IServerCommandExecuteContext context)
    {
        await context.Context.WriteAsync("Hello");
        return new ExecuteResult(){ AllowWriteResultToResponse = false };// success
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandExecutableInServerSideAsync Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ICommandExecutableInServerSideAsync Interface Members
Methods

GrapeCity.Forguncy.Commands Namespace : ICommandExecutableInServerSideAsync Interface

The following tables list the members exposed by ICommandExecutableInServerSideAsync.

Public Methods
 | Name | Description
Method | ExecuteAsync | 命令执行方法。
Top
See Also

Reference

ICommandExecutableInServerSideAsync Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

ICommandExecutableInServerSideAsync Interface Methods

GrapeCity.Forguncy.Commands Namespace : ICommandExecutableInServerSideAsync Interface

For a list of all members of this type, see ICommandExecutableInServerSideAsync members.

Public Methods
 | Name | Description
Method | ExecuteAsync | 命令执行方法。
Top
See Also

Reference

ICommandExecutableInServerSideAsync Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

ExecuteAsync Method

GrapeCity.Forguncy.Commands Namespace > ICommandExecutableInServerSideAsync Interface : ExecuteAsync Method
从服务器端传递给命令执行时的上下文信息。
命令执行方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExecuteAsync( _
   ByVal dataContext As IServerCommandExecuteContext _
) As Task(Of ExecuteResult)
'Usage

Dim instance As ICommandExecutableInServerSideAsync
Dim dataContext As IServerCommandExecuteContext
Dim value As Task(Of ExecuteResult)

value = instance.ExecuteAsync(dataContext)
Task<ExecuteResult> ExecuteAsync(
   IServerCommandExecuteContext dataContext
)
Task<ExecuteResult^>^ ExecuteAsync(
   IServerCommandExecuteContext^ dataContext
)

Parameters

dataContext
从服务器端传递给命令执行时的上下文信息。

Return Value

是否执行成功。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandExecutableInServerSideAsync Interface
ICommandExecutableInServerSideAsync Members


%%PageItemTitle%%

IContainSubCommands Interface
Members

GrapeCity.Forguncy.Commands Namespace : IContainSubCommands Interface
迭代当前命令的子命令，用于查找替换。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IContainSubCommands
'Usage

Dim instance As IContainSubCommands
public interface IContainSubCommands
public interface class IContainSubCommands
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IContainSubCommands Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

IContainSubCommands Interface Members
Methods

GrapeCity.Forguncy.Commands Namespace : IContainSubCommands Interface

The following tables list the members exposed by IContainSubCommands.

Public Methods
 | Name | Description
Method | EnumSubCommands | 迭代子命令列表。
Top
See Also

Reference

IContainSubCommands Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

IContainSubCommands Interface Methods

GrapeCity.Forguncy.Commands Namespace : IContainSubCommands Interface

For a list of all members of this type, see IContainSubCommands members.

Public Methods
 | Name | Description
Method | EnumSubCommands | 迭代子命令列表。
Top
See Also

Reference

IContainSubCommands Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

EnumSubCommands Method

GrapeCity.Forguncy.Commands Namespace > IContainSubCommands Interface : EnumSubCommands Method
迭代子命令列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumSubCommands() As IEnumerable(Of List(Of Command))
'Usage

Dim instance As IContainSubCommands
Dim value As IEnumerable(Of List(Of Command))

value = instance.EnumSubCommands()
IEnumerable<List<Command>> EnumSubCommands()
IEnumerable<List<Command^>^>^ EnumSubCommands();

Return Value

子命令迭代器。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IContainSubCommands Interface
IContainSubCommands Members


%%PageItemTitle%%

IExportHelper Interface
Members

GrapeCity.Forguncy.Commands Namespace : IExportHelper Interface
提供导出相关的方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IExportHelper
'Usage

Dim instance As IExportHelper
public interface IExportHelper
public interface class IExportHelper
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportHelper Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

IExportHelper Interface Members
Methods

GrapeCity.Forguncy.Commands Namespace : IExportHelper Interface

The following tables list the members exposed by IExportHelper.

Public Methods
 | Name | Description
Method | ExportPageToExcel | 导出页面到Excel。
Method | ExportPageToPDF | 导出页面到PDF。
Top
See Also

Reference

IExportHelper Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

IExportHelper Interface Methods

GrapeCity.Forguncy.Commands Namespace : IExportHelper Interface

For a list of all members of this type, see IExportHelper members.

Public Methods
 | Name | Description
Method | ExportPageToExcel | 导出页面到Excel。
Method | ExportPageToPDF | 导出页面到PDF。
Top
See Also

Reference

IExportHelper Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

ExportPageToExcel Method

GrapeCity.Forguncy.Commands Namespace > IExportHelper Interface : ExportPageToExcel Method
导出页面到excel的相关设置。
导出页面到Excel。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExportPageToExcel( _
   ByVal setting As ExportPageToExcelSetting _
) As Stream
'Usage

Dim instance As IExportHelper
Dim setting As ExportPageToExcelSetting
Dim value As Stream

value = instance.ExportPageToExcel(setting)
Stream ExportPageToExcel(
   ExportPageToExcelSetting setting
)
Stream^ ExportPageToExcel(
   ExportPageToExcelSetting^ setting
)

Parameters

setting
导出页面到excel的相关设置。

Return Value

导出的excel文件的文件流。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportHelper Interface
IExportHelper Members


%%ItemTitle%%

ExportPageToPDF Method

GrapeCity.Forguncy.Commands Namespace > IExportHelper Interface : ExportPageToPDF Method
导出页面到pdf的相关设置。
导出页面到PDF。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExportPageToPDF( _
   ByVal setting As ExportPageToPdfSetting _
) As Stream
'Usage

Dim instance As IExportHelper
Dim setting As ExportPageToPdfSetting
Dim value As Stream

value = instance.ExportPageToPDF(setting)
Stream ExportPageToPDF(
   ExportPageToPdfSetting setting
)
Stream^ ExportPageToPDF(
   ExportPageToPdfSetting^ setting
)

Parameters

setting
导出页面到pdf的相关设置。

Return Value

导出的PDF文件的文件流。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportHelper Interface
IExportHelper Members


%%PageItemTitle%%

ILog Interface
Members

GrapeCity.Forguncy.Commands Namespace : ILog Interface
提供打印日志的方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ILog
'Usage

Dim instance As ILog
public interface ILog
public interface class ILog
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ILog Interface Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : ILog Interface

The following tables list the members exposed by ILog.

Public Properties
 | Name | Description
Property | LogLevel | 日志详细程度。
Top
Public Methods
 | Name | Description
Method | AppendLine | Overloaded. 追加一行日志。
Method | ClearLog | 清楚日志内容。
Method | DecreaseIndent | 减少缩进。
Method | GetLog | 获取日志内容。
Method | IncreaseIndent | 增加缩进。
Top
See Also

Reference

ILog Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

ILog Interface Methods

GrapeCity.Forguncy.Commands Namespace : ILog Interface

For a list of all members of this type, see ILog members.

Public Methods
 | Name | Description
Method | AppendLine | Overloaded. 追加一行日志。
Method | ClearLog | 清楚日志内容。
Method | DecreaseIndent | 减少缩进。
Method | GetLog | 获取日志内容。
Method | IncreaseIndent | 增加缩进。
Top
See Also

Reference

ILog Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

AppendLine Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface : AppendLine Method
追加一行日志。
Overload List
Overload | Description
AppendLine(String,String[]) | 追加一行日志。
AppendLine(String,LogLevel,String[]) | 追加一行日志。
AppendLine(String,LogLevel,Boolean,String[]) | 追加一行日志。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members


%%ItemTitle%%

AppendLine(String,String[]) Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface > AppendLine Method : AppendLine(String,String[]) Method
日志模板内容。
日志模板对应参数。
追加一行日志。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Sub AppendLine( _
   ByVal content As String, _
   ByVal ParamArray args() As String _
)
'Usage

Dim instance As ILog
Dim content As String
Dim args() As String

instance.AppendLine(content, args)
void AppendLine(
   string content,
   params string[] args
)
void AppendLine(
   String^ content,
   ... array<String^>^ args
)

Parameters

content
日志模板内容。
args
日志模板对应参数。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members
Overload List


%%ItemTitle%%

AppendLine(String,LogLevel,String[]) Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface > AppendLine Method : AppendLine(String,LogLevel,String[]) Method
日志模板内容。
日志详细程度。
日志模板对应参数。
追加一行日志。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Sub AppendLine( _
   ByVal content As String, _
   Optional ByVal logLevel As LogLevel, _
   ByVal ParamArray args() As String _
)
'Usage

Dim instance As ILog
Dim content As String
Dim logLevel As LogLevel
Dim args() As String

instance.AppendLine(content, logLevel, args)
void AppendLine(
   string content,
   LogLevel logLevel,
   params string[] args
)
void AppendLine(
   String^ content,
   LogLevel logLevel,
   ... array<String^>^ args
)

Parameters

content
日志模板内容。
logLevel
日志详细程度。
args
日志模板对应参数。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members
Overload List


%%ItemTitle%%

AppendLine(String,LogLevel,Boolean,String[]) Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface > AppendLine Method : AppendLine(String,LogLevel,Boolean,String[]) Method
日志模板内容。
日志详细程度。
是否截除超出1000个字符长度部分的内容。
日志模板对应参数。
追加一行日志。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Sub AppendLine( _
   ByVal content As String, _
   Optional ByVal logLevel As LogLevel, _
   Optional ByVal trancatedExceed As Boolean, _
   ByVal ParamArray args() As String _
)
'Usage

Dim instance As ILog
Dim content As String
Dim logLevel As LogLevel
Dim trancatedExceed As Boolean
Dim args() As String

instance.AppendLine(content, logLevel, trancatedExceed, args)
void AppendLine(
   string content,
   LogLevel logLevel,
   bool trancatedExceed,
   params string[] args
)
void AppendLine(
   String^ content,
   LogLevel logLevel,
   bool trancatedExceed,
   ... array<String^>^ args
)

Parameters

content
日志模板内容。
logLevel
日志详细程度。
trancatedExceed
是否截除超出1000个字符长度部分的内容。
args
日志模板对应参数。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members
Overload List


%%ItemTitle%%

ClearLog Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface : ClearLog Method
清楚日志内容。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub ClearLog()
'Usage

Dim instance As ILog

instance.ClearLog()
void ClearLog()
void ClearLog();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members


%%ItemTitle%%

DecreaseIndent Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface : DecreaseIndent Method
减少缩进。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub DecreaseIndent()
'Usage

Dim instance As ILog

instance.DecreaseIndent()
void DecreaseIndent()
void DecreaseIndent();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members


%%ItemTitle%%

GetLog Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface : GetLog Method
获取日志内容。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetLog() As String
'Usage

Dim instance As ILog
Dim value As String

value = instance.GetLog()
string GetLog()
String^ GetLog();

Return Value

日志内容。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members


%%ItemTitle%%

IncreaseIndent Method

GrapeCity.Forguncy.Commands Namespace > ILog Interface : IncreaseIndent Method
增加缩进。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub IncreaseIndent()
'Usage

Dim instance As ILog

instance.IncreaseIndent()
void IncreaseIndent()
void IncreaseIndent();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members


%%PageItemTitle%% $$Properties$$

ILog Interface Properties

GrapeCity.Forguncy.Commands Namespace : ILog Interface

For a list of all members of this type, see ILog members.

Public Properties
 | Name | Description
Property | LogLevel | 日志详细程度。
Top
See Also

Reference

ILog Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

LogLevel Property

GrapeCity.Forguncy.Commands Namespace > ILog Interface : LogLevel Property
日志详细程度。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property LogLevel As LogLevel
'Usage

Dim instance As ILog
Dim value As LogLevel

value = instance.LogLevel
LogLevel LogLevel {get;}
property LogLevel LogLevel {
   LogLevel get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILog Interface
ILog Members


%%PageItemTitle%%

IServerCommandExecuteContext Interface
Members

GrapeCity.Forguncy.Commands Namespace : IServerCommandExecuteContext Interface
当在服务器端执行实现了ICommandExecutableInServerSide接口的命令时，从服务器端传递的上下文信息。
Object Model
IServerCommandExecuteContext InterfaceIDataAccess InterfaceIExportHelper InterfaceILog InterfaceIUserInfos Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IServerCommandExecuteContext
'Usage

Dim instance As IServerCommandExecuteContext
public interface IServerCommandExecuteContext
public interface class IServerCommandExecuteContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

IServerCommandExecuteContext Interface Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : IServerCommandExecuteContext Interface

The following tables list the members exposed by IServerCommandExecuteContext.

Public Properties
 | Name | Description
Property | AppBaseUrl | 应用的Base Url。
Property | Context | 返回IOwinContext类的实例。
Property | CurrentServerCommandName | 服务端命令的名称。
Property | DataAccess | 用于操作数据库的上下文信息。
Property | ExportHelper | 用于导出页面的上下文信息。
Property | Log | 用于记录日志的上下文环境。
Property | Parameters | 当前上下文中可用参数。
Property | UserInfos | 用于操作用户的上下文环境。
Top
Public Methods
 | Name | Description
Method | EvaluateFormula | 计算公式的工具方法，返回公式的计算结果。
Method | EvaluateQueryConditionValueFormula | 计算查询条件的工具方法，返回查询条件的计算结果。
Method | ExecuteCommands | 执行命令列表并返回执行结果。
Method | ExecuteCommandsAsync | 执行命令列表并返回执行结果。
Method | ExecuteServerCommands | 执行服务端命令列表并返回执行结果。
Method | ExecuteServerCommandsAsync | 执行服务端命令列表并返回执行结果。
Method | ReplaceKeyWord | 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
Method | SendMail | 调用该方法可以异步发送邮件。
Top
See Also

Reference

IServerCommandExecuteContext Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

IServerCommandExecuteContext Interface Methods

GrapeCity.Forguncy.Commands Namespace : IServerCommandExecuteContext Interface

For a list of all members of this type, see IServerCommandExecuteContext members.

Public Methods
 | Name | Description
Method | EvaluateFormula | 计算公式的工具方法，返回公式的计算结果。
Method | EvaluateQueryConditionValueFormula | 计算查询条件的工具方法，返回查询条件的计算结果。
Method | ExecuteCommands | 执行命令列表并返回执行结果。
Method | ExecuteCommandsAsync | 执行命令列表并返回执行结果。
Method | ExecuteServerCommands | 执行服务端命令列表并返回执行结果。
Method | ExecuteServerCommandsAsync | 执行服务端命令列表并返回执行结果。
Method | ReplaceKeyWord | 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
Method | SendMail | 调用该方法可以异步发送邮件。
Top
See Also

Reference

IServerCommandExecuteContext Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

EvaluateFormula Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : EvaluateFormula Method
原始公式字符串。
计算公式的工具方法，返回公式的计算结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EvaluateFormula( _
   ByVal value As Object _
) As Object
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As Object
Dim value As Object

value = instance.EvaluateFormula(value)
object EvaluateFormula(
   object value
)
Object^ EvaluateFormula(
   Object^ value
)

Parameters

value
原始公式字符串。

Return Value

公式的计算结果。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

EvaluateQueryConditionValueFormula Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : EvaluateQueryConditionValueFormula Method
原始查询条件。
计算查询条件的工具方法，返回查询条件的计算结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EvaluateQueryConditionValueFormula( _
   ByVal queryCondition As Object _
) As Object
'Usage

Dim instance As IServerCommandExecuteContext
Dim queryCondition As Object
Dim value As Object

value = instance.EvaluateQueryConditionValueFormula(queryCondition)
object EvaluateQueryConditionValueFormula(
   object queryCondition
)
Object^ EvaluateQueryConditionValueFormula(
   Object^ queryCondition
)

Parameters

queryCondition
原始查询条件。

Return Value

查询条件的计算结果。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

ExecuteCommands Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : ExecuteCommands Method
待执行命令列表。
执行命令列表并返回执行结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExecuteCommands( _
   ByVal commands As List(Of Command) _
) As ExecuteResult
'Usage

Dim instance As IServerCommandExecuteContext
Dim commands As List(Of Command)
Dim value As ExecuteResult

value = instance.ExecuteCommands(commands)
ExecuteResult ExecuteCommands(
   List<Command> commands
)
ExecuteResult^ ExecuteCommands(
   List<Command^>^ commands
)

Parameters

commands
待执行命令列表。

Return Value

命令执行结果。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

ExecuteCommandsAsync Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : ExecuteCommandsAsync Method
待执行命令列表。
执行命令列表并返回执行结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExecuteCommandsAsync( _
   ByVal commands As List(Of Command) _
) As Task(Of ExecuteResult)
'Usage

Dim instance As IServerCommandExecuteContext
Dim commands As List(Of Command)
Dim value As Task(Of ExecuteResult)

value = instance.ExecuteCommandsAsync(commands)
Task<ExecuteResult> ExecuteCommandsAsync(
   List<Command> commands
)
Task<ExecuteResult^>^ ExecuteCommandsAsync(
   List<Command^>^ commands
)

Parameters

commands
待执行命令列表。

Return Value

命令执行结果。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

ExecuteServerCommands Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : ExecuteServerCommands Method
服务端命令的名称。
执行服务端命令的上下文。
执行服务端命令列表并返回执行结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExecuteServerCommands( _
   ByVal serverCommandName As String, _
   ByVal dataContext As IServerCommandExecuteContext _
) As ExecuteResult
'Usage

Dim instance As IServerCommandExecuteContext
Dim serverCommandName As String
Dim dataContext As IServerCommandExecuteContext
Dim value As ExecuteResult

value = instance.ExecuteServerCommands(serverCommandName, dataContext)
ExecuteResult ExecuteServerCommands(
   string serverCommandName,
   IServerCommandExecuteContext dataContext
)
ExecuteResult^ ExecuteServerCommands(
   String^ serverCommandName,
   IServerCommandExecuteContext^ dataContext
)

Parameters

serverCommandName
服务端命令的名称。
dataContext
执行服务端命令的上下文。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

ExecuteServerCommandsAsync Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : ExecuteServerCommandsAsync Method
服务端命令的名称。
执行服务端命令的上下文。
执行服务端命令列表并返回执行结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExecuteServerCommandsAsync( _
   ByVal serverCommandName As String, _
   ByVal dataContext As IServerCommandExecuteContext _
) As Task(Of ExecuteResult)
'Usage

Dim instance As IServerCommandExecuteContext
Dim serverCommandName As String
Dim dataContext As IServerCommandExecuteContext
Dim value As Task(Of ExecuteResult)

value = instance.ExecuteServerCommandsAsync(serverCommandName, dataContext)
Task<ExecuteResult> ExecuteServerCommandsAsync(
   string serverCommandName,
   IServerCommandExecuteContext dataContext
)
Task<ExecuteResult^>^ ExecuteServerCommandsAsync(
   String^ serverCommandName,
   IServerCommandExecuteContext^ dataContext
)

Parameters

serverCommandName
服务端命令的名称。
dataContext
执行服务端命令的上下文。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

ReplaceKeyWord Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : ReplaceKeyWord Method
原始字符串。
更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ReplaceKeyWord( _
   ByVal value As String _
) As String
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As String
Dim value As String

value = instance.ReplaceKeyWord(value)
string ReplaceKeyWord(
   string value
)
String^ ReplaceKeyWord(
   String^ value
)

Parameters

value
原始字符串。

Return Value

返回更换过关键字后的字符串。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

SendMail Method

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : SendMail Method
发送人邮件地址（可以使用用户名）
收件人列表（可以使用用户名）
标题
邮件正文
调用该方法可以异步发送邮件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function SendMail( _
   ByVal fromAddress As String, _
   ByVal toList As List(Of String), _
   ByVal title As String, _
   ByVal content As String _
) As String
'Usage

Dim instance As IServerCommandExecuteContext
Dim fromAddress As String
Dim toList As List(Of String)
Dim title As String
Dim content As String
Dim value As String

value = instance.SendMail(fromAddress, toList, title, content)
string SendMail(
   string fromAddress,
   List<string> toList,
   string title,
   string content
)
String^ SendMail(
   String^ fromAddress,
   List<String^>^ toList,
   String^ title,
   String^ content
)

Parameters

fromAddress
发送人邮件地址（可以使用用户名）
toList
收件人列表（可以使用用户名）
title
标题
content
邮件正文

Return Value

如果有非空返回值表示邮件发送失败
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%PageItemTitle%% $$Properties$$

IServerCommandExecuteContext Interface Properties

GrapeCity.Forguncy.Commands Namespace : IServerCommandExecuteContext Interface

For a list of all members of this type, see IServerCommandExecuteContext members.

Public Properties
 | Name | Description
Property | AppBaseUrl | 应用的Base Url。
Property | Context | 返回IOwinContext类的实例。
Property | CurrentServerCommandName | 服务端命令的名称。
Property | DataAccess | 用于操作数据库的上下文信息。
Property | ExportHelper | 用于导出页面的上下文信息。
Property | Log | 用于记录日志的上下文环境。
Property | Parameters | 当前上下文中可用参数。
Property | UserInfos | 用于操作用户的上下文环境。
Top
See Also

Reference

IServerCommandExecuteContext Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

AppBaseUrl Property

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : AppBaseUrl Property
应用的Base Url。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AppBaseUrl As String
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As String

value = instance.AppBaseUrl
string AppBaseUrl {get;}
property String^ AppBaseUrl {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

Context Property (IServerCommandExecuteContext)

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : Context Property
返回IOwinContext类的实例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Context As HttpContext
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As HttpContext

value = instance.Context
HttpContext Context {get;}
property HttpContext^ Context {
   HttpContext^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

CurrentServerCommandName Property

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : CurrentServerCommandName Property
服务端命令的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property CurrentServerCommandName As String
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As String

value = instance.CurrentServerCommandName
string CurrentServerCommandName {get;}
property String^ CurrentServerCommandName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

DataAccess Property (IServerCommandExecuteContext)

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : DataAccess Property
用于操作数据库的上下文信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property DataAccess As IDataAccess
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As IDataAccess

value = instance.DataAccess
IDataAccess DataAccess {get;}
property IDataAccess^ DataAccess {
   IDataAccess^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

ExportHelper Property

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : ExportHelper Property
用于导出页面的上下文信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ExportHelper As IExportHelper
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As IExportHelper

value = instance.ExportHelper
IExportHelper ExportHelper {get;}
property IExportHelper^ ExportHelper {
   IExportHelper^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

Log Property (IServerCommandExecuteContext)

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : Log Property
用于记录日志的上下文环境。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Log As ILog
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As ILog

value = instance.Log
ILog Log {get;}
property ILog^ Log {
   ILog^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

Parameters Property

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : Parameters Property
当前上下文中可用参数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Parameters As IDictionary(Of String,Object)
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As IDictionary(Of String,Object)

value = instance.Parameters
IDictionary<string,object> Parameters {get;}
property IDictionary<String^,Object^>^ Parameters {
   IDictionary<String^,Object^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%ItemTitle%%

UserInfos Property (IServerCommandExecuteContext)

GrapeCity.Forguncy.Commands Namespace > IServerCommandExecuteContext Interface : UserInfos Property
用于操作用户的上下文环境。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property UserInfos As IUserInfos
'Usage

Dim instance As IServerCommandExecuteContext
Dim value As IUserInfos

value = instance.UserInfos
IUserInfos UserInfos {get;}
property IUserInfos^ UserInfos {
   IUserInfos^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IServerCommandExecuteContext Interface
IServerCommandExecuteContext Members


%%PageItemTitle%%

ISubListCommand Interface
Members

GrapeCity.Forguncy.Commands Namespace : ISubListCommand Interface
如果命令包含子命令(例如循环命令)，则需要实现该接口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISubListCommand
'Usage

Dim instance As ISubListCommand
public interface ISubListCommand
public interface class ISubListCommand
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubListCommand Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ISubListCommand Interface Members
Properties

GrapeCity.Forguncy.Commands Namespace : ISubListCommand Interface

The following tables list the members exposed by ISubListCommand.

Public Properties
 | Name | Description
Property | CommandList | 子命令列表。
Top
See Also

Reference

ISubListCommand Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Properties$$

ISubListCommand Interface Properties

GrapeCity.Forguncy.Commands Namespace : ISubListCommand Interface

For a list of all members of this type, see ISubListCommand members.

Public Properties
 | Name | Description
Property | CommandList | 子命令列表。
Top
See Also

Reference

ISubListCommand Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

CommandList Property (ISubListCommand)

GrapeCity.Forguncy.Commands Namespace > ISubListCommand Interface : CommandList Property
子命令列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property CommandList As List(Of Command)
'Usage

Dim instance As ISubListCommand
Dim value As List(Of Command)

value = instance.CommandList
List<Command> CommandList {get;}
property List<Command^>^ CommandList {
   List<Command^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISubListCommand Interface
ISubListCommand Members


%%PageItemTitle%%

IUpdateDatabaseCommand Interface
Members

GrapeCity.Forguncy.Commands Namespace : IUpdateDatabaseCommand Interface
提供更新数据库的方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IUpdateDatabaseCommand
'Usage

Dim instance As IUpdateDatabaseCommand
public interface IUpdateDatabaseCommand
public interface class IUpdateDatabaseCommand
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUpdateDatabaseCommand Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

IUpdateDatabaseCommand Interface Members
Methods

GrapeCity.Forguncy.Commands Namespace : IUpdateDatabaseCommand Interface

The following tables list the members exposed by IUpdateDatabaseCommand.

Public Methods
 | Name | Description
Method | GetUpdatingDatabaseConnectionStrings | 从服务端命令上下文环境获取待更新数据库的连接字符串数组。
Top
See Also

Reference

IUpdateDatabaseCommand Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

IUpdateDatabaseCommand Interface Methods

GrapeCity.Forguncy.Commands Namespace : IUpdateDatabaseCommand Interface

For a list of all members of this type, see IUpdateDatabaseCommand members.

Public Methods
 | Name | Description
Method | GetUpdatingDatabaseConnectionStrings | 从服务端命令上下文环境获取待更新数据库的连接字符串数组。
Top
See Also

Reference

IUpdateDatabaseCommand Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

GetUpdatingDatabaseConnectionStrings Method

GrapeCity.Forguncy.Commands Namespace > IUpdateDatabaseCommand Interface : GetUpdatingDatabaseConnectionStrings Method
执行服务端命令的上下文环境。
从服务端命令上下文环境获取待更新数据库的连接字符串数组。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetUpdatingDatabaseConnectionStrings( _
   ByVal context As IServerCommandExecuteContext _
) As IEnumerable(Of String)
'Usage

Dim instance As IUpdateDatabaseCommand
Dim context As IServerCommandExecuteContext
Dim value As IEnumerable(Of String)

value = instance.GetUpdatingDatabaseConnectionStrings(context)
IEnumerable<string> GetUpdatingDatabaseConnectionStrings(
   IServerCommandExecuteContext context
)
IEnumerable<String^>^ GetUpdatingDatabaseConnectionStrings(
   IServerCommandExecuteContext^ context
)

Parameters

context
执行服务端命令的上下文环境。

Return Value

待执行命令列表。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUpdateDatabaseCommand Interface
IUpdateDatabaseCommand Members


%%ItemTitle%%

Forguncy.Commands.Design Assembly
Namespaces
Namespace | Description
GrapeCity.Forguncy.Commands |


%%ItemTitle%%

GrapeCity.Forguncy.Commands Namespace (Forguncy.Commands.Design)
Inheritance Hierarchy
Classes
 | Class | Description
Class | CommandDesigner | 命令设计器。
Class | CommandDesigner<T> | 命令编辑器。
Interfaces
 | Interface | Description
Interface | IBuilderCommandContext | 命令编辑上下文信息。
Interface | ICommandChecker | 如果执行命令需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
Interface | ICommandEditor | 插件命令数据编辑器。
Interface | IQueryConditionWindow | 活字格内置的设置查询条件的对话窗口。 注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现GrapeCity.Forguncy.Plugin.IReferenceFormula接口。
Interface | IWindow | 内置对话框接口。
See Also

Reference

Forguncy.Commands.Design Assembly


%%PageItemTitle%%

CommandDesigner Class
Members

GrapeCity.Forguncy.Commands Namespace : CommandDesigner Class
命令设计器。
Object Model
CommandDesigner ClassCommand Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CommandDesigner
'Usage

Dim instance As CommandDesigner
public class CommandDesigner
public ref class CommandDesigner
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Commands.CommandDesigner
GrapeCity.Forguncy.Commands.CommandDesigner<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

CommandDesigner Class Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : CommandDesigner Class

The following tables list the members exposed by CommandDesigner.

Public Constructors
 | Name | Description
Public Constructor | CommandDesigner Constructor |
Top
Public Properties
 | Name | Description
Public Property | Command | 编辑器对应的命令。
Top
Public Methods
 | Name | Description
Public Method | GetCommandEditor | Overloaded. 返回命令插件对应的编辑器。
Public Method | GetEditorSetting | 返回插件命令内部属性对应的编辑器。
Top
See Also

Reference

CommandDesigner Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

CommandDesigner Constructor

GrapeCity.Forguncy.Commands Namespace > CommandDesigner Class : CommandDesigner Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CommandDesigner()
public CommandDesigner()
public:
CommandDesigner();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner Class
CommandDesigner Members


%%PageItemTitle%% $$Methods$$

CommandDesigner Class Methods

GrapeCity.Forguncy.Commands Namespace : CommandDesigner Class

For a list of all members of this type, see CommandDesigner members.

Public Methods
 | Name | Description
Public Method | GetCommandEditor | Overloaded. 返回命令插件对应的编辑器。
Public Method | GetEditorSetting | 返回插件命令内部属性对应的编辑器。
Top
See Also

Reference

CommandDesigner Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

GetCommandEditor Method

GrapeCity.Forguncy.Commands Namespace > CommandDesigner Class : GetCommandEditor Method
返回命令插件对应的编辑器。
Overload List
Overload | Description
GetCommandEditor() | 返回命令插件对应的编辑器。
GetCommandEditor(IBuilderCommandContext) | 返回命令插件对应的编辑器。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner Class
CommandDesigner Members


%%ItemTitle%%

GetCommandEditor() Method
Example

GrapeCity.Forguncy.Commands Namespace > CommandDesigner Class > GetCommandEditor Method : GetCommandEditor() Method
返回命令插件对应的编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function GetCommandEditor() As ICommandEditor
'Usage

Dim instance As CommandDesigner
Dim value As ICommandEditor

value = instance.GetCommandEditor()
public virtual ICommandEditor GetCommandEditor()
public:
virtual ICommandEditor^ GetCommandEditor();

Return Value

返回命令对应的编辑器。
Example

UserControl和自定义插件弹出消息框命令定义如下：

  • C#
public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
 {
     public ShowMessageCommandEditor()
     {
         InitializeComponent();
     }
     public Command Command
     {
         get
         {
             return new ShowMessageBoxCommand() { Message = messageTextBox.Text };
             //messageTextBox is the name of TextBox in UserControl.
         }
         set
         {
             ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
             if (command != null)
             {
                 messageTextBox.Text = command.Message;
             }
         }
     }

     public bool Validate()
     {
         return true;
     }
 }
public class ShowMessageCommandDesigner : CommandDesigner<ShowMessageBoxCommand>, ICommandChecker
{

    public override ICommandEditor GetCommandEditor()
    {
        return new ShowMessageCommandEditor();
    }
}

[Designer("ShowMessageBoxCommand.ShowMessageCommandDesigner, ShowMessageBoxCommand")]
public class ShowMessageBoxCommand : Command
{

    public string Message { get; set; }

}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner Class
CommandDesigner Members
Overload List


%%ItemTitle%%

GetCommandEditor(IBuilderCommandContext) Method
Example

GrapeCity.Forguncy.Commands Namespace > CommandDesigner Class > GetCommandEditor Method : GetCommandEditor(IBuilderCommandContext) Method
返回命令插件对应的编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overloads Overridable Function GetCommandEditor( _
   ByVal context As IBuilderCommandContext _
) As ICommandEditor
'Usage

Dim instance As CommandDesigner
Dim context As IBuilderCommandContext
Dim value As ICommandEditor

value = instance.GetCommandEditor(context)
public virtual ICommandEditor GetCommandEditor(
   IBuilderCommandContext context
)
public:
virtual ICommandEditor^ GetCommandEditor(
   IBuilderCommandContext^ context
)

Parameters

context

Return Value

返回命令对应的编辑器。
Example

UserControl和自定义插件弹出消息框命令定义如下：

  • C#
public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
{
    public ShowMessageCommandEditor()
    {
        InitializeComponent();
    }
    public Command Command
    {
        get
        {
            return new ShowMessageBoxCommand() { Message = messageTextBox.Text };
            //messageTextBox is the name of TextBox in UserControl.
        }
        set
        {
            ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
            if (command != null)
            {
                messageTextBox.Text = command.Message;
            }
        }
    }

    public bool Validate()
    {
        return true;
    }
}
public class ShowMessageCommandDesigner : CommandDesigner<ShowMessageBoxCommand>, ICommandChecker
{

    public override ICommandEditor GetCommandEditor(IBuilderCommandContext context)
    {
        return new ShowMessageCommandEditor();
    }
}

[Designer("ShowMessageBoxCommand.ShowMessageCommandDesigner, ShowMessageBoxCommand")]
public class ShowMessageBoxCommand : Command
{

    public string Message { get; set; }

}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner Class
CommandDesigner Members
Overload List


%%ItemTitle%%

GetEditorSetting Method (CommandDesigner)
Example

GrapeCity.Forguncy.Commands Namespace > CommandDesigner Class : GetEditorSetting Method
命令内部属性
命令编辑上下文信息。
返回插件命令内部属性对应的编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetEditorSetting( _
   ByVal property As PropertyDescriptor, _
   ByVal builderContext As IBuilderCommandContext _
) As EditorSetting
'Usage

Dim instance As CommandDesigner
Dim property As PropertyDescriptor
Dim builderContext As IBuilderCommandContext
Dim value As EditorSetting

value = instance.GetEditorSetting(property, builderContext)
public virtual EditorSetting GetEditorSetting(
   PropertyDescriptor property,
   IBuilderCommandContext builderContext
)
public:
virtual EditorSetting^ GetEditorSetting(
   PropertyDescriptor^ property,
   IBuilderCommandContext^ builderContext
)

Parameters

property
命令内部属性
builderContext
命令编辑上下文信息。

Return Value

返回插件命令内部属性对应的编辑器。
Example
  • C#
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>;
{
    public string TableName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if (property.Name == "TableName")
        {
            return new ComboEditorSetting(builderContext.EnumAllTableInfos().Where(t => t.WorkflowInfo != null && t.WorkflowInfo.IsEnabled).Select(t => t.TableName));
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner Class
CommandDesigner Members


%%PageItemTitle%% $$Properties$$

CommandDesigner Class Properties

GrapeCity.Forguncy.Commands Namespace : CommandDesigner Class

For a list of all members of this type, see CommandDesigner members.

Public Properties
 | Name | Description
Public Property | Command | 编辑器对应的命令。
Top
See Also

Reference

CommandDesigner Class
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

Command Property (CommandDesigner)

GrapeCity.Forguncy.Commands Namespace > CommandDesigner Class : Command Property
编辑器对应的命令。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Command As Command
'Usage

Dim instance As CommandDesigner
Dim value As Command

instance.Command = value

value = instance.Command
public Command Command {get; set;}
public:
property Command^ Command {
   Command^ get();
   void set (    Command^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner Class
CommandDesigner Members


%%PageItemTitle%%

CommandDesigner<T> Class
Members

GrapeCity.Forguncy.Commands Namespace : CommandDesigner<T> Class
命令编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CommandDesigner(Of T As Command)
   Inherits CommandDesigner
'Usage

Dim instance As CommandDesigner(Of T)
public class CommandDesigner<T> : CommandDesigner
where T: Command
generic<typename T>
public ref class CommandDesigner : public CommandDesigner
where T: Command
Type Parameters
T
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Commands.CommandDesigner
GrapeCity.Forguncy.Commands.CommandDesigner<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner<T> Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

CommandDesigner<T> Class Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : CommandDesigner<T> Class

The following tables list the members exposed by CommandDesigner<T>.

Public Constructors
 | Name | Description
Public Constructor | CommandDesigner<T> Constructor |
Top
Public Properties
 | Name | Description
Public Property | Command | 编辑器对应的命令。
Top
Public Methods
 | Name | Description
Public Method | GetCommandEditor | Overloaded. 返回命令插件对应的编辑器。 (Inherited from GrapeCity.Forguncy.Commands.CommandDesigner)
Public Method | GetEditorSetting | 返回插件命令内部属性对应的编辑器。 (Inherited from GrapeCity.Forguncy.Commands.CommandDesigner)
Top
See Also

Reference

CommandDesigner<T> Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

CommandDesigner<T> Constructor

GrapeCity.Forguncy.Commands Namespace > CommandDesigner<T> Class : CommandDesigner<T> Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CommandDesigner(Of T)()
public CommandDesigner<T>()
public:
CommandDesigner<T>();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CommandDesigner<T> Class
CommandDesigner<T> Members


%%PageItemTitle%% $$Properties$$

CommandDesigner<T> Class Properties

GrapeCity.Forguncy.Commands Namespace : CommandDesigner<T> Class

For a list of all members of this type, see CommandDesigner<T> members.

Public Properties
 | Name | Description
Public Property | Command | 编辑器对应的命令。
Top
See Also

Reference

CommandDesigner<T> Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%%

IBuilderCommandContext Interface
Members

GrapeCity.Forguncy.Commands Namespace : IBuilderCommandContext Interface
命令编辑上下文信息。
Object Model
IBuilderCommandContext InterfaceICommandCellInfo InterfaceILocalServerInfo InterfaceIUserServiceInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IBuilderCommandContext
   Inherits GrapeCity.Forguncy.Plugin.IBuilderContextBase
'Usage

Dim instance As IBuilderCommandContext
public interface IBuilderCommandContext : GrapeCity.Forguncy.Plugin.IBuilderContextBase
public interface class IBuilderCommandContext : public GrapeCity.Forguncy.Plugin.IBuilderContextBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

IBuilderCommandContext Interface Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : IBuilderCommandContext Interface

The following tables list the members exposed by IBuilderCommandContext.

Public Properties
 | Name | Description
Property | AuthenticationMode | 获取当前工程的认证模式。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | CommandCell | 返回设置了命令的单元格信息。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
Property | IsShareCommandMode | 判断当前命令窗口是否为模板命令的命令窗口
Property | LocalServerInfo | 本地网站应用信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | PageName | 获取当前所在页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | UserServiceInfo | 获取用户管理网站的信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Top
Public Methods
 | Name | Description
Method | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllPageInfos | 获取所有的页面信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllTableInfos | 获取所有的数据表信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | GetCell | Overloaded. 返回指定页面指定行列的单元格信息。
Method | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
Method | HideCommandDialog | 隐藏命令窗口，配合ShowCommandDialog使用。 一般情况下，如果命令属性的编辑子窗口中有公式选择框，那么需要使用该函数。
Method | ShowCommandDialog | 重新显示命令窗口，配合HideCommandDialog使用。
Method | StartServer | 生成页面并启动服务器。
Top
See Also

Reference

IBuilderCommandContext Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

IBuilderCommandContext Interface Methods

GrapeCity.Forguncy.Commands Namespace : IBuilderCommandContext Interface

For a list of all members of this type, see IBuilderCommandContext members.

Public Methods
 | Name | Description
Method | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllPageInfos | 获取所有的页面信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllTableInfos | 获取所有的数据表信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | GetCell | Overloaded. 返回指定页面指定行列的单元格信息。
Method | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
Method | HideCommandDialog | 隐藏命令窗口，配合ShowCommandDialog使用。 一般情况下，如果命令属性的编辑子窗口中有公式选择框，那么需要使用该函数。
Method | ShowCommandDialog | 重新显示命令窗口，配合HideCommandDialog使用。
Method | StartServer | 生成页面并启动服务器。
Top
See Also

Reference

IBuilderCommandContext Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

GetCell Method

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : GetCell Method
返回指定页面指定行列的单元格信息。
Overload List
Overload | Description
GetCell(String,Int32,Int32) | 返回指定页面指定行列的单元格信息。
GetCell(IFormulaReferObject) | 返回引用单元格公式所在的单元格信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%ItemTitle%%

GetCell(String,Int32,Int32) Method

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface > GetCell Method : GetCell(String,Int32,Int32) Method
页面名称。
行索引。
列索引。
返回指定页面指定行列的单元格信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetCell( _
   ByVal pageName As String, _
   ByVal row As Integer, _
   ByVal column As Integer _
) As ICommandCellInfo
'Usage

Dim instance As IBuilderCommandContext
Dim pageName As String
Dim row As Integer
Dim column As Integer
Dim value As ICommandCellInfo

value = instance.GetCell(pageName, row, column)
ICommandCellInfo GetCell(
   string pageName,
   int row,
   int column
)
ICommandCellInfo^ GetCell(
   String^ pageName,
   int row,
   int column
)

Parameters

pageName
页面名称。
row
行索引。
column
列索引。

Return Value

返回指定页面指定行列的单元格信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members
Overload List


%%ItemTitle%%

GetCell(IFormulaReferObject) Method

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface > GetCell Method : GetCell(IFormulaReferObject) Method
引用单元格公式。
返回引用单元格公式所在的单元格信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetCell( _
   ByVal obj As IFormulaReferObject _
) As ICommandCellInfo
'Usage

Dim instance As IBuilderCommandContext
Dim obj As IFormulaReferObject
Dim value As ICommandCellInfo

value = instance.GetCell(obj)
ICommandCellInfo GetCell(
   IFormulaReferObject obj
)
ICommandCellInfo^ GetCell(
   IFormulaReferObject^ obj
)

Parameters

obj
引用单元格公式。

Return Value

返回引用单元格公式所在的单元格信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members
Overload List


%%ItemTitle%%

GetQueryConditionWindow Method (IBuilderCommandContext)

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : GetQueryConditionWindow Method
初始化内置查询条件对话窗口的对象。
数据表名。
是否允许选择表。
获取活字格内部查询条件的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetQueryConditionWindow( _
   ByVal queryCondition As Object, _
   ByVal tableName As String, _
   ByVal allowSelectTable As Boolean _
) As IQueryConditionWindow
'Usage

Dim instance As IBuilderCommandContext
Dim queryCondition As Object
Dim tableName As String
Dim allowSelectTable As Boolean
Dim value As IQueryConditionWindow

value = instance.GetQueryConditionWindow(queryCondition, tableName, allowSelectTable)
IQueryConditionWindow GetQueryConditionWindow(
   object queryCondition,
   string tableName,
   bool allowSelectTable
)
IQueryConditionWindow^ GetQueryConditionWindow(
   Object^ queryCondition,
   String^ tableName,
   bool allowSelectTable
)

Parameters

queryCondition
初始化内置查询条件对话窗口的对象。
tableName
数据表名。
allowSelectTable
是否允许选择表。

Return Value

返回活字格内部查询条件的对话窗口。
Example
代码参照IQueryConditionWindow。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%ItemTitle%%

HideCommandDialog Method

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : HideCommandDialog Method
隐藏命令窗口，配合ShowCommandDialog使用。 一般情况下，如果命令属性的编辑子窗口中有公式选择框，那么需要使用该函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub HideCommandDialog()
'Usage

Dim instance As IBuilderCommandContext

instance.HideCommandDialog()
void HideCommandDialog()
void HideCommandDialog();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%ItemTitle%%

ShowCommandDialog Method

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : ShowCommandDialog Method
重新显示命令窗口，配合HideCommandDialog使用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub ShowCommandDialog()
'Usage

Dim instance As IBuilderCommandContext

instance.ShowCommandDialog()
void ShowCommandDialog()
void ShowCommandDialog();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%ItemTitle%%

StartServer Method

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : StartServer Method
生成页面并启动服务器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub StartServer()
'Usage

Dim instance As IBuilderCommandContext

instance.StartServer()
void StartServer()
void StartServer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%PageItemTitle%% $$Properties$$

IBuilderCommandContext Interface Properties

GrapeCity.Forguncy.Commands Namespace : IBuilderCommandContext Interface

For a list of all members of this type, see IBuilderCommandContext members.

Public Properties
 | Name | Description
Property | AuthenticationMode | 获取当前工程的认证模式。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | CommandCell | 返回设置了命令的单元格信息。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
Property | IsShareCommandMode | 判断当前命令窗口是否为模板命令的命令窗口
Property | LocalServerInfo | 本地网站应用信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | PageName | 获取当前所在页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | UserServiceInfo | 获取用户管理网站的信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Top
See Also

Reference

IBuilderCommandContext Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

CommandCell Property

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : CommandCell Property
返回设置了命令的单元格信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property CommandCell As ICommandCellInfo
'Usage

Dim instance As IBuilderCommandContext
Dim value As ICommandCellInfo

value = instance.CommandCell
ICommandCellInfo CommandCell {get;}
property ICommandCellInfo^ CommandCell {
   ICommandCellInfo^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%ItemTitle%%

ForguncyUploadFilesFolderPath Property (IBuilderCommandContext)

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : ForguncyUploadFilesFolderPath Property
用户在设计器中上传的文件或图片所在的文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyUploadFilesFolderPath As String
'Usage

Dim instance As IBuilderCommandContext
Dim value As String

value = instance.ForguncyUploadFilesFolderPath
string ForguncyUploadFilesFolderPath {get;}
property String^ ForguncyUploadFilesFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%ItemTitle%%

IsShareCommandMode Property

GrapeCity.Forguncy.Commands Namespace > IBuilderCommandContext Interface : IsShareCommandMode Property
判断当前命令窗口是否为模板命令的命令窗口
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property IsShareCommandMode As Boolean
'Usage

Dim instance As IBuilderCommandContext
Dim value As Boolean

value = instance.IsShareCommandMode
bool IsShareCommandMode {get;}
property bool IsShareCommandMode {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderCommandContext Interface
IBuilderCommandContext Members


%%PageItemTitle%%

ICommandChecker Interface
Members Example

GrapeCity.Forguncy.Commands Namespace : ICommandChecker Interface
如果执行命令需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICommandChecker
'Usage

Dim instance As ICommandChecker
public interface ICommandChecker
public interface class ICommandChecker
Example
  • C#
public class ShowMessageBoxCommandDesigner: CommandDesigner<ShowMessageBoxCommand>, ICommandChecker
{
    public string Message { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCommandErrors(IBuilderCommandContext context)
    {
        if(string.IsNullOrEmpty(this.Message))
        {
            yield return new ForguncyErrorInfo()
            {
                Message = "消息文本不能为空。",
                ErrorType = ForguncyErrorType.Warning
            };
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandChecker Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ICommandChecker Interface Members
Methods

GrapeCity.Forguncy.Commands Namespace : ICommandChecker Interface

The following tables list the members exposed by ICommandChecker.

Public Methods
 | Name | Description
Method | CheckCommandErrors | 运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
Top
See Also

Reference

ICommandChecker Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

ICommandChecker Interface Methods

GrapeCity.Forguncy.Commands Namespace : ICommandChecker Interface

For a list of all members of this type, see ICommandChecker members.

Public Methods
 | Name | Description
Method | CheckCommandErrors | 运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
Top
See Also

Reference

ICommandChecker Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

CheckCommandErrors Method

GrapeCity.Forguncy.Commands Namespace > ICommandChecker Interface : CheckCommandErrors Method
与执行命令相关的上下文信息
运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function CheckCommandErrors( _
   ByVal context As IBuilderCommandContext _
) As IEnumerable(Of ForguncyErrorInfo)
'Usage

Dim instance As ICommandChecker
Dim context As IBuilderCommandContext
Dim value As IEnumerable(Of ForguncyErrorInfo)

value = instance.CheckCommandErrors(context)
IEnumerable<ForguncyErrorInfo> CheckCommandErrors(
   IBuilderCommandContext context
)
IEnumerable<ForguncyErrorInfo^>^ CheckCommandErrors(
   IBuilderCommandContext^ context
)

Parameters

context
与执行命令相关的上下文信息

Return Value

返回与命令插件相关的所有错误和提醒列表。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandChecker Interface
ICommandChecker Members


%%PageItemTitle%%

ICommandEditor Interface
Members Example

GrapeCity.Forguncy.Commands Namespace : ICommandEditor Interface
插件命令数据编辑器。
Object Model
ICommandEditor InterfaceCommand Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICommandEditor
'Usage

Dim instance As ICommandEditor
public interface ICommandEditor
public interface class ICommandEditor
Example

UserControl和自定义插件弹出消息框命令定义如下：

  • C#
public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
{
    public ShowMessageCommandEditor()
    {
       InitializeComponent();
    }

    public Command Command
    {
        get
        {
            return new ShowMessageBoxCommand() { Message = messageTextBox.Text };  //messageTextBox is the name of TextBox in UserControl.
        }
        set
        {
            ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
            if(command != null)
            {
                messageTextBox.Text = command.Message;
            }
        }
    }

    public bool Validate()
    {
        return true;
    }
}
public class ShowMessageBoxCommand: Command
{
    public string Message { get; set; }

    public override ICommandEditor GetCommandEditor() => new ShowMessageCommandEditor();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandEditor Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

ICommandEditor Interface Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : ICommandEditor Interface

The following tables list the members exposed by ICommandEditor.

Public Properties
 | Name | Description
Property | Command | 命令数据。
Top
Public Methods
 | Name | Description
Method | Validate | 编辑器关闭前的数据校验。
Top
See Also

Reference

ICommandEditor Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

ICommandEditor Interface Methods

GrapeCity.Forguncy.Commands Namespace : ICommandEditor Interface

For a list of all members of this type, see ICommandEditor members.

Public Methods
 | Name | Description
Method | Validate | 编辑器关闭前的数据校验。
Top
See Also

Reference

ICommandEditor Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

Validate Method (ICommandEditor)

GrapeCity.Forguncy.Commands Namespace > ICommandEditor Interface : Validate Method
编辑器关闭前的数据校验。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function Validate() As Boolean
'Usage

Dim instance As ICommandEditor
Dim value As Boolean

value = instance.Validate()
bool Validate()
bool Validate();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandEditor Interface
ICommandEditor Members


%%PageItemTitle%% $$Properties$$

ICommandEditor Interface Properties

GrapeCity.Forguncy.Commands Namespace : ICommandEditor Interface

For a list of all members of this type, see ICommandEditor members.

Public Properties
 | Name | Description
Property | Command | 命令数据。
Top
See Also

Reference

ICommandEditor Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

Command Property (ICommandEditor)

GrapeCity.Forguncy.Commands Namespace > ICommandEditor Interface : Command Property
命令数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property Command As Command
'Usage

Dim instance As ICommandEditor
Dim value As Command

instance.Command = value

value = instance.Command
Command Command {get; set;}
property Command^ Command {
   Command^ get();
   void set (    Command^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandEditor Interface
ICommandEditor Members


%%PageItemTitle%%

IQueryConditionWindow Interface
Members Example

GrapeCity.Forguncy.Commands Namespace : IQueryConditionWindow Interface

活字格内置的设置查询条件的对话窗口。

注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现GrapeCity.Forguncy.Plugin.IReferenceFormula接口。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IQueryConditionWindow
   Inherits IWindow
'Usage

Dim instance As IQueryConditionWindow
public interface IQueryConditionWindow : IWindow
public interface class IQueryConditionWindow : public IWindow
Example
  • C#
public class TreeCellTypeDesigner : CellTypeDesigner<TreeCellType>
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}

[Designer("Forguncy.TreeCellTypeDesigner, Forguncy")]
public class TreeCellType : CellType, IDependenceCells, IReferenceFormula
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        if (this.BindingTreeLevelInfo != null)
        {
            return this.BindingTreeLevelInfo.GetFormulaReferObjects(location);
        }
        return Enumerable.Empty<LocatedObject<object>>();
    }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return EnumDependenceCells(this.BindingTreeLevelInfo, context);
    }

    private IEnumerable<object> EnumDependenceCells(BindingTreeLevelInfo info, IBuilderContext context)
    {
        var result = Enumerable.Empty<object>();
        if (info != null)
        {
            if (info.QueryCondition != null)
            {
                result = result.Union(context.EnumDependenceCells(info.QueryCondition) ?? Enumerable.Empty<object>());
            }
            if (info.SubBindingTreeLevelInfo != null)
            {
                result = result.Union(EnumDependenceCells(info.SubBindingTreeLevelInfo, context) ?? Enumerable.Empty<object>());
            }
        }
        return result;
    }
}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出查询对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditQueryConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的查询条件和表名初始化查询对话窗口。*/
        var window = _builderContext?.GetQueryConditionWindow(queryCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的查询条件提交到数据层。*/
                /*ViewModel.QueryCondition = window.QueryCondition;*/

                /*重新打开父窗口。*/
                _builderContext.ShowParentDialog(this);
            }
        }
        /*由于查询条件中可能引用单元格，所以这里需要暂时隐藏父窗口。*/
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object QueryCondition { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("TreeCellType").AppendProperty("BindingTreeLevelInfo");
        if(this.QueryCondition is IReferenceFormula)
        {
            var items = (this.QueryCondition as IReferenceFormula).GetFormulaReferObjects(newLocation);
            foreach (var item in items)
            {
                yield return item;
            }
        }
        if (this.SubBindingTreeLevelInfo != null)
        {
            var items = this.SubBindingTreeLevelInfo.GetFormulaReferObjects(location);
            foreach (var item in items)
            {
                yield return item;
            }
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IQueryConditionWindow Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

IQueryConditionWindow Interface Members
Properties Methods

GrapeCity.Forguncy.Commands Namespace : IQueryConditionWindow Interface

The following tables list the members exposed by IQueryConditionWindow.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.Commands.IWindow)
Property | QueryCondition | 查询条件。
Top
Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.Commands.IWindow)
Top
See Also

Reference

IQueryConditionWindow Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Properties$$

IQueryConditionWindow Interface Properties

GrapeCity.Forguncy.Commands Namespace : IQueryConditionWindow Interface

For a list of all members of this type, see IQueryConditionWindow members.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.Commands.IWindow)
Property | QueryCondition | 查询条件。
Top
See Also

Reference

IQueryConditionWindow Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

QueryCondition Property (IQueryConditionWindow)

GrapeCity.Forguncy.Commands Namespace > IQueryConditionWindow Interface : QueryCondition Property
查询条件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property QueryCondition As Object
'Usage

Dim instance As IQueryConditionWindow
Dim value As Object

value = instance.QueryCondition
object QueryCondition {get;}
property Object^ QueryCondition {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IQueryConditionWindow Interface
IQueryConditionWindow Members


%%PageItemTitle%%

IWindow Interface
Members

GrapeCity.Forguncy.Commands Namespace : IWindow Interface
内置对话框接口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IWindow
'Usage

Dim instance As IWindow
public interface IWindow
public interface class IWindow
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Members
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Members$$

IWindow Interface Members
Properties Methods Events

GrapeCity.Forguncy.Commands Namespace : IWindow Interface

The following tables list the members exposed by IWindow.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。
Top
Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。
Top
Public Events
 | Name | Description
Event | Closed | 对话框关闭事件。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

IWindow Interface Methods

GrapeCity.Forguncy.Commands Namespace : IWindow Interface

For a list of all members of this type, see IWindow members.

Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

ShowDialog Method (IWindow)

GrapeCity.Forguncy.Commands Namespace > IWindow Interface : ShowDialog Method
打开对话框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ShowDialog() As Nullable(Of Boolean)
'Usage

Dim instance As IWindow
Dim value As Nullable(Of Boolean)

value = instance.ShowDialog()
Nullable<bool> ShowDialog()
Nullable<bool> ShowDialog();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Interface
IWindow Members


%%PageItemTitle%% $$Properties$$

IWindow Interface Properties

GrapeCity.Forguncy.Commands Namespace : IWindow Interface

For a list of all members of this type, see IWindow members.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

DialogResult Property (IWindow)

GrapeCity.Forguncy.Commands Namespace > IWindow Interface : DialogResult Property
对话框返回结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property DialogResult As Nullable(Of Boolean)
'Usage

Dim instance As IWindow
Dim value As Nullable(Of Boolean)

value = instance.DialogResult
Nullable<bool> DialogResult {get;}
property Nullable<bool> DialogResult {
   Nullable<bool> get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Interface
IWindow Members


%%PageItemTitle%% $$Events$$

IWindow Interface Events

GrapeCity.Forguncy.Commands Namespace : IWindow Interface

For a list of all members of this type, see IWindow members.

Public Events
 | Name | Description
Event | Closed | 对话框关闭事件。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%%

Closed Event (IWindow)

GrapeCity.Forguncy.Commands Namespace > IWindow Interface : Closed Event
对话框关闭事件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Event Closed As EventHandler
'Usage

Dim instance As IWindow
Dim handler As EventHandler

AddHandler instance.Closed, handler
event EventHandler Closed
event EventHandler^ Closed
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Interface
IWindow Members


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes Assembly
Namespaces
Namespace | Description
GrapeCity.Forguncy.CellTypes |


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes Namespace (GrapeCity.Forguncy.CellTypes)
Inheritance Hierarchy
Classes
 | Class | Description
Class | CategoryHeaderAttribute | 单元格类型插件中的属性编辑器中的类目属性，如文本框中使用的[显示密码]属性的类目属性[外观]。
Class | CellType | 单元格类型插件的父类定义。
Class | CellTypeStyleTemplate | 单元格的模板样式。它定义了该单元格的一份完整的样式外观，包括该单元格由几个模板组件组成，以及每个模板组件的具体样式。
Class | CellTypeStyleTemplateSupportAttribute | 单元格类型支持模板样式的标志。如果该单元格支持模板样式，可使用某个继承自此标志的标志，对模板样式进行相关配置。
Class | ExportResultInfo | 导出单元格类型的返回结果。
Class | PartStyleUnit | 模板组件的状态样式单元。它代表了模板组件在某一种状态下的完整样式信息。
Class | SubUIPermission | 单元格类型子元素的界面权限项。
Class | SupportLanguageScopeAttribute | 插件支持的语言版本，如果不指定默认所有语言都支持。
Class | SupportUsingScopeAttribute | 单元格类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
Class | TemplatePart | 单元格模板样式的模板组件。它以样式的角度，划分单元格的组成部分，也是设置单元格模板样式的基本单位。一个单元格类型可由一个或多个模板组件组成。每一个部分可单独设置样式。
Class | TemplatePartStyle | 模板组件的样式。保存了该模板组件在各自状态下的具体样式信息。
Class | UIPermission | 单元格类型的界面权限项。
Interfaces
 | Interface | Description
Interface | IAttachedInfo | 单元格的附加信息。
Interface | IBorderLine | 设置边框。
Interface | ICanOverflow | 单元格类型是否支持溢出。 例如，如果超链接单元格类型所在的单元格大小不够显示完全字，并且本身和后续单元格均没有合并的情况下，超链接的字会溢出到后续单元格中。
Interface | ICellInfo | 单元格的信息。
Interface | ICommandCellType | 如果单元格类型本身允许执行命令，需实现该接口。
Interface | ICommandWindow | 活字格内部编辑命令的对话窗口。
Interface | IDisablePropertySettings | 获取单元格类型中不可用的样式属性，如对齐方式等。
Interface | IExportCellType | 导出单元格类型有特殊处理时需实现该接口，比如生成图片等。
Interface | IExportContext | 导出单元格类型的上下文信息。
Interface | IExportDrawingHelper | 主要用于单元格预览和导出单元格到Excel中的画法。
Interface | IExportValueProvider | 数据访问器，提供数据表的查询结果。
Interface | IForguncyFormatter | 单元格格式。
Interface | IIgnoreAlternativeRowBackColorWhenExport | 配合IExportCellType使用，导出Excel时不使用页面中表格的交替色作为背景色，如表格中的按钮导出到Excel时不使用交替色作为背景色。
Interface | IReferenceCommand | 如果一个单元格不是ICommandCellType，但是该单元格内部属性中有命令设置，如菜单单元格类型，需实现该接口； 否则有些命令执行会出错，而且查找所有引用会有遗漏。
Interface | ISelectImageWindow | 内置图片选择对话窗口。
Interface | ISortConditionWindow | 活字格内置的设置排序条件的对话窗口。
Interface | IStaticValueCellType | 忽略单元格的值，可以自定义单元格类型返回的值； 例如，如果一个单元格引用登录用户单元格类型的值，返回的是当前用户，而非单元格上的值或0。
Interface | IStyleInfo | 设置样式。
Interface | IStyleTemplateInfo | 单元格模板样式的样式信息。若想添加单元格模板样式的设计时预览，该单元格需要实现此接口。
Interface | IStyleTemplateSupport | 单元格支持模板样式。若想某单元格支持模板样式，需要实现此接口。
Interface | ISupportStyleInitialize | 设置单元格类型的默认样式和属性。
Interface | ISupportUIPermission | 主要用于单元格类型的界面权限设置。
Interface | IWindow | 内置对话框接口。
Enumerations
 | Enumeration | Description
Enumeration | CellStates | 模板组件的状态种类。
Enumeration | CommandExcuteKind | 触发命令时机。
Enumeration | CopyFontInfoToControlOption | 主要用于单元格预览和导出单元格到Excel中的画法。
Enumeration | DisplayBehaviour | 单元格的默认显示特性。
Enumeration | ForguncyAuthenticationMode | 页面认证模式。
Enumeration | ForguncyBorderLineStyle | 边框线型列表。
Enumeration | ForguncyCellHorizontalAlignment | 单元格水平对齐方式列表。
Enumeration | ForguncyCellVerticalAlignment | 单元格垂直对齐方式列表。
Enumeration | ForguncyDisabledSettings | 开始菜单中的不可用属性列表。
Enumeration | ForguncyPageKind | 页面类型列表。
Enumeration | ImeMode | Ime输入模式。
Enumeration | LanguageScope | 插件支持的语言版本。
Enumeration | ListViewScope | 单元格类型插件或其内部属性所支持的表格使用范围。
Enumeration | PageScope | 单元格类型插件或其内部属性所支持的页面使用范围。
Enumeration | StylePropertyName | 样式列表。
Enumeration | SupportFeatures | 单元格类型的插件支持的特性。
Enumeration | SupportStyles | 模板组件所支持的可设置的样式种类。
Enumeration | UIPermissionScope | 界面元素的权限适用范围。
See Also

Reference

GrapeCity.Forguncy.CellTypes Assembly


%%PageItemTitle%%

CategoryHeaderAttribute Class
Members Example

GrapeCity.Forguncy.CellTypes Namespace : CategoryHeaderAttribute Class
单元格类型插件中的属性编辑器中的类目属性，如文本框中使用的[显示密码]属性的类目属性[外观]。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CategoryHeaderAttribute
   Inherits System.Attribute
'Usage

Dim instance As CategoryHeaderAttribute
public class CategoryHeaderAttribute : System.Attribute
public ref class CategoryHeaderAttribute : public System.Attribute
Example
  • C#
public class TextCellType :
{
    [CategoryHeader("外观")]
    [DisplayName("显示密码")]
    public bool ShowPassword { get; set; }
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.CellTypes.CategoryHeaderAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryHeaderAttribute Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

CategoryHeaderAttribute Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : CategoryHeaderAttribute Class

The following tables list the members exposed by CategoryHeaderAttribute.

Public Constructors
 | Name | Description
Public Constructor | CategoryHeaderAttribute Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | CategoryHeader | 分类标题。
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

CategoryHeaderAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

CategoryHeaderAttribute Constructor

GrapeCity.Forguncy.CellTypes Namespace > CategoryHeaderAttribute Class : CategoryHeaderAttribute Constructor
分类标题。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal categoryHeader As String _
)
'Usage

Dim categoryHeader As String

Dim instance As New CategoryHeaderAttribute(categoryHeader)
public CategoryHeaderAttribute(
   string categoryHeader
)
public:
CategoryHeaderAttribute(
   String^ categoryHeader
)

Parameters

categoryHeader
分类标题。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryHeaderAttribute Class
CategoryHeaderAttribute Members


%%PageItemTitle%% $$Properties$$

CategoryHeaderAttribute Class Properties

GrapeCity.Forguncy.CellTypes Namespace : CategoryHeaderAttribute Class

For a list of all members of this type, see CategoryHeaderAttribute members.

Public Properties
 | Name | Description
Public Property | CategoryHeader | 分类标题。
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

CategoryHeaderAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

CategoryHeader Property

GrapeCity.Forguncy.CellTypes Namespace > CategoryHeaderAttribute Class : CategoryHeader Property
分类标题。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Property CategoryHeader As String
'Usage

Dim instance As CategoryHeaderAttribute
Dim value As String

instance.CategoryHeader = value

value = instance.CategoryHeader
public virtual string CategoryHeader {get; set;}
public:
virtual property String^ CategoryHeader {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CategoryHeaderAttribute Class
CategoryHeaderAttribute Members


%%PageItemTitle%%

CellType Class
Members Example

GrapeCity.Forguncy.CellTypes Namespace : CellType Class
单元格类型插件的父类定义。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<IconAttribute(pack://application:,,,/Forguncy;component/Images/DefaultCellTypeIcon.png)>
Public MustInherit Class CellType
'Usage

Dim instance As CellType
[Icon(pack://application:,,,/Forguncy;component/Images/DefaultCellTypeIcon.png)]
public abstract class CellType
[Icon(pack://application:,,,/Forguncy;component/Images/DefaultCellTypeIcon.png)]
public ref class CellType abstract
Example
  • C#
public class MyPluginCellType : CellType
{
    ...
}
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.CellType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

CellType Class Members
Properties Methods Events

GrapeCity.Forguncy.CellTypes Namespace : CellType Class

The following tables list the members exposed by CellType.

Public Properties
 | Name | Description
Public Property | CellTextPropertyName | 设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
Public Property | DefaultAlignment | 单元格类型插件的默认水平对齐方式。
Public Property | DisplayBehaviour | 单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
Public Property | IsAutoGenerated | 内部使用。
Public Property | SupportFeatures | 支持的特性，如设置单元格格式，Tab键设置等。
Public Property | TabIndex | Tab键顺序。
Top
Public Methods
 | Name | Description
Public Method | Clone | 克隆方法。
Public Method | GetCellValue | 获取单元格属性的值从而设值给单元格。
Public Method | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
Public Method | GetDisplayString | 获取资源化后的显示文本，通常需要在使用自定义资源文件时重写。
Public Method | GetDocProperties | 获取在“导出文档”时，要显示在文档里的属性。
Public Method | OnPropertyChanged | 当属性变更时发出通知。
Public Method | SetCellValue | 通过单元格本身的值设值给单元格属性。
Public Method | ToString | 单元格类型的显示名。 如果不指定，默认与类型名一致。
Top
Protected Methods
 | Name | Description
Protected Method | CloneImp | 克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | 内部使用。
Top
See Also

Reference

CellType Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

CellType Class Methods

GrapeCity.Forguncy.CellTypes Namespace : CellType Class

For a list of all members of this type, see CellType members.

Public Methods
 | Name | Description
Public Method | Clone | 克隆方法。
Public Method | GetCellValue | 获取单元格属性的值从而设值给单元格。
Public Method | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
Public Method | GetDisplayString | 获取资源化后的显示文本，通常需要在使用自定义资源文件时重写。
Public Method | GetDocProperties | 获取在“导出文档”时，要显示在文档里的属性。
Public Method | OnPropertyChanged | 当属性变更时发出通知。
Public Method | SetCellValue | 通过单元格本身的值设值给单元格属性。
Public Method | ToString | 单元格类型的显示名。 如果不指定，默认与类型名一致。
Top
Protected Methods
 | Name | Description
Protected Method | CloneImp | 克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
Top
See Also

Reference

CellType Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Clone Method (CellType)

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : Clone Method
克隆方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Clone() As CellType
'Usage

Dim instance As CellType
Dim value As CellType

value = instance.Clone()
public CellType Clone()
public:
CellType^ Clone();

Return Value

克隆后的插件对象。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

CloneImp Method
Example

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : CloneImp Method
克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Protected Overridable Function CloneImp() As CellType
'Usage

Dim instance As CellType
Dim value As CellType

value = instance.CloneImp()
protected virtual CellType CloneImp()
protected:
virtual CellType^ CloneImp();

Return Value

克隆后的插件对象。
Example
  • C#
public class MenuCellType : CellType
{
    public  List<MenuItemInfo> MenuItems { get; set; }
}

public class MenuItemInfo : ICloneable
{
    public object Value { get; set; }

    public string Text { get; set; }

    public  List<MenuItemInfo> SubMenuItems { get; set; }

    /*here need implement this method.*/
    public object Clone()
    {
        /*处理>*/
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

GetCellValue Method

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : GetCellValue Method
返回属性的值
返回属性的格式
获取单元格属性的值从而设值给单元格。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub GetCellValue( _
   ByRef value As Object, _
   ByRef formula As String _
)
'Usage

Dim instance As CellType
Dim value As Object
Dim formula As String

instance.GetCellValue(value, formula)
public virtual void GetCellValue(
   out object value,
   out string formula
)
public:
virtual void GetCellValue(
   [Out] Object^ value,
   [Out] String^ formula
)

Parameters

value
返回属性的值
formula
返回属性的格式
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

GetDesignerPropertyVisible Method (CellType)
Example

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : GetDesignerPropertyVisible Method
属性名
如果需要动态改变属性编辑器的可见性，可以重写该函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetDesignerPropertyVisible( _
   ByVal propertyName As String _
) As Boolean
'Usage

Dim instance As CellType
Dim propertyName As String
Dim value As Boolean

value = instance.GetDesignerPropertyVisible(propertyName)
public virtual bool GetDesignerPropertyVisible(
   string propertyName
)
public:
virtual bool GetDesignerPropertyVisible(
   String^ propertyName
)

Parameters

propertyName
属性名

Return Value

返回True表示属性编辑器可见，否则不可见。
Example
  • C#
public class MenuCellType: CellType
{
    public Orientation Orientation { get; set; }

    public ExpandStyle DefaultExpandStyle { get; set; }

    public override bool GetDesignerPropertyVisible(string propertyName)
    {
        if (propertyName == "DefaultExpandStyle")
        {
            if (Orientation == MenuOrientation.Horizontal)  //如果是水平方向的菜单隐藏默认展开方式。
            {
                return false;
            }
            return true;
        }
        return base.GetDesignerPropertyVisible(propertyName);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

GetDisplayString Method

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : GetDisplayString Method
获取资源化后的显示文本，通常需要在使用自定义资源文件时重写。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetDisplayString( _
   ByVal str As String _
) As String
'Usage

Dim instance As CellType
Dim str As String
Dim value As String

value = instance.GetDisplayString(str)
public virtual string GetDisplayString(
   string str
)
public:
virtual String^ GetDisplayString(
   String^ str
)

Parameters

str
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

GetDocProperties Method

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : GetDocProperties Method
获取在“导出文档”时，要显示在文档里的属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetDocProperties( _
   ByVal pageScope As PageScope, _
   ByVal listViewScope As ListViewScope, _
   ByVal languageScope As LanguageScope _
) As List(Of Tuple(Of String,Object))
'Usage

Dim instance As CellType
Dim pageScope As PageScope
Dim listViewScope As ListViewScope
Dim languageScope As LanguageScope
Dim value As List(Of Tuple(Of String,Object))

value = instance.GetDocProperties(pageScope, listViewScope, languageScope)
public virtual List<Tuple<string,object>> GetDocProperties(
   PageScope pageScope,
   ListViewScope listViewScope,
   LanguageScope languageScope
)
public:
virtual List<Tuple<String^,Object^>^>^ GetDocProperties(
   PageScope pageScope,
   ListViewScope listViewScope,
   LanguageScope languageScope
)

Parameters

pageScope
listViewScope
languageScope
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

OnPropertyChanged Method

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : OnPropertyChanged Method
发生变更的属性名称。
当属性变更时发出通知。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub OnPropertyChanged( _
   Optional ByVal propertyName As String _
)
'Usage

Dim instance As CellType
Dim propertyName As String

instance.OnPropertyChanged(propertyName)
public virtual void OnPropertyChanged(
   string propertyName
)
public:
virtual void OnPropertyChanged(
   String^ propertyName
)

Parameters

propertyName
发生变更的属性名称。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

SetCellValue Method

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : SetCellValue Method
单元格的值
单元格的文本
单元格是否有公式
单元格的格式
通过单元格本身的值设值给单元格属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Sub SetCellValue( _
   ByVal value As Object, _
   ByVal text As String, _
   ByVal haveFormula As Boolean, _
   ByVal formatter As IForguncyFormatter _
)
'Usage

Dim instance As CellType
Dim value As Object
Dim text As String
Dim haveFormula As Boolean
Dim formatter As IForguncyFormatter

instance.SetCellValue(value, text, haveFormula, formatter)
public virtual void SetCellValue(
   object value,
   string text,
   bool haveFormula,
   IForguncyFormatter formatter
)
public:
virtual void SetCellValue(
   Object^ value,
   String^ text,
   bool haveFormula,
   IForguncyFormatter^ formatter
)

Parameters

value
单元格的值
text
单元格的文本
haveFormula
单元格是否有公式
formatter
单元格的格式
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

ToString Method (CellType)
Example

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : ToString Method
单元格类型的显示名。 如果不指定，默认与类型名一致。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As CellType
Dim value As String

value = instance.ToString()
public override string ToString()
public:
String^ ToString(); override
Example
  • C#
public class MyPluginCellType : CellType
{
    public override string ToString()
    {
        /*return this.GetType().Name;  //默认*/
        return "我的插件";
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%PageItemTitle%% $$Properties$$

CellType Class Properties

GrapeCity.Forguncy.CellTypes Namespace : CellType Class

For a list of all members of this type, see CellType members.

Public Properties
 | Name | Description
Public Property | CellTextPropertyName | 设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
Public Property | DefaultAlignment | 单元格类型插件的默认水平对齐方式。
Public Property | DisplayBehaviour | 单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
Public Property | IsAutoGenerated | 内部使用。
Public Property | SupportFeatures | 支持的特性，如设置单元格格式，Tab键设置等。
Public Property | TabIndex | Tab键顺序。
Top
See Also

Reference

CellType Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

CellTextPropertyName Property
Example

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : CellTextPropertyName Property
设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property CellTextPropertyName As String
'Usage

Dim instance As CellType
Dim value As String

value = instance.CellTextPropertyName
public virtual string CellTextPropertyName {get;}
public:
virtual property String^ CellTextPropertyName {
   String^ get();
}
Example
  • C#
public class MyNumberCellType : CellType
{
    [FormulaProperty]
    public object DefaultNumberValue { get; set; }

    public override string CellTextPropertyName
    {
        get
        {
            return "DefaultNumberValue";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

DefaultAlignment Property
Example

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : DefaultAlignment Property
单元格类型插件的默认水平对齐方式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property DefaultAlignment As ForguncyCellHorizontalAlignment
'Usage

Dim instance As CellType
Dim value As ForguncyCellHorizontalAlignment

value = instance.DefaultAlignment
public virtual ForguncyCellHorizontalAlignment DefaultAlignment {get;}
public:
virtual property ForguncyCellHorizontalAlignment DefaultAlignment {
   ForguncyCellHorizontalAlignment get();
}
Example
  • C#
public class MyNumberCellType : CellType
{
    public override ForguncyCellHorizontalAlignment DefaultAlignment
    {
        /*return ForguncyCellHorizontalAlignment.General;  //默认对齐方式*/
        return ForguncyCellHorizontalAlignment.Right;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

DisplayBehaviour Property
Example

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : DisplayBehaviour Property
单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property DisplayBehaviour As DisplayBehaviour
'Usage

Dim instance As CellType
Dim value As DisplayBehaviour

value = instance.DisplayBehaviour
public virtual DisplayBehaviour DisplayBehaviour {get;}
public:
virtual property DisplayBehaviour DisplayBehaviour {
   DisplayBehaviour get();
}
Example
  • C#
public class MyNumberCellType : CellType
{
    public override DisplayBehaviour DisplayBehaviour
    {
        /*return DisplayBehaviour.None;  //默认没有特殊行为。*/
        return DisplayBehaviour.KeepBorderWhenMerge;  /*插件自带边框。*/
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

IsAutoGenerated Property

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : IsAutoGenerated Property
内部使用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IsAutoGenerated As Boolean
'Usage

Dim instance As CellType
Dim value As Boolean

instance.IsAutoGenerated = value

value = instance.IsAutoGenerated
public bool IsAutoGenerated {get; set;}
public:
property bool IsAutoGenerated {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

SupportFeatures Property
Example

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : SupportFeatures Property
支持的特性，如设置单元格格式，Tab键设置等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property SupportFeatures As SupportFeatures
'Usage

Dim instance As CellType
Dim value As SupportFeatures

value = instance.SupportFeatures
public virtual SupportFeatures SupportFeatures {get;}
public:
virtual property SupportFeatures SupportFeatures {
   SupportFeatures get();
}
Example
  • C#
public class MyNumberCellType : CellType
{
    public override SupportFeatures SupportFeatures
    {
        /*return SupportFeatures.None;  //默认没有特性。*/
        return SupportFeatures.AllowSetFormat;  /*插件支持单元格格式设置。*/
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%ItemTitle%%

TabIndex Property

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : TabIndex Property
Tab键顺序。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property TabIndex As Nullable(Of Integer)
'Usage

Dim instance As CellType
Dim value As Nullable(Of Integer)

instance.TabIndex = value

value = instance.TabIndex
[DefaultValue()]
[Browsable(false)]
public Nullable<int> TabIndex {get; set;}
[DefaultValue()]
[Browsable(false)]
public:
property Nullable<int> TabIndex {
   Nullable<int> get();
   void set (    Nullable<int> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%PageItemTitle%% $$Events$$

CellType Class Events

GrapeCity.Forguncy.CellTypes Namespace : CellType Class

For a list of all members of this type, see CellType members.

Public Events
 | Name | Description
Public Event | PropertyChanged | 内部使用。
Top
See Also

Reference

CellType Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

PropertyChanged Event

GrapeCity.Forguncy.CellTypes Namespace > CellType Class : PropertyChanged Event
内部使用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Event PropertyChanged As PropertyChangedEventHandler
'Usage

Dim instance As CellType
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event PropertyChangedEventHandler PropertyChanged
public:
event PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellType Class
CellType Members


%%PageItemTitle%%

CellTypeStyleTemplate Class
Members

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplate Class
单元格的模板样式。它定义了该单元格的一份完整的样式外观，包括该单元格由几个模板组件组成，以及每个模板组件的具体样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CellTypeStyleTemplate
'Usage

Dim instance As CellTypeStyleTemplate
public class CellTypeStyleTemplate
public ref class CellTypeStyleTemplate
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.CellTypeStyleTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplate Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

CellTypeStyleTemplate Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplate Class

The following tables list the members exposed by CellTypeStyleTemplate.

Public Constructors
 | Name | Description
Public Constructor | CellTypeStyleTemplate Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | Category | 单元格模板样式的所属类目。用于给模板样式分类。在设计器的功能区，预览模板样式时，它可以区分不同分类的模板样式。
Public Property | Key | 单元格模板样式的唯一标识。
Public Property | Styles | 单元格模板样式的样式组成。它是一个字典，Key为模板组件，Value为每个模板组件的具体样式信息。单元格的模板样式，由该单元格所包含的模板组件的样式所组成。一个单元格可以有一个或多个模板组件。
Top
Public Methods
 | Name | Description
Public Method | Clone | 克隆单元格模板样式。
Top
See Also

Reference

CellTypeStyleTemplate Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

CellTypeStyleTemplate Constructor

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplate Class : CellTypeStyleTemplate Constructor
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CellTypeStyleTemplate()
public CellTypeStyleTemplate()
public:
CellTypeStyleTemplate();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplate Class
CellTypeStyleTemplate Members


%%PageItemTitle%% $$Methods$$

CellTypeStyleTemplate Class Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplate Class

For a list of all members of this type, see CellTypeStyleTemplate members.

Public Methods
 | Name | Description
Public Method | Clone | 克隆单元格模板样式。
Top
See Also

Reference

CellTypeStyleTemplate Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Clone Method (CellTypeStyleTemplate)

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplate Class : Clone Method
克隆单元格模板样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Clone() As CellTypeStyleTemplate
'Usage

Dim instance As CellTypeStyleTemplate
Dim value As CellTypeStyleTemplate

value = instance.Clone()
public CellTypeStyleTemplate Clone()
public:
CellTypeStyleTemplate^ Clone();

Return Value

克隆后的单元格模板样式。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplate Class
CellTypeStyleTemplate Members


%%PageItemTitle%% $$Properties$$

CellTypeStyleTemplate Class Properties

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplate Class

For a list of all members of this type, see CellTypeStyleTemplate members.

Public Properties
 | Name | Description
Public Property | Category | 单元格模板样式的所属类目。用于给模板样式分类。在设计器的功能区，预览模板样式时，它可以区分不同分类的模板样式。
Public Property | Key | 单元格模板样式的唯一标识。
Public Property | Styles | 单元格模板样式的样式组成。它是一个字典，Key为模板组件，Value为每个模板组件的具体样式信息。单元格的模板样式，由该单元格所包含的模板组件的样式所组成。一个单元格可以有一个或多个模板组件。
Top
See Also

Reference

CellTypeStyleTemplate Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Category Property (CellTypeStyleTemplate)

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplate Class : Category Property
单元格模板样式的所属类目。用于给模板样式分类。在设计器的功能区，预览模板样式时，它可以区分不同分类的模板样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Category As String
'Usage

Dim instance As CellTypeStyleTemplate
Dim value As String

instance.Category = value

value = instance.Category
[DefaultValue()]
public string Category {get; set;}
[DefaultValue()]
public:
property String^ Category {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplate Class
CellTypeStyleTemplate Members


%%ItemTitle%%

Key Property

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplate Class : Key Property
单元格模板样式的唯一标识。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Key As String
'Usage

Dim instance As CellTypeStyleTemplate
Dim value As String

instance.Key = value

value = instance.Key
[DefaultValue()]
public string Key {get; set;}
[DefaultValue()]
public:
property String^ Key {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplate Class
CellTypeStyleTemplate Members


%%ItemTitle%%

Styles Property

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplate Class : Styles Property
单元格模板样式的样式组成。它是一个字典，Key为模板组件，Value为每个模板组件的具体样式信息。单元格的模板样式，由该单元格所包含的模板组件的样式所组成。一个单元格可以有一个或多个模板组件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Styles As Dictionary(Of String,TemplatePartStyle)
'Usage

Dim instance As CellTypeStyleTemplate
Dim value As Dictionary(Of String,TemplatePartStyle)

instance.Styles = value

value = instance.Styles
public Dictionary<string,TemplatePartStyle> Styles {get; set;}
public:
property Dictionary<String^,TemplatePartStyle^>^ Styles {
   Dictionary<String^,TemplatePartStyle^>^ get();
   void set (    Dictionary<String^,TemplatePartStyle^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplate Class
CellTypeStyleTemplate Members


%%PageItemTitle%%

CellTypeStyleTemplateSupportAttribute Class
Members Example

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplateSupportAttribute Class
单元格类型支持模板样式的标志。如果该单元格支持模板样式，可使用某个继承自此标志的标志，对模板样式进行相关配置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class CellTypeStyleTemplateSupportAttribute
   Inherits System.Attribute
'Usage

Dim instance As CellTypeStyleTemplateSupportAttribute
public abstract class CellTypeStyleTemplateSupportAttribute : System.Attribute
public ref class CellTypeStyleTemplateSupportAttribute abstract : public System.Attribute
Example
  • C#
public class YourCellTypeStyleTemplateSupportAttribute : CellTypeStyleTemplateSupportAttribute
{
    ...
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.CellTypes.CellTypeStyleTemplateSupportAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplateSupportAttribute Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

CellTypeStyleTemplateSupportAttribute Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplateSupportAttribute Class

The following tables list the members exposed by CellTypeStyleTemplateSupportAttribute.

Public Properties
 | Name | Description
Public Property | DefaultTemplateKey | 单元格默认的模板样式。它是从PresetTemplates中选择某一个模板的Key作为值。新建该单元格时，会应用上默认的模板样式。如果为空，则新建该单元格时，不应用模板样式。
Public Property | PresetTemplates | 预置的模板样式。可供用户直接选择。
Public Property | PreviewHeight | 设计器中，在功能区，显示的单元格模板样式的预览高度。默认值24。
Public Property | PreviewWidth | 设计器中，在功能区，显示的单元格模板样式的预览宽度。默认值80。
Public Property | TemplateParts | 设置单元格类型的组成部分。每一个部分的样式可单独进行设置。
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

CellTypeStyleTemplateSupportAttribute Class Properties

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplateSupportAttribute Class

For a list of all members of this type, see CellTypeStyleTemplateSupportAttribute members.

Public Properties
 | Name | Description
Public Property | DefaultTemplateKey | 单元格默认的模板样式。它是从PresetTemplates中选择某一个模板的Key作为值。新建该单元格时，会应用上默认的模板样式。如果为空，则新建该单元格时，不应用模板样式。
Public Property | PresetTemplates | 预置的模板样式。可供用户直接选择。
Public Property | PreviewHeight | 设计器中，在功能区，显示的单元格模板样式的预览高度。默认值24。
Public Property | PreviewWidth | 设计器中，在功能区，显示的单元格模板样式的预览宽度。默认值80。
Public Property | TemplateParts | 设置单元格类型的组成部分。每一个部分的样式可单独进行设置。
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

DefaultTemplateKey Property

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplateSupportAttribute Class : DefaultTemplateKey Property
单元格默认的模板样式。它是从PresetTemplates中选择某一个模板的Key作为值。新建该单元格时，会应用上默认的模板样式。如果为空，则新建该单元格时，不应用模板样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property DefaultTemplateKey As String
'Usage

Dim instance As CellTypeStyleTemplateSupportAttribute
Dim value As String

value = instance.DefaultTemplateKey
public abstract string DefaultTemplateKey {get;}
public:
abstract property String^ DefaultTemplateKey {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
CellTypeStyleTemplateSupportAttribute Members


%%ItemTitle%%

PresetTemplates Property

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplateSupportAttribute Class : PresetTemplates Property
预置的模板样式。可供用户直接选择。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property PresetTemplates As List(Of CellTypeStyleTemplate)
'Usage

Dim instance As CellTypeStyleTemplateSupportAttribute
Dim value As List(Of CellTypeStyleTemplate)

value = instance.PresetTemplates
public abstract List<CellTypeStyleTemplate> PresetTemplates {get;}
public:
abstract property List<CellTypeStyleTemplate^>^ PresetTemplates {
   List<CellTypeStyleTemplate^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
CellTypeStyleTemplateSupportAttribute Members


%%ItemTitle%%

PreviewHeight Property

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplateSupportAttribute Class : PreviewHeight Property
设计器中，在功能区，显示的单元格模板样式的预览高度。默认值24。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property PreviewHeight As Double
'Usage

Dim instance As CellTypeStyleTemplateSupportAttribute
Dim value As Double

value = instance.PreviewHeight
public virtual double PreviewHeight {get;}
public:
virtual property double PreviewHeight {
   double get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
CellTypeStyleTemplateSupportAttribute Members


%%ItemTitle%%

PreviewWidth Property

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplateSupportAttribute Class : PreviewWidth Property
设计器中，在功能区，显示的单元格模板样式的预览宽度。默认值80。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property PreviewWidth As Double
'Usage

Dim instance As CellTypeStyleTemplateSupportAttribute
Dim value As Double

value = instance.PreviewWidth
public virtual double PreviewWidth {get;}
public:
virtual property double PreviewWidth {
   double get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
CellTypeStyleTemplateSupportAttribute Members


%%ItemTitle%%

TemplateParts Property

GrapeCity.Forguncy.CellTypes Namespace > CellTypeStyleTemplateSupportAttribute Class : TemplateParts Property
设置单元格类型的组成部分。每一个部分的样式可单独进行设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property TemplateParts As List(Of TemplatePart)
'Usage

Dim instance As CellTypeStyleTemplateSupportAttribute
Dim value As List(Of TemplatePart)

value = instance.TemplateParts
public abstract List<TemplatePart> TemplateParts {get;}
public:
abstract property List<TemplatePart^>^ TemplateParts {
   List<TemplatePart^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
CellTypeStyleTemplateSupportAttribute Members


%%PageItemTitle%%

ExportResultInfo Class
Members

GrapeCity.Forguncy.CellTypes Namespace : ExportResultInfo Class
导出单元格类型的返回结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ExportResultInfo
'Usage

Dim instance As ExportResultInfo
public class ExportResultInfo
public ref class ExportResultInfo
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.ExportResultInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportResultInfo Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ExportResultInfo Class Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : ExportResultInfo Class

The following tables list the members exposed by ExportResultInfo.

Public Constructors
 | Name | Description
Public Constructor | ExportResultInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | ExportPicture | 导出单元格类型的图片。
Public Property | ExportStyleInfos | 导出单元格类型的样式。 例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。
Public Property | ExportValue | 导出单元格类型的值。
Public Property | NeedResetExportPicture | 导出时是否需要将单元格类型导出为图片。
Public Property | NeedResetExportValue | 导出时是否需要重置单元格类型的值。
Top
See Also

Reference

ExportResultInfo Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ExportResultInfo Constructor

GrapeCity.Forguncy.CellTypes Namespace > ExportResultInfo Class : ExportResultInfo Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ExportResultInfo()
public ExportResultInfo()
public:
ExportResultInfo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportResultInfo Class
ExportResultInfo Members


%%PageItemTitle%% $$Properties$$

ExportResultInfo Class Properties

GrapeCity.Forguncy.CellTypes Namespace : ExportResultInfo Class

For a list of all members of this type, see ExportResultInfo members.

Public Properties
 | Name | Description
Public Property | ExportPicture | 导出单元格类型的图片。
Public Property | ExportStyleInfos | 导出单元格类型的样式。 例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。
Public Property | ExportValue | 导出单元格类型的值。
Public Property | NeedResetExportPicture | 导出时是否需要将单元格类型导出为图片。
Public Property | NeedResetExportValue | 导出时是否需要重置单元格类型的值。
Top
See Also

Reference

ExportResultInfo Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ExportPicture Property (ExportResultInfo)
Example

GrapeCity.Forguncy.CellTypes Namespace > ExportResultInfo Class : ExportPicture Property
导出单元格类型的图片。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExportPicture As Stream
'Usage

Dim instance As ExportResultInfo
Dim value As Stream

instance.ExportPicture = value

value = instance.ExportPicture
public Stream ExportPicture {get; set;}
public:
property Stream^ ExportPicture {
   Stream^ get();
   void set (    Stream^ value);
}
Example
  • C#
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
            if (ImageInfo.BuiltIn)
            {
                folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
            }

            var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

            var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportResultInfo Class
ExportResultInfo Members


%%ItemTitle%%

ExportStyleInfos Property
Example

GrapeCity.Forguncy.CellTypes Namespace > ExportResultInfo Class : ExportStyleInfos Property

导出单元格类型的样式。

例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ExportStyleInfos As Dictionary(Of StylePropertyName,Object)
'Usage

Dim instance As ExportResultInfo
Dim value As Dictionary(Of StylePropertyName,Object)

value = instance.ExportStyleInfos
public Dictionary<StylePropertyName,object> ExportStyleInfos {get;}
public:
property Dictionary<StylePropertyName,Object^>^ ExportStyleInfos {
   Dictionary<StylePropertyName,Object^>^ get();
}
Example
  • C#
public class MultilineTextBox : CellType, IExportCellType
{
    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();

        result.ExportStyleInfos.Add(StylePropertyName.VerticalAlignment, ForguncyCellVerticalAlignment.Top);
        if (targetCell.HorizontalAlignment == ForguncyCellHorizontalAlignment.General)
        {
            result.ExportStyleInfos.Add(StylePropertyName.HorizontalAlignment, ForguncyCellHorizontalAlignment.Left);
        }
        result.ExportStyleInfos.Add(StylePropertyName.WordWrap, true);

        return result;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportResultInfo Class
ExportResultInfo Members


%%ItemTitle%%

ExportValue Property
Example

GrapeCity.Forguncy.CellTypes Namespace > ExportResultInfo Class : ExportValue Property
导出单元格类型的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ExportValue As Object
'Usage

Dim instance As ExportResultInfo
Dim value As Object

instance.ExportValue = value

value = instance.ExportValue
public object ExportValue {get; set;}
public:
property Object^ ExportValue {
   Object^ get();
   void set (    Object^ value);
}
Example
  • C#
public class ComboBoxCellType : CellType, IExportCellType
{
    public List<ItemInfo> Items { get; set; }

    public bool ExportPicture
    {
        get
        {
            return false;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();
        if(this.Items != null)
        {
            foreach (var item in this.Items)
            {
                if(object.Equals(item.Value, targetCell.Value))
                {
                    result.ExportValue = item.Text;
                    break;
                }
            }
        }

        return result;
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public object Value { get; set; }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportResultInfo Class
ExportResultInfo Members


%%ItemTitle%%

NeedResetExportPicture Property

GrapeCity.Forguncy.CellTypes Namespace > ExportResultInfo Class : NeedResetExportPicture Property
导出时是否需要将单元格类型导出为图片。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property NeedResetExportPicture As Boolean
'Usage

Dim instance As ExportResultInfo
Dim value As Boolean

value = instance.NeedResetExportPicture
public bool NeedResetExportPicture {get;}
public:
property bool NeedResetExportPicture {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportResultInfo Class
ExportResultInfo Members


%%ItemTitle%%

NeedResetExportValue Property

GrapeCity.Forguncy.CellTypes Namespace > ExportResultInfo Class : NeedResetExportValue Property
导出时是否需要重置单元格类型的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property NeedResetExportValue As Boolean
'Usage

Dim instance As ExportResultInfo
Dim value As Boolean

value = instance.NeedResetExportValue
public bool NeedResetExportValue {get;}
public:
property bool NeedResetExportValue {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportResultInfo Class
ExportResultInfo Members


%%PageItemTitle%%

PartStyleUnit Class
Members

GrapeCity.Forguncy.CellTypes Namespace : PartStyleUnit Class
模板组件的状态样式单元。它代表了模板组件在某一种状态下的完整样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PartStyleUnit
'Usage

Dim instance As PartStyleUnit
public class PartStyleUnit
public ref class PartStyleUnit
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.PartStyleUnit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

PartStyleUnit Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : PartStyleUnit Class

The following tables list the members exposed by PartStyleUnit.

Public Constructors
 | Name | Description
Public Constructor | PartStyleUnit Constructor |
Top
Public Properties
 | Name | Description
Public Property | Background | 背景。
Public Property | Bold | 字体粗细
Public Property | BorderBottomString | 下边框。
Public Property | BorderLeftString | 左边框。
Public Property | BorderRadiusString | 圆角
Public Property | BorderRightString | 右边框。
Public Property | BorderTopString | 上边框。
Public Property | BoxShadowString | 阴影
Public Property | CellHorizontalAlignment | 水平
Public Property | CellVerticalAligment | 垂直
Public Property | FontColor | 字体颜色。
Public Property | FrozenlineColor | 冻结线颜色。
Public Property | InsideHorizontalBorderString | 内部水平边框。
Public Property | InsideVerticalBorderString | 内部垂直边框。
Public Property | Italic | 字体倾斜
Public Property | Opacity | 透明度
Public Property | PaddingBottom | 下内边距
Public Property | PaddingLeft | 左内边距
Public Property | PaddingRight | 右内边距
Public Property | PaddingTop | 上内边距
Top
Public Methods
 | Name | Description
Public Method | Clone | 克隆模板组件的状态样式单元。
Public Method | CombineStyle | 将当前状态单元和另一个进行合并。
Public Method | Equals | 判断两个样式单元是否相等
Public Method | GetHashCode | 获取Hash值，以供比较
Top
See Also

Reference

PartStyleUnit Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

PartStyleUnit Constructor

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : PartStyleUnit Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PartStyleUnit()
public PartStyleUnit()
public:
PartStyleUnit();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%PageItemTitle%% $$Methods$$

PartStyleUnit Class Methods

GrapeCity.Forguncy.CellTypes Namespace : PartStyleUnit Class

For a list of all members of this type, see PartStyleUnit members.

Public Methods
 | Name | Description
Public Method | Clone | 克隆模板组件的状态样式单元。
Public Method | CombineStyle | 将当前状态单元和另一个进行合并。
Public Method | Equals | 判断两个样式单元是否相等
Public Method | GetHashCode | 获取Hash值，以供比较
Top
See Also

Reference

PartStyleUnit Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Clone Method (PartStyleUnit)

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : Clone Method
克隆模板组件的状态样式单元。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Clone() As Object
'Usage

Dim instance As PartStyleUnit
Dim value As Object

value = instance.Clone()
public object Clone()
public:
Object^ Clone();

Return Value

克隆后的状态样式单元。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

CombineStyle Method

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : CombineStyle Method
进行合并的另一个状态单元。
将当前状态单元和另一个进行合并。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function CombineStyle( _
   ByVal style As PartStyleUnit _
) As PartStyleUnit
'Usage

Dim instance As PartStyleUnit
Dim style As PartStyleUnit
Dim value As PartStyleUnit

value = instance.CombineStyle(style)
public PartStyleUnit CombineStyle(
   PartStyleUnit style
)
public:
PartStyleUnit^ CombineStyle(
   PartStyleUnit^ style
)

Parameters

style
进行合并的另一个状态单元。

Return Value

组合后的状态样式单元。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

Equals Method

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : Equals Method
判断两个样式单元是否相等
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PartStyleUnit
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public:
bool Equals(
   Object^ obj
) override

Parameters

obj

Return Value

是否相等。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

GetHashCode Method

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : GetHashCode Method
获取Hash值，以供比较
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PartStyleUnit
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public:
int GetHashCode(); override

Return Value

Hash值
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%PageItemTitle%% $$Properties$$

PartStyleUnit Class Properties

GrapeCity.Forguncy.CellTypes Namespace : PartStyleUnit Class

For a list of all members of this type, see PartStyleUnit members.

Public Properties
 | Name | Description
Public Property | Background | 背景。
Public Property | Bold | 字体粗细
Public Property | BorderBottomString | 下边框。
Public Property | BorderLeftString | 左边框。
Public Property | BorderRadiusString | 圆角
Public Property | BorderRightString | 右边框。
Public Property | BorderTopString | 上边框。
Public Property | BoxShadowString | 阴影
Public Property | CellHorizontalAlignment | 水平
Public Property | CellVerticalAligment | 垂直
Public Property | FontColor | 字体颜色。
Public Property | FrozenlineColor | 冻结线颜色。
Public Property | InsideHorizontalBorderString | 内部水平边框。
Public Property | InsideVerticalBorderString | 内部垂直边框。
Public Property | Italic | 字体倾斜
Public Property | Opacity | 透明度
Public Property | PaddingBottom | 下内边距
Public Property | PaddingLeft | 左内边距
Public Property | PaddingRight | 右内边距
Public Property | PaddingTop | 上内边距
Top
See Also

Reference

PartStyleUnit Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Background Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : Background Property
背景。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Background As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.Background = value

value = instance.Background
[DefaultValue()]
public string Background {get; set;}
[DefaultValue()]
public:
property String^ Background {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

Bold Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : Bold Property
字体粗细
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Bold As Boolean
'Usage

Dim instance As PartStyleUnit
Dim value As Boolean

instance.Bold = value

value = instance.Bold
[DefaultValue()]
public bool Bold {get; set;}
[DefaultValue()]
public:
property bool Bold {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

BorderBottomString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : BorderBottomString Property
下边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderBottomString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.BorderBottomString = value

value = instance.BorderBottomString
public string BorderBottomString {get; set;}
public:
property String^ BorderBottomString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

BorderLeftString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : BorderLeftString Property
左边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property BorderLeftString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.BorderLeftString = value

value = instance.BorderLeftString
[DefaultValue()]
public string BorderLeftString {get; set;}
[DefaultValue()]
public:
property String^ BorderLeftString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

BorderRadiusString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : BorderRadiusString Property
圆角
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property BorderRadiusString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.BorderRadiusString = value

value = instance.BorderRadiusString
[DefaultValue()]
public string BorderRadiusString {get; set;}
[DefaultValue()]
public:
property String^ BorderRadiusString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

BorderRightString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : BorderRightString Property
右边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderRightString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.BorderRightString = value

value = instance.BorderRightString
public string BorderRightString {get; set;}
public:
property String^ BorderRightString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

BorderTopString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : BorderTopString Property
上边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property BorderTopString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.BorderTopString = value

value = instance.BorderTopString
public string BorderTopString {get; set;}
public:
property String^ BorderTopString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

BoxShadowString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : BoxShadowString Property
阴影
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property BoxShadowString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.BoxShadowString = value

value = instance.BoxShadowString
[DefaultValue()]
public string BoxShadowString {get; set;}
[DefaultValue()]
public:
property String^ BoxShadowString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

CellHorizontalAlignment Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : CellHorizontalAlignment Property
水平
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property CellHorizontalAlignment As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.CellHorizontalAlignment = value

value = instance.CellHorizontalAlignment
[DefaultValue()]
public string CellHorizontalAlignment {get; set;}
[DefaultValue()]
public:
property String^ CellHorizontalAlignment {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

CellVerticalAligment Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : CellVerticalAligment Property
垂直
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property CellVerticalAligment As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.CellVerticalAligment = value

value = instance.CellVerticalAligment
[DefaultValue()]
public string CellVerticalAligment {get; set;}
[DefaultValue()]
public:
property String^ CellVerticalAligment {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

FontColor Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : FontColor Property
字体颜色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property FontColor As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.FontColor = value

value = instance.FontColor
[DefaultValue()]
public string FontColor {get; set;}
[DefaultValue()]
public:
property String^ FontColor {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

FrozenlineColor Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : FrozenlineColor Property
冻结线颜色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property FrozenlineColor As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.FrozenlineColor = value

value = instance.FrozenlineColor
[DefaultValue()]
public string FrozenlineColor {get; set;}
[DefaultValue()]
public:
property String^ FrozenlineColor {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

InsideHorizontalBorderString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : InsideHorizontalBorderString Property
内部水平边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property InsideHorizontalBorderString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.InsideHorizontalBorderString = value

value = instance.InsideHorizontalBorderString
[DefaultValue()]
public string InsideHorizontalBorderString {get; set;}
[DefaultValue()]
public:
property String^ InsideHorizontalBorderString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

InsideVerticalBorderString Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : InsideVerticalBorderString Property
内部垂直边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property InsideVerticalBorderString As String
'Usage

Dim instance As PartStyleUnit
Dim value As String

instance.InsideVerticalBorderString = value

value = instance.InsideVerticalBorderString
[DefaultValue()]
public string InsideVerticalBorderString {get; set;}
[DefaultValue()]
public:
property String^ InsideVerticalBorderString {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

Italic Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : Italic Property
字体倾斜
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Italic As Boolean
'Usage

Dim instance As PartStyleUnit
Dim value As Boolean

instance.Italic = value

value = instance.Italic
[DefaultValue()]
public bool Italic {get; set;}
[DefaultValue()]
public:
property bool Italic {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

Opacity Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : Opacity Property
透明度
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Opacity As Double
'Usage

Dim instance As PartStyleUnit
Dim value As Double

instance.Opacity = value

value = instance.Opacity
[DefaultValue()]
public double Opacity {get; set;}
[DefaultValue()]
public:
property double Opacity {
   double get();
   void set (    double value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

PaddingBottom Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : PaddingBottom Property
下内边距
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property PaddingBottom As Integer
'Usage

Dim instance As PartStyleUnit
Dim value As Integer

instance.PaddingBottom = value

value = instance.PaddingBottom
[DefaultValue()]
public int PaddingBottom {get; set;}
[DefaultValue()]
public:
property int PaddingBottom {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

PaddingLeft Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : PaddingLeft Property
左内边距
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property PaddingLeft As Integer
'Usage

Dim instance As PartStyleUnit
Dim value As Integer

instance.PaddingLeft = value

value = instance.PaddingLeft
[DefaultValue()]
public int PaddingLeft {get; set;}
[DefaultValue()]
public:
property int PaddingLeft {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

PaddingRight Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : PaddingRight Property
右内边距
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property PaddingRight As Integer
'Usage

Dim instance As PartStyleUnit
Dim value As Integer

instance.PaddingRight = value

value = instance.PaddingRight
[DefaultValue()]
public int PaddingRight {get; set;}
[DefaultValue()]
public:
property int PaddingRight {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%ItemTitle%%

PaddingTop Property

GrapeCity.Forguncy.CellTypes Namespace > PartStyleUnit Class : PaddingTop Property
上内边距
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property PaddingTop As Integer
'Usage

Dim instance As PartStyleUnit
Dim value As Integer

instance.PaddingTop = value

value = instance.PaddingTop
[DefaultValue()]
public int PaddingTop {get; set;}
[DefaultValue()]
public:
property int PaddingTop {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PartStyleUnit Class
PartStyleUnit Members


%%PageItemTitle%%

SubUIPermission Class
Members

GrapeCity.Forguncy.CellTypes Namespace : SubUIPermission Class
单元格类型子元素的界面权限项。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class SubUIPermission
'Usage

Dim instance As SubUIPermission
public class SubUIPermission
public ref class SubUIPermission
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.SubUIPermission
GrapeCity.Forguncy.CellTypes.UIPermission

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

SubUIPermission Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : SubUIPermission Class

The following tables list the members exposed by SubUIPermission.

Public Constructors
 | Name | Description
Public Constructor | SubUIPermission Constructor |
Top
Public Properties
 | Name | Description
Public Property | AllowRoles | 有权限的角色列表。
Public Property | Children | 子元素权限项集合。
Public Property | Name | 标识子元素的名称。
Top
Public Methods
 | Name | Description
Public Method | Clone | 克隆方法。
Public Method | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。
Public Method | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。
Top
See Also

Reference

SubUIPermission Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

SubUIPermission Constructor

GrapeCity.Forguncy.CellTypes Namespace > SubUIPermission Class : SubUIPermission Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SubUIPermission()
public SubUIPermission()
public:
SubUIPermission();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Class
SubUIPermission Members


%%PageItemTitle%% $$Methods$$

SubUIPermission Class Methods

GrapeCity.Forguncy.CellTypes Namespace : SubUIPermission Class

For a list of all members of this type, see SubUIPermission members.

Public Methods
 | Name | Description
Public Method | Clone | 克隆方法。
Public Method | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。
Public Method | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。
Top
See Also

Reference

SubUIPermission Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Clone Method (SubUIPermission)

GrapeCity.Forguncy.CellTypes Namespace > SubUIPermission Class : Clone Method
克隆方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function Clone() As Object
'Usage

Dim instance As SubUIPermission
Dim value As Object

value = instance.Clone()
public virtual object Clone()
public:
virtual Object^ Clone();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Class
SubUIPermission Members


%%ItemTitle%%

ShouldSerializeAllowRoles Method

GrapeCity.Forguncy.CellTypes Namespace > SubUIPermission Class : ShouldSerializeAllowRoles Method
是否需要序列化有权限的角色列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ShouldSerializeAllowRoles() As Boolean
'Usage

Dim instance As SubUIPermission
Dim value As Boolean

value = instance.ShouldSerializeAllowRoles()
public bool ShouldSerializeAllowRoles()
public:
bool ShouldSerializeAllowRoles();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Class
SubUIPermission Members


%%ItemTitle%%

ShouldSerializeChildren Method

GrapeCity.Forguncy.CellTypes Namespace > SubUIPermission Class : ShouldSerializeChildren Method
是否需要序列化子元素权限项集合。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function ShouldSerializeChildren() As Boolean
'Usage

Dim instance As SubUIPermission
Dim value As Boolean

value = instance.ShouldSerializeChildren()
public bool ShouldSerializeChildren()
public:
bool ShouldSerializeChildren();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Class
SubUIPermission Members


%%PageItemTitle%% $$Properties$$

SubUIPermission Class Properties

GrapeCity.Forguncy.CellTypes Namespace : SubUIPermission Class

For a list of all members of this type, see SubUIPermission members.

Public Properties
 | Name | Description
Public Property | AllowRoles | 有权限的角色列表。
Public Property | Children | 子元素权限项集合。
Public Property | Name | 标识子元素的名称。
Top
See Also

Reference

SubUIPermission Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

AllowRoles Property

GrapeCity.Forguncy.CellTypes Namespace > SubUIPermission Class : AllowRoles Property
有权限的角色列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property AllowRoles As List(Of String)
'Usage

Dim instance As SubUIPermission
Dim value As List(Of String)

instance.AllowRoles = value

value = instance.AllowRoles
[DefaultValue()]
public List<string> AllowRoles {get; set;}
[DefaultValue()]
public:
property List<String^>^ AllowRoles {
   List<String^>^ get();
   void set (    List<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Class
SubUIPermission Members


%%ItemTitle%%

Children Property

GrapeCity.Forguncy.CellTypes Namespace > SubUIPermission Class : Children Property
子元素权限项集合。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Children As List(Of SubUIPermission)
'Usage

Dim instance As SubUIPermission
Dim value As List(Of SubUIPermission)

instance.Children = value

value = instance.Children
[DefaultValue()]
public List<SubUIPermission> Children {get; set;}
[DefaultValue()]
public:
property List<SubUIPermission^>^ Children {
   List<SubUIPermission^>^ get();
   void set (    List<SubUIPermission^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Class
SubUIPermission Members


%%ItemTitle%%

Name Property (SubUIPermission)

GrapeCity.Forguncy.CellTypes Namespace > SubUIPermission Class : Name Property
标识子元素的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Name As String
'Usage

Dim instance As SubUIPermission
Dim value As String

instance.Name = value

value = instance.Name
[DefaultValue()]
public string Name {get; set;}
[DefaultValue()]
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubUIPermission Class
SubUIPermission Members


%%PageItemTitle%%

SupportLanguageScopeAttribute Class
Members Example

GrapeCity.Forguncy.CellTypes Namespace : SupportLanguageScopeAttribute Class
插件支持的语言版本，如果不指定默认所有语言都支持。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class SupportLanguageScopeAttribute
   Inherits System.Attribute
'Usage

Dim instance As SupportLanguageScopeAttribute
public class SupportLanguageScopeAttribute : System.Attribute
public ref class SupportLanguageScopeAttribute : public System.Attribute
Example
  • C#
[SupportLanguageScope(LanguageScope.Chinese)]  /*只支持中文版。*/
public class BDMapCellType :
{
    ...
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.CellTypes.SupportLanguageScopeAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportLanguageScopeAttribute Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

SupportLanguageScopeAttribute Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : SupportLanguageScopeAttribute Class

The following tables list the members exposed by SupportLanguageScopeAttribute.

Public Constructors
 | Name | Description
Public Constructor | SupportLanguageScopeAttribute Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | LanguageScope | 支持的语言版本。
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

SupportLanguageScopeAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

SupportLanguageScopeAttribute Constructor

GrapeCity.Forguncy.CellTypes Namespace > SupportLanguageScopeAttribute Class : SupportLanguageScopeAttribute Constructor
支持的语言版本。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal scope As LanguageScope _
)
'Usage

Dim scope As LanguageScope

Dim instance As New SupportLanguageScopeAttribute(scope)
public SupportLanguageScopeAttribute(
   LanguageScope scope
)
public:
SupportLanguageScopeAttribute(
   LanguageScope scope
)

Parameters

scope
支持的语言版本。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportLanguageScopeAttribute Class
SupportLanguageScopeAttribute Members


%%PageItemTitle%% $$Properties$$

SupportLanguageScopeAttribute Class Properties

GrapeCity.Forguncy.CellTypes Namespace : SupportLanguageScopeAttribute Class

For a list of all members of this type, see SupportLanguageScopeAttribute members.

Public Properties
 | Name | Description
Public Property | LanguageScope | 支持的语言版本。
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

SupportLanguageScopeAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

LanguageScope Property

GrapeCity.Forguncy.CellTypes Namespace > SupportLanguageScopeAttribute Class : LanguageScope Property
支持的语言版本。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property LanguageScope As LanguageScope
'Usage

Dim instance As SupportLanguageScopeAttribute
Dim value As LanguageScope

instance.LanguageScope = value

value = instance.LanguageScope
public LanguageScope LanguageScope {get; set;}
public:
property LanguageScope LanguageScope {
   LanguageScope get();
   void set (    LanguageScope value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportLanguageScopeAttribute Class
SupportLanguageScopeAttribute Members


%%PageItemTitle%%

SupportUsingScopeAttribute Class
Members Example

GrapeCity.Forguncy.CellTypes Namespace : SupportUsingScopeAttribute Class
单元格类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class SupportUsingScopeAttribute
   Inherits System.Attribute
'Usage

Dim instance As SupportUsingScopeAttribute
public class SupportUsingScopeAttribute : System.Attribute
public ref class SupportUsingScopeAttribute : public System.Attribute
Example
  • C#
[SupportUsingScope(PageScope.AllPage, ListViewScope.None)]  /*支持所有页面，不支持在表格中使用。*/
public class BDMapCellType :
{
    [SupportUsingScope(PageScope.AllPCPage, ListViewScope.None)]  /*只支持所有PC页面，不支持在手机页面或表格中使用。*/
    public bool Distance { get; set; }

    public bool ReadOnly { get; set; }  /*支持所有PC页面和手机页面，不支持在表格中使用。*/
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.CellTypes.SupportUsingScopeAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportUsingScopeAttribute Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

SupportUsingScopeAttribute Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : SupportUsingScopeAttribute Class

The following tables list the members exposed by SupportUsingScopeAttribute.

Public Constructors
 | Name | Description
Public Constructor | SupportUsingScopeAttribute Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | ListViewScope | 表格的使用范围。
Public Property | PageScope | 页面的使用范围。
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

SupportUsingScopeAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

SupportUsingScopeAttribute Constructor

GrapeCity.Forguncy.CellTypes Namespace > SupportUsingScopeAttribute Class : SupportUsingScopeAttribute Constructor
插件所支持的页面使用范围。
插件所支持的表格使用范围。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pageScope As PageScope, _
   ByVal listviewScope As ListViewScope _
)
'Usage

Dim pageScope As PageScope
Dim listviewScope As ListViewScope

Dim instance As New SupportUsingScopeAttribute(pageScope, listviewScope)
public SupportUsingScopeAttribute(
   PageScope pageScope,
   ListViewScope listviewScope
)
public:
SupportUsingScopeAttribute(
   PageScope pageScope,
   ListViewScope listviewScope
)

Parameters

pageScope
插件所支持的页面使用范围。
listviewScope
插件所支持的表格使用范围。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportUsingScopeAttribute Class
SupportUsingScopeAttribute Members


%%PageItemTitle%% $$Properties$$

SupportUsingScopeAttribute Class Properties

GrapeCity.Forguncy.CellTypes Namespace : SupportUsingScopeAttribute Class

For a list of all members of this type, see SupportUsingScopeAttribute members.

Public Properties
 | Name | Description
Public Property | ListViewScope | 表格的使用范围。
Public Property | PageScope | 页面的使用范围。
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

SupportUsingScopeAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ListViewScope Property

GrapeCity.Forguncy.CellTypes Namespace > SupportUsingScopeAttribute Class : ListViewScope Property
表格的使用范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ListViewScope As ListViewScope
'Usage

Dim instance As SupportUsingScopeAttribute
Dim value As ListViewScope

value = instance.ListViewScope
public ListViewScope ListViewScope {get;}
public:
property ListViewScope ListViewScope {
   ListViewScope get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportUsingScopeAttribute Class
SupportUsingScopeAttribute Members


%%ItemTitle%%

PageScope Property

GrapeCity.Forguncy.CellTypes Namespace > SupportUsingScopeAttribute Class : PageScope Property
页面的使用范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property PageScope As PageScope
'Usage

Dim instance As SupportUsingScopeAttribute
Dim value As PageScope

value = instance.PageScope
public PageScope PageScope {get;}
public:
property PageScope PageScope {
   PageScope get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SupportUsingScopeAttribute Class
SupportUsingScopeAttribute Members


%%PageItemTitle%%

TemplatePart Class
Members

GrapeCity.Forguncy.CellTypes Namespace : TemplatePart Class
单元格模板样式的模板组件。它以样式的角度，划分单元格的组成部分，也是设置单元格模板样式的基本单位。一个单元格类型可由一个或多个模板组件组成。每一个部分可单独设置样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class TemplatePart
'Usage

Dim instance As TemplatePart
public class TemplatePart
public ref class TemplatePart
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.TemplatePart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePart Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

TemplatePart Class Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : TemplatePart Class

The following tables list the members exposed by TemplatePart.

Public Constructors
 | Name | Description
Public Constructor | TemplatePart Constructor | 构造函数。默认支持四种状态：一遍，鼠标悬停，按下和聚焦，默认支持6种可设置的样式：背景色，背景渐变色，前景色，边框，圆角和阴影。
Top
Public Properties
 | Name | Description
Public Property | Name | 模板组件的名字。在一个单元格类型里，每个模板组件的名字应该是唯一的。
Public Property | SupportStates | 模板组件所支持的状态。
Public Property | SupportStyles | 模板组件所支持的可设置的样式。
Top
See Also

Reference

TemplatePart Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

TemplatePart Constructor

GrapeCity.Forguncy.CellTypes Namespace > TemplatePart Class : TemplatePart Constructor
构造函数。默认支持四种状态：一遍，鼠标悬停，按下和聚焦，默认支持6种可设置的样式：背景色，背景渐变色，前景色，边框，圆角和阴影。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TemplatePart()
public TemplatePart()
public:
TemplatePart();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePart Class
TemplatePart Members


%%PageItemTitle%% $$Properties$$

TemplatePart Class Properties

GrapeCity.Forguncy.CellTypes Namespace : TemplatePart Class

For a list of all members of this type, see TemplatePart members.

Public Properties
 | Name | Description
Public Property | Name | 模板组件的名字。在一个单元格类型里，每个模板组件的名字应该是唯一的。
Public Property | SupportStates | 模板组件所支持的状态。
Public Property | SupportStyles | 模板组件所支持的可设置的样式。
Top
See Also

Reference

TemplatePart Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Name Property (TemplatePart)

GrapeCity.Forguncy.CellTypes Namespace > TemplatePart Class : Name Property
模板组件的名字。在一个单元格类型里，每个模板组件的名字应该是唯一的。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As TemplatePart
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePart Class
TemplatePart Members


%%ItemTitle%%

SupportStates Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePart Class : SupportStates Property
模板组件所支持的状态。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SupportStates As CellStates
'Usage

Dim instance As TemplatePart
Dim value As CellStates

instance.SupportStates = value

value = instance.SupportStates
public CellStates SupportStates {get; set;}
public:
property CellStates SupportStates {
   CellStates get();
   void set (    CellStates value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePart Class
TemplatePart Members


%%ItemTitle%%

SupportStyles Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePart Class : SupportStyles Property
模板组件所支持的可设置的样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SupportStyles As SupportStyles
'Usage

Dim instance As TemplatePart
Dim value As SupportStyles

instance.SupportStyles = value

value = instance.SupportStyles
public SupportStyles SupportStyles {get; set;}
public:
property SupportStyles SupportStyles {
   SupportStyles get();
   void set (    SupportStyles value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePart Class
TemplatePart Members


%%PageItemTitle%%

TemplatePartStyle Class
Members

GrapeCity.Forguncy.CellTypes Namespace : TemplatePartStyle Class
模板组件的样式。保存了该模板组件在各自状态下的具体样式信息。
Object Model
TemplatePartStyle ClassPartStyleUnit ClassPartStyleUnit ClassPartStyleUnit ClassPartStyleUnit ClassPartStyleUnit ClassPartStyleUnit Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class TemplatePartStyle
'Usage

Dim instance As TemplatePartStyle
public class TemplatePartStyle
public ref class TemplatePartStyle
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.TemplatePartStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

TemplatePartStyle Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : TemplatePartStyle Class

The following tables list the members exposed by TemplatePartStyle.

Public Constructors
 | Name | Description
Public Constructor | TemplatePartStyle Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | ActiveStyle | 在鼠标按下或者触摸按下的状态下，模板组件的样式信息。
Public Property | DisableStyle | 在禁用状态下，模板组件的样式信息。
Public Property | FocusStyle | 在获取焦点状态下，模板组件的样式信息。
Public Property | HoverStyle | 在鼠标悬停状态下，模板组件的样式信息。
Public Property | NormalStyle | 在一般状态下，模板组件的样式信息。
Public Property | SelectedStyle | 在选中状态下，模板组件的样式信息。
Public Property | Transition | 切换状态时，样式变化的过渡动画时长。
Top
Public Methods
 | Name | Description
Public Method | Clone | 克隆模板组件的样式。
Top
See Also

Reference

TemplatePartStyle Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

TemplatePartStyle Constructor

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : TemplatePartStyle Constructor
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TemplatePartStyle()
public TemplatePartStyle()
public:
TemplatePartStyle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%PageItemTitle%% $$Methods$$

TemplatePartStyle Class Methods

GrapeCity.Forguncy.CellTypes Namespace : TemplatePartStyle Class

For a list of all members of this type, see TemplatePartStyle members.

Public Methods
 | Name | Description
Public Method | Clone | 克隆模板组件的样式。
Top
See Also

Reference

TemplatePartStyle Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Clone Method (TemplatePartStyle)

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : Clone Method
克隆模板组件的样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Clone() As Object
'Usage

Dim instance As TemplatePartStyle
Dim value As Object

value = instance.Clone()
public object Clone()
public:
Object^ Clone();

Return Value

克隆后的模板组件样式。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%PageItemTitle%% $$Properties$$

TemplatePartStyle Class Properties

GrapeCity.Forguncy.CellTypes Namespace : TemplatePartStyle Class

For a list of all members of this type, see TemplatePartStyle members.

Public Properties
 | Name | Description
Public Property | ActiveStyle | 在鼠标按下或者触摸按下的状态下，模板组件的样式信息。
Public Property | DisableStyle | 在禁用状态下，模板组件的样式信息。
Public Property | FocusStyle | 在获取焦点状态下，模板组件的样式信息。
Public Property | HoverStyle | 在鼠标悬停状态下，模板组件的样式信息。
Public Property | NormalStyle | 在一般状态下，模板组件的样式信息。
Public Property | SelectedStyle | 在选中状态下，模板组件的样式信息。
Public Property | Transition | 切换状态时，样式变化的过渡动画时长。
Top
See Also

Reference

TemplatePartStyle Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ActiveStyle Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : ActiveStyle Property
在鼠标按下或者触摸按下的状态下，模板组件的样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ActiveStyle As PartStyleUnit
'Usage

Dim instance As TemplatePartStyle
Dim value As PartStyleUnit

instance.ActiveStyle = value

value = instance.ActiveStyle
public PartStyleUnit ActiveStyle {get; set;}
public:
property PartStyleUnit^ ActiveStyle {
   PartStyleUnit^ get();
   void set (    PartStyleUnit^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%ItemTitle%%

DisableStyle Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : DisableStyle Property
在禁用状态下，模板组件的样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DisableStyle As PartStyleUnit
'Usage

Dim instance As TemplatePartStyle
Dim value As PartStyleUnit

instance.DisableStyle = value

value = instance.DisableStyle
public PartStyleUnit DisableStyle {get; set;}
public:
property PartStyleUnit^ DisableStyle {
   PartStyleUnit^ get();
   void set (    PartStyleUnit^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%ItemTitle%%

FocusStyle Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : FocusStyle Property
在获取焦点状态下，模板组件的样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property FocusStyle As PartStyleUnit
'Usage

Dim instance As TemplatePartStyle
Dim value As PartStyleUnit

instance.FocusStyle = value

value = instance.FocusStyle
public PartStyleUnit FocusStyle {get; set;}
public:
property PartStyleUnit^ FocusStyle {
   PartStyleUnit^ get();
   void set (    PartStyleUnit^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%ItemTitle%%

HoverStyle Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : HoverStyle Property
在鼠标悬停状态下，模板组件的样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property HoverStyle As PartStyleUnit
'Usage

Dim instance As TemplatePartStyle
Dim value As PartStyleUnit

instance.HoverStyle = value

value = instance.HoverStyle
public PartStyleUnit HoverStyle {get; set;}
public:
property PartStyleUnit^ HoverStyle {
   PartStyleUnit^ get();
   void set (    PartStyleUnit^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%ItemTitle%%

NormalStyle Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : NormalStyle Property
在一般状态下，模板组件的样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property NormalStyle As PartStyleUnit
'Usage

Dim instance As TemplatePartStyle
Dim value As PartStyleUnit

instance.NormalStyle = value

value = instance.NormalStyle
public PartStyleUnit NormalStyle {get; set;}
public:
property PartStyleUnit^ NormalStyle {
   PartStyleUnit^ get();
   void set (    PartStyleUnit^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%ItemTitle%%

SelectedStyle Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : SelectedStyle Property
在选中状态下，模板组件的样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SelectedStyle As PartStyleUnit
'Usage

Dim instance As TemplatePartStyle
Dim value As PartStyleUnit

instance.SelectedStyle = value

value = instance.SelectedStyle
public PartStyleUnit SelectedStyle {get; set;}
public:
property PartStyleUnit^ SelectedStyle {
   PartStyleUnit^ get();
   void set (    PartStyleUnit^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%ItemTitle%%

Transition Property

GrapeCity.Forguncy.CellTypes Namespace > TemplatePartStyle Class : Transition Property
切换状态时，样式变化的过渡动画时长。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Transition As String
'Usage

Dim instance As TemplatePartStyle
Dim value As String

instance.Transition = value

value = instance.Transition
[DefaultValue()]
public string Transition {get; set;}
[DefaultValue()]
public:
property String^ Transition {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemplatePartStyle Class
TemplatePartStyle Members


%%PageItemTitle%%

UIPermission Class
Members

GrapeCity.Forguncy.CellTypes Namespace : UIPermission Class
单元格类型的界面权限项。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class UIPermission
   Inherits SubUIPermission
'Usage

Dim instance As UIPermission
public class UIPermission : SubUIPermission
public ref class UIPermission : public SubUIPermission
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.SubUIPermission
GrapeCity.Forguncy.CellTypes.UIPermission

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UIPermission Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

UIPermission Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : UIPermission Class

The following tables list the members exposed by UIPermission.

Public Constructors
 | Name | Description
Public Constructor | UIPermission Constructor |
Top
Public Properties
 | Name | Description
Public Property | AllowRoles | 有权限的角色列表。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Property | Category | 类目。
Public Property | Children | 子元素权限项集合。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Property | Enabled | 是否启用权限设置。
Public Property | Ignore | 隐藏当前的权限设置，如菜单只有菜单项的权限设置，此时可隐藏菜单本身的权限设置。
Public Property | Name | 标识子元素的名称。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Property | Scope | 权限的适用范围。
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. 克隆方法。
Public Method | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Method | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Top
See Also

Reference

UIPermission Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

UIPermission Constructor

GrapeCity.Forguncy.CellTypes Namespace > UIPermission Class : UIPermission Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New UIPermission()
public UIPermission()
public:
UIPermission();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UIPermission Class
UIPermission Members


%%PageItemTitle%% $$Methods$$

UIPermission Class Methods

GrapeCity.Forguncy.CellTypes Namespace : UIPermission Class

For a list of all members of this type, see UIPermission members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. 克隆方法。
Public Method | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Method | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Top
See Also

Reference

UIPermission Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Clone Method (UIPermission)

GrapeCity.Forguncy.CellTypes Namespace > UIPermission Class : Clone Method
克隆方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function Clone() As Object
'Usage

Dim instance As UIPermission
Dim value As Object

value = instance.Clone()
public override object Clone()
public:
Object^ Clone(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UIPermission Class
UIPermission Members


%%PageItemTitle%% $$Properties$$

UIPermission Class Properties

GrapeCity.Forguncy.CellTypes Namespace : UIPermission Class

For a list of all members of this type, see UIPermission members.

Public Properties
 | Name | Description
Public Property | AllowRoles | 有权限的角色列表。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Property | Category | 类目。
Public Property | Children | 子元素权限项集合。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Property | Enabled | 是否启用权限设置。
Public Property | Ignore | 隐藏当前的权限设置，如菜单只有菜单项的权限设置，此时可隐藏菜单本身的权限设置。
Public Property | Name | 标识子元素的名称。 (Inherited from GrapeCity.Forguncy.CellTypes.SubUIPermission)
Public Property | Scope | 权限的适用范围。
Top
See Also

Reference

UIPermission Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Category Property (UIPermission)

GrapeCity.Forguncy.CellTypes Namespace > UIPermission Class : Category Property
类目。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<SaveJsonIgnoreAttribute()>
Public Property Category As String
'Usage

Dim instance As UIPermission
Dim value As String

instance.Category = value

value = instance.Category
[DefaultValue()]
[SaveJsonIgnore()]
public string Category {get; set;}
[DefaultValue()]
[SaveJsonIgnore()]
public:
property String^ Category {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UIPermission Class
UIPermission Members


%%ItemTitle%%

Enabled Property

GrapeCity.Forguncy.CellTypes Namespace > UIPermission Class : Enabled Property
是否启用权限设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Enabled As Boolean
'Usage

Dim instance As UIPermission
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
[DefaultValue()]
public bool Enabled {get; set;}
[DefaultValue()]
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UIPermission Class
UIPermission Members


%%ItemTitle%%

Ignore Property

GrapeCity.Forguncy.CellTypes Namespace > UIPermission Class : Ignore Property
隐藏当前的权限设置，如菜单只有菜单项的权限设置，此时可隐藏菜单本身的权限设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Ignore As Boolean
'Usage

Dim instance As UIPermission
Dim value As Boolean

instance.Ignore = value

value = instance.Ignore
[DefaultValue()]
public bool Ignore {get; set;}
[DefaultValue()]
public:
property bool Ignore {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UIPermission Class
UIPermission Members


%%ItemTitle%%

Scope Property

GrapeCity.Forguncy.CellTypes Namespace > UIPermission Class : Scope Property
权限的适用范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Scope As UIPermissionScope
'Usage

Dim instance As UIPermission
Dim value As UIPermissionScope

instance.Scope = value

value = instance.Scope
[DefaultValue()]
public UIPermissionScope Scope {get; set;}
[DefaultValue()]
public:
property UIPermissionScope Scope {
   UIPermissionScope get();
   void set (    UIPermissionScope value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UIPermission Class
UIPermission Members


%%PageItemTitle%%

CellStates Enumeration

GrapeCity.Forguncy.CellTypes Namespace : CellStates Enumeration
模板组件的状态种类。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum CellStates
   Inherits System.Enum
'Usage

Dim instance As CellStates
[Flags()]
public enum CellStates : System.Enum
[Flags()]
public enum class CellStates : public System.Enum
Members
Member | Description
Active | 被按下。可以是鼠标按下，或者触摸屏的被触摸。
Disable | 禁用
Focus | 获得焦点
Hover | 鼠标悬停
Normal | 一般状态
Selected | 选中
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.CellStates

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

CommandExcuteKind Enumeration

GrapeCity.Forguncy.CellTypes Namespace : CommandExcuteKind Enumeration
触发命令时机。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum CommandExcuteKind
   Inherits System.Enum
'Usage

Dim instance As CommandExcuteKind
public enum CommandExcuteKind : System.Enum
public enum class CommandExcuteKind : public System.Enum
Members
Member | Description
Click | 点击单元格时。
OnValueChanged | 单元格值发生变化时。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.CommandExcuteKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

CopyFontInfoToControlOption Enumeration

GrapeCity.Forguncy.CellTypes Namespace : CopyFontInfoToControlOption Enumeration
主要用于单元格预览和导出单元格到Excel中的画法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum CopyFontInfoToControlOption
   Inherits System.Enum
'Usage

Dim instance As CopyFontInfoToControlOption
[Flags()]
public enum CopyFontInfoToControlOption : System.Enum
[Flags()]
public enum class CopyFontInfoToControlOption : public System.Enum
Members
Member | Description
All | 根据所有样式画WPF元素。
FontInfo | 根据字体样式画WPF元素。
HorizontalAlignment | 根据水平对齐方式画WPF元素。
Indent | 根据缩进方式画WPF元素。
Normal | 根据字体样式，下划线样式，垂直和水平对齐方式画WPF元素。
Text | 根据文本内容画WPF元素。
TextDecoration | 根据下划线样式画WPF元素。
VerticalAlignment | 根据垂直对齐方式画WPF元素。
Wrap | 根据换行方式画WPF元素。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.CopyFontInfoToControlOption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

DisplayBehaviour Enumeration

GrapeCity.Forguncy.CellTypes Namespace : DisplayBehaviour Enumeration
单元格的默认显示特性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum DisplayBehaviour
   Inherits System.Enum
'Usage

Dim instance As DisplayBehaviour
[Flags()]
public enum DisplayBehaviour : System.Enum
[Flags()]
public enum class DisplayBehaviour : public System.Enum
Members
Member | Description
KeepBorderWhenMerge | 单元格类型默认生成边框，并且合并单元格后，边框会相应的发生变化。
None | 默认无特性。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.DisplayBehaviour

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ForguncyAuthenticationMode Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ForguncyAuthenticationMode Enumeration
页面认证模式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyAuthenticationMode
   Inherits System.Enum
'Usage

Dim instance As ForguncyAuthenticationMode
public enum ForguncyAuthenticationMode : System.Enum
public enum class ForguncyAuthenticationMode : public System.Enum
Members
Member | Description
Forms | 登录用户认证。
Windows | Windows域认证。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyAuthenticationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ForguncyBorderLineStyle Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ForguncyBorderLineStyle Enumeration
边框线型列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyBorderLineStyle
   Inherits System.Enum
'Usage

Dim instance As ForguncyBorderLineStyle
public enum ForguncyBorderLineStyle : System.Enum
public enum class ForguncyBorderLineStyle : public System.Enum
Members
Member | Description
Dashed | 虚线（较细）。
Dotted | 斑点线。
Double | 双线型。
Medium | 单线型（中等粗细）。
MediumDashed | 虚线（中等粗细）。
None | 无。
Thick | 粗线型。
Thin | 单线型（较细）。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyBorderLineStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ForguncyCellHorizontalAlignment Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ForguncyCellHorizontalAlignment Enumeration
单元格水平对齐方式列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyCellHorizontalAlignment
   Inherits System.Enum
'Usage

Dim instance As ForguncyCellHorizontalAlignment
public enum ForguncyCellHorizontalAlignment : System.Enum
public enum class ForguncyCellHorizontalAlignment : public System.Enum
Members
Member | Description
Center | 水平方向居中对齐。
General | 水平方向常规对齐。
Left | 水平方向靠左对齐。
Right | 水平方向靠右对齐。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyCellHorizontalAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ForguncyCellVerticalAlignment Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ForguncyCellVerticalAlignment Enumeration
单元格垂直对齐方式列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyCellVerticalAlignment
   Inherits System.Enum
'Usage

Dim instance As ForguncyCellVerticalAlignment
public enum ForguncyCellVerticalAlignment : System.Enum
public enum class ForguncyCellVerticalAlignment : public System.Enum
Members
Member | Description
Bottom | 垂直方向靠下对齐。
Center | 垂直居中对齐。
Top | 垂直方向靠上对齐。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyCellVerticalAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ForguncyDisabledSettings Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ForguncyDisabledSettings Enumeration
开始菜单中的不可用属性列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ForguncyDisabledSettings
   Inherits System.Enum
'Usage

Dim instance As ForguncyDisabledSettings
[Flags()]
public enum ForguncyDisabledSettings : System.Enum
[Flags()]
public enum class ForguncyDisabledSettings : public System.Enum
Members
Member | Description
Bold | 字体加粗。
BottomAlignment | 垂直向下对齐。
CenterAlignment | 水平居中对齐。
Italic | 斜体。
LeftAlignment | 水平向左对齐。
MiddleAlignment | 垂直居中对齐。
RightAlignment | 水平向右对齐。
TopAlignment | 垂直向上对齐。
Underline | 下划线。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyDisabledSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ForguncyPageKind Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ForguncyPageKind Enumeration
页面类型列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyPageKind
   Inherits System.Enum
'Usage

Dim instance As ForguncyPageKind
public enum ForguncyPageKind : System.Enum
public enum class ForguncyPageKind : public System.Enum
Members
Member | Description
MasterMobilePage | 手机母版页。
MasterPCPage | PC母版页。
NormalMobilePage | 普通手机页面。
NormalPCPage | 普通PC页面。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyPageKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ImeMode Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ImeMode Enumeration
Ime输入模式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ImeMode
   Inherits System.Enum
'Usage

Dim instance As ImeMode
public enum ImeMode : System.Enum
public enum class ImeMode : public System.Enum
Members
Member | Description
Active | 激活状态。
Auto | 自动。
Disabled | 禁用状态。
Inactive | 非激活状态。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ImeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

LanguageScope Enumeration

GrapeCity.Forguncy.CellTypes Namespace : LanguageScope Enumeration
插件支持的语言版本。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum LanguageScope
   Inherits System.Enum
'Usage

Dim instance As LanguageScope
[Flags()]
public enum LanguageScope : System.Enum
[Flags()]
public enum class LanguageScope : public System.Enum
Members
Member | Description
All | 同时支持所有语言的版本。
Chinese | 只支持中文版。
Japanese | 只支持日文版。
Korean | 只支持韩文版。
None | 所有语言都不支持。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.LanguageScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ListViewScope Enumeration

GrapeCity.Forguncy.CellTypes Namespace : ListViewScope Enumeration
单元格类型插件或其内部属性所支持的表格使用范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ListViewScope
   Inherits System.Enum
'Usage

Dim instance As ListViewScope
[Flags()]
public enum ListViewScope : System.Enum
[Flags()]
public enum class ListViewScope : public System.Enum
Members
Member | Description
AllListView | 支持在PC页面和手机页面的表格中使用。
ListViewInMobilePage | 只支持在手机页面的表格中使用。
ListViewInPCPage | 只支持在PC页面的表格中使用。
None | 不支持在表格中使用。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ListViewScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

PageScope Enumeration

GrapeCity.Forguncy.CellTypes Namespace : PageScope Enumeration
单元格类型插件或其内部属性所支持的页面使用范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PageScope
   Inherits System.Enum
'Usage

Dim instance As PageScope
[Flags()]
public enum PageScope : System.Enum
[Flags()]
public enum class PageScope : public System.Enum
Members
Member | Description
AllMasterPage | 支持PC母版页和手机母版页在内的所有母版页。
AllMobilePage | 支持普通手机页面和手机母版页在内的所有手机页面。
AllNormalPage | 支持普通PC页面和普通手机页面在内的所有普通页面。
AllPage | 支持所有类型页面。
AllPCPage | 支持普通PC页面和PC母版页在内的所有PC页面。
AllTemplatePage | 支持PC模板页和手机模板页在内的所有模板页。
MasterMobilePage | 只支持手机母版页。
MasterPCPage | 只支持PC母版页。
None | 所有页面都不支持。
NormalMobilePage | 只支持普通手机页面。
NormalPCPage | 只支持普通PC页面。
TemplateMobilePage | 支持手机模板页面。
TemplatePCPage | 支持模板页面。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.PageScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

StylePropertyName Enumeration

GrapeCity.Forguncy.CellTypes Namespace : StylePropertyName Enumeration
样式列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum StylePropertyName
   Inherits System.Enum
'Usage

Dim instance As StylePropertyName
public enum StylePropertyName : System.Enum
public enum class StylePropertyName : public System.Enum
Members
Member | Description
Background | 背景色。
BorderBottom | 下边框。
BorderLeft | 左边框。
BorderRight | 右边框。
BorderTop | 上边框。
FontFamily | 字体。
FontSize | 字号。
FontStyle | 字体样式。
FontWeight | 字体加粗。
Foreground | 字体颜色。
Formatter | 格式。
HorizontalAlignment | 水平对齐方式。
Strikethrough | 是否有删除线效果。
TextIndent | 缩进大小。
Underline | 是否有下划线。
VerticalAlignment | 垂直对齐方式。
WordWrap | 是否换行。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.StylePropertyName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

SupportFeatures Enumeration

GrapeCity.Forguncy.CellTypes Namespace : SupportFeatures Enumeration
单元格类型的插件支持的特性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum SupportFeatures
   Inherits System.Enum
'Usage

Dim instance As SupportFeatures
[Flags()]
public enum SupportFeatures : System.Enum
[Flags()]
public enum class SupportFeatures : public System.Enum
Members
Member | Description
All | 支持Tab键设置及所有单元格上设置格式。
AllowSetFormat | 支持在所有单元格上设置格式。
AllowSetFormatInListview | 只支持在表格单元格上设置格式。
AllowSetFormatInNormalCell | 只支持在普通单元格上设置格式。
AllowSetTabOrder | 支持Tab键设置。
None | 没有特性。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.SupportFeatures

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

SupportStyles Enumeration

GrapeCity.Forguncy.CellTypes Namespace : SupportStyles Enumeration
模板组件所支持的可设置的样式种类。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum SupportStyles
   Inherits System.Enum
'Usage

Dim instance As SupportStyles
[Flags()]
public enum SupportStyles : System.Enum
[Flags()]
public enum class SupportStyles : public System.Enum
Members
Member | Description
BackgroundColor | 背景色。
BackgroundGradient | 背景渐变色。
Bold | 粗体。
Border | 外边框。
ForegroundColor | 前景色。
FrozenlineColor | 冻结线的颜色。
HorizontalAlignment | 水平对齐方式。
InnerBorder | 内边框。
Italic | 斜体。
Opacity | 透明度。
Padding | 边距。
RoundedCorner | 圆角。
Shadow | 阴影。
VerticalAlignment | 垂直对齐方式。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.SupportStyles

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

UIPermissionScope Enumeration

GrapeCity.Forguncy.CellTypes Namespace : UIPermissionScope Enumeration
界面元素的权限适用范围。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum UIPermissionScope
   Inherits System.Enum
'Usage

Dim instance As UIPermissionScope
[Flags()]
public enum UIPermissionScope : System.Enum
[Flags()]
public enum class UIPermissionScope : public System.Enum
Members
Member | Description
Enable | 可用性权限
None | 无
Visible | 可见性权限
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.UIPermissionScope

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

IAttachedInfo Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IAttachedInfo Interface
单元格的附加信息。
Object Model
IAttachedInfo InterfaceIBindingInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IAttachedInfo
'Usage

Dim instance As IAttachedInfo
public interface IAttachedInfo
public interface class IAttachedInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAttachedInfo Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IAttachedInfo Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : IAttachedInfo Interface

The following tables list the members exposed by IAttachedInfo.

Public Properties
 | Name | Description
Property | BindingInfo | 数据绑定信息。
Top
See Also

Reference

IAttachedInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IAttachedInfo Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IAttachedInfo Interface

For a list of all members of this type, see IAttachedInfo members.

Public Properties
 | Name | Description
Property | BindingInfo | 数据绑定信息。
Top
See Also

Reference

IAttachedInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

BindingInfo Property (IAttachedInfo)

GrapeCity.Forguncy.CellTypes Namespace > IAttachedInfo Interface : BindingInfo Property
数据绑定信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BindingInfo As IBindingInfo
'Usage

Dim instance As IAttachedInfo
Dim value As IBindingInfo

value = instance.BindingInfo
IBindingInfo BindingInfo {get;}
property IBindingInfo^ BindingInfo {
   IBindingInfo^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IAttachedInfo Interface
IAttachedInfo Members


%%PageItemTitle%%

IBorderLine Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IBorderLine Interface
设置边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IBorderLine
'Usage

Dim instance As IBorderLine
public interface IBorderLine
public interface class IBorderLine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorderLine Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IBorderLine Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : IBorderLine Interface

The following tables list the members exposed by IBorderLine.

Public Properties
 | Name | Description
Property | ColorStr | 边框颜色。
Property | Style | 边框线型。
Top
See Also

Reference

IBorderLine Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IBorderLine Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IBorderLine Interface

For a list of all members of this type, see IBorderLine members.

Public Properties
 | Name | Description
Property | ColorStr | 边框颜色。
Property | Style | 边框线型。
Top
See Also

Reference

IBorderLine Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ColorStr Property

GrapeCity.Forguncy.CellTypes Namespace > IBorderLine Interface : ColorStr Property
边框颜色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ColorStr As String
'Usage

Dim instance As IBorderLine
Dim value As String

value = instance.ColorStr
string ColorStr {get;}
property String^ ColorStr {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorderLine Interface
IBorderLine Members


%%ItemTitle%%

Style Property

GrapeCity.Forguncy.CellTypes Namespace > IBorderLine Interface : Style Property
边框线型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Style As ForguncyBorderLineStyle
'Usage

Dim instance As IBorderLine
Dim value As ForguncyBorderLineStyle

value = instance.Style
ForguncyBorderLineStyle Style {get;}
property ForguncyBorderLineStyle Style {
   ForguncyBorderLineStyle get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBorderLine Interface
IBorderLine Members


%%PageItemTitle%%

ICanOverflow Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : ICanOverflow Interface

单元格类型是否支持溢出。

例如，如果超链接单元格类型所在的单元格大小不够显示完全字，并且本身和后续单元格均没有合并的情况下，超链接的字会溢出到后续单元格中。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICanOverflow
'Usage

Dim instance As ICanOverflow
public interface ICanOverflow
public interface class ICanOverflow
Example
  • C#
public class HyperlinkCellType : CellType, ICanOverflow
{
    ...
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICanOverflow Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ICanOverflow Interface Members

GrapeCity.Forguncy.CellTypes Namespace : ICanOverflow Interface

The following tables list the members exposed by ICanOverflow.

See Also

Reference

ICanOverflow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

ICellInfo Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : ICellInfo Interface
单元格的信息。
Object Model
ICellInfo InterfaceIBindingInfo InterfaceIBorderLine InterfaceIBorderLine InterfaceIBorderLine InterfaceIBorderLine InterfaceIForguncyFormatter InterfaceIListViewInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICellInfo
   Inherits IStyleInfo, IStyleTemplateInfo, GrapeCity.Forguncy.Plugin.ICellInfoBase
'Usage

Dim instance As ICellInfo
public interface ICellInfo : IStyleInfo, IStyleTemplateInfo, GrapeCity.Forguncy.Plugin.ICellInfoBase
public interface class ICellInfo : public IStyleInfo, IStyleTemplateInfo, GrapeCity.Forguncy.Plugin.ICellInfoBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ICellInfo Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : ICellInfo Interface

The following tables list the members exposed by ICellInfo.

Public Properties
 | Name | Description
Property | BackgroundStr | 背景色。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BindingInfo | 单元格的数据绑定信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | BorderBottom | 下边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BorderLeft | 左边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BorderRight | 右边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BorderTop | 上边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | ColumnIndex | 获取单元格所在列的索引。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | FontFamily | 字体。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | FontSize | 字号。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | FontStyle | 字体倾斜。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | FontWeight | 字体加粗。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | ForegroundStr | 字体颜色。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Formatter | 格式设置。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Formula | 公式。
Property | HorizontalAlignment | 水平对齐方式。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | ListViewInfo | 单元格所在表格的信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | PageName | 单元格所在的页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | PageType | 单元格所在页面的类型。
Property | RowIndex | 获取单元格所在行的索引 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | Strikethrough | 是否有删除线。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleTemplateInfo)
Property | Text | 单元格的文本。
Property | TextIndent | 缩进。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Underline | 是否有下划线。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Value | 单元格的值。
Property | VerticalAlignment | 垂直对齐方式。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | WordWrap | 是否可换行。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Top
Public Methods
 | Name | Description
Method | GetFormulaReferObject | 返回单元格对应的公式对象。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Method | InMasterPage | 单元格是否在母版页。
Method | InMobilePage | 单元格是否在手机页面。
Method | InPCPage | 单元格是否在PC页面。
Top
See Also

Reference

ICellInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

ICellInfo Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : ICellInfo Interface

For a list of all members of this type, see ICellInfo members.

Public Methods
 | Name | Description
Method | GetFormulaReferObject | 返回单元格对应的公式对象。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Method | InMasterPage | 单元格是否在母版页。
Method | InMobilePage | 单元格是否在手机页面。
Method | InPCPage | 单元格是否在PC页面。
Top
See Also

Reference

ICellInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

InMasterPage Method

GrapeCity.Forguncy.CellTypes Namespace > ICellInfo Interface : InMasterPage Method
单元格是否在母版页。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function InMasterPage() As Boolean
'Usage

Dim instance As ICellInfo
Dim value As Boolean

value = instance.InMasterPage()
bool InMasterPage()
bool InMasterPage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Interface
ICellInfo Members


%%ItemTitle%%

InMobilePage Method

GrapeCity.Forguncy.CellTypes Namespace > ICellInfo Interface : InMobilePage Method
单元格是否在手机页面。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function InMobilePage() As Boolean
'Usage

Dim instance As ICellInfo
Dim value As Boolean

value = instance.InMobilePage()
bool InMobilePage()
bool InMobilePage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Interface
ICellInfo Members


%%ItemTitle%%

InPCPage Method

GrapeCity.Forguncy.CellTypes Namespace > ICellInfo Interface : InPCPage Method
单元格是否在PC页面。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function InPCPage() As Boolean
'Usage

Dim instance As ICellInfo
Dim value As Boolean

value = instance.InPCPage()
bool InPCPage()
bool InPCPage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Interface
ICellInfo Members


%%PageItemTitle%% $$Properties$$

ICellInfo Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : ICellInfo Interface

For a list of all members of this type, see ICellInfo members.

Public Properties
 | Name | Description
Property | BackgroundStr | 背景色。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BindingInfo | 单元格的数据绑定信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | BorderBottom | 下边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BorderLeft | 左边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BorderRight | 右边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | BorderTop | 上边框。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | ColumnIndex | 获取单元格所在列的索引。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | FontFamily | 字体。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | FontSize | 字号。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | FontStyle | 字体倾斜。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | FontWeight | 字体加粗。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | ForegroundStr | 字体颜色。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Formatter | 格式设置。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Formula | 公式。
Property | HorizontalAlignment | 水平对齐方式。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | ListViewInfo | 单元格所在表格的信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | PageName | 单元格所在的页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | PageType | 单元格所在页面的类型。
Property | RowIndex | 获取单元格所在行的索引 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | Strikethrough | 是否有删除线。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleTemplateInfo)
Property | Text | 单元格的文本。
Property | TextIndent | 缩进。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Underline | 是否有下划线。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | Value | 单元格的值。
Property | VerticalAlignment | 垂直对齐方式。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Property | WordWrap | 是否可换行。 (Inherited from GrapeCity.Forguncy.CellTypes.IStyleInfo)
Top
See Also

Reference

ICellInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Formula Property

GrapeCity.Forguncy.CellTypes Namespace > ICellInfo Interface : Formula Property
公式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Formula As String
'Usage

Dim instance As ICellInfo
Dim value As String

value = instance.Formula
string Formula {get;}
property String^ Formula {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Interface
ICellInfo Members


%%ItemTitle%%

PageType Property (ICellInfo)

GrapeCity.Forguncy.CellTypes Namespace > ICellInfo Interface : PageType Property
单元格所在页面的类型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PageType As ForguncyPageKind
'Usage

Dim instance As ICellInfo
Dim value As ForguncyPageKind

value = instance.PageType
ForguncyPageKind PageType {get;}
property ForguncyPageKind PageType {
   ForguncyPageKind get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Interface
ICellInfo Members


%%ItemTitle%%

Text Property

GrapeCity.Forguncy.CellTypes Namespace > ICellInfo Interface : Text Property
单元格的文本。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Text As String
'Usage

Dim instance As ICellInfo
Dim value As String

value = instance.Text
string Text {get;}
property String^ Text {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Interface
ICellInfo Members


%%ItemTitle%%

Value Property (ICellInfo)

GrapeCity.Forguncy.CellTypes Namespace > ICellInfo Interface : Value Property
单元格的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property Value As Object
'Usage

Dim instance As ICellInfo
Dim value As Object

instance.Value = value

value = instance.Value
object Value {get; set;}
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfo Interface
ICellInfo Members


%%PageItemTitle%%

ICommandCellType Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : ICommandCellType Interface
如果单元格类型本身允许执行命令，需实现该接口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICommandCellType
'Usage

Dim instance As ICommandCellType
public interface ICommandCellType
public interface class ICommandCellType
Example
  • C#
public class ButtonCellType : CellType, ICommandCellType
{
    public List<Command> CommandList { get; set; }

    public CommandExcuteKind CommandExcuteKind
    {
        get
        {
            return CommandExcuteKind.Click;
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandCellType Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ICommandCellType Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : ICommandCellType Interface

The following tables list the members exposed by ICommandCellType.

Public Properties
 | Name | Description
Property | CommandExcuteKind | 触发命令的时机。
Property | CommandList | 命令列表。
Top
See Also

Reference

ICommandCellType Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

ICommandCellType Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : ICommandCellType Interface

For a list of all members of this type, see ICommandCellType members.

Public Properties
 | Name | Description
Property | CommandExcuteKind | 触发命令的时机。
Property | CommandList | 命令列表。
Top
See Also

Reference

ICommandCellType Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

CommandExcuteKind Property

GrapeCity.Forguncy.CellTypes Namespace > ICommandCellType Interface : CommandExcuteKind Property
触发命令的时机。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property CommandExcuteKind As CommandExcuteKind
'Usage

Dim instance As ICommandCellType
Dim value As CommandExcuteKind

value = instance.CommandExcuteKind
CommandExcuteKind CommandExcuteKind {get;}
property CommandExcuteKind CommandExcuteKind {
   CommandExcuteKind get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandCellType Interface
ICommandCellType Members


%%ItemTitle%%

CommandList Property (ICommandCellType)

GrapeCity.Forguncy.CellTypes Namespace > ICommandCellType Interface : CommandList Property
命令列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property CommandList As List(Of Command)
'Usage

Dim instance As ICommandCellType
Dim value As List(Of Command)

instance.CommandList = value

value = instance.CommandList
List<Command> CommandList {get; set;}
property List<Command^>^ CommandList {
   List<Command^>^ get();
   void set (    List<Command^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandCellType Interface
ICommandCellType Members


%%PageItemTitle%%

ICommandWindow Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : ICommandWindow Interface
活字格内部编辑命令的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICommandWindow
   Inherits IWindow
'Usage

Dim instance As ICommandWindow
public interface ICommandWindow : IWindow
public interface class ICommandWindow : public IWindow
Example
  • C#
public partial class MenuItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public MenuItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();

        _builderContext = builderContext;
    }

    private void SetCommandListHyperlink_Click(object sender, RoutedEventArgs e)
    {
        var window = _builderContext.GetCommandWindow(CommandScope.Cell);
        window.InitCommandEvent += () =>
        {
            return ViewModel.CommandList;  //基于数据层的命令列表初始化命令对话窗口。
        }
        window.UpdateCommandEvent += (sender2, commandList) =>
        {
            ViewModel.CommandList = commandList;  //提交命令设置到数据层。
        }
        window.Closed += (sender2, e2) =>
        {
            _builderContext.ShowParentDialog(this);  //关闭窗口之后打开父窗口；
        }
        //由于命令设置过程中可能会引用单元格，所以这里暂时先隐藏父窗口；
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandWindow Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ICommandWindow Interface Members
Properties Methods Events

GrapeCity.Forguncy.CellTypes Namespace : ICommandWindow Interface

The following tables list the members exposed by ICommandWindow.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
Public Events
 | Name | Description
Event | InitCommandEvent | 初始化对话框中的命令列表。
Event | UpdateCommandEvent | 更新命令数据，即将对话框中的命令列表更新会数据层。
Top
See Also

Reference

ICommandWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Events$$

ICommandWindow Interface Events

GrapeCity.Forguncy.CellTypes Namespace : ICommandWindow Interface

For a list of all members of this type, see ICommandWindow members.

Public Events
 | Name | Description
Event | InitCommandEvent | 初始化对话框中的命令列表。
Event | UpdateCommandEvent | 更新命令数据，即将对话框中的命令列表更新会数据层。
Top
See Also

Reference

ICommandWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

InitCommandEvent Event

GrapeCity.Forguncy.CellTypes Namespace > ICommandWindow Interface : InitCommandEvent Event
初始化对话框中的命令列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Event InitCommandEvent As Func(Of List(Of Command))
'Usage

Dim instance As ICommandWindow
Dim handler As Func(Of List(Of Command))

AddHandler instance.InitCommandEvent, handler
event Func<List<Command>> InitCommandEvent
event Func<List<Command^>^>^ InitCommandEvent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandWindow Interface
ICommandWindow Members


%%ItemTitle%%

UpdateCommandEvent Event

GrapeCity.Forguncy.CellTypes Namespace > ICommandWindow Interface : UpdateCommandEvent Event
更新命令数据，即将对话框中的命令列表更新会数据层。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Event UpdateCommandEvent As EventHandler(Of List(Of Command))
'Usage

Dim instance As ICommandWindow
Dim handler As EventHandler(Of List(Of Command))

AddHandler instance.UpdateCommandEvent, handler
event EventHandler<List<Command>> UpdateCommandEvent
event EventHandler<List<Command^>^>^ UpdateCommandEvent
Event Data

The event handler receives an argument of type List<T> containing data related to this event. The following List<T> properties provide information specific to this event.

Property | Description
Capacity |
Count |
Item |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICommandWindow Interface
ICommandWindow Members


%%PageItemTitle%%

IDisablePropertySettings Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IDisablePropertySettings Interface
获取单元格类型中不可用的样式属性，如对齐方式等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IDisablePropertySettings
'Usage

Dim instance As IDisablePropertySettings
public interface IDisablePropertySettings
public interface class IDisablePropertySettings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDisablePropertySettings Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IDisablePropertySettings Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : IDisablePropertySettings Interface

The following tables list the members exposed by IDisablePropertySettings.

Public Methods
 | Name | Description
Method | GetDisabledPropertySettings | 根据页面类型获取单元格类型不可用的样式属性。
Top
See Also

Reference

IDisablePropertySettings Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IDisablePropertySettings Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IDisablePropertySettings Interface

For a list of all members of this type, see IDisablePropertySettings members.

Public Methods
 | Name | Description
Method | GetDisabledPropertySettings | 根据页面类型获取单元格类型不可用的样式属性。
Top
See Also

Reference

IDisablePropertySettings Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetDisabledPropertySettings Method
Example

GrapeCity.Forguncy.CellTypes Namespace > IDisablePropertySettings Interface : GetDisabledPropertySettings Method
页面类型。
根据页面类型获取单元格类型不可用的样式属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetDisabledPropertySettings( _
   ByVal pageType As ForguncyPageKind _
) As ForguncyDisabledSettings
'Usage

Dim instance As IDisablePropertySettings
Dim pageType As ForguncyPageKind
Dim value As ForguncyDisabledSettings

value = instance.GetDisabledPropertySettings(pageType)
ForguncyDisabledSettings GetDisabledPropertySettings(
   ForguncyPageKind pageType
)
ForguncyDisabledSettings GetDisabledPropertySettings(
   ForguncyPageKind pageType
)

Parameters

pageType
页面类型。

Return Value

返回不可用的样式属性。
Example
  • C#
public class DateCellType : CellType, IDisablePropertySettings
{
    public ForguncyDisabledSettings GetDisabledPropertySettings(ForguncyPageKind pageType)
    {
        return ForguncyDisabledSettings.TopAlignment | ForguncyDisabledSettings.MiddleAlignment | ForguncyDisabledSettings.BottomAlignment;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDisablePropertySettings Interface
IDisablePropertySettings Members


%%PageItemTitle%%

IExportCellType Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : IExportCellType Interface
导出单元格类型有特殊处理时需实现该接口，比如生成图片等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IExportCellType
'Usage

Dim instance As IExportCellType
public interface IExportCellType
public interface class IExportCellType
Example
  • C#
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
            if (ImageInfo.BuiltIn)
            {
                folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
            }

            var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

            var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportCellType Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IExportCellType Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportCellType Interface

The following tables list the members exposed by IExportCellType.

Public Properties
 | Name | Description
Property | ExportPicture | 是否将单元格类型导出成图片。
Top
Public Methods
 | Name | Description
Method | ExportToExcel | 导出单元格类型时的处理。
Top
See Also

Reference

IExportCellType Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IExportCellType Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportCellType Interface

For a list of all members of this type, see IExportCellType members.

Public Methods
 | Name | Description
Method | ExportToExcel | 导出单元格类型时的处理。
Top
See Also

Reference

IExportCellType Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ExportToExcel Method

GrapeCity.Forguncy.CellTypes Namespace > IExportCellType Interface : ExportToExcel Method
单元格类型所在单元格信息。
单元格类型在导出时的上下文信息。
导出单元格类型时的处理。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ExportToExcel( _
   ByVal targetCell As ICellInfo, _
   ByVal context As IExportContext _
) As ExportResultInfo
'Usage

Dim instance As IExportCellType
Dim targetCell As ICellInfo
Dim context As IExportContext
Dim value As ExportResultInfo

value = instance.ExportToExcel(targetCell, context)
ExportResultInfo ExportToExcel(
   ICellInfo targetCell,
   IExportContext context
)
ExportResultInfo^ ExportToExcel(
   ICellInfo^ targetCell,
   IExportContext^ context
)

Parameters

targetCell
单元格类型所在单元格信息。
context
单元格类型在导出时的上下文信息。

Return Value

返回导出的单元格类型的值或图片等。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportCellType Interface
IExportCellType Members


%%PageItemTitle%% $$Properties$$

IExportCellType Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IExportCellType Interface

For a list of all members of this type, see IExportCellType members.

Public Properties
 | Name | Description
Property | ExportPicture | 是否将单元格类型导出成图片。
Top
See Also

Reference

IExportCellType Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ExportPicture Property (IExportCellType)

GrapeCity.Forguncy.CellTypes Namespace > IExportCellType Interface : ExportPicture Property
是否将单元格类型导出成图片。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ExportPicture As Boolean
'Usage

Dim instance As IExportCellType
Dim value As Boolean

value = instance.ExportPicture
bool ExportPicture {get;}
property bool ExportPicture {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportCellType Interface
IExportCellType Members


%%PageItemTitle%%

IExportContext Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IExportContext Interface
导出单元格类型的上下文信息。
Object Model
IExportContext InterfaceIExportDrawingHelper InterfaceIExportValueProvider Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IExportContext
'Usage

Dim instance As IExportContext
public interface IExportContext
public interface class IExportContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IExportContext Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportContext Interface

The following tables list the members exposed by IExportContext.

Public Properties
 | Name | Description
Property | DrawingHelper | 单元格类型生成图片时的画布工具。
Property | ExportImageContext | 导出图片时的上下文信息，如图片保存路径等相关信息。
Property | IsDebugMode | 是否是调试模式。
Property | PictureSize | 导出时单元格类型生成的图片大小。
Property | ValueProvider | 数据访问器，提供数据表的查询结果。
Top
Public Methods
 | Name | Description
Method | GetPictureByByteArray | 根据图片比特数组生成图片对象。
Method | GetPictureByPicturePath | 根据图片路径生成图片对象。
Method | SetCellTypeStyleTemplateToCell | 把模板组件在某一状态下的样式设置给单元格。
Top
See Also

Reference

IExportContext Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IExportContext Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportContext Interface

For a list of all members of this type, see IExportContext members.

Public Methods
 | Name | Description
Method | GetPictureByByteArray | 根据图片比特数组生成图片对象。
Method | GetPictureByPicturePath | 根据图片路径生成图片对象。
Method | SetCellTypeStyleTemplateToCell | 把模板组件在某一状态下的样式设置给单元格。
Top
See Also

Reference

IExportContext Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetPictureByByteArray Method
Example

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : GetPictureByByteArray Method
图片比特数组。
图片宽度。
图片高度。
根据图片比特数组生成图片对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetPictureByByteArray( _
   ByVal byteArray() As Byte, _
   ByVal width As Double, _
   ByVal height As Double _
) As Stream
'Usage

Dim instance As IExportContext
Dim byteArray() As Byte
Dim width As Double
Dim height As Double
Dim value As Stream

value = instance.GetPictureByByteArray(byteArray, width, height)
Stream GetPictureByByteArray(
   byte[] byteArray,
   double width,
   double height
)
Stream^ GetPictureByByteArray(
   array<byte>^ byteArray,
   double width,
   double height
)

Parameters

byteArray
图片比特数组。
width
图片宽度。
height
图片高度。

Return Value

返回图片对象。
Example
  • C#
public class SignatureCellType : CellType, IExportCellType
{
    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var value = targetCell.Value as string;
        if (string.IsNullOrEmpty(value))
        {
            return null;
        }

        var byteArray = Convert.FromBase64String(value);
        var bitmapImageSource = context.GetPictureByByteArray(byteArray, context.PictureSize.Width, context.PictureSize.Height);
        return new ExportResultInfo()
        {
            ExportValue = null,
            ExportPicture = bitmapImageSource
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%ItemTitle%%

GetPictureByPicturePath Method
Example

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : GetPictureByPicturePath Method
图片路径。
图片宽度。
图片高度。
根据图片路径生成图片对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetPictureByPicturePath( _
   ByVal path As String, _
   ByVal width As Double, _
   ByVal height As Double _
) As Stream
'Usage

Dim instance As IExportContext
Dim path As String
Dim width As Double
Dim height As Double
Dim value As Stream

value = instance.GetPictureByPicturePath(path, width, height)
Stream GetPictureByPicturePath(
   string path,
   double width,
   double height
)
Stream^ GetPictureByPicturePath(
   String^ path,
   double width,
   double height
)

Parameters

path
图片路径。
width
图片宽度。
height
图片高度。

Return Value

返回图片对象。
Example
  • C#
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
            if (ImageInfo.BuiltIn)
            {
                folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
            }

            var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

            var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%ItemTitle%%

SetCellTypeStyleTemplateToCell Method

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : SetCellTypeStyleTemplateToCell Method
模板组件的状态样式单元。
导出单元格类型的返回结果。
把模板组件在某一状态下的样式设置给单元格。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub SetCellTypeStyleTemplateToCell( _
   ByVal style As PartStyleUnit, _
   ByVal exportInfo As ExportResultInfo _
)
'Usage

Dim instance As IExportContext
Dim style As PartStyleUnit
Dim exportInfo As ExportResultInfo

instance.SetCellTypeStyleTemplateToCell(style, exportInfo)
void SetCellTypeStyleTemplateToCell(
   PartStyleUnit style,
   ExportResultInfo exportInfo
)
void SetCellTypeStyleTemplateToCell(
   PartStyleUnit^ style,
   ExportResultInfo^ exportInfo
)

Parameters

style
模板组件的状态样式单元。
exportInfo
导出单元格类型的返回结果。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%PageItemTitle%% $$Properties$$

IExportContext Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IExportContext Interface

For a list of all members of this type, see IExportContext members.

Public Properties
 | Name | Description
Property | DrawingHelper | 单元格类型生成图片时的画布工具。
Property | ExportImageContext | 导出图片时的上下文信息，如图片保存路径等相关信息。
Property | IsDebugMode | 是否是调试模式。
Property | PictureSize | 导出时单元格类型生成的图片大小。
Property | ValueProvider | 数据访问器，提供数据表的查询结果。
Top
See Also

Reference

IExportContext Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

DrawingHelper Property
Example

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : DrawingHelper Property
单元格类型生成图片时的画布工具。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property DrawingHelper As IExportDrawingHelper
'Usage

Dim instance As IExportContext
Dim value As IExportDrawingHelper

value = instance.DrawingHelper
IExportDrawingHelper DrawingHelper {get;}
property IExportDrawingHelper^ DrawingHelper {
   IExportDrawingHelper^ get();
}
Example
  • C#
public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
{
    TextBlock textBlock = new TextBlock();
    textBlock.Text = targetCell.Text;

    context.DrawingHelper.SetFontInfoToControl(textBlock, CopyFontInfoToControlOption.All);

    //to do...
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%ItemTitle%%

ExportImageContext Property
Example

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : ExportImageContext Property
导出图片时的上下文信息，如图片保存路径等相关信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ExportImageContext As IExportImageContext
'Usage

Dim instance As IExportContext
Dim value As IExportImageContext

value = instance.ExportImageContext
IExportImageContext ExportImageContext {get;}
property IExportImageContext^ ExportImageContext {
   IExportImageContext^ get();
}
Example
  • C#
public class SignatureCellType : CellType, IExportCellType
{
    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var value = targetCell.Value as string;
        if (string.IsNullOrEmpty(value))
        {
            return null;
        }

        var byteArray = Convert.FromBase64String(value);
        var bitmapImageSource = context.GetPictureByByteArray(byteArray, context.PictureSize.Width, context.PictureSize.Height);
        return new ExportResultInfo()
        {
            ExportValue = null,
            ExportPicture = bitmapImageSource
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%ItemTitle%%

IsDebugMode Property

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : IsDebugMode Property
是否是调试模式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property IsDebugMode As Boolean
'Usage

Dim instance As IExportContext
Dim value As Boolean

value = instance.IsDebugMode
bool IsDebugMode {get;}
property bool IsDebugMode {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%ItemTitle%%

PictureSize Property
Example

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : PictureSize Property
导出时单元格类型生成的图片大小。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PictureSize As SizeF
'Usage

Dim instance As IExportContext
Dim value As SizeF

value = instance.PictureSize
SizeF PictureSize {get;}
property SizeF PictureSize {
   SizeF get();
}
Example
  • C#
public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
{
    var result = new ExportResultInfo();
    if (this.ImageInfo != null)
    {
        var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
        if (ImageInfo.BuiltIn)
        {
            folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
        }

        var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

        var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
        result.ExportPicture = imageSource;
    }

    return result;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%ItemTitle%%

ValueProvider Property
Example

GrapeCity.Forguncy.CellTypes Namespace > IExportContext Interface : ValueProvider Property
数据访问器，提供数据表的查询结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ValueProvider As IExportValueProvider
'Usage

Dim instance As IExportContext
Dim value As IExportValueProvider

value = instance.ValueProvider
IExportValueProvider ValueProvider {get;}
property IExportValueProvider^ ValueProvider {
   IExportValueProvider^ get();
}
Example
  • C#
public class RadioGroupCellType : CellType, IExportCellType
{
    public string TableName { get; set; }

    public string TextColumn { get; set; }

    public string ValueColumn { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();

       Dictionary<string, object> queryInfo = new Dictionary<string, object>();
        queryInfo.Add(this.ValueColumn, targetCell.Value);

        var tableData = context.ValueProvider.GetTableData(TableName, new List<string>() { this.TextColumn, this.ValueColumn }, queryInfo, true);
        if(tableData != null && tableData.Count > 0)
        {
            result.ExportValue = tableData[0][this.TextColumn];
        }

        //export image
        //to do...

        return result;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportContext Interface
IExportContext Members


%%PageItemTitle%%

IExportDrawingHelper Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IExportDrawingHelper Interface
主要用于单元格预览和导出单元格到Excel中的画法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IExportDrawingHelper
'Usage

Dim instance As IExportDrawingHelper
public interface IExportDrawingHelper
public interface class IExportDrawingHelper
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IExportDrawingHelper Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportDrawingHelper Interface

The following tables list the members exposed by IExportDrawingHelper.

Public Properties
 | Name | Description
Property | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
Property | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
Property | ZoomFactor | 设计器中的缩放比例。
Top
Public Methods
 | Name | Description
Method | GetBrush |
Method | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
Top
See Also

Reference

IExportDrawingHelper Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IExportDrawingHelper Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportDrawingHelper Interface

For a list of all members of this type, see IExportDrawingHelper members.

Public Methods
 | Name | Description
Method | GetBrush |
Method | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
Top
See Also

Reference

IExportDrawingHelper Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetBrush() Method

GrapeCity.Forguncy.CellTypes Namespace > IExportDrawingHelper Interface : GetBrush() Method
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub GetBrush()
'Usage

Dim instance As IExportDrawingHelper

instance.GetBrush()
void GetBrush()
void GetBrush();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Interface
IExportDrawingHelper Members


%%ItemTitle%%

GetRealHorizontalAlignment Method (IExportDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IExportDrawingHelper Interface : GetRealHorizontalAlignment Method
单元格的信息。
单元格类型的信息。
获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetRealHorizontalAlignment( _
   ByVal cellInfo As ICellInfo, _
   ByVal cellType As Object _
) As ForguncyCellHorizontalAlignment
'Usage

Dim instance As IExportDrawingHelper
Dim cellInfo As ICellInfo
Dim cellType As Object
Dim value As ForguncyCellHorizontalAlignment

value = instance.GetRealHorizontalAlignment(cellInfo, cellType)
ForguncyCellHorizontalAlignment GetRealHorizontalAlignment(
   ICellInfo cellInfo,
   object cellType
)
ForguncyCellHorizontalAlignment GetRealHorizontalAlignment(
   ICellInfo^ cellInfo,
   Object^ cellType
)

Parameters

cellInfo
单元格的信息。
cellType
单元格类型的信息。

Return Value

返回水平对齐方式。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Interface
IExportDrawingHelper Members


%%PageItemTitle%% $$Properties$$

IExportDrawingHelper Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IExportDrawingHelper Interface

For a list of all members of this type, see IExportDrawingHelper members.

Public Properties
 | Name | Description
Property | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
Property | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
Property | ZoomFactor | 设计器中的缩放比例。
Top
See Also

Reference

IExportDrawingHelper Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ForguncyBuiltInImagesFolderPath Property (IExportDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IExportDrawingHelper Interface : ForguncyBuiltInImagesFolderPath Property
内建图片所在的文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyBuiltInImagesFolderPath As String
'Usage

Dim instance As IExportDrawingHelper
Dim value As String

value = instance.ForguncyBuiltInImagesFolderPath
string ForguncyBuiltInImagesFolderPath {get;}
property String^ ForguncyBuiltInImagesFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Interface
IExportDrawingHelper Members


%%ItemTitle%%

ForguncyImageEditorFolderPath Property (IExportDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IExportDrawingHelper Interface : ForguncyImageEditorFolderPath Property
图片选择对话框中上传的图片所在文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyImageEditorFolderPath As String
'Usage

Dim instance As IExportDrawingHelper
Dim value As String

value = instance.ForguncyImageEditorFolderPath
string ForguncyImageEditorFolderPath {get;}
property String^ ForguncyImageEditorFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Interface
IExportDrawingHelper Members


%%ItemTitle%%

ForguncyUploadFilesFolderPath Property (IExportDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IExportDrawingHelper Interface : ForguncyUploadFilesFolderPath Property
用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyUploadFilesFolderPath As String
'Usage

Dim instance As IExportDrawingHelper
Dim value As String

value = instance.ForguncyUploadFilesFolderPath
string ForguncyUploadFilesFolderPath {get;}
property String^ ForguncyUploadFilesFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Interface
IExportDrawingHelper Members


%%ItemTitle%%

ZoomFactor Property (IExportDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IExportDrawingHelper Interface : ZoomFactor Property
设计器中的缩放比例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ZoomFactor As Single
'Usage

Dim instance As IExportDrawingHelper
Dim value As Single

value = instance.ZoomFactor
float ZoomFactor {get;}
property float ZoomFactor {
   float get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Interface
IExportDrawingHelper Members


%%PageItemTitle%%

IExportValueProvider Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IExportValueProvider Interface
数据访问器，提供数据表的查询结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IExportValueProvider
'Usage

Dim instance As IExportValueProvider
public interface IExportValueProvider
public interface class IExportValueProvider
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportValueProvider Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IExportValueProvider Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportValueProvider Interface

The following tables list the members exposed by IExportValueProvider.

Public Methods
 | Name | Description
Method | GetTableData | Overloaded. 获取数据库表中的数据。
Top
See Also

Reference

IExportValueProvider Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IExportValueProvider Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IExportValueProvider Interface

For a list of all members of this type, see IExportValueProvider members.

Public Methods
 | Name | Description
Method | GetTableData | Overloaded. 获取数据库表中的数据。
Top
See Also

Reference

IExportValueProvider Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetTableData Method (IExportValueProvider)

GrapeCity.Forguncy.CellTypes Namespace > IExportValueProvider Interface : GetTableData Method
获取数据库表中的数据。
Overload List
Overload | Description
GetTableData(String,List<String>,List<String>,Dictionary<String,Object>,Boolean) | 获取数据库表中的数据。
GetTableData(String,List<String>,List<String>,Object,Boolean) | 获取数据库表中的数据。
GetTableData(List<Object>,Dictionary<Object,Object>,Boolean) | 获取数据库表中的数据。
GetTableData(List<Object>,Object,Boolean) | 获取数据库表中的数据。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportValueProvider Interface
IExportValueProvider Members


%%ItemTitle%%

GetTableData(String,List<String>,List<String>,Dictionary<String,Object>,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IExportValueProvider Interface > GetTableData Method : GetTableData(String,List<String>,List<String>,Dictionary<String,Object>,Boolean) Method
数据表名。
查询的列名集合。
查询数据的主键集合。
简单查询条件。
是否去重。
获取数据库表中的数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableData( _
   ByVal tableName As String, _
   ByVal columns As List(Of String), _
   ByVal pkl As List(Of String), _
   Optional ByVal queryInfo As Dictionary(Of String,Object), _
   Optional ByVal distinct As Boolean _
) As List(Of Dictionary(Of String,Object))
'Usage

Dim instance As IExportValueProvider
Dim tableName As String
Dim columns As List(Of String)
Dim pkl As List(Of String)
Dim queryInfo As Dictionary(Of String,Object)
Dim distinct As Boolean
Dim value As List(Of Dictionary(Of String,Object))

value = instance.GetTableData(tableName, columns, pkl, queryInfo, distinct)
List<Dictionary<string,object>> GetTableData(
   string tableName,
   List<string> columns,
   List<string> pkl,
   Dictionary<string,object> queryInfo,
   bool distinct
)
List<Dictionary<String^,Object^>^>^ GetTableData(
   String^ tableName,
   List<String^>^ columns,
   List<String^>^ pkl,
   Dictionary<String^,Object^>^ queryInfo,
   bool distinct
)

Parameters

tableName
数据表名。
columns
查询的列名集合。
pkl
查询数据的主键集合。
queryInfo
简单查询条件。
distinct
是否去重。

Return Value

查询后的数据库表中的数据。
Example
代码查看IExportContext.ValueProvider
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportValueProvider Interface
IExportValueProvider Members
Overload List


%%ItemTitle%%

GetTableData(String,List<String>,List<String>,Object,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IExportValueProvider Interface > GetTableData Method : GetTableData(String,List<String>,List<String>,Object,Boolean) Method
数据表名。
查询的列名集合。
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
去重。
获取数据库表中的数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableData( _
   ByVal tableName As String, _
   ByVal columns As List(Of String), _
   ByVal pkl As List(Of String), _
   Optional ByVal queryCondition As Object, _
   Optional ByVal distinct As Boolean _
) As List(Of Dictionary(Of String,Object))
'Usage

Dim instance As IExportValueProvider
Dim tableName As String
Dim columns As List(Of String)
Dim pkl As List(Of String)
Dim queryCondition As Object
Dim distinct As Boolean
Dim value As List(Of Dictionary(Of String,Object))

value = instance.GetTableData(tableName, columns, pkl, queryCondition, distinct)
List<Dictionary<string,object>> GetTableData(
   string tableName,
   List<string> columns,
   List<string> pkl,
   object queryCondition,
   bool distinct
)
List<Dictionary<String^,Object^>^>^ GetTableData(
   String^ tableName,
   List<String^>^ columns,
   List<String^>^ pkl,
   Object^ queryCondition,
   bool distinct
)

Parameters

tableName
数据表名。
columns
查询的列名集合。
pkl
queryCondition
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
distinct
去重。

Return Value

查询后的数据库表中的数据。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportValueProvider Interface
IExportValueProvider Members
Overload List


%%ItemTitle%%

GetTableData(List<Object>,Dictionary<Object,Object>,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IExportValueProvider Interface > GetTableData Method : GetTableData(List<Object>,Dictionary<Object,Object>,Boolean) Method
绑定的数据表中的字段列表。
绑定字段查询条件。
是否去重。
获取数据库表中的数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableData( _
   ByVal columnInfos As List(Of Object), _
   ByVal queryInfo As Dictionary(Of Object,Object), _
   Optional ByVal distinct As Boolean _
) As List(Of Dictionary(Of Object,Object))
'Usage

Dim instance As IExportValueProvider
Dim columnInfos As List(Of Object)
Dim queryInfo As Dictionary(Of Object,Object)
Dim distinct As Boolean
Dim value As List(Of Dictionary(Of Object,Object))

value = instance.GetTableData(columnInfos, queryInfo, distinct)
List<Dictionary<object,object>> GetTableData(
   List<object> columnInfos,
   Dictionary<object,object> queryInfo,
   bool distinct
)
List<Dictionary<Object^,Object^>^>^ GetTableData(
   List<Object^>^ columnInfos,
   Dictionary<Object^,Object^>^ queryInfo,
   bool distinct
)

Parameters

columnInfos
绑定的数据表中的字段列表。
queryInfo
绑定字段查询条件。
distinct
是否去重。

Return Value

查询后的数据库表中的数据。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportValueProvider Interface
IExportValueProvider Members
Overload List


%%ItemTitle%%

GetTableData(List<Object>,Object,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IExportValueProvider Interface > GetTableData Method : GetTableData(List<Object>,Object,Boolean) Method
绑定的数据表中的字段列表。
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
是否去重。
获取数据库表中的数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableData( _
   ByVal columnInfos As List(Of Object), _
   ByVal queryCondition As Object, _
   Optional ByVal distinct As Boolean _
) As List(Of Dictionary(Of Object,Object))
'Usage

Dim instance As IExportValueProvider
Dim columnInfos As List(Of Object)
Dim queryCondition As Object
Dim distinct As Boolean
Dim value As List(Of Dictionary(Of Object,Object))

value = instance.GetTableData(columnInfos, queryCondition, distinct)
List<Dictionary<object,object>> GetTableData(
   List<object> columnInfos,
   object queryCondition,
   bool distinct
)
List<Dictionary<Object^,Object^>^>^ GetTableData(
   List<Object^>^ columnInfos,
   Object^ queryCondition,
   bool distinct
)

Parameters

columnInfos
绑定的数据表中的字段列表。
queryCondition
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
distinct
是否去重。

Return Value

查询后的数据库表中的数据。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportValueProvider Interface
IExportValueProvider Members
Overload List


%%PageItemTitle%%

IForguncyFormatter Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IForguncyFormatter Interface
单元格格式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IForguncyFormatter
'Usage

Dim instance As IForguncyFormatter
public interface IForguncyFormatter
public interface class IForguncyFormatter
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IForguncyFormatter Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IForguncyFormatter Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : IForguncyFormatter Interface

The following tables list the members exposed by IForguncyFormatter.

Public Properties
 | Name | Description
Property | FormatString | 格式字符串。
Top
Public Methods
 | Name | Description
Method | Format | 通过格式字符串转换成值。
Top
See Also

Reference

IForguncyFormatter Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IForguncyFormatter Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IForguncyFormatter Interface

For a list of all members of this type, see IForguncyFormatter members.

Public Methods
 | Name | Description
Method | Format | 通过格式字符串转换成值。
Top
See Also

Reference

IForguncyFormatter Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Format Method

GrapeCity.Forguncy.CellTypes Namespace > IForguncyFormatter Interface : Format Method
原始值。
通过格式字符串转换成值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function Format( _
   ByVal value As Object _
) As String
'Usage

Dim instance As IForguncyFormatter
Dim value As Object
Dim value As String

value = instance.Format(value)
string Format(
   object value
)
String^ Format(
   Object^ value
)

Parameters

value
原始值。

Return Value

返回转换之后的值。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IForguncyFormatter Interface
IForguncyFormatter Members


%%PageItemTitle%% $$Properties$$

IForguncyFormatter Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IForguncyFormatter Interface

For a list of all members of this type, see IForguncyFormatter members.

Public Properties
 | Name | Description
Property | FormatString | 格式字符串。
Top
See Also

Reference

IForguncyFormatter Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

FormatString Property

GrapeCity.Forguncy.CellTypes Namespace > IForguncyFormatter Interface : FormatString Property
格式字符串。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property FormatString As String
'Usage

Dim instance As IForguncyFormatter
Dim value As String

value = instance.FormatString
string FormatString {get;}
property String^ FormatString {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IForguncyFormatter Interface
IForguncyFormatter Members


%%PageItemTitle%%

IIgnoreAlternativeRowBackColorWhenExport Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : IIgnoreAlternativeRowBackColorWhenExport Interface
配合IExportCellType使用，导出Excel时不使用页面中表格的交替色作为背景色，如表格中的按钮导出到Excel时不使用交替色作为背景色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IIgnoreAlternativeRowBackColorWhenExport
'Usage

Dim instance As IIgnoreAlternativeRowBackColorWhenExport
public interface IIgnoreAlternativeRowBackColorWhenExport
public interface class IIgnoreAlternativeRowBackColorWhenExport
Example
  • C#
public class ButtonCellType : CellType, IExportCellType, IIgnoreAlternativeRowBackColorWhenExport
{
    ...
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IIgnoreAlternativeRowBackColorWhenExport Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IIgnoreAlternativeRowBackColorWhenExport Interface Members

GrapeCity.Forguncy.CellTypes Namespace : IIgnoreAlternativeRowBackColorWhenExport Interface

The following tables list the members exposed by IIgnoreAlternativeRowBackColorWhenExport.

See Also

Reference

IIgnoreAlternativeRowBackColorWhenExport Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

IReferenceCommand Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : IReferenceCommand Interface
如果一个单元格不是ICommandCellType，但是该单元格内部属性中有命令设置，如菜单单元格类型，需实现该接口； 否则有些命令执行会出错，而且查找所有引用会有遗漏。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IReferenceCommand
'Usage

Dim instance As IReferenceCommand
public interface IReferenceCommand
public interface class IReferenceCommand
Example
  • C#
public class MyMenuCellType : CellType, IReferenceCommand
{
    public List<ItemInfo> Items { get; set; }

    public IEnumerable<LocatedObject<List<Command>>> GetCommandList(LocationIndicator location)
    {
        return this.GetCommandList(this.Items, location);
    }

    private IEnumerable<LocatedObject<List<Command>>> GetCommandList(List<ItemInfo> items, LocationIndicator location)
    {
        if (items == null)
        {
            yield break;
        }
        foreach (var item in items)
        {
            if (item.CommandList != null)
            {
                var newLocation = location.AppendProperty("MyMenuCellType").AppendProperty(item.Text).AppendProperty("CommandList");
                yield return new LocatedObject<List<Command>>(item.CommandList, newLocation);
            }

            foreach (var item2 in GetCommandList(item.SubItems, location))
            {
                yield return item2;
            }
        }
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public List<Command> CommandList { get; set; }

    public List<ItemInfo> SubItems { get; set; }
    //...
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceCommand Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IReferenceCommand Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : IReferenceCommand Interface

The following tables list the members exposed by IReferenceCommand.

Public Methods
 | Name | Description
Method | GetCommandList | 返回插件内部属性使用到的所有的命令列表。
Top
See Also

Reference

IReferenceCommand Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IReferenceCommand Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IReferenceCommand Interface

For a list of all members of this type, see IReferenceCommand members.

Public Methods
 | Name | Description
Method | GetCommandList | 返回插件内部属性使用到的所有的命令列表。
Top
See Also

Reference

IReferenceCommand Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetCommandList Method

GrapeCity.Forguncy.CellTypes Namespace > IReferenceCommand Interface : GetCommandList Method
坐标定位器。
返回插件内部属性使用到的所有的命令列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetCommandList( _
   ByVal location As LocationIndicator _
) As IEnumerable(Of LocatedObject(Of List(Of Command)))
'Usage

Dim instance As IReferenceCommand
Dim location As LocationIndicator
Dim value As IEnumerable(Of LocatedObject(Of List(Of Command)))

value = instance.GetCommandList(location)
IEnumerable<LocatedObject<List<Command>>> GetCommandList(
   LocationIndicator location
)
IEnumerable<LocatedObject<List<Command^>^>^>^ GetCommandList(
   LocationIndicator^ location
)

Parameters

location
坐标定位器。

Return Value

返回插件内部属性使用到的所有的命令列表。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceCommand Interface
IReferenceCommand Members


%%PageItemTitle%%

ISelectImageWindow Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : ISelectImageWindow Interface
内置图片选择对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISelectImageWindow
   Inherits IWindow
'Usage

Dim instance As ISelectImageWindow
public interface ISelectImageWindow : IWindow
public interface class ISelectImageWindow : public IWindow
Example
  • C#
public partial class MenuItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public MenuItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();

        _builderContext = builderContext;
    }

    private void SelectImageHyperlink_Click(object sender, RoutedEventArgs e)
    {
        var window = _builderContext.GetSelectImageWindow(ViewModel.ImagePath, ViewModel.IsBuiltInImage);
        window.Closed += (sender2, e2) =>
        {
            if (window.DialogResult == true)
            {
                ViewModel.ImagePath = window.ImagePath;
                ViewModel.IsBuiltInImage = window.BuiltIn;
            }
        }

        window.ShowDialog();
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISelectImageWindow Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ISelectImageWindow Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : ISelectImageWindow Interface

The following tables list the members exposed by ISelectImageWindow.

Public Properties
 | Name | Description
Property | BuiltIn | 返回选中图片是否是内置图片。
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Property | ImageColor | 返回选中图片的填充颜色
Property | ImagePath | 返回选中图片的名称。
Top
Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

ISelectImageWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

ISelectImageWindow Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : ISelectImageWindow Interface

For a list of all members of this type, see ISelectImageWindow members.

Public Properties
 | Name | Description
Property | BuiltIn | 返回选中图片是否是内置图片。
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Property | ImageColor | 返回选中图片的填充颜色
Property | ImagePath | 返回选中图片的名称。
Top
See Also

Reference

ISelectImageWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

BuiltIn Property (ISelectImageWindow)

GrapeCity.Forguncy.CellTypes Namespace > ISelectImageWindow Interface : BuiltIn Property
返回选中图片是否是内置图片。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BuiltIn As Boolean
'Usage

Dim instance As ISelectImageWindow
Dim value As Boolean

value = instance.BuiltIn
bool BuiltIn {get;}
property bool BuiltIn {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISelectImageWindow Interface
ISelectImageWindow Members


%%ItemTitle%%

ImageColor Property

GrapeCity.Forguncy.CellTypes Namespace > ISelectImageWindow Interface : ImageColor Property
返回选中图片的填充颜色
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ImageColor As String
'Usage

Dim instance As ISelectImageWindow
Dim value As String

value = instance.ImageColor
string ImageColor {get;}
property String^ ImageColor {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISelectImageWindow Interface
ISelectImageWindow Members


%%ItemTitle%%

ImagePath Property

GrapeCity.Forguncy.CellTypes Namespace > ISelectImageWindow Interface : ImagePath Property
返回选中图片的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ImagePath As String
'Usage

Dim instance As ISelectImageWindow
Dim value As String

value = instance.ImagePath
string ImagePath {get;}
property String^ ImagePath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISelectImageWindow Interface
ISelectImageWindow Members


%%PageItemTitle%%

ISortConditionWindow Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : ISortConditionWindow Interface
活字格内置的设置排序条件的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISortConditionWindow
   Inherits IWindow
'Usage

Dim instance As ISortConditionWindow
public interface ISortConditionWindow : IWindow
public interface class ISortConditionWindow : public IWindow
Example
  • C#
public class TreeCellTypeDesigner : CellTypeDesigner<TreeCellType>
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出排序对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditSortConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的排序条件和表名初始化排序对话窗口。*/
        var window = _builderContext?.GetSortConditionWindow(sortCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的排序条件提交到数据层。*/
                /*ViewModel.SortCondition = window.SortCondition;*/
            }
        }
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object SortCondition { get; set; }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISortConditionWindow Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ISortConditionWindow Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : ISortConditionWindow Interface

The following tables list the members exposed by ISortConditionWindow.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Property | SortCondition | 排序条件。
Top
Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

ISortConditionWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

ISortConditionWindow Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : ISortConditionWindow Interface

For a list of all members of this type, see ISortConditionWindow members.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Property | SortCondition | 排序条件。
Top
See Also

Reference

ISortConditionWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

SortCondition Property

GrapeCity.Forguncy.CellTypes Namespace > ISortConditionWindow Interface : SortCondition Property
排序条件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property SortCondition As Object
'Usage

Dim instance As ISortConditionWindow
Dim value As Object

value = instance.SortCondition
object SortCondition {get;}
property Object^ SortCondition {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISortConditionWindow Interface
ISortConditionWindow Members


%%PageItemTitle%%

IStaticValueCellType Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IStaticValueCellType Interface
忽略单元格的值，可以自定义单元格类型返回的值； 例如，如果一个单元格引用登录用户单元格类型的值，返回的是当前用户，而非单元格上的值或0。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IStaticValueCellType
'Usage

Dim instance As IStaticValueCellType
public interface IStaticValueCellType
public interface class IStaticValueCellType
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticValueCellType Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IStaticValueCellType Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : IStaticValueCellType Interface

The following tables list the members exposed by IStaticValueCellType.

Public Properties
 | Name | Description
Property | CellCustomValue | 单元格返回的自定义固定值。
Top
See Also

Reference

IStaticValueCellType Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IStaticValueCellType Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IStaticValueCellType Interface

For a list of all members of this type, see IStaticValueCellType members.

Public Properties
 | Name | Description
Property | CellCustomValue | 单元格返回的自定义固定值。
Top
See Also

Reference

IStaticValueCellType Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

CellCustomValue Property
Example

GrapeCity.Forguncy.CellTypes Namespace > IStaticValueCellType Interface : CellCustomValue Property
单元格返回的自定义固定值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property CellCustomValue As Object
'Usage

Dim instance As IStaticValueCellType
Dim value As Object

value = instance.CellCustomValue
object CellCustomValue {get;}
property Object^ CellCustomValue {
   Object^ get();
}
Example
  • C#
public class CurrentUserCellType : CellType, IStaticValueCellType
{
    public object CellCustomValue
    {
        get
        {
            return "CurrentUser";
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStaticValueCellType Interface
IStaticValueCellType Members


%%PageItemTitle%%

IStyleInfo Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IStyleInfo Interface
设置样式。
Object Model
IStyleInfo InterfaceIBorderLine InterfaceIBorderLine InterfaceIBorderLine InterfaceIBorderLine InterfaceIForguncyFormatter Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IStyleInfo
'Usage

Dim instance As IStyleInfo
public interface IStyleInfo
public interface class IStyleInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IStyleInfo Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : IStyleInfo Interface

The following tables list the members exposed by IStyleInfo.

Public Properties
 | Name | Description
Property | BackgroundStr | 背景色。
Property | BorderBottom | 下边框。
Property | BorderLeft | 左边框。
Property | BorderRight | 右边框。
Property | BorderTop | 上边框。
Property | FontFamily | 字体。
Property | FontSize | 字号。
Property | FontStyle | 字体倾斜。
Property | FontWeight | 字体加粗。
Property | ForegroundStr | 字体颜色。
Property | Formatter | 格式设置。
Property | HorizontalAlignment | 水平对齐方式。
Property | Strikethrough | 是否有删除线。
Property | TextIndent | 缩进。
Property | Underline | 是否有下划线。
Property | VerticalAlignment | 垂直对齐方式。
Property | WordWrap | 是否可换行。
Top
See Also

Reference

IStyleInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IStyleInfo Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IStyleInfo Interface

For a list of all members of this type, see IStyleInfo members.

Public Properties
 | Name | Description
Property | BackgroundStr | 背景色。
Property | BorderBottom | 下边框。
Property | BorderLeft | 左边框。
Property | BorderRight | 右边框。
Property | BorderTop | 上边框。
Property | FontFamily | 字体。
Property | FontSize | 字号。
Property | FontStyle | 字体倾斜。
Property | FontWeight | 字体加粗。
Property | ForegroundStr | 字体颜色。
Property | Formatter | 格式设置。
Property | HorizontalAlignment | 水平对齐方式。
Property | Strikethrough | 是否有删除线。
Property | TextIndent | 缩进。
Property | Underline | 是否有下划线。
Property | VerticalAlignment | 垂直对齐方式。
Property | WordWrap | 是否可换行。
Top
See Also

Reference

IStyleInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

BackgroundStr Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : BackgroundStr Property
背景色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BackgroundStr As String
'Usage

Dim instance As IStyleInfo
Dim value As String

value = instance.BackgroundStr
string BackgroundStr {get;}
property String^ BackgroundStr {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

BorderBottom Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : BorderBottom Property
下边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BorderBottom As IBorderLine
'Usage

Dim instance As IStyleInfo
Dim value As IBorderLine

value = instance.BorderBottom
IBorderLine BorderBottom {get;}
property IBorderLine^ BorderBottom {
   IBorderLine^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

BorderLeft Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : BorderLeft Property
左边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BorderLeft As IBorderLine
'Usage

Dim instance As IStyleInfo
Dim value As IBorderLine

value = instance.BorderLeft
IBorderLine BorderLeft {get;}
property IBorderLine^ BorderLeft {
   IBorderLine^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

BorderRight Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : BorderRight Property
右边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BorderRight As IBorderLine
'Usage

Dim instance As IStyleInfo
Dim value As IBorderLine

value = instance.BorderRight
IBorderLine BorderRight {get;}
property IBorderLine^ BorderRight {
   IBorderLine^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

BorderTop Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : BorderTop Property
上边框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BorderTop As IBorderLine
'Usage

Dim instance As IStyleInfo
Dim value As IBorderLine

value = instance.BorderTop
IBorderLine BorderTop {get;}
property IBorderLine^ BorderTop {
   IBorderLine^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

FontFamily Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : FontFamily Property
字体。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property FontFamily As String
'Usage

Dim instance As IStyleInfo
Dim value As String

value = instance.FontFamily
string FontFamily {get;}
property String^ FontFamily {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

FontSize Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : FontSize Property
字号。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property FontSize As Double
'Usage

Dim instance As IStyleInfo
Dim value As Double

value = instance.FontSize
double FontSize {get;}
property double FontSize {
   double get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

FontStyle Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : FontStyle Property
字体倾斜。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property FontStyle As String
'Usage

Dim instance As IStyleInfo
Dim value As String

value = instance.FontStyle
string FontStyle {get;}
property String^ FontStyle {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

FontWeight Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : FontWeight Property
字体加粗。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property FontWeight As String
'Usage

Dim instance As IStyleInfo
Dim value As String

value = instance.FontWeight
string FontWeight {get;}
property String^ FontWeight {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

ForegroundStr Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : ForegroundStr Property
字体颜色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForegroundStr As String
'Usage

Dim instance As IStyleInfo
Dim value As String

value = instance.ForegroundStr
string ForegroundStr {get;}
property String^ ForegroundStr {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

Formatter Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : Formatter Property
格式设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Formatter As IForguncyFormatter
'Usage

Dim instance As IStyleInfo
Dim value As IForguncyFormatter

value = instance.Formatter
IForguncyFormatter Formatter {get;}
property IForguncyFormatter^ Formatter {
   IForguncyFormatter^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

HorizontalAlignment Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : HorizontalAlignment Property
水平对齐方式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property HorizontalAlignment As ForguncyCellHorizontalAlignment
'Usage

Dim instance As IStyleInfo
Dim value As ForguncyCellHorizontalAlignment

value = instance.HorizontalAlignment
ForguncyCellHorizontalAlignment HorizontalAlignment {get;}
property ForguncyCellHorizontalAlignment HorizontalAlignment {
   ForguncyCellHorizontalAlignment get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

Strikethrough Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : Strikethrough Property
是否有删除线。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Strikethrough As Nullable(Of Boolean)
'Usage

Dim instance As IStyleInfo
Dim value As Nullable(Of Boolean)

value = instance.Strikethrough
Nullable<bool> Strikethrough {get;}
property Nullable<bool> Strikethrough {
   Nullable<bool> get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

TextIndent Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : TextIndent Property
缩进。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property TextIndent As Integer
'Usage

Dim instance As IStyleInfo
Dim value As Integer

value = instance.TextIndent
int TextIndent {get;}
property int TextIndent {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

Underline Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : Underline Property
是否有下划线。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Underline As Nullable(Of Boolean)
'Usage

Dim instance As IStyleInfo
Dim value As Nullable(Of Boolean)

value = instance.Underline
Nullable<bool> Underline {get;}
property Nullable<bool> Underline {
   Nullable<bool> get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

VerticalAlignment Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : VerticalAlignment Property
垂直对齐方式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property VerticalAlignment As ForguncyCellVerticalAlignment
'Usage

Dim instance As IStyleInfo
Dim value As ForguncyCellVerticalAlignment

value = instance.VerticalAlignment
ForguncyCellVerticalAlignment VerticalAlignment {get;}
property ForguncyCellVerticalAlignment VerticalAlignment {
   ForguncyCellVerticalAlignment get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%ItemTitle%%

WordWrap Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleInfo Interface : WordWrap Property
是否可换行。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property WordWrap As Boolean
'Usage

Dim instance As IStyleInfo
Dim value As Boolean

value = instance.WordWrap
bool WordWrap {get;}
property bool WordWrap {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleInfo Interface
IStyleInfo Members


%%PageItemTitle%%

IStyleTemplateInfo Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateInfo Interface
单元格模板样式的样式信息。若想添加单元格模板样式的设计时预览，该单元格需要实现此接口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IStyleTemplateInfo
'Usage

Dim instance As IStyleTemplateInfo
public interface IStyleTemplateInfo
public interface class IStyleTemplateInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleTemplateInfo Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IStyleTemplateInfo Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateInfo Interface

The following tables list the members exposed by IStyleTemplateInfo.

Public Properties
 | Name | Description
Property | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。
Top
See Also

Reference

IStyleTemplateInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IStyleTemplateInfo Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateInfo Interface

For a list of all members of this type, see IStyleTemplateInfo members.

Public Properties
 | Name | Description
Property | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。
Top
See Also

Reference

IStyleTemplateInfo Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

StyleTemplateInfo Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleTemplateInfo Interface : StyleTemplateInfo Property
单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property StyleTemplateInfo As Dictionary(Of String,TemplatePartStyle)
'Usage

Dim instance As IStyleTemplateInfo
Dim value As Dictionary(Of String,TemplatePartStyle)

value = instance.StyleTemplateInfo
Dictionary<string,TemplatePartStyle> StyleTemplateInfo {get;}
property Dictionary<String^,TemplatePartStyle^>^ StyleTemplateInfo {
   Dictionary<String^,TemplatePartStyle^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleTemplateInfo Interface
IStyleTemplateInfo Members


%%PageItemTitle%%

IStyleTemplateSupport Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateSupport Interface
单元格支持模板样式。若想某单元格支持模板样式，需要实现此接口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IStyleTemplateSupport
'Usage

Dim instance As IStyleTemplateSupport
public interface IStyleTemplateSupport
public interface class IStyleTemplateSupport
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleTemplateSupport Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IStyleTemplateSupport Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateSupport Interface

The following tables list the members exposed by IStyleTemplateSupport.

Public Properties
 | Name | Description
Property | TemplateKey | 单元格模板样式的标识。它必须取自于某个CellTypeStyleTemplate的Key。表明该单元格应用了哪一个模板样式。
Top
See Also

Reference

IStyleTemplateSupport Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IStyleTemplateSupport Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateSupport Interface

For a list of all members of this type, see IStyleTemplateSupport members.

Public Properties
 | Name | Description
Property | TemplateKey | 单元格模板样式的标识。它必须取自于某个CellTypeStyleTemplate的Key。表明该单元格应用了哪一个模板样式。
Top
See Also

Reference

IStyleTemplateSupport Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

TemplateKey Property

GrapeCity.Forguncy.CellTypes Namespace > IStyleTemplateSupport Interface : TemplateKey Property
单元格模板样式的标识。它必须取自于某个CellTypeStyleTemplate的Key。表明该单元格应用了哪一个模板样式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property TemplateKey As String
'Usage

Dim instance As IStyleTemplateSupport
Dim value As String

instance.TemplateKey = value

value = instance.TemplateKey
string TemplateKey {get; set;}
property String^ TemplateKey {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleTemplateSupport Interface
IStyleTemplateSupport Members


%%PageItemTitle%%

ISupportStyleInitialize Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : ISupportStyleInitialize Interface
设置单元格类型的默认样式和属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISupportStyleInitialize
'Usage

Dim instance As ISupportStyleInitialize
public interface ISupportStyleInitialize
public interface class ISupportStyleInitialize
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportStyleInitialize Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ISupportStyleInitialize Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : ISupportStyleInitialize Interface

The following tables list the members exposed by ISupportStyleInitialize.

Public Methods
 | Name | Description
Method | GetDefaultStyleInfos | 设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
Top
See Also

Reference

ISupportStyleInitialize Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

ISupportStyleInitialize Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : ISupportStyleInitialize Interface

For a list of all members of this type, see ISupportStyleInitialize members.

Public Methods
 | Name | Description
Method | GetDefaultStyleInfos | 设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
Top
See Also

Reference

ISupportStyleInitialize Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetDefaultStyleInfos Method
Example

GrapeCity.Forguncy.CellTypes Namespace > ISupportStyleInitialize Interface : GetDefaultStyleInfos Method
单元格信息，如可以知道单元格所在页面类型或者是否在表格中等信息。
设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetDefaultStyleInfos( _
   ByVal cellInfo As ICellInfo _
) As Dictionary(Of StylePropertyName,Object)
'Usage

Dim instance As ISupportStyleInitialize
Dim cellInfo As ICellInfo
Dim value As Dictionary(Of StylePropertyName,Object)

value = instance.GetDefaultStyleInfos(cellInfo)
Dictionary<StylePropertyName,object> GetDefaultStyleInfos(
   ICellInfo cellInfo
)
Dictionary<StylePropertyName,Object^>^ GetDefaultStyleInfos(
   ICellInfo^ cellInfo
)

Parameters

cellInfo
单元格信息，如可以知道单元格所在页面类型或者是否在表格中等信息。

Return Value

默认样式列表。
Example
  • C#
public class HyperlinkCellType : CellType, ISupportStyleInitialize
{
    public Dictionary<StylePropertyName, object> GetDefaultStyleInfos(ICellInfo cellInfo)
    {
        var dic = new Dictionary<StylePropertyName, object>();

        dic.Add(StylePropertyName.Foreground, new SolidColorBrush(Colors.Blue));
        dic.Add(StylePropertyName.Underline, true);

        return dic;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportStyleInitialize Interface
ISupportStyleInitialize Members


%%PageItemTitle%%

ISupportUIPermission Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : ISupportUIPermission Interface
主要用于单元格类型的界面权限设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISupportUIPermission
'Usage

Dim instance As ISupportUIPermission
public interface ISupportUIPermission
public interface class ISupportUIPermission
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportUIPermission Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ISupportUIPermission Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : ISupportUIPermission Interface

The following tables list the members exposed by ISupportUIPermission.

Public Properties
 | Name | Description
Property | UIPermissions | 单元格类型的界面权限设置。
Top
See Also

Reference

ISupportUIPermission Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

ISupportUIPermission Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : ISupportUIPermission Interface

For a list of all members of this type, see ISupportUIPermission members.

Public Properties
 | Name | Description
Property | UIPermissions | 单元格类型的界面权限设置。
Top
See Also

Reference

ISupportUIPermission Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

UIPermissions Property

GrapeCity.Forguncy.CellTypes Namespace > ISupportUIPermission Interface : UIPermissions Property
单元格类型的界面权限设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property UIPermissions As List(Of UIPermission)
'Usage

Dim instance As ISupportUIPermission
Dim value As List(Of UIPermission)

instance.UIPermissions = value

value = instance.UIPermissions
List<UIPermission> UIPermissions {get; set;}
property List<UIPermission^>^ UIPermissions {
   List<UIPermission^>^ get();
   void set (    List<UIPermission^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportUIPermission Interface
ISupportUIPermission Members


%%PageItemTitle%%

IWindow Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IWindow Interface
内置对话框接口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IWindow
'Usage

Dim instance As IWindow
public interface IWindow
public interface class IWindow
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IWindow Interface Members
Properties Methods Events

GrapeCity.Forguncy.CellTypes Namespace : IWindow Interface

The following tables list the members exposed by IWindow.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。
Top
Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。
Top
Public Events
 | Name | Description
Event | Closed | 对话框关闭事件。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IWindow Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IWindow Interface

For a list of all members of this type, see IWindow members.

Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ShowDialog Method (IWindow)

GrapeCity.Forguncy.CellTypes Namespace > IWindow Interface : ShowDialog Method
打开对话框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function ShowDialog() As Nullable(Of Boolean)
'Usage

Dim instance As IWindow
Dim value As Nullable(Of Boolean)

value = instance.ShowDialog()
Nullable<bool> ShowDialog()
Nullable<bool> ShowDialog();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Interface
IWindow Members


%%PageItemTitle%% $$Properties$$

IWindow Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IWindow Interface

For a list of all members of this type, see IWindow members.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

DialogResult Property (IWindow)

GrapeCity.Forguncy.CellTypes Namespace > IWindow Interface : DialogResult Property
对话框返回结果。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property DialogResult As Nullable(Of Boolean)
'Usage

Dim instance As IWindow
Dim value As Nullable(Of Boolean)

value = instance.DialogResult
Nullable<bool> DialogResult {get;}
property Nullable<bool> DialogResult {
   Nullable<bool> get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Interface
IWindow Members


%%PageItemTitle%% $$Events$$

IWindow Interface Events

GrapeCity.Forguncy.CellTypes Namespace : IWindow Interface

For a list of all members of this type, see IWindow members.

Public Events
 | Name | Description
Event | Closed | 对话框关闭事件。
Top
See Also

Reference

IWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Closed Event (IWindow)

GrapeCity.Forguncy.CellTypes Namespace > IWindow Interface : Closed Event
对话框关闭事件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Event Closed As EventHandler
'Usage

Dim instance As IWindow
Dim handler As EventHandler

AddHandler instance.Closed, handler
event EventHandler Closed
event EventHandler^ Closed
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWindow Interface
IWindow Members


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes.Design Assembly
Namespaces
Namespace | Description
GrapeCity.Forguncy.CellTypes |


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes Namespace (GrapeCity.Forguncy.CellTypes.Design)
Inheritance Hierarchy
Classes
 | Class | Description
Class | CellTypeDesigner | CellType设计器。
Class | CellTypeDesigner<T> | CellType设计器。
Interfaces
 | Interface | Description
Interface | IBuilderContext | 插件所需的上下文信息。
Interface | ICellTypeChecker | 如果单元格类型需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
Interface | IDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知依赖了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Interface | IDrawingHelper | 主要用于单元格预览和导出单元格到Excel中的画法。
Interface | IQueryConditionWindow | 活字格内置的设置查询条件的对话窗口。 注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现GrapeCity.Forguncy.Plugin.IReferenceFormula和IDependenceCells这两个接口。
Interface | IStylePreviewControl | 用于预览单元格样式模板组件的控件。可实现对边框、圆角、阴影的预览。
Interface | IStyleTemplateCustomDrawingSupport | 支持改写CellType的设计时的预览。如果实现了这个接口，CellType会用这个方法在样式选择中显示，如果没有实现则会使用CellTypeDesigner上的GetDrawingControl方法来预览。
Interface | ISupportPropertyInitialize | 设置单元格类型的默认属性值。 例如，可以设置【超链接】单元格的点击模式默认为单元格而非文字区域。
See Also

Reference

GrapeCity.Forguncy.CellTypes.Design Assembly


%%PageItemTitle%%

CellTypeDesigner Class
Members

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner Class
CellType设计器。
Object Model
CellTypeDesigner ClassCellType Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CellTypeDesigner
'Usage

Dim instance As CellTypeDesigner
public class CellTypeDesigner
public ref class CellTypeDesigner
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.CellTypeDesigner
GrapeCity.Forguncy.CellTypes.CellTypeDesigner<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeDesigner Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

CellTypeDesigner Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner Class

The following tables list the members exposed by CellTypeDesigner.

Public Constructors
 | Name | Description
Public Constructor | CellTypeDesigner Constructor |
Top
Public Properties
 | Name | Description
Public Property | CellType | 设计器对应的CellType。
Top
Public Methods
 | Name | Description
Public Method | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
Public Method | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
Top
See Also

Reference

CellTypeDesigner Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

CellTypeDesigner Constructor

GrapeCity.Forguncy.CellTypes Namespace > CellTypeDesigner Class : CellTypeDesigner Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CellTypeDesigner()
public CellTypeDesigner()
public:
CellTypeDesigner();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeDesigner Class
CellTypeDesigner Members


%%PageItemTitle%% $$Methods$$

CellTypeDesigner Class Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner Class

For a list of all members of this type, see CellTypeDesigner members.

Public Methods
 | Name | Description
Public Method | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
Public Method | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
Top
See Also

Reference

CellTypeDesigner Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetDrawingControl Method
Example

GrapeCity.Forguncy.CellTypes Namespace > CellTypeDesigner Class : GetDrawingControl Method
单元格信息。
画法帮助工具。
如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetDrawingControl( _
   ByVal cellInfo As ICellInfo, _
   ByVal drawingHelper As IDrawingHelper _
) As FrameworkElement
'Usage

Dim instance As CellTypeDesigner
Dim cellInfo As ICellInfo
Dim drawingHelper As IDrawingHelper
Dim value As FrameworkElement

value = instance.GetDrawingControl(cellInfo, drawingHelper)
public virtual FrameworkElement GetDrawingControl(
   ICellInfo cellInfo,
   IDrawingHelper drawingHelper
)
public:
virtual FrameworkElement^ GetDrawingControl(
   ICellInfo^ cellInfo,
   IDrawingHelper^ drawingHelper
)

Parameters

cellInfo
单元格信息。
drawingHelper
画法帮助工具。

Return Value

返回WPF元素。
Example
  • C#
public class ButtonGroupCellType : CellType
{
    public string AddButtonText { get; set; }

    public string DeleteButtonText { get; set; }

    public override FrameworkElement GetDrawingControl(ICellInfo cellInfo, IDrawingHelper drawingHelper)
    {
        Button addButton = new Button() { Content = this.AddButtonText };
        Button deleteButton = new Button() { Content = this.DeleteButtonText, Margin = new Thickness(5, 0, 0, 0) };

        Grid container = new Grid();
        container.ColumnDefinitions.Add(new ColumnDefinition() { Width = new GridLength(1, GridUnitType.Star) });
        container.ColumnDefinitions.Add(new ColumnDefinition() { Width = new GridLength(1, GridUnitType.Star) });
        container.Children.Add(addButton);
        container.Children.Add(deleteButton);
        Grid.SetColumn(addButton, 0);
        Grid.SetColumn(deleteButton, 1);

        return container;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeDesigner Class
CellTypeDesigner Members


%%ItemTitle%%

GetEditorSetting Method (CellTypeDesigner)
Example

GrapeCity.Forguncy.CellTypes Namespace > CellTypeDesigner Class : GetEditorSetting Method
属性信息
上下文信息
获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function GetEditorSetting( _
   ByVal property As PropertyDescriptor, _
   ByVal builderContext As IBuilderContext _
) As EditorSetting
'Usage

Dim instance As CellTypeDesigner
Dim property As PropertyDescriptor
Dim builderContext As IBuilderContext
Dim value As EditorSetting

value = instance.GetEditorSetting(property, builderContext)
public virtual EditorSetting GetEditorSetting(
   PropertyDescriptor property,
   IBuilderContext builderContext
)
public:
virtual EditorSetting^ GetEditorSetting(
   PropertyDescriptor^ property,
   IBuilderContext^ builderContext
)

Parameters

property
属性信息
builderContext
上下文信息

Return Value

属性编辑器。
Example
  • C#
public class MyTextCellTypeDesigner : CellTypeDesigner<CurrentUserCellType>
{
    public string Text { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if(property.Name == "Text")
        {
            return new TextEditorSetting();
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeDesigner Class
CellTypeDesigner Members


%%PageItemTitle%% $$Properties$$

CellTypeDesigner Class Properties

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner Class

For a list of all members of this type, see CellTypeDesigner members.

Public Properties
 | Name | Description
Public Property | CellType | 设计器对应的CellType。
Top
See Also

Reference

CellTypeDesigner Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

CellType Property (CellTypeDesigner)

GrapeCity.Forguncy.CellTypes Namespace > CellTypeDesigner Class : CellType Property
设计器对应的CellType。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property CellType As CellType
'Usage

Dim instance As CellTypeDesigner
Dim value As CellType

instance.CellType = value

value = instance.CellType
public CellType CellType {get; set;}
public:
property CellType^ CellType {
   CellType^ get();
   void set (    CellType^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeDesigner Class
CellTypeDesigner Members


%%PageItemTitle%%

CellTypeDesigner<T> Class
Members

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner<T> Class
CellType设计器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CellTypeDesigner(Of T As CellType)
   Inherits CellTypeDesigner
'Usage

Dim instance As CellTypeDesigner(Of T)
public class CellTypeDesigner<T> : CellTypeDesigner
where T: CellType
generic<typename T>
public ref class CellTypeDesigner : public CellTypeDesigner
where T: CellType
Type Parameters
T
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.CellTypes.CellTypeDesigner
GrapeCity.Forguncy.CellTypes.CellTypeDesigner<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeDesigner<T> Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

CellTypeDesigner<T> Class Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner<T> Class

The following tables list the members exposed by CellTypeDesigner<T>.

Public Constructors
 | Name | Description
Public Constructor | CellTypeDesigner<T> Constructor |
Top
Public Properties
 | Name | Description
Public Property | CellType | 设计器对应的CellType。
Top
Public Methods
 | Name | Description
Public Method | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。 (Inherited from GrapeCity.Forguncy.CellTypes.CellTypeDesigner)
Public Method | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。 (Inherited from GrapeCity.Forguncy.CellTypes.CellTypeDesigner)
Top
See Also

Reference

CellTypeDesigner<T> Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

CellTypeDesigner<T> Constructor

GrapeCity.Forguncy.CellTypes Namespace > CellTypeDesigner<T> Class : CellTypeDesigner<T> Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CellTypeDesigner(Of T)()
public CellTypeDesigner<T>()
public:
CellTypeDesigner<T>();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CellTypeDesigner<T> Class
CellTypeDesigner<T> Members


%%PageItemTitle%% $$Properties$$

CellTypeDesigner<T> Class Properties

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner<T> Class

For a list of all members of this type, see CellTypeDesigner<T> members.

Public Properties
 | Name | Description
Public Property | CellType | 设计器对应的CellType。
Top
See Also

Reference

CellTypeDesigner<T> Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%%

IBuilderContext Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IBuilderContext Interface
插件所需的上下文信息。
Object Model
IBuilderContext InterfaceICellInfo InterfaceILocalServerInfo InterfaceIUserServiceInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IBuilderContext
   Inherits GrapeCity.Forguncy.Plugin.IBuilderContextBase
'Usage

Dim instance As IBuilderContext
public interface IBuilderContext : GrapeCity.Forguncy.Plugin.IBuilderContextBase
public interface class IBuilderContext : public GrapeCity.Forguncy.Plugin.IBuilderContextBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IBuilderContext Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : IBuilderContext Interface

The following tables list the members exposed by IBuilderContext.

Public Properties
 | Name | Description
Property | AuthenticationMode | 获取当前工程的认证模式。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | Cell | 单元格类型所在的单元格信息。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
Property | LocalServerInfo | 本地网站应用信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | PageName | 获取当前所在页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | PageType | 页面类型。
Property | UserServiceInfo | 获取用户管理网站的信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Top
Public Methods
 | Name | Description
Method | EnumAllAttachedInfos | 获取某个页面所有的单元格附加信息。
Method | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllPageInfos | 获取所有的页面信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllTableInfos | 获取所有的数据表信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Method | EnumDependenceCellsFromFormula | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | GetCommandWindow | 根据使用范围获取活字格内部编辑命令的对话窗口。
Method | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
Method | GetSelectImageWindow | Overloaded. 获取活字格内部选择图片的对话窗口。
Method | GetSortConditionWindow | 获取活字格内部排序的对话窗口。
Method | HideParentDialog | 如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
Method | ShowParentDialog | 重新显示被隐藏的父窗口，配合HideParentDialog使用。
Top
See Also

Reference

IBuilderContext Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IBuilderContext Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IBuilderContext Interface

For a list of all members of this type, see IBuilderContext members.

Public Methods
 | Name | Description
Method | EnumAllAttachedInfos | 获取某个页面所有的单元格附加信息。
Method | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllPageInfos | 获取所有的页面信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumAllTableInfos | 获取所有的数据表信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | EnumDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Method | EnumDependenceCellsFromFormula | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Method | GetCommandWindow | 根据使用范围获取活字格内部编辑命令的对话窗口。
Method | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
Method | GetSelectImageWindow | Overloaded. 获取活字格内部选择图片的对话窗口。
Method | GetSortConditionWindow | 获取活字格内部排序的对话窗口。
Method | HideParentDialog | 如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
Method | ShowParentDialog | 重新显示被隐藏的父窗口，配合HideParentDialog使用。
Top
See Also

Reference

IBuilderContext Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

EnumAllAttachedInfos Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : EnumAllAttachedInfos Method
页面名称。
获取某个页面所有的单元格附加信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumAllAttachedInfos( _
   ByVal pageName As String _
) As IEnumerable(Of IAttachedInfo)
'Usage

Dim instance As IBuilderContext
Dim pageName As String
Dim value As IEnumerable(Of IAttachedInfo)

value = instance.EnumAllAttachedInfos(pageName)
IEnumerable<IAttachedInfo> EnumAllAttachedInfos(
   string pageName
)
IEnumerable<IAttachedInfo^>^ EnumAllAttachedInfos(
   String^ pageName
)

Parameters

pageName
页面名称。

Return Value

返回页面所有单元格的附加信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

EnumDependenceCells Method (IBuilderContext)

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : EnumDependenceCells Method
查询条件
依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumDependenceCells( _
   ByVal queryCondition As Object _
) As IEnumerable(Of Object)
'Usage

Dim instance As IBuilderContext
Dim queryCondition As Object
Dim value As IEnumerable(Of Object)

value = instance.EnumDependenceCells(queryCondition)
IEnumerable<object> EnumDependenceCells(
   object queryCondition
)
IEnumerable<Object^>^ EnumDependenceCells(
   Object^ queryCondition
)

Parameters

queryCondition
查询条件

Return Value

插件中所有引用的单元格列表。
Example
代码参照IQueryConditionWindow
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

EnumDependenceCellsFromFormula Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : EnumDependenceCellsFromFormula Method
公式
依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumDependenceCellsFromFormula( _
   ByVal formula As Object _
) As IEnumerable(Of Object)
'Usage

Dim instance As IBuilderContext
Dim formula As Object
Dim value As IEnumerable(Of Object)

value = instance.EnumDependenceCellsFromFormula(formula)
IEnumerable<object> EnumDependenceCellsFromFormula(
   object formula
)
IEnumerable<Object^>^ EnumDependenceCellsFromFormula(
   Object^ formula
)

Parameters

formula
公式

Return Value

插件中所有引用的单元格列表。
Example
代码参照IDependenceCells
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

GetCommandWindow Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : GetCommandWindow Method
指定命令使用范围。
根据使用范围获取活字格内部编辑命令的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetCommandWindow( _
   ByVal commandScope As CommandScope _
) As ICommandWindow
'Usage

Dim instance As IBuilderContext
Dim commandScope As CommandScope
Dim value As ICommandWindow

value = instance.GetCommandWindow(commandScope)
ICommandWindow GetCommandWindow(
   CommandScope commandScope
)
ICommandWindow^ GetCommandWindow(
   CommandScope commandScope
)

Parameters

commandScope
指定命令使用范围。

Return Value

返回活字格内部编辑命令的对话窗口。
Example
代码参照ICommandWindow。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

GetQueryConditionWindow Method (IBuilderContext)

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : GetQueryConditionWindow Method
初始化内置查询条件对话窗口的对象。
数据表名。
获取活字格内部查询条件的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetQueryConditionWindow( _
   ByVal queryCondition As Object, _
   Optional ByVal tableName As String _
) As IQueryConditionWindow
'Usage

Dim instance As IBuilderContext
Dim queryCondition As Object
Dim tableName As String
Dim value As IQueryConditionWindow

value = instance.GetQueryConditionWindow(queryCondition, tableName)
IQueryConditionWindow GetQueryConditionWindow(
   object queryCondition,
   string tableName
)
IQueryConditionWindow^ GetQueryConditionWindow(
   Object^ queryCondition,
   String^ tableName
)

Parameters

queryCondition
初始化内置查询条件对话窗口的对象。
tableName
数据表名。

Return Value

返回活字格内部查询条件的对话窗口。
Example
代码参照IQueryConditionWindow。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

GetSelectImageWindow Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : GetSelectImageWindow Method
获取活字格内部选择图片的对话窗口。
Overload List
Overload | Description
GetSelectImageWindow(String,Boolean) | 获取活字格内部选择图片的对话窗口。
GetSelectImageWindow(String,Boolean,String) | 获取活字格内部选择图片的对话窗口。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

GetSelectImageWindow(String,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface > GetSelectImageWindow Method : GetSelectImageWindow(String,Boolean) Method
初始化选择图片对话窗口的图片名。
初始化选择图片对话窗口的图片是否是内置图片。
获取活字格内部选择图片的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetSelectImageWindow( _
   ByVal imagePath As String, _
   ByVal builtIn As Boolean _
) As ISelectImageWindow
'Usage

Dim instance As IBuilderContext
Dim imagePath As String
Dim builtIn As Boolean
Dim value As ISelectImageWindow

value = instance.GetSelectImageWindow(imagePath, builtIn)
ISelectImageWindow GetSelectImageWindow(
   string imagePath,
   bool builtIn
)
ISelectImageWindow^ GetSelectImageWindow(
   String^ imagePath,
   bool builtIn
)

Parameters

imagePath
初始化选择图片对话窗口的图片名。
builtIn
初始化选择图片对话窗口的图片是否是内置图片。

Return Value

返回活字格内部选择图片的对话窗口。
Example
代码参照ISelectImageWindow。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members
Overload List


%%ItemTitle%%

GetSelectImageWindow(String,Boolean,String) Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface > GetSelectImageWindow Method : GetSelectImageWindow(String,Boolean,String) Method
初始化选择图片对话窗口的图片名。
初始化选择图片对话窗口的图片是否是内置图片。
初始化选择图片对话窗口的图片颜色。
获取活字格内部选择图片的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetSelectImageWindow( _
   ByVal imagePath As String, _
   ByVal builtIn As Boolean, _
   ByVal fill As String _
) As ISelectImageWindow
'Usage

Dim instance As IBuilderContext
Dim imagePath As String
Dim builtIn As Boolean
Dim fill As String
Dim value As ISelectImageWindow

value = instance.GetSelectImageWindow(imagePath, builtIn, fill)
ISelectImageWindow GetSelectImageWindow(
   string imagePath,
   bool builtIn,
   string fill
)
ISelectImageWindow^ GetSelectImageWindow(
   String^ imagePath,
   bool builtIn,
   String^ fill
)

Parameters

imagePath
初始化选择图片对话窗口的图片名。
builtIn
初始化选择图片对话窗口的图片是否是内置图片。
fill
初始化选择图片对话窗口的图片颜色。

Return Value

返回活字格内部选择图片的对话窗口。
Example
代码参照ISelectImageWindow。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members
Overload List


%%ItemTitle%%

GetSortConditionWindow Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : GetSortConditionWindow Method
初始化内置排序对话窗口的对象。
数据表名。
获取活字格内部排序的对话窗口。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetSortConditionWindow( _
   ByVal sortCondition As Object, _
   Optional ByVal tableName As String _
) As ISortConditionWindow
'Usage

Dim instance As IBuilderContext
Dim sortCondition As Object
Dim tableName As String
Dim value As ISortConditionWindow

value = instance.GetSortConditionWindow(sortCondition, tableName)
ISortConditionWindow GetSortConditionWindow(
   object sortCondition,
   string tableName
)
ISortConditionWindow^ GetSortConditionWindow(
   Object^ sortCondition,
   String^ tableName
)

Parameters

sortCondition
初始化内置排序对话窗口的对象。
tableName
数据表名。

Return Value

返回活字格内部排序的对话窗口。
Example
代码参照ISortConditionWindow。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

HideParentDialog Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : HideParentDialog Method
父窗口。
如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub HideParentDialog( _
   ByVal userControl As UserControl _
)
'Usage

Dim instance As IBuilderContext
Dim userControl As UserControl

instance.HideParentDialog(userControl)
void HideParentDialog(
   UserControl userControl
)
void HideParentDialog(
   UserControl^ userControl
)

Parameters

userControl
父窗口。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

ShowParentDialog Method

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : ShowParentDialog Method
父窗口。
重新显示被隐藏的父窗口，配合HideParentDialog使用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub ShowParentDialog( _
   ByVal userControl As UserControl _
)
'Usage

Dim instance As IBuilderContext
Dim userControl As UserControl

instance.ShowParentDialog(userControl)
void ShowParentDialog(
   UserControl userControl
)
void ShowParentDialog(
   UserControl^ userControl
)

Parameters

userControl
父窗口。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%PageItemTitle%% $$Properties$$

IBuilderContext Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IBuilderContext Interface

For a list of all members of this type, see IBuilderContext members.

Public Properties
 | Name | Description
Property | AuthenticationMode | 获取当前工程的认证模式。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | Cell | 单元格类型所在的单元格信息。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
Property | LocalServerInfo | 本地网站应用信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | PageName | 获取当前所在页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Property | PageType | 页面类型。
Property | UserServiceInfo | 获取用户管理网站的信息。 (Inherited from GrapeCity.Forguncy.Plugin.IBuilderContextBase)
Top
See Also

Reference

IBuilderContext Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Cell Property

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : Cell Property
单元格类型所在的单元格信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Cell As ICellInfo
'Usage

Dim instance As IBuilderContext
Dim value As ICellInfo

value = instance.Cell
ICellInfo Cell {get;}
property ICellInfo^ Cell {
   ICellInfo^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

ForguncyUploadFilesFolderPath Property (IBuilderContext)

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : ForguncyUploadFilesFolderPath Property
用户在设计器中上传的文件或图片所在的文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyUploadFilesFolderPath As String
'Usage

Dim instance As IBuilderContext
Dim value As String

value = instance.ForguncyUploadFilesFolderPath
string ForguncyUploadFilesFolderPath {get;}
property String^ ForguncyUploadFilesFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%ItemTitle%%

PageType Property (IBuilderContext)

GrapeCity.Forguncy.CellTypes Namespace > IBuilderContext Interface : PageType Property
页面类型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PageType As ForguncyPageKind
'Usage

Dim instance As IBuilderContext
Dim value As ForguncyPageKind

value = instance.PageType
ForguncyPageKind PageType {get;}
property ForguncyPageKind PageType {
   ForguncyPageKind get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContext Interface
IBuilderContext Members


%%PageItemTitle%%

ICellTypeChecker Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : ICellTypeChecker Interface
如果单元格类型需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICellTypeChecker
'Usage

Dim instance As ICellTypeChecker
public interface ICellTypeChecker
public interface class ICellTypeChecker
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellTypeChecker Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ICellTypeChecker Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : ICellTypeChecker Interface

The following tables list the members exposed by ICellTypeChecker.

Public Methods
 | Name | Description
Method | CheckCellTypeErrors | 运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
Top
See Also

Reference

ICellTypeChecker Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

ICellTypeChecker Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : ICellTypeChecker Interface

For a list of all members of this type, see ICellTypeChecker members.

Public Methods
 | Name | Description
Method | CheckCellTypeErrors | 运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
Top
See Also

Reference

ICellTypeChecker Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

CheckCellTypeErrors Method
Example

GrapeCity.Forguncy.CellTypes Namespace > ICellTypeChecker Interface : CheckCellTypeErrors Method
与单元格类型相关的上下文信息
运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function CheckCellTypeErrors( _
   ByVal context As IBuilderContext _
) As IEnumerable(Of ForguncyErrorInfo)
'Usage

Dim instance As ICellTypeChecker
Dim context As IBuilderContext
Dim value As IEnumerable(Of ForguncyErrorInfo)

value = instance.CheckCellTypeErrors(context)
IEnumerable<ForguncyErrorInfo> CheckCellTypeErrors(
   IBuilderContext context
)
IEnumerable<ForguncyErrorInfo^>^ CheckCellTypeErrors(
   IBuilderContext^ context
)

Parameters

context
与单元格类型相关的上下文信息

Return Value

返回与单元格类型相关的所有错误和提醒列表。
Example
  • C#
public class PageNavigateCellType : CellType, ICellTypeChecker
{
    public string PagingListviewName { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCellTypeErrors(IBuilderContext context)
    {
        List<ForguncyErrorInfo> result = new List<ForguncyErrorInfo>();
        if(string.IsNullOrEmpty(PagingListviewName))
        {
            result.Add(new ForguncyErrorInfo()
            {
                ErrorType = ForguncyErrorType.Error,
                Message = "The paging listview name cannot be null."
            });
        }

        return result;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellTypeChecker Interface
ICellTypeChecker Members


%%PageItemTitle%%

IDependenceCells Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : IDependenceCells Interface
依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知依赖了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IDependenceCells
'Usage

Dim instance As IDependenceCells
public interface IDependenceCells
public interface class IDependenceCells
Example
  • C#
public class ForguncyMenuCellType : CellType, IDependenceCells
{
    public List<ItemInfo> Items { get; set; }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return this.EnumDependenceCells(this.Items, context);
    }

    private IEnumerable<object> EnumDependenceCells(List<ItemInfo> items, IBuilderContext context)
    {
        foreach (var item in items)
        {
            if(item.Notification != null)
            {
                var cells = context.EnumDependenceCellsFromFormula(item.Notification);
                foreach(var cell in cells)
                {
                    yield return cell;
                }
            }
            if(item.SubItems != null)
            {
                foreach(var cell in EnumDependenceCells(item.SubItems, context))
                {
                    yield return cell;
                }
            }
        }
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public object Notification { get; set; }

    public List<ItemInfo> SubItems { get; set; }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDependenceCells Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IDependenceCells Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : IDependenceCells Interface

The following tables list the members exposed by IDependenceCells.

Public Methods
 | Name | Description
Method | EnumDependenceCells | 返回插件中所引用的单元格列表。
Top
See Also

Reference

IDependenceCells Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IDependenceCells Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IDependenceCells Interface

For a list of all members of this type, see IDependenceCells members.

Public Methods
 | Name | Description
Method | EnumDependenceCells | 返回插件中所引用的单元格列表。
Top
See Also

Reference

IDependenceCells Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

EnumDependenceCells Method (IDependenceCells)

GrapeCity.Forguncy.CellTypes Namespace > IDependenceCells Interface : EnumDependenceCells Method
上下文信息。
返回插件中所引用的单元格列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumDependenceCells( _
   ByVal context As IBuilderContext _
) As IEnumerable(Of Object)
'Usage

Dim instance As IDependenceCells
Dim context As IBuilderContext
Dim value As IEnumerable(Of Object)

value = instance.EnumDependenceCells(context)
IEnumerable<object> EnumDependenceCells(
   IBuilderContext context
)
IEnumerable<Object^>^ EnumDependenceCells(
   IBuilderContext^ context
)

Parameters

context
上下文信息。

Return Value

返回插件中引用的单元格列表。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDependenceCells Interface
IDependenceCells Members


%%PageItemTitle%%

IDrawingHelper Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IDrawingHelper Interface
主要用于单元格预览和导出单元格到Excel中的画法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IDrawingHelper
'Usage

Dim instance As IDrawingHelper
public interface IDrawingHelper
public interface class IDrawingHelper
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IDrawingHelper Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : IDrawingHelper Interface

The following tables list the members exposed by IDrawingHelper.

Public Properties
 | Name | Description
Property | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
Property | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
Property | ZoomFactor | 设计器中的缩放比例。
Top
Public Methods
 | Name | Description
Method | CreateStylePreviewControl | 创建模板样式的预览。
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
Method | GetFontFamily | 从字体字符串获取一个WPF的字体（FontFamily）。
Method | GetForguncyImageControl | 获取图片预览的控件。
Method | GetForguncyImageFullFileName | 获取图片文件的完整路径，该路径被用于GetForguncyImageControl方法。
Method | GetHelpTextForPage | 获取单元格的显示文本，如绑定信息，公式或值等。
Method | GetImageCellSize | 如果生成图片的话可获取单元格所占区域的大小。
Method | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
Method | GetTableDataForPreview | Overloaded. 如果预览单元格想要从数据表中获取数据，可调用该函数。
Method | SetFontInfoToControl | 设置基本的字体颜色，背景色，字体，字号等。
Method | SetFontInfoToFrameworkElement | 设置基本的字体颜色，背景色，字体，字号等。
Method | SetIndentToControl | 设置缩进。
Top
See Also

Reference

IDrawingHelper Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IDrawingHelper Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IDrawingHelper Interface

For a list of all members of this type, see IDrawingHelper members.

Public Methods
 | Name | Description
Method | CreateStylePreviewControl | 创建模板样式的预览。
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
Method | GetFontFamily | 从字体字符串获取一个WPF的字体（FontFamily）。
Method | GetForguncyImageControl | 获取图片预览的控件。
Method | GetForguncyImageFullFileName | 获取图片文件的完整路径，该路径被用于GetForguncyImageControl方法。
Method | GetHelpTextForPage | 获取单元格的显示文本，如绑定信息，公式或值等。
Method | GetImageCellSize | 如果生成图片的话可获取单元格所占区域的大小。
Method | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
Method | GetTableDataForPreview | Overloaded. 如果预览单元格想要从数据表中获取数据，可调用该函数。
Method | SetFontInfoToControl | 设置基本的字体颜色，背景色，字体，字号等。
Method | SetFontInfoToFrameworkElement | 设置基本的字体颜色，背景色，字体，字号等。
Method | SetIndentToControl | 设置缩进。
Top
See Also

Reference

IDrawingHelper Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

CreateStylePreviewControl Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : CreateStylePreviewControl Method
模板组件在某一状态下的样式单元。用于预览设计器中预览。
创建模板样式的预览。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function CreateStylePreviewControl( _
   ByVal style As PartStyleUnit _
) As IStylePreviewControl
'Usage

Dim instance As IDrawingHelper
Dim style As PartStyleUnit
Dim value As IStylePreviewControl

value = instance.CreateStylePreviewControl(style)
IStylePreviewControl CreateStylePreviewControl(
   PartStyleUnit style
)
IStylePreviewControl^ CreateStylePreviewControl(
   PartStyleUnit^ style
)

Parameters

style
模板组件在某一状态下的样式单元。用于预览设计器中预览。

Return Value

用于预览模板样式的组件。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetBrush Method (IDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetBrush Method
颜色字符串
从颜色字符串获取一个WPF的画笔（Brush）。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetBrush( _
   ByVal colorStr As String _
) As Brush
'Usage

Dim instance As IDrawingHelper
Dim colorStr As String
Dim value As Brush

value = instance.GetBrush(colorStr)
Brush GetBrush(
   string colorStr
)
Brush^ GetBrush(
   String^ colorStr
)

Parameters

colorStr
颜色字符串

Return Value

WPF的画笔
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetFontFamily Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetFontFamily Method
字体字符串
从字体字符串获取一个WPF的字体（FontFamily）。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetFontFamily( _
   ByVal fontFamilyStr As String _
) As FontFamily
'Usage

Dim instance As IDrawingHelper
Dim fontFamilyStr As String
Dim value As FontFamily

value = instance.GetFontFamily(fontFamilyStr)
FontFamily GetFontFamily(
   string fontFamilyStr
)
FontFamily^ GetFontFamily(
   String^ fontFamilyStr
)

Parameters

fontFamilyStr
字体字符串

Return Value

WPF的字体（FontFamily）
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetForguncyImageControl Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetForguncyImageControl Method
从GetForguncyImageFullFileName方法返回得到的路径
填充色。
获取图片预览的控件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetForguncyImageControl( _
   ByVal path As String, _
   ByVal fill As String _
) As Control
'Usage

Dim instance As IDrawingHelper
Dim path As String
Dim fill As String
Dim value As Control

value = instance.GetForguncyImageControl(path, fill)
Control GetForguncyImageControl(
   string path,
   string fill
)
Control^ GetForguncyImageControl(
   String^ path,
   String^ fill
)

Parameters

path
从GetForguncyImageFullFileName方法返回得到的路径
fill
填充色。

Return Value

预览图片的控件。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetForguncyImageFullFileName Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetForguncyImageFullFileName Method
图片文件的路径。
是否为内建图片。
获取图片文件的完整路径，该路径被用于GetForguncyImageControl方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetForguncyImageFullFileName( _
   ByVal path As String, _
   ByVal builtIn As Boolean _
) As String
'Usage

Dim instance As IDrawingHelper
Dim path As String
Dim builtIn As Boolean
Dim value As String

value = instance.GetForguncyImageFullFileName(path, builtIn)
string GetForguncyImageFullFileName(
   string path,
   bool builtIn
)
String^ GetForguncyImageFullFileName(
   String^ path,
   bool builtIn
)

Parameters

path
图片文件的路径。
builtIn
是否为内建图片。

Return Value

图片文件的完整路径。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetHelpTextForPage Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetHelpTextForPage Method
获取单元格的显示文本，如绑定信息，公式或值等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetHelpTextForPage() As String
'Usage

Dim instance As IDrawingHelper
Dim value As String

value = instance.GetHelpTextForPage()
string GetHelpTextForPage()
String^ GetHelpTextForPage();

Return Value

返回单元格的显示文本。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetImageCellSize Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetImageCellSize Method
如果生成图片的话可获取单元格所占区域的大小。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetImageCellSize() As Size
'Usage

Dim instance As IDrawingHelper
Dim value As Size

value = instance.GetImageCellSize()
Size GetImageCellSize()
Size GetImageCellSize();

Return Value

返回图片所占的单元格区域的大小。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetRealHorizontalAlignment Method (IDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetRealHorizontalAlignment Method
单元格的信息。
单元格类型的信息。
获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetRealHorizontalAlignment( _
   ByVal cellInfo As ICellInfo, _
   ByVal cellType As CellType _
) As ForguncyCellHorizontalAlignment
'Usage

Dim instance As IDrawingHelper
Dim cellInfo As ICellInfo
Dim cellType As CellType
Dim value As ForguncyCellHorizontalAlignment

value = instance.GetRealHorizontalAlignment(cellInfo, cellType)
ForguncyCellHorizontalAlignment GetRealHorizontalAlignment(
   ICellInfo cellInfo,
   CellType cellType
)
ForguncyCellHorizontalAlignment GetRealHorizontalAlignment(
   ICellInfo^ cellInfo,
   CellType^ cellType
)

Parameters

cellInfo
单元格的信息。
cellType
单元格类型的信息。

Return Value

返回水平对齐方式。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetTableDataForPreview Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : GetTableDataForPreview Method
如果预览单元格想要从数据表中获取数据，可调用该函数。
Overload List
Overload | Description
GetTableDataForPreview(String,List<String>,Dictionary<String,Object>,Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
GetTableDataForPreview(String,List<String>,Object,Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
GetTableDataForPreview(List<Object>,Object,Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

GetTableDataForPreview(String,List<String>,Dictionary<String,Object>,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface > GetTableDataForPreview Method : GetTableDataForPreview(String,List<String>,Dictionary<String,Object>,Boolean) Method
数据表名。
获取的字段列表。
当前表的查询条件，多用于主键键值对。
去重。
如果预览单元格想要从数据表中获取数据，可调用该函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableDataForPreview( _
   ByVal tableName As String, _
   ByVal columns As List(Of String), _
   Optional ByVal queryInfo As Dictionary(Of String,Object), _
   Optional ByVal distinct As Boolean _
) As List(Of Dictionary(Of String,Object))
'Usage

Dim instance As IDrawingHelper
Dim tableName As String
Dim columns As List(Of String)
Dim queryInfo As Dictionary(Of String,Object)
Dim distinct As Boolean
Dim value As List(Of Dictionary(Of String,Object))

value = instance.GetTableDataForPreview(tableName, columns, queryInfo, distinct)
List<Dictionary<string,object>> GetTableDataForPreview(
   string tableName,
   List<string> columns,
   Dictionary<string,object> queryInfo,
   bool distinct
)
List<Dictionary<String^,Object^>^>^ GetTableDataForPreview(
   String^ tableName,
   List<String^>^ columns,
   Dictionary<String^,Object^>^ queryInfo,
   bool distinct
)

Parameters

tableName
数据表名。
columns
获取的字段列表。
queryInfo
当前表的查询条件，多用于主键键值对。
distinct
去重。

Return Value

返回查询后的数据表的数据。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members
Overload List


%%ItemTitle%%

GetTableDataForPreview(String,List<String>,Object,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface > GetTableDataForPreview Method : GetTableDataForPreview(String,List<String>,Object,Boolean) Method
数据表名。
获取的字段列表。
查询条件，由内置查询条件对话框生成的对象。
去重。
如果预览单元格想要从数据表中获取数据，可调用该函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableDataForPreview( _
   ByVal tableName As String, _
   ByVal columns As List(Of String), _
   Optional ByVal queryCondition As Object, _
   Optional ByVal distinct As Boolean _
) As List(Of Dictionary(Of String,Object))
'Usage

Dim instance As IDrawingHelper
Dim tableName As String
Dim columns As List(Of String)
Dim queryCondition As Object
Dim distinct As Boolean
Dim value As List(Of Dictionary(Of String,Object))

value = instance.GetTableDataForPreview(tableName, columns, queryCondition, distinct)
List<Dictionary<string,object>> GetTableDataForPreview(
   string tableName,
   List<string> columns,
   object queryCondition,
   bool distinct
)
List<Dictionary<String^,Object^>^>^ GetTableDataForPreview(
   String^ tableName,
   List<String^>^ columns,
   Object^ queryCondition,
   bool distinct
)

Parameters

tableName
数据表名。
columns
获取的字段列表。
queryCondition
查询条件，由内置查询条件对话框生成的对象。
distinct
去重。

Return Value

返回查询后的数据表的数据。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members
Overload List


%%ItemTitle%%

GetTableDataForPreview(List<Object>,Object,Boolean) Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface > GetTableDataForPreview Method : GetTableDataForPreview(List<Object>,Object,Boolean) Method
绑定的数据字段列表。
查询条件，由内置查询条件对话框生成的对象。
去重。
如果预览单元格想要从数据表中获取数据，可调用该函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableDataForPreview( _
   ByVal columnInfos As List(Of Object), _
   ByVal queryCondition As Object, _
   Optional ByVal distinct As Boolean _
) As List(Of Dictionary(Of Object,Object))
'Usage

Dim instance As IDrawingHelper
Dim columnInfos As List(Of Object)
Dim queryCondition As Object
Dim distinct As Boolean
Dim value As List(Of Dictionary(Of Object,Object))

value = instance.GetTableDataForPreview(columnInfos, queryCondition, distinct)
List<Dictionary<object,object>> GetTableDataForPreview(
   List<object> columnInfos,
   object queryCondition,
   bool distinct
)
List<Dictionary<Object^,Object^>^>^ GetTableDataForPreview(
   List<Object^>^ columnInfos,
   Object^ queryCondition,
   bool distinct
)

Parameters

columnInfos
绑定的数据字段列表。
queryCondition
查询条件，由内置查询条件对话框生成的对象。
distinct
去重。

Return Value

返回查询后的数据表的数据。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members
Overload List


%%ItemTitle%%

SetFontInfoToControl Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : SetFontInfoToControl Method
要设置样式的文本元素。
要设置的样式选项。
设置基本的字体颜色，背景色，字体，字号等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub SetFontInfoToControl( _
   ByVal textBlock As TextBlock, _
   ByVal copyFontInfoToControlOption As CopyFontInfoToControlOption _
)
'Usage

Dim instance As IDrawingHelper
Dim textBlock As TextBlock
Dim copyFontInfoToControlOption As CopyFontInfoToControlOption

instance.SetFontInfoToControl(textBlock, copyFontInfoToControlOption)
void SetFontInfoToControl(
   TextBlock textBlock,
   CopyFontInfoToControlOption copyFontInfoToControlOption
)
void SetFontInfoToControl(
   TextBlock^ textBlock,
   CopyFontInfoToControlOption copyFontInfoToControlOption
)

Parameters

textBlock
要设置样式的文本元素。
copyFontInfoToControlOption
要设置的样式选项。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

SetFontInfoToFrameworkElement Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : SetFontInfoToFrameworkElement Method
要设置样式的WPF元素。
设置基本的字体颜色，背景色，字体，字号等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub SetFontInfoToFrameworkElement( _
   ByVal control As FrameworkElement _
)
'Usage

Dim instance As IDrawingHelper
Dim control As FrameworkElement

instance.SetFontInfoToFrameworkElement(control)
void SetFontInfoToFrameworkElement(
   FrameworkElement control
)
void SetFontInfoToFrameworkElement(
   FrameworkElement^ control
)

Parameters

control
要设置样式的WPF元素。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

SetIndentToControl Method

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : SetIndentToControl Method
要设置缩进的WPF元素。
设置缩进。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub SetIndentToControl( _
   ByVal control As FrameworkElement _
)
'Usage

Dim instance As IDrawingHelper
Dim control As FrameworkElement

instance.SetIndentToControl(control)
void SetIndentToControl(
   FrameworkElement control
)
void SetIndentToControl(
   FrameworkElement^ control
)

Parameters

control
要设置缩进的WPF元素。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%PageItemTitle%% $$Properties$$

IDrawingHelper Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IDrawingHelper Interface

For a list of all members of this type, see IDrawingHelper members.

Public Properties
 | Name | Description
Property | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
Property | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
Property | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
Property | ZoomFactor | 设计器中的缩放比例。
Top
See Also

Reference

IDrawingHelper Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

ForguncyBuiltInImagesFolderPath Property (IDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : ForguncyBuiltInImagesFolderPath Property
内建图片所在的文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyBuiltInImagesFolderPath As String
'Usage

Dim instance As IDrawingHelper
Dim value As String

value = instance.ForguncyBuiltInImagesFolderPath
string ForguncyBuiltInImagesFolderPath {get;}
property String^ ForguncyBuiltInImagesFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

ForguncyImageEditorFolderPath Property (IDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : ForguncyImageEditorFolderPath Property
图片选择对话框中上传的图片所在文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyImageEditorFolderPath As String
'Usage

Dim instance As IDrawingHelper
Dim value As String

value = instance.ForguncyImageEditorFolderPath
string ForguncyImageEditorFolderPath {get;}
property String^ ForguncyImageEditorFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

ForguncyUploadFilesFolderPath Property (IDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : ForguncyUploadFilesFolderPath Property
用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ForguncyUploadFilesFolderPath As String
'Usage

Dim instance As IDrawingHelper
Dim value As String

value = instance.ForguncyUploadFilesFolderPath
string ForguncyUploadFilesFolderPath {get;}
property String^ ForguncyUploadFilesFolderPath {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%ItemTitle%%

ZoomFactor Property (IDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IDrawingHelper Interface : ZoomFactor Property
设计器中的缩放比例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ZoomFactor As Single
'Usage

Dim instance As IDrawingHelper
Dim value As Single

value = instance.ZoomFactor
float ZoomFactor {get;}
property float ZoomFactor {
   float get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDrawingHelper Interface
IDrawingHelper Members


%%PageItemTitle%%

IQueryConditionWindow Interface
Members Example

GrapeCity.Forguncy.CellTypes Namespace : IQueryConditionWindow Interface

活字格内置的设置查询条件的对话窗口。

注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现GrapeCity.Forguncy.Plugin.IReferenceFormula和IDependenceCells这两个接口。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IQueryConditionWindow
   Inherits IWindow
'Usage

Dim instance As IQueryConditionWindow
public interface IQueryConditionWindow : IWindow
public interface class IQueryConditionWindow : public IWindow
Example
  • C#
[Designer("Forguncy.TreeCellTypeDesigner, Forguncy")]
public class TreeCellType : CellType, IDependenceCells, IReferenceFormula
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        if (this.BindingTreeLevelInfo != null)
        {
            return this.BindingTreeLevelInfo.GetFormulaReferObjects(location);
        }
        return Enumerable.Empty<LocatedObject<object>>();
    }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return EnumDependenceCells(this.BindingTreeLevelInfo, context);
    }

    private IEnumerable<object> EnumDependenceCells(BindingTreeLevelInfo info, IBuilderContext context)
    {
        var result = Enumerable.Empty<object>();
        if (info != null)
        {
            if (info.QueryCondition != null)
            {
                result = result.Union(context.EnumDependenceCells(info.QueryCondition) ?? Enumerable.Empty<object>());
            }
            if (info.SubBindingTreeLevelInfo != null)
            {
                result = result.Union(EnumDependenceCells(info.SubBindingTreeLevelInfo, context) ?? Enumerable.Empty<object>());
            }
        }
        return result;
    }
}

public class TreeCellTypeDesigner : CellTypeDesigner<CurrentUserCellType>
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }

}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出查询对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditQueryConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的查询条件和表名初始化查询对话窗口。*/
        var window = _builderContext?.GetQueryConditionWindow(queryCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的查询条件提交到数据层。*/
                /*ViewModel.QueryCondition = window.QueryCondition;*/

                /*重新打开父窗口。*/
                _builderContext.ShowParentDialog(this);
            }
        }
        /*由于查询条件中可能引用单元格，所以这里需要暂时隐藏父窗口。*/
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object QueryCondition { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("TreeCellType").AppendProperty("BindingTreeLevelInfo");
        if(this.QueryCondition is IReferenceFormula)
        {
            var items = (this.QueryCondition as IReferenceFormula).GetFormulaReferObjects(newLocation);
            foreach (var item in items)
            {
                yield return item;
            }
        }
        if (this.SubBindingTreeLevelInfo != null)
        {
            var items = this.SubBindingTreeLevelInfo.GetFormulaReferObjects(location);
            foreach (var item in items)
            {
                yield return item;
            }
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IQueryConditionWindow Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IQueryConditionWindow Interface Members
Properties Methods

GrapeCity.Forguncy.CellTypes Namespace : IQueryConditionWindow Interface

The following tables list the members exposed by IQueryConditionWindow.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Property | QueryCondition | 查询条件。
Top
Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

IQueryConditionWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IQueryConditionWindow Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IQueryConditionWindow Interface

For a list of all members of this type, see IQueryConditionWindow members.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Property | QueryCondition | 查询条件。
Top
See Also

Reference

IQueryConditionWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

QueryCondition Property (IQueryConditionWindow)

GrapeCity.Forguncy.CellTypes Namespace > IQueryConditionWindow Interface : QueryCondition Property
查询条件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property QueryCondition As Object
'Usage

Dim instance As IQueryConditionWindow
Dim value As Object

value = instance.QueryCondition
object QueryCondition {get;}
property Object^ QueryCondition {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IQueryConditionWindow Interface
IQueryConditionWindow Members


%%PageItemTitle%%

IStylePreviewControl Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IStylePreviewControl Interface
用于预览单元格样式模板组件的控件。可实现对边框、圆角、阴影的预览。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IStylePreviewControl
'Usage

Dim instance As IStylePreviewControl
public interface IStylePreviewControl
public interface class IStylePreviewControl
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStylePreviewControl Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IStylePreviewControl Interface Members
Properties

GrapeCity.Forguncy.CellTypes Namespace : IStylePreviewControl Interface

The following tables list the members exposed by IStylePreviewControl.

Public Properties
 | Name | Description
Property | Child | 预览时包含的内部控件。
Top
See Also

Reference

IStylePreviewControl Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

IStylePreviewControl Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : IStylePreviewControl Interface

For a list of all members of this type, see IStylePreviewControl members.

Public Properties
 | Name | Description
Property | Child | 预览时包含的内部控件。
Top
See Also

Reference

IStylePreviewControl Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

Child Property

GrapeCity.Forguncy.CellTypes Namespace > IStylePreviewControl Interface : Child Property
预览时包含的内部控件。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property Child As UIElement
'Usage

Dim instance As IStylePreviewControl
Dim value As UIElement

instance.Child = value

value = instance.Child
UIElement Child {get; set;}
property UIElement^ Child {
   UIElement^ get();
   void set (    UIElement^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStylePreviewControl Interface
IStylePreviewControl Members


%%PageItemTitle%%

IStyleTemplateCustomDrawingSupport Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateCustomDrawingSupport Interface
支持改写CellType的设计时的预览。如果实现了这个接口，CellType会用这个方法在样式选择中显示，如果没有实现则会使用CellTypeDesigner上的GetDrawingControl方法来预览。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IStyleTemplateCustomDrawingSupport
'Usage

Dim instance As IStyleTemplateCustomDrawingSupport
public interface IStyleTemplateCustomDrawingSupport
public interface class IStyleTemplateCustomDrawingSupport
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleTemplateCustomDrawingSupport Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

IStyleTemplateCustomDrawingSupport Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateCustomDrawingSupport Interface

The following tables list the members exposed by IStyleTemplateCustomDrawingSupport.

Public Methods
 | Name | Description
Method | GetPreviewSize | 获取设计时预览的大小。 Get preview size in designer.
Method | GetStyleTemplateCustomDrawingControl | 支持改写单元格模板样式的预览。如果修改单元格模板样式的预览效果，需重写该方法。
Top
See Also

Reference

IStyleTemplateCustomDrawingSupport Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IStyleTemplateCustomDrawingSupport Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IStyleTemplateCustomDrawingSupport Interface

For a list of all members of this type, see IStyleTemplateCustomDrawingSupport members.

Public Methods
 | Name | Description
Method | GetPreviewSize | 获取设计时预览的大小。 Get preview size in designer.
Method | GetStyleTemplateCustomDrawingControl | 支持改写单元格模板样式的预览。如果修改单元格模板样式的预览效果，需重写该方法。
Top
See Also

Reference

IStyleTemplateCustomDrawingSupport Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetPreviewSize Method

GrapeCity.Forguncy.CellTypes Namespace > IStyleTemplateCustomDrawingSupport Interface : GetPreviewSize Method
获取设计时预览的大小。 Get preview size in designer.
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetPreviewSize() As Size
'Usage

Dim instance As IStyleTemplateCustomDrawingSupport
Dim value As Size

value = instance.GetPreviewSize()
Size GetPreviewSize()
Size GetPreviewSize();

Return Value

预览的大小。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleTemplateCustomDrawingSupport Interface
IStyleTemplateCustomDrawingSupport Members


%%ItemTitle%%

GetStyleTemplateCustomDrawingControl Method

GrapeCity.Forguncy.CellTypes Namespace > IStyleTemplateCustomDrawingSupport Interface : GetStyleTemplateCustomDrawingControl Method
单元格信息。
画法帮助工具。
显示文本。
支持改写单元格模板样式的预览。如果修改单元格模板样式的预览效果，需重写该方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetStyleTemplateCustomDrawingControl( _
   ByVal cellInfo As ICellInfo, _
   ByVal drawingHelper As IDrawingHelper, _
   ByVal displayText As String _
) As FrameworkElement
'Usage

Dim instance As IStyleTemplateCustomDrawingSupport
Dim cellInfo As ICellInfo
Dim drawingHelper As IDrawingHelper
Dim displayText As String
Dim value As FrameworkElement

value = instance.GetStyleTemplateCustomDrawingControl(cellInfo, drawingHelper, displayText)
FrameworkElement GetStyleTemplateCustomDrawingControl(
   ICellInfo cellInfo,
   IDrawingHelper drawingHelper,
   string displayText
)
FrameworkElement^ GetStyleTemplateCustomDrawingControl(
   ICellInfo^ cellInfo,
   IDrawingHelper^ drawingHelper,
   String^ displayText
)

Parameters

cellInfo
单元格信息。
drawingHelper
画法帮助工具。
displayText
显示文本。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IStyleTemplateCustomDrawingSupport Interface
IStyleTemplateCustomDrawingSupport Members


%%PageItemTitle%%

ISupportPropertyInitialize Interface
Members

GrapeCity.Forguncy.CellTypes Namespace : ISupportPropertyInitialize Interface
设置单元格类型的默认属性值。 例如，可以设置【超链接】单元格的点击模式默认为单元格而非文字区域。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ISupportPropertyInitialize
'Usage

Dim instance As ISupportPropertyInitialize
public interface ISupportPropertyInitialize
public interface class ISupportPropertyInitialize
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportPropertyInitialize Members
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Members$$

ISupportPropertyInitialize Interface Members
Methods

GrapeCity.Forguncy.CellTypes Namespace : ISupportPropertyInitialize Interface

The following tables list the members exposed by ISupportPropertyInitialize.

Public Methods
 | Name | Description
Method | InitDefaultPropertyValues | 初始化默认属性值。
Top
See Also

Reference

ISupportPropertyInitialize Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

ISupportPropertyInitialize Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : ISupportPropertyInitialize Interface

For a list of all members of this type, see ISupportPropertyInitialize members.

Public Methods
 | Name | Description
Method | InitDefaultPropertyValues | 初始化默认属性值。
Top
See Also

Reference

ISupportPropertyInitialize Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

InitDefaultPropertyValues Method (ISupportPropertyInitialize)
Example

GrapeCity.Forguncy.CellTypes Namespace > ISupportPropertyInitialize Interface : InitDefaultPropertyValues Method
初始化需要的参数
初始化默认属性值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub InitDefaultPropertyValues( _
   ByVal context As IBuilderContext _
)
'Usage

Dim instance As ISupportPropertyInitialize
Dim context As IBuilderContext

instance.InitDefaultPropertyValues(context)
void InitDefaultPropertyValues(
   IBuilderContext context
)
void InitDefaultPropertyValues(
   IBuilderContext^ context
)

Parameters

context
初始化需要的参数
Example
  • C#
public class HyperlinkCellType : CellType, ISupportPropertyInitialize
{
    [DisplayName("点击模式")]
    public HyperlinkClickMode ClickMode { get; set; }

    public void InitDefaultPropertyValues(IBuilderContext context)
    {
        this.ClickMode = HyperlinkClickMode.Cell;
    }
}

public enum HyperlinkClickMode
{
    [Description("文字")]
    Text,
    [Description("单元格")]
    Cell
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISupportPropertyInitialize Interface
ISupportPropertyInitialize Members


%%ItemTitle%%

GrapeCity.Forguncy.Plugin Assembly
Namespaces
Namespace | Description
Forguncy |
GrapeCity.Forguncy.Plugin |


%%ItemTitle%%

Forguncy Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | ForguncyVersionPlugin | 活字格插件版本信息
See Also

Reference

GrapeCity.Forguncy.Plugin Assembly


%%PageItemTitle%%

ForguncyVersionPlugin Class
Members

Forguncy Namespace : ForguncyVersionPlugin Class
活字格插件版本信息
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class ForguncyVersionPlugin
'Usage

Dim instance As ForguncyVersionPlugin
public static class ForguncyVersionPlugin
public ref class ForguncyVersionPlugin abstract sealed
Inheritance Hierarchy

System.Object
Forguncy.ForguncyVersionPlugin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Members
Forguncy Namespace


%%PageItemTitle%% $$Members$$

ForguncyVersionPlugin Class Members
Fields

Forguncy Namespace : ForguncyVersionPlugin Class

The following tables list the members exposed by ForguncyVersionPlugin.

Public Fields
 | Name | Description
Public Field | AssemblyCopyright |
Public Field | AssemblyCopyrightDisplay | 显示的程序集版权表示されるアセンブリの著作権
static (Shared in Visual Basic) | LicenseVersionNumber |
static (Shared in Visual Basic) | LicenseVersionNumber_CN |
static (Shared in Visual Basic) | MainVersionString |
Public Field | PID |
Public Field | ProductName |
Public Field | UpdateString |
static (Shared in Visual Basic) | Version |
Public Field | VersionString |
Top
See Also

Reference

ForguncyVersionPlugin Class
Forguncy Namespace


%%PageItemTitle%% $$Fields$$

ForguncyVersionPlugin Class Fields

Forguncy Namespace : ForguncyVersionPlugin Class

For a list of all members of this type, see ForguncyVersionPlugin members.

Public Fields
 | Name | Description
Public Field | AssemblyCopyright |
Public Field | AssemblyCopyrightDisplay | 显示的程序集版权表示されるアセンブリの著作権
static (Shared in Visual Basic) | LicenseVersionNumber |
static (Shared in Visual Basic) | LicenseVersionNumber_CN |
static (Shared in Visual Basic) | MainVersionString |
Public Field | PID |
Public Field | ProductName |
Public Field | UpdateString |
static (Shared in Visual Basic) | Version |
Public Field | VersionString |
Top
See Also

Reference

ForguncyVersionPlugin Class
Forguncy Namespace


%%ItemTitle%%

AssemblyCopyright Field

Forguncy Namespace > ForguncyVersionPlugin Class : AssemblyCopyright Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const AssemblyCopyright As String
'Usage

Dim value As String

value = ForguncyVersionPlugin.AssemblyCopyright
public const string AssemblyCopyright
public:
const String^ AssemblyCopyright
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

AssemblyCopyrightDisplay Field

Forguncy Namespace > ForguncyVersionPlugin Class : AssemblyCopyrightDisplay Field
显示的程序集版权表示されるアセンブリの著作権
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const AssemblyCopyrightDisplay As String
'Usage

Dim value As String

value = ForguncyVersionPlugin.AssemblyCopyrightDisplay
public const string AssemblyCopyrightDisplay
public:
const String^ AssemblyCopyrightDisplay
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

LicenseVersionNumber Field

Forguncy Namespace > ForguncyVersionPlugin Class : LicenseVersionNumber Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly LicenseVersionNumber As Integer
'Usage

Dim value As Integer

value = ForguncyVersionPlugin.LicenseVersionNumber
public static readonly int LicenseVersionNumber
public:
static readonly int LicenseVersionNumber
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

LicenseVersionNumber_CN Field

Forguncy Namespace > ForguncyVersionPlugin Class : LicenseVersionNumber_CN Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly LicenseVersionNumber_CN As Integer
'Usage

Dim value As Integer

value = ForguncyVersionPlugin.LicenseVersionNumber_CN
public static readonly int LicenseVersionNumber_CN
public:
static readonly int LicenseVersionNumber_CN
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

MainVersionString Field

Forguncy Namespace > ForguncyVersionPlugin Class : MainVersionString Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly MainVersionString As String
'Usage

Dim value As String

value = ForguncyVersionPlugin.MainVersionString
public static readonly string MainVersionString
public:
static readonly String^ MainVersionString
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

PID Field

Forguncy Namespace > ForguncyVersionPlugin Class : PID Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const PID As String
'Usage

Dim value As String

value = ForguncyVersionPlugin.PID
public const string PID
public:
const String^ PID
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

ProductName Field

Forguncy Namespace > ForguncyVersionPlugin Class : ProductName Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const ProductName As String
'Usage

Dim value As String

value = ForguncyVersionPlugin.ProductName
public const string ProductName
public:
const String^ ProductName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

UpdateString Field

Forguncy Namespace > ForguncyVersionPlugin Class : UpdateString Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const UpdateString As String
'Usage

Dim value As String

value = ForguncyVersionPlugin.UpdateString
public const string UpdateString
public:
const String^ UpdateString
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

Version Field

Forguncy Namespace > ForguncyVersionPlugin Class : Version Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared ReadOnly Version As Version
'Usage

Dim value As Version

value = ForguncyVersionPlugin.Version
public static readonly Version Version
public:
static readonly Version^ Version
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

VersionString Field

Forguncy Namespace > ForguncyVersionPlugin Class : VersionString Field
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Const VersionString As String
'Usage

Dim value As String

value = ForguncyVersionPlugin.VersionString
public const string VersionString
public:
const String^ VersionString
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyVersionPlugin Class
ForguncyVersionPlugin Members


%%ItemTitle%%

GrapeCity.Forguncy.Plugin Namespace (GrapeCity.Forguncy.Plugin)
Inheritance Hierarchy
Classes
 | Class | Description
Class | ColorPropertyAttribute | 指定插件内部属性对应的编辑器为颜色选择框。 注意：使用颜色选择框作为属性值编辑器的属性，其值类型必须是System.String。
Class | FileCopyInfo | 在导入活字格页面过程中，需要复制的文件信息。
Class | FileUploadInfo | 上传文件的信息，用于保存。
Class | FindResultItem | 记录查找项结果。
Class | ForguncyErrorInfo | 运行页面时，内部检查出的错误或者提醒信息。
Class | FormulaPropertyAttribute | 指定插件内部属性对应的编辑器为公式选择框。 注意：使用公式选择框作为属性值编辑器的属性，其值类型必须是object。
Class | GenerateCellInfo | 用于IForceGenerateCell接口，强行生成单元格所需的信息。
Class | IconAttribute | 设置插件的图标。 该图标会应用到单元格类型下拉列表或命令选择下拉列表中，如果开启了单元格类型的显示模式，该图标也会应用到使用了该单元格类型的单元格上。
Class | ImageValue | 一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
Class | ListPropertyAttribute |
Class | LocatedObject | 带坐标定位器的对象。
Class | LocatedObject<T> | 带坐标定位器的特定类型的对象，如页面，命名等。
Class | LocationIndicator | 坐标定位器，查找引用时基于它可以帮助用户快速找到相关对象的位置。
Class | LocationIndicatorExtension | 坐标定位器扩展类。
Class | NameIndicator | 名称定位器，一种特定类型的坐标定位器。
Class | ObjectIndicator | 对象定位器，一种特定类型的坐标定位器。
Class | ObjectIndicator<T> | 特定类型的对象定位器。
Class | OrderWeightAttribute | 插件或插件内部属性的权重, 权重越大位置越靠后。
Class | PageMetadataJsonIgnoreAttribute | 忽略运行页面时不需要的属性，例如只用于单元格类型预览的属性。
Class | PluginUtilities | 插件公用类。
Class | PropertyIndicator | 属性定位器，一种特定类型的坐标定位器。
Class | SaveJsonIgnoreAttribute | 忽略不需要保存到文档的属性。
Class | TableCheckInfo | 查找数据表的引用时返回的数据表的位置信息。
Class | WindowsIgnorePropertyAttribute | 具有此标签的属性在Windows认证模式下将不会自动生成UI
Interfaces
 | Interface | Description
Interface | IBindingInfo | 单元格的数据绑定信息，即一旦单元格绑定到A表的B字段,如果页面中存在A表，那么该单元格就会显示当前行的B字段的值。
Interface | ICellInfoBase | 单元格的信息。
Interface | IColumnInfo | 数据表中的字段信息。
Interface | IFileUploadContext | 上传的文件需要的上下文信息。
Interface | IForceGenerateCell | 在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
Interface | IFormulaReferObject | 公式对象。
Interface | IListViewInfo | 页面中的表格信息。
Interface | IListViewInfoDesigner | 页面中的表格信息。
Interface | ILocalServerInfo | 本地网站应用信息。
Interface | INeedUploadFileByUser | 如果插件使用过程中需要用户上传文件或者图片等，在保存或导入活字格文件时需给出相关的文件或图片信息，如存储文件夹路径，文件名等。
Interface | IPageInfo | 页面信息。
Interface | IPropertySearchable | 能够检索替换单元格类型和命令上的某些属性。
Interface | IReferenceFormula | 如果插件中引用了页面中的单元格，一旦被引用的单元格的位置发生了变化，如拖拽，那么插件中的相关单元格引用也应该被同步； 这种情况下就需要实现这个接口，而且，当查找页面中的单元格引用时，插件中的相关属性也会被查找出来。
Interface | IReferenceListView | 如果插件中引用了页面中的表格的名称，一旦表格重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找页面中的表格引用时，插件中的相关属性也会被查找出来。
Interface | IReferenceListViewColumn | 如果插件中引用了页面表格中列名，一旦表格中的列重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口。
Interface | IReferencePage | 如果插件中引用了页面名，一旦页面重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找页面的引用时，插件中的相关属性也会被查找出来。
Interface | IReferenceTable | 如果插件中引用了数据表名或者字段名，一旦数据表或字段重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找数据表或字段的引用时，插件中的相关属性也会被查找出来。
Interface | IReferFiles | 此接口将返回当前对象关联的所有文件的物理文件路径。
Interface | ITableInfo | 数据表的信息。
Interface | IUserServiceInfo | 用户管理网站的信息。
Interface | IWorkflowInfo | 数据表中的工作流信息。
Enumerations
 | Enumeration | Description
Enumeration | AuthenticationMode | 认证模式。
Enumeration | ForguncyErrorType | 运行页面时，系统内部会进行出错检查并显示在错误列表中，会根据出错类型显示不同的信息，并影响页面是否能够运行起来。
Enumeration | ForguncyTableColumnType | 内建字段的值的类型。
Enumeration | ForguncyTableType | 数据表的类型。
Enumeration | TableColumnKind | 字段分类。
See Also

Reference

GrapeCity.Forguncy.Plugin Assembly


%%PageItemTitle%%

ColorPropertyAttribute Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : ColorPropertyAttribute Class

指定插件内部属性对应的编辑器为颜色选择框。

注意：使用颜色选择框作为属性值编辑器的属性，其值类型必须是System.String。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ColorPropertyAttribute
   Inherits System.Attribute
'Usage

Dim instance As ColorPropertyAttribute
public class ColorPropertyAttribute : System.Attribute
public ref class ColorPropertyAttribute : public System.Attribute
Example
  • C#
public class SetColorCommand : Command
{
    [ColorProperty]
    public object DefaultColor { get; set; }
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.ColorPropertyAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorPropertyAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ColorPropertyAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ColorPropertyAttribute Class

The following tables list the members exposed by ColorPropertyAttribute.

Public Constructors
 | Name | Description
Public Constructor | ColorPropertyAttribute Constructor | 默认构造函数。
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ColorPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ColorPropertyAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > ColorPropertyAttribute Class : ColorPropertyAttribute Constructor
默认构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ColorPropertyAttribute()
public ColorPropertyAttribute()
public:
ColorPropertyAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorPropertyAttribute Class
ColorPropertyAttribute Members


%%PageItemTitle%%

FileCopyInfo Class
Members

GrapeCity.Forguncy.Plugin Namespace : FileCopyInfo Class
在导入活字格页面过程中，需要复制的文件信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class FileCopyInfo
'Usage

Dim instance As FileCopyInfo
public class FileCopyInfo
public ref class FileCopyInfo
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.FileCopyInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileCopyInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

FileCopyInfo Class Members
Properties

GrapeCity.Forguncy.Plugin Namespace : FileCopyInfo Class

The following tables list the members exposed by FileCopyInfo.

Public Constructors
 | Name | Description
Public Constructor | FileCopyInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | SourceFileFolder | 原文件所在文件夹路径。
Public Property | SourceFileName | 原文件名。
Public Property | TargetFileFolder | 目标文件所在文件夹路径。
Public Property | TargetFileName | 目标文件名。
Top
See Also

Reference

FileCopyInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

FileCopyInfo Constructor

GrapeCity.Forguncy.Plugin Namespace > FileCopyInfo Class : FileCopyInfo Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileCopyInfo()
public FileCopyInfo()
public:
FileCopyInfo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileCopyInfo Class
FileCopyInfo Members


%%PageItemTitle%% $$Properties$$

FileCopyInfo Class Properties

GrapeCity.Forguncy.Plugin Namespace : FileCopyInfo Class

For a list of all members of this type, see FileCopyInfo members.

Public Properties
 | Name | Description
Public Property | SourceFileFolder | 原文件所在文件夹路径。
Public Property | SourceFileName | 原文件名。
Public Property | TargetFileFolder | 目标文件所在文件夹路径。
Public Property | TargetFileName | 目标文件名。
Top
See Also

Reference

FileCopyInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

SourceFileFolder Property

GrapeCity.Forguncy.Plugin Namespace > FileCopyInfo Class : SourceFileFolder Property
原文件所在文件夹路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SourceFileFolder As String
'Usage

Dim instance As FileCopyInfo
Dim value As String

instance.SourceFileFolder = value

value = instance.SourceFileFolder
public string SourceFileFolder {get; set;}
public:
property String^ SourceFileFolder {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileCopyInfo Class
FileCopyInfo Members


%%ItemTitle%%

SourceFileName Property

GrapeCity.Forguncy.Plugin Namespace > FileCopyInfo Class : SourceFileName Property
原文件名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property SourceFileName As String
'Usage

Dim instance As FileCopyInfo
Dim value As String

instance.SourceFileName = value

value = instance.SourceFileName
public string SourceFileName {get; set;}
public:
property String^ SourceFileName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileCopyInfo Class
FileCopyInfo Members


%%ItemTitle%%

TargetFileFolder Property

GrapeCity.Forguncy.Plugin Namespace > FileCopyInfo Class : TargetFileFolder Property
目标文件所在文件夹路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TargetFileFolder As String
'Usage

Dim instance As FileCopyInfo
Dim value As String

instance.TargetFileFolder = value

value = instance.TargetFileFolder
public string TargetFileFolder {get; set;}
public:
property String^ TargetFileFolder {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileCopyInfo Class
FileCopyInfo Members


%%ItemTitle%%

TargetFileName Property

GrapeCity.Forguncy.Plugin Namespace > FileCopyInfo Class : TargetFileName Property
目标文件名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property TargetFileName As String
'Usage

Dim instance As FileCopyInfo
Dim value As String

instance.TargetFileName = value

value = instance.TargetFileName
public string TargetFileName {get; set;}
public:
property String^ TargetFileName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileCopyInfo Class
FileCopyInfo Members


%%PageItemTitle%%

FileUploadInfo Class
Members

GrapeCity.Forguncy.Plugin Namespace : FileUploadInfo Class
上传文件的信息，用于保存。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class FileUploadInfo
'Usage

Dim instance As FileUploadInfo
public class FileUploadInfo
public ref class FileUploadInfo
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.FileUploadInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileUploadInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

FileUploadInfo Class Members
Properties

GrapeCity.Forguncy.Plugin Namespace : FileUploadInfo Class

The following tables list the members exposed by FileUploadInfo.

Public Constructors
 | Name | Description
Public Constructor | FileUploadInfo Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | AllUsedUploadFilePaths | 所有上传文件的名称列表。
Public Property | UploadFileFolder | 上传文件所在的文件夹路径。
Top
See Also

Reference

FileUploadInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

FileUploadInfo Constructor

GrapeCity.Forguncy.Plugin Namespace > FileUploadInfo Class : FileUploadInfo Constructor
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileUploadInfo()
public FileUploadInfo()
public:
FileUploadInfo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileUploadInfo Class
FileUploadInfo Members


%%PageItemTitle%% $$Properties$$

FileUploadInfo Class Properties

GrapeCity.Forguncy.Plugin Namespace : FileUploadInfo Class

For a list of all members of this type, see FileUploadInfo members.

Public Properties
 | Name | Description
Public Property | AllUsedUploadFilePaths | 所有上传文件的名称列表。
Public Property | UploadFileFolder | 上传文件所在的文件夹路径。
Top
See Also

Reference

FileUploadInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

AllUsedUploadFilePaths Property

GrapeCity.Forguncy.Plugin Namespace > FileUploadInfo Class : AllUsedUploadFilePaths Property
所有上传文件的名称列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AllUsedUploadFilePaths As List(Of String)
'Usage

Dim instance As FileUploadInfo
Dim value As List(Of String)

value = instance.AllUsedUploadFilePaths
public List<string> AllUsedUploadFilePaths {get;}
public:
property List<String^>^ AllUsedUploadFilePaths {
   List<String^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileUploadInfo Class
FileUploadInfo Members


%%ItemTitle%%

UploadFileFolder Property

GrapeCity.Forguncy.Plugin Namespace > FileUploadInfo Class : UploadFileFolder Property
上传文件所在的文件夹路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UploadFileFolder As String
'Usage

Dim instance As FileUploadInfo
Dim value As String

instance.UploadFileFolder = value

value = instance.UploadFileFolder
public string UploadFileFolder {get; set;}
public:
property String^ UploadFileFolder {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileUploadInfo Class
FileUploadInfo Members


%%PageItemTitle%%

FindResultItem Class
Members

GrapeCity.Forguncy.Plugin Namespace : FindResultItem Class
记录查找项结果。
Object Model
FindResultItem ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class FindResultItem
'Usage

Dim instance As FindResultItem
public class FindResultItem
public ref class FindResultItem
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.FindResultItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindResultItem Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

FindResultItem Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : FindResultItem Class

The following tables list the members exposed by FindResultItem.

Public Constructors
 | Name | Description
Public Constructor | FindResultItem Constructor |
Top
Public Properties
 | Name | Description
Public Property | Location | 查找某一项的位置信息。
Public Property | Value | 查找某一项的值。
Top
Public Methods
 | Name | Description
Public Method | IsEquals | 是否是同一对象的引用。
Top
See Also

Reference

FindResultItem Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

FindResultItem Constructor

GrapeCity.Forguncy.Plugin Namespace > FindResultItem Class : FindResultItem Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FindResultItem()
public FindResultItem()
public:
FindResultItem();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindResultItem Class
FindResultItem Members


%%PageItemTitle%% $$Methods$$

FindResultItem Class Methods

GrapeCity.Forguncy.Plugin Namespace : FindResultItem Class

For a list of all members of this type, see FindResultItem members.

Public Methods
 | Name | Description
Public Method | IsEquals | 是否是同一对象的引用。
Top
See Also

Reference

FindResultItem Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

IsEquals Method

GrapeCity.Forguncy.Plugin Namespace > FindResultItem Class : IsEquals Method
是否是同一对象的引用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function IsEquals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As FindResultItem
Dim obj As Object
Dim value As Boolean

value = instance.IsEquals(obj)
public virtual bool IsEquals(
   object obj
)
public:
virtual bool IsEquals(
   Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindResultItem Class
FindResultItem Members


%%PageItemTitle%% $$Properties$$

FindResultItem Class Properties

GrapeCity.Forguncy.Plugin Namespace : FindResultItem Class

For a list of all members of this type, see FindResultItem members.

Public Properties
 | Name | Description
Public Property | Location | 查找某一项的位置信息。
Public Property | Value | 查找某一项的值。
Top
See Also

Reference

FindResultItem Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

Location Property (FindResultItem)

GrapeCity.Forguncy.Plugin Namespace > FindResultItem Class : Location Property
查找某一项的位置信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Location As LocationIndicator
'Usage

Dim instance As FindResultItem
Dim value As LocationIndicator

instance.Location = value

value = instance.Location
public LocationIndicator Location {get; set;}
public:
property LocationIndicator^ Location {
   LocationIndicator^ get();
   void set (    LocationIndicator^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindResultItem Class
FindResultItem Members


%%ItemTitle%%

Value Property (FindResultItem)

GrapeCity.Forguncy.Plugin Namespace > FindResultItem Class : Value Property
查找某一项的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As String
'Usage

Dim instance As FindResultItem
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FindResultItem Class
FindResultItem Members


%%PageItemTitle%%

ForguncyErrorInfo Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : ForguncyErrorInfo Class
运行页面时，内部检查出的错误或者提醒信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ForguncyErrorInfo
'Usage

Dim instance As ForguncyErrorInfo
public class ForguncyErrorInfo
public ref class ForguncyErrorInfo
Example
  • C#
public class SetFocusCommandDesigner : CommandDesigner<SetFocusCommand>,ICommandChecker
{
    [FormulaProperty]
    public object TargetCell { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCommandErrors(IBuilderCommandContext context)
    {
        if(TargetCell == null)
        {
            yield return new ForguncyErrorInfo()
           {
               Message = "Target cell cannot be null.",
               ErrorType = ForguncyErrorType.Error
           };
        }
    }
}
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.ForguncyErrorInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyErrorInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ForguncyErrorInfo Class Members
Properties

GrapeCity.Forguncy.Plugin Namespace : ForguncyErrorInfo Class

The following tables list the members exposed by ForguncyErrorInfo.

Public Constructors
 | Name | Description
Public Constructor | ForguncyErrorInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | ErrorType | 错误类型：错误或者提醒。
Public Property | Message | 错误信息。
Top
See Also

Reference

ForguncyErrorInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ForguncyErrorInfo Constructor

GrapeCity.Forguncy.Plugin Namespace > ForguncyErrorInfo Class : ForguncyErrorInfo Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ForguncyErrorInfo()
public ForguncyErrorInfo()
public:
ForguncyErrorInfo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyErrorInfo Class
ForguncyErrorInfo Members


%%PageItemTitle%% $$Properties$$

ForguncyErrorInfo Class Properties

GrapeCity.Forguncy.Plugin Namespace : ForguncyErrorInfo Class

For a list of all members of this type, see ForguncyErrorInfo members.

Public Properties
 | Name | Description
Public Property | ErrorType | 错误类型：错误或者提醒。
Public Property | Message | 错误信息。
Top
See Also

Reference

ForguncyErrorInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

ErrorType Property

GrapeCity.Forguncy.Plugin Namespace > ForguncyErrorInfo Class : ErrorType Property
错误类型：错误或者提醒。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ErrorType As ForguncyErrorType
'Usage

Dim instance As ForguncyErrorInfo
Dim value As ForguncyErrorType

instance.ErrorType = value

value = instance.ErrorType
public ForguncyErrorType ErrorType {get; set;}
public:
property ForguncyErrorType ErrorType {
   ForguncyErrorType get();
   void set (    ForguncyErrorType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyErrorInfo Class
ForguncyErrorInfo Members


%%ItemTitle%%

Message Property (ForguncyErrorInfo)

GrapeCity.Forguncy.Plugin Namespace > ForguncyErrorInfo Class : Message Property
错误信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Message As String
'Usage

Dim instance As ForguncyErrorInfo
Dim value As String

instance.Message = value

value = instance.Message
public string Message {get; set;}
public:
property String^ Message {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyErrorInfo Class
ForguncyErrorInfo Members


%%PageItemTitle%%

FormulaPropertyAttribute Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : FormulaPropertyAttribute Class

指定插件内部属性对应的编辑器为公式选择框。

注意：使用公式选择框作为属性值编辑器的属性，其值类型必须是object。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class FormulaPropertyAttribute
   Inherits System.Attribute
'Usage

Dim instance As FormulaPropertyAttribute
public class FormulaPropertyAttribute : System.Attribute
public ref class FormulaPropertyAttribute : public System.Attribute
Example
  • C#
public class SetFocusCommand : Command
{
    [FormulaProperty(true)]
    public object TargetCell { get; set; }
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.FormulaPropertyAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaPropertyAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

FormulaPropertyAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : FormulaPropertyAttribute Class

The following tables list the members exposed by FormulaPropertyAttribute.

Public Constructors
 | Name | Description
Public Constructor | FormulaPropertyAttribute Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | OnlySupportCell | 公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

FormulaPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

FormulaPropertyAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > FormulaPropertyAttribute Class : FormulaPropertyAttribute Constructor
Overload List
Overload | Description
FormulaPropertyAttribute Constructor() | 默认构造函数。
FormulaPropertyAttribute Constructor(Boolean) | 构造函数，指定其公式选择框是否只能选择单元格而不支持选择单元格区域或者函数。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaPropertyAttribute Class
FormulaPropertyAttribute Members


%%PageItemTitle%%

FormulaPropertyAttribute Constructor()

GrapeCity.Forguncy.Plugin Namespace > FormulaPropertyAttribute Class > FormulaPropertyAttribute Constructor : FormulaPropertyAttribute Constructor()
默认构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FormulaPropertyAttribute()
public FormulaPropertyAttribute()
public:
FormulaPropertyAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaPropertyAttribute Class
FormulaPropertyAttribute Members
Overload List


%%PageItemTitle%%

FormulaPropertyAttribute Constructor(Boolean)

GrapeCity.Forguncy.Plugin Namespace > FormulaPropertyAttribute Class > FormulaPropertyAttribute Constructor : FormulaPropertyAttribute Constructor(Boolean)
是否只支持单元格。
构造函数，指定其公式选择框是否只能选择单元格而不支持选择单元格区域或者函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal onlySupportCell As Boolean _
)
'Usage

Dim onlySupportCell As Boolean

Dim instance As New FormulaPropertyAttribute(onlySupportCell)
public FormulaPropertyAttribute(
   bool onlySupportCell
)
public:
FormulaPropertyAttribute(
   bool onlySupportCell
)

Parameters

onlySupportCell
是否只支持单元格。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaPropertyAttribute Class
FormulaPropertyAttribute Members
Overload List


%%PageItemTitle%% $$Properties$$

FormulaPropertyAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : FormulaPropertyAttribute Class

For a list of all members of this type, see FormulaPropertyAttribute members.

Public Properties
 | Name | Description
Public Property | OnlySupportCell | 公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

FormulaPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

OnlySupportCell Property (FormulaPropertyAttribute)

GrapeCity.Forguncy.Plugin Namespace > FormulaPropertyAttribute Class : OnlySupportCell Property
公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property OnlySupportCell As Boolean
'Usage

Dim instance As FormulaPropertyAttribute
Dim value As Boolean

instance.OnlySupportCell = value

value = instance.OnlySupportCell
public bool OnlySupportCell {get; set;}
public:
property bool OnlySupportCell {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaPropertyAttribute Class
FormulaPropertyAttribute Members


%%PageItemTitle%%

GenerateCellInfo Class
Members

GrapeCity.Forguncy.Plugin Namespace : GenerateCellInfo Class
用于IForceGenerateCell接口，强行生成单元格所需的信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class GenerateCellInfo
'Usage

Dim instance As GenerateCellInfo
public class GenerateCellInfo
public ref class GenerateCellInfo
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.GenerateCellInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenerateCellInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

GenerateCellInfo Class Members
Properties

GrapeCity.Forguncy.Plugin Namespace : GenerateCellInfo Class

The following tables list the members exposed by GenerateCellInfo.

Public Constructors
 | Name | Description
Public Constructor | GenerateCellInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | ColumnIndex | 单元格列索引，从0开始计算。
Public Property | PageName | 单元格所在页面的名字。
Public Property | RowIndex | 单元格行索引，从0开始计算。
Top
See Also

Reference

GenerateCellInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

GenerateCellInfo Constructor

GrapeCity.Forguncy.Plugin Namespace > GenerateCellInfo Class : GenerateCellInfo Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New GenerateCellInfo()
public GenerateCellInfo()
public:
GenerateCellInfo();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenerateCellInfo Class
GenerateCellInfo Members


%%PageItemTitle%% $$Properties$$

GenerateCellInfo Class Properties

GrapeCity.Forguncy.Plugin Namespace : GenerateCellInfo Class

For a list of all members of this type, see GenerateCellInfo members.

Public Properties
 | Name | Description
Public Property | ColumnIndex | 单元格列索引，从0开始计算。
Public Property | PageName | 单元格所在页面的名字。
Public Property | RowIndex | 单元格行索引，从0开始计算。
Top
See Also

Reference

GenerateCellInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

ColumnIndex Property (GenerateCellInfo)

GrapeCity.Forguncy.Plugin Namespace > GenerateCellInfo Class : ColumnIndex Property
单元格列索引，从0开始计算。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColumnIndex As Integer
'Usage

Dim instance As GenerateCellInfo
Dim value As Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
public int ColumnIndex {get; set;}
public:
property int ColumnIndex {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenerateCellInfo Class
GenerateCellInfo Members


%%ItemTitle%%

PageName Property (GenerateCellInfo)

GrapeCity.Forguncy.Plugin Namespace > GenerateCellInfo Class : PageName Property
单元格所在页面的名字。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PageName As String
'Usage

Dim instance As GenerateCellInfo
Dim value As String

instance.PageName = value

value = instance.PageName
public string PageName {get; set;}
public:
property String^ PageName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenerateCellInfo Class
GenerateCellInfo Members


%%ItemTitle%%

RowIndex Property (GenerateCellInfo)

GrapeCity.Forguncy.Plugin Namespace > GenerateCellInfo Class : RowIndex Property
单元格行索引，从0开始计算。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property RowIndex As Integer
'Usage

Dim instance As GenerateCellInfo
Dim value As Integer

instance.RowIndex = value

value = instance.RowIndex
public int RowIndex {get; set;}
public:
property int RowIndex {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GenerateCellInfo Class
GenerateCellInfo Members


%%PageItemTitle%%

IconAttribute Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : IconAttribute Class

设置插件的图标。

该图标会应用到单元格类型下拉列表或命令选择下拉列表中，如果开启了单元格类型的显示模式，该图标也会应用到使用了该单元格类型的单元格上。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class IconAttribute
   Inherits System.Attribute
'Usage

Dim instance As IconAttribute
public class IconAttribute : System.Attribute
public ref class IconAttribute : public System.Attribute
Example
  • C#
[Icon("pack://application:,,,/SignatureCellType;component/Resources/icon.png")]  //指定签名单元格类型的图标
public class SignatureCellType : CellType //自定义了签名单元格类型
{
    ...
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.IconAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IconAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IconAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : IconAttribute Class

The following tables list the members exposed by IconAttribute.

Public Constructors
 | Name | Description
Public Constructor | IconAttribute Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

IconAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

IconAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > IconAttribute Class : IconAttribute Constructor
图标的路径。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As String _
)
'Usage

Dim uri As String

Dim instance As New IconAttribute(uri)
public IconAttribute(
   string uri
)
public:
IconAttribute(
   String^ uri
)

Parameters

uri
图标的路径。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IconAttribute Class
IconAttribute Members


%%PageItemTitle%%

ImageValue Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : ImageValue Class
一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ImageValue
'Usage

Dim instance As ImageValue
public class ImageValue
public ref class ImageValue
Example
  • C#
public class MyImageCellType : CellType
{
    public ImageValue ImageInfo { get; set; }
}
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.ImageValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageValue Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ImageValue Class Members
Properties

GrapeCity.Forguncy.Plugin Namespace : ImageValue Class

The following tables list the members exposed by ImageValue.

Public Constructors
 | Name | Description
Public Constructor | ImageValue Constructor |
Top
Public Properties
 | Name | Description
Public Property | BuiltIn | 是否是内置图片。
Public Property | Color | 内置图片的颜色，只有当图片为SVG格式时才能起作用。
Public Property | Name | 图片名。
Top
See Also

Reference

ImageValue Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ImageValue Constructor

GrapeCity.Forguncy.Plugin Namespace > ImageValue Class : ImageValue Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageValue()
public ImageValue()
public:
ImageValue();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageValue Class
ImageValue Members


%%PageItemTitle%% $$Properties$$

ImageValue Class Properties

GrapeCity.Forguncy.Plugin Namespace : ImageValue Class

For a list of all members of this type, see ImageValue members.

Public Properties
 | Name | Description
Public Property | BuiltIn | 是否是内置图片。
Public Property | Color | 内置图片的颜色，只有当图片为SVG格式时才能起作用。
Public Property | Name | 图片名。
Top
See Also

Reference

ImageValue Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

BuiltIn Property (ImageValue)

GrapeCity.Forguncy.Plugin Namespace > ImageValue Class : BuiltIn Property
是否是内置图片。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property BuiltIn As Boolean
'Usage

Dim instance As ImageValue
Dim value As Boolean

instance.BuiltIn = value

value = instance.BuiltIn
[DefaultValue()]
public bool BuiltIn {get; set;}
[DefaultValue()]
public:
property bool BuiltIn {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageValue Class
ImageValue Members


%%ItemTitle%%

Color Property

GrapeCity.Forguncy.Plugin Namespace > ImageValue Class : Color Property
内置图片的颜色，只有当图片为SVG格式时才能起作用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Overridable Property Color As String
'Usage

Dim instance As ImageValue
Dim value As String

instance.Color = value

value = instance.Color
[DefaultValue()]
public virtual string Color {get; set;}
[DefaultValue()]
public:
virtual property String^ Color {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageValue Class
ImageValue Members


%%ItemTitle%%

Name Property (ImageValue)

GrapeCity.Forguncy.Plugin Namespace > ImageValue Class : Name Property
图片名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property Name As String
'Usage

Dim instance As ImageValue
Dim value As String

instance.Name = value

value = instance.Name
[DefaultValue()]
public string Name {get; set;}
[DefaultValue()]
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageValue Class
ImageValue Members


%%PageItemTitle%%

ListPropertyAttribute Class
Members

GrapeCity.Forguncy.Plugin Namespace : ListPropertyAttribute Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ListPropertyAttribute
   Inherits System.Attribute
'Usage

Dim instance As ListPropertyAttribute
public class ListPropertyAttribute : System.Attribute
public ref class ListPropertyAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.ListPropertyAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListPropertyAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ListPropertyAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ListPropertyAttribute Class

The following tables list the members exposed by ListPropertyAttribute.

Public Constructors
 | Name | Description
Public Constructor | ListPropertyAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ListPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ListPropertyAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > ListPropertyAttribute Class : ListPropertyAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ListPropertyAttribute()
public ListPropertyAttribute()
public:
ListPropertyAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListPropertyAttribute Class
ListPropertyAttribute Members


%%PageItemTitle%%

LocatedObject Class
Members

GrapeCity.Forguncy.Plugin Namespace : LocatedObject Class
带坐标定位器的对象。
Object Model
LocatedObject ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class LocatedObject
'Usage

Dim instance As LocatedObject
public class LocatedObject
public ref class LocatedObject
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocatedObject
GrapeCity.Forguncy.Plugin.LocatedObject<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocatedObject Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

LocatedObject Class Members
Properties

GrapeCity.Forguncy.Plugin Namespace : LocatedObject Class

The following tables list the members exposed by LocatedObject.

Public Constructors
 | Name | Description
Public Constructor | LocatedObject Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | Location | 坐标定位器。
Public Property | Object | 有坐标定位器的对象。
Top
See Also

Reference

LocatedObject Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

LocatedObject Constructor

GrapeCity.Forguncy.Plugin Namespace > LocatedObject Class : LocatedObject Constructor
对象。
坐标定位器。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal obj As Object, _
   ByVal location As LocationIndicator _
)
'Usage

Dim obj As Object
Dim location As LocationIndicator

Dim instance As New LocatedObject(obj, location)
public LocatedObject(
   object obj,
   LocationIndicator location
)
public:
LocatedObject(
   Object^ obj,
   LocationIndicator^ location
)

Parameters

obj
对象。
location
坐标定位器。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocatedObject Class
LocatedObject Members


%%PageItemTitle%% $$Properties$$

LocatedObject Class Properties

GrapeCity.Forguncy.Plugin Namespace : LocatedObject Class

For a list of all members of this type, see LocatedObject members.

Public Properties
 | Name | Description
Public Property | Location | 坐标定位器。
Public Property | Object | 有坐标定位器的对象。
Top
See Also

Reference

LocatedObject Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

Location Property (LocatedObject)

GrapeCity.Forguncy.Plugin Namespace > LocatedObject Class : Location Property
坐标定位器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Location As LocationIndicator
'Usage

Dim instance As LocatedObject
Dim value As LocationIndicator

instance.Location = value

value = instance.Location
public LocationIndicator Location {get; set;}
public:
property LocationIndicator^ Location {
   LocationIndicator^ get();
   void set (    LocationIndicator^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocatedObject Class
LocatedObject Members


%%ItemTitle%%

Object Property (LocatedObject)

GrapeCity.Forguncy.Plugin Namespace > LocatedObject Class : Object Property
有坐标定位器的对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Object As Object
'Usage

Dim instance As LocatedObject
Dim value As Object

instance.Object = value

value = instance.Object
public object Object {get; set;}
public:
property Object^ Object {
   Object^ get();
   void set (    Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocatedObject Class
LocatedObject Members


%%PageItemTitle%%

LocatedObject<T> Class
Members

GrapeCity.Forguncy.Plugin Namespace : LocatedObject<T> Class
特定类型。
带坐标定位器的特定类型的对象，如页面，命名等。
Object Model
LocatedObject<T> ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class LocatedObject(Of T)
   Inherits LocatedObject
'Usage

Dim instance As LocatedObject(Of T)
public class LocatedObject<T> : LocatedObject
generic<typename T>
public ref class LocatedObject : public LocatedObject
Type Parameters
T
特定类型。
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocatedObject
GrapeCity.Forguncy.Plugin.LocatedObject<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocatedObject<T> Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

LocatedObject<T> Class Members
Properties

GrapeCity.Forguncy.Plugin Namespace : LocatedObject<T> Class

The following tables list the members exposed by LocatedObject<T>.

Public Constructors
 | Name | Description
Public Constructor | LocatedObject<T> Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | Location | 坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocatedObject)
Public Property | Object | 特定类型的对象。
Top
See Also

Reference

LocatedObject<T> Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

LocatedObject<T> Class Properties

GrapeCity.Forguncy.Plugin Namespace : LocatedObject<T> Class

For a list of all members of this type, see LocatedObject<T> members.

Public Properties
 | Name | Description
Public Property | Location | 坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocatedObject)
Public Property | Object | 特定类型的对象。
Top
See Also

Reference

LocatedObject<T> Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

LocationIndicator Class
Members

GrapeCity.Forguncy.Plugin Namespace : LocationIndicator Class
坐标定位器，查找引用时基于它可以帮助用户快速找到相关对象的位置。
Object Model
LocationIndicator ClassLocationIndicator ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class LocationIndicator
'Usage

Dim instance As LocationIndicator
public abstract class LocationIndicator
public ref class LocationIndicator abstract
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

LocationIndicator Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : LocationIndicator Class

The following tables list the members exposed by LocationIndicator.

Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
Public Property | Parent | 父节点
Public Property | Root | 根坐标定位器。
Top
Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。
Top
See Also

Reference

LocationIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

LocationIndicator Class Methods

GrapeCity.Forguncy.Plugin Namespace : LocationIndicator Class

For a list of all members of this type, see LocationIndicator members.

Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。
Top
See Also

Reference

LocationIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

Append Method

GrapeCity.Forguncy.Plugin Namespace > LocationIndicator Class : Append Method
要拼接的坐标定位器。
拼接一个坐标定位器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function Append( _
   ByVal location As LocationIndicator _
) As LocationIndicator
'Usage

Dim instance As LocationIndicator
Dim location As LocationIndicator
Dim value As LocationIndicator

value = instance.Append(location)
public LocationIndicator Append(
   LocationIndicator location
)
public:
LocationIndicator^ Append(
   LocationIndicator^ location
)

Parameters

location
要拼接的坐标定位器。

Return Value

返回拼接后的坐标定位器。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Class
LocationIndicator Members


%%ItemTitle%%

Enum Method

GrapeCity.Forguncy.Plugin Namespace > LocationIndicator Class : Enum Method
遍历当前坐标定位器以及该链表中所有的父坐标定位器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<IteratorStateMachineAttribute(GrapeCity.Forguncy.Plugin.LocationIndicator+d__10)>
Public Function Enum() As IEnumerable(Of LocationIndicator)
'Usage

Dim instance As LocationIndicator
Dim value As IEnumerable(Of LocationIndicator)

value = instance.Enum()
[IteratorStateMachine(GrapeCity.Forguncy.Plugin.LocationIndicator+d__10)]
public IEnumerable<LocationIndicator> Enum()
[IteratorStateMachine(GrapeCity.Forguncy.Plugin.LocationIndicator+d__10)]
public:
IEnumerable<LocationIndicator^>^ Enum();

Return Value

返回包括父坐标定位器在内的链表中的坐标定位器。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Class
LocationIndicator Members


%%ItemTitle%%

GetPathString Method

GrapeCity.Forguncy.Plugin Namespace > LocationIndicator Class : GetPathString Method
拼接符
过滤方法
基于拼接符和过滤方法返回坐标定位器的查找路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetPathString( _
   ByVal seperator As String, _
   Optional ByVal filter As Func(Of LocationIndicator,Boolean) _
) As String
'Usage

Dim instance As LocationIndicator
Dim seperator As String
Dim filter As Func(Of LocationIndicator,Boolean)
Dim value As String

value = instance.GetPathString(seperator, filter)
public string GetPathString(
   string seperator,
   Func<LocationIndicator,bool> filter
)
public:
String^ GetPathString(
   String^ seperator,
   Func<LocationIndicator^,bool>^ filter
)

Parameters

seperator
拼接符
filter
过滤方法

Return Value

返回查找路径。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Class
LocationIndicator Members


%%PageItemTitle%% $$Properties$$

LocationIndicator Class Properties

GrapeCity.Forguncy.Plugin Namespace : LocationIndicator Class

For a list of all members of this type, see LocationIndicator members.

Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
Public Property | Parent | 父节点
Public Property | Root | 根坐标定位器。
Top
See Also

Reference

LocationIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

DisplayString Property (LocationIndicator)

GrapeCity.Forguncy.Plugin Namespace > LocationIndicator Class : DisplayString Property
当前坐标定位器的显示文字。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property DisplayString As String
'Usage

Dim instance As LocationIndicator
Dim value As String

value = instance.DisplayString
public abstract string DisplayString {get;}
public:
abstract property String^ DisplayString {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Class
LocationIndicator Members


%%ItemTitle%%

FullString Property

GrapeCity.Forguncy.Plugin Namespace > LocationIndicator Class : FullString Property
返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FullString As String
'Usage

Dim instance As LocationIndicator
Dim value As String

value = instance.FullString
public string FullString {get;}
public:
property String^ FullString {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Class
LocationIndicator Members


%%ItemTitle%%

Parent Property

GrapeCity.Forguncy.Plugin Namespace > LocationIndicator Class : Parent Property
父节点
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As LocationIndicator
'Usage

Dim instance As LocationIndicator
Dim value As LocationIndicator

value = instance.Parent
public LocationIndicator Parent {get;}
public:
property LocationIndicator^ Parent {
   LocationIndicator^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Class
LocationIndicator Members


%%ItemTitle%%

Root Property

GrapeCity.Forguncy.Plugin Namespace > LocationIndicator Class : Root Property
根坐标定位器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Root As LocationIndicator
'Usage

Dim instance As LocationIndicator
Dim value As LocationIndicator

value = instance.Root
public LocationIndicator Root {get;}
public:
property LocationIndicator^ Root {
   LocationIndicator^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicator Class
LocationIndicator Members


%%PageItemTitle%%

LocationIndicatorExtension Class
Members

GrapeCity.Forguncy.Plugin Namespace : LocationIndicatorExtension Class
坐标定位器扩展类。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<ExtensionAttribute()>
Public MustInherit NotInheritable Class LocationIndicatorExtension
'Usage

Dim instance As LocationIndicatorExtension
[Extension()]
public static class LocationIndicatorExtension
[Extension()]
public ref class LocationIndicatorExtension abstract sealed
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicatorExtension

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicatorExtension Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

LocationIndicatorExtension Class Members
Methods

GrapeCity.Forguncy.Plugin Namespace : LocationIndicatorExtension Class

The following tables list the members exposed by LocationIndicatorExtension.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AppendProperty | 增加一个属性定位器。
static (Shared in Visual Basic) | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
static (Shared in Visual Basic) | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
Top
See Also

Reference

LocationIndicatorExtension Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

LocationIndicatorExtension Class Methods

GrapeCity.Forguncy.Plugin Namespace : LocationIndicatorExtension Class

For a list of all members of this type, see LocationIndicatorExtension members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AppendProperty | 增加一个属性定位器。
static (Shared in Visual Basic) | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
static (Shared in Visual Basic) | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
Top
See Also

Reference

LocationIndicatorExtension Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

AppendProperty Method

GrapeCity.Forguncy.Plugin Namespace > LocationIndicatorExtension Class : AppendProperty Method
当前坐标定位器。
要增加的属性定位器的名称。
增加一个属性定位器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<ExtensionAttribute()>
Public Shared Function AppendProperty( _
   ByVal current As LocationIndicator, _
   ByVal propertyName As String _
) As LocationIndicator
'Usage

Dim current As LocationIndicator
Dim propertyName As String
Dim value As LocationIndicator

value = LocationIndicatorExtension.AppendProperty(current, propertyName)
[Extension()]
public static LocationIndicator AppendProperty(
   LocationIndicator current,
   string propertyName
)
[Extension()]
public:
static LocationIndicator^ AppendProperty(
   LocationIndicator^ current,
   String^ propertyName
)

Parameters

current
当前坐标定位器。
propertyName
要增加的属性定位器的名称。

Return Value

返回增加了属性定位器的坐标定位器。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicatorExtension Class
LocationIndicatorExtension Members


%%ItemTitle%%

ContainObject Method

GrapeCity.Forguncy.Plugin Namespace > LocationIndicatorExtension Class : ContainObject Method
当前坐标定位器。
查找的对象。
坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<ExtensionAttribute()>
Public Shared Function ContainObject( _
   ByVal current As LocationIndicator, _
   ByVal obj As Object _
) As Boolean
'Usage

Dim current As LocationIndicator
Dim obj As Object
Dim value As Boolean

value = LocationIndicatorExtension.ContainObject(current, obj)
[Extension()]
public static bool ContainObject(
   LocationIndicator current,
   object obj
)
[Extension()]
public:
static bool ContainObject(
   LocationIndicator^ current,
   Object^ obj
)

Parameters

current
当前坐标定位器。
obj
查找的对象。

Return Value

返回true则包含，否则不包含。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicatorExtension Class
LocationIndicatorExtension Members


%%ItemTitle%%

ContainProperty Method

GrapeCity.Forguncy.Plugin Namespace > LocationIndicatorExtension Class : ContainProperty Method
当前坐标定位器。
查找的属性名称。
坐标定位器所在链表中的属性定位器中是否包含特定的属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<ExtensionAttribute()>
Public Shared Function ContainProperty( _
   ByVal current As LocationIndicator, _
   ByVal property As String _
) As Boolean
'Usage

Dim current As LocationIndicator
Dim property As String
Dim value As Boolean

value = LocationIndicatorExtension.ContainProperty(current, property)
[Extension()]
public static bool ContainProperty(
   LocationIndicator current,
   string property
)
[Extension()]
public:
static bool ContainProperty(
   LocationIndicator^ current,
   String^ property
)

Parameters

current
当前坐标定位器。
property
查找的属性名称。

Return Value

返回true则包含，否则不包含。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocationIndicatorExtension Class
LocationIndicatorExtension Members


%%PageItemTitle%%

NameIndicator Class
Members

GrapeCity.Forguncy.Plugin Namespace : NameIndicator Class
名称定位器，一种特定类型的坐标定位器。
Object Model
NameIndicator ClassLocationIndicator ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class NameIndicator
   Inherits LocationIndicator
'Usage

Dim instance As NameIndicator
public class NameIndicator : LocationIndicator
public ref class NameIndicator : public LocationIndicator
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.PropertyIndicator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameIndicator Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

NameIndicator Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : NameIndicator Class

The following tables list the members exposed by NameIndicator.

Public Constructors
 | Name | Description
Public Constructor | NameIndicator Constructor |
Top
Public Properties
 | Name | Description
Public Property | DisplayString | Overridden. 当前坐标定位器的显示文字。
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Name | 当前坐标定位器的名称。
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

NameIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

NameIndicator Constructor

GrapeCity.Forguncy.Plugin Namespace > NameIndicator Class : NameIndicator Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NameIndicator()
public NameIndicator()
public:
NameIndicator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameIndicator Class
NameIndicator Members


%%PageItemTitle%% $$Properties$$

NameIndicator Class Properties

GrapeCity.Forguncy.Plugin Namespace : NameIndicator Class

For a list of all members of this type, see NameIndicator members.

Public Properties
 | Name | Description
Public Property | DisplayString | Overridden. 当前坐标定位器的显示文字。
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Name | 当前坐标定位器的名称。
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

NameIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

DisplayString Property (NameIndicator)

GrapeCity.Forguncy.Plugin Namespace > NameIndicator Class : DisplayString Property
当前坐标定位器的显示文字。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property DisplayString As String
'Usage

Dim instance As NameIndicator
Dim value As String

value = instance.DisplayString
public override string DisplayString {get;}
public:
property String^ DisplayString {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameIndicator Class
NameIndicator Members


%%ItemTitle%%

Name Property (NameIndicator)

GrapeCity.Forguncy.Plugin Namespace > NameIndicator Class : Name Property
当前坐标定位器的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As NameIndicator
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NameIndicator Class
NameIndicator Members


%%PageItemTitle%%

ObjectIndicator Class
Members

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator Class
对象定位器，一种特定类型的坐标定位器。
Object Model
ObjectIndicator ClassLocationIndicator ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class ObjectIndicator
   Inherits LocationIndicator
'Usage

Dim instance As ObjectIndicator
public abstract class ObjectIndicator : LocationIndicator
public ref class ObjectIndicator abstract : public LocationIndicator
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectIndicator Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ObjectIndicator Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator Class

The following tables list the members exposed by ObjectIndicator.

Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Object | 对象定位器中的对象。
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

ObjectIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

ObjectIndicator Class Properties

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator Class

For a list of all members of this type, see ObjectIndicator members.

Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Object | 对象定位器中的对象。
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

ObjectIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

Object Property (ObjectIndicator)

GrapeCity.Forguncy.Plugin Namespace > ObjectIndicator Class : Object Property
对象定位器中的对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Object As Object
'Usage

Dim instance As ObjectIndicator
Dim value As Object

value = instance.Object
public object Object {get;}
public:
property Object^ Object {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectIndicator Class
ObjectIndicator Members


%%PageItemTitle%%

ObjectIndicator<T> Class
Members

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator<T> Class
特定类型。
特定类型的对象定位器。
Object Model
ObjectIndicator<T> ClassLocationIndicator ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class ObjectIndicator(Of T)
   Inherits ObjectIndicator
'Usage

Dim instance As ObjectIndicator(Of T)
public abstract class ObjectIndicator<T> : ObjectIndicator
generic<typename T>
public ref class ObjectIndicator abstract : public ObjectIndicator
Type Parameters
T
特定类型。
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectIndicator<T> Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ObjectIndicator<T> Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator<T> Class

The following tables list the members exposed by ObjectIndicator<T>.

Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Object | 特定类型的对象。
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

ObjectIndicator<T> Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

ObjectIndicator<T> Class Properties

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator<T> Class

For a list of all members of this type, see ObjectIndicator<T> members.

Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Object | 特定类型的对象。
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

ObjectIndicator<T> Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

OrderWeightAttribute Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : OrderWeightAttribute Class
插件或插件内部属性的权重, 权重越大位置越靠后。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class OrderWeightAttribute
   Inherits System.Attribute
'Usage

Dim instance As OrderWeightAttribute
public class OrderWeightAttribute : System.Attribute
public ref class OrderWeightAttribute : public System.Attribute
Example
  • C#
public class SignatureCellType : CellType
{
    [OrderWeight(0)]
    public double DotSize
    {
        get;
        set;
    }

    [OrderWeight(1)]
    public double LineMinWidth
    {
        get;
        set;
    }

    ...
}
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.OrderWeightAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderWeightAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

OrderWeightAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : OrderWeightAttribute Class

The following tables list the members exposed by OrderWeightAttribute.

Public Constructors
 | Name | Description
Public Constructor | OrderWeightAttribute Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

OrderWeightAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

OrderWeightAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > OrderWeightAttribute Class : OrderWeightAttribute Constructor
权重值，默认值为0。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   Optional ByVal orderWeight As Integer _
)
'Usage

Dim orderWeight As Integer

Dim instance As New OrderWeightAttribute(orderWeight)
public OrderWeightAttribute(
   int orderWeight
)
public:
OrderWeightAttribute(
   int orderWeight
)

Parameters

orderWeight
权重值，默认值为0。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrderWeightAttribute Class
OrderWeightAttribute Members


%%PageItemTitle%%

PageMetadataJsonIgnoreAttribute Class
Members

GrapeCity.Forguncy.Plugin Namespace : PageMetadataJsonIgnoreAttribute Class
忽略运行页面时不需要的属性，例如只用于单元格类型预览的属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PageMetadataJsonIgnoreAttribute
   Inherits System.Attribute
'Usage

Dim instance As PageMetadataJsonIgnoreAttribute
public class PageMetadataJsonIgnoreAttribute : System.Attribute
public ref class PageMetadataJsonIgnoreAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.PageMetadataJsonIgnoreAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageMetadataJsonIgnoreAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

PageMetadataJsonIgnoreAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : PageMetadataJsonIgnoreAttribute Class

The following tables list the members exposed by PageMetadataJsonIgnoreAttribute.

Public Constructors
 | Name | Description
Public Constructor | PageMetadataJsonIgnoreAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

PageMetadataJsonIgnoreAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

PageMetadataJsonIgnoreAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > PageMetadataJsonIgnoreAttribute Class : PageMetadataJsonIgnoreAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PageMetadataJsonIgnoreAttribute()
public PageMetadataJsonIgnoreAttribute()
public:
PageMetadataJsonIgnoreAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PageMetadataJsonIgnoreAttribute Class
PageMetadataJsonIgnoreAttribute Members


%%PageItemTitle%%

PluginUtilities Class
Members

GrapeCity.Forguncy.Plugin Namespace : PluginUtilities Class
插件公用类。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class PluginUtilities
'Usage

Dim instance As PluginUtilities
public static class PluginUtilities
public ref class PluginUtilities abstract sealed
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.PluginUtilities

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PluginUtilities Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

PluginUtilities Class Members
Methods

GrapeCity.Forguncy.Plugin Namespace : PluginUtilities Class

The following tables list the members exposed by PluginUtilities.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CommonClone | 克隆方法，返回一个对象的复制品。
Top
See Also

Reference

PluginUtilities Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

PluginUtilities Class Methods

GrapeCity.Forguncy.Plugin Namespace : PluginUtilities Class

For a list of all members of this type, see PluginUtilities members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CommonClone | 克隆方法，返回一个对象的复制品。
Top
See Also

Reference

PluginUtilities Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

CommonClone Method

GrapeCity.Forguncy.Plugin Namespace > PluginUtilities Class : CommonClone Method
原对象。
克隆方法，返回一个对象的复制品。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Shared Function CommonClone( _
   ByVal obj As Object _
) As Object
'Usage

Dim obj As Object
Dim value As Object

value = PluginUtilities.CommonClone(obj)
public static object CommonClone(
   object obj
)
public:
static Object^ CommonClone(
   Object^ obj
)

Parameters

obj
原对象。

Return Value

克隆对象。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PluginUtilities Class
PluginUtilities Members


%%PageItemTitle%%

PropertyIndicator Class
Members

GrapeCity.Forguncy.Plugin Namespace : PropertyIndicator Class
属性定位器，一种特定类型的坐标定位器。
Object Model
PropertyIndicator ClassLocationIndicator ClassLocationIndicator Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PropertyIndicator
   Inherits NameIndicator
'Usage

Dim instance As PropertyIndicator
public class PropertyIndicator : NameIndicator
public ref class PropertyIndicator : public NameIndicator
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.PropertyIndicator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyIndicator Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

PropertyIndicator Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : PropertyIndicator Class

The following tables list the members exposed by PropertyIndicator.

Public Constructors
 | Name | Description
Public Constructor | PropertyIndicator Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。 (Inherited from GrapeCity.Forguncy.Plugin.NameIndicator)
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Name | 当前坐标定位器的名称。 (Inherited from GrapeCity.Forguncy.Plugin.NameIndicator)
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

PropertyIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

PropertyIndicator Constructor

GrapeCity.Forguncy.Plugin Namespace > PropertyIndicator Class : PropertyIndicator Constructor
属性名称。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal propertyName As String _
)
'Usage

Dim propertyName As String

Dim instance As New PropertyIndicator(propertyName)
public PropertyIndicator(
   string propertyName
)
public:
PropertyIndicator(
   String^ propertyName
)

Parameters

propertyName
属性名称。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PropertyIndicator Class
PropertyIndicator Members


%%PageItemTitle%%

SaveJsonIgnoreAttribute Class
Members

GrapeCity.Forguncy.Plugin Namespace : SaveJsonIgnoreAttribute Class
忽略不需要保存到文档的属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class SaveJsonIgnoreAttribute
   Inherits System.Attribute
'Usage

Dim instance As SaveJsonIgnoreAttribute
public class SaveJsonIgnoreAttribute : System.Attribute
public ref class SaveJsonIgnoreAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.SaveJsonIgnoreAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveJsonIgnoreAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

SaveJsonIgnoreAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : SaveJsonIgnoreAttribute Class

The following tables list the members exposed by SaveJsonIgnoreAttribute.

Public Constructors
 | Name | Description
Public Constructor | SaveJsonIgnoreAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

SaveJsonIgnoreAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

SaveJsonIgnoreAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > SaveJsonIgnoreAttribute Class : SaveJsonIgnoreAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveJsonIgnoreAttribute()
public SaveJsonIgnoreAttribute()
public:
SaveJsonIgnoreAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SaveJsonIgnoreAttribute Class
SaveJsonIgnoreAttribute Members


%%PageItemTitle%%

TableCheckInfo Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : TableCheckInfo Class
查找数据表的引用时返回的数据表的位置信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class TableCheckInfo
'Usage

Dim instance As TableCheckInfo
public class TableCheckInfo
public ref class TableCheckInfo
Example
  • C#
TableCheckInfo info = new TableCheckInfo("table1");
info.AddColumns("column1");
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.TableCheckInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCheckInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

TableCheckInfo Class Members
Fields Properties Methods

GrapeCity.Forguncy.Plugin Namespace : TableCheckInfo Class

The following tables list the members exposed by TableCheckInfo.

Public Constructors
 | Name | Description
Public Constructor | TableCheckInfo Constructor | 构造函数。
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | IndicateStringSeperator | 废弃属性。
Top
Public Properties
 | Name | Description
Public Property | ColumnNames | 所有的字段名。
Public Property | TableName | 数据表名。
Top
Public Methods
 | Name | Description
Public Method | AddColumns | 添加一个或多个字段。
Top
See Also

Reference

TableCheckInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

TableCheckInfo Constructor

GrapeCity.Forguncy.Plugin Namespace > TableCheckInfo Class : TableCheckInfo Constructor
数据表名。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal tableName As String _
)
'Usage

Dim tableName As String

Dim instance As New TableCheckInfo(tableName)
public TableCheckInfo(
   string tableName
)
public:
TableCheckInfo(
   String^ tableName
)

Parameters

tableName
数据表名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCheckInfo Class
TableCheckInfo Members


%%PageItemTitle%% $$Methods$$

TableCheckInfo Class Methods

GrapeCity.Forguncy.Plugin Namespace : TableCheckInfo Class

For a list of all members of this type, see TableCheckInfo members.

Public Methods
 | Name | Description
Public Method | AddColumns | 添加一个或多个字段。
Top
See Also

Reference

TableCheckInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

AddColumns Method

GrapeCity.Forguncy.Plugin Namespace > TableCheckInfo Class : AddColumns Method
添加一个或多个字段。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Sub AddColumns( _
   ByVal ParamArray fields() As String _
)
'Usage

Dim instance As TableCheckInfo
Dim fields() As String

instance.AddColumns(fields)
public void AddColumns(
   params string[] fields
)
public:
void AddColumns(
   ... array<String^>^ fields
)

Parameters

fields
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCheckInfo Class
TableCheckInfo Members


%%PageItemTitle%% $$Properties$$

TableCheckInfo Class Properties

GrapeCity.Forguncy.Plugin Namespace : TableCheckInfo Class

For a list of all members of this type, see TableCheckInfo members.

Public Properties
 | Name | Description
Public Property | ColumnNames | 所有的字段名。
Public Property | TableName | 数据表名。
Top
See Also

Reference

TableCheckInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

ColumnNames Property

GrapeCity.Forguncy.Plugin Namespace > TableCheckInfo Class : ColumnNames Property
所有的字段名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColumnNames As IList(Of String)
'Usage

Dim instance As TableCheckInfo
Dim value As IList(Of String)

instance.ColumnNames = value

value = instance.ColumnNames
public IList<string> ColumnNames {get; set;}
public:
property IList<String^>^ ColumnNames {
   IList<String^>^ get();
   void set (    IList<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCheckInfo Class
TableCheckInfo Members


%%ItemTitle%%

TableName Property (TableCheckInfo)

GrapeCity.Forguncy.Plugin Namespace > TableCheckInfo Class : TableName Property
数据表名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property TableName As String
'Usage

Dim instance As TableCheckInfo
Dim value As String

value = instance.TableName
public string TableName {get;}
public:
property String^ TableName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCheckInfo Class
TableCheckInfo Members


%%PageItemTitle%% $$Fields$$

TableCheckInfo Class Fields

GrapeCity.Forguncy.Plugin Namespace : TableCheckInfo Class

For a list of all members of this type, see TableCheckInfo members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | IndicateStringSeperator | 废弃属性。
Top
See Also

Reference

TableCheckInfo Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

IndicateStringSeperator Field

GrapeCity.Forguncy.Plugin Namespace > TableCheckInfo Class : IndicateStringSeperator Field
废弃属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

<ObsoleteAttribute("Obsolete attribute.")>
Public Shared ReadOnly IndicateStringSeperator As String
'Usage

Dim value As String

value = TableCheckInfo.IndicateStringSeperator
[Obsolete("Obsolete attribute.")]
public static readonly string IndicateStringSeperator
[Obsolete("Obsolete attribute.")]
public:
static readonly String^ IndicateStringSeperator
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableCheckInfo Class
TableCheckInfo Members


%%PageItemTitle%%

WindowsIgnorePropertyAttribute Class
Members

GrapeCity.Forguncy.Plugin Namespace : WindowsIgnorePropertyAttribute Class
具有此标签的属性在Windows认证模式下将不会自动生成UI
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class WindowsIgnorePropertyAttribute
   Inherits System.Attribute
'Usage

Dim instance As WindowsIgnorePropertyAttribute
public class WindowsIgnorePropertyAttribute : System.Attribute
public ref class WindowsIgnorePropertyAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.WindowsIgnorePropertyAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WindowsIgnorePropertyAttribute Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

WindowsIgnorePropertyAttribute Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : WindowsIgnorePropertyAttribute Class

The following tables list the members exposed by WindowsIgnorePropertyAttribute.

Public Constructors
 | Name | Description
Public Constructor | WindowsIgnorePropertyAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

WindowsIgnorePropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

WindowsIgnorePropertyAttribute Constructor

GrapeCity.Forguncy.Plugin Namespace > WindowsIgnorePropertyAttribute Class : WindowsIgnorePropertyAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WindowsIgnorePropertyAttribute()
public WindowsIgnorePropertyAttribute()
public:
WindowsIgnorePropertyAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WindowsIgnorePropertyAttribute Class
WindowsIgnorePropertyAttribute Members


%%PageItemTitle%%

AuthenticationMode Enumeration

GrapeCity.Forguncy.Plugin Namespace : AuthenticationMode Enumeration
认证模式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum AuthenticationMode
   Inherits System.Enum
'Usage

Dim instance As AuthenticationMode
public enum AuthenticationMode : System.Enum
public enum class AuthenticationMode : public System.Enum
Members
Member | Description
Forms | 普通登录认证模式。
SecurityProvider | 第三方集成认证模式。
Windows | Windows域认证模式。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.AuthenticationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ForguncyErrorType Enumeration

GrapeCity.Forguncy.Plugin Namespace : ForguncyErrorType Enumeration
运行页面时，系统内部会进行出错检查并显示在错误列表中，会根据出错类型显示不同的信息，并影响页面是否能够运行起来。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyErrorType
   Inherits System.Enum
'Usage

Dim instance As ForguncyErrorType
public enum ForguncyErrorType : System.Enum
public enum class ForguncyErrorType : public System.Enum
Members
Member | Description
Error | 出错信息类型：错误，会导致页面运行不了。
Warning | 出错信息类型：提醒，页面可以运行，但是出错部分功能可能会有问题。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.ForguncyErrorType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ForguncyTableColumnType Enumeration

GrapeCity.Forguncy.Plugin Namespace : ForguncyTableColumnType Enumeration
内建字段的值的类型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyTableColumnType
   Inherits System.Enum
'Usage

Dim instance As ForguncyTableColumnType
public enum ForguncyTableColumnType : System.Enum
public enum class ForguncyTableColumnType : public System.Enum
Members
Member | Description
Attachment | 附件。
Bool | 是/否。
DateTime | 日期。
Decimel | 小数。
Image | 图片。
Int | 整数。
Text | 文本。
Time | 时间。
User | 用户。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.ForguncyTableColumnType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ForguncyTableType Enumeration

GrapeCity.Forguncy.Plugin Namespace : ForguncyTableType Enumeration
数据表的类型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum ForguncyTableType
   Inherits System.Enum
'Usage

Dim instance As ForguncyTableType
public enum ForguncyTableType : System.Enum
public enum class ForguncyTableType : public System.Enum
Members
Member | Description
BuiltInCopyExternalTable | 外联表副本。
BuiltInCustomView | 内建表视图。
BuiltInTable | 内建表。
BuiltInUserInfoView | 用户信息视图。
BuiltInWorkflowHistoryView | 工作流历史视图。
LinkedTable | 外联表。
LinkedView | 外联表视图。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.ForguncyTableType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

TableColumnKind Enumeration

GrapeCity.Forguncy.Plugin Namespace : TableColumnKind Enumeration
字段分类。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Enum TableColumnKind
   Inherits System.Enum
'Usage

Dim instance As TableColumnKind
public enum TableColumnKind : System.Enum
public enum class TableColumnKind : public System.Enum
Members
Member | Description
BindingColumn | 普通字段。
FormulaColumn | 公式字段。
StatisticsColumn | 统计字段。
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.TableColumnKind

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

IBindingInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IBindingInfo Interface
单元格的数据绑定信息，即一旦单元格绑定到A表的B字段,如果页面中存在A表，那么该单元格就会显示当前行的B字段的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IBindingInfo
'Usage

Dim instance As IBindingInfo
public interface IBindingInfo
public interface class IBindingInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBindingInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IBindingInfo Interface Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : IBindingInfo Interface

The following tables list the members exposed by IBindingInfo.

Public Properties
 | Name | Description
Property | ColumnName | 绑定的数据列名。
Property | TableName | 绑定的数据表名。
Top
Public Methods
 | Name | Description
Method | GetExtendColumnName | 表中扩展列的显示名。例如，日期列的年、月、日信息。
Method | GetLastColumnName | 如果有多级绑定的话，返回绑定信息中的最后一个数据列名，否则返回当前绑定级别的数据列名。
Method | GetLastTableName | 如果有多级绑定的话，返回绑定信息中的最后一个数据表名，否则返回当前绑定级别的数据表名。
Top
See Also

Reference

IBindingInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IBindingInfo Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IBindingInfo Interface

For a list of all members of this type, see IBindingInfo members.

Public Methods
 | Name | Description
Method | GetExtendColumnName | 表中扩展列的显示名。例如，日期列的年、月、日信息。
Method | GetLastColumnName | 如果有多级绑定的话，返回绑定信息中的最后一个数据列名，否则返回当前绑定级别的数据列名。
Method | GetLastTableName | 如果有多级绑定的话，返回绑定信息中的最后一个数据表名，否则返回当前绑定级别的数据表名。
Top
See Also

Reference

IBindingInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetExtendColumnName Method

GrapeCity.Forguncy.Plugin Namespace > IBindingInfo Interface : GetExtendColumnName Method
表中扩展列的显示名。例如，日期列的年、月、日信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetExtendColumnName() As String
'Usage

Dim instance As IBindingInfo
Dim value As String

value = instance.GetExtendColumnName()
string GetExtendColumnName()
String^ GetExtendColumnName();

Return Value

扩展列的显示名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBindingInfo Interface
IBindingInfo Members


%%ItemTitle%%

GetLastColumnName Method

GrapeCity.Forguncy.Plugin Namespace > IBindingInfo Interface : GetLastColumnName Method
如果有多级绑定的话，返回绑定信息中的最后一个数据列名，否则返回当前绑定级别的数据列名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetLastColumnName() As String
'Usage

Dim instance As IBindingInfo
Dim value As String

value = instance.GetLastColumnName()
string GetLastColumnName()
String^ GetLastColumnName();

Return Value

返回绑定信息中的最后一个数据列名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBindingInfo Interface
IBindingInfo Members


%%ItemTitle%%

GetLastTableName Method

GrapeCity.Forguncy.Plugin Namespace > IBindingInfo Interface : GetLastTableName Method
如果有多级绑定的话，返回绑定信息中的最后一个数据表名，否则返回当前绑定级别的数据表名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetLastTableName() As String
'Usage

Dim instance As IBindingInfo
Dim value As String

value = instance.GetLastTableName()
string GetLastTableName()
String^ GetLastTableName();

Return Value

返回绑定信息中的最后一个数据表名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBindingInfo Interface
IBindingInfo Members


%%PageItemTitle%% $$Properties$$

IBindingInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IBindingInfo Interface

For a list of all members of this type, see IBindingInfo members.

Public Properties
 | Name | Description
Property | ColumnName | 绑定的数据列名。
Property | TableName | 绑定的数据表名。
Top
See Also

Reference

IBindingInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

ColumnName Property (IBindingInfo)

GrapeCity.Forguncy.Plugin Namespace > IBindingInfo Interface : ColumnName Property
绑定的数据列名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ColumnName As String
'Usage

Dim instance As IBindingInfo
Dim value As String

value = instance.ColumnName
string ColumnName {get;}
property String^ ColumnName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBindingInfo Interface
IBindingInfo Members


%%ItemTitle%%

TableName Property (IBindingInfo)

GrapeCity.Forguncy.Plugin Namespace > IBindingInfo Interface : TableName Property
绑定的数据表名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property TableName As String
'Usage

Dim instance As IBindingInfo
Dim value As String

value = instance.TableName
string TableName {get;}
property String^ TableName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBindingInfo Interface
IBindingInfo Members


%%PageItemTitle%%

ICellInfoBase Interface
Members

GrapeCity.Forguncy.Plugin Namespace : ICellInfoBase Interface
单元格的信息。
Object Model
ICellInfoBase InterfaceIBindingInfo InterfaceIListViewInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ICellInfoBase
'Usage

Dim instance As ICellInfoBase
public interface ICellInfoBase
public interface class ICellInfoBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ICellInfoBase Interface Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ICellInfoBase Interface

The following tables list the members exposed by ICellInfoBase.

Public Properties
 | Name | Description
Property | BindingInfo | 单元格的数据绑定信息。
Property | ColumnIndex | 获取单元格所在列的索引。
Property | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。
Property | ListViewInfo | 单元格所在表格的信息。
Property | PageName | 单元格所在的页面名称。
Property | RowIndex | 获取单元格所在行的索引
Property | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。
Top
Public Methods
 | Name | Description
Method | GetFormulaReferObject | 返回单元格对应的公式对象。
Top
See Also

Reference

ICellInfoBase Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

ICellInfoBase Interface Methods

GrapeCity.Forguncy.Plugin Namespace : ICellInfoBase Interface

For a list of all members of this type, see ICellInfoBase members.

Public Methods
 | Name | Description
Method | GetFormulaReferObject | 返回单元格对应的公式对象。
Top
See Also

Reference

ICellInfoBase Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetFormulaReferObject Method

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : GetFormulaReferObject Method
返回单元格对应的公式对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetFormulaReferObject( _
   Optional ByVal rowRelative As Boolean, _
   Optional ByVal columnRelative As Boolean _
) As IFormulaReferObject
'Usage

Dim instance As ICellInfoBase
Dim rowRelative As Boolean
Dim columnRelative As Boolean
Dim value As IFormulaReferObject

value = instance.GetFormulaReferObject(rowRelative, columnRelative)
IFormulaReferObject GetFormulaReferObject(
   bool rowRelative,
   bool columnRelative
)
IFormulaReferObject^ GetFormulaReferObject(
   bool rowRelative,
   bool columnRelative
)

Parameters

rowRelative
columnRelative
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%PageItemTitle%% $$Properties$$

ICellInfoBase Interface Properties

GrapeCity.Forguncy.Plugin Namespace : ICellInfoBase Interface

For a list of all members of this type, see ICellInfoBase members.

Public Properties
 | Name | Description
Property | BindingInfo | 单元格的数据绑定信息。
Property | ColumnIndex | 获取单元格所在列的索引。
Property | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。
Property | ListViewInfo | 单元格所在表格的信息。
Property | PageName | 单元格所在的页面名称。
Property | RowIndex | 获取单元格所在行的索引
Property | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。
Top
See Also

Reference

ICellInfoBase Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

BindingInfo Property (ICellInfoBase)

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : BindingInfo Property
单元格的数据绑定信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BindingInfo As IBindingInfo
'Usage

Dim instance As ICellInfoBase
Dim value As IBindingInfo

value = instance.BindingInfo
IBindingInfo BindingInfo {get;}
property IBindingInfo^ BindingInfo {
   IBindingInfo^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%ItemTitle%%

ColumnIndex Property (ICellInfoBase)

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : ColumnIndex Property
获取单元格所在列的索引。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ColumnIndex As Integer
'Usage

Dim instance As ICellInfoBase
Dim value As Integer

value = instance.ColumnIndex
int ColumnIndex {get;}
property int ColumnIndex {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%ItemTitle%%

ColumnSpan Property

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : ColumnSpan Property
获取单元格上合并列的数量，没有合并时返回1。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ColumnSpan As Integer
'Usage

Dim instance As ICellInfoBase
Dim value As Integer

value = instance.ColumnSpan
int ColumnSpan {get;}
property int ColumnSpan {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%ItemTitle%%

ListViewInfo Property

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : ListViewInfo Property
单元格所在表格的信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ListViewInfo As IListViewInfo
'Usage

Dim instance As ICellInfoBase
Dim value As IListViewInfo

value = instance.ListViewInfo
IListViewInfo ListViewInfo {get;}
property IListViewInfo^ ListViewInfo {
   IListViewInfo^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%ItemTitle%%

PageName Property (ICellInfoBase)

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : PageName Property
单元格所在的页面名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PageName As String
'Usage

Dim instance As ICellInfoBase
Dim value As String

value = instance.PageName
string PageName {get;}
property String^ PageName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%ItemTitle%%

RowIndex Property (ICellInfoBase)

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : RowIndex Property
获取单元格所在行的索引
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property RowIndex As Integer
'Usage

Dim instance As ICellInfoBase
Dim value As Integer

value = instance.RowIndex
int RowIndex {get;}
property int RowIndex {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%ItemTitle%%

RowSpan Property

GrapeCity.Forguncy.Plugin Namespace > ICellInfoBase Interface : RowSpan Property
获取单元格上合并行的数量，没有合并时返回1。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property RowSpan As Integer
'Usage

Dim instance As ICellInfoBase
Dim value As Integer

value = instance.RowSpan
int RowSpan {get;}
property int RowSpan {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICellInfoBase Interface
ICellInfoBase Members


%%PageItemTitle%%

IColumnInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IColumnInfo Interface
数据表中的字段信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IColumnInfo
'Usage

Dim instance As IColumnInfo
public interface IColumnInfo
public interface class IColumnInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IColumnInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IColumnInfo Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : IColumnInfo Interface

The following tables list the members exposed by IColumnInfo.

Public Properties
 | Name | Description
Property | ColumnKind | 字段的分类：普通字段，公式字段还是统计字段。
Property | ColumnName | 字段名称。
Property | ColumnType | 字段中值的类型。
Top
See Also

Reference

IColumnInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IColumnInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IColumnInfo Interface

For a list of all members of this type, see IColumnInfo members.

Public Properties
 | Name | Description
Property | ColumnKind | 字段的分类：普通字段，公式字段还是统计字段。
Property | ColumnName | 字段名称。
Property | ColumnType | 字段中值的类型。
Top
See Also

Reference

IColumnInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

ColumnKind Property

GrapeCity.Forguncy.Plugin Namespace > IColumnInfo Interface : ColumnKind Property
字段的分类：普通字段，公式字段还是统计字段。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ColumnKind As TableColumnKind
'Usage

Dim instance As IColumnInfo
Dim value As TableColumnKind

value = instance.ColumnKind
TableColumnKind ColumnKind {get;}
property TableColumnKind ColumnKind {
   TableColumnKind get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IColumnInfo Interface
IColumnInfo Members


%%ItemTitle%%

ColumnName Property (IColumnInfo)

GrapeCity.Forguncy.Plugin Namespace > IColumnInfo Interface : ColumnName Property
字段名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ColumnName As String
'Usage

Dim instance As IColumnInfo
Dim value As String

value = instance.ColumnName
string ColumnName {get;}
property String^ ColumnName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IColumnInfo Interface
IColumnInfo Members


%%ItemTitle%%

ColumnType Property

GrapeCity.Forguncy.Plugin Namespace > IColumnInfo Interface : ColumnType Property
字段中值的类型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ColumnType As ForguncyTableColumnType
'Usage

Dim instance As IColumnInfo
Dim value As ForguncyTableColumnType

value = instance.ColumnType
ForguncyTableColumnType ColumnType {get;}
property ForguncyTableColumnType ColumnType {
   ForguncyTableColumnType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IColumnInfo Interface
IColumnInfo Members


%%PageItemTitle%%

IFileUploadContext Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IFileUploadContext Interface
上传的文件需要的上下文信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IFileUploadContext
'Usage

Dim instance As IFileUploadContext
public interface IFileUploadContext
public interface class IFileUploadContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFileUploadContext Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IFileUploadContext Interface Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : IFileUploadContext Interface

The following tables list the members exposed by IFileUploadContext.

Public Properties
 | Name | Description
Property | SourceDocumentFolder | 活字格文件所在的文件夹路径。
Top
Public Methods
 | Name | Description
Method | GetForguncyUploadFilesFolderLocalPath | 返回上传文件的临时路径。
Method | GetForguncyUploadFilesRelativePath | 返回上传文件的相对路径（基于活字格文件所在目录）。
Top
See Also

Reference

IFileUploadContext Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IFileUploadContext Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IFileUploadContext Interface

For a list of all members of this type, see IFileUploadContext members.

Public Methods
 | Name | Description
Method | GetForguncyUploadFilesFolderLocalPath | 返回上传文件的临时路径。
Method | GetForguncyUploadFilesRelativePath | 返回上传文件的相对路径（基于活字格文件所在目录）。
Top
See Also

Reference

IFileUploadContext Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetForguncyUploadFilesFolderLocalPath Method

GrapeCity.Forguncy.Plugin Namespace > IFileUploadContext Interface : GetForguncyUploadFilesFolderLocalPath Method
返回上传文件的临时路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetForguncyUploadFilesFolderLocalPath() As String
'Usage

Dim instance As IFileUploadContext
Dim value As String

value = instance.GetForguncyUploadFilesFolderLocalPath()
string GetForguncyUploadFilesFolderLocalPath()
String^ GetForguncyUploadFilesFolderLocalPath();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFileUploadContext Interface
IFileUploadContext Members


%%ItemTitle%%

GetForguncyUploadFilesRelativePath Method

GrapeCity.Forguncy.Plugin Namespace > IFileUploadContext Interface : GetForguncyUploadFilesRelativePath Method
活字格文件所在的文件夹路径。
返回上传文件的相对路径（基于活字格文件所在目录）。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetForguncyUploadFilesRelativePath( _
   ByVal baseFolder As String _
) As String
'Usage

Dim instance As IFileUploadContext
Dim baseFolder As String
Dim value As String

value = instance.GetForguncyUploadFilesRelativePath(baseFolder)
string GetForguncyUploadFilesRelativePath(
   string baseFolder
)
String^ GetForguncyUploadFilesRelativePath(
   String^ baseFolder
)

Parameters

baseFolder
活字格文件所在的文件夹路径。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFileUploadContext Interface
IFileUploadContext Members


%%PageItemTitle%% $$Properties$$

IFileUploadContext Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IFileUploadContext Interface

For a list of all members of this type, see IFileUploadContext members.

Public Properties
 | Name | Description
Property | SourceDocumentFolder | 活字格文件所在的文件夹路径。
Top
See Also

Reference

IFileUploadContext Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

SourceDocumentFolder Property

GrapeCity.Forguncy.Plugin Namespace > IFileUploadContext Interface : SourceDocumentFolder Property
活字格文件所在的文件夹路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property SourceDocumentFolder As String
'Usage

Dim instance As IFileUploadContext
Dim value As String

value = instance.SourceDocumentFolder
string SourceDocumentFolder {get;}
property String^ SourceDocumentFolder {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFileUploadContext Interface
IFileUploadContext Members


%%PageItemTitle%%

IForceGenerateCell Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IForceGenerateCell Interface
在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IForceGenerateCell
'Usage

Dim instance As IForceGenerateCell
public interface IForceGenerateCell
public interface class IForceGenerateCell
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IForceGenerateCell Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IForceGenerateCell Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IForceGenerateCell Interface

The following tables list the members exposed by IForceGenerateCell.

Public Methods
 | Name | Description
Method | GetForceGenerateCells | 在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
Top
See Also

Reference

IForceGenerateCell Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IForceGenerateCell Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IForceGenerateCell Interface

For a list of all members of this type, see IForceGenerateCell members.

Public Methods
 | Name | Description
Method | GetForceGenerateCells | 在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
Top
See Also

Reference

IForceGenerateCell Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetForceGenerateCells Method

GrapeCity.Forguncy.Plugin Namespace > IForceGenerateCell Interface : GetForceGenerateCells Method
在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetForceGenerateCells() As IEnumerable(Of GenerateCellInfo)
'Usage

Dim instance As IForceGenerateCell
Dim value As IEnumerable(Of GenerateCellInfo)

value = instance.GetForceGenerateCells()
IEnumerable<GenerateCellInfo> GetForceGenerateCells()
IEnumerable<GenerateCellInfo^>^ GetForceGenerateCells();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IForceGenerateCell Interface
IForceGenerateCell Members


%%PageItemTitle%%

IFormulaReferObject Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IFormulaReferObject Interface
公式对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IFormulaReferObject
'Usage

Dim instance As IFormulaReferObject
public interface IFormulaReferObject
public interface class IFormulaReferObject
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormulaReferObject Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IFormulaReferObject Interface Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : IFormulaReferObject Interface

The following tables list the members exposed by IFormulaReferObject.

Public Properties
 | Name | Description
Property | PageName | 公式对象所在的页面名称。
Top
Public Methods
 | Name | Description
Method | GetGenerateCellInfo | 获取Cell信息。
Method | IsNormalFormula | 是否是公式。
Top
See Also

Reference

IFormulaReferObject Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IFormulaReferObject Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IFormulaReferObject Interface

For a list of all members of this type, see IFormulaReferObject members.

Public Methods
 | Name | Description
Method | GetGenerateCellInfo | 获取Cell信息。
Method | IsNormalFormula | 是否是公式。
Top
See Also

Reference

IFormulaReferObject Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetGenerateCellInfo Method

GrapeCity.Forguncy.Plugin Namespace > IFormulaReferObject Interface : GetGenerateCellInfo Method
获取Cell信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetGenerateCellInfo() As GenerateCellInfo
'Usage

Dim instance As IFormulaReferObject
Dim value As GenerateCellInfo

value = instance.GetGenerateCellInfo()
GenerateCellInfo GetGenerateCellInfo()
GenerateCellInfo^ GetGenerateCellInfo();

Return Value

Cell信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormulaReferObject Interface
IFormulaReferObject Members


%%ItemTitle%%

IsNormalFormula Method

GrapeCity.Forguncy.Plugin Namespace > IFormulaReferObject Interface : IsNormalFormula Method
是否是公式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function IsNormalFormula() As Boolean
'Usage

Dim instance As IFormulaReferObject
Dim value As Boolean

value = instance.IsNormalFormula()
bool IsNormalFormula()
bool IsNormalFormula();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormulaReferObject Interface
IFormulaReferObject Members


%%PageItemTitle%% $$Properties$$

IFormulaReferObject Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IFormulaReferObject Interface

For a list of all members of this type, see IFormulaReferObject members.

Public Properties
 | Name | Description
Property | PageName | 公式对象所在的页面名称。
Top
See Also

Reference

IFormulaReferObject Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

PageName Property (IFormulaReferObject)

GrapeCity.Forguncy.Plugin Namespace > IFormulaReferObject Interface : PageName Property
公式对象所在的页面名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PageName As String
'Usage

Dim instance As IFormulaReferObject
Dim value As String

value = instance.PageName
string PageName {get;}
property String^ PageName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IFormulaReferObject Interface
IFormulaReferObject Members


%%PageItemTitle%%

IListViewInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IListViewInfo Interface
页面中的表格信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IListViewInfo
'Usage

Dim instance As IListViewInfo
public interface IListViewInfo
public interface class IListViewInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IListViewInfo Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : IListViewInfo Interface

The following tables list the members exposed by IListViewInfo.

Public Properties
 | Name | Description
Property | AllowAddNewRow | 是否允许在表格中加行。
Property | AllowDeleteRow | 是否允许在表格中删行。
Property | AllowEditRow | 是否允许在表格中编辑。
Property | BindingTableName | 绑定的数据表名。
Property | ListViewName | 表格的名称。
Top
See Also

Reference

IListViewInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IListViewInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IListViewInfo Interface

For a list of all members of this type, see IListViewInfo members.

Public Properties
 | Name | Description
Property | AllowAddNewRow | 是否允许在表格中加行。
Property | AllowDeleteRow | 是否允许在表格中删行。
Property | AllowEditRow | 是否允许在表格中编辑。
Property | BindingTableName | 绑定的数据表名。
Property | ListViewName | 表格的名称。
Top
See Also

Reference

IListViewInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

AllowAddNewRow Property

GrapeCity.Forguncy.Plugin Namespace > IListViewInfo Interface : AllowAddNewRow Property
是否允许在表格中加行。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AllowAddNewRow As Boolean
'Usage

Dim instance As IListViewInfo
Dim value As Boolean

value = instance.AllowAddNewRow
bool AllowAddNewRow {get;}
property bool AllowAddNewRow {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfo Interface
IListViewInfo Members


%%ItemTitle%%

AllowDeleteRow Property

GrapeCity.Forguncy.Plugin Namespace > IListViewInfo Interface : AllowDeleteRow Property
是否允许在表格中删行。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AllowDeleteRow As Boolean
'Usage

Dim instance As IListViewInfo
Dim value As Boolean

value = instance.AllowDeleteRow
bool AllowDeleteRow {get;}
property bool AllowDeleteRow {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfo Interface
IListViewInfo Members


%%ItemTitle%%

AllowEditRow Property

GrapeCity.Forguncy.Plugin Namespace > IListViewInfo Interface : AllowEditRow Property
是否允许在表格中编辑。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AllowEditRow As Boolean
'Usage

Dim instance As IListViewInfo
Dim value As Boolean

value = instance.AllowEditRow
bool AllowEditRow {get;}
property bool AllowEditRow {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfo Interface
IListViewInfo Members


%%ItemTitle%%

BindingTableName Property

GrapeCity.Forguncy.Plugin Namespace > IListViewInfo Interface : BindingTableName Property
绑定的数据表名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property BindingTableName As String
'Usage

Dim instance As IListViewInfo
Dim value As String

value = instance.BindingTableName
string BindingTableName {get;}
property String^ BindingTableName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfo Interface
IListViewInfo Members


%%ItemTitle%%

ListViewName Property

GrapeCity.Forguncy.Plugin Namespace > IListViewInfo Interface : ListViewName Property
表格的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property ListViewName As String
'Usage

Dim instance As IListViewInfo
Dim value As String

value = instance.ListViewName
string ListViewName {get;}
property String^ ListViewName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfo Interface
IListViewInfo Members


%%PageItemTitle%%

IListViewInfoDesigner Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IListViewInfoDesigner Interface
页面中的表格信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IListViewInfoDesigner
   Inherits IListViewInfo
'Usage

Dim instance As IListViewInfoDesigner
public interface IListViewInfoDesigner : IListViewInfo
public interface class IListViewInfoDesigner : public IListViewInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfoDesigner Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IListViewInfoDesigner Interface Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : IListViewInfoDesigner Interface

The following tables list the members exposed by IListViewInfoDesigner.

Public Properties
 | Name | Description
Property | AllowAddNewRow | 是否允许在表格中加行。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | AllowDeleteRow | 是否允许在表格中删行。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | AllowEditRow | 是否允许在表格中编辑。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | BindingTableName | 绑定的数据表名。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | ListViewName | 表格的名称。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Top
Public Methods
 | Name | Description
Method | EnumAllColumnHeaderCells | 遍历列头区域中的所有合并后的有内容的单元格。 如果列头有多行，会返回所有列头上的Cell，请根据Cell上的RowIndex，ColumnIndex，RowSpan，ColumnSpan属性判断单元格在列头上的位置。
Method | EnumAllTemplateCells | 遍历模板行中的所有合并后的有内容的单元格。
Method | GetAllColumnNames | 获取所有列名。
Top
See Also

Reference

IListViewInfoDesigner Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IListViewInfoDesigner Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IListViewInfoDesigner Interface

For a list of all members of this type, see IListViewInfoDesigner members.

Public Methods
 | Name | Description
Method | EnumAllColumnHeaderCells | 遍历列头区域中的所有合并后的有内容的单元格。 如果列头有多行，会返回所有列头上的Cell，请根据Cell上的RowIndex，ColumnIndex，RowSpan，ColumnSpan属性判断单元格在列头上的位置。
Method | EnumAllTemplateCells | 遍历模板行中的所有合并后的有内容的单元格。
Method | GetAllColumnNames | 获取所有列名。
Top
See Also

Reference

IListViewInfoDesigner Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

EnumAllColumnHeaderCells Method

GrapeCity.Forguncy.Plugin Namespace > IListViewInfoDesigner Interface : EnumAllColumnHeaderCells Method
遍历列头区域中的所有合并后的有内容的单元格。 如果列头有多行，会返回所有列头上的Cell，请根据Cell上的RowIndex，ColumnIndex，RowSpan，ColumnSpan属性判断单元格在列头上的位置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumAllColumnHeaderCells() As IEnumerable(Of ICellInfoBase)
'Usage

Dim instance As IListViewInfoDesigner
Dim value As IEnumerable(Of ICellInfoBase)

value = instance.EnumAllColumnHeaderCells()
IEnumerable<ICellInfoBase> EnumAllColumnHeaderCells()
IEnumerable<ICellInfoBase^>^ EnumAllColumnHeaderCells();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfoDesigner Interface
IListViewInfoDesigner Members


%%ItemTitle%%

EnumAllTemplateCells Method

GrapeCity.Forguncy.Plugin Namespace > IListViewInfoDesigner Interface : EnumAllTemplateCells Method
遍历模板行中的所有合并后的有内容的单元格。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumAllTemplateCells() As IEnumerable(Of ICellInfoBase)
'Usage

Dim instance As IListViewInfoDesigner
Dim value As IEnumerable(Of ICellInfoBase)

value = instance.EnumAllTemplateCells()
IEnumerable<ICellInfoBase> EnumAllTemplateCells()
IEnumerable<ICellInfoBase^>^ EnumAllTemplateCells();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfoDesigner Interface
IListViewInfoDesigner Members


%%ItemTitle%%

GetAllColumnNames Method

GrapeCity.Forguncy.Plugin Namespace > IListViewInfoDesigner Interface : GetAllColumnNames Method
获取所有列名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetAllColumnNames() As List(Of String)
'Usage

Dim instance As IListViewInfoDesigner
Dim value As List(Of String)

value = instance.GetAllColumnNames()
List<string> GetAllColumnNames()
List<String^>^ GetAllColumnNames();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IListViewInfoDesigner Interface
IListViewInfoDesigner Members


%%PageItemTitle%%

ILocalServerInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : ILocalServerInfo Interface
本地网站应用信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ILocalServerInfo
'Usage

Dim instance As ILocalServerInfo
public interface ILocalServerInfo
public interface class ILocalServerInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILocalServerInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ILocalServerInfo Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : ILocalServerInfo Interface

The following tables list the members exposed by ILocalServerInfo.

Public Properties
 | Name | Description
Property | HostAddress | 主机地址。
Property | PortNumber | 端口号。
Top
See Also

Reference

ILocalServerInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

ILocalServerInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : ILocalServerInfo Interface

For a list of all members of this type, see ILocalServerInfo members.

Public Properties
 | Name | Description
Property | HostAddress | 主机地址。
Property | PortNumber | 端口号。
Top
See Also

Reference

ILocalServerInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

HostAddress Property

GrapeCity.Forguncy.Plugin Namespace > ILocalServerInfo Interface : HostAddress Property
主机地址。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property HostAddress As String
'Usage

Dim instance As ILocalServerInfo
Dim value As String

value = instance.HostAddress
string HostAddress {get;}
property String^ HostAddress {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILocalServerInfo Interface
ILocalServerInfo Members


%%ItemTitle%%

PortNumber Property

GrapeCity.Forguncy.Plugin Namespace > ILocalServerInfo Interface : PortNumber Property
端口号。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PortNumber As Integer
'Usage

Dim instance As ILocalServerInfo
Dim value As Integer

value = instance.PortNumber
int PortNumber {get;}
property int PortNumber {
   int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ILocalServerInfo Interface
ILocalServerInfo Members


%%PageItemTitle%%

INeedUploadFileByUser Interface
Members

GrapeCity.Forguncy.Plugin Namespace : INeedUploadFileByUser Interface
如果插件使用过程中需要用户上传文件或者图片等，在保存或导入活字格文件时需给出相关的文件或图片信息，如存储文件夹路径，文件名等。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface INeedUploadFileByUser
'Usage

Dim instance As INeedUploadFileByUser
public interface INeedUploadFileByUser
public interface class INeedUploadFileByUser
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INeedUploadFileByUser Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

INeedUploadFileByUser Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : INeedUploadFileByUser Interface

The following tables list the members exposed by INeedUploadFileByUser.

Public Methods
 | Name | Description
Method | GetAllFileSourceAndTargetPathsWhenImportForguncyFile | 当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
Method | GetUploadFileInfosWhenSaveFile | 保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
Top
See Also

Reference

INeedUploadFileByUser Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

INeedUploadFileByUser Interface Methods

GrapeCity.Forguncy.Plugin Namespace : INeedUploadFileByUser Interface

For a list of all members of this type, see INeedUploadFileByUser members.

Public Methods
 | Name | Description
Method | GetAllFileSourceAndTargetPathsWhenImportForguncyFile | 当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
Method | GetUploadFileInfosWhenSaveFile | 保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
Top
See Also

Reference

INeedUploadFileByUser Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetAllFileSourceAndTargetPathsWhenImportForguncyFile Method

GrapeCity.Forguncy.Plugin Namespace > INeedUploadFileByUser Interface : GetAllFileSourceAndTargetPathsWhenImportForguncyFile Method
提供了一些获取当前活字格文件的存储位置等信息。
当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetAllFileSourceAndTargetPathsWhenImportForguncyFile( _
   ByVal context As IFileUploadContext _
) As List(Of FileCopyInfo)
'Usage

Dim instance As INeedUploadFileByUser
Dim context As IFileUploadContext
Dim value As List(Of FileCopyInfo)

value = instance.GetAllFileSourceAndTargetPathsWhenImportForguncyFile(context)
List<FileCopyInfo> GetAllFileSourceAndTargetPathsWhenImportForguncyFile(
   IFileUploadContext context
)
List<FileCopyInfo^>^ GetAllFileSourceAndTargetPathsWhenImportForguncyFile(
   IFileUploadContext^ context
)

Parameters

context
提供了一些获取当前活字格文件的存储位置等信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INeedUploadFileByUser Interface
INeedUploadFileByUser Members


%%ItemTitle%%

GetUploadFileInfosWhenSaveFile Method

GrapeCity.Forguncy.Plugin Namespace > INeedUploadFileByUser Interface : GetUploadFileInfosWhenSaveFile Method
提供了一些获取当前活字格文件的存储位置等信息。
保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetUploadFileInfosWhenSaveFile( _
   ByVal context As IFileUploadContext _
) As FileUploadInfo
'Usage

Dim instance As INeedUploadFileByUser
Dim context As IFileUploadContext
Dim value As FileUploadInfo

value = instance.GetUploadFileInfosWhenSaveFile(context)
FileUploadInfo GetUploadFileInfosWhenSaveFile(
   IFileUploadContext context
)
FileUploadInfo^ GetUploadFileInfosWhenSaveFile(
   IFileUploadContext^ context
)

Parameters

context
提供了一些获取当前活字格文件的存储位置等信息。

Return Value

保存时上传文件的信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

INeedUploadFileByUser Interface
INeedUploadFileByUser Members


%%PageItemTitle%%

IPageInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IPageInfo Interface
页面信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IPageInfo
'Usage

Dim instance As IPageInfo
public interface IPageInfo
public interface class IPageInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IPageInfo Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : IPageInfo Interface

The following tables list the members exposed by IPageInfo.

Public Properties
 | Name | Description
Property | IsBuiltInPage | 是否内建页。
Property | IsMasterPage | 是否母版页。
Property | IsMobilePage | 是否手机页。
Property | PageName | 页面名。
Top
See Also

Reference

IPageInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IPageInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IPageInfo Interface

For a list of all members of this type, see IPageInfo members.

Public Properties
 | Name | Description
Property | IsBuiltInPage | 是否内建页。
Property | IsMasterPage | 是否母版页。
Property | IsMobilePage | 是否手机页。
Property | PageName | 页面名。
Top
See Also

Reference

IPageInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

IsBuiltInPage Property

GrapeCity.Forguncy.Plugin Namespace > IPageInfo Interface : IsBuiltInPage Property
是否内建页。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property IsBuiltInPage As Boolean
'Usage

Dim instance As IPageInfo
Dim value As Boolean

value = instance.IsBuiltInPage
bool IsBuiltInPage {get;}
property bool IsBuiltInPage {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInfo Interface
IPageInfo Members


%%ItemTitle%%

IsMasterPage Property

GrapeCity.Forguncy.Plugin Namespace > IPageInfo Interface : IsMasterPage Property
是否母版页。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property IsMasterPage As Boolean
'Usage

Dim instance As IPageInfo
Dim value As Boolean

value = instance.IsMasterPage
bool IsMasterPage {get;}
property bool IsMasterPage {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInfo Interface
IPageInfo Members


%%ItemTitle%%

IsMobilePage Property

GrapeCity.Forguncy.Plugin Namespace > IPageInfo Interface : IsMobilePage Property
是否手机页。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property IsMobilePage As Boolean
'Usage

Dim instance As IPageInfo
Dim value As Boolean

value = instance.IsMobilePage
bool IsMobilePage {get;}
property bool IsMobilePage {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInfo Interface
IPageInfo Members


%%ItemTitle%%

PageName Property (IPageInfo)

GrapeCity.Forguncy.Plugin Namespace > IPageInfo Interface : PageName Property
页面名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PageName As String
'Usage

Dim instance As IPageInfo
Dim value As String

value = instance.PageName
string PageName {get;}
property String^ PageName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPageInfo Interface
IPageInfo Members


%%PageItemTitle%%

IPropertySearchable Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IPropertySearchable Interface
能够检索替换单元格类型和命令上的某些属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IPropertySearchable
'Usage

Dim instance As IPropertySearchable
public interface IPropertySearchable
public interface class IPropertySearchable
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPropertySearchable Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IPropertySearchable Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IPropertySearchable Interface

The following tables list the members exposed by IPropertySearchable.

Public Methods
 | Name | Description
Method | EnumSearchableProperty | 查找到某一个单元格类型或命令时，需要检索的属性名称和检索时使用的值的集合。
Top
See Also

Reference

IPropertySearchable Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IPropertySearchable Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IPropertySearchable Interface

For a list of all members of this type, see IPropertySearchable members.

Public Methods
 | Name | Description
Method | EnumSearchableProperty | 查找到某一个单元格类型或命令时，需要检索的属性名称和检索时使用的值的集合。
Top
See Also

Reference

IPropertySearchable Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

EnumSearchableProperty Method

GrapeCity.Forguncy.Plugin Namespace > IPropertySearchable Interface : EnumSearchableProperty Method
查找到某一个单元格类型或命令时，需要检索的属性名称和检索时使用的值的集合。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumSearchableProperty( _
   ByVal location As LocationIndicator _
) As IEnumerable(Of FindResultItem)
'Usage

Dim instance As IPropertySearchable
Dim location As LocationIndicator
Dim value As IEnumerable(Of FindResultItem)

value = instance.EnumSearchableProperty(location)
IEnumerable<FindResultItem> EnumSearchableProperty(
   LocationIndicator location
)
IEnumerable<FindResultItem^>^ EnumSearchableProperty(
   LocationIndicator^ location
)

Parameters

location
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPropertySearchable Interface
IPropertySearchable Members


%%PageItemTitle%%

IReferenceFormula Interface
Members Example

GrapeCity.Forguncy.Plugin Namespace : IReferenceFormula Interface

如果插件中引用了页面中的单元格，一旦被引用的单元格的位置发生了变化，如拖拽，那么插件中的相关单元格引用也应该被同步；

这种情况下就需要实现这个接口，而且，当查找页面中的单元格引用时，插件中的相关属性也会被查找出来。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IReferenceFormula
'Usage

Dim instance As IReferenceFormula
public interface IReferenceFormula
public interface class IReferenceFormula
Example
  • C#
public class MyCellType : CellType, IReferenceFormula
{
    [FormulaProperty]
    public object ReferCell { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("MyCellType").AppendProperty("ReferCell");
        yield return new LocatedObject<object>(this.ReferCell, newLocation);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceFormula Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IReferenceFormula Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceFormula Interface

The following tables list the members exposed by IReferenceFormula.

Public Methods
 | Name | Description
Method | GetFormulaReferObjects | 获取插件中所有引用单元格或单元格区域的公式对象。
Top
See Also

Reference

IReferenceFormula Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IReferenceFormula Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceFormula Interface

For a list of all members of this type, see IReferenceFormula members.

Public Methods
 | Name | Description
Method | GetFormulaReferObjects | 获取插件中所有引用单元格或单元格区域的公式对象。
Top
See Also

Reference

IReferenceFormula Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetFormulaReferObjects Method

GrapeCity.Forguncy.Plugin Namespace > IReferenceFormula Interface : GetFormulaReferObjects Method
坐标定位器。
获取插件中所有引用单元格或单元格区域的公式对象。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetFormulaReferObjects( _
   ByVal location As LocationIndicator _
) As IEnumerable(Of LocatedObject(Of Object))
'Usage

Dim instance As IReferenceFormula
Dim location As LocationIndicator
Dim value As IEnumerable(Of LocatedObject(Of Object))

value = instance.GetFormulaReferObjects(location)
IEnumerable<LocatedObject<object>> GetFormulaReferObjects(
   LocationIndicator location
)
IEnumerable<LocatedObject<Object^>^>^ GetFormulaReferObjects(
   LocationIndicator^ location
)

Parameters

location
坐标定位器。

Return Value

返回所有引用单元格或单元格区域的公式对象。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceFormula Interface
IReferenceFormula Members


%%PageItemTitle%%

IReferenceListView Interface
Members Example

GrapeCity.Forguncy.Plugin Namespace : IReferenceListView Interface

如果插件中引用了页面中的表格的名称，一旦表格重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找页面中的表格引用时，插件中的相关属性也会被查找出来。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IReferenceListView
'Usage

Dim instance As IReferenceListView
public interface IReferenceListView
public interface class IReferenceListView
Example
  • C#
public class MyPageNavigateCellType : CellType, IReferenceListView
{
    public string ListViewName { get; set; }

    public IEnumerable<string>> GetListViewNames()
    {
        yield return this.ListViewName;
    }

    public void RenameListviewName(string oldName, string newName)
    {
        if(string.Equals(this.ListViewName, oldName))
        {
            this.ListViewName = newName;
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceListView Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IReferenceListView Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceListView Interface

The following tables list the members exposed by IReferenceListView.

Public Methods
 | Name | Description
Method | GetListViewNames | 返回插件中所有引用页面表格的信息。
Method | RenameListviewName | 一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
Top
See Also

Reference

IReferenceListView Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IReferenceListView Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceListView Interface

For a list of all members of this type, see IReferenceListView members.

Public Methods
 | Name | Description
Method | GetListViewNames | 返回插件中所有引用页面表格的信息。
Method | RenameListviewName | 一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
Top
See Also

Reference

IReferenceListView Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetListViewNames Method

GrapeCity.Forguncy.Plugin Namespace > IReferenceListView Interface : GetListViewNames Method
返回插件中所有引用页面表格的信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetListViewNames() As IEnumerable(Of String)
'Usage

Dim instance As IReferenceListView
Dim value As IEnumerable(Of String)

value = instance.GetListViewNames()
IEnumerable<string> GetListViewNames()
IEnumerable<String^>^ GetListViewNames();

Return Value

返回插件中所有引用页面表格的信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceListView Interface
IReferenceListView Members


%%ItemTitle%%

RenameListviewName Method

GrapeCity.Forguncy.Plugin Namespace > IReferenceListView Interface : RenameListviewName Method
重命名之前的表格名。
重命名之后的表格名。
一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub RenameListviewName( _
   ByVal oldName As String, _
   ByVal newName As String _
)
'Usage

Dim instance As IReferenceListView
Dim oldName As String
Dim newName As String

instance.RenameListviewName(oldName, newName)
void RenameListviewName(
   string oldName,
   string newName
)
void RenameListviewName(
   String^ oldName,
   String^ newName
)

Parameters

oldName
重命名之前的表格名。
newName
重命名之后的表格名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceListView Interface
IReferenceListView Members


%%PageItemTitle%%

IReferenceListViewColumn Interface
Members Example

GrapeCity.Forguncy.Plugin Namespace : IReferenceListViewColumn Interface

如果插件中引用了页面表格中列名，一旦表格中的列重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IReferenceListViewColumn
'Usage

Dim instance As IReferenceListViewColumn
public interface IReferenceListViewColumn
public interface class IReferenceListViewColumn
Example
  • C#
public class UpdateListviewCommand : Command, IReferenceListView
{
    public string ListViewName { get; set; }

    public List<string> UpdateColumns { get; set; }

    public void RenameListviewColumnName(string listviewName, string oldName, string newName)
    {
        if(string.Equals(this.ListViewName, listviewName))
        {
            for (var i = 0; i < this.UpdateColumns.Count; i++)
            {
                if(this.UpdateColumns[i] == oldName)
                {
                    this.UpdateColumns[i] = newName;
                }
            }
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceListViewColumn Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IReferenceListViewColumn Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceListViewColumn Interface

The following tables list the members exposed by IReferenceListViewColumn.

Public Methods
 | Name | Description
Method | RenameListviewColumnName | 一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
Top
See Also

Reference

IReferenceListViewColumn Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IReferenceListViewColumn Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceListViewColumn Interface

For a list of all members of this type, see IReferenceListViewColumn members.

Public Methods
 | Name | Description
Method | RenameListviewColumnName | 一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
Top
See Also

Reference

IReferenceListViewColumn Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

RenameListviewColumnName Method

GrapeCity.Forguncy.Plugin Namespace > IReferenceListViewColumn Interface : RenameListviewColumnName Method
表格名称。
重命名之前的表格列名。
重命名之后的表格列名。
一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub RenameListviewColumnName( _
   ByVal listviewName As String, _
   ByVal oldName As String, _
   ByVal newName As String _
)
'Usage

Dim instance As IReferenceListViewColumn
Dim listviewName As String
Dim oldName As String
Dim newName As String

instance.RenameListviewColumnName(listviewName, oldName, newName)
void RenameListviewColumnName(
   string listviewName,
   string oldName,
   string newName
)
void RenameListviewColumnName(
   String^ listviewName,
   String^ oldName,
   String^ newName
)

Parameters

listviewName
表格名称。
oldName
重命名之前的表格列名。
newName
重命名之后的表格列名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceListViewColumn Interface
IReferenceListViewColumn Members


%%PageItemTitle%%

IReferencePage Interface
Members Example

GrapeCity.Forguncy.Plugin Namespace : IReferencePage Interface

如果插件中引用了页面名，一旦页面重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找页面的引用时，插件中的相关属性也会被查找出来。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IReferencePage
'Usage

Dim instance As IReferencePage
public interface IReferencePage
public interface class IReferencePage
Example
  • C#
public class MyNavigatePageCommand : Command, IReferencePage
{
    public string NavigatePageName { get; set; }

    public IEnumerable<LocatedObject<string>> GetPageNames(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("MyNavigatePageCommand");

        yield return new LocatedObject<string>(this.NavigatePageName, newLocation);
    }

    public void RenamePageName(string oldName, string newName)
    {
        if(string.Equals(this.NavigatePageName, oldName))
        {
            this.NavigatePageName = newName;
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferencePage Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IReferencePage Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IReferencePage Interface

The following tables list the members exposed by IReferencePage.

Public Methods
 | Name | Description
Method | GetPageNames | 返回插件中所有引用页面的信息。
Method | RenamePageName | 一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
Top
See Also

Reference

IReferencePage Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IReferencePage Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IReferencePage Interface

For a list of all members of this type, see IReferencePage members.

Public Methods
 | Name | Description
Method | GetPageNames | 返回插件中所有引用页面的信息。
Method | RenamePageName | 一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
Top
See Also

Reference

IReferencePage Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetPageNames Method

GrapeCity.Forguncy.Plugin Namespace > IReferencePage Interface : GetPageNames Method
坐标定位器。
返回插件中所有引用页面的信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetPageNames( _
   ByVal location As LocationIndicator _
) As IEnumerable(Of LocatedObject(Of String))
'Usage

Dim instance As IReferencePage
Dim location As LocationIndicator
Dim value As IEnumerable(Of LocatedObject(Of String))

value = instance.GetPageNames(location)
IEnumerable<LocatedObject<string>> GetPageNames(
   LocationIndicator location
)
IEnumerable<LocatedObject<String^>^>^ GetPageNames(
   LocationIndicator^ location
)

Parameters

location
坐标定位器。

Return Value

返回插件中所有引用页面的信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferencePage Interface
IReferencePage Members


%%ItemTitle%%

RenamePageName Method

GrapeCity.Forguncy.Plugin Namespace > IReferencePage Interface : RenamePageName Method
重命名之前的页面名。
重命名之后的页面名。
一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub RenamePageName( _
   ByVal oldName As String, _
   ByVal newName As String _
)
'Usage

Dim instance As IReferencePage
Dim oldName As String
Dim newName As String

instance.RenamePageName(oldName, newName)
void RenamePageName(
   string oldName,
   string newName
)
void RenamePageName(
   String^ oldName,
   String^ newName
)

Parameters

oldName
重命名之前的页面名。
newName
重命名之后的页面名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferencePage Interface
IReferencePage Members


%%PageItemTitle%%

IReferenceTable Interface
Members Example

GrapeCity.Forguncy.Plugin Namespace : IReferenceTable Interface

如果插件中引用了数据表名或者字段名，一旦数据表或字段重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找数据表或字段的引用时，插件中的相关属性也会被查找出来。

Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IReferenceTable
'Usage

Dim instance As IReferenceTable
public interface IReferenceTable
public interface class IReferenceTable
Example
  • C#
public class ListCellType : CellType, IReferenceTable
{
    public string TableName { get; set; }

    public string TextColumn { get; set; }

    public string ValueColumn { get; set; }

    public  IEnumerable<LocatedObject<TableCheckInfo>> GetTableInfo(LocationIndicator location)
    {
        var list = new List<LocatedObject<TableCheckInfo>>();

        TableCheckInfo info = new TableCheckInfo(TableName);
        var columns = (new List<string>() { ValueColumn, TextColumn }).Distinct();
        foreach (var col in columns)
        {
            info.AddColumns(col);
        }

        var newLocation = location.AppendProperty("ListCellType");

        list.Add(new LocatedObject<TableCheckInfo>(info, newLocation));

        return list;
    }

    public void RenameTableColumnName(string tableName, string oldName, string newName)
    {
        if (string.Equals(this.TableName, tableName))
        {
            if (oldName == this.ValueColumn)
            {
                this.ValueColumn = newName;
            }
            if (oldName == this.TextColumn)
            {
                this.TextColumn = newName;
            }
        }
    }

    public void RenameTableName(string oldName, string newName)
    {
        if(string.Equals(this.TableName, oldName))
        {
            this.TableName = newName;
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceTable Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IReferenceTable Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceTable Interface

The following tables list the members exposed by IReferenceTable.

Public Methods
 | Name | Description
Method | GetTableInfo | 返回插件中所有引用数据表和字段的信息。
Method | RenameTableColumnName | 一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
Method | RenameTableName | 一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
Top
See Also

Reference

IReferenceTable Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IReferenceTable Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IReferenceTable Interface

For a list of all members of this type, see IReferenceTable members.

Public Methods
 | Name | Description
Method | GetTableInfo | 返回插件中所有引用数据表和字段的信息。
Method | RenameTableColumnName | 一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
Method | RenameTableName | 一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
Top
See Also

Reference

IReferenceTable Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetTableInfo Method

GrapeCity.Forguncy.Plugin Namespace > IReferenceTable Interface : GetTableInfo Method
原有坐标定位器。
返回插件中所有引用数据表和字段的信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetTableInfo( _
   ByVal location As LocationIndicator _
) As IEnumerable(Of LocatedObject(Of TableCheckInfo))
'Usage

Dim instance As IReferenceTable
Dim location As LocationIndicator
Dim value As IEnumerable(Of LocatedObject(Of TableCheckInfo))

value = instance.GetTableInfo(location)
IEnumerable<LocatedObject<TableCheckInfo>> GetTableInfo(
   LocationIndicator location
)
IEnumerable<LocatedObject<TableCheckInfo^>^>^ GetTableInfo(
   LocationIndicator^ location
)

Parameters

location
原有坐标定位器。

Return Value

返回插件中所有引用数据表和字段的信息。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceTable Interface
IReferenceTable Members


%%ItemTitle%%

RenameTableColumnName Method

GrapeCity.Forguncy.Plugin Namespace > IReferenceTable Interface : RenameTableColumnName Method
数据表名。
重命名之前的字段名。
重命名之后的字段名。
一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub RenameTableColumnName( _
   ByVal tableName As String, _
   ByVal oldName As String, _
   ByVal newName As String _
)
'Usage

Dim instance As IReferenceTable
Dim tableName As String
Dim oldName As String
Dim newName As String

instance.RenameTableColumnName(tableName, oldName, newName)
void RenameTableColumnName(
   string tableName,
   string oldName,
   string newName
)
void RenameTableColumnName(
   String^ tableName,
   String^ oldName,
   String^ newName
)

Parameters

tableName
数据表名。
oldName
重命名之前的字段名。
newName
重命名之后的字段名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceTable Interface
IReferenceTable Members


%%ItemTitle%%

RenameTableName Method

GrapeCity.Forguncy.Plugin Namespace > IReferenceTable Interface : RenameTableName Method
重命名之前的数据表名。
重命名之后的数据表名。
一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub RenameTableName( _
   ByVal oldName As String, _
   ByVal newName As String _
)
'Usage

Dim instance As IReferenceTable
Dim oldName As String
Dim newName As String

instance.RenameTableName(oldName, newName)
void RenameTableName(
   string oldName,
   string newName
)
void RenameTableName(
   String^ oldName,
   String^ newName
)

Parameters

oldName
重命名之前的数据表名。
newName
重命名之后的数据表名。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceTable Interface
IReferenceTable Members


%%PageItemTitle%%

IReferFiles Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IReferFiles Interface
此接口将返回当前对象关联的所有文件的物理文件路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IReferFiles
'Usage

Dim instance As IReferFiles
public interface IReferFiles
public interface class IReferFiles
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferFiles Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IReferFiles Interface Members
Methods

GrapeCity.Forguncy.Plugin Namespace : IReferFiles Interface

The following tables list the members exposed by IReferFiles.

Public Methods
 | Name | Description
Method | GetReferFiles | 此接口将返回当前对象关联的所有文件的物理文件路径。
Top
See Also

Reference

IReferFiles Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IReferFiles Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IReferFiles Interface

For a list of all members of this type, see IReferFiles members.

Public Methods
 | Name | Description
Method | GetReferFiles | 此接口将返回当前对象关联的所有文件的物理文件路径。
Top
See Also

Reference

IReferFiles Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetReferFiles Method

GrapeCity.Forguncy.Plugin Namespace > IReferFiles Interface : GetReferFiles Method
此接口将返回当前对象关联的所有文件的物理文件路径。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetReferFiles() As IEnumerable(Of String)
'Usage

Dim instance As IReferFiles
Dim value As IEnumerable(Of String)

value = instance.GetReferFiles()
IEnumerable<string> GetReferFiles()
IEnumerable<String^>^ GetReferFiles();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferFiles Interface
IReferFiles Members


%%PageItemTitle%%

ITableInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : ITableInfo Interface
数据表的信息。
Object Model
ITableInfo InterfaceIWorkflowInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface ITableInfo
'Usage

Dim instance As ITableInfo
public interface ITableInfo
public interface class ITableInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ITableInfo Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : ITableInfo Interface

The following tables list the members exposed by ITableInfo.

Public Properties
 | Name | Description
Property | Columns | 数据表中字段名集合。
Property | TableName | 数据表名。
Property | TableType | 数据表的类型。
Property | WorkflowInfo | 数据表的工作流信息。
Top
See Also

Reference

ITableInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

ITableInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : ITableInfo Interface

For a list of all members of this type, see ITableInfo members.

Public Properties
 | Name | Description
Property | Columns | 数据表中字段名集合。
Property | TableName | 数据表名。
Property | TableType | 数据表的类型。
Property | WorkflowInfo | 数据表的工作流信息。
Top
See Also

Reference

ITableInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

Columns Property

GrapeCity.Forguncy.Plugin Namespace > ITableInfo Interface : Columns Property
数据表中字段名集合。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property Columns As IEnumerable(Of IColumnInfo)
'Usage

Dim instance As ITableInfo
Dim value As IEnumerable(Of IColumnInfo)

value = instance.Columns
IEnumerable<IColumnInfo> Columns {get;}
property IEnumerable<IColumnInfo^>^ Columns {
   IEnumerable<IColumnInfo^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableInfo Interface
ITableInfo Members


%%ItemTitle%%

TableName Property (ITableInfo)

GrapeCity.Forguncy.Plugin Namespace > ITableInfo Interface : TableName Property
数据表名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property TableName As String
'Usage

Dim instance As ITableInfo
Dim value As String

value = instance.TableName
string TableName {get;}
property String^ TableName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableInfo Interface
ITableInfo Members


%%ItemTitle%%

TableType Property

GrapeCity.Forguncy.Plugin Namespace > ITableInfo Interface : TableType Property
数据表的类型。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property TableType As ForguncyTableType
'Usage

Dim instance As ITableInfo
Dim value As ForguncyTableType

value = instance.TableType
ForguncyTableType TableType {get;}
property ForguncyTableType TableType {
   ForguncyTableType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableInfo Interface
ITableInfo Members


%%ItemTitle%%

WorkflowInfo Property

GrapeCity.Forguncy.Plugin Namespace > ITableInfo Interface : WorkflowInfo Property
数据表的工作流信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property WorkflowInfo As IWorkflowInfo
'Usage

Dim instance As ITableInfo
Dim value As IWorkflowInfo

value = instance.WorkflowInfo
IWorkflowInfo WorkflowInfo {get;}
property IWorkflowInfo^ WorkflowInfo {
   IWorkflowInfo^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITableInfo Interface
ITableInfo Members


%%PageItemTitle%%

IUserServiceInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IUserServiceInfo Interface
用户管理网站的信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IUserServiceInfo
'Usage

Dim instance As IUserServiceInfo
public interface IUserServiceInfo
public interface class IUserServiceInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUserServiceInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IUserServiceInfo Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : IUserServiceInfo Interface

The following tables list the members exposed by IUserServiceInfo.

Public Properties
 | Name | Description
Property | AllRoles | 获取所有的角色。
Top
See Also

Reference

IUserServiceInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IUserServiceInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IUserServiceInfo Interface

For a list of all members of this type, see IUserServiceInfo members.

Public Properties
 | Name | Description
Property | AllRoles | 获取所有的角色。
Top
See Also

Reference

IUserServiceInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

AllRoles Property

GrapeCity.Forguncy.Plugin Namespace > IUserServiceInfo Interface : AllRoles Property
获取所有的角色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AllRoles As List(Of String)
'Usage

Dim instance As IUserServiceInfo
Dim value As List(Of String)

value = instance.AllRoles
List<string> AllRoles {get;}
property List<String^>^ AllRoles {
   List<String^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUserServiceInfo Interface
IUserServiceInfo Members


%%PageItemTitle%%

IWorkflowInfo Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IWorkflowInfo Interface
数据表中的工作流信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IWorkflowInfo
'Usage

Dim instance As IWorkflowInfo
public interface IWorkflowInfo
public interface class IWorkflowInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWorkflowInfo Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IWorkflowInfo Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : IWorkflowInfo Interface

The following tables list the members exposed by IWorkflowInfo.

Public Properties
 | Name | Description
Property | IsEnabled | 是否启用工作流。
Property | StateList | 工作流中的状态集合。
Top
See Also

Reference

IWorkflowInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IWorkflowInfo Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IWorkflowInfo Interface

For a list of all members of this type, see IWorkflowInfo members.

Public Properties
 | Name | Description
Property | IsEnabled | 是否启用工作流。
Property | StateList | 工作流中的状态集合。
Top
See Also

Reference

IWorkflowInfo Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

IsEnabled Property (IWorkflowInfo)

GrapeCity.Forguncy.Plugin Namespace > IWorkflowInfo Interface : IsEnabled Property
是否启用工作流。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property IsEnabled As Boolean
'Usage

Dim instance As IWorkflowInfo
Dim value As Boolean

value = instance.IsEnabled
bool IsEnabled {get;}
property bool IsEnabled {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWorkflowInfo Interface
IWorkflowInfo Members


%%ItemTitle%%

StateList Property

GrapeCity.Forguncy.Plugin Namespace > IWorkflowInfo Interface : StateList Property
工作流中的状态集合。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property StateList As IEnumerable(Of String)
'Usage

Dim instance As IWorkflowInfo
Dim value As IEnumerable(Of String)

value = instance.StateList
IEnumerable<string> StateList {get;}
property IEnumerable<String^>^ StateList {
   IEnumerable<String^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWorkflowInfo Interface
IWorkflowInfo Members


%%ItemTitle%%

GrapeCity.Forguncy.Plugin.Design Assembly
Namespaces
Namespace | Description
GrapeCity.Forguncy.Plugin |


%%ItemTitle%%

GrapeCity.Forguncy.Plugin Namespace (GrapeCity.Forguncy.Plugin.Design)
Inheritance Hierarchy
Classes
 | Class | Description
Class | BuiltinEditorSetting | 活字格内置的属性编辑器。
Class | CheckBoxEidtorSetting | 是/否类型的属性对应的编辑器，如[只读]属性。
Class | ColorSelectorEditorSetting | 颜色类型的属性对应的编辑器，如[颜色]属性。
Class | ComboEditorSetting | 组合框。如菜单中使用的[主题]属性。
Class | DoubleEditorSetting | 小数类型的属性对应的编辑器，如地图插件使用的[经度]或[纬度]属性。
Class | EditorSetting | 插件内部属性对应的编辑器设置。
Class | EnumValueEditorSetting | 枚举类型编辑器。如菜单中使用的[主题]属性。
Class | FormulaSelectorEditorSetting | 公式类型的属性对应的编辑器，如[缺省值]属性。
Class | HyperlinkEditorSetting | 超链接编辑器，如果一个属性比较复杂，需要单独提供一个对话框去设置属性内部的值的时候会用到这个编辑器，如[编辑菜单项目...]属性。
Class | ImageEditorSetting | 图片编辑器。如图片类型使用的[选择图片...]属性。
Class | IntEditorSetting | 整数类型的属性对应的编辑器，如单选按钮使用的[项目间距]属性。
Class | OrientationEidtorSetting | 排列方向类型的属性对应的编辑器，如单选按钮使用的[布局]属性。
Class | TableComboTreeSelectorEditorSetting | 数据表选择器。如数据导航按钮中使用的[导航表]属性。
Class | TextEditorSetting | 文本类型的属性对应的编辑器，如[水印]属性。
Class | TimeValueEditorSetting | 时间类型编辑器。如时间单元类型使用的[下拉框开始时间]属性。
Interfaces
 | Interface | Description
Interface | IBuilderContextBase | 设计器上下文信息。
Interface | IEditorSettingsDataContext | 属性编辑器上下文信息。
See Also

Reference

GrapeCity.Forguncy.Plugin.Design Assembly


%%PageItemTitle%%

BuiltinEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : BuiltinEditorSetting Class
活字格内置的属性编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class BuiltinEditorSetting
   Inherits EditorSetting
'Usage

Dim instance As BuiltinEditorSetting
public abstract class BuiltinEditorSetting : EditorSetting
public ref class BuiltinEditorSetting abstract : public EditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.CheckBoxEidtorSetting
GrapeCity.Forguncy.Plugin.ColorSelectorEditorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.DoubleEditorSetting
GrapeCity.Forguncy.Plugin.FormulaSelectorEditorSetting
GrapeCity.Forguncy.Plugin.HyperlinkEditorSetting
GrapeCity.Forguncy.Plugin.ImageEditorSetting
GrapeCity.Forguncy.Plugin.IntEditorSetting
GrapeCity.Forguncy.Plugin.OrientationEidtorSetting
GrapeCity.Forguncy.Plugin.TableComboTreeSelectorEditorSetting
GrapeCity.Forguncy.Plugin.TextEditorSetting
GrapeCity.Forguncy.Plugin.TimeValueEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BuiltinEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

BuiltinEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : BuiltinEditorSetting Class

The following tables list the members exposed by BuiltinEditorSetting.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | Overridden. 属性编辑器对应的数据模板。
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

BuiltinEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

BuiltinEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : BuiltinEditorSetting Class

For a list of all members of this type, see BuiltinEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | Overridden. 属性编辑器对应的数据模板。
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

BuiltinEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetDataTemplate Method (BuiltinEditorSetting)
Example

GrapeCity.Forguncy.Plugin Namespace > BuiltinEditorSetting Class : GetDataTemplate Method
属性编辑器对应的数据模板。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides Function GetDataTemplate() As DataTemplate
'Usage

Dim instance As BuiltinEditorSetting
Dim value As DataTemplate

value = instance.GetDataTemplate()
public override DataTemplate GetDataTemplate()
public:
DataTemplate^ GetDataTemplate(); override

Return Value

属性编辑器对应的数据模板。
Example

自定义属性编辑器的数据模板。

  • C#
public class PassValueItemsEditorSetting : BuiltinEditorSetting
{
    public override DataTemplate GetDataTemplate()
    {
        var myResourceDictionary = new ResourceDictionary()
        {
            Source = new Uri("/PassListviewDataCommand;component/Control/Dictionary1.xaml", UriKind.RelativeOrAbsolute)
        };
        return myResourceDictionary["passValueItemsEditor"] as DataTemplate;
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BuiltinEditorSetting Class
BuiltinEditorSetting Members


%%PageItemTitle%% $$Properties$$

BuiltinEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : BuiltinEditorSetting Class

For a list of all members of this type, see BuiltinEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

BuiltinEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (BuiltinEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > BuiltinEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property TemplateName As String
'Usage

Dim instance As BuiltinEditorSetting
Dim value As String

value = instance.TemplateName
public virtual string TemplateName {get;}
public:
virtual property String^ TemplateName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BuiltinEditorSetting Class
BuiltinEditorSetting Members


%%PageItemTitle%%

CheckBoxEidtorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : CheckBoxEidtorSetting Class
是/否类型的属性对应的编辑器，如[只读]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class CheckBoxEidtorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As CheckBoxEidtorSetting
public class CheckBoxEidtorSetting : BuiltinEditorSetting
public ref class CheckBoxEidtorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.CheckBoxEidtorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBoxEidtorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

CheckBoxEidtorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : CheckBoxEidtorSetting Class

The following tables list the members exposed by CheckBoxEidtorSetting.

Public Constructors
 | Name | Description
Public Constructor | CheckBoxEidtorSetting Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | Overridden. 命令插件中的属性编辑器中的属性名是否显示。
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

CheckBoxEidtorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

CheckBoxEidtorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > CheckBoxEidtorSetting Class : CheckBoxEidtorSetting Constructor
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CheckBoxEidtorSetting()
public CheckBoxEidtorSetting()
public:
CheckBoxEidtorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBoxEidtorSetting Class
CheckBoxEidtorSetting Members


%%PageItemTitle%% $$Properties$$

CheckBoxEidtorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : CheckBoxEidtorSetting Class

For a list of all members of this type, see CheckBoxEidtorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | Overridden. 命令插件中的属性编辑器中的属性名是否显示。
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

CheckBoxEidtorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

DefaultCaptionVisibility Property (CheckBoxEidtorSetting)

GrapeCity.Forguncy.Plugin Namespace > CheckBoxEidtorSetting Class : DefaultCaptionVisibility Property
命令插件中的属性编辑器中的属性名是否显示。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property DefaultCaptionVisibility As Visibility
'Usage

Dim instance As CheckBoxEidtorSetting
Dim value As Visibility

value = instance.DefaultCaptionVisibility
public override Visibility DefaultCaptionVisibility {get;}
public:
property Visibility DefaultCaptionVisibility {
   Visibility get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBoxEidtorSetting Class
CheckBoxEidtorSetting Members


%%ItemTitle%%

TemplateName Property (CheckBoxEidtorSetting)

GrapeCity.Forguncy.Plugin Namespace > CheckBoxEidtorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As CheckBoxEidtorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CheckBoxEidtorSetting Class
CheckBoxEidtorSetting Members


%%PageItemTitle%%

ColorSelectorEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : ColorSelectorEditorSetting Class
颜色类型的属性对应的编辑器，如[颜色]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ColorSelectorEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As ColorSelectorEditorSetting
public class ColorSelectorEditorSetting : BuiltinEditorSetting
public ref class ColorSelectorEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.ColorSelectorEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorSelectorEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ColorSelectorEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ColorSelectorEditorSetting Class

The following tables list the members exposed by ColorSelectorEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | ColorSelectorEditorSetting Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ColorSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ColorSelectorEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > ColorSelectorEditorSetting Class : ColorSelectorEditorSetting Constructor
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ColorSelectorEditorSetting()
public ColorSelectorEditorSetting()
public:
ColorSelectorEditorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorSelectorEditorSetting Class
ColorSelectorEditorSetting Members


%%PageItemTitle%% $$Properties$$

ColorSelectorEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : ColorSelectorEditorSetting Class

For a list of all members of this type, see ColorSelectorEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ColorSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (ColorSelectorEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > ColorSelectorEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As ColorSelectorEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColorSelectorEditorSetting Class
ColorSelectorEditorSetting Members


%%PageItemTitle%%

ComboEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : ComboEditorSetting Class
组合框。如菜单中使用的[主题]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ComboEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As ComboEditorSetting
public class ComboEditorSetting : BuiltinEditorSetting
public ref class ComboEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.EnumValueEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ComboEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ComboEditorSetting Class

The following tables list the members exposed by ComboEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | ComboEditorSetting Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | DisplayMember | 下拉项目文本属性。
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Source | 下拉项目集合。
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | ValueMember | 下拉项目值属性。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ComboEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ComboEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > ComboEditorSetting Class : ComboEditorSetting Constructor
下拉项目集合。
下拉项目文本属性。
下拉项目值属性。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal source As Object, _
   Optional ByVal displayMember As String, _
   Optional ByVal valueMember As String _
)
'Usage

Dim source As Object
Dim displayMember As String
Dim valueMember As String

Dim instance As New ComboEditorSetting(source, displayMember, valueMember)
public ComboEditorSetting(
   object source,
   string displayMember,
   string valueMember
)
public:
ComboEditorSetting(
   Object^ source,
   String^ displayMember,
   String^ valueMember
)

Parameters

source
下拉项目集合。
displayMember
下拉项目文本属性。
valueMember
下拉项目值属性。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditorSetting Class
ComboEditorSetting Members


%%PageItemTitle%% $$Properties$$

ComboEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : ComboEditorSetting Class

For a list of all members of this type, see ComboEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | DisplayMember | 下拉项目文本属性。
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Source | 下拉项目集合。
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | ValueMember | 下拉项目值属性。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ComboEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

DisplayMember Property

GrapeCity.Forguncy.Plugin Namespace > ComboEditorSetting Class : DisplayMember Property
下拉项目文本属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DisplayMember As String
'Usage

Dim instance As ComboEditorSetting
Dim value As String

value = instance.DisplayMember
public string DisplayMember {get;}
public:
property String^ DisplayMember {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditorSetting Class
ComboEditorSetting Members


%%ItemTitle%%

Source Property

GrapeCity.Forguncy.Plugin Namespace > ComboEditorSetting Class : Source Property
下拉项目集合。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Source As Object
'Usage

Dim instance As ComboEditorSetting
Dim value As Object

value = instance.Source
public object Source {get;}
public:
property Object^ Source {
   Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditorSetting Class
ComboEditorSetting Members


%%ItemTitle%%

TemplateName Property (ComboEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > ComboEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As ComboEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditorSetting Class
ComboEditorSetting Members


%%ItemTitle%%

ValueMember Property

GrapeCity.Forguncy.Plugin Namespace > ComboEditorSetting Class : ValueMember Property
下拉项目值属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property ValueMember As String
'Usage

Dim instance As ComboEditorSetting
Dim value As String

value = instance.ValueMember
public string ValueMember {get;}
public:
property String^ ValueMember {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ComboEditorSetting Class
ComboEditorSetting Members


%%PageItemTitle%%

DoubleEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : DoubleEditorSetting Class
小数类型的属性对应的编辑器，如地图插件使用的[经度]或[纬度]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class DoubleEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As DoubleEditorSetting
public class DoubleEditorSetting : BuiltinEditorSetting
public ref class DoubleEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.DoubleEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

DoubleEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : DoubleEditorSetting Class

The following tables list the members exposed by DoubleEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | DoubleEditorSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

DoubleEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

DoubleEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > DoubleEditorSetting Class : DoubleEditorSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DoubleEditorSetting()
public DoubleEditorSetting()
public:
DoubleEditorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleEditorSetting Class
DoubleEditorSetting Members


%%PageItemTitle%% $$Properties$$

DoubleEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : DoubleEditorSetting Class

For a list of all members of this type, see DoubleEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

DoubleEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (DoubleEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > DoubleEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As DoubleEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DoubleEditorSetting Class
DoubleEditorSetting Members


%%PageItemTitle%%

EditorSetting Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : EditorSetting Class
插件内部属性对应的编辑器设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustInherit Class EditorSetting
'Usage

Dim instance As EditorSetting
public abstract class EditorSetting
public ref class EditorSetting abstract
Example
  • C#
public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
{
    return new ComboEditorSetting(new List<string>()  { "aaa", "bbb", "ccc"});
}
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

EditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : EditorSetting Class

The following tables list the members exposed by EditorSetting.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。
Public Property | IsEnabled | 属性编辑器是否可用。
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
Public Property | Visibility | 属性编辑器是否可见。
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。
Public Method | Validate | 插件内部属性编辑器的校验处理。
Top
See Also

Reference

EditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

EditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : EditorSetting Class

For a list of all members of this type, see EditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。
Public Method | Validate | 插件内部属性编辑器的校验处理。
Top
See Also

Reference

EditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

GetDataTemplate Method (EditorSetting)

GrapeCity.Forguncy.Plugin Namespace > EditorSetting Class : GetDataTemplate Method
属性编辑器对应的数据模板。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public MustOverride Function GetDataTemplate() As DataTemplate
'Usage

Dim instance As EditorSetting
Dim value As DataTemplate

value = instance.GetDataTemplate()
public abstract DataTemplate GetDataTemplate()
public:
abstract DataTemplate^ GetDataTemplate();

Return Value

属性编辑器对应的数据模板。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditorSetting Class
EditorSetting Members


%%ItemTitle%%

Validate Method (EditorSetting)

GrapeCity.Forguncy.Plugin Namespace > EditorSetting Class : Validate Method
属性的值。
插件内部属性编辑器的校验处理。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable Function Validate( _
   ByVal propValue As Object _
) As Boolean
'Usage

Dim instance As EditorSetting
Dim propValue As Object
Dim value As Boolean

value = instance.Validate(propValue)
public virtual bool Validate(
   object propValue
)
public:
virtual bool Validate(
   Object^ propValue
)

Parameters

propValue
属性的值。

Return Value

校验通过返回True，否则返回False。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditorSetting Class
EditorSetting Members


%%PageItemTitle%% $$Properties$$

EditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : EditorSetting Class

For a list of all members of this type, see EditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。
Public Property | IsEnabled | 属性编辑器是否可用。
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
Public Property | Visibility | 属性编辑器是否可见。
Top
See Also

Reference

EditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

DefaultCaptionVisibility Property (EditorSetting)

GrapeCity.Forguncy.Plugin Namespace > EditorSetting Class : DefaultCaptionVisibility Property
命令插件中的属性编辑器中的属性名是否显示。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property DefaultCaptionVisibility As Visibility
'Usage

Dim instance As EditorSetting
Dim value As Visibility

value = instance.DefaultCaptionVisibility
public virtual Visibility DefaultCaptionVisibility {get;}
public:
virtual property Visibility DefaultCaptionVisibility {
   Visibility get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditorSetting Class
EditorSetting Members


%%ItemTitle%%

IsEnabled Property (EditorSetting)

GrapeCity.Forguncy.Plugin Namespace > EditorSetting Class : IsEnabled Property
属性编辑器是否可用。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property IsEnabled As Boolean
'Usage

Dim instance As EditorSetting
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
public bool IsEnabled {get; set;}
public:
property bool IsEnabled {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditorSetting Class
EditorSetting Members


%%ItemTitle%%

Orientation Property

GrapeCity.Forguncy.Plugin Namespace > EditorSetting Class : Orientation Property
命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Orientation As Orientation
'Usage

Dim instance As EditorSetting
Dim value As Orientation

value = instance.Orientation
public virtual Orientation Orientation {get;}
public:
virtual property Orientation Orientation {
   Orientation get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditorSetting Class
EditorSetting Members


%%ItemTitle%%

Visibility Property

GrapeCity.Forguncy.Plugin Namespace > EditorSetting Class : Visibility Property
属性编辑器是否可见。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Visibility As Visibility
'Usage

Dim instance As EditorSetting
Dim value As Visibility

instance.Visibility = value

value = instance.Visibility
public Visibility Visibility {get; set;}
public:
property Visibility Visibility {
   Visibility get();
   void set (    Visibility value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditorSetting Class
EditorSetting Members


%%PageItemTitle%%

EnumValueEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : EnumValueEditorSetting Class
枚举类型编辑器。如菜单中使用的[主题]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class EnumValueEditorSetting
   Inherits ComboEditorSetting
'Usage

Dim instance As EnumValueEditorSetting
public class EnumValueEditorSetting : ComboEditorSetting
public ref class EnumValueEditorSetting : public ComboEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.EnumValueEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumValueEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

EnumValueEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : EnumValueEditorSetting Class

The following tables list the members exposed by EnumValueEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | EnumValueEditorSetting Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | DisplayMember | 下拉项目文本属性。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Source | 下拉项目集合。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | TemplateName | 内置的数据模板名称。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | ValueMember | 下拉项目值属性。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

EnumValueEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

EnumValueEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > EnumValueEditorSetting Class : EnumValueEditorSetting Constructor
枚举类型。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal enumType As Type _
)
'Usage

Dim enumType As Type

Dim instance As New EnumValueEditorSetting(enumType)
public EnumValueEditorSetting(
   Type enumType
)
public:
EnumValueEditorSetting(
   Type^ enumType
)

Parameters

enumType
枚举类型。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnumValueEditorSetting Class
EnumValueEditorSetting Members


%%PageItemTitle%%

FormulaSelectorEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : FormulaSelectorEditorSetting Class
公式类型的属性对应的编辑器，如[缺省值]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class FormulaSelectorEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As FormulaSelectorEditorSetting
public class FormulaSelectorEditorSetting : BuiltinEditorSetting
public ref class FormulaSelectorEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.FormulaSelectorEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaSelectorEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

FormulaSelectorEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : FormulaSelectorEditorSetting Class

The following tables list the members exposed by FormulaSelectorEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | FormulaSelectorEditorSetting Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | OnlySupportCell | 是否只能选择单元格，不支持单元格区域或者函数。
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | ShowSheetName | 显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

FormulaSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

FormulaSelectorEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > FormulaSelectorEditorSetting Class : FormulaSelectorEditorSetting Constructor
是否只能选择单元格。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal onlySupportCell As Boolean _
)
'Usage

Dim onlySupportCell As Boolean

Dim instance As New FormulaSelectorEditorSetting(onlySupportCell)
public FormulaSelectorEditorSetting(
   bool onlySupportCell
)
public:
FormulaSelectorEditorSetting(
   bool onlySupportCell
)

Parameters

onlySupportCell
是否只能选择单元格。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaSelectorEditorSetting Class
FormulaSelectorEditorSetting Members


%%PageItemTitle%% $$Properties$$

FormulaSelectorEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : FormulaSelectorEditorSetting Class

For a list of all members of this type, see FormulaSelectorEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | OnlySupportCell | 是否只能选择单元格，不支持单元格区域或者函数。
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | ShowSheetName | 显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

FormulaSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

OnlySupportCell Property (FormulaSelectorEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > FormulaSelectorEditorSetting Class : OnlySupportCell Property
是否只能选择单元格，不支持单元格区域或者函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property OnlySupportCell As Boolean
'Usage

Dim instance As FormulaSelectorEditorSetting
Dim value As Boolean

value = instance.OnlySupportCell
public bool OnlySupportCell {get;}
public:
property bool OnlySupportCell {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaSelectorEditorSetting Class
FormulaSelectorEditorSetting Members


%%ItemTitle%%

ShowSheetName Property

GrapeCity.Forguncy.Plugin Namespace > FormulaSelectorEditorSetting Class : ShowSheetName Property
显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ShowSheetName As Boolean
'Usage

Dim instance As FormulaSelectorEditorSetting
Dim value As Boolean

instance.ShowSheetName = value

value = instance.ShowSheetName
public bool ShowSheetName {get; set;}
public:
property bool ShowSheetName {
   bool get();
   void set (    bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaSelectorEditorSetting Class
FormulaSelectorEditorSetting Members


%%ItemTitle%%

TemplateName Property (FormulaSelectorEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > FormulaSelectorEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As FormulaSelectorEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FormulaSelectorEditorSetting Class
FormulaSelectorEditorSetting Members


%%PageItemTitle%%

HyperlinkEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : HyperlinkEditorSetting Class
超链接编辑器，如果一个属性比较复杂，需要单独提供一个对话框去设置属性内部的值的时候会用到这个编辑器，如[编辑菜单项目...]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class HyperlinkEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As HyperlinkEditorSetting
public class HyperlinkEditorSetting : BuiltinEditorSetting
public ref class HyperlinkEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.HyperlinkEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperlinkEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

HyperlinkEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : HyperlinkEditorSetting Class

The following tables list the members exposed by HyperlinkEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | HyperlinkEditorSetting Constructor | 构造函数。
Top
Public Properties
 | Name | Description
Public Property | Command | 点击超链接要执行的命令。
Public Property | DefaultCaptionVisibility | Overridden. 命令插件中的属性编辑器中的属性名是否显示。
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

HyperlinkEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

HyperlinkEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > HyperlinkEditorSetting Class : HyperlinkEditorSetting Constructor
点击超链接要执行的命令。
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal command As ICommand _
)
'Usage

Dim command As ICommand

Dim instance As New HyperlinkEditorSetting(command)
public HyperlinkEditorSetting(
   ICommand command
)
public:
HyperlinkEditorSetting(
   ICommand^ command
)

Parameters

command
点击超链接要执行的命令。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperlinkEditorSetting Class
HyperlinkEditorSetting Members


%%PageItemTitle%% $$Properties$$

HyperlinkEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : HyperlinkEditorSetting Class

For a list of all members of this type, see HyperlinkEditorSetting members.

Public Properties
 | Name | Description
Public Property | Command | 点击超链接要执行的命令。
Public Property | DefaultCaptionVisibility | Overridden. 命令插件中的属性编辑器中的属性名是否显示。
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

HyperlinkEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

Command Property (HyperlinkEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > HyperlinkEditorSetting Class : Command Property
点击超链接要执行的命令。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Command As ICommand
'Usage

Dim instance As HyperlinkEditorSetting
Dim value As ICommand

value = instance.Command
public ICommand Command {get;}
public:
property ICommand^ Command {
   ICommand^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperlinkEditorSetting Class
HyperlinkEditorSetting Members


%%ItemTitle%%

DefaultCaptionVisibility Property (HyperlinkEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > HyperlinkEditorSetting Class : DefaultCaptionVisibility Property
命令插件中的属性编辑器中的属性名是否显示。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property DefaultCaptionVisibility As Visibility
'Usage

Dim instance As HyperlinkEditorSetting
Dim value As Visibility

value = instance.DefaultCaptionVisibility
public override Visibility DefaultCaptionVisibility {get;}
public:
property Visibility DefaultCaptionVisibility {
   Visibility get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperlinkEditorSetting Class
HyperlinkEditorSetting Members


%%ItemTitle%%

TemplateName Property (HyperlinkEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > HyperlinkEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As HyperlinkEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HyperlinkEditorSetting Class
HyperlinkEditorSetting Members


%%PageItemTitle%%

ImageEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : ImageEditorSetting Class
图片编辑器。如图片类型使用的[选择图片...]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ImageEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As ImageEditorSetting
public class ImageEditorSetting : BuiltinEditorSetting
public ref class ImageEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.ImageEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

ImageEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : ImageEditorSetting Class

The following tables list the members exposed by ImageEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | ImageEditorSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ImageEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

ImageEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > ImageEditorSetting Class : ImageEditorSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageEditorSetting()
public ImageEditorSetting()
public:
ImageEditorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageEditorSetting Class
ImageEditorSetting Members


%%PageItemTitle%% $$Properties$$

ImageEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : ImageEditorSetting Class

For a list of all members of this type, see ImageEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ImageEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (ImageEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > ImageEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As ImageEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageEditorSetting Class
ImageEditorSetting Members


%%PageItemTitle%%

IntEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : IntEditorSetting Class
整数类型的属性对应的编辑器，如单选按钮使用的[项目间距]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class IntEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As IntEditorSetting
public class IntEditorSetting : BuiltinEditorSetting
public ref class IntEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.IntEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IntEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : IntEditorSetting Class

The following tables list the members exposed by IntEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | IntEditorSetting Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Max | 整数类型的属性编辑器的最大值。
Public Property | Min | 整数类型的属性编辑器的最小值。
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

IntEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

IntEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > IntEditorSetting Class : IntEditorSetting Constructor
Overload List
Overload | Description
IntEditorSetting Constructor() | 构造函数。
IntEditorSetting Constructor(Int32,Int32) | 构造函数，指定了最小值和最大值的整数类型的编辑器。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntEditorSetting Class
IntEditorSetting Members


%%PageItemTitle%%

IntEditorSetting Constructor()

GrapeCity.Forguncy.Plugin Namespace > IntEditorSetting Class > IntEditorSetting Constructor : IntEditorSetting Constructor()
构造函数。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IntEditorSetting()
public IntEditorSetting()
public:
IntEditorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntEditorSetting Class
IntEditorSetting Members
Overload List


%%PageItemTitle%%

IntEditorSetting Constructor(Int32,Int32)

GrapeCity.Forguncy.Plugin Namespace > IntEditorSetting Class > IntEditorSetting Constructor : IntEditorSetting Constructor(Int32,Int32)
构造函数，指定了最小值和最大值的整数类型的编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal min As Integer, _
   ByVal max As Integer _
)
'Usage

Dim min As Integer
Dim max As Integer

Dim instance As New IntEditorSetting(min, max)
public IntEditorSetting(
   int min,
   int max
)
public:
IntEditorSetting(
   int min,
   int max
)

Parameters

min
max
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntEditorSetting Class
IntEditorSetting Members
Overload List


%%PageItemTitle%% $$Properties$$

IntEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : IntEditorSetting Class

For a list of all members of this type, see IntEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Max | 整数类型的属性编辑器的最大值。
Public Property | Min | 整数类型的属性编辑器的最小值。
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

IntEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

Max Property

GrapeCity.Forguncy.Plugin Namespace > IntEditorSetting Class : Max Property
整数类型的属性编辑器的最大值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Max As Integer
'Usage

Dim instance As IntEditorSetting
Dim value As Integer

instance.Max = value

value = instance.Max
public int Max {get; set;}
public:
property int Max {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntEditorSetting Class
IntEditorSetting Members


%%ItemTitle%%

Min Property

GrapeCity.Forguncy.Plugin Namespace > IntEditorSetting Class : Min Property
整数类型的属性编辑器的最小值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Min As Integer
'Usage

Dim instance As IntEditorSetting
Dim value As Integer

instance.Min = value

value = instance.Min
public int Min {get; set;}
public:
property int Min {
   int get();
   void set (    int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntEditorSetting Class
IntEditorSetting Members


%%ItemTitle%%

TemplateName Property (IntEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > IntEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As IntEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IntEditorSetting Class
IntEditorSetting Members


%%PageItemTitle%%

OrientationEidtorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : OrientationEidtorSetting Class
排列方向类型的属性对应的编辑器，如单选按钮使用的[布局]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class OrientationEidtorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As OrientationEidtorSetting
public class OrientationEidtorSetting : BuiltinEditorSetting
public ref class OrientationEidtorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.OrientationEidtorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrientationEidtorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

OrientationEidtorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : OrientationEidtorSetting Class

The following tables list the members exposed by OrientationEidtorSetting.

Public Constructors
 | Name | Description
Public Constructor | OrientationEidtorSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

OrientationEidtorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

OrientationEidtorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > OrientationEidtorSetting Class : OrientationEidtorSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OrientationEidtorSetting()
public OrientationEidtorSetting()
public:
OrientationEidtorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrientationEidtorSetting Class
OrientationEidtorSetting Members


%%PageItemTitle%% $$Properties$$

OrientationEidtorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : OrientationEidtorSetting Class

For a list of all members of this type, see OrientationEidtorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

OrientationEidtorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (OrientationEidtorSetting)

GrapeCity.Forguncy.Plugin Namespace > OrientationEidtorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As OrientationEidtorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OrientationEidtorSetting Class
OrientationEidtorSetting Members


%%PageItemTitle%%

TableComboTreeSelectorEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : TableComboTreeSelectorEditorSetting Class
数据表选择器。如数据导航按钮中使用的[导航表]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class TableComboTreeSelectorEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As TableComboTreeSelectorEditorSetting
public class TableComboTreeSelectorEditorSetting : BuiltinEditorSetting
public ref class TableComboTreeSelectorEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.TableComboTreeSelectorEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableComboTreeSelectorEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

TableComboTreeSelectorEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : TableComboTreeSelectorEditorSetting Class

The following tables list the members exposed by TableComboTreeSelectorEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | TableComboTreeSelectorEditorSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TableComboTreeSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

TableComboTreeSelectorEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > TableComboTreeSelectorEditorSetting Class : TableComboTreeSelectorEditorSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TableComboTreeSelectorEditorSetting()
public TableComboTreeSelectorEditorSetting()
public:
TableComboTreeSelectorEditorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableComboTreeSelectorEditorSetting Class
TableComboTreeSelectorEditorSetting Members


%%PageItemTitle%% $$Properties$$

TableComboTreeSelectorEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : TableComboTreeSelectorEditorSetting Class

For a list of all members of this type, see TableComboTreeSelectorEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TableComboTreeSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (TableComboTreeSelectorEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > TableComboTreeSelectorEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As TableComboTreeSelectorEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TableComboTreeSelectorEditorSetting Class
TableComboTreeSelectorEditorSetting Members


%%PageItemTitle%%

TextEditorSetting Class
Members Example

GrapeCity.Forguncy.Plugin Namespace : TextEditorSetting Class
文本类型的属性对应的编辑器，如[水印]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class TextEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As TextEditorSetting
public class TextEditorSetting : BuiltinEditorSetting
public ref class TextEditorSetting : public BuiltinEditorSetting
Example
  • C#
public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
{
    return new TextEditorSetting();
}
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.TextEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

TextEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : TextEditorSetting Class

The following tables list the members exposed by TextEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | TextEditorSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TextEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

TextEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > TextEditorSetting Class : TextEditorSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TextEditorSetting()
public TextEditorSetting()
public:
TextEditorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextEditorSetting Class
TextEditorSetting Members


%%PageItemTitle%% $$Properties$$

TextEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : TextEditorSetting Class

For a list of all members of this type, see TextEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TextEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (TextEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > TextEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As TextEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TextEditorSetting Class
TextEditorSetting Members


%%PageItemTitle%%

TimeValueEditorSetting Class
Members

GrapeCity.Forguncy.Plugin Namespace : TimeValueEditorSetting Class
时间类型编辑器。如时间单元类型使用的[下拉框开始时间]属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class TimeValueEditorSetting
   Inherits BuiltinEditorSetting
'Usage

Dim instance As TimeValueEditorSetting
public class TimeValueEditorSetting : BuiltinEditorSetting
public ref class TimeValueEditorSetting : public BuiltinEditorSetting
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.TimeValueEditorSetting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeValueEditorSetting Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

TimeValueEditorSetting Class Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : TimeValueEditorSetting Class

The following tables list the members exposed by TimeValueEditorSetting.

Public Constructors
 | Name | Description
Public Constructor | TimeValueEditorSetting Constructor |
Top
Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TimeValueEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%%

TimeValueEditorSetting Constructor

GrapeCity.Forguncy.Plugin Namespace > TimeValueEditorSetting Class : TimeValueEditorSetting Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TimeValueEditorSetting()
public TimeValueEditorSetting()
public:
TimeValueEditorSetting();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeValueEditorSetting Class
TimeValueEditorSetting Members


%%PageItemTitle%% $$Properties$$

TimeValueEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : TimeValueEditorSetting Class

For a list of all members of this type, see TimeValueEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | TemplateName | Overridden. 内置的数据模板名称。
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TimeValueEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

TemplateName Property (TimeValueEditorSetting)

GrapeCity.Forguncy.Plugin Namespace > TimeValueEditorSetting Class : TemplateName Property
内置的数据模板名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TemplateName As String
'Usage

Dim instance As TimeValueEditorSetting
Dim value As String

value = instance.TemplateName
public override string TemplateName {get;}
public:
property String^ TemplateName {
   String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeValueEditorSetting Class
TimeValueEditorSetting Members


%%PageItemTitle%%

IBuilderContextBase Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IBuilderContextBase Interface
设计器上下文信息。
Object Model
IBuilderContextBase InterfaceILocalServerInfo InterfaceIUserServiceInfo Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IBuilderContextBase
'Usage

Dim instance As IBuilderContextBase
public interface IBuilderContextBase
public interface class IBuilderContextBase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IBuilderContextBase Interface Members
Properties Methods

GrapeCity.Forguncy.Plugin Namespace : IBuilderContextBase Interface

The following tables list the members exposed by IBuilderContextBase.

Public Properties
 | Name | Description
Property | AuthenticationMode | 获取当前工程的认证模式。
Property | LocalServerInfo | 本地网站应用信息。
Property | PageName | 获取当前所在页面名称。
Property | UserServiceInfo | 获取用户管理网站的信息。
Top
Public Methods
 | Name | Description
Method | EnumAllListViewInfos | 获取某个页面所有的表格信息。
Method | EnumAllPageInfos | 获取所有的页面信息。
Method | EnumAllTableInfos | 获取所有的数据表信息。
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
Top
See Also

Reference

IBuilderContextBase Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IBuilderContextBase Interface Methods

GrapeCity.Forguncy.Plugin Namespace : IBuilderContextBase Interface

For a list of all members of this type, see IBuilderContextBase members.

Public Methods
 | Name | Description
Method | EnumAllListViewInfos | 获取某个页面所有的表格信息。
Method | EnumAllPageInfos | 获取所有的页面信息。
Method | EnumAllTableInfos | 获取所有的数据表信息。
Method | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
Top
See Also

Reference

IBuilderContextBase Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

EnumAllListViewInfos Method
Example

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : EnumAllListViewInfos Method
页面名，如果为空即表示当前所在页面。
获取某个页面所有的表格信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumAllListViewInfos( _
   ByVal pageName As String _
) As IEnumerable(Of IListViewInfoDesigner)
'Usage

Dim instance As IBuilderContextBase
Dim pageName As String
Dim value As IEnumerable(Of IListViewInfoDesigner)

value = instance.EnumAllListViewInfos(pageName)
IEnumerable<IListViewInfoDesigner> EnumAllListViewInfos(
   string pageName
)
IEnumerable<IListViewInfoDesigner^>^ EnumAllListViewInfos(
   String^ pageName
)

Parameters

pageName
页面名，如果为空即表示当前所在页面。

Return Value

表格集合
Example
  • C#
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>
{
    public string ListViewName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "ListViewName")
        {
            return new ComboEditorSetting(new List<string> (builderContext.EnumAllListViewInfos(null).Select(i=>i.ListViewName)));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%ItemTitle%%

EnumAllPageInfos Method
Example

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : EnumAllPageInfos Method
获取所有的页面信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumAllPageInfos() As IEnumerable(Of IPageInfo)
'Usage

Dim instance As IBuilderContextBase
Dim value As IEnumerable(Of IPageInfo)

value = instance.EnumAllPageInfos()
IEnumerable<IPageInfo> EnumAllPageInfos()
IEnumerable<IPageInfo^>^ EnumAllPageInfos();

Return Value

页面集合。
Example
  • C#
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>
{
    public string NavigatePageName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "NavigatePageName")
        {
            return new ComboEditorSetting(builderContext.EnumAllPageInfos().Select(p => p.PageName));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%ItemTitle%%

EnumAllTableInfos Method
Example

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : EnumAllTableInfos Method
获取所有的数据表信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function EnumAllTableInfos() As IEnumerable(Of ITableInfo)
'Usage

Dim instance As IBuilderContextBase
Dim value As IEnumerable(Of ITableInfo)

value = instance.EnumAllTableInfos()
IEnumerable<ITableInfo> EnumAllTableInfos()
IEnumerable<ITableInfo^>^ EnumAllTableInfos();

Return Value

数据表集合
Example
  • C#
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>
{
    public string TableName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "TableName")
        {
            return new ComboEditorSetting(builderContext.EnumAllTableInfos().Where(t => t.WorkflowInfo != null && t.WorkflowInfo.IsEnabled).Select(t => t.TableName));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%ItemTitle%%

GetBrush Method (IBuilderContextBase)

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : GetBrush Method
颜色字符串
从颜色字符串获取一个WPF的画笔（Brush）。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetBrush( _
   ByVal colorStr As String _
) As Brush
'Usage

Dim instance As IBuilderContextBase
Dim colorStr As String
Dim value As Brush

value = instance.GetBrush(colorStr)
Brush GetBrush(
   string colorStr
)
Brush^ GetBrush(
   String^ colorStr
)

Parameters

colorStr
颜色字符串

Return Value

WPF的画笔
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%PageItemTitle%% $$Properties$$

IBuilderContextBase Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IBuilderContextBase Interface

For a list of all members of this type, see IBuilderContextBase members.

Public Properties
 | Name | Description
Property | AuthenticationMode | 获取当前工程的认证模式。
Property | LocalServerInfo | 本地网站应用信息。
Property | PageName | 获取当前所在页面名称。
Property | UserServiceInfo | 获取用户管理网站的信息。
Top
See Also

Reference

IBuilderContextBase Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

AuthenticationMode Property

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : AuthenticationMode Property
获取当前工程的认证模式。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property AuthenticationMode As AuthenticationMode
'Usage

Dim instance As IBuilderContextBase
Dim value As AuthenticationMode

value = instance.AuthenticationMode
AuthenticationMode AuthenticationMode {get;}
property AuthenticationMode AuthenticationMode {
   AuthenticationMode get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%ItemTitle%%

LocalServerInfo Property

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : LocalServerInfo Property
本地网站应用信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property LocalServerInfo As ILocalServerInfo
'Usage

Dim instance As IBuilderContextBase
Dim value As ILocalServerInfo

value = instance.LocalServerInfo
ILocalServerInfo LocalServerInfo {get;}
property ILocalServerInfo^ LocalServerInfo {
   ILocalServerInfo^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%ItemTitle%%

PageName Property (IBuilderContextBase)

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : PageName Property
获取当前所在页面名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property PageName As String
'Usage

Dim instance As IBuilderContextBase
Dim value As String

value = instance.PageName
string PageName {get;}
property String^ PageName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%ItemTitle%%

UserServiceInfo Property
Example

GrapeCity.Forguncy.Plugin Namespace > IBuilderContextBase Interface : UserServiceInfo Property
获取用户管理网站的信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

ReadOnly Property UserServiceInfo As IUserServiceInfo
'Usage

Dim instance As IBuilderContextBase
Dim value As IUserServiceInfo

value = instance.UserServiceInfo
IUserServiceInfo UserServiceInfo {get;}
property IUserServiceInfo^ UserServiceInfo {
   IUserServiceInfo^ get();
}
Example
  • C#
public class MyUserSelectorCellTypeDesigner : CellTypeDesigner<MyUserSelectorCellType>
{
    public string Role { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "Role")
        {
            return new ComboEditorSetting(builderContext.UserServiceInfo.AllRoles);
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IBuilderContextBase Interface
IBuilderContextBase Members


%%PageItemTitle%%

IEditorSettingsDataContext Interface
Members

GrapeCity.Forguncy.Plugin Namespace : IEditorSettingsDataContext Interface
属性编辑器上下文信息。
Object Model
IEditorSettingsDataContext InterfaceEditorSetting Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IEditorSettingsDataContext
'Usage

Dim instance As IEditorSettingsDataContext
public interface IEditorSettingsDataContext
public interface class IEditorSettingsDataContext
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEditorSettingsDataContext Members
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Members$$

IEditorSettingsDataContext Interface Members
Properties

GrapeCity.Forguncy.Plugin Namespace : IEditorSettingsDataContext Interface

The following tables list the members exposed by IEditorSettingsDataContext.

Public Properties
 | Name | Description
Property | EditorSetting | 属性编辑器。
Property | Value | 属性的值。
Top
See Also

Reference

IEditorSettingsDataContext Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IEditorSettingsDataContext Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IEditorSettingsDataContext Interface

For a list of all members of this type, see IEditorSettingsDataContext members.

Public Properties
 | Name | Description
Property | EditorSetting | 属性编辑器。
Property | Value | 属性的值。
Top
See Also

Reference

IEditorSettingsDataContext Interface
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%%

EditorSetting Property

GrapeCity.Forguncy.Plugin Namespace > IEditorSettingsDataContext Interface : EditorSetting Property
属性编辑器。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property EditorSetting As EditorSetting
'Usage

Dim instance As IEditorSettingsDataContext
Dim value As EditorSetting

instance.EditorSetting = value

value = instance.EditorSetting
EditorSetting EditorSetting {get; set;}
property EditorSetting^ EditorSetting {
   EditorSetting^ get();
   void set (    EditorSetting^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEditorSettingsDataContext Interface
IEditorSettingsDataContext Members


%%ItemTitle%%

Value Property (IEditorSettingsDataContext)

GrapeCity.Forguncy.Plugin Namespace > IEditorSettingsDataContext Interface : Value Property
属性的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Property Value As Object
'Usage

Dim instance As IEditorSettingsDataContext
Dim value As Object

instance.Value = value

value = instance.Value
object Value {get; set;}
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}
Example
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEditorSettingsDataContext Interface
IEditorSettingsDataContext Members


%%ItemTitle%%

GrapeCity.Forguncy.ServerApi Assembly
Namespaces
Namespace | Description
GrapeCity.Forguncy.ServerApi |


%%ItemTitle%%

GrapeCity.Forguncy.ServerApi Namespace
Inheritance Hierarchy
Classes
 | Class | Description
Class | ColumnValuePair | 定义字段的名称和值。
Class | EditData | 提供一个数据结构，用于编辑多个数据。
Class | ForguncyApi | 提供Forguncy服务器端API。 通常情况下，这个类是用来继承而不是直接创建一个新的实例。。
Class | GetAttribute | 指定GET方法要执行的Action。
Class | ModifyData | 提供一种用于创建多个编辑数据的方法。
Class | PostAttribute | 指定POST方法要执行的Action。
Class | ScheduleApiAttribute | 指定该Action应定期执行。
Class | UserInfo | 定义一个用户帐户数据。
Interfaces
 | Interface | Description
Interface | IDataAccess | 提供访问Forguncy表的方法。
Interface | IEmailSender | 提供一种发送电子邮件的方法。
Interface | IUserInfos | 提供用于管理用户帐户的方法。
See Also

Reference

GrapeCity.Forguncy.ServerApi Assembly


%%PageItemTitle%%

ColumnValuePair Class
Members

GrapeCity.Forguncy.ServerApi Namespace : ColumnValuePair Class
定义字段的名称和值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ColumnValuePair
'Usage

Dim instance As ColumnValuePair
public class ColumnValuePair
public ref class ColumnValuePair
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.ServerApi.ColumnValuePair

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnValuePair Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

ColumnValuePair Class Members
Properties

GrapeCity.Forguncy.ServerApi Namespace : ColumnValuePair Class

The following tables list the members exposed by ColumnValuePair.

Public Constructors
 | Name | Description
Public Constructor | ColumnValuePair Constructor |
Top
Public Properties
 | Name | Description
Public Property | ColumnName | 定义字段的名称。
Public Property | Value | 定义字段的值。
Top
See Also

Reference

ColumnValuePair Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

ColumnValuePair Constructor

GrapeCity.Forguncy.ServerApi Namespace > ColumnValuePair Class : ColumnValuePair Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ColumnValuePair()
public ColumnValuePair()
public:
ColumnValuePair();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnValuePair Class
ColumnValuePair Members


%%PageItemTitle%% $$Properties$$

ColumnValuePair Class Properties

GrapeCity.Forguncy.ServerApi Namespace : ColumnValuePair Class

For a list of all members of this type, see ColumnValuePair members.

Public Properties
 | Name | Description
Public Property | ColumnName | 定义字段的名称。
Public Property | Value | 定义字段的值。
Top
See Also

Reference

ColumnValuePair Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

ColumnName Property (ColumnValuePair)

GrapeCity.Forguncy.ServerApi Namespace > ColumnValuePair Class : ColumnName Property
定义字段的名称。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property ColumnName As String
'Usage

Dim instance As ColumnValuePair
Dim value As String

instance.ColumnName = value

value = instance.ColumnName
public string ColumnName {get; set;}
public:
property String^ ColumnName {
   String^ get();
   void set (    String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnValuePair Class
ColumnValuePair Members


%%ItemTitle%%

Value Property (ColumnValuePair)

GrapeCity.Forguncy.ServerApi Namespace > ColumnValuePair Class : Value Property
定义字段的值。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Value As Object
'Usage

Dim instance As ColumnValuePair
Dim value As Object

instance.Value = value

value = instance.Value
public object Value {get; set;}
public:
property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ColumnValuePair Class
ColumnValuePair Members


%%PageItemTitle%%

EditData Class
Members

GrapeCity.Forguncy.ServerApi Namespace : EditData Class
提供一个数据结构，用于编辑多个数据。
Object Model
EditData ClassColumnValuePair Class
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class EditData
'Usage

Dim instance As EditData
public class EditData
public ref class EditData
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.ServerApi.EditData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditData Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

EditData Class Members
Properties

GrapeCity.Forguncy.ServerApi Namespace : EditData Class

The following tables list the members exposed by EditData.

Public Constructors
 | Name | Description
Public Constructor | EditData Constructor |
Top
Public Properties
 | Name | Description
Public Property | PrimaryKey | 定义代表主键的字段名/值对。
Public Property | Values | 定义一个数据列表供编辑。
Top
See Also

Reference

EditData Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

EditData Constructor

GrapeCity.Forguncy.ServerApi Namespace > EditData Class : EditData Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New EditData()
public EditData()
public:
EditData();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditData Class
EditData Members


%%PageItemTitle%% $$Properties$$

EditData Class Properties

GrapeCity.Forguncy.ServerApi Namespace : EditData Class

For a list of all members of this type, see EditData members.

Public Properties
 | Name | Description
Public Property | PrimaryKey | 定义代表主键的字段名/值对。
Public Property | Values | 定义一个数据列表供编辑。
Top
See Also

Reference

EditData Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

PrimaryKey Property

GrapeCity.Forguncy.ServerApi Namespace > EditData Class : PrimaryKey Property
定义代表主键的字段名/值对。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property PrimaryKey As ColumnValuePair
'Usage

Dim instance As EditData
Dim value As ColumnValuePair

instance.PrimaryKey = value

value = instance.PrimaryKey
public ColumnValuePair PrimaryKey {get; set;}
public:
property ColumnValuePair^ PrimaryKey {
   ColumnValuePair^ get();
   void set (    ColumnValuePair^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditData Class
EditData Members


%%ItemTitle%%

Values Property

GrapeCity.Forguncy.ServerApi Namespace > EditData Class : Values Property
定义一个数据列表供编辑。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Values As Dictionary(Of String,Object)
'Usage

Dim instance As EditData
Dim value As Dictionary(Of String,Object)

instance.Values = value

value = instance.Values
public Dictionary<string,object> Values {get; set;}
public:
property Dictionary<String^,Object^>^ Values {
   Dictionary<String^,Object^>^ get();
   void set (    Dictionary<String^,Object^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EditData Class
EditData Members


%%PageItemTitle%%

ForguncyApi Class
Members

GrapeCity.Forguncy.ServerApi Namespace : ForguncyApi Class
提供Forguncy服务器端API。 通常情况下，这个类是用来继承而不是直接创建一个新的实例。。
Object Model
ForguncyApi ClassIDataAccess InterfaceIEmailSender InterfaceIUserInfos Interface
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ForguncyApi
'Usage

Dim instance As ForguncyApi
public class ForguncyApi
public ref class ForguncyApi
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.ServerApi.ForguncyApi

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyApi Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

ForguncyApi Class Members
Properties

GrapeCity.Forguncy.ServerApi Namespace : ForguncyApi Class

The following tables list the members exposed by ForguncyApi.

Public Constructors
 | Name | Description
Public Constructor | ForguncyApi Constructor |
Top
Public Properties
 | Name | Description
Public Property | Context | 返回AspNetCore HttpContext类的实例。
Public Property | DataAccess | 返回一个DataAccess类的实例。
Public Property | EmailSender | 返回EmailSender类的实例。
Public Property | UserInfos | 返回IUserInfos类的实例。
Top
See Also

Reference

ForguncyApi Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

ForguncyApi Constructor

GrapeCity.Forguncy.ServerApi Namespace > ForguncyApi Class : ForguncyApi Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ForguncyApi()
public ForguncyApi()
public:
ForguncyApi();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyApi Class
ForguncyApi Members


%%PageItemTitle%% $$Properties$$

ForguncyApi Class Properties

GrapeCity.Forguncy.ServerApi Namespace : ForguncyApi Class

For a list of all members of this type, see ForguncyApi members.

Public Properties
 | Name | Description
Public Property | Context | 返回AspNetCore HttpContext类的实例。
Public Property | DataAccess | 返回一个DataAccess类的实例。
Public Property | EmailSender | 返回EmailSender类的实例。
Public Property | UserInfos | 返回IUserInfos类的实例。
Top
See Also

Reference

ForguncyApi Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

Context Property (ForguncyApi)

GrapeCity.Forguncy.ServerApi Namespace > ForguncyApi Class : Context Property
返回AspNetCore HttpContext类的实例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property Context As HttpContext
'Usage

Dim instance As ForguncyApi
Dim value As HttpContext

instance.Context = value

value = instance.Context
public HttpContext Context {get; set;}
public:
property HttpContext^ Context {
   HttpContext^ get();
   void set (    HttpContext^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyApi Class
ForguncyApi Members


%%ItemTitle%%

DataAccess Property (ForguncyApi)

GrapeCity.Forguncy.ServerApi Namespace > ForguncyApi Class : DataAccess Property
返回一个DataAccess类的实例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property DataAccess As IDataAccess
'Usage

Dim instance As ForguncyApi
Dim value As IDataAccess

instance.DataAccess = value

value = instance.DataAccess
public IDataAccess DataAccess {get; set;}
public:
property IDataAccess^ DataAccess {
   IDataAccess^ get();
   void set (    IDataAccess^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyApi Class
ForguncyApi Members


%%ItemTitle%%

EmailSender Property

GrapeCity.Forguncy.ServerApi Namespace > ForguncyApi Class : EmailSender Property
返回EmailSender类的实例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property EmailSender As IEmailSender
'Usage

Dim instance As ForguncyApi
Dim value As IEmailSender

instance.EmailSender = value

value = instance.EmailSender
public IEmailSender EmailSender {get; set;}
public:
property IEmailSender^ EmailSender {
   IEmailSender^ get();
   void set (    IEmailSender^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyApi Class
ForguncyApi Members


%%ItemTitle%%

UserInfos Property (ForguncyApi)

GrapeCity.Forguncy.ServerApi Namespace > ForguncyApi Class : UserInfos Property
返回IUserInfos类的实例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Property UserInfos As IUserInfos
'Usage

Dim instance As ForguncyApi
Dim value As IUserInfos

instance.UserInfos = value

value = instance.UserInfos
public IUserInfos UserInfos {get; set;}
public:
property IUserInfos^ UserInfos {
   IUserInfos^ get();
   void set (    IUserInfos^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForguncyApi Class
ForguncyApi Members


%%PageItemTitle%%

GetAttribute Class
Members

GrapeCity.Forguncy.ServerApi Namespace : GetAttribute Class
指定GET方法要执行的Action。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class GetAttribute
   Inherits System.Attribute
'Usage

Dim instance As GetAttribute
public class GetAttribute : System.Attribute
public ref class GetAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.ServerApi.GetAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetAttribute Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

GetAttribute Class Members
Properties Methods

GrapeCity.Forguncy.ServerApi Namespace : GetAttribute Class

The following tables list the members exposed by GetAttribute.

Public Constructors
 | Name | Description
Public Constructor | GetAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

GetAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

GetAttribute Constructor

GrapeCity.Forguncy.ServerApi Namespace > GetAttribute Class : GetAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New GetAttribute()
public GetAttribute()
public:
GetAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GetAttribute Class
GetAttribute Members


%%PageItemTitle%%

ModifyData Class
Members

GrapeCity.Forguncy.ServerApi Namespace : ModifyData Class
提供一种用于创建多个编辑数据的方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ModifyData
'Usage

Dim instance As ModifyData
public class ModifyData
public ref class ModifyData
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.ServerApi.ModifyData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyData Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

ModifyData Class Members
Properties

GrapeCity.Forguncy.ServerApi Namespace : ModifyData Class

The following tables list the members exposed by ModifyData.

Public Constructors
 | Name | Description
Public Constructor | ModifyData Constructor | 返回ModifyData类的实例。
Top
Public Properties
 | Name | Description
Public Property | AddRows | 返回用于一次添加多个记录的列表。
Public Property | DeleteRows | 返回用于一次删除多个记录的列表。
Public Property | EditRows | 返回用于一次更新多个记录的列表。
Top
See Also

Reference

ModifyData Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

ModifyData Constructor

GrapeCity.Forguncy.ServerApi Namespace > ModifyData Class : ModifyData Constructor
返回ModifyData类的实例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ModifyData()
public ModifyData()
public:
ModifyData();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyData Class
ModifyData Members


%%PageItemTitle%% $$Properties$$

ModifyData Class Properties

GrapeCity.Forguncy.ServerApi Namespace : ModifyData Class

For a list of all members of this type, see ModifyData members.

Public Properties
 | Name | Description
Public Property | AddRows | 返回用于一次添加多个记录的列表。
Public Property | DeleteRows | 返回用于一次删除多个记录的列表。
Public Property | EditRows | 返回用于一次更新多个记录的列表。
Top
See Also

Reference

ModifyData Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

AddRows Property

GrapeCity.Forguncy.ServerApi Namespace > ModifyData Class : AddRows Property
返回用于一次添加多个记录的列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property AddRows As List(Of Dictionary(Of String,Object))
'Usage

Dim instance As ModifyData
Dim value As List(Of Dictionary(Of String,Object))

value = instance.AddRows
public List<Dictionary<string,object>> AddRows {get;}
public:
property List<Dictionary<String^,Object^>^>^ AddRows {
   List<Dictionary<String^,Object^>^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyData Class
ModifyData Members


%%ItemTitle%%

DeleteRows Property

GrapeCity.Forguncy.ServerApi Namespace > ModifyData Class : DeleteRows Property
返回用于一次删除多个记录的列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property DeleteRows As List(Of ColumnValuePair)
'Usage

Dim instance As ModifyData
Dim value As List(Of ColumnValuePair)

value = instance.DeleteRows
public List<ColumnValuePair> DeleteRows {get;}
public:
property List<ColumnValuePair^>^ DeleteRows {
   List<ColumnValuePair^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyData Class
ModifyData Members


%%ItemTitle%%

EditRows Property

GrapeCity.Forguncy.ServerApi Namespace > ModifyData Class : EditRows Property
返回用于一次更新多个记录的列表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property EditRows As List(Of EditData)
'Usage

Dim instance As ModifyData
Dim value As List(Of EditData)

value = instance.EditRows
public List<EditData> EditRows {get;}
public:
property List<EditData^>^ EditRows {
   List<EditData^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ModifyData Class
ModifyData Members


%%PageItemTitle%%

PostAttribute Class
Members

GrapeCity.Forguncy.ServerApi Namespace : PostAttribute Class
指定POST方法要执行的Action。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class PostAttribute
   Inherits System.Attribute
'Usage

Dim instance As PostAttribute
public class PostAttribute : System.Attribute
public ref class PostAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.ServerApi.PostAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostAttribute Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

PostAttribute Class Members
Properties Methods

GrapeCity.Forguncy.ServerApi Namespace : PostAttribute Class

The following tables list the members exposed by PostAttribute.

Public Constructors
 | Name | Description
Public Constructor | PostAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

PostAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

PostAttribute Constructor

GrapeCity.Forguncy.ServerApi Namespace > PostAttribute Class : PostAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PostAttribute()
public PostAttribute()
public:
PostAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostAttribute Class
PostAttribute Members


%%PageItemTitle%%

ScheduleApiAttribute Class
Members

GrapeCity.Forguncy.ServerApi Namespace : ScheduleApiAttribute Class
指定该Action应定期执行。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class ScheduleApiAttribute
   Inherits System.Attribute
'Usage

Dim instance As ScheduleApiAttribute
public class ScheduleApiAttribute : System.Attribute
public ref class ScheduleApiAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Forguncy.ServerApi.ScheduleApiAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

ScheduleApiAttribute Class Members
Properties Methods

GrapeCity.Forguncy.ServerApi Namespace : ScheduleApiAttribute Class

The following tables list the members exposed by ScheduleApiAttribute.

Public Constructors
 | Name | Description
Public Constructor | ScheduleApiAttribute Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Interval | 获取当前设置的定期执行间隔。
Public Property | IsValid | 获取设置的间隔是否有效。
Public Property | StartWhen | 获取当前设置的定期执行的执行时间。
Public Property | StartWhenServerStart | 获取是否从Forguncy Server启动时开始安排运行。
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ScheduleApiAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

ScheduleApiAttribute Constructor

GrapeCity.Forguncy.ServerApi Namespace > ScheduleApiAttribute Class : ScheduleApiAttribute Constructor
Overload List
Overload | Description
ScheduleApiAttribute Constructor(String,String) | 指定这是在指定的时间和时间间隔内执行的预定Action。
ScheduleApiAttribute Constructor(String) | 指定Action应以指定的时间间隔定期执行。。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Class
ScheduleApiAttribute Members


%%PageItemTitle%%

ScheduleApiAttribute Constructor(String,String)
Example

GrapeCity.Forguncy.ServerApi Namespace > ScheduleApiAttribute Class > ScheduleApiAttribute Constructor : ScheduleApiAttribute Constructor(String,String)
定期执行时间。 如 "12：30：00"。
定期执行的时间间隔。 应指定为字符串，如 "7"。
指定这是在指定的时间和时间间隔内执行的预定Action。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal startWhen As String, _
   ByVal interval As String _
)
'Usage

Dim startWhen As String
Dim interval As String

Dim instance As New ScheduleApiAttribute(startWhen, interval)
public ScheduleApiAttribute(
   string startWhen,
   string interval
)
public:
ScheduleApiAttribute(
   String^ startWhen,
   String^ interval
)

Parameters

startWhen
定期执行时间。 如 "12：30：00"。
interval
定期执行的时间间隔。 应指定为字符串，如 "7"。
Example
下面的代码示例是一种每周12:30运行（每周7天）的方法。
  • C#
public class Class1 : ForguncyApi
{
    [ScheduleApi("12:30:0", "7")]
    public void SampleScheduleApi1()
    {
        // ここに処理を記述します。
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Class
ScheduleApiAttribute Members
Overload List


%%PageItemTitle%%

ScheduleApiAttribute Constructor(String)
Example

GrapeCity.Forguncy.ServerApi Namespace > ScheduleApiAttribute Class > ScheduleApiAttribute Constructor : ScheduleApiAttribute Constructor(String)
定期处理间隔。 用诸如“ 3：0：0”之类的字符串指定。
指定Action应以指定的时间间隔定期执行。。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal interval As String _
)
'Usage

Dim interval As String

Dim instance As New ScheduleApiAttribute(interval)
public ScheduleApiAttribute(
   string interval
)
public:
ScheduleApiAttribute(
   String^ interval
)

Parameters

interval
定期处理间隔。 用诸如“ 3：0：0”之类的字符串指定。
Example
下面是一个每三小时运行一次的方法的示例代码。
  • C#
public class Class1 : ForguncyApi
{
    [ScheduleApi("3:0:0")]
    public void SampleScheduleApi2()
    {
        // ここに処理を記述します。
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Class
ScheduleApiAttribute Members
Overload List


%%PageItemTitle%% $$Properties$$

ScheduleApiAttribute Class Properties

GrapeCity.Forguncy.ServerApi Namespace : ScheduleApiAttribute Class

For a list of all members of this type, see ScheduleApiAttribute members.

Public Properties
 | Name | Description
Public Property | Interval | 获取当前设置的定期执行间隔。
Public Property | IsValid | 获取设置的间隔是否有效。
Public Property | StartWhen | 获取当前设置的定期执行的执行时间。
Public Property | StartWhenServerStart | 获取是否从Forguncy Server启动时开始安排运行。
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

ScheduleApiAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

Interval Property

GrapeCity.Forguncy.ServerApi Namespace > ScheduleApiAttribute Class : Interval Property
获取当前设置的定期执行间隔。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Interval As TimeSpan
'Usage

Dim instance As ScheduleApiAttribute
Dim value As TimeSpan

value = instance.Interval
public TimeSpan Interval {get;}
public:
property TimeSpan Interval {
   TimeSpan get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Class
ScheduleApiAttribute Members


%%ItemTitle%%

IsValid Property

GrapeCity.Forguncy.ServerApi Namespace > ScheduleApiAttribute Class : IsValid Property
获取设置的间隔是否有效。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property IsValid As Boolean
'Usage

Dim instance As ScheduleApiAttribute
Dim value As Boolean

value = instance.IsValid
public bool IsValid {get;}
public:
property bool IsValid {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Class
ScheduleApiAttribute Members


%%ItemTitle%%

StartWhen Property

GrapeCity.Forguncy.ServerApi Namespace > ScheduleApiAttribute Class : StartWhen Property
获取当前设置的定期执行的执行时间。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property StartWhen As TimeSpan
'Usage

Dim instance As ScheduleApiAttribute
Dim value As TimeSpan

value = instance.StartWhen
public TimeSpan StartWhen {get;}
public:
property TimeSpan StartWhen {
   TimeSpan get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Class
ScheduleApiAttribute Members


%%ItemTitle%%

StartWhenServerStart Property

GrapeCity.Forguncy.ServerApi Namespace > ScheduleApiAttribute Class : StartWhenServerStart Property
获取是否从Forguncy Server启动时开始安排运行。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property StartWhenServerStart As Boolean
'Usage

Dim instance As ScheduleApiAttribute
Dim value As Boolean

value = instance.StartWhenServerStart
public bool StartWhenServerStart {get;}
public:
property bool StartWhenServerStart {
   bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScheduleApiAttribute Class
ScheduleApiAttribute Members


%%PageItemTitle%%

UserInfo Class
Members

GrapeCity.Forguncy.ServerApi Namespace : UserInfo Class
定义一个用户帐户数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Class UserInfo
'Usage

Dim instance As UserInfo
public class UserInfo
public ref class UserInfo
Inheritance Hierarchy

System.Object
GrapeCity.Forguncy.ServerApi.UserInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInfo Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

UserInfo Class Members
Properties Methods

GrapeCity.Forguncy.ServerApi Namespace : UserInfo Class

The following tables list the members exposed by UserInfo.

Public Constructors
 | Name | Description
Public Constructor | UserInfo Constructor | 给定行数据，初始化UserInfo的新实例。
Top
Public Properties
 | Name | Description
Public Property | Email | 获取电子邮件地址。
Public Property | FullName | 获取全名。
Public Property | Role | 获得角色。
Public Property | UserName | 获取用户名。
Top
Public Methods
 | Name | Description
Public Method | GetPropertyValue | 获取扩展属性。
Top
See Also

Reference

UserInfo Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%%

UserInfo Constructor

GrapeCity.Forguncy.ServerApi Namespace > UserInfo Class : UserInfo Constructor
数据行
给定行数据，初始化UserInfo的新实例。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function New( _
   ByVal row As DataRow _
)
'Usage

Dim row As DataRow

Dim instance As New UserInfo(row)
public UserInfo(
   DataRow row
)
public:
UserInfo(
   DataRow^ row
)

Parameters

row
数据行
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInfo Class
UserInfo Members


%%PageItemTitle%% $$Methods$$

UserInfo Class Methods

GrapeCity.Forguncy.ServerApi Namespace : UserInfo Class

For a list of all members of this type, see UserInfo members.

Public Methods
 | Name | Description
Public Method | GetPropertyValue | 获取扩展属性。
Top
See Also

Reference

UserInfo Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

GetPropertyValue Method

GrapeCity.Forguncy.ServerApi Namespace > UserInfo Class : GetPropertyValue Method
扩展属性名
获取扩展属性。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Function GetPropertyValue( _
   ByVal propertyName As String _
) As String
'Usage

Dim instance As UserInfo
Dim propertyName As String
Dim value As String

value = instance.GetPropertyValue(propertyName)
public string GetPropertyValue(
   string propertyName
)
public:
String^ GetPropertyValue(
   String^ propertyName
)

Parameters

propertyName
扩展属性名
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInfo Class
UserInfo Members


%%PageItemTitle%% $$Properties$$

UserInfo Class Properties

GrapeCity.Forguncy.ServerApi Namespace : UserInfo Class

For a list of all members of this type, see UserInfo members.

Public Properties
 | Name | Description
Public Property | Email | 获取电子邮件地址。
Public Property | FullName | 获取全名。
Public Property | Role | 获得角色。
Public Property | UserName | 获取用户名。
Top
See Also

Reference

UserInfo Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

Email Property

GrapeCity.Forguncy.ServerApi Namespace > UserInfo Class : Email Property
获取电子邮件地址。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Email As String
'Usage

Dim instance As UserInfo
Dim value As String

value = instance.Email
public string Email {get;}
public:
property String^ Email {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInfo Class
UserInfo Members


%%ItemTitle%%

FullName Property

GrapeCity.Forguncy.ServerApi Namespace > UserInfo Class : FullName Property
获取全名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property FullName As String
'Usage

Dim instance As UserInfo
Dim value As String

value = instance.FullName
public string FullName {get;}
public:
property String^ FullName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInfo Class
UserInfo Members


%%ItemTitle%%

Role Property

GrapeCity.Forguncy.ServerApi Namespace > UserInfo Class : Role Property
获得角色。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property Role As String
'Usage

Dim instance As UserInfo
Dim value As String

value = instance.Role
public string Role {get;}
public:
property String^ Role {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInfo Class
UserInfo Members


%%ItemTitle%%

UserName Property

GrapeCity.Forguncy.ServerApi Namespace > UserInfo Class : UserName Property
获取用户名。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public ReadOnly Property UserName As String
'Usage

Dim instance As UserInfo
Dim value As String

value = instance.UserName
public string UserName {get;}
public:
property String^ UserName {
   String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserInfo Class
UserInfo Members


%%PageItemTitle%%

IDataAccess Interface
Members

GrapeCity.Forguncy.ServerApi Namespace : IDataAccess Interface
提供访问Forguncy表的方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IDataAccess
'Usage

Dim instance As IDataAccess
public interface IDataAccess
public interface class IDataAccess
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

IDataAccess Interface Members
Methods

GrapeCity.Forguncy.ServerApi Namespace : IDataAccess Interface

The following tables list the members exposed by IDataAccess.

Public Methods
 | Name | Description
Method | AddTableData | 将数据添加到指定的表。
Method | DeleteTableData | 从表中删除与指定值匹配的记录。
Method | GetTableData | Overloaded. 从表中获取与指定值匹配的记录。
Method | ModifyTablesData | 根据多个已编辑的数据更新（添加/编辑/删除）数据。
Method | UpdateTableData | 更新与指定值匹配的记录。
Top
See Also

Reference

IDataAccess Interface
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Methods$$

IDataAccess Interface Methods

GrapeCity.Forguncy.ServerApi Namespace : IDataAccess Interface

For a list of all members of this type, see IDataAccess members.

Public Methods
 | Name | Description
Method | AddTableData | 将数据添加到指定的表。
Method | DeleteTableData | 从表中删除与指定值匹配的记录。
Method | GetTableData | Overloaded. 从表中获取与指定值匹配的记录。
Method | ModifyTablesData | 根据多个已编辑的数据更新（添加/编辑/删除）数据。
Method | UpdateTableData | 更新与指定值匹配的记录。
Top
See Also

Reference

IDataAccess Interface
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

AddTableData Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IDataAccess Interface : AddTableData Method
要向其添加数据的表名。
作为字段名称和值的集合创建的其他数据。
将数据添加到指定的表。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub AddTableData( _
   ByVal tableName As String, _
   ByVal newValues As Dictionary(Of String,Object) _
)
'Usage

Dim instance As IDataAccess
Dim tableName As String
Dim newValues As Dictionary(Of String,Object)

instance.AddTableData(tableName, newValues)
void AddTableData(
   string tableName,
   Dictionary<string,object> newValues
)
void AddTableData(
   String^ tableName,
   Dictionary<String^,Object^>^ newValues
)

Parameters

tableName
要向其添加数据的表名。
newValues
作为字段名称和值的集合创建的其他数据。
Example
下面的代码示例根据POST方法基于请求的内容将值添加到Forguncy表。。
  • C#
public class SampleApi : ForguncyApi
{
    [Post]
    public void AddSampleData()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();

        Dictionary<string, object> values = new Dictionary<string, object>();

        values.Add("date", DateTime.Now);
        values.Add("message", message);
        values.Add("ip", Context.Request.RemoteIpAddress);

        this.DataAccess.AddTableData("SampleTable1", values);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Interface
IDataAccess Members


%%ItemTitle%%

DeleteTableData Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IDataAccess Interface : DeleteTableData Method
要删除的表名。
字段名称/值对（使用唯一字段）以指定找到的集合。
从表中删除与指定值匹配的记录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub DeleteTableData( _
   ByVal tableName As String, _
   ByVal primaryKey As ColumnValuePair _
)
'Usage

Dim instance As IDataAccess
Dim tableName As String
Dim primaryKey As ColumnValuePair

instance.DeleteTableData(tableName, primaryKey)
void DeleteTableData(
   string tableName,
   ColumnValuePair primaryKey
)
void DeleteTableData(
   String^ tableName,
   ColumnValuePair^ primaryKey
)

Parameters

tableName
要删除的表名。
primaryKey
字段名称/值对（使用唯一字段）以指定找到的集合。
Example
下面的代码示例根据POST方法发出的请求的内容删除Forguncy表中的特定记录。
  • C#
public class SampleApi : ForguncyApi
{
    [Post]
    public void DeleteDataSample()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();
        var valuePair = JsonConvert.DeserializeObject<ColumnValuePair>(message);

        this.DataAccess.DeleteTableData("SampleTable1", valuePair);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Interface
IDataAccess Members


%%ItemTitle%%

GetTableData Method (IDataAccess)

GrapeCity.Forguncy.ServerApi Namespace > IDataAccess Interface : GetTableData Method
从表中获取与指定值匹配的记录。
Overload List
Overload | Description
GetTableData(String,ColumnValuePair) | 从表中获取与指定值匹配的记录。
GetTableData(String) | 通过指定OData路径获取一条记录。 在资源路径之后指定OData路径，但不包括根URI。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Interface
IDataAccess Members


%%ItemTitle%%

GetTableData(String,ColumnValuePair) Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IDataAccess Interface > GetTableData Method : GetTableData(String,ColumnValuePair) Method
要获取的表名。
字段名称/值对（使用唯一字段）以指定找到的集合
从表中获取与指定值匹配的记录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableData( _
   ByVal tableName As String, _
   ByVal primaryKey As ColumnValuePair _
) As Dictionary(Of String,Object)
'Usage

Dim instance As IDataAccess
Dim tableName As String
Dim primaryKey As ColumnValuePair
Dim value As Dictionary(Of String,Object)

value = instance.GetTableData(tableName, primaryKey)
Dictionary<string,object> GetTableData(
   string tableName,
   ColumnValuePair primaryKey
)
Dictionary<String^,Object^>^ GetTableData(
   String^ tableName,
   ColumnValuePair^ primaryKey
)

Parameters

tableName
要获取的表名。
primaryKey
字段名称/值对（使用唯一字段）以指定找到的集合
Example
下面的代码示例根据POST方法请求的内容在Forguncy表中检索特定记录。
  • C#
public class SampleApi : ForguncyApi
{
    [Post]
    public void GetDataSample()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();
        var valuePair = JsonConvert.DeserializeObject<ColumnValuePair>(message);

        using (var responseWriter = new StreamWriter(this.Context.Response.Body, Encoding.UTF8))
        {
            responseWriter.Write(JsonConvert.SerializeObject(this.DataAccess.GetTableData("SampleTable1", valuePair), Formatting.Indented));
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Interface
IDataAccess Members
Overload List


%%ItemTitle%%

GetTableData(String) Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IDataAccess Interface > GetTableData Method : GetTableData(String) Method
OData路径。
通过指定OData路径获取一条记录。 在资源路径之后指定OData路径，但不包括根URI。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function GetTableData( _
   ByVal odataPath As String _
) As Object
'Usage

Dim instance As IDataAccess
Dim odataPath As String
Dim value As Object

value = instance.GetTableData(odataPath)
object GetTableData(
   string odataPath
)
Object^ GetTableData(
   String^ odataPath
)

Parameters

odataPath
OData路径。
Example
下面的代码示例在POST方法中接收OData路径，并基于该路径检索Forguncy表中的记录。
  • C#
public class SampleApi : ForguncyApi
{
    [Post]
    public void GetDataSampleByOData()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();

        using (var responseWriter = new StreamWriter(this.Context.Response.Body, Encoding.UTF8))
        {
            responseWriter.Write(JsonConvert.SerializeObject(this.DataAccess.GetTableData(message), Formatting.Indented));
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Interface
IDataAccess Members
Overload List


%%ItemTitle%%

ModifyTablesData Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IDataAccess Interface : ModifyTablesData Method
要编辑的数据列表。
根据多个已编辑的数据更新（添加/编辑/删除）数据。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub ModifyTablesData( _
   ByVal modifyData As Dictionary(Of String,ModifyData) _
)
'Usage

Dim instance As IDataAccess
Dim modifyData As Dictionary(Of String,ModifyData)

instance.ModifyTablesData(modifyData)
void ModifyTablesData(
   Dictionary<string,ModifyData> modifyData
)
void ModifyTablesData(
   Dictionary<String^,ModifyData^>^ modifyData
)

Parameters

modifyData
要编辑的数据列表。
Example
下面的代码示例添加，更新和删除多个数据。 添加到DeleteRows属性的ColumnValuePair对象必须指定一个唯一记录，例如ID/值。 添加到EditRows属性的EditData对象的PrimaryKey属性还必须具有唯一记录。
  • C#
public class SampleApi : ForguncyApi
{
    [Post]
    public void ModifySampleData()
    {
        var data = new Dictionary<string, ModifyData>();
        var modifyData = new ModifyData();
        modifyData.AddRows.Add(new Dictionary<string, object>
        {
            {"フィールド1", 1 },
            {"フィールド2", 2 }
        });
        modifyData.DeleteRows.Add(new ColumnValuePair()
        {
            ColumnName = "ID",
            Value = 2
        });
        modifyData.EditRows.Add(new EditData()
        {
            PrimaryKey = new ColumnValuePair()
            {
                ColumnName = "ID",
                Value = 3
            },
            Values = new Dictionary<string, object>
            {
                {"フィールド1", 1 },
                {"フィールド2", 2 }
            }
        });
        data.Add("テーブル1", modifyData);
        this.DataAccess.ModifyTablesData(data);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Interface
IDataAccess Members


%%ItemTitle%%

UpdateTableData Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IDataAccess Interface : UpdateTableData Method
更新目标表名称。
字段名称/值对（使用唯一字段）以指定找到的集合。
要被更新的值，Key表示列名，值是要被更新的值。
更新与指定值匹配的记录。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub UpdateTableData( _
   ByVal tableName As String, _
   ByVal primaryKey As ColumnValuePair, _
   ByVal updateValues As Dictionary(Of String,Object) _
)
'Usage

Dim instance As IDataAccess
Dim tableName As String
Dim primaryKey As ColumnValuePair
Dim updateValues As Dictionary(Of String,Object)

instance.UpdateTableData(tableName, primaryKey, updateValues)
void UpdateTableData(
   string tableName,
   ColumnValuePair primaryKey,
   Dictionary<string,object> updateValues
)
void UpdateTableData(
   String^ tableName,
   ColumnValuePair^ primaryKey,
   Dictionary<String^,Object^>^ updateValues
)

Parameters

tableName
更新目标表名称。
primaryKey
字段名称/值对（使用唯一字段）以指定找到的集合。
updateValues
要被更新的值，Key表示列名，值是要被更新的值。
Example
下面的代码示例根据POST方法请求的内容更新Forguncy表中的特定记录。。
  • C#
public class SampleApi : ForguncyApi
{
    [Post]
    public void UpdateDataSample()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();
        UpdateObj updateData = JsonConvert.DeserializeObject<UpdateObj>(message);
        var targetRecord = new ColumnValuePair() { ColumnName = "ID", Value = updateData.ID };

        this.DataAccess.UpdateTableData("SampleTable1", targetRecord, updateData.UpdateData);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDataAccess Interface
IDataAccess Members


%%PageItemTitle%%

IEmailSender Interface
Members

GrapeCity.Forguncy.ServerApi Namespace : IEmailSender Interface
提供一种发送电子邮件的方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IEmailSender
'Usage

Dim instance As IEmailSender
public interface IEmailSender
public interface class IEmailSender
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEmailSender Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

IEmailSender Interface Members
Methods

GrapeCity.Forguncy.ServerApi Namespace : IEmailSender Interface

The following tables list the members exposed by IEmailSender.

Public Methods
 | Name | Description
Method | SendEmail | Overloaded. 将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
Top
See Also

Reference

IEmailSender Interface
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Methods$$

IEmailSender Interface Methods

GrapeCity.Forguncy.ServerApi Namespace : IEmailSender Interface

For a list of all members of this type, see IEmailSender members.

Public Methods
 | Name | Description
Method | SendEmail | Overloaded. 将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
Top
See Also

Reference

IEmailSender Interface
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

SendEmail Method

GrapeCity.Forguncy.ServerApi Namespace > IEmailSender Interface : SendEmail Method
将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
Overload List
Overload | Description
SendEmail(String,String,String,String) | 将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
SendEmail(String,List<String>,String,String) | 将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。。
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEmailSender Interface
IEmailSender Members


%%ItemTitle%%

SendEmail(String,String,String,String) Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IEmailSender Interface > SendEmail Method : SendEmail(String,String,String,String) Method
发件人的电子邮件地址。
收件人的电子邮件地址。
要发送的电子邮件标题。
要发送的电子邮件正文。
将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function SendEmail( _
   ByVal from As String, _
   ByVal to As String, _
   ByVal title As String, _
   ByVal content As String _
) As String
'Usage

Dim instance As IEmailSender
Dim from As String
Dim to As String
Dim title As String
Dim content As String
Dim value As String

value = instance.SendEmail(from, to, title, content)
string SendEmail(
   string from,
   string to,
   string title,
   string content
)
String^ SendEmail(
   String^ from,
   String^ to,
   String^ title,
   String^ content
)

Parameters

from
发件人的电子邮件地址。
to
收件人的电子邮件地址。
title
要发送的电子邮件标题。
content
要发送的电子邮件正文。
Example
以下代码示例使用HTML标签发送电子邮件。
  • C#
public class SampleApi : ForguncyApi
{
    [Get]
    public void SendMail()
    {
        var errorMessage = this.EmailSender.SendEmail("examplefrom@example.com", "exampleto@example.com", "発注警告メール", "<h1>在庫数が少なくなっています</h1><p>在庫数が残りわずかとなりました。発注処理をこなってください。</p>");
        if (string.IsNullOrEmpty(errorMessage))
        {
            // 成功
        }
        else
        {
            // 失敗
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEmailSender Interface
IEmailSender Members
Overload List


%%ItemTitle%%

SendEmail(String,List<String>,String,String) Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IEmailSender Interface > SendEmail Method : SendEmail(String,List<String>,String,String) Method
发件人的电子邮件地址。
收件人的电子邮件地址列表。
要发送的电子邮件标题。
要发送的电子邮件正文。
将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Overloads Function SendEmail( _
   ByVal from As String, _
   ByVal to As List(Of String), _
   ByVal title As String, _
   ByVal content As String _
) As String
'Usage

Dim instance As IEmailSender
Dim from As String
Dim to As List(Of String)
Dim title As String
Dim content As String
Dim value As String

value = instance.SendEmail(from, to, title, content)
string SendEmail(
   string from,
   List<string> to,
   string title,
   string content
)
String^ SendEmail(
   String^ from,
   List<String^>^ to,
   String^ title,
   String^ content
)

Parameters

from
发件人的电子邮件地址。
to
收件人的电子邮件地址列表。
title
要发送的电子邮件标题。
content
要发送的电子邮件正文。
Example
HTMLタグを使用したメールを複数の宛先に送信するコード例を次に示します。
  • C#
public class SampleApi : ForguncyApi
{
    [Get]
    public void SendMail()
    {
        var toList = new List<string>() { "example1@example.com", "example2@example.com" };
        var errorMessage = this.EmailSender.SendEmail("examplefrom@example.com", toList, "発注警告メール", "<h1>在庫数が少なくなっています</h1><p>在庫数が残りわずかとなりました。発注処理をこなってください。</p>");
        if (string.IsNullOrEmpty(errorMessage))
        {
            // 成功
        }
        else
        {
            // 失敗
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IEmailSender Interface
IEmailSender Members
Overload List


%%PageItemTitle%%

IUserInfos Interface
Members

GrapeCity.Forguncy.ServerApi Namespace : IUserInfos Interface
提供用于管理用户帐户的方法。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Public Interface IUserInfos
'Usage

Dim instance As IUserInfos
public interface IUserInfos
public interface class IUserInfos
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUserInfos Members
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Members$$

IUserInfos Interface Members
Methods

GrapeCity.Forguncy.ServerApi Namespace : IUserInfos Interface

The following tables list the members exposed by IUserInfos.

Public Methods
 | Name | Description
Method | AddUser | 添加Forguncy用户帐户。
Method | DeleteUser | 删除Forguncy用户帐户。
Method | GetUserInfos | 获取所有注册的Forguncy用户帐户信息。
Top
See Also

Reference

IUserInfos Interface
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Methods$$

IUserInfos Interface Methods

GrapeCity.Forguncy.ServerApi Namespace : IUserInfos Interface

For a list of all members of this type, see IUserInfos members.

Public Methods
 | Name | Description
Method | AddUser | 添加Forguncy用户帐户。
Method | DeleteUser | 删除Forguncy用户帐户。
Method | GetUserInfos | 获取所有注册的Forguncy用户帐户信息。
Top
See Also

Reference

IUserInfos Interface
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%%

AddUser Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IUserInfos Interface : AddUser Method
用户名
密码
邮件地址
显示名称
扩展属性列表
添加Forguncy用户帐户。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub AddUser( _
   ByVal userName As String, _
   ByVal password As String, _
   ByVal email As String, _
   ByVal displayName As String, _
   ByVal extendedPropertyList As Dictionary(Of String,String) _
)
'Usage

Dim instance As IUserInfos
Dim userName As String
Dim password As String
Dim email As String
Dim displayName As String
Dim extendedPropertyList As Dictionary(Of String,String)

instance.AddUser(userName, password, email, displayName, extendedPropertyList)
void AddUser(
   string userName,
   string password,
   string email,
   string displayName,
   Dictionary<string,string> extendedPropertyList
)
void AddUser(
   String^ userName,
   String^ password,
   String^ email,
   String^ displayName,
   Dictionary<String^,String^>^ extendedPropertyList
)

Parameters

userName
用户名
password
密码
email
邮件地址
displayName
显示名称
extendedPropertyList
扩展属性列表
Example
指定注册所需的信息并添加一个Forguncy用户帐户。。
  • C#
public class SampleApi : ForguncyApi
{
    [Get]
    public void TestAddUser()
    {
    var dic = new Dictionary<string, string>();
    dic.Add("上長", "Administrator");// '上長'、および'肩書'という名称の拡張属性の値を設定
    dic.Add("肩書", "プロダクトマネージャ");
    this.UserInfos.AddUser("testUser1", "123456", "example1@example.com", "テスト一郎", dic);
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUserInfos Interface
IUserInfos Members


%%ItemTitle%%

DeleteUser Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IUserInfos Interface : DeleteUser Method
用户名
删除Forguncy用户帐户。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Sub DeleteUser( _
   ByVal userName As String _
)
'Usage

Dim instance As IUserInfos
Dim userName As String

instance.DeleteUser(userName)
void DeleteUser(
   string userName
)
void DeleteUser(
   String^ userName
)

Parameters

userName
用户名
Example
通过用户名删除Forguncy用户帐户。
  • C#
public class SampleApi : ForguncyApi
{
    [Get]
    public void TestDeleteUser()
    {
        this.UserInfos.DeleteUser("testUser1");
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUserInfos Interface
IUserInfos Members


%%ItemTitle%%

GetUserInfos Method
Example

GrapeCity.Forguncy.ServerApi Namespace > IUserInfos Interface : GetUserInfos Method
获取所有注册的Forguncy用户帐户信息。
Syntax
  • Visual Basic
  • C#
  • C++/CLI
'Declaration

Function GetUserInfos() As List(Of UserInfo)
'Usage

Dim instance As IUserInfos
Dim value As List(Of UserInfo)

value = instance.GetUserInfos()
List<UserInfo> GetUserInfos()
List<UserInfo^>^ GetUserInfos();
Example
以下代码示例检索所有Forguncy用户帐户信息并将其打印到控制台。。
  • C#
public class SampleApi : ForguncyApi
{
    [Get]
    public void TestGetUser()
    {
        var userInfos = this.UserInfos.GetUserInfos();
        for (int i = 0; i < userInfos.Count; i++)

        {
            var userInfo = userInfos[i];
            Console.Write(userInfo.UserName);
            Console.Write(userInfo.Email);
            Console.Write(userInfo.GetPropertyValue("上長")); // '上長'という名称の拡張属性を取得
        }
    }
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IUserInfos Interface
IUserInfos Members


%%PageItemTitle%% $$Methods$$

CommandDesigner<T> Class Methods

GrapeCity.Forguncy.Commands Namespace : CommandDesigner<T> Class

For a list of all members of this type, see CommandDesigner<T> members.

Public Methods
 | Name | Description
Public Method | GetCommandEditor | Overloaded. 返回命令插件对应的编辑器。 (Inherited from GrapeCity.Forguncy.Commands.CommandDesigner)
Public Method | GetEditorSetting | 返回插件命令内部属性对应的编辑器。 (Inherited from GrapeCity.Forguncy.Commands.CommandDesigner)
Top
See Also

Reference

CommandDesigner<T> Class
GrapeCity.Forguncy.Commands Namespace


%%PageItemTitle%% $$Methods$$

IQueryConditionWindow Interface Methods

GrapeCity.Forguncy.Commands Namespace : IQueryConditionWindow Interface

For a list of all members of this type, see IQueryConditionWindow members.

Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.Commands.IWindow)
Top
See Also

Reference

IQueryConditionWindow Interface
GrapeCity.Forguncy.Commands Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.Commands Namespace (Forguncy.Commands.Design) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.Commands.CommandDesigner
GrapeCity.Forguncy.Commands.CommandDesigner<T>
See Also

Reference

Forguncy.Commands.Design Assembly


%%PageItemTitle%% $$Methods$$

ICommandCellInfo Interface Methods

GrapeCity.Forguncy.Commands Namespace : ICommandCellInfo Interface

For a list of all members of this type, see ICommandCellInfo members.

Public Methods
 | Name | Description
Method | GetFormulaReferObject | 返回单元格对应的公式对象。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Top
See Also

Reference

ICommandCellInfo Interface
GrapeCity.Forguncy.Commands Namespace
ICellInfoBase Interface


%%PageItemTitle%% $$Properties$$

ICommandCellInfo Interface Properties

GrapeCity.Forguncy.Commands Namespace : ICommandCellInfo Interface

For a list of all members of this type, see ICommandCellInfo members.

Public Properties
 | Name | Description
Property | BindingInfo | 单元格的数据绑定信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ColumnIndex | 获取单元格所在列的索引。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | ListViewInfo | 单元格所在表格的信息。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | PageName | 单元格所在的页面名称。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | RowIndex | 获取单元格所在行的索引 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Property | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (Inherited from GrapeCity.Forguncy.Plugin.ICellInfoBase)
Top
See Also

Reference

ICommandCellInfo Interface
GrapeCity.Forguncy.Commands Namespace
ICellInfoBase Interface


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.Commands Namespace (Forguncy.Commands) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.Commands.Command
GrapeCity.Forguncy.Commands.ExecuteResult
GrapeCity.Forguncy.Commands.ExportPageSettingBase
GrapeCity.Forguncy.Commands.ExportPageToExcelSetting
GrapeCity.Forguncy.Commands.ExportPageToPdfSetting
See Also

Reference

Forguncy.Commands Assembly


%%PageItemTitle%% $$Methods$$

CellTypeDesigner<T> Class Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeDesigner<T> Class

For a list of all members of this type, see CellTypeDesigner<T> members.

Public Methods
 | Name | Description
Public Method | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。 (Inherited from GrapeCity.Forguncy.CellTypes.CellTypeDesigner)
Public Method | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。 (Inherited from GrapeCity.Forguncy.CellTypes.CellTypeDesigner)
Top
See Also

Reference

CellTypeDesigner<T> Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

IQueryConditionWindow Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : IQueryConditionWindow Interface

For a list of all members of this type, see IQueryConditionWindow members.

Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

IQueryConditionWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.CellTypes Namespace (GrapeCity.Forguncy.CellTypes.Design) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.CellTypes.CellTypeDesigner
GrapeCity.Forguncy.CellTypes.CellTypeDesigner<T>
See Also

Reference

GrapeCity.Forguncy.CellTypes.Design Assembly


%%PageItemTitle%% $$Methods$$

CategoryHeaderAttribute Class Methods

GrapeCity.Forguncy.CellTypes Namespace : CategoryHeaderAttribute Class

For a list of all members of this type, see CategoryHeaderAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

CategoryHeaderAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

CellTypeStyleTemplateSupportAttribute Class Methods

GrapeCity.Forguncy.CellTypes Namespace : CellTypeStyleTemplateSupportAttribute Class

For a list of all members of this type, see CellTypeStyleTemplateSupportAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

CellTypeStyleTemplateSupportAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

ICommandWindow Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : ICommandWindow Interface

For a list of all members of this type, see ICommandWindow members.

Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

ICommandWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Properties$$

ICommandWindow Interface Properties

GrapeCity.Forguncy.CellTypes Namespace : ICommandWindow Interface

For a list of all members of this type, see ICommandWindow members.

Public Properties
 | Name | Description
Property | DialogResult | 对话框返回结果。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

ICommandWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%%

GetBrush Method (IExportDrawingHelper)

GrapeCity.Forguncy.CellTypes Namespace > IExportDrawingHelper Interface : GetBrush Method
Overload List
Overload | Description
GetBrush |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExportDrawingHelper Interface
IExportDrawingHelper Members


%%PageItemTitle%% $$Methods$$

ISelectImageWindow Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : ISelectImageWindow Interface

For a list of all members of this type, see ISelectImageWindow members.

Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

ISelectImageWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

ISortConditionWindow Interface Methods

GrapeCity.Forguncy.CellTypes Namespace : ISortConditionWindow Interface

For a list of all members of this type, see ISortConditionWindow members.

Public Methods
 | Name | Description
Method | ShowDialog | 打开对话框。 (Inherited from GrapeCity.Forguncy.CellTypes.IWindow)
Top
See Also

Reference

ISortConditionWindow Interface
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

SupportLanguageScopeAttribute Class Methods

GrapeCity.Forguncy.CellTypes Namespace : SupportLanguageScopeAttribute Class

For a list of all members of this type, see SupportLanguageScopeAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

SupportLanguageScopeAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%PageItemTitle%% $$Methods$$

SupportUsingScopeAttribute Class Methods

GrapeCity.Forguncy.CellTypes Namespace : SupportUsingScopeAttribute Class

For a list of all members of this type, see SupportUsingScopeAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

SupportUsingScopeAttribute Class
GrapeCity.Forguncy.CellTypes Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.CellTypes Namespace (GrapeCity.Forguncy.CellTypes) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.CellTypes.CellType
GrapeCity.Forguncy.CellTypes.CellTypeStyleTemplate
GrapeCity.Forguncy.CellTypes.ExportResultInfo
GrapeCity.Forguncy.CellTypes.PartStyleUnit
GrapeCity.Forguncy.CellTypes.SubUIPermission
GrapeCity.Forguncy.CellTypes.UIPermission
GrapeCity.Forguncy.CellTypes.TemplatePart
GrapeCity.Forguncy.CellTypes.TemplatePartStyle
System.Attribute
GrapeCity.Forguncy.CellTypes.CategoryHeaderAttribute
GrapeCity.Forguncy.CellTypes.CellTypeStyleTemplateSupportAttribute
GrapeCity.Forguncy.CellTypes.SupportLanguageScopeAttribute
GrapeCity.Forguncy.CellTypes.SupportUsingScopeAttribute
See Also

Reference

GrapeCity.Forguncy.CellTypes Assembly


%%PageItemTitle%% $$Methods$$

CheckBoxEidtorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : CheckBoxEidtorSetting Class

For a list of all members of this type, see CheckBoxEidtorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

CheckBoxEidtorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

ColorSelectorEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : ColorSelectorEditorSetting Class

For a list of all members of this type, see ColorSelectorEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ColorSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

ComboEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : ComboEditorSetting Class

For a list of all members of this type, see ComboEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ComboEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

DoubleEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : DoubleEditorSetting Class

For a list of all members of this type, see DoubleEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

DoubleEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

EnumValueEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : EnumValueEditorSetting Class

For a list of all members of this type, see EnumValueEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

EnumValueEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

EnumValueEditorSetting Class Properties

GrapeCity.Forguncy.Plugin Namespace : EnumValueEditorSetting Class

For a list of all members of this type, see EnumValueEditorSetting members.

Public Properties
 | Name | Description
Public Property | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | DisplayMember | 下拉项目文本属性。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | IsEnabled | 属性编辑器是否可用。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Public Property | Source | 下拉项目集合。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | TemplateName | 内置的数据模板名称。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | ValueMember | 下拉项目值属性。 (Inherited from GrapeCity.Forguncy.Plugin.ComboEditorSetting)
Public Property | Visibility | 属性编辑器是否可见。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

EnumValueEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

FormulaSelectorEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : FormulaSelectorEditorSetting Class

For a list of all members of this type, see FormulaSelectorEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

FormulaSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

HyperlinkEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : HyperlinkEditorSetting Class

For a list of all members of this type, see HyperlinkEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

HyperlinkEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

ImageEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : ImageEditorSetting Class

For a list of all members of this type, see ImageEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

ImageEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IntEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : IntEditorSetting Class

For a list of all members of this type, see IntEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

IntEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

OrientationEidtorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : OrientationEidtorSetting Class

For a list of all members of this type, see OrientationEidtorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

OrientationEidtorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

TableComboTreeSelectorEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : TableComboTreeSelectorEditorSetting Class

For a list of all members of this type, see TableComboTreeSelectorEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TableComboTreeSelectorEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

TextEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : TextEditorSetting Class

For a list of all members of this type, see TextEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TextEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

TimeValueEditorSetting Class Methods

GrapeCity.Forguncy.Plugin Namespace : TimeValueEditorSetting Class

For a list of all members of this type, see TimeValueEditorSetting members.

Public Methods
 | Name | Description
Public Method | GetDataTemplate | 属性编辑器对应的数据模板。 (Inherited from GrapeCity.Forguncy.Plugin.BuiltinEditorSetting)
Public Method | Validate | 插件内部属性编辑器的校验处理。 (Inherited from GrapeCity.Forguncy.Plugin.EditorSetting)
Top
See Also

Reference

TimeValueEditorSetting Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.Plugin Namespace (GrapeCity.Forguncy.Plugin.Design) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.CheckBoxEidtorSetting
GrapeCity.Forguncy.Plugin.ColorSelectorEditorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.EnumValueEditorSetting
GrapeCity.Forguncy.Plugin.DoubleEditorSetting
GrapeCity.Forguncy.Plugin.FormulaSelectorEditorSetting
GrapeCity.Forguncy.Plugin.HyperlinkEditorSetting
GrapeCity.Forguncy.Plugin.ImageEditorSetting
GrapeCity.Forguncy.Plugin.IntEditorSetting
GrapeCity.Forguncy.Plugin.OrientationEidtorSetting
GrapeCity.Forguncy.Plugin.TableComboTreeSelectorEditorSetting
GrapeCity.Forguncy.Plugin.TextEditorSetting
GrapeCity.Forguncy.Plugin.TimeValueEditorSetting
See Also

Reference

GrapeCity.Forguncy.Plugin.Design Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Forguncy Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Forguncy.ForguncyVersionPlugin
See Also

Reference

GrapeCity.Forguncy.Plugin Assembly


%%PageItemTitle%% $$Methods$$

ColorPropertyAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : ColorPropertyAttribute Class

For a list of all members of this type, see ColorPropertyAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ColorPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

ColorPropertyAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : ColorPropertyAttribute Class

For a list of all members of this type, see ColorPropertyAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

ColorPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

FormulaPropertyAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : FormulaPropertyAttribute Class

For a list of all members of this type, see FormulaPropertyAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

FormulaPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

IconAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : IconAttribute Class

For a list of all members of this type, see IconAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

IconAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IconAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : IconAttribute Class

For a list of all members of this type, see IconAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

IconAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

IListViewInfoDesigner Interface Properties

GrapeCity.Forguncy.Plugin Namespace : IListViewInfoDesigner Interface

For a list of all members of this type, see IListViewInfoDesigner members.

Public Properties
 | Name | Description
Property | AllowAddNewRow | 是否允许在表格中加行。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | AllowDeleteRow | 是否允许在表格中删行。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | AllowEditRow | 是否允许在表格中编辑。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | BindingTableName | 绑定的数据表名。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Property | ListViewName | 表格的名称。 (Inherited from GrapeCity.Forguncy.Plugin.IListViewInfo)
Top
See Also

Reference

IListViewInfoDesigner Interface
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

ListPropertyAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : ListPropertyAttribute Class

For a list of all members of this type, see ListPropertyAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ListPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

ListPropertyAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : ListPropertyAttribute Class

For a list of all members of this type, see ListPropertyAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

ListPropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

NameIndicator Class Methods

GrapeCity.Forguncy.Plugin Namespace : NameIndicator Class

For a list of all members of this type, see NameIndicator members.

Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

NameIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

ObjectIndicator Class Methods

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator Class

For a list of all members of this type, see ObjectIndicator members.

Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

ObjectIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

ObjectIndicator<T> Class Methods

GrapeCity.Forguncy.Plugin Namespace : ObjectIndicator<T> Class

For a list of all members of this type, see ObjectIndicator<T> members.

Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

ObjectIndicator<T> Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

OrderWeightAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : OrderWeightAttribute Class

For a list of all members of this type, see OrderWeightAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

OrderWeightAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

OrderWeightAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : OrderWeightAttribute Class

For a list of all members of this type, see OrderWeightAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

OrderWeightAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

PageMetadataJsonIgnoreAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : PageMetadataJsonIgnoreAttribute Class

For a list of all members of this type, see PageMetadataJsonIgnoreAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

PageMetadataJsonIgnoreAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

PageMetadataJsonIgnoreAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : PageMetadataJsonIgnoreAttribute Class

For a list of all members of this type, see PageMetadataJsonIgnoreAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

PageMetadataJsonIgnoreAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

PropertyIndicator Class Methods

GrapeCity.Forguncy.Plugin Namespace : PropertyIndicator Class

For a list of all members of this type, see PropertyIndicator members.

Public Methods
 | Name | Description
Public Method | Append | 拼接一个坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Method | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

PropertyIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

PropertyIndicator Class Properties

GrapeCity.Forguncy.Plugin Namespace : PropertyIndicator Class

For a list of all members of this type, see PropertyIndicator members.

Public Properties
 | Name | Description
Public Property | DisplayString | 当前坐标定位器的显示文字。 (Inherited from GrapeCity.Forguncy.Plugin.NameIndicator)
Public Property | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Name | 当前坐标定位器的名称。 (Inherited from GrapeCity.Forguncy.Plugin.NameIndicator)
Public Property | Parent | 父节点 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Public Property | Root | 根坐标定位器。 (Inherited from GrapeCity.Forguncy.Plugin.LocationIndicator)
Top
See Also

Reference

PropertyIndicator Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

SaveJsonIgnoreAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : SaveJsonIgnoreAttribute Class

For a list of all members of this type, see SaveJsonIgnoreAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

SaveJsonIgnoreAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

SaveJsonIgnoreAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : SaveJsonIgnoreAttribute Class

For a list of all members of this type, see SaveJsonIgnoreAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

SaveJsonIgnoreAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Methods$$

WindowsIgnorePropertyAttribute Class Methods

GrapeCity.Forguncy.Plugin Namespace : WindowsIgnorePropertyAttribute Class

For a list of all members of this type, see WindowsIgnorePropertyAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

WindowsIgnorePropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%PageItemTitle%% $$Properties$$

WindowsIgnorePropertyAttribute Class Properties

GrapeCity.Forguncy.Plugin Namespace : WindowsIgnorePropertyAttribute Class

For a list of all members of this type, see WindowsIgnorePropertyAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

WindowsIgnorePropertyAttribute Class
GrapeCity.Forguncy.Plugin Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.Plugin Namespace (GrapeCity.Forguncy.Plugin) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.Plugin.FileCopyInfo
GrapeCity.Forguncy.Plugin.FileUploadInfo
GrapeCity.Forguncy.Plugin.FindResultItem
GrapeCity.Forguncy.Plugin.ForguncyErrorInfo
GrapeCity.Forguncy.Plugin.GenerateCellInfo
GrapeCity.Forguncy.Plugin.ImageValue
GrapeCity.Forguncy.Plugin.LocatedObject
GrapeCity.Forguncy.Plugin.LocatedObject<T>
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.PropertyIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator<T>
GrapeCity.Forguncy.Plugin.LocationIndicatorExtension
GrapeCity.Forguncy.Plugin.PluginUtilities
GrapeCity.Forguncy.Plugin.TableCheckInfo
System.Attribute
GrapeCity.Forguncy.Plugin.ColorPropertyAttribute
GrapeCity.Forguncy.Plugin.FormulaPropertyAttribute
GrapeCity.Forguncy.Plugin.IconAttribute
GrapeCity.Forguncy.Plugin.ListPropertyAttribute
GrapeCity.Forguncy.Plugin.OrderWeightAttribute
GrapeCity.Forguncy.Plugin.PageMetadataJsonIgnoreAttribute
GrapeCity.Forguncy.Plugin.SaveJsonIgnoreAttribute
GrapeCity.Forguncy.Plugin.WindowsIgnorePropertyAttribute
See Also

Reference

GrapeCity.Forguncy.Plugin Assembly


%%PageItemTitle%% $$Methods$$

GetAttribute Class Methods

GrapeCity.Forguncy.ServerApi Namespace : GetAttribute Class

For a list of all members of this type, see GetAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

GetAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Properties$$

GetAttribute Class Properties

GrapeCity.Forguncy.ServerApi Namespace : GetAttribute Class

For a list of all members of this type, see GetAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

GetAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Methods$$

PostAttribute Class Methods

GrapeCity.Forguncy.ServerApi Namespace : PostAttribute Class

For a list of all members of this type, see PostAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

PostAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Properties$$

PostAttribute Class Properties

GrapeCity.Forguncy.ServerApi Namespace : PostAttribute Class

For a list of all members of this type, see PostAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

PostAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%PageItemTitle%% $$Methods$$

ScheduleApiAttribute Class Methods

GrapeCity.Forguncy.ServerApi Namespace : ScheduleApiAttribute Class

For a list of all members of this type, see ScheduleApiAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

ScheduleApiAttribute Class
GrapeCity.Forguncy.ServerApi Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.ServerApi Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
GrapeCity.Forguncy.ServerApi.ColumnValuePair
GrapeCity.Forguncy.ServerApi.EditData
GrapeCity.Forguncy.ServerApi.ForguncyApi
GrapeCity.Forguncy.ServerApi.ModifyData
GrapeCity.Forguncy.ServerApi.UserInfo
System.Attribute
GrapeCity.Forguncy.ServerApi.GetAttribute
GrapeCity.Forguncy.ServerApi.PostAttribute
GrapeCity.Forguncy.ServerApi.ScheduleApiAttribute
See Also

Reference

GrapeCity.Forguncy.ServerApi Assembly