GrapeCity.Forguncy.CellTypes 命名空间

类
 | 类 | 说明
 | CategoryHeaderAttribute | 单元格类型插件中的属性编辑器中的类目属性，如文本框中使用的[显示密码]属性的类目属性[外观]。
 | CellType | 单元格类型插件的父类定义。
公共类 | CellTypeDesigner | CellType设计器。
公共类 | CellTypeDesignerT | CellType设计器。
公共类 | CellTypeStyleTemplate | 单元格的模板样式。它定义了该单元格的一份完整的样式外观，包括该单元格由几个模板组件组成，以及每个模板组件的具体样式。
 | CellTypeStyleTemplateDisplayNameAttribute | 单元格类型插件中的属性编辑器中的类目属性的名称。
 | CellTypeStyleTemplateSupportAttribute | 单元格类型支持模板样式的标志。如果该单元格支持模板样式，可使用某个继承自此标志的标志，对模板样式进行相关配置。
公共类 | DataValidationLink | 数据验证类
公共类 | ExportResultInfo | 导出单元格类型的返回结果。
公共类 | PartStyleUnit | 模板组件的状态样式单元。它代表了模板组件在某一种状态下的完整样式信息。
公共类 | SubUIPermission | 单元格类型子元素的界面权限项。
 | SupportUsingScopeAttribute | 单元格类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
公共类 | TemplatePart | 单元格模板样式的模板组件。它以样式的角度，划分单元格的组成部分，也是设置单元格模板样式的基本单位。一个单元格类型可由一个或多个模板组件组成。每一个部分可单独设置样式。
公共类 | TemplatePartStyle | 模板组件的样式。保存了该模板组件在各自状态下的具体样式信息。
公共类 | UIPermission | 单元格类型的界面权限项。
接口
 | 接口 | 说明
公共接口 | IAttachedInfo | 单元格的附加信息。
公共接口 | IBorderLine | 设置边框。
公共接口 | IBuilderContext | 插件所需的上下文信息。
 | ICanOverflow | 单元格类型是否支持溢出。 例如，如果超链接单元格类型所在的单元格大小不够完全显示字，并且本身和后续单元格均没有合并的情况下，超链接的字会溢出到后续单元格中。
公共接口 | ICellInfo | 单元格的信息。
公共接口 | ICellTypeChecker | 如果单元格类型需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
 | ICommandCellType | 如果单元格类型本身允许执行命令，需实现该接口。
 | ICommandWindow | 活字格内部编辑命令的对话窗口。
 | IDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知依赖了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
公共接口 | IDisablePropertySettings | 获取单元格类型中不可用的样式属性，如对齐方式等。
公共接口 | IDrawingHelper | 主要用于单元格预览和导出单元格到Excel中的画法。
 | IExportCellType | 导出单元格类型有特殊处理时需实现该接口，比如生成图片等。
公共接口 | IExportContext | 导出单元格类型的上下文信息。
公共接口 | IExportValueProvider | 数据访问器，提供数据表的查询结果。
公共接口 | IForguncyFormatter | 单元格格式。
 | IIgnoreAlternativeRowBackColorWhenExport | 配合IExportCellType使用，导出Excel时不使用页面中表格的交替色作为背景色，如表格中的按钮导出到Excel时不使用交替色作为背景色。
公共接口 | IPagingCellType | 表示单元格为分页单元格
 | IQueryConditionWindow | 活字格内置的设置查询条件的对话窗口。 注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现IReferenceFormula和IDependenceCells这两个接口。
 | IReferenceCommand | 如果一个单元格不是ICommandCellType，但是该单元格内部属性中有命令设置，如菜单单元格类型，需实现该接口； 否则有些命令执行会出错，而且查找所有引用会有遗漏。
 | ISelectImageWindow | 内置图片选择对话窗口。
 | ISortConditionWindow | 活字格内置的设置排序条件的对话窗口。
公共接口 | IStaticValueCellType | 忽略单元格的值，可以自定义单元格类型返回的值； 例如，如果一个单元格引用登录用户单元格类型的值，返回的是当前用户，而非单元格上的值或0。
公共接口 | IStyleInfo | 设置样式。
公共接口 | IStylePreviewControl | 用于预览单元格样式模板组件的控件。可实现对边框、圆角、阴影的预览。
公共接口 | IStyleTemplateCustomDrawingSupport | 支持改写CellType的设计时的预览。如果实现了这个接口，CellType会用这个方法在样式选择中显示，如果没有实现则会使用CellTypeDesigner上的GetDrawingControl方法来预览。
公共接口 | IStyleTemplateInfo | 单元格模板样式的样式信息。若想添加单元格模板样式的设计时预览，该单元格需要实现此接口。
公共接口 | IStyleTemplatesNeedLoad | 单元格额外需要加载的模板样式。若想某单元格加载额外的模板样式，需要实现此接口。若支持 IStyleTemplateSupport 接口，该接口对应模板样式会默认加载。
公共接口 | IStyleTemplateSupport | 单元格支持模板样式。若想某单元格支持模板样式，需要实现此接口。
公共接口 | ISupportDataValidation | 主要用于支持单元格类型的数据验证。
公共接口 | ISupportDefaultValue | 表示单元格支持默认值
公共接口 | ISupportDisable | 表示单元格支持禁用
公共接口 | ISupportPropertyInitialize | 设置单元格类型的默认属性值。 例如，可以设置【超链接】单元格的点击模式默认为单元格而非文字区域。
公共接口 | ISupportReadOnly | 表示单元格支持只读
公共接口 | ISupportStyleInitialize | 设置单元格类型的默认样式和属性。
公共接口 | ISupportUIPermission | 主要用于单元格类型的界面权限设置。
公共接口 | IWindow | 内置对话框接口。
枚举
 | 枚举 | 说明
公共枚举 | CellStates | 模板组件的状态种类。
公共枚举 | CommandExcuteKind | 触发命令时机。
公共枚举 | CopyFontInfoToControlOption | 主要用于单元格预览和导出单元格到Excel中的画法。
公共枚举 | DisplayBehaviour | 单元格的默认显示特性。
公共枚举 | ForguncyAuthenticationMode | 页面认证模式。
公共枚举 | ForguncyBorderLineStyle | 边框线型列表。
公共枚举 | ForguncyCellHorizontalAlignment | 单元格水平对齐方式列表。
公共枚举 | ForguncyCellVerticalAlignment | 单元格垂直对齐方式列表。
公共枚举 | ForguncyDisabledSettings | 开始菜单中的不可用属性列表。
公共枚举 | ForguncyPageKind | 页面类型列表。
公共枚举 | ListViewScope | 单元格类型插件或其内部属性所支持的表格使用范围。
公共枚举 | PageScope | 单元格类型插件或其内部属性所支持的页面使用范围。
公共枚举 | StylePropertyName | 样式列表。
公共枚举 | StyleTemplateScope | 指定样式可以生效的范围
公共枚举 | SupportFeatures | 单元格类型的插件支持的特性。
公共枚举 | SupportStyles | 模板组件所支持的可设置的样式种类。
公共枚举 | UIPermissionScope | 界面元素的权限适用范围。


CategoryHeaderAttribute 类

单元格类型插件中的属性编辑器中的类目属性，如文本框中使用的[显示密码]属性的类目属性[外观]。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.CellTypesCategoryHeaderAttribute

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CategoryHeaderAttribute : Attribute

CategoryHeaderAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CategoryHeaderAttribute | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | CategoryHeader | 分类标题。
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class TextCellType : <see cref="T:GrapeCity.Forguncy.CellTypes.CellType" />
{
    [CategoryHeader("外观")]
    [DisplayName("显示密码")]
    public bool ShowPassword { get; set; }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CategoryHeaderAttribute 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CategoryHeaderAttribute(
    string categoryHeader
)

参数

categoryHeader
类型：SystemString
分类标题。
参见

引用

CategoryHeaderAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CategoryHeaderAttribute 属性

CategoryHeaderAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CategoryHeader | 分类标题。
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

CategoryHeaderAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CategoryHeaderAttribute.CategoryHeader 属性

活字格插件API文档

CategoryHeaderAttributeCategoryHeader 属性

分类标题。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string CategoryHeader { get; set; }

属性值

类型：String
参见

引用

CategoryHeaderAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CategoryHeaderAttribute 方法

CategoryHeaderAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CategoryHeaderAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellStates 枚举

模板组件的状态种类。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum CellStates
成员
成员名称 | 值 | 说明
Normal | 1 | 一般状态
Hover | 2 | 鼠标悬停
Active | 4 | 被按下。可以是鼠标按下，或者触摸屏的被触摸。
Focus | 8 | 获得焦点
Disable | 16 | 禁用
Selected | 32 | 选中
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CellType 类

单元格类型插件的父类定义。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesCellType

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class CellType : INotifyPropertyChanged

CellType 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | CellType | 初始化 CellType 类的一个新实例
Top
属性
 | 名称 | 说明
 | CellTextPropertyName | 设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
 | DefaultAlignment | 单元格类型插件的默认水平对齐方式。
 | DisplayBehaviour | 单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
 | SupportFeatures | 支持的特性，如设置单元格格式，Tab键设置等。
公共属性 | TabIndex | Tab键顺序。
Top
方法
 | 名称 | 说明
公共方法 | Clone | 克隆方法。
 | CloneImp | 克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetCellValue | 获取单元格属性的值从而设值给单元格。
 | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
公共方法 | GetDisplayString | 获取资源化后的显示文本，通常需要在使用自定义资源文件时重写。
公共方法 | GetDocProperties | 获取在“导出文档”时，要显示在文档里的属性。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetRunTimeMethodVisible |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | OnPropertyChanged | 当属性变更时发出通知。
公共方法 | SetCellValue | 通过单元格本身的值设值给单元格属性。
 | ToString | 单元格类型的显示名。 如果不指定，默认与类型名一致。 (重写 ObjectToString.)
Top
事件
 | 名称 | 说明
公共事件 | PropertyChanged | 内部使用。
Top
示例
C#
复制
public class MyPluginCellType : CellType
{
    ...
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CellType 构造函数

初始化 CellType 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected CellType()
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType 属性

CellType 类型公开以下成员。

属性
 | 名称 | 说明
 | CellTextPropertyName | 设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
 | DefaultAlignment | 单元格类型插件的默认水平对齐方式。
 | DisplayBehaviour | 单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
 | SupportFeatures | 支持的特性，如设置单元格格式，Tab键设置等。
公共属性 | TabIndex | Tab键顺序。
Top
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.CellTextPropertyName 属性

活字格插件API文档

CellTypeCellTextPropertyName 属性

设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string CellTextPropertyName { get; }

属性值

类型：String
示例
C#
复制
public class MyNumberCellType : CellType
{
    [FormulaProperty]
    public object DefaultNumberValue { get; set; }

    public override string CellTextPropertyName
    {
        get
        {
            return "DefaultNumberValue";
        }
    }
}
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.DefaultAlignment 属性

活字格插件API文档

CellTypeDefaultAlignment 属性

单元格类型插件的默认水平对齐方式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual ForguncyCellHorizontalAlignment DefaultAlignment { get; }

属性值

类型：ForguncyCellHorizontalAlignment
示例
C#
复制
public class MyNumberCellType : CellType
{
    public override ForguncyCellHorizontalAlignment DefaultAlignment
    {
        /*return ForguncyCellHorizontalAlignment.General;  //默认对齐方式*/
        return ForguncyCellHorizontalAlignment.Right;
    }
}
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.DisplayBehaviour 属性

活字格插件API文档

CellTypeDisplayBehaviour 属性

单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual DisplayBehaviour DisplayBehaviour { get; }

属性值

类型：DisplayBehaviour
示例
C#
复制
public class MyNumberCellType : CellType
{
    public override DisplayBehaviour DisplayBehaviour
    {
        /*return DisplayBehaviour.None;  //默认没有特殊行为。*/
        return DisplayBehaviour.KeepBorderWhenMerge;  /*插件自带边框。*/
    }
}
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.SupportFeatures 属性

活字格插件API文档

CellTypeSupportFeatures 属性

支持的特性，如设置单元格格式，Tab键设置等。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual SupportFeatures SupportFeatures { get; }

属性值

类型：SupportFeatures
示例
C#
复制
public class MyNumberCellType : CellType
{
    public override SupportFeatures SupportFeatures
    {
        /*return SupportFeatures.None;  //默认没有特性。*/
        return SupportFeatures.AllowSetFormat;  /*插件支持单元格格式设置。*/
    }
}
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.TabIndex 属性

活字格插件API文档

CellTypeTabIndex 属性

Tab键顺序。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int? TabIndex { get; set; }

属性值

类型：Nullable Int32
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType 方法

CellType 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone | 克隆方法。
 | CloneImp | 克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetCellValue | 获取单元格属性的值从而设值给单元格。
 | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
公共方法 | GetDisplayString | 获取资源化后的显示文本，通常需要在使用自定义资源文件时重写。
公共方法 | GetDocProperties | 获取在“导出文档”时，要显示在文档里的属性。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetRunTimeMethodVisible |
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | OnPropertyChanged | 当属性变更时发出通知。
公共方法 | SetCellValue | 通过单元格本身的值设值给单元格属性。
 | ToString | 单元格类型的显示名。 如果不指定，默认与类型名一致。 (重写 ObjectToString.)
Top
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.Clone 方法

活字格插件API文档

CellTypeClone 方法

克隆方法。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellType Clone()

返回值

类型：CellType
克隆后的插件对象。
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.CloneImp 方法

活字格插件API文档

CellTypeCloneImp 方法

克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected virtual CellType CloneImp()

返回值

类型：CellType
克隆后的插件对象。
示例
C#
复制
public class MenuCellType : CellType
{
    public  List<MenuItemInfo> MenuItems { get; set; }
}

public class MenuItemInfo : ICloneable
{
    public object Value { get; set; }

    public string Text { get; set; }

    public  List<MenuItemInfo> SubMenuItems { get; set; }

    /*here need implement this method.*/
    public object Clone()
    {
        /*处理>*/
    }
}
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.GetCellValue 方法

活字格插件API文档

CellTypeGetCellValue 方法

获取单元格属性的值从而设值给单元格。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual void GetCellValue(
    out Object value,
    out string formula
)

参数

value
类型：SystemObject
返回属性的值
formula
类型：SystemString
返回属性的格式
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.GetDesignerPropertyVisible 方法

活字格插件API文档

CellTypeGetDesignerPropertyVisible 方法

如果需要动态改变属性编辑器的可见性，可以重写该函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool GetDesignerPropertyVisible(
    string propertyName
)

参数

propertyName
类型：SystemString
属性名

返回值

类型：Boolean
返回True表示属性编辑器可见，否则不可见。
示例
C#
复制
public class MenuCellType: CellType
{
    public Orientation Orientation { get; set; }

    public ExpandStyle DefaultExpandStyle { get; set; }

    public override bool GetDesignerPropertyVisible(string propertyName)
    {
        if (propertyName == "DefaultExpandStyle")
        {
            if (Orientation == MenuOrientation.Horizontal)  //如果是水平方向的菜单隐藏默认展开方式。
            {
                return false;
            }
            return true;
        }
        return base.GetDesignerPropertyVisible(propertyName);
    }
}
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.GetDisplayString 方法

活字格插件API文档

CellTypeGetDisplayString 方法

获取资源化后的显示文本，通常需要在使用自定义资源文件时重写。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string GetDisplayString(
    string str
)

参数

str
类型：SystemString

返回值

类型：String
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.GetDocProperties 方法

活字格插件API文档

CellTypeGetDocProperties 方法

获取在“导出文档”时，要显示在文档里的属性。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual List<Tuple<string, Object>> GetDocProperties(
    PageScope pageScope,
    ListViewScope listViewScope,
    LanguageScope languageScope
)

参数

pageScope
类型：GrapeCity.Forguncy.CellTypesPageScope
listViewScope
类型：GrapeCity.Forguncy.CellTypesListViewScope
languageScope
类型：LanguageScope

返回值

类型：List Tuple String, Object
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.GetRunTimeMethodVisible 方法

活字格插件API文档

CellTypeGetRunTimeMethodVisible 方法

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool GetRunTimeMethodVisible(
    string name
)

参数

name
类型：SystemString

返回值

类型：Boolean
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.OnPropertyChanged 方法

活字格插件API文档

CellTypeOnPropertyChanged 方法

当属性变更时发出通知。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual void OnPropertyChanged(
    string propertyName = null
)

参数

propertyName (Optional)
类型：SystemString
发生变更的属性名称。
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.SetCellValue 方法

活字格插件API文档

CellTypeSetCellValue 方法

通过单元格本身的值设值给单元格属性。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual void SetCellValue(
    Object value,
    string text,
    bool haveFormula,
    IForguncyFormatter formatter
)

参数

value
类型：SystemObject
单元格的值
text
类型：SystemString
单元格的文本
haveFormula
类型：SystemBoolean
单元格是否有公式
formatter
类型：GrapeCity.Forguncy.CellTypesIForguncyFormatter
单元格的格式
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.ToString 方法

活字格插件API文档

CellTypeToString 方法

单元格类型的显示名。 如果不指定，默认与类型名一致。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
示例
C#
复制
public class MyPluginCellType : CellType
{
    public override string ToString()
    {
        /*return this.GetType().Name;  //默认*/
        return "我的插件";
    }
}
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType 事件

CellType 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | PropertyChanged | 内部使用。
Top
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellType.PropertyChanged 事件

活字格插件API文档

CellTypePropertyChanged 事件

内部使用。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public event PropertyChangedEventHandler PropertyChanged

值

类型：System.ComponentModelPropertyChangedEventHandler
参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner 类

CellType设计器。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesCellTypeDesigner
GrapeCity.Forguncy.CellTypesCellTypeDesignerT

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CellTypeDesigner

CellTypeDesigner 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CellTypeDesigner | 初始化 CellTypeDesigner 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CellType | 设计器对应的CellType。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
 | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 List<Command> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner 构造函数

初始化 CellTypeDesigner 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeDesigner()
参见

引用

CellTypeDesigner 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner 属性

CellTypeDesigner 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CellType | 设计器对应的CellType。
Top
参见

引用

CellTypeDesigner 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner.CellType 属性

活字格插件API文档

CellTypeDesignerCellType 属性

设计器对应的CellType。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellType CellType { get; set; }

属性值

类型：CellType
参见

引用

CellTypeDesigner 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner 方法

CellTypeDesigner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
 | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 List<Command> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CellTypeDesigner 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner.GetDrawingControl 方法

活字格插件API文档

CellTypeDesignerGetDrawingControl 方法

如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual FrameworkElement GetDrawingControl(
    ICellInfo cellInfo,
    IDrawingHelper drawingHelper
)

参数

cellInfo
类型：GrapeCity.Forguncy.CellTypesICellInfo
单元格信息。
drawingHelper
类型：GrapeCity.Forguncy.CellTypesIDrawingHelper
画法帮助工具。

返回值

类型：FrameworkElement
返回WPF元素。
示例
C#
复制
public class ButtonGroupCellType : CellType
{
    public string AddButtonText { get; set; }

    public string DeleteButtonText { get; set; }

    public override FrameworkElement GetDrawingControl(ICellInfo cellInfo, IDrawingHelper drawingHelper)
    {
        Button addButton = new Button() { Content = this.AddButtonText };
        Button deleteButton = new Button() { Content = this.DeleteButtonText, Margin = new Thickness(5, 0, 0, 0) };

        Grid container = new Grid();
        container.ColumnDefinitions.Add(new ColumnDefinition() { Width = new GridLength(1, GridUnitType.Star) });
        container.ColumnDefinitions.Add(new ColumnDefinition() { Width = new GridLength(1, GridUnitType.Star) });
        container.Children.Add(addButton);
        container.Children.Add(deleteButton);
        Grid.SetColumn(addButton, 0);
        Grid.SetColumn(deleteButton, 1);

        return container;
    }
}
参见

引用

CellTypeDesigner 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner.GetEditorSetting 方法

活字格插件API文档

CellTypeDesignerGetEditorSetting 方法

获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 List<Command> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual EditorSetting GetEditorSetting(
    PropertyDescriptor property,
    IBuilderContext builderContext
)

参数

property
类型：System.ComponentModelPropertyDescriptor
属性信息
builderContext
类型：GrapeCity.Forguncy.CellTypesIBuilderContext
上下文信息

返回值

类型：EditorSetting
属性编辑器。
示例
C#
复制
public class MyTextCellTypeDesigner : CellTypeDesigner<CurrentUserCellType>
{
    public string Text { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if(property.Name == "Text")
        {
            return new TextEditorSetting();
        }
    }
}
参见

引用

CellTypeDesigner 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner(T) 类

活字格插件API文档

CellTypeDesignerT 类

CellType设计器。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesCellTypeDesigner
GrapeCity.Forguncy.CellTypesCellTypeDesignerT

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CellTypeDesigner<T> : CellTypeDesigner
where T : CellType

类型参数

T

CellTypeDesignerT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CellTypeDesignerT | 初始化 CellTypeDesignerT 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CellType | 设计器对应的CellType。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。 (继承自 CellTypeDesigner。)
 | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 List<Command> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。 (继承自 CellTypeDesigner。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner(T) 构造函数

活字格插件API文档

CellTypeDesignerT 构造函数

初始化 CellTypeDesignerT 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeDesigner()
参见

引用

CellTypeDesignerT 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner(T) 属性

活字格插件API文档

CellTypeDesignerT 属性

CellTypeDesignerT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CellType | 设计器对应的CellType。
Top
参见

引用

CellTypeDesignerT 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner(T).CellType 属性

活字格插件API文档

CellTypeDesignerTCellType 属性

设计器对应的CellType。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public T CellType { get; }

属性值

类型：T
参见

引用

CellTypeDesignerT 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeDesigner(T) 方法

活字格插件API文档

CellTypeDesignerT 方法

CellTypeDesignerT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。 (继承自 CellTypeDesigner。)
 | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 List<Command> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。 (继承自 CellTypeDesigner。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CellTypeDesignerT 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate 类

单元格的模板样式。它定义了该单元格的一份完整的样式外观，包括该单元格由几个模板组件组成，以及每个模板组件的具体样式。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesCellTypeStyleTemplate

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CellTypeStyleTemplate

CellTypeStyleTemplate 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CellTypeStyleTemplate | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | Category | 单元格模板样式的所属类目。用于给模板样式分类。在设计器的功能区，预览模板样式时，它可以区分不同分类的模板样式。
公共属性 | Key | 单元格模板样式的唯一标识。
公共属性 | Scope | 指定样式可以生效的范围
公共属性 | Styles | 单元格模板样式的样式组成。它是一个字典，Key为模板组件，Value为每个模板组件的具体样式信息。单元格的模板样式，由该单元格所包含的模板组件的样式所组成。一个单元格可以有一个或多个模板组件。
Top
方法
 | 名称 | 说明
公共方法 | Clone | 克隆单元格模板样式。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeStyleTemplate()
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate 属性

CellTypeStyleTemplate 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Category | 单元格模板样式的所属类目。用于给模板样式分类。在设计器的功能区，预览模板样式时，它可以区分不同分类的模板样式。
公共属性 | Key | 单元格模板样式的唯一标识。
公共属性 | Scope | 指定样式可以生效的范围
公共属性 | Styles | 单元格模板样式的样式组成。它是一个字典，Key为模板组件，Value为每个模板组件的具体样式信息。单元格的模板样式，由该单元格所包含的模板组件的样式所组成。一个单元格可以有一个或多个模板组件。
Top
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate.Category 属性

活字格插件API文档

CellTypeStyleTemplateCategory 属性

单元格模板样式的所属类目。用于给模板样式分类。在设计器的功能区，预览模板样式时，它可以区分不同分类的模板样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Category { get; set; }

属性值

类型：String
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate.Key 属性

活字格插件API文档

CellTypeStyleTemplateKey 属性

单元格模板样式的唯一标识。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Key { get; set; }

属性值

类型：String
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate.Scope 属性

活字格插件API文档

CellTypeStyleTemplateScope 属性

指定样式可以生效的范围

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public StyleTemplateScope Scope { get; set; }

属性值

类型：StyleTemplateScope
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate.Styles 属性

活字格插件API文档

CellTypeStyleTemplateStyles 属性

单元格模板样式的样式组成。它是一个字典，Key为模板组件，Value为每个模板组件的具体样式信息。单元格的模板样式，由该单元格所包含的模板组件的样式所组成。一个单元格可以有一个或多个模板组件。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Dictionary<string, TemplatePartStyle> Styles { get; set; }

属性值

类型：Dictionary String, TemplatePartStyle
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate 方法

CellTypeStyleTemplate 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone | 克隆单元格模板样式。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplate.Clone 方法

活字格插件API文档

CellTypeStyleTemplateClone 方法

克隆单元格模板样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeStyleTemplate Clone()

返回值

类型：CellTypeStyleTemplate
克隆后的单元格模板样式。
参见

引用

CellTypeStyleTemplate 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute 类

单元格类型插件中的属性编辑器中的类目属性的名称。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.CellTypesCellTypeStyleTemplateDisplayNameAttribute

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CellTypeStyleTemplateDisplayNameAttribute : Attribute

CellTypeStyleTemplateDisplayNameAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CellTypeStyleTemplateDisplayNameAttribute | 构造函数。
公共方法 | CellTypeStyleTemplateDisplayNameAttribute(String) | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | Name | 类目属性的名称
公共属性 | ResourceType | Resources Type
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetName | 获得类目属性的名称
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
[CellTypeStyleTemplateDisplayNameAttribute("display name")]
public class YourCellTypeStyleTemplateSupportAttribute : CellTypeStyleTemplateSupportAttribute
{
    ...
}
[CellTypeStyleTemplateDisplayName(Name = nameof(Resources.Display), ResourceType = typeof(Properties.Resources))]
public class YourCellTypeStyleTemplateSupportAttribute : CellTypeStyleTemplateSupportAttribute
{
    ...
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute 构造函数

重载列表
 | 名称 | 说明
公共方法 | CellTypeStyleTemplateDisplayNameAttribute | 构造函数。
公共方法 | CellTypeStyleTemplateDisplayNameAttribute(String) | 构造函数。
Top
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeStyleTemplateDisplayNameAttribute()
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
CellTypeStyleTemplateDisplayNameAttribute 重载
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute 构造函数 (String)

构造函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeStyleTemplateDisplayNameAttribute(
    string name
)

参数

name
类型：SystemString
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
CellTypeStyleTemplateDisplayNameAttribute 重载
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute 属性

CellTypeStyleTemplateDisplayNameAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Name | 类目属性的名称
公共属性 | ResourceType | Resources Type
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute.Name 属性

活字格插件API文档

CellTypeStyleTemplateDisplayNameAttributeName 属性

类目属性的名称

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string Name { get; set; }

属性值

类型：String
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute.ResourceType 属性

活字格插件API文档

CellTypeStyleTemplateDisplayNameAttributeResourceType 属性

Resources Type

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual Type ResourceType { get; set; }

属性值

类型：Type
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute 方法

CellTypeStyleTemplateDisplayNameAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetName | 获得类目属性的名称
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateDisplayNameAttribute.GetName 方法

活字格插件API文档

CellTypeStyleTemplateDisplayNameAttributeGetName 方法

获得类目属性的名称

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string GetName()

返回值

类型：String
参见

引用

CellTypeStyleTemplateDisplayNameAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute 类

单元格类型支持模板样式的标志。如果该单元格支持模板样式，可使用某个继承自此标志的标志，对模板样式进行相关配置。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.CellTypesCellTypeStyleTemplateSupportAttribute

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class CellTypeStyleTemplateSupportAttribute : Attribute

CellTypeStyleTemplateSupportAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | CellTypeStyleTemplateSupportAttribute | 初始化 CellTypeStyleTemplateSupportAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultTemplateKey | 单元格默认的模板样式。它是从PresetTemplates中选择某一个模板的Key作为值。新建该单元格时，会应用上默认的模板样式。如果为空，则新建该单元格时，不应用模板样式。
公共属性 | PresetTemplates | 预置的模板样式。可供用户直接选择。
公共属性 | PreviewHeight | 设计器中，在功能区，显示的单元格模板样式的预览高度。默认值24。
公共属性 | PreviewWidth | 设计器中，在功能区，显示的单元格模板样式的预览宽度。默认值80。
公共属性 | TemplateParts | 设置单元格类型的组成部分。每一个部分的样式可单独进行设置。
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class YourCellTypeStyleTemplateSupportAttribute : CellTypeStyleTemplateSupportAttribute
{
    ...
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute 构造函数

初始化 CellTypeStyleTemplateSupportAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected CellTypeStyleTemplateSupportAttribute()
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute 属性

CellTypeStyleTemplateSupportAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultTemplateKey | 单元格默认的模板样式。它是从PresetTemplates中选择某一个模板的Key作为值。新建该单元格时，会应用上默认的模板样式。如果为空，则新建该单元格时，不应用模板样式。
公共属性 | PresetTemplates | 预置的模板样式。可供用户直接选择。
公共属性 | PreviewHeight | 设计器中，在功能区，显示的单元格模板样式的预览高度。默认值24。
公共属性 | PreviewWidth | 设计器中，在功能区，显示的单元格模板样式的预览宽度。默认值80。
公共属性 | TemplateParts | 设置单元格类型的组成部分。每一个部分的样式可单独进行设置。
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute.DefaultTemplateKey 属性

活字格插件API文档

CellTypeStyleTemplateSupportAttributeDefaultTemplateKey 属性

单元格默认的模板样式。它是从PresetTemplates中选择某一个模板的Key作为值。新建该单元格时，会应用上默认的模板样式。如果为空，则新建该单元格时，不应用模板样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract string DefaultTemplateKey { get; }

属性值

类型：String
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute.PresetTemplates 属性

活字格插件API文档

CellTypeStyleTemplateSupportAttributePresetTemplates 属性

预置的模板样式。可供用户直接选择。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract List<CellTypeStyleTemplate> PresetTemplates { get; }

属性值

类型：List CellTypeStyleTemplate
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute.PreviewHeight 属性

活字格插件API文档

CellTypeStyleTemplateSupportAttributePreviewHeight 属性

设计器中，在功能区，显示的单元格模板样式的预览高度。默认值24。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual double PreviewHeight { get; }

属性值

类型：Double
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute.PreviewWidth 属性

活字格插件API文档

CellTypeStyleTemplateSupportAttributePreviewWidth 属性

设计器中，在功能区，显示的单元格模板样式的预览宽度。默认值80。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual double PreviewWidth { get; }

属性值

类型：Double
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute.TemplateParts 属性

活字格插件API文档

CellTypeStyleTemplateSupportAttributeTemplateParts 属性

设置单元格类型的组成部分。每一个部分的样式可单独进行设置。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract List<TemplatePart> TemplateParts { get; }

属性值

类型：List TemplatePart
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CellTypeStyleTemplateSupportAttribute 方法

CellTypeStyleTemplateSupportAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CellTypeStyleTemplateSupportAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


CommandExcuteKind 枚举

触发命令时机。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum CommandExcuteKind
成员
成员名称 | 值 | 说明
Click | 0 | 点击单元格时。
OnValueChanged | 1 | 单元格值发生变化时。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


CopyFontInfoToControlOption 枚举

主要用于单元格预览和导出单元格到Excel中的画法。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum CopyFontInfoToControlOption
成员
成员名称 | 值 | 说明
FontInfo | 1 | 根据字体样式画WPF元素。
TextDecoration | 2 | 根据下划线样式画WPF元素。
VerticalAlignment | 4 | 根据垂直对齐方式画WPF元素。
HorizontalAlignment | 8 | 根据水平对齐方式画WPF元素。
Wrap | 16 | 根据换行方式画WPF元素。
Indent | 32 | 根据缩进方式画WPF元素。
Text | 64 | 根据文本内容画WPF元素。
Normal | 15 | 根据字体样式，下划线样式，垂直和水平对齐方式画WPF元素。
All | 127 | 根据所有样式画WPF元素。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


DataValidationLink 类

数据验证类
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesDataValidationLink

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class DataValidationLink

DataValidationLink 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DataValidationLink | 初始化 DataValidationLink 类的一个新实例
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


DataValidationLink 构造函数

初始化 DataValidationLink 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public DataValidationLink()
参见

引用

DataValidationLink 类
GrapeCity.Forguncy.CellTypes 命名空间


DataValidationLink 方法

DataValidationLink 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

DataValidationLink 类
GrapeCity.Forguncy.CellTypes 命名空间


DisplayBehaviour 枚举

单元格的默认显示特性。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum DisplayBehaviour
成员
成员名称 | 值 | 说明
None | 0 | 默认无特性。
KeepBorderWhenMerge | 1 | 单元格类型默认生成边框，并且合并单元格后，边框会相应的发生变化。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo 类

导出单元格类型的返回结果。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesExportResultInfo

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ExportResultInfo

ExportResultInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExportResultInfo | 初始化 ExportResultInfo 类的一个新实例
Top
属性
 | 名称 | 说明
 | ExportPicture | 导出单元格类型的图片。
 | ExportStyleInfos | 导出单元格类型的样式。 例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。
 | ExportValue | 导出单元格类型的值。
公共属性 | NeedResetExportPicture | 导出时是否需要将单元格类型导出为图片。
公共属性 | NeedResetExportValue | 导出时是否需要重置单元格类型的值。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo 构造函数

初始化 ExportResultInfo 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ExportResultInfo()
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo 属性

ExportResultInfo 类型公开以下成员。

属性
 | 名称 | 说明
 | ExportPicture | 导出单元格类型的图片。
 | ExportStyleInfos | 导出单元格类型的样式。 例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。
 | ExportValue | 导出单元格类型的值。
公共属性 | NeedResetExportPicture | 导出时是否需要将单元格类型导出为图片。
公共属性 | NeedResetExportValue | 导出时是否需要重置单元格类型的值。
Top
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo.ExportPicture 属性

活字格插件API文档

ExportResultInfoExportPicture 属性

导出单元格类型的图片。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Stream ExportPicture { get; set; }

属性值

类型：Stream
示例
C#
复制
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            //var folderPath = ...
            //var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);
            var imageSource = GetImageSource(....);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo.ExportStyleInfos 属性

活字格插件API文档

ExportResultInfoExportStyleInfos 属性

导出单元格类型的样式。

例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Dictionary<StylePropertyName, Object> ExportStyleInfos { get; }

属性值

类型：Dictionary StylePropertyName, Object
示例
C#
复制
public class MultilineTextBox : CellType, IExportCellType
{
    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();

        result.ExportStyleInfos.Add(StylePropertyName.VerticalAlignment, ForguncyCellVerticalAlignment.Top);
        if (targetCell.HorizontalAlignment == ForguncyCellHorizontalAlignment.General)
        {
            result.ExportStyleInfos.Add(StylePropertyName.HorizontalAlignment, ForguncyCellHorizontalAlignment.Left);
        }
        result.ExportStyleInfos.Add(StylePropertyName.WordWrap, true);

        return result;
    }
}
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo.ExportValue 属性

活字格插件API文档

ExportResultInfoExportValue 属性

导出单元格类型的值。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object ExportValue { get; set; }

属性值

类型：Object
示例
C#
复制
public class ComboBoxCellType : CellType, IExportCellType
{
    public List<ItemInfo> Items { get; set; }

    public bool ExportPicture
    {
        get
        {
            return false;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();
        if(this.Items != null)
        {
            foreach (var item in this.Items)
            {
                if(object.Equals(item.Value, targetCell.Value))
                {
                    result.ExportValue = item.Text;
                    break;
                }
            }
        }

        return result;
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public object Value { get; set; }
}
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo.NeedResetExportPicture 属性

活字格插件API文档

ExportResultInfoNeedResetExportPicture 属性

导出时是否需要将单元格类型导出为图片。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool NeedResetExportPicture { get; }

属性值

类型：Boolean
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo.NeedResetExportValue 属性

活字格插件API文档

ExportResultInfoNeedResetExportValue 属性

导出时是否需要重置单元格类型的值。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool NeedResetExportValue { get; }

属性值

类型：Boolean
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ExportResultInfo 方法

ExportResultInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


ForguncyAuthenticationMode 枚举

页面认证模式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyAuthenticationMode
成员
成员名称 | 值 | 说明
Windows | 1 | Windows域认证。
Forms | 2 | 登录用户认证。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ForguncyBorderLineStyle 枚举

边框线型列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyBorderLineStyle
成员
成员名称 | 值 | 说明
None | 0 | 无。
Thin | 1 | 单线型（较细）。
Medium | 2 | 单线型（中等粗细）。
Dashed | 3 | 虚线（较细）。
Dotted | 4 | 斑点线。
Thick | 5 | 粗线型。
Double | 6 | 双线型。
MediumDashed | 8 | 虚线（中等粗细）。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ForguncyCellHorizontalAlignment 枚举

单元格水平对齐方式列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyCellHorizontalAlignment
成员
成员名称 | 值 | 说明
Left | 0 | 水平方向靠左对齐。
Center | 1 | 水平方向居中对齐。
Right | 2 | 水平方向靠右对齐。
General | 3 | 水平方向常规对齐。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ForguncyCellVerticalAlignment 枚举

单元格垂直对齐方式列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyCellVerticalAlignment
成员
成员名称 | 值 | 说明
Top | 0 | 垂直方向靠上对齐。
Center | 1 | 垂直居中对齐。
Bottom | 2 | 垂直方向靠下对齐。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ForguncyDisabledSettings 枚举

开始菜单中的不可用属性列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum ForguncyDisabledSettings
成员
成员名称 | 值 | 说明
TopAlignment | 1 | 垂直向上对齐。
MiddleAlignment | 2 | 垂直居中对齐。
BottomAlignment | 4 | 垂直向下对齐。
LeftAlignment | 8 | 水平向左对齐。
CenterAlignment | 16 | 水平居中对齐。
RightAlignment | 32 | 水平向右对齐。
Bold | 64 | 字体加粗。
Italic | 128 | 斜体。
Underline | 256 | 下划线。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ForguncyPageKind 枚举

页面类型列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyPageKind
成员
成员名称 | 值 | 说明
NormalPCPage | 0 | 普通PC页面。
NormalMobilePage | 1 | 普通手机页面。
MasterPCPage | 2 | PC母版页。
MasterMobilePage | 3 | 手机母版页。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IAttachedInfo 接口

单元格的附加信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IAttachedInfo

IAttachedInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindingInfo | 数据绑定信息。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IAttachedInfo 属性

IAttachedInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindingInfo | 数据绑定信息。
Top
参见

引用

IAttachedInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IAttachedInfo.BindingInfo 属性

活字格插件API文档

IAttachedInfoBindingInfo 属性

数据绑定信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IBindingInfo BindingInfo { get; }

属性值

类型：IBindingInfo
参见

引用

IAttachedInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBorderLine 接口

设置边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IBorderLine

IBorderLine 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColorStr | 边框颜色。
公共属性 | Style | 边框线型。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IBorderLine 属性

IBorderLine 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColorStr | 边框颜色。
公共属性 | Style | 边框线型。
Top
参见

引用

IBorderLine 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBorderLine.ColorStr 属性

活字格插件API文档

IBorderLineColorStr 属性

边框颜色。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ColorStr { get; }

属性值

类型：String
参见

引用

IBorderLine 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBorderLine.Style 属性

活字格插件API文档

IBorderLineStyle 属性

边框线型。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyBorderLineStyle Style { get; }

属性值

类型：ForguncyBorderLineStyle
参见

引用

IBorderLine 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext 接口

插件所需的上下文信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IBuilderContext : IBuilderContextBase

IBuilderContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AuthenticationMode | 获取当前工程的认证模式。 (继承自 IBuilderContextBase。)
公共属性 | Cell | 单元格类型所在的单元格信息。
公共属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
公共属性 | LocalServerInfo | 本地网站应用信息。 (继承自 IBuilderContextBase。)
公共属性 | PageName | 获取当前所在页面名称。 (继承自 IBuilderContextBase。)
公共属性 | PageType | 页面类型。
 | UserServiceInfo | 获取用户管理网站的信息。 (继承自 IBuilderContextBase。)
Top
方法
 | 名称 | 说明
公共方法 | EnumAllAttachedInfos | 获取某个页面所有的单元格附加信息。
 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (继承自 IBuilderContextBase。)
 | EnumAllPageInfos | 获取所有的页面信息。 (继承自 IBuilderContextBase。)
 | EnumAllTableInfos | 获取所有的数据表信息。 (继承自 IBuilderContextBase。)
 | EnumDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
 | EnumDependenceCellsFromFormula | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (继承自 IBuilderContextBase。)
 | GetCommandWindow | 根据使用范围获取活字格内部编辑命令的对话窗口。
 | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
 | GetSelectImageWindow(String, Boolean) | 获取活字格内部选择图片的对话窗口。
 | GetSelectImageWindow(String, Boolean, String) | 获取活字格内部选择图片的对话窗口。
 | GetSortConditionWindow | 获取活字格内部排序的对话窗口。
公共方法 | HideParentDialog | 如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog(UserControl)使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
公共方法 | ShowParentDialog | 重新显示被隐藏的父窗口，配合HideParentDialog(UserControl)使用。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext 属性

IBuilderContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AuthenticationMode | 获取当前工程的认证模式。 (继承自 IBuilderContextBase。)
公共属性 | Cell | 单元格类型所在的单元格信息。
公共属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
公共属性 | LocalServerInfo | 本地网站应用信息。 (继承自 IBuilderContextBase。)
公共属性 | PageName | 获取当前所在页面名称。 (继承自 IBuilderContextBase。)
公共属性 | PageType | 页面类型。
 | UserServiceInfo | 获取用户管理网站的信息。 (继承自 IBuilderContextBase。)
Top
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.Cell 属性

活字格插件API文档

IBuilderContextCell 属性

单元格类型所在的单元格信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ICellInfo Cell { get; }

属性值

类型：ICellInfo
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.ForguncyUploadFilesFolderPath 属性

活字格插件API文档

IBuilderContextForguncyUploadFilesFolderPath 属性

用户在设计器中上传的文件或图片所在的文件目录。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ForguncyUploadFilesFolderPath { get; }

属性值

类型：String
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.PageType 属性

活字格插件API文档

IBuilderContextPageType 属性

页面类型。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyPageKind PageType { get; }

属性值

类型：ForguncyPageKind
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext 方法

IBuilderContext 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumAllAttachedInfos | 获取某个页面所有的单元格附加信息。
 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (继承自 IBuilderContextBase。)
 | EnumAllPageInfos | 获取所有的页面信息。 (继承自 IBuilderContextBase。)
 | EnumAllTableInfos | 获取所有的数据表信息。 (继承自 IBuilderContextBase。)
 | EnumDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
 | EnumDependenceCellsFromFormula | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (继承自 IBuilderContextBase。)
 | GetCommandWindow | 根据使用范围获取活字格内部编辑命令的对话窗口。
 | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
 | GetSelectImageWindow(String, Boolean) | 获取活字格内部选择图片的对话窗口。
 | GetSelectImageWindow(String, Boolean, String) | 获取活字格内部选择图片的对话窗口。
 | GetSortConditionWindow | 获取活字格内部排序的对话窗口。
公共方法 | HideParentDialog | 如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog(UserControl)使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
公共方法 | ShowParentDialog | 重新显示被隐藏的父窗口，配合HideParentDialog(UserControl)使用。
Top
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.EnumAllAttachedInfos 方法

活字格插件API文档

IBuilderContextEnumAllAttachedInfos 方法

获取某个页面所有的单元格附加信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<IAttachedInfo> EnumAllAttachedInfos(
    string pageName
)

参数

pageName
类型：SystemString
页面名称。

返回值

类型：IEnumerable IAttachedInfo
返回页面所有单元格的附加信息。
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.EnumDependenceCells 方法

活字格插件API文档

IBuilderContextEnumDependenceCells 方法

依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<Object> EnumDependenceCells(
    Object queryCondition
)

参数

queryCondition
类型：SystemObject
查询条件

返回值

类型：IEnumerable Object
插件中所有引用的单元格列表。
示例
代码参照IQueryConditionWindow
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.EnumDependenceCellsFromFormula 方法

活字格插件API文档

IBuilderContextEnumDependenceCellsFromFormula 方法

依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<Object> EnumDependenceCellsFromFormula(
    Object formula
)

参数

formula
类型：SystemObject
公式

返回值

类型：IEnumerable Object
插件中所有引用的单元格列表。
示例
代码参照IDependenceCells
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.GetCommandWindow 方法

活字格插件API文档

IBuilderContextGetCommandWindow 方法

根据使用范围获取活字格内部编辑命令的对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ICommandWindow GetCommandWindow(
    CommandScope commandScope
)

参数

commandScope
类型：GrapeCity.Forguncy.CommandsCommandScope
指定命令使用范围。

返回值

类型：ICommandWindow
返回活字格内部编辑命令的对话窗口。
示例
代码参照ICommandWindow。
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.GetQueryConditionWindow 方法

活字格插件API文档

IBuilderContextGetQueryConditionWindow 方法

获取活字格内部查询条件的对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IQueryConditionWindow GetQueryConditionWindow(
    Object queryCondition,
    string tableName = null
)

参数

queryCondition
类型：SystemObject
初始化内置查询条件对话窗口的对象。
tableName (Optional)
类型：SystemString
数据表名。

返回值

类型：IQueryConditionWindow
返回活字格内部查询条件的对话窗口。
示例
代码参照IQueryConditionWindow。
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.GetSelectImageWindow 方法

活字格插件API文档

IBuilderContextGetSelectImageWindow 方法

重载列表
名称 | 说明
GetSelectImageWindow(String, Boolean) | 获取活字格内部选择图片的对话窗口。
GetSelectImageWindow(String, Boolean, String) | 获取活字格内部选择图片的对话窗口。
Top
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.GetSelectImageWindow 方法 (String, Boolean)

活字格插件API文档

IBuilderContextGetSelectImageWindow 方法 (String, Boolean)

获取活字格内部选择图片的对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ISelectImageWindow GetSelectImageWindow(
    string imagePath,
    bool builtIn
)

参数

imagePath
类型：SystemString
初始化选择图片对话窗口的图片名。
builtIn
类型：SystemBoolean
初始化选择图片对话窗口的图片是否是内置图片。

返回值

类型：ISelectImageWindow
返回活字格内部选择图片的对话窗口。
示例
代码参照ISelectImageWindow。
参见

引用

IBuilderContext 接口
GetSelectImageWindow 重载
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.GetSelectImageWindow 方法 (String, Boolean, String)

活字格插件API文档

IBuilderContextGetSelectImageWindow 方法 (String, Boolean, String)

获取活字格内部选择图片的对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ISelectImageWindow GetSelectImageWindow(
    string imagePath,
    bool builtIn,
    string fill
)

参数

imagePath
类型：SystemString
初始化选择图片对话窗口的图片名。
builtIn
类型：SystemBoolean
初始化选择图片对话窗口的图片是否是内置图片。
fill
类型：SystemString
初始化选择图片对话窗口的图片颜色。

返回值

类型：ISelectImageWindow
返回活字格内部选择图片的对话窗口。
示例
代码参照ISelectImageWindow。
参见

引用

IBuilderContext 接口
GetSelectImageWindow 重载
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.GetSortConditionWindow 方法

活字格插件API文档

IBuilderContextGetSortConditionWindow 方法

获取活字格内部排序的对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ISortConditionWindow GetSortConditionWindow(
    Object sortCondition,
    string tableName = null
)

参数

sortCondition
类型：SystemObject
初始化内置排序对话窗口的对象。
tableName (Optional)
类型：SystemString
数据表名。

返回值

类型：ISortConditionWindow
返回活字格内部排序的对话窗口。
示例
代码参照ISortConditionWindow。
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.HideParentDialog 方法

活字格插件API文档

IBuilderContextHideParentDialog 方法

如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog(UserControl)使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void HideParentDialog(
    UserControl userControl
)

参数

userControl
类型：System.Windows.ControlsUserControl
父窗口。
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IBuilderContext.ShowParentDialog 方法

活字格插件API文档

IBuilderContextShowParentDialog 方法

重新显示被隐藏的父窗口，配合HideParentDialog(UserControl)使用。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void ShowParentDialog(
    UserControl userControl
)

参数

userControl
类型：System.Windows.ControlsUserControl
父窗口。
参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICanOverflow 接口

单元格类型是否支持溢出。

例如，如果超链接单元格类型所在的单元格大小不够完全显示字，并且本身和后续单元格均没有合并的情况下，超链接的字会溢出到后续单元格中。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICanOverflow
示例
C#
复制
public class HyperlinkCellType : CellType, ICanOverflow
{
    ...
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo 接口

单元格的信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICellInfo : ICellInfoBase,
    IStyleInfo, IStyleTemplateInfo

ICellInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BackgroundStr | 背景色。 (继承自 IStyleInfo。)
公共属性 | BindingInfo | 单元格的数据绑定信息。 (继承自 ICellInfoBase。)
公共属性 | BorderBottom | 下边框。 (继承自 IStyleInfo。)
公共属性 | BorderLeft | 左边框。 (继承自 IStyleInfo。)
公共属性 | BorderRight | 右边框。 (继承自 IStyleInfo。)
公共属性 | BorderTop | 上边框。 (继承自 IStyleInfo。)
公共属性 | ColumnIndex | 获取单元格所在列的索引。 (继承自 ICellInfoBase。)
公共属性 | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
公共属性 | FontFamily | 字体。 (继承自 IStyleInfo。)
公共属性 | FontSize | 字号。 (继承自 IStyleInfo。)
公共属性 | FontStyle | 字体倾斜。 (继承自 IStyleInfo。)
公共属性 | FontWeight | 字体加粗。 (继承自 IStyleInfo。)
公共属性 | ForegroundStr | 字体颜色。 (继承自 IStyleInfo。)
公共属性 | Formatter | 格式设置。 (继承自 IStyleInfo。)
公共属性 | Formula | 公式。
公共属性 | HorizontalAlignment | 水平对齐方式。 (继承自 IStyleInfo。)
公共属性 | ListViewInfo | 单元格所在表格的信息。 (继承自 ICellInfoBase。)
公共属性 | PageName | 单元格所在的页面名称。 (继承自 ICellInfoBase。)
公共属性 | PageType | 单元格所在页面的类型。
公共属性 | RowIndex | 获取单元格所在行的索引 (继承自 ICellInfoBase。)
公共属性 | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
公共属性 | ShrinkToFit | 缩小字体填充。 (继承自 IStyleInfo。)
公共属性 | Strikethrough | 是否有删除线。 (继承自 IStyleInfo。)
公共属性 | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。 (继承自 IStyleTemplateInfo。)
公共属性 | Text | 单元格的文本。
公共属性 | TextIndent | 缩进。 (继承自 IStyleInfo。)
公共属性 | Underline | 是否有下划线。 (继承自 IStyleInfo。)
公共属性 | Value | 单元格的值。
公共属性 | VerticalAlignment | 垂直对齐方式。 (继承自 IStyleInfo。)
公共属性 | WordWrap | 是否可换行。 (继承自 IStyleInfo。)
Top
方法
 | 名称 | 说明
公共方法 | GetFormulaReferObject | 返回单元格对应的公式对象。 (继承自 ICellInfoBase。)
公共方法 | InMasterPage | 单元格是否在母版页。
公共方法 | InMobilePage | 单元格是否在手机页面。
公共方法 | InPCPage | 单元格是否在PC页面。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo 属性

ICellInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BackgroundStr | 背景色。 (继承自 IStyleInfo。)
公共属性 | BindingInfo | 单元格的数据绑定信息。 (继承自 ICellInfoBase。)
公共属性 | BorderBottom | 下边框。 (继承自 IStyleInfo。)
公共属性 | BorderLeft | 左边框。 (继承自 IStyleInfo。)
公共属性 | BorderRight | 右边框。 (继承自 IStyleInfo。)
公共属性 | BorderTop | 上边框。 (继承自 IStyleInfo。)
公共属性 | ColumnIndex | 获取单元格所在列的索引。 (继承自 ICellInfoBase。)
公共属性 | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
公共属性 | FontFamily | 字体。 (继承自 IStyleInfo。)
公共属性 | FontSize | 字号。 (继承自 IStyleInfo。)
公共属性 | FontStyle | 字体倾斜。 (继承自 IStyleInfo。)
公共属性 | FontWeight | 字体加粗。 (继承自 IStyleInfo。)
公共属性 | ForegroundStr | 字体颜色。 (继承自 IStyleInfo。)
公共属性 | Formatter | 格式设置。 (继承自 IStyleInfo。)
公共属性 | Formula | 公式。
公共属性 | HorizontalAlignment | 水平对齐方式。 (继承自 IStyleInfo。)
公共属性 | ListViewInfo | 单元格所在表格的信息。 (继承自 ICellInfoBase。)
公共属性 | PageName | 单元格所在的页面名称。 (继承自 ICellInfoBase。)
公共属性 | PageType | 单元格所在页面的类型。
公共属性 | RowIndex | 获取单元格所在行的索引 (继承自 ICellInfoBase。)
公共属性 | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
公共属性 | ShrinkToFit | 缩小字体填充。 (继承自 IStyleInfo。)
公共属性 | Strikethrough | 是否有删除线。 (继承自 IStyleInfo。)
公共属性 | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。 (继承自 IStyleTemplateInfo。)
公共属性 | Text | 单元格的文本。
公共属性 | TextIndent | 缩进。 (继承自 IStyleInfo。)
公共属性 | Underline | 是否有下划线。 (继承自 IStyleInfo。)
公共属性 | Value | 单元格的值。
公共属性 | VerticalAlignment | 垂直对齐方式。 (继承自 IStyleInfo。)
公共属性 | WordWrap | 是否可换行。 (继承自 IStyleInfo。)
Top
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo.Formula 属性

活字格插件API文档

ICellInfoFormula 属性

公式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string Formula { get; }

属性值

类型：String
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo.PageType 属性

活字格插件API文档

ICellInfoPageType 属性

单元格所在页面的类型。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyPageKind PageType { get; }

属性值

类型：ForguncyPageKind
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo.Text 属性

活字格插件API文档

ICellInfoText 属性

单元格的文本。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string Text { get; }

属性值

类型：String
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo.Value 属性

活字格插件API文档

ICellInfoValue 属性

单元格的值。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object Value { get; set; }

属性值

类型：Object
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo 方法

ICellInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetFormulaReferObject | 返回单元格对应的公式对象。 (继承自 ICellInfoBase。)
公共方法 | InMasterPage | 单元格是否在母版页。
公共方法 | InMobilePage | 单元格是否在手机页面。
公共方法 | InPCPage | 单元格是否在PC页面。
Top
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo.InMasterPage 方法

活字格插件API文档

ICellInfoInMasterPage 方法

单元格是否在母版页。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool InMasterPage()

返回值

类型：Boolean
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo.InMobilePage 方法

活字格插件API文档

ICellInfoInMobilePage 方法

单元格是否在手机页面。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool InMobilePage()

返回值

类型：Boolean
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellInfo.InPCPage 方法

活字格插件API文档

ICellInfoInPCPage 方法

单元格是否在PC页面。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool InPCPage()

返回值

类型：Boolean
参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellTypeChecker 接口

如果单元格类型需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICellTypeChecker

ICellTypeChecker 类型公开以下成员。

方法
名称 | 说明
CheckCellTypeErrors | 运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ICellTypeChecker 方法

ICellTypeChecker 类型公开以下成员。

方法
名称 | 说明
CheckCellTypeErrors | 运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
Top
参见

引用

ICellTypeChecker 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICellTypeChecker.CheckCellTypeErrors 方法

活字格插件API文档

ICellTypeCheckerCheckCellTypeErrors 方法

运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<ForguncyErrorInfo> CheckCellTypeErrors(
    IBuilderContext context
)

参数

context
类型：GrapeCity.Forguncy.CellTypesIBuilderContext
与单元格类型相关的上下文信息

返回值

类型：IEnumerable ForguncyErrorInfo
返回与单元格类型相关的所有错误和提醒列表。
示例
C#
复制
public class PageNavigateCellType : CellType, ICellTypeChecker
{
    public string PagingListviewName { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCellTypeErrors(IBuilderContext context)
    {
        List<ForguncyErrorInfo> result = new List<ForguncyErrorInfo>();
        if(string.IsNullOrEmpty(PagingListviewName))
        {
            result.Add(new ForguncyErrorInfo()
            {
                ErrorType = ForguncyErrorType.Error,
                Message = "The paging listview name cannot be null."
            });
        }

        return result;
    }
}
参见

引用

ICellTypeChecker 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandCellType 接口

如果单元格类型本身允许执行命令，需实现该接口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICommandCellType

ICommandCellType 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CommandExcuteKind | 触发命令的时机。
公共属性 | CommandList | 命令列表。
Top
示例
C#
复制
public class ButtonCellType : CellType, ICommandCellType
{
    public List<Command> CommandList { get; set; }

    public CommandExcuteKind CommandExcuteKind
    {
        get
        {
            return CommandExcuteKind.Click;
        }
    }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ICommandCellType 属性

ICommandCellType 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CommandExcuteKind | 触发命令的时机。
公共属性 | CommandList | 命令列表。
Top
参见

引用

ICommandCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandCellType.CommandExcuteKind 属性

活字格插件API文档

ICommandCellTypeCommandExcuteKind 属性

触发命令的时机。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
CommandExcuteKind CommandExcuteKind { get; }

属性值

类型：CommandExcuteKind
参见

引用

ICommandCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandCellType.CommandList 属性

活字格插件API文档

ICommandCellTypeCommandList 属性

命令列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Command> CommandList { get; set; }

属性值

类型：List Command
参见

引用

ICommandCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandWindow 接口

活字格内部编辑命令的对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICommandWindow : IWindow

ICommandWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
Top
方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
公共事件 | InitCommandEvent | 初始化对话框中的命令列表。
公共事件 | UpdateCommandEvent | 更新命令数据，即将对话框中的命令列表更新会数据层。
Top
示例
C#
复制
public partial class MenuItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public MenuItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();

        _builderContext = builderContext;
    }

    private void SetCommandListHyperlink_Click(object sender, RoutedEventArgs e)
    {
        var window = _builderContext.GetCommandWindow(CommandScope.Cell);
        window.InitCommandEvent += () =>
        {
            return ViewModel.CommandList;  //基于数据层的命令列表初始化命令对话窗口。
        }
        window.UpdateCommandEvent += (sender2, commandList) =>
        {
            ViewModel.CommandList = commandList;  //提交命令设置到数据层。
        }
        window.Closed += (sender2, e2) =>
        {
            _builderContext.ShowParentDialog(this);  //关闭窗口之后打开父窗口；
        }
        //由于命令设置过程中可能会引用单元格，所以这里暂时先隐藏父窗口；
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ICommandWindow 属性

ICommandWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
Top
参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandWindow 方法

ICommandWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandWindow 事件

ICommandWindow 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
公共事件 | InitCommandEvent | 初始化对话框中的命令列表。
公共事件 | UpdateCommandEvent | 更新命令数据，即将对话框中的命令列表更新会数据层。
Top
参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandWindow.InitCommandEvent 事件

活字格插件API文档

ICommandWindowInitCommandEvent 事件

初始化对话框中的命令列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
event Func<List<Command>> InitCommandEvent

值

类型：SystemFunc List Command
参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ICommandWindow.UpdateCommandEvent 事件

活字格插件API文档

ICommandWindowUpdateCommandEvent 事件

更新命令数据，即将对话框中的命令列表更新会数据层。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
event EventHandler<List<Command>> UpdateCommandEvent

值

类型：SystemEventHandler List Command
参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDependenceCells 接口

依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知依赖了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IDependenceCells

IDependenceCells 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumDependenceCells | 返回插件中所引用的单元格列表。
Top
示例
C#
复制
public class ForguncyMenuCellType : CellType, IDependenceCells
{
    public List<ItemInfo> Items { get; set; }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return this.EnumDependenceCells(this.Items, context);
    }

    private IEnumerable<object> EnumDependenceCells(List<ItemInfo> items, IBuilderContext context)
    {
        foreach (var item in items)
        {
            if(item.Notification != null)
            {
                var cells = context.EnumDependenceCellsFromFormula(item.Notification);
                foreach(var cell in cells)
                {
                    yield return cell;
                }
            }
            if(item.SubItems != null)
            {
                foreach(var cell in EnumDependenceCells(item.SubItems, context))
                {
                    yield return cell;
                }
            }
        }
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public object Notification { get; set; }

    public List<ItemInfo> SubItems { get; set; }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IDependenceCells 方法

IDependenceCells 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumDependenceCells | 返回插件中所引用的单元格列表。
Top
参见

引用

IDependenceCells 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDependenceCells.EnumDependenceCells 方法

活字格插件API文档

IDependenceCellsEnumDependenceCells 方法

返回插件中所引用的单元格列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<Object> EnumDependenceCells(
    IBuilderContext context
)

参数

context
类型：GrapeCity.Forguncy.CellTypesIBuilderContext
上下文信息。

返回值

类型：IEnumerable Object
返回插件中引用的单元格列表。
参见

引用

IDependenceCells 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDisablePropertySettings 接口

获取单元格类型中不可用的样式属性，如对齐方式等。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IDisablePropertySettings

IDisablePropertySettings 类型公开以下成员。

方法
名称 | 说明
GetDisabledPropertySettings | 根据页面类型获取单元格类型不可用的样式属性。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IDisablePropertySettings 方法

IDisablePropertySettings 类型公开以下成员。

方法
名称 | 说明
GetDisabledPropertySettings | 根据页面类型获取单元格类型不可用的样式属性。
Top
参见

引用

IDisablePropertySettings 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDisablePropertySettings.GetDisabledPropertySettings 方法

活字格插件API文档

IDisablePropertySettingsGetDisabledPropertySettings 方法

根据页面类型获取单元格类型不可用的样式属性。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyDisabledSettings GetDisabledPropertySettings(
    ForguncyPageKind pageType
)

参数

pageType
类型：GrapeCity.Forguncy.CellTypesForguncyPageKind
页面类型。

返回值

类型：ForguncyDisabledSettings
返回不可用的样式属性。
示例
C#
复制
public class DateCellType : CellType, IDisablePropertySettings
{
    public ForguncyDisabledSettings GetDisabledPropertySettings(ForguncyPageKind pageType)
    {
        return ForguncyDisabledSettings.TopAlignment | ForguncyDisabledSettings.MiddleAlignment | ForguncyDisabledSettings.BottomAlignment;
    }
}
参见

引用

IDisablePropertySettings 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper 接口

主要用于单元格预览和导出单元格到Excel中的画法。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IDrawingHelper

IDrawingHelper 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
公共属性 | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
公共属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
公共属性 | ZoomFactor | 设计器中的缩放比例。
Top
方法
 | 名称 | 说明
公共方法 | CreateStylePreviewControl | 创建模板样式的预览。
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
公共方法 | GetFontFamily | 从字体字符串获取一个WPF的字体（FontFamily）。
公共方法 | GetForguncyImageControl | 获取图片预览的控件。
公共方法 | GetForguncyImageFullFileName | 获取图片文件的完整路径，该路径被用于GetForguncyImageControl方法。
公共方法 | GetHelpTextForPage | 获取单元格的显示文本，如绑定信息，公式或值等。
公共方法 | GetImageCellSize | 如果生成图片的话可获取单元格所占区域的大小。
公共方法 | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
公共方法 | GetTableDataForPreview(ListObject, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | GetTableDataForPreview(String, ListString, DictionaryString, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | GetTableDataForPreview(String, ListString, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | SetFontInfoToControl | 设置基本的字体颜色，背景色，字体，字号等。
公共方法 | SetFontInfoToFrameworkElement | 设置基本的字体颜色，背景色，字体，字号等。
公共方法 | SetIndentToControl | 设置缩进。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper 属性

IDrawingHelper 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
公共属性 | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
公共属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
公共属性 | ZoomFactor | 设计器中的缩放比例。
Top
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.ForguncyBuiltInImagesFolderPath 属性

活字格插件API文档

IDrawingHelperForguncyBuiltInImagesFolderPath 属性

内建图片所在的文件目录。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ForguncyBuiltInImagesFolderPath { get; }

属性值

类型：String
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.ForguncyImageEditorFolderPath 属性

活字格插件API文档

IDrawingHelperForguncyImageEditorFolderPath 属性

图片选择对话框中上传的图片所在文件目录。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ForguncyImageEditorFolderPath { get; }

属性值

类型：String
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.ForguncyUploadFilesFolderPath 属性

活字格插件API文档

IDrawingHelperForguncyUploadFilesFolderPath 属性

用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ForguncyUploadFilesFolderPath { get; }

属性值

类型：String
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.ZoomFactor 属性

活字格插件API文档

IDrawingHelperZoomFactor 属性

设计器中的缩放比例。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
float ZoomFactor { get; }

属性值

类型：Single
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper 方法

IDrawingHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CreateStylePreviewControl | 创建模板样式的预览。
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
公共方法 | GetFontFamily | 从字体字符串获取一个WPF的字体（FontFamily）。
公共方法 | GetForguncyImageControl | 获取图片预览的控件。
公共方法 | GetForguncyImageFullFileName | 获取图片文件的完整路径，该路径被用于GetForguncyImageControl方法。
公共方法 | GetHelpTextForPage | 获取单元格的显示文本，如绑定信息，公式或值等。
公共方法 | GetImageCellSize | 如果生成图片的话可获取单元格所占区域的大小。
公共方法 | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
公共方法 | GetTableDataForPreview(ListObject, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | GetTableDataForPreview(String, ListString, DictionaryString, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | GetTableDataForPreview(String, ListString, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | SetFontInfoToControl | 设置基本的字体颜色，背景色，字体，字号等。
公共方法 | SetFontInfoToFrameworkElement | 设置基本的字体颜色，背景色，字体，字号等。
公共方法 | SetIndentToControl | 设置缩进。
Top
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.CreateStylePreviewControl 方法

活字格插件API文档

IDrawingHelperCreateStylePreviewControl 方法

创建模板样式的预览。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IStylePreviewControl CreateStylePreviewControl(
    PartStyleUnit style
)

参数

style
类型：GrapeCity.Forguncy.CellTypesPartStyleUnit
模板组件在某一状态下的样式单元。用于预览设计器中预览。

返回值

类型：IStylePreviewControl
用于预览模板样式的组件。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetBrush 方法

活字格插件API文档

IDrawingHelperGetBrush 方法

从颜色字符串获取一个WPF的画笔（Brush）。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Brush GetBrush(
    string colorStr
)

参数

colorStr
类型：SystemString
颜色字符串

返回值

类型：Brush
WPF的画笔
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetFontFamily 方法

活字格插件API文档

IDrawingHelperGetFontFamily 方法

从字体字符串获取一个WPF的字体（FontFamily）。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
FontFamily GetFontFamily(
    string fontFamilyStr
)

参数

fontFamilyStr
类型：SystemString
字体字符串

返回值

类型：FontFamily
WPF的字体（FontFamily）
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetForguncyImageControl 方法

活字格插件API文档

IDrawingHelperGetForguncyImageControl 方法

获取图片预览的控件。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Control GetForguncyImageControl(
    string path,
    string fill
)

参数

path
类型：SystemString
从GetForguncyImageFullFileName方法返回得到的路径
fill
类型：SystemString
填充色。

返回值

类型：Control
预览图片的控件。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetForguncyImageFullFileName 方法

活字格插件API文档

IDrawingHelperGetForguncyImageFullFileName 方法

获取图片文件的完整路径，该路径被用于GetForguncyImageControl方法。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetForguncyImageFullFileName(
    string path,
    bool builtIn
)

参数

path
类型：SystemString
图片文件的路径。
builtIn
类型：SystemBoolean
是否为内建图片。

返回值

类型：String
图片文件的完整路径。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetHelpTextForPage 方法

活字格插件API文档

IDrawingHelperGetHelpTextForPage 方法

获取单元格的显示文本，如绑定信息，公式或值等。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetHelpTextForPage()

返回值

类型：String
返回单元格的显示文本。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetImageCellSize 方法

活字格插件API文档

IDrawingHelperGetImageCellSize 方法

如果生成图片的话可获取单元格所占区域的大小。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Size GetImageCellSize()

返回值

类型：Size
返回图片所占的单元格区域的大小。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetRealHorizontalAlignment 方法

活字格插件API文档

IDrawingHelperGetRealHorizontalAlignment 方法

获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyCellHorizontalAlignment GetRealHorizontalAlignment(
    ICellInfo cellInfo,
    CellType cellType
)

参数

cellInfo
类型：GrapeCity.Forguncy.CellTypesICellInfo
单元格的信息。
cellType
类型：GrapeCity.Forguncy.CellTypesCellType
单元格类型的信息。

返回值

类型：ForguncyCellHorizontalAlignment
返回水平对齐方式。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetTableDataForPreview 方法

活字格插件API文档

IDrawingHelperGetTableDataForPreview 方法

重载列表
 | 名称 | 说明
公共方法 | GetTableDataForPreview(ListObject, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | GetTableDataForPreview(String, ListString, DictionaryString, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
公共方法 | GetTableDataForPreview(String, ListString, Object, Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
Top
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetTableDataForPreview 方法 (List(Object), Object, Boolean)

活字格插件API文档

IDrawingHelperGetTableDataForPreview 方法 (ListObject, Object, Boolean)

如果预览单元格想要从数据表中获取数据，可调用该函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Dictionary<Object, Object>> GetTableDataForPreview(
    List<Object> columnInfos,
    Object queryCondition,
    bool distinct = false
)

参数

columnInfos
类型：System.Collections.GenericList Object
绑定的数据字段列表。
queryCondition
类型：SystemObject
查询条件，由内置查询条件对话框生成的对象。
distinct (Optional)
类型：SystemBoolean
去重。

返回值

类型：List Dictionary Object, Object
返回查询后的数据表的数据。
参见

引用

IDrawingHelper 接口
GetTableDataForPreview 重载
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetTableDataForPreview 方法 (String, List(String), Dictionary(String, Object), Boolean)

活字格插件API文档

IDrawingHelperGetTableDataForPreview 方法 (String, ListString, DictionaryString, Object, Boolean)

如果预览单元格想要从数据表中获取数据，可调用该函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Dictionary<string, Object>> GetTableDataForPreview(
    string tableName,
    List<string> columns,
    Dictionary<string, Object> queryInfo = null,
    bool distinct = false
)

参数

tableName
类型：SystemString
数据表名。
columns
类型：System.Collections.GenericList String
获取的字段列表。
queryInfo (Optional)
类型：System.Collections.GenericDictionary String, Object
当前表的查询条件，多用于主键键值对。
distinct (Optional)
类型：SystemBoolean
去重。

返回值

类型：List Dictionary String, Object
返回查询后的数据表的数据。
参见

引用

IDrawingHelper 接口
GetTableDataForPreview 重载
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.GetTableDataForPreview 方法 (String, List(String), Object, Boolean)

活字格插件API文档

IDrawingHelperGetTableDataForPreview 方法 (String, ListString, Object, Boolean)

如果预览单元格想要从数据表中获取数据，可调用该函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Dictionary<string, Object>> GetTableDataForPreview(
    string tableName,
    List<string> columns,
    Object queryCondition = null,
    bool distinct = false
)

参数

tableName
类型：SystemString
数据表名。
columns
类型：System.Collections.GenericList String
获取的字段列表。
queryCondition (Optional)
类型：SystemObject
查询条件，由内置查询条件对话框生成的对象。
distinct (Optional)
类型：SystemBoolean
去重。

返回值

类型：List Dictionary String, Object
返回查询后的数据表的数据。
参见

引用

IDrawingHelper 接口
GetTableDataForPreview 重载
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.SetFontInfoToControl 方法

活字格插件API文档

IDrawingHelperSetFontInfoToControl 方法

设置基本的字体颜色，背景色，字体，字号等。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void SetFontInfoToControl(
    TextBlock textBlock,
    CopyFontInfoToControlOption copyFontInfoToControlOption
)

参数

textBlock
类型：System.Windows.ControlsTextBlock
要设置样式的文本元素。
copyFontInfoToControlOption
类型：GrapeCity.Forguncy.CellTypesCopyFontInfoToControlOption
要设置的样式选项。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.SetFontInfoToFrameworkElement 方法

活字格插件API文档

IDrawingHelperSetFontInfoToFrameworkElement 方法

设置基本的字体颜色，背景色，字体，字号等。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void SetFontInfoToFrameworkElement(
    FrameworkElement control
)

参数

control
类型：System.WindowsFrameworkElement
要设置样式的WPF元素。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IDrawingHelper.SetIndentToControl 方法

活字格插件API文档

IDrawingHelperSetIndentToControl 方法

设置缩进。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void SetIndentToControl(
    FrameworkElement control
)

参数

control
类型：System.WindowsFrameworkElement
要设置缩进的WPF元素。
参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportCellType 接口

导出单元格类型有特殊处理时需实现该接口，比如生成图片等。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IExportCellType

IExportCellType 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ExportPicture | 是否将单元格类型导出成图片。
Top
方法
 | 名称 | 说明
公共方法 | ExportToExcel | 导出单元格类型时的处理。
Top
示例
C#
复制
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            //var folderPath = ...
            //var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);
            var imageSource = GetImageSource(....);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IExportCellType 属性

IExportCellType 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ExportPicture | 是否将单元格类型导出成图片。
Top
参见

引用

IExportCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportCellType.ExportPicture 属性

活字格插件API文档

IExportCellTypeExportPicture 属性

是否将单元格类型导出成图片。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool ExportPicture { get; }

属性值

类型：Boolean
参见

引用

IExportCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportCellType 方法

IExportCellType 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ExportToExcel | 导出单元格类型时的处理。
Top
参见

引用

IExportCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportCellType.ExportToExcel 方法

活字格插件API文档

IExportCellTypeExportToExcel 方法

导出单元格类型时的处理。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ExportResultInfo ExportToExcel(
    ICellInfo targetCell,
    IExportContext context
)

参数

targetCell
类型：GrapeCity.Forguncy.CellTypesICellInfo
单元格类型所在单元格信息。
context
类型：GrapeCity.Forguncy.CellTypesIExportContext
单元格类型在导出时的上下文信息。

返回值

类型：ExportResultInfo
返回导出的单元格类型的值或图片等。
参见

引用

IExportCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext 接口

导出单元格类型的上下文信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IExportContext

IExportContext 类型公开以下成员。

属性
 | 名称 | 说明
 | ExportImageContext | 导出图片时的上下文信息，如图片保存路径等相关信息。
公共属性 | IsDebugMode | 是否是调试模式。
 | PictureSize | 导出时单元格类型生成的图片大小。
 | ValueProvider | 数据访问器，提供数据表的查询结果。
Top
方法
 | 名称 | 说明
 | GetPictureByByteArray | 根据图片比特数组生成图片对象。
 | GetPictureByPicturePath | 根据图片路径生成图片对象。
公共方法 | SetCellTypeStyleTemplateToCell | 把模板组件在某一状态下的样式设置给单元格。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IExportContext 属性

IExportContext 类型公开以下成员。

属性
 | 名称 | 说明
 | ExportImageContext | 导出图片时的上下文信息，如图片保存路径等相关信息。
公共属性 | IsDebugMode | 是否是调试模式。
 | PictureSize | 导出时单元格类型生成的图片大小。
 | ValueProvider | 数据访问器，提供数据表的查询结果。
Top
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext.ExportImageContext 属性

活字格插件API文档

IExportContextExportImageContext 属性

导出图片时的上下文信息，如图片保存路径等相关信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IExportImageContext ExportImageContext { get; }

属性值

类型：IExportImageContext
示例
C#
复制
public class SignatureCellType : CellType, IExportCellType
{
    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var value = targetCell.Value as string;
        if (string.IsNullOrEmpty(value))
        {
            return null;
        }

        var byteArray = Convert.FromBase64String(value);
        var bitmapImageSource = context.GetPictureByByteArray(byteArray, context.PictureSize.Width, context.PictureSize.Height);
        return new ExportResultInfo()
        {
            ExportValue = null,
            ExportPicture = bitmapImageSource
        }
    }
}
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext.IsDebugMode 属性

活字格插件API文档

IExportContextIsDebugMode 属性

是否是调试模式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsDebugMode { get; }

属性值

类型：Boolean
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext.PictureSize 属性

活字格插件API文档

IExportContextPictureSize 属性

导出时单元格类型生成的图片大小。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
SizeF PictureSize { get; }

属性值

类型：SizeF
示例
C#
复制
public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
{
    var result = new ExportResultInfo();
    if (this.ImageInfo != null)
    {
            //var folderPath = ...
            //var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);
            var imageSource = GetImageSource(....);
            result.ExportPicture = imageSource;
    }

    return result;
}
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext.ValueProvider 属性

活字格插件API文档

IExportContextValueProvider 属性

数据访问器，提供数据表的查询结果。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IExportValueProvider ValueProvider { get; }

属性值

类型：IExportValueProvider
示例
C#
复制
public class RadioGroupCellType : CellType, IExportCellType
{
    public string TableName { get; set; }

    public string TextColumn { get; set; }

    public string ValueColumn { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();

       Dictionary<string, object> queryInfo = new Dictionary<string, object>();
        queryInfo.Add(this.ValueColumn, targetCell.Value);

        var tableData = context.ValueProvider.GetTableData(TableName, new List<string>() { this.TextColumn, this.ValueColumn }, queryInfo, true);
        if(tableData != null && tableData.Count > 0)
        {
            result.ExportValue = tableData[0][this.TextColumn];
        }

        //export image
        //to do...

        return result;
    }
}
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext 方法

IExportContext 类型公开以下成员。

方法
 | 名称 | 说明
 | GetPictureByByteArray | 根据图片比特数组生成图片对象。
 | GetPictureByPicturePath | 根据图片路径生成图片对象。
公共方法 | SetCellTypeStyleTemplateToCell | 把模板组件在某一状态下的样式设置给单元格。
Top
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext.GetPictureByByteArray 方法

活字格插件API文档

IExportContextGetPictureByByteArray 方法

根据图片比特数组生成图片对象。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Stream GetPictureByByteArray(
    byte[] byteArray,
    double width,
    double height
)

参数

byteArray
类型：SystemByte
图片比特数组。
width
类型：SystemDouble
图片宽度。
height
类型：SystemDouble
图片高度。

返回值

类型：Stream
返回图片对象。
示例
C#
复制
public class SignatureCellType : CellType, IExportCellType
{
    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var value = targetCell.Value as string;
        if (string.IsNullOrEmpty(value))
        {
            return null;
        }

        var byteArray = Convert.FromBase64String(value);
        var bitmapImageSource = context.GetPictureByByteArray(byteArray, context.PictureSize.Width, context.PictureSize.Height);
        return new ExportResultInfo()
        {
            ExportValue = null,
            ExportPicture = bitmapImageSource
        }
    }
}
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext.GetPictureByPicturePath 方法

活字格插件API文档

IExportContextGetPictureByPicturePath 方法

根据图片路径生成图片对象。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Stream GetPictureByPicturePath(
    string path,
    double width,
    double height
)

参数

path
类型：SystemString
图片路径。
width
类型：SystemDouble
图片宽度。
height
类型：SystemDouble
图片高度。

返回值

类型：Stream
返回图片对象。
示例
C#
复制
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            //var folderPath = ...
            //var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);
            var imageSource = GetImageSource(....);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportContext.SetCellTypeStyleTemplateToCell 方法

活字格插件API文档

IExportContextSetCellTypeStyleTemplateToCell 方法

把模板组件在某一状态下的样式设置给单元格。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void SetCellTypeStyleTemplateToCell(
    PartStyleUnit style,
    ExportResultInfo exportInfo
)

参数

style
类型：GrapeCity.Forguncy.CellTypesPartStyleUnit
模板组件的状态样式单元。
exportInfo
类型：GrapeCity.Forguncy.CellTypesExportResultInfo
导出单元格类型的返回结果。
参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportValueProvider 接口

数据访问器，提供数据表的查询结果。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IExportValueProvider
方法
 | 名称 | 说明
公共方法 | GetTableData(ListObject, DictionaryObject, Object, Boolean) | 获取数据库表中的数据。
公共方法 | GetTableData(ListObject, Object, Boolean) | 获取数据库表中的数据。
 | GetTableData(String, ListString, ListString, DictionaryString, Object, Boolean) | 获取数据库表中的数据。
公共方法 | GetTableData(String, ListString, ListString, Object, Boolean) | 获取数据库表中的数据。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IExportValueProvider 方法

方法
 | 名称 | 说明
公共方法 | GetTableData(ListObject, DictionaryObject, Object, Boolean) | 获取数据库表中的数据。
公共方法 | GetTableData(ListObject, Object, Boolean) | 获取数据库表中的数据。
 | GetTableData(String, ListString, ListString, DictionaryString, Object, Boolean) | 获取数据库表中的数据。
公共方法 | GetTableData(String, ListString, ListString, Object, Boolean) | 获取数据库表中的数据。
Top
参见

引用

IExportValueProvider 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportValueProvider.GetTableData 方法

活字格插件API文档

IExportValueProviderGetTableData 方法

重载列表
 | 名称 | 说明
公共方法 | GetTableData(ListObject, DictionaryObject, Object, Boolean) | 获取数据库表中的数据。
公共方法 | GetTableData(ListObject, Object, Boolean) | 获取数据库表中的数据。
 | GetTableData(String, ListString, ListString, DictionaryString, Object, Boolean) | 获取数据库表中的数据。
公共方法 | GetTableData(String, ListString, ListString, Object, Boolean) | 获取数据库表中的数据。
Top
参见

引用

IExportValueProvider 接口
GrapeCity.Forguncy.CellTypes 命名空间


IExportValueProvider.GetTableData 方法 (List(Object), Dictionary(Object, Object), Boolean)

活字格插件API文档

IExportValueProviderGetTableData 方法 (ListObject, DictionaryObject, Object, Boolean)

获取数据库表中的数据。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Dictionary<Object, Object>> GetTableData(
    List<Object> columnInfos,
    Dictionary<Object, Object> queryInfo,
    bool distinct = false
)

参数

columnInfos
类型：System.Collections.GenericList Object
绑定的数据表中的字段列表。
queryInfo
类型：System.Collections.GenericDictionary Object, Object
绑定字段查询条件。
distinct (Optional)
类型：SystemBoolean
是否去重。

返回值

类型：List Dictionary Object, Object
查询后的数据库表中的数据。
参见

引用

IExportValueProvider 接口
GetTableData 重载
GrapeCity.Forguncy.CellTypes 命名空间


IExportValueProvider.GetTableData 方法 (List(Object), Object, Boolean)

活字格插件API文档

IExportValueProviderGetTableData 方法 (ListObject, Object, Boolean)

获取数据库表中的数据。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Dictionary<Object, Object>> GetTableData(
    List<Object> columnInfos,
    Object queryCondition,
    bool distinct = false
)

参数

columnInfos
类型：System.Collections.GenericList Object
绑定的数据表中的字段列表。
queryCondition
类型：SystemObject
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
distinct (Optional)
类型：SystemBoolean
是否去重。

返回值

类型：List Dictionary Object, Object
查询后的数据库表中的数据。
参见

引用

IExportValueProvider 接口
GetTableData 重载
GrapeCity.Forguncy.CellTypes 命名空间


IExportValueProvider.GetTableData 方法 (String, List(String), List(String), Dictionary(String, Object), Boolean)

活字格插件API文档

IExportValueProviderGetTableData 方法 (String, ListString, ListString, DictionaryString, Object, Boolean)

获取数据库表中的数据。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Dictionary<string, Object>> GetTableData(
    string tableName,
    List<string> columns,
    List<string> pkl,
    Dictionary<string, Object> queryInfo = null,
    bool distinct = false
)

参数

tableName
类型：SystemString
数据表名。
columns
类型：System.Collections.GenericList String
查询的列名集合。
pkl
类型：System.Collections.GenericList String
查询数据的主键集合。
queryInfo (Optional)
类型：System.Collections.GenericDictionary String, Object
简单查询条件。
distinct (Optional)
类型：SystemBoolean
是否去重。

返回值

类型：List Dictionary String, Object
查询后的数据库表中的数据。
示例
代码查看ValueProvider
参见

引用

IExportValueProvider 接口
GetTableData 重载
GrapeCity.Forguncy.CellTypes 命名空间


IExportValueProvider.GetTableData 方法 (String, List(String), List(String), Object, Boolean)

活字格插件API文档

IExportValueProviderGetTableData 方法 (String, ListString, ListString, Object, Boolean)

获取数据库表中的数据。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Dictionary<string, Object>> GetTableData(
    string tableName,
    List<string> columns,
    List<string> pkl,
    Object queryCondition = null,
    bool distinct = false
)

参数

tableName
类型：SystemString
数据表名。
columns
类型：System.Collections.GenericList String
查询的列名集合。
pkl
类型：System.Collections.GenericList String
查询数据的主键集合。
queryCondition (Optional)
类型：SystemObject
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
distinct (Optional)
类型：SystemBoolean
去重。

返回值

类型：List Dictionary String, Object
查询后的数据库表中的数据。
参见

引用

IExportValueProvider 接口
GetTableData 重载
GrapeCity.Forguncy.CellTypes 命名空间


IForguncyFormatter 接口

单元格格式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IForguncyFormatter

IForguncyFormatter 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | FormatString | 格式字符串。
Top
方法
 | 名称 | 说明
公共方法 | Format | 通过格式字符串转换成值。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IForguncyFormatter 属性

IForguncyFormatter 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | FormatString | 格式字符串。
Top
参见

引用

IForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


IForguncyFormatter.FormatString 属性

活字格插件API文档

IForguncyFormatterFormatString 属性

格式字符串。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string FormatString { get; }

属性值

类型：String
参见

引用

IForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


IForguncyFormatter 方法

IForguncyFormatter 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Format | 通过格式字符串转换成值。
Top
参见

引用

IForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


IForguncyFormatter.Format 方法

活字格插件API文档

IForguncyFormatterFormat 方法

通过格式字符串转换成值。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string Format(
    Object value
)

参数

value
类型：SystemObject
原始值。

返回值

类型：String
返回转换之后的值。
参见

引用

IForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


IIgnoreAlternativeRowBackColorWhenExport 接口

配合IExportCellType使用，导出Excel时不使用页面中表格的交替色作为背景色，如表格中的按钮导出到Excel时不使用交替色作为背景色。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IIgnoreAlternativeRowBackColorWhenExport
示例
C#
复制
public class ButtonCellType : CellType, IExportCellType, IIgnoreAlternativeRowBackColorWhenExport
{
    ...
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IPagingCellType 接口

表示单元格为分页单元格

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IPagingCellType

IPagingCellType 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ListviewName | 分页单元对应的表格名称
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IPagingCellType 属性

IPagingCellType 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ListviewName | 分页单元对应的表格名称
Top
参见

引用

IPagingCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IPagingCellType.ListviewName 属性

活字格插件API文档

IPagingCellTypeListviewName 属性

分页单元对应的表格名称

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ListviewName { get; set; }

属性值

类型：String
参见

引用

IPagingCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IQueryConditionWindow 接口

活字格内置的设置查询条件的对话窗口。

注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现IReferenceFormula和IDependenceCells这两个接口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IQueryConditionWindow : IWindow

IQueryConditionWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | QueryCondition | 查询条件。
Top
方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
示例
C#
复制
[Designer("Forguncy.TreeCellTypeDesigner, Forguncy")]
public class TreeCellType : CellType, IDependenceCells, IReferenceFormula
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        if (this.BindingTreeLevelInfo != null)
        {
            return this.BindingTreeLevelInfo.GetFormulaReferObjects(location);
        }
        return Enumerable.Empty<LocatedObject<object>>();
    }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return EnumDependenceCells(this.BindingTreeLevelInfo, context);
    }

    private IEnumerable<object> EnumDependenceCells(BindingTreeLevelInfo info, IBuilderContext context)
    {
        var result = Enumerable.Empty<object>();
        if (info != null)
        {
            if (info.QueryCondition != null)
            {
                result = result.Union(context.EnumDependenceCells(info.QueryCondition) ?? Enumerable.Empty<object>());
            }
            if (info.SubBindingTreeLevelInfo != null)
            {
                result = result.Union(EnumDependenceCells(info.SubBindingTreeLevelInfo, context) ?? Enumerable.Empty<object>());
            }
        }
        return result;
    }
}

public class TreeCellTypeDesigner : CellTypeDesigner<CurrentUserCellType>
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }

}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出查询对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditQueryConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的查询条件和表名初始化查询对话窗口。*/
        var window = _builderContext?.GetQueryConditionWindow(queryCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的查询条件提交到数据层。*/
                /*ViewModel.QueryCondition = window.QueryCondition;*/

                /*重新打开父窗口。*/
                _builderContext.ShowParentDialog(this);
            }
        }
        /*由于查询条件中可能引用单元格，所以这里需要暂时隐藏父窗口。*/
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object QueryCondition { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("TreeCellType").AppendProperty("BindingTreeLevelInfo");
        if(this.QueryCondition is IReferenceFormula)
        {
            var items = (this.QueryCondition as IReferenceFormula).GetFormulaReferObjects(newLocation);
            foreach (var item in items)
            {
                yield return item;
            }
        }
        if (this.SubBindingTreeLevelInfo != null)
        {
            var items = this.SubBindingTreeLevelInfo.GetFormulaReferObjects(location);
            foreach (var item in items)
            {
                yield return item;
            }
        }
    }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IQueryConditionWindow 属性

IQueryConditionWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | QueryCondition | 查询条件。
Top
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IQueryConditionWindow.QueryCondition 属性

活字格插件API文档

IQueryConditionWindowQueryCondition 属性

查询条件。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object QueryCondition { get; }

属性值

类型：Object
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IQueryConditionWindow 方法

IQueryConditionWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IQueryConditionWindow 事件

IQueryConditionWindow 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IReferenceCommand 接口

如果一个单元格不是ICommandCellType，但是该单元格内部属性中有命令设置，如菜单单元格类型，需实现该接口； 否则有些命令执行会出错，而且查找所有引用会有遗漏。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferenceCommand

IReferenceCommand 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetCommandList | 返回插件内部属性使用到的所有的命令列表。
Top
示例
C#
复制
public class MyMenuCellType : CellType, IReferenceCommand
{
    public List<ItemInfo> Items { get; set; }

    public IEnumerable<LocatedObject<List<Command>>> GetCommandList(LocationIndicator location)
    {
        return this.GetCommandList(this.Items, location);
    }

    private IEnumerable<LocatedObject<List<Command>>> GetCommandList(List<ItemInfo> items, LocationIndicator location)
    {
        if (items == null)
        {
            yield break;
        }
        foreach (var item in items)
        {
            if (item.CommandList != null)
            {
                var newLocation = location.AppendProperty("MyMenuCellType").AppendProperty(item.Text).AppendProperty("CommandList");
                yield return new LocatedObject<List<Command>>(item.CommandList, newLocation);
            }

            foreach (var item2 in GetCommandList(item.SubItems, location))
            {
                yield return item2;
            }
        }
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public List<Command> CommandList { get; set; }

    public List<ItemInfo> SubItems { get; set; }
    //...
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IReferenceCommand 方法

IReferenceCommand 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetCommandList | 返回插件内部属性使用到的所有的命令列表。
Top
参见

引用

IReferenceCommand 接口
GrapeCity.Forguncy.CellTypes 命名空间


IReferenceCommand.GetCommandList 方法

活字格插件API文档

IReferenceCommandGetCommandList 方法

返回插件内部属性使用到的所有的命令列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<LocatedObject<List<Command>>> GetCommandList(
    LocationIndicator location
)

参数

location
类型：GrapeCity.Forguncy.PluginLocationIndicator
坐标定位器。

返回值

类型：IEnumerable LocatedObject List Command
返回插件内部属性使用到的所有的命令列表。
参见

引用

IReferenceCommand 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISelectImageWindow 接口

内置图片选择对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISelectImageWindow : IWindow

ISelectImageWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BuiltIn | 返回选中图片是否是内置图片。
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | ImageColor | 返回选中图片的填充颜色
公共属性 | ImagePath | 返回选中图片的名称。
Top
方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
示例
C#
复制
public partial class MenuItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public MenuItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();

        _builderContext = builderContext;
    }

    private void SelectImageHyperlink_Click(object sender, RoutedEventArgs e)
    {
        var window = _builderContext.GetSelectImageWindow(ViewModel.ImagePath, ViewModel.IsBuiltInImage);
        window.Closed += (sender2, e2) =>
        {
            if (window.DialogResult == true)
            {
                ViewModel.ImagePath = window.ImagePath;
                ViewModel.IsBuiltInImage = window.BuiltIn;
            }
        }

        window.ShowDialog();
    }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISelectImageWindow 属性

ISelectImageWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BuiltIn | 返回选中图片是否是内置图片。
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | ImageColor | 返回选中图片的填充颜色
公共属性 | ImagePath | 返回选中图片的名称。
Top
参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISelectImageWindow.BuiltIn 属性

活字格插件API文档

ISelectImageWindowBuiltIn 属性

返回选中图片是否是内置图片。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool BuiltIn { get; }

属性值

类型：Boolean
参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISelectImageWindow.ImageColor 属性

活字格插件API文档

ISelectImageWindowImageColor 属性

返回选中图片的填充颜色

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ImageColor { get; }

属性值

类型：String
参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISelectImageWindow.ImagePath 属性

活字格插件API文档

ISelectImageWindowImagePath 属性

返回选中图片的名称。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ImagePath { get; }

属性值

类型：String
参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISelectImageWindow 方法

ISelectImageWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISelectImageWindow 事件

ISelectImageWindow 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISortConditionWindow 接口

活字格内置的设置排序条件的对话窗口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISortConditionWindow : IWindow

ISortConditionWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | SortCondition | 排序条件。
Top
方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
示例
C#
复制
public class TreeCellTypeDesigner : CellTypeDesigner<TreeCellType>
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出排序对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditSortConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的排序条件和表名初始化排序对话窗口。*/
        var window = _builderContext?.GetSortConditionWindow(sortCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的排序条件提交到数据层。*/
                /*ViewModel.SortCondition = window.SortCondition;*/
            }
        }
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object SortCondition { get; set; }
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISortConditionWindow 属性

ISortConditionWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | SortCondition | 排序条件。
Top
参见

引用

ISortConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISortConditionWindow.SortCondition 属性

活字格插件API文档

ISortConditionWindowSortCondition 属性

排序条件。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object SortCondition { get; }

属性值

类型：Object
参见

引用

ISortConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISortConditionWindow 方法

ISortConditionWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
参见

引用

ISortConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISortConditionWindow 事件

ISortConditionWindow 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
参见

引用

ISortConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStaticValueCellType 接口

忽略单元格的值，可以自定义单元格类型返回的值； 例如，如果一个单元格引用登录用户单元格类型的值，返回的是当前用户，而非单元格上的值或0。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IStaticValueCellType

IStaticValueCellType 类型公开以下成员。

属性
名称 | 说明
CellCustomValue | 单元格返回的自定义固定值。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IStaticValueCellType 属性

IStaticValueCellType 类型公开以下成员。

属性
名称 | 说明
CellCustomValue | 单元格返回的自定义固定值。
Top
参见

引用

IStaticValueCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStaticValueCellType.CellCustomValue 属性

活字格插件API文档

IStaticValueCellTypeCellCustomValue 属性

单元格返回的自定义固定值。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object CellCustomValue { get; }

属性值

类型：Object
示例
C#
复制
public class CurrentUserCellType : CellType, IStaticValueCellType
{
    public object CellCustomValue
    {
        get
        {
            return "%CurrentUser%";
        }
    }
}
参见

引用

IStaticValueCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo 接口

设置样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IStyleInfo

IStyleInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BackgroundStr | 背景色。
公共属性 | BorderBottom | 下边框。
公共属性 | BorderLeft | 左边框。
公共属性 | BorderRight | 右边框。
公共属性 | BorderTop | 上边框。
公共属性 | FontFamily | 字体。
公共属性 | FontSize | 字号。
公共属性 | FontStyle | 字体倾斜。
公共属性 | FontWeight | 字体加粗。
公共属性 | ForegroundStr | 字体颜色。
公共属性 | Formatter | 格式设置。
公共属性 | HorizontalAlignment | 水平对齐方式。
公共属性 | ShrinkToFit | 缩小字体填充。
公共属性 | Strikethrough | 是否有删除线。
公共属性 | TextIndent | 缩进。
公共属性 | Underline | 是否有下划线。
公共属性 | VerticalAlignment | 垂直对齐方式。
公共属性 | WordWrap | 是否可换行。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo 属性

IStyleInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BackgroundStr | 背景色。
公共属性 | BorderBottom | 下边框。
公共属性 | BorderLeft | 左边框。
公共属性 | BorderRight | 右边框。
公共属性 | BorderTop | 上边框。
公共属性 | FontFamily | 字体。
公共属性 | FontSize | 字号。
公共属性 | FontStyle | 字体倾斜。
公共属性 | FontWeight | 字体加粗。
公共属性 | ForegroundStr | 字体颜色。
公共属性 | Formatter | 格式设置。
公共属性 | HorizontalAlignment | 水平对齐方式。
公共属性 | ShrinkToFit | 缩小字体填充。
公共属性 | Strikethrough | 是否有删除线。
公共属性 | TextIndent | 缩进。
公共属性 | Underline | 是否有下划线。
公共属性 | VerticalAlignment | 垂直对齐方式。
公共属性 | WordWrap | 是否可换行。
Top
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.BackgroundStr 属性

活字格插件API文档

IStyleInfoBackgroundStr 属性

背景色。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string BackgroundStr { get; }

属性值

类型：String
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.BorderBottom 属性

活字格插件API文档

IStyleInfoBorderBottom 属性

下边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IBorderLine BorderBottom { get; }

属性值

类型：IBorderLine
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.BorderLeft 属性

活字格插件API文档

IStyleInfoBorderLeft 属性

左边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IBorderLine BorderLeft { get; }

属性值

类型：IBorderLine
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.BorderRight 属性

活字格插件API文档

IStyleInfoBorderRight 属性

右边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IBorderLine BorderRight { get; }

属性值

类型：IBorderLine
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.BorderTop 属性

活字格插件API文档

IStyleInfoBorderTop 属性

上边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IBorderLine BorderTop { get; }

属性值

类型：IBorderLine
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.FontFamily 属性

活字格插件API文档

IStyleInfoFontFamily 属性

字体。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string FontFamily { get; }

属性值

类型：String
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.FontSize 属性

活字格插件API文档

IStyleInfoFontSize 属性

字号。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
double FontSize { get; }

属性值

类型：Double
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.FontStyle 属性

活字格插件API文档

IStyleInfoFontStyle 属性

字体倾斜。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string FontStyle { get; }

属性值

类型：String
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.FontWeight 属性

活字格插件API文档

IStyleInfoFontWeight 属性

字体加粗。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string FontWeight { get; }

属性值

类型：String
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.ForegroundStr 属性

活字格插件API文档

IStyleInfoForegroundStr 属性

字体颜色。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ForegroundStr { get; }

属性值

类型：String
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.Formatter 属性

活字格插件API文档

IStyleInfoFormatter 属性

格式设置。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IForguncyFormatter Formatter { get; }

属性值

类型：IForguncyFormatter
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.HorizontalAlignment 属性

活字格插件API文档

IStyleInfoHorizontalAlignment 属性

水平对齐方式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyCellHorizontalAlignment HorizontalAlignment { get; }

属性值

类型：ForguncyCellHorizontalAlignment
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.ShrinkToFit 属性

活字格插件API文档

IStyleInfoShrinkToFit 属性

缩小字体填充。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool ShrinkToFit { get; }

属性值

类型：Boolean
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.Strikethrough 属性

活字格插件API文档

IStyleInfoStrikethrough 属性

是否有删除线。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool? Strikethrough { get; }

属性值

类型：Nullable Boolean
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.TextIndent 属性

活字格插件API文档

IStyleInfoTextIndent 属性

缩进。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
int TextIndent { get; }

属性值

类型：Int32
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.Underline 属性

活字格插件API文档

IStyleInfoUnderline 属性

是否有下划线。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool? Underline { get; }

属性值

类型：Nullable Boolean
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.VerticalAlignment 属性

活字格插件API文档

IStyleInfoVerticalAlignment 属性

垂直对齐方式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyCellVerticalAlignment VerticalAlignment { get; }

属性值

类型：ForguncyCellVerticalAlignment
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleInfo.WordWrap 属性

活字格插件API文档

IStyleInfoWordWrap 属性

是否可换行。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool WordWrap { get; }

属性值

类型：Boolean
参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStylePreviewControl 接口

用于预览单元格样式模板组件的控件。可实现对边框、圆角、阴影的预览。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IStylePreviewControl

IStylePreviewControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Child | 预览时包含的内部控件。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IStylePreviewControl 属性

IStylePreviewControl 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Child | 预览时包含的内部控件。
Top
参见

引用

IStylePreviewControl 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStylePreviewControl.Child 属性

活字格插件API文档

IStylePreviewControlChild 属性

预览时包含的内部控件。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
UIElement Child { get; set; }

属性值

类型：UIElement
参见

引用

IStylePreviewControl 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateCustomDrawingSupport 接口

支持改写CellType的设计时的预览。如果实现了这个接口，CellType会用这个方法在样式选择中显示，如果没有实现则会使用CellTypeDesigner上的GetDrawingControl方法来预览。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IStyleTemplateCustomDrawingSupport

IStyleTemplateCustomDrawingSupport 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPreviewSize | 获取设计时预览的大小。 Get preview size in designer.
公共方法 | GetStyleTemplateCustomDrawingControl | 支持改写单元格模板样式的预览。如果修改单元格模板样式的预览效果，需重写该方法。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateCustomDrawingSupport 方法

IStyleTemplateCustomDrawingSupport 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPreviewSize | 获取设计时预览的大小。 Get preview size in designer.
公共方法 | GetStyleTemplateCustomDrawingControl | 支持改写单元格模板样式的预览。如果修改单元格模板样式的预览效果，需重写该方法。
Top
参见

引用

IStyleTemplateCustomDrawingSupport 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateCustomDrawingSupport.GetPreviewSize 方法

活字格插件API文档

IStyleTemplateCustomDrawingSupportGetPreviewSize 方法

获取设计时预览的大小。 Get preview size in designer.

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Size GetPreviewSize()

返回值

类型：Size
预览的大小。
参见

引用

IStyleTemplateCustomDrawingSupport 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateCustomDrawingSupport.GetStyleTemplateCustomDrawingControl 方法

活字格插件API文档

IStyleTemplateCustomDrawingSupportGetStyleTemplateCustomDrawingControl 方法

支持改写单元格模板样式的预览。如果修改单元格模板样式的预览效果，需重写该方法。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
FrameworkElement GetStyleTemplateCustomDrawingControl(
    ICellInfo cellInfo,
    IDrawingHelper drawingHelper,
    string displayText
)

参数

cellInfo
类型：GrapeCity.Forguncy.CellTypesICellInfo
单元格信息。
drawingHelper
类型：GrapeCity.Forguncy.CellTypesIDrawingHelper
画法帮助工具。
displayText
类型：SystemString
显示文本。

返回值

类型：FrameworkElement
参见

引用

IStyleTemplateCustomDrawingSupport 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateInfo 接口

单元格模板样式的样式信息。若想添加单元格模板样式的设计时预览，该单元格需要实现此接口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IStyleTemplateInfo

IStyleTemplateInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateInfo 属性

IStyleTemplateInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | StyleTemplateInfo | 单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。
Top
参见

引用

IStyleTemplateInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateInfo.StyleTemplateInfo 属性

活字格插件API文档

IStyleTemplateInfoStyleTemplateInfo 属性

单元格模板样式的所有信息。用于该单元模板样式的设计时预览。用字典存储模板组件。Key表示一个模板组件，Value是模板组件的样式信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Dictionary<string, TemplatePartStyle> StyleTemplateInfo { get; }

属性值

类型：Dictionary String, TemplatePartStyle
参见

引用

IStyleTemplateInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplatesNeedLoad 接口

单元格额外需要加载的模板样式。若想某单元格加载额外的模板样式，需要实现此接口。若支持 IStyleTemplateSupport 接口，该接口对应模板样式会默认加载。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IStyleTemplatesNeedLoad

IStyleTemplatesNeedLoad 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TemplateKeys | 单元格模板样式的标识列表。列表值必须取自于某个CellTypeStyleTemplate的Key，表明该单元格的某个模板样式。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplatesNeedLoad 属性

IStyleTemplatesNeedLoad 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TemplateKeys | 单元格模板样式的标识列表。列表值必须取自于某个CellTypeStyleTemplate的Key，表明该单元格的某个模板样式。
Top
参见

引用

IStyleTemplatesNeedLoad 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplatesNeedLoad.TemplateKeys 属性

活字格插件API文档

IStyleTemplatesNeedLoadTemplateKeys 属性

单元格模板样式的标识列表。列表值必须取自于某个CellTypeStyleTemplate的Key，表明该单元格的某个模板样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<string> TemplateKeys { get; set; }

属性值

类型：List String
参见

引用

IStyleTemplatesNeedLoad 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateSupport 接口

单元格支持模板样式。若想某单元格支持模板样式，需要实现此接口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IStyleTemplateSupport

IStyleTemplateSupport 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TemplateKey | 单元格模板样式的标识。它必须取自于某个CellTypeStyleTemplate的Key。表明该单元格应用了哪一个模板样式。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateSupport 属性

IStyleTemplateSupport 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TemplateKey | 单元格模板样式的标识。它必须取自于某个CellTypeStyleTemplate的Key。表明该单元格应用了哪一个模板样式。
Top
参见

引用

IStyleTemplateSupport 接口
GrapeCity.Forguncy.CellTypes 命名空间


IStyleTemplateSupport.TemplateKey 属性

活字格插件API文档

IStyleTemplateSupportTemplateKey 属性

单元格模板样式的标识。它必须取自于某个CellTypeStyleTemplate的Key。表明该单元格应用了哪一个模板样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string TemplateKey { get; set; }

属性值

类型：String
参见

引用

IStyleTemplateSupport 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportDataValidation 接口

主要用于支持单元格类型的数据验证。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISupportDataValidation

ISupportDataValidation 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DataValidationLink | 支持单元格类型的数据验证
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISupportDataValidation 属性

ISupportDataValidation 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DataValidationLink | 支持单元格类型的数据验证
Top
参见

引用

ISupportDataValidation 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportDataValidation.DataValidationLink 属性

活字格插件API文档

ISupportDataValidationDataValidationLink 属性

支持单元格类型的数据验证

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
DataValidationLink DataValidationLink { get; set; }

属性值

类型：DataValidationLink
参见

引用

ISupportDataValidation 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportDefaultValue 接口

表示单元格支持默认值

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISupportDefaultValue

ISupportDefaultValue 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultValue | 默认值
公共属性 | NeedFormatDefaultValue | 返回True表示用户设置默认值时，活字格会做智能的类型转换，如把字符串"123",转成数字123并保存，反之则只保存字符串
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISupportDefaultValue 属性

ISupportDefaultValue 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultValue | 默认值
公共属性 | NeedFormatDefaultValue | 返回True表示用户设置默认值时，活字格会做智能的类型转换，如把字符串"123",转成数字123并保存，反之则只保存字符串
Top
参见

引用

ISupportDefaultValue 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportDefaultValue.DefaultValue 属性

活字格插件API文档

ISupportDefaultValueDefaultValue 属性

默认值

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object DefaultValue { get; set; }

属性值

类型：Object
参见

引用

ISupportDefaultValue 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportDefaultValue.NeedFormatDefaultValue 属性

活字格插件API文档

ISupportDefaultValueNeedFormatDefaultValue 属性

返回True表示用户设置默认值时，活字格会做智能的类型转换，如把字符串"123",转成数字123并保存，反之则只保存字符串

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool NeedFormatDefaultValue { get; }

属性值

类型：Boolean
参见

引用

ISupportDefaultValue 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportDisable 接口

表示单元格支持禁用

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISupportDisable

ISupportDisable 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsDisabled | 是否禁用，值为True表示禁用，否则为启用
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISupportDisable 属性

ISupportDisable 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsDisabled | 是否禁用，值为True表示禁用，否则为启用
Top
参见

引用

ISupportDisable 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportDisable.IsDisabled 属性

活字格插件API文档

ISupportDisableIsDisabled 属性

是否禁用，值为True表示禁用，否则为启用

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsDisabled { get; set; }

属性值

类型：Boolean
参见

引用

ISupportDisable 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportPropertyInitialize 接口

设置单元格类型的默认属性值。 例如，可以设置【超链接】单元格的点击模式默认为单元格而非文字区域。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISupportPropertyInitialize

ISupportPropertyInitialize 类型公开以下成员。

方法
名称 | 说明
InitDefaultPropertyValues | 初始化默认属性值。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISupportPropertyInitialize 方法

ISupportPropertyInitialize 类型公开以下成员。

方法
名称 | 说明
InitDefaultPropertyValues | 初始化默认属性值。
Top
参见

引用

ISupportPropertyInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportPropertyInitialize.InitDefaultPropertyValues 方法

活字格插件API文档

ISupportPropertyInitializeInitDefaultPropertyValues 方法

初始化默认属性值。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes.Design (在 GrapeCity.Forguncy.CellTypes.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void InitDefaultPropertyValues(
    IBuilderContext context
)

参数

context
类型：GrapeCity.Forguncy.CellTypesIBuilderContext
初始化需要的参数
示例
C#
复制
public class HyperlinkCellType : CellType, ISupportPropertyInitialize
{
    [DisplayName("点击模式")]
    public HyperlinkClickMode ClickMode { get; set; }

    public void InitDefaultPropertyValues(IBuilderContext context)
    {
        this.ClickMode = HyperlinkClickMode.Cell;
    }
}

public enum HyperlinkClickMode
{
    [Description("文字")]
    Text,
    [Description("单元格")]
    Cell
}
参见

引用

ISupportPropertyInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportReadOnly 接口

表示单元格支持只读

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISupportReadOnly

ISupportReadOnly 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ReadOnly | 是否只读，值为True表示只读，否则为可编辑
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISupportReadOnly 属性

ISupportReadOnly 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ReadOnly | 是否只读，值为True表示只读，否则为可编辑
Top
参见

引用

ISupportReadOnly 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportReadOnly.ReadOnly 属性

活字格插件API文档

ISupportReadOnlyReadOnly 属性

是否只读，值为True表示只读，否则为可编辑

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool ReadOnly { get; }

属性值

类型：Boolean
参见

引用

ISupportReadOnly 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportStyleInitialize 接口

设置单元格类型的默认样式和属性。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISupportStyleInitialize

ISupportStyleInitialize 类型公开以下成员。

方法
名称 | 说明
GetDefaultStyleInfos | 设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISupportStyleInitialize 方法

ISupportStyleInitialize 类型公开以下成员。

方法
名称 | 说明
GetDefaultStyleInfos | 设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
Top
参见

引用

ISupportStyleInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportStyleInitialize.GetDefaultStyleInfos 方法

活字格插件API文档

ISupportStyleInitializeGetDefaultStyleInfos 方法

设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Dictionary<StylePropertyName, Object> GetDefaultStyleInfos(
    ICellInfo cellInfo
)

参数

cellInfo
类型：GrapeCity.Forguncy.CellTypesICellInfo
单元格信息，如可以知道单元格所在页面类型或者是否在表格中等信息。

返回值

类型：Dictionary StylePropertyName, Object
默认样式列表。
示例
C#
复制
public class HyperlinkCellType : CellType, ISupportStyleInitialize
{
    public Dictionary<StylePropertyName, object> GetDefaultStyleInfos(ICellInfo cellInfo)
    {
        var dic = new Dictionary<StylePropertyName, object>();

        dic.Add(StylePropertyName.Foreground, new SolidColorBrush(Colors.Blue));
        dic.Add(StylePropertyName.Underline, true);

        return dic;
    }
}
参见

引用

ISupportStyleInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportUIPermission 接口

主要用于单元格类型的界面权限设置。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISupportUIPermission

ISupportUIPermission 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | UIPermissions | 单元格类型的界面权限设置。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


ISupportUIPermission 属性

ISupportUIPermission 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | UIPermissions | 单元格类型的界面权限设置。
Top
参见

引用

ISupportUIPermission 接口
GrapeCity.Forguncy.CellTypes 命名空间


ISupportUIPermission.UIPermissions 属性

活字格插件API文档

ISupportUIPermissionUIPermissions 属性

单元格类型的界面权限设置。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<UIPermission> UIPermissions { get; set; }

属性值

类型：List UIPermission
参见

引用

ISupportUIPermission 接口
GrapeCity.Forguncy.CellTypes 命名空间


IWindow 接口

内置对话框接口。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IWindow

IWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。
Top
方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。
Top
事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


IWindow 属性

IWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。
Top
参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IWindow.DialogResult 属性

活字格插件API文档

IWindowDialogResult 属性

对话框返回结果。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool? DialogResult { get; }

属性值

类型：Nullable Boolean
参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IWindow 方法

IWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。
Top
参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IWindow.ShowDialog 方法

活字格插件API文档

IWindowShowDialog 方法

打开对话框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool? ShowDialog()

返回值

类型：Nullable Boolean
参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IWindow 事件

IWindow 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。
Top
参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


IWindow.Closed 事件

活字格插件API文档

IWindowClosed 事件

对话框关闭事件。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
event EventHandler Closed

值

类型：SystemEventHandler
参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


ListViewScope 枚举

单元格类型插件或其内部属性所支持的表格使用范围。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum ListViewScope
成员
成员名称 | 值 | 说明
None | 0 | 不支持在表格中使用。
ListViewInPCPage | 1 | 只支持在PC页面的表格中使用。
ListViewInMobilePage | 2 | 只支持在手机页面的表格中使用。
AllListView | 3 | 支持在PC页面和手机页面的表格中使用。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


PageScope 枚举

单元格类型插件或其内部属性所支持的页面使用范围。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum PageScope
成员
成员名称 | 值 | 说明
None | 0 | 所有页面都不支持。
NormalPCPage | 1 | 只支持普通PC页面。
NormalMobilePage | 2 | 只支持普通手机页面。
MasterPCPage | 4 | 只支持PC母版页。
MasterMobilePage | 8 | 只支持手机母版页。
TemplatePCPage | 16 | 支持模板页面。
TemplateMobilePage | 32 | 支持手机模板页面。
AllPCPage | 21 | 支持普通PC页面和PC母版页在内的所有PC页面。
AllMobilePage | 42 | 支持普通手机页面和手机母版页在内的所有手机页面。
AllNormalPage | 3 | 支持普通PC页面和普通手机页面在内的所有普通页面。
AllMasterPage | 12 | 支持PC母版页和手机母版页在内的所有母版页。
AllTemplatePage | 48 | 支持PC模板页和手机模板页在内的所有模板页。
AllPage | 63 | 支持所有类型页面。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit 类

模板组件的状态样式单元。它代表了模板组件在某一种状态下的完整样式信息。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesPartStyleUnit

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class PartStyleUnit : ICloneable

PartStyleUnit 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PartStyleUnit | 初始化 PartStyleUnit 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Background | 背景。
公共属性 | Bold | 字体粗细
公共属性 | BorderBottomString | 下边框。
公共属性 | BorderLeftString | 左边框。
公共属性 | BorderRadiusString | 圆角
公共属性 | BorderRightString | 右边框。
公共属性 | BorderTopString | 上边框。
公共属性 | BoxShadowString | 阴影
公共属性 | CellHorizontalAlignment | 水平
公共属性 | CellVerticalAligment | 垂直
公共属性 | FontColor | 字体颜色。
公共属性 | FrozenlineColor | 冻结线颜色。
公共属性 | InsideHorizontalBorderString | 内部水平边框。
公共属性 | InsideVerticalBorderString | 内部垂直边框。
公共属性 | Italic | 字体倾斜
公共属性 | MarginBottom | 下外边距
公共属性 | MarginLeft | 左外边距
公共属性 | MarginRight | 右外边距
公共属性 | MarginTop | 上外边距
公共属性 | Opacity | 透明度
公共属性 | PaddingBottom | 下内边距
公共属性 | PaddingLeft | 左内边距
公共属性 | PaddingRight | 右内边距
公共属性 | PaddingTop | 上内边距
公共属性 | Underline | 下划线
Top
方法
 | 名称 | 说明
公共方法 | Clone | 克隆模板组件的状态样式单元。
公共方法 | CombineStyle | 将当前状态单元和另一个进行合并。
公共方法 | Equals | 判断两个样式单元是否相等 (重写 ObjectEquals(Object).)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | 获取Hash值，以供比较 (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit 构造函数

初始化 PartStyleUnit 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit()
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit 属性

PartStyleUnit 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Background | 背景。
公共属性 | Bold | 字体粗细
公共属性 | BorderBottomString | 下边框。
公共属性 | BorderLeftString | 左边框。
公共属性 | BorderRadiusString | 圆角
公共属性 | BorderRightString | 右边框。
公共属性 | BorderTopString | 上边框。
公共属性 | BoxShadowString | 阴影
公共属性 | CellHorizontalAlignment | 水平
公共属性 | CellVerticalAligment | 垂直
公共属性 | FontColor | 字体颜色。
公共属性 | FrozenlineColor | 冻结线颜色。
公共属性 | InsideHorizontalBorderString | 内部水平边框。
公共属性 | InsideVerticalBorderString | 内部垂直边框。
公共属性 | Italic | 字体倾斜
公共属性 | MarginBottom | 下外边距
公共属性 | MarginLeft | 左外边距
公共属性 | MarginRight | 右外边距
公共属性 | MarginTop | 上外边距
公共属性 | Opacity | 透明度
公共属性 | PaddingBottom | 下内边距
公共属性 | PaddingLeft | 左内边距
公共属性 | PaddingRight | 右内边距
公共属性 | PaddingTop | 上内边距
公共属性 | Underline | 下划线
Top
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.Background 属性

活字格插件API文档

PartStyleUnitBackground 属性

背景。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Background { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.Bold 属性

活字格插件API文档

PartStyleUnitBold 属性

字体粗细

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool Bold { get; set; }

属性值

类型：Boolean
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.BorderBottomString 属性

活字格插件API文档

PartStyleUnitBorderBottomString 属性

下边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string BorderBottomString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.BorderLeftString 属性

活字格插件API文档

PartStyleUnitBorderLeftString 属性

左边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string BorderLeftString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.BorderRadiusString 属性

活字格插件API文档

PartStyleUnitBorderRadiusString 属性

圆角

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string BorderRadiusString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.BorderRightString 属性

活字格插件API文档

PartStyleUnitBorderRightString 属性

右边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string BorderRightString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.BorderTopString 属性

活字格插件API文档

PartStyleUnitBorderTopString 属性

上边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string BorderTopString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.BoxShadowString 属性

活字格插件API文档

PartStyleUnitBoxShadowString 属性

阴影

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string BoxShadowString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.CellHorizontalAlignment 属性

活字格插件API文档

PartStyleUnitCellHorizontalAlignment 属性

水平

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string CellHorizontalAlignment { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.CellVerticalAligment 属性

活字格插件API文档

PartStyleUnitCellVerticalAligment 属性

垂直

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string CellVerticalAligment { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.FontColor 属性

活字格插件API文档

PartStyleUnitFontColor 属性

字体颜色。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string FontColor { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.FrozenlineColor 属性

活字格插件API文档

PartStyleUnitFrozenlineColor 属性

冻结线颜色。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string FrozenlineColor { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.InsideHorizontalBorderString 属性

活字格插件API文档

PartStyleUnitInsideHorizontalBorderString 属性

内部水平边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string InsideHorizontalBorderString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.InsideVerticalBorderString 属性

活字格插件API文档

PartStyleUnitInsideVerticalBorderString 属性

内部垂直边框。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string InsideVerticalBorderString { get; set; }

属性值

类型：String
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.Italic 属性

活字格插件API文档

PartStyleUnitItalic 属性

字体倾斜

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool Italic { get; set; }

属性值

类型：Boolean
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.MarginBottom 属性

活字格插件API文档

PartStyleUnitMarginBottom 属性

下外边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int MarginBottom { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.MarginLeft 属性

活字格插件API文档

PartStyleUnitMarginLeft 属性

左外边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int MarginLeft { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.MarginRight 属性

活字格插件API文档

PartStyleUnitMarginRight 属性

右外边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int MarginRight { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.MarginTop 属性

活字格插件API文档

PartStyleUnitMarginTop 属性

上外边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int MarginTop { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.Opacity 属性

活字格插件API文档

PartStyleUnitOpacity 属性

透明度

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public double Opacity { get; set; }

属性值

类型：Double
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.PaddingBottom 属性

活字格插件API文档

PartStyleUnitPaddingBottom 属性

下内边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int PaddingBottom { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.PaddingLeft 属性

活字格插件API文档

PartStyleUnitPaddingLeft 属性

左内边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int PaddingLeft { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.PaddingRight 属性

活字格插件API文档

PartStyleUnitPaddingRight 属性

右内边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int PaddingRight { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.PaddingTop 属性

活字格插件API文档

PartStyleUnitPaddingTop 属性

上内边距

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int PaddingTop { get; set; }

属性值

类型：Int32
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.Underline 属性

活字格插件API文档

PartStyleUnitUnderline 属性

下划线

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool Underline { get; set; }

属性值

类型：Boolean
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit 方法

PartStyleUnit 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone | 克隆模板组件的状态样式单元。
公共方法 | CombineStyle | 将当前状态单元和另一个进行合并。
公共方法 | Equals | 判断两个样式单元是否相等 (重写 ObjectEquals(Object).)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | 获取Hash值，以供比较 (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.Clone 方法

活字格插件API文档

PartStyleUnitClone 方法

克隆模板组件的状态样式单元。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Clone()

返回值

类型：Object
克隆后的状态样式单元。

实现

ICloneableClone
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.CombineStyle 方法

活字格插件API文档

PartStyleUnitCombineStyle 方法

将当前状态单元和另一个进行合并。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit CombineStyle(
    PartStyleUnit style
)

参数

style
类型：GrapeCity.Forguncy.CellTypesPartStyleUnit
进行合并的另一个状态单元。

返回值

类型：PartStyleUnit
组合后的状态样式单元。
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.Equals 方法

活字格插件API文档

PartStyleUnitEquals 方法

判断两个样式单元是否相等

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override bool Equals(
    Object obj
)

参数

obj
类型：SystemObject

返回值

类型：Boolean
是否相等。
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


PartStyleUnit.GetHashCode 方法

活字格插件API文档

PartStyleUnitGetHashCode 方法

获取Hash值，以供比较

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override int GetHashCode()

返回值

类型：Int32
Hash值
参见

引用

PartStyleUnit 类
GrapeCity.Forguncy.CellTypes 命名空间


StylePropertyName 枚举

样式列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum StylePropertyName
成员
成员名称 | 值 | 说明
Background | 0 | 背景色。
BorderLeft | 1 | 左边框。
BorderTop | 2 | 上边框。
BorderRight | 3 | 右边框。
BorderBottom | 4 | 下边框。
FontFamily | 5 | 字体。
FontSize | 6 | 字号。
FontStyle | 7 | 字体样式。
FontWeight | 8 | 字体加粗。
Foreground | 9 | 字体颜色。
Formatter | 10 | 格式。
Strikethrough | 11 | 是否有删除线效果。
TextIndent | 12 | 缩进大小。
Underline | 13 | 是否有下划线。
WordWrap | 14 | 是否换行。
HorizontalAlignment | 15 | 水平对齐方式。
VerticalAlignment | 16 | 垂直对齐方式。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


StyleTemplateScope 枚举

指定样式可以生效的范围

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum StyleTemplateScope
成员
成员名称 | 值 | 说明
Listview | 1 | 表格中
NormalCell | 2 | 普通单元格
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission 类

单元格类型子元素的界面权限项。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesSubUIPermission
GrapeCity.Forguncy.CellTypesUIPermission

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class SubUIPermission : ICloneable

SubUIPermission 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SubUIPermission | 初始化 SubUIPermission 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowRoles | 有权限的角色列表。
公共属性 | Children | 子元素权限项集合。
公共属性 | Name | 标识子元素的名称。
Top
方法
 | 名称 | 说明
公共方法 | Clone | 克隆方法。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。
公共方法 | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission 构造函数

初始化 SubUIPermission 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public SubUIPermission()
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission 属性

SubUIPermission 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowRoles | 有权限的角色列表。
公共属性 | Children | 子元素权限项集合。
公共属性 | Name | 标识子元素的名称。
Top
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission.AllowRoles 属性

活字格插件API文档

SubUIPermissionAllowRoles 属性

有权限的角色列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<string> AllowRoles { get; set; }

属性值

类型：List String
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission.Children 属性

活字格插件API文档

SubUIPermissionChildren 属性

子元素权限项集合。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<SubUIPermission> Children { get; set; }

属性值

类型：List SubUIPermission
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission.Name 属性

活字格插件API文档

SubUIPermissionName 属性

标识子元素的名称。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission 方法

SubUIPermission 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone | 克隆方法。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。
公共方法 | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission.Clone 方法

活字格插件API文档

SubUIPermissionClone 方法

克隆方法。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual Object Clone()

返回值

类型：Object

实现

ICloneableClone
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission.ShouldSerializeAllowRoles 方法

活字格插件API文档

SubUIPermissionShouldSerializeAllowRoles 方法

是否需要序列化有权限的角色列表。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool ShouldSerializeAllowRoles()

返回值

类型：Boolean
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SubUIPermission.ShouldSerializeChildren 方法

活字格插件API文档

SubUIPermissionShouldSerializeChildren 方法

是否需要序列化子元素权限项集合。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool ShouldSerializeChildren()

返回值

类型：Boolean
参见

引用

SubUIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


SupportFeatures 枚举

单元格类型的插件支持的特性。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum SupportFeatures
成员
成员名称 | 值 | 说明
None | 0 | 没有特性。
AllowSetTabOrder | 1 | 支持Tab键设置。
AllowSetFormatInNormalCell | 2 | 只支持在普通单元格上设置格式。
AllowSetFormatInListview | 4 | 只支持在表格单元格上设置格式。
ShouldCheckDirtyWhenLeavePage | 8 | 在离开页面检查是否有未保存的数据时，是否检查该单元格类型。
AllowSetFormat | 6 | 支持在所有单元格上设置格式。
All | 7 | 支持Tab键设置及所有单元格上设置格式。
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


SupportStyles 枚举

模板组件所支持的可设置的样式种类。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum SupportStyles
成员
成员名称 | 值 | 说明
BackgroundColor | 1 | 背景色。
BackgroundGradient | 49152 | 背景渐变色。
ForegroundColor | 4 | 前景色。
Border | 8 | 外边框。
InnerBorder | 16 | 内边框。
RoundedCorner | 32 | 圆角。
Shadow | 64 | 阴影。
Padding | 128 | 边距。
HorizontalAlignment | 256 | 水平对齐方式。
VerticalAlignment | 512 | 垂直对齐方式。
Opacity | 1024 | 透明度。
Bold | 2048 | 粗体。
Italic | 4096 | 斜体。
FrozenlineColor | 8192 | 冻结线的颜色。
BackgroundLinearGradient | 16384 | 背景颜色线性渐变。
BackgroundRadialGradient | 32768 | 背景颜色圆形渐变。
Underline | 65536 | underline
Margin | 131072 | margin
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


SupportUsingScopeAttribute 类

单元格类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.CellTypesSupportUsingScopeAttribute

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class SupportUsingScopeAttribute : Attribute

SupportUsingScopeAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SupportUsingScopeAttribute | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | ListViewScope | 表格的使用范围。
公共属性 | PageScope | 页面的使用范围。
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
[SupportUsingScope(PageScope.AllPage, ListViewScope.None)]  /*支持所有页面，不支持在表格中使用。*/
public class BDMapCellType : <see cref="T:GrapeCity.Forguncy.CellTypes.CellType" />
{
    [SupportUsingScope(PageScope.AllPCPage, ListViewScope.None)]  /*只支持所有PC页面，不支持在手机页面或表格中使用。*/
    public bool Distance { get; set; }

    public bool ReadOnly { get; set; }  /*支持所有PC页面和手机页面，不支持在表格中使用。*/
}
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


SupportUsingScopeAttribute 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public SupportUsingScopeAttribute(
    PageScope pageScope,
    ListViewScope listviewScope
)

参数

pageScope
类型：GrapeCity.Forguncy.CellTypesPageScope
插件所支持的页面使用范围。
listviewScope
类型：GrapeCity.Forguncy.CellTypesListViewScope
插件所支持的表格使用范围。
参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


SupportUsingScopeAttribute 属性

SupportUsingScopeAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ListViewScope | 表格的使用范围。
公共属性 | PageScope | 页面的使用范围。
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


SupportUsingScopeAttribute.ListViewScope 属性

活字格插件API文档

SupportUsingScopeAttributeListViewScope 属性

表格的使用范围。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ListViewScope ListViewScope { get; }

属性值

类型：ListViewScope
参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


SupportUsingScopeAttribute.PageScope 属性

活字格插件API文档

SupportUsingScopeAttributePageScope 属性

页面的使用范围。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PageScope PageScope { get; }

属性值

类型：PageScope
参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


SupportUsingScopeAttribute 方法

SupportUsingScopeAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart 类

单元格模板样式的模板组件。它以样式的角度，划分单元格的组成部分，也是设置单元格模板样式的基本单位。一个单元格类型可由一个或多个模板组件组成。每一个部分可单独设置样式。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesTemplatePart

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class TemplatePart

TemplatePart 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TemplatePart | 构造函数。默认支持四种状态：一般状态，鼠标悬停，按下和聚焦，默认支持6种可设置的样式：背景色，背景渐变色，前景色，边框，圆角和阴影。
Top
属性
 | 名称 | 说明
公共属性 | DisableTransition | 禁用动画过渡时间
公共属性 | Name | 模板组件的名字。在一个单元格类型里，每个模板组件的名字应该是唯一的。
公共属性 | SupportStates | 模板组件所支持的状态。
公共属性 | SupportStyles | 模板组件所支持的可设置的样式。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetStateTitle | Internal use
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart 构造函数

构造函数。默认支持四种状态：一般状态，鼠标悬停，按下和聚焦，默认支持6种可设置的样式：背景色，背景渐变色，前景色，边框，圆角和阴影。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TemplatePart()
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart 属性

TemplatePart 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisableTransition | 禁用动画过渡时间
公共属性 | Name | 模板组件的名字。在一个单元格类型里，每个模板组件的名字应该是唯一的。
公共属性 | SupportStates | 模板组件所支持的状态。
公共属性 | SupportStyles | 模板组件所支持的可设置的样式。
Top
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart.DisableTransition 属性

活字格插件API文档

TemplatePartDisableTransition 属性

禁用动画过渡时间

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool DisableTransition { get; set; }

属性值

类型：Boolean
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart.Name 属性

活字格插件API文档

TemplatePartName 属性

模板组件的名字。在一个单元格类型里，每个模板组件的名字应该是唯一的。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart.SupportStates 属性

活字格插件API文档

TemplatePartSupportStates 属性

模板组件所支持的状态。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellStates SupportStates { get; set; }

属性值

类型：CellStates
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart.SupportStyles 属性

活字格插件API文档

TemplatePartSupportStyles 属性

模板组件所支持的可设置的样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public SupportStyles SupportStyles { get; set; }

属性值

类型：SupportStyles
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart 方法

TemplatePart 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetStateTitle | Internal use
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePart.GetStateTitle 方法

活字格插件API文档

TemplatePartGetStateTitle 方法

Internal use

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string GetStateTitle(
    CellStates states
)

参数

states
类型：GrapeCity.Forguncy.CellTypesCellStates

返回值

类型：String
参见

引用

TemplatePart 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle 类

模板组件的样式。保存了该模板组件在各自状态下的具体样式信息。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesTemplatePartStyle

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class TemplatePartStyle : ICloneable

TemplatePartStyle 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TemplatePartStyle | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | ActiveStyle | 在鼠标按下或者触摸按下的状态下，模板组件的样式信息。
公共属性 | DisableStyle | 在禁用状态下，模板组件的样式信息。
公共属性 | FocusStyle | 在获取焦点状态下，模板组件的样式信息。
公共属性 | HoverStyle | 在鼠标悬停状态下，模板组件的样式信息。
公共属性 | NormalStyle | 在一般状态下，模板组件的样式信息。
公共属性 | SelectedStyle | 在选中状态下，模板组件的样式信息。
公共属性 | Transition | 切换状态时，样式变化的过渡动画时长。
Top
方法
 | 名称 | 说明
公共方法 | Clone | 克隆模板组件的样式。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TemplatePartStyle()
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle 属性

TemplatePartStyle 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ActiveStyle | 在鼠标按下或者触摸按下的状态下，模板组件的样式信息。
公共属性 | DisableStyle | 在禁用状态下，模板组件的样式信息。
公共属性 | FocusStyle | 在获取焦点状态下，模板组件的样式信息。
公共属性 | HoverStyle | 在鼠标悬停状态下，模板组件的样式信息。
公共属性 | NormalStyle | 在一般状态下，模板组件的样式信息。
公共属性 | SelectedStyle | 在选中状态下，模板组件的样式信息。
公共属性 | Transition | 切换状态时，样式变化的过渡动画时长。
Top
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.ActiveStyle 属性

活字格插件API文档

TemplatePartStyleActiveStyle 属性

在鼠标按下或者触摸按下的状态下，模板组件的样式信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit ActiveStyle { get; set; }

属性值

类型：PartStyleUnit
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.DisableStyle 属性

活字格插件API文档

TemplatePartStyleDisableStyle 属性

在禁用状态下，模板组件的样式信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit DisableStyle { get; set; }

属性值

类型：PartStyleUnit
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.FocusStyle 属性

活字格插件API文档

TemplatePartStyleFocusStyle 属性

在获取焦点状态下，模板组件的样式信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit FocusStyle { get; set; }

属性值

类型：PartStyleUnit
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.HoverStyle 属性

活字格插件API文档

TemplatePartStyleHoverStyle 属性

在鼠标悬停状态下，模板组件的样式信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit HoverStyle { get; set; }

属性值

类型：PartStyleUnit
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.NormalStyle 属性

活字格插件API文档

TemplatePartStyleNormalStyle 属性

在一般状态下，模板组件的样式信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit NormalStyle { get; set; }

属性值

类型：PartStyleUnit
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.SelectedStyle 属性

活字格插件API文档

TemplatePartStyleSelectedStyle 属性

在选中状态下，模板组件的样式信息。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PartStyleUnit SelectedStyle { get; set; }

属性值

类型：PartStyleUnit
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.Transition 属性

活字格插件API文档

TemplatePartStyleTransition 属性

切换状态时，样式变化的过渡动画时长。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Transition { get; set; }

属性值

类型：String
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle 方法

TemplatePartStyle 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone | 克隆模板组件的样式。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


TemplatePartStyle.Clone 方法

活字格插件API文档

TemplatePartStyleClone 方法

克隆模板组件的样式。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Clone()

返回值

类型：Object
克隆后的模板组件样式。

实现

ICloneableClone
参见

引用

TemplatePartStyle 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission 类

单元格类型的界面权限项。
继承层次
SystemObject
GrapeCity.Forguncy.CellTypesSubUIPermission
GrapeCity.Forguncy.CellTypesUIPermission

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class UIPermission : SubUIPermission

UIPermission 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | UIPermission | 初始化 UIPermission 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowRoles | 有权限的角色列表。 (继承自 SubUIPermission。)
公共属性 | Category | 类目。
公共属性 | Children | 子元素权限项集合。 (继承自 SubUIPermission。)
公共属性 | Enabled | 是否启用权限设置。
公共属性 | Ignore | 隐藏当前的权限设置，如菜单只有菜单项的权限设置，此时可隐藏菜单本身的权限设置。
公共属性 | Name | 标识子元素的名称。 (继承自 SubUIPermission。)
公共属性 | Scope | 权限的适用范围。
Top
方法
 | 名称 | 说明
公共方法 | Clone | 克隆方法。 (重写 SubUIPermissionClone.)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。 (继承自 SubUIPermission。)
公共方法 | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。 (继承自 SubUIPermission。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


UIPermission 构造函数

初始化 UIPermission 类的一个新实例

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public UIPermission()
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission 属性

UIPermission 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowRoles | 有权限的角色列表。 (继承自 SubUIPermission。)
公共属性 | Category | 类目。
公共属性 | Children | 子元素权限项集合。 (继承自 SubUIPermission。)
公共属性 | Enabled | 是否启用权限设置。
公共属性 | Ignore | 隐藏当前的权限设置，如菜单只有菜单项的权限设置，此时可隐藏菜单本身的权限设置。
公共属性 | Name | 标识子元素的名称。 (继承自 SubUIPermission。)
公共属性 | Scope | 权限的适用范围。
Top
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission.Category 属性

活字格插件API文档

UIPermissionCategory 属性

类目。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Category { get; set; }

属性值

类型：String
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission.Enabled 属性

活字格插件API文档

UIPermissionEnabled 属性

是否启用权限设置。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool Enabled { get; set; }

属性值

类型：Boolean
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission.Ignore 属性

活字格插件API文档

UIPermissionIgnore 属性

隐藏当前的权限设置，如菜单只有菜单项的权限设置，此时可隐藏菜单本身的权限设置。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool Ignore { get; set; }

属性值

类型：Boolean
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission.Scope 属性

活字格插件API文档

UIPermissionScope 属性

权限的适用范围。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public UIPermissionScope Scope { get; set; }

属性值

类型：UIPermissionScope
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission 方法

UIPermission 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone | 克隆方法。 (重写 SubUIPermissionClone.)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ShouldSerializeAllowRoles | 是否需要序列化有权限的角色列表。 (继承自 SubUIPermission。)
公共方法 | ShouldSerializeChildren | 是否需要序列化子元素权限项集合。 (继承自 SubUIPermission。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermission.Clone 方法

活字格插件API文档

UIPermissionClone 方法

克隆方法。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override Object Clone()

返回值

类型：Object

实现

ICloneableClone
参见

引用

UIPermission 类
GrapeCity.Forguncy.CellTypes 命名空间


UIPermissionScope 枚举

界面元素的权限适用范围。

命名空间： GrapeCity.Forguncy.CellTypes
程序集： GrapeCity.Forguncy.CellTypes (在 GrapeCity.Forguncy.CellTypes.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum UIPermissionScope
成员
成员名称 | 值 | 说明
None | 0 | 无
Visible | 1 | 可见性权限
Enable | 2 | 可用性权限
Editable | 4 | 可编辑权限
参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


GrapeCity.Forguncy.Commands 命名空间

类
 | 类 | 说明
 | Command | 命令类型插件的父类定义。
公共类 | CommandDesigner | 命令设计器。
公共类 | CommandDesignerT | 命令编辑器。
 | CommandSupportUsingScopeAttribute | 命令类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
公共类 | CustomCommandObject |
公共类 | CustomCommandObjectAttribute | 通过标注此属性给单元格或命令声明自定义命令 被标注的属性应该是 object类型
公共类 | ExecuteResult | 命令的执行结果。
公共类 | ExportPageSettingBase | 导出页面相关设置。
公共类 | ExportPageToExcelSetting | 导出页面到Excel相关设置。
公共类 | ExportPageToHtmlSetting | 导出页面到HTML相关设置。
公共类 | ExportPageToPdfSetting | 导出页面到PDF相关设置。
 | ResultToPropertyAttribute | 声明属性的值表示命令执行后存入变量的变量名称。
接口
 | 接口 | 说明
公共接口 | IBuilderCommandContext | 命令编辑上下文信息。
公共接口 | ICommandCellInfo | 命令单元格信息。详情参照。
 | ICommandChecker | 如果执行命令需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
 | ICommandEditor | 插件命令数据编辑器。
 | ICommandExecutableInServerSide | 具有可独立执行能力的命令需要实现这个接口。 用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。
 | ICommandExecutableInServerSideAsync | 具有可独立执行能力的命令需要实现这个接口。 用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。
公共接口 | IContainSubCommands | 迭代当前命令的子命令，用于查找替换。
公共接口 | IExportHelper | 提供导出相关的方法。
公共接口 | ILog | 提供打印日志的方法。
 | IQueryConditionWindow | 活字格内置的设置查询条件的对话窗口。 注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现IReferenceFormula接口。
公共接口 | IServerCommandExecuteContext | 当在服务器端执行实现了ICommandExecutableInServerSide接口的命令时，从服务器端传递的上下文信息。
公共接口 | ISubListCommand | 如果命令包含子命令(例如循环命令)，则需要实现该接口。
公共接口 | IUpdateDatabaseCommand | 提供更新数据库的方法。
公共接口 | IWindow | 内置对话框接口。
枚举
 | 枚举 | 说明
公共枚举 | CommandPageScope | 命令类型插件或其内部属性所支持的页面使用范围。
 | CommandScope | 活字格打开编辑命令窗口时会根据使用范围的不同显示不同的命令集合，该Flags枚举列出了以下几种范围。
公共枚举 | LogLevel | 日志详细程度。
公共枚举 | NullFormulaValueQueryPolicy |
公共枚举 | ProcessControl | 流程控制信息。


Command 类

命令类型插件的父类定义。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsCommand

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class Command : ICloneable

Command 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | Command | 初始化 Command 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Comments | 命令的注释。
公共属性 | Disabled | 命令是否被禁用。
公共属性 | DisplayName | Internal use
Top
方法
 | 名称 | 说明
公共方法 | Clone | 克隆命令插件。
公共方法 | ContainSubCommands | 指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCommandScope | 指定命令插件的使用范围。
 | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | InitDefaultPropertyValues | 初始化默认属性值。
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | ToString | 命令插件的显示名称，默认与插件定义的类名一样。 (重写 ObjectToString.)
公共方法 | WillNavigateOrReload | 该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
Top
示例
C#
复制
public class MyPluginCommand : Command
{
    ...
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


Command 构造函数

初始化 Command 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected Command()
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command 属性

Command 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Comments | 命令的注释。
公共属性 | Disabled | 命令是否被禁用。
公共属性 | DisplayName | Internal use
Top
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.Comments 属性

活字格插件API文档

CommandComments 属性

命令的注释。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Comments { get; set; }

属性值

类型：String
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.Disabled 属性

活字格插件API文档

CommandDisabled 属性

命令是否被禁用。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool Disabled { get; set; }

属性值

类型：Boolean
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.DisplayName 属性

活字格插件API文档

CommandDisplayName 属性

Internal use

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string DisplayName { get; }

属性值

类型：String
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command 方法

Command 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone | 克隆命令插件。
公共方法 | ContainSubCommands | 指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCommandScope | 指定命令插件的使用范围。
 | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
 | InitDefaultPropertyValues | 初始化默认属性值。
受保护的方法 | MemberwiseClone | (继承自 Object。)
 | ToString | 命令插件的显示名称，默认与插件定义的类名一样。 (重写 ObjectToString.)
公共方法 | WillNavigateOrReload | 该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
Top
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.Clone 方法

活字格插件API文档

CommandClone 方法

克隆命令插件。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual Command Clone()

返回值

类型：Command
返回克隆后的命令。
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.ContainSubCommands 方法

活字格插件API文档

CommandContainSubCommands 方法

指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool ContainSubCommands()

返回值

类型：Boolean
返回true表示包含子命令，否则不包含。
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.GetCommandScope 方法

活字格插件API文档

CommandGetCommandScope 方法

指定命令插件的使用范围。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual CommandScope GetCommandScope()

返回值

类型：CommandScope
返回命令的使用范围。
示例
示例请参照CommandScope
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.GetDesignerPropertyVisible 方法

活字格插件API文档

CommandGetDesignerPropertyVisible 方法

如果需要动态改变属性编辑器的可见性，可以重写该函数。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool GetDesignerPropertyVisible(
    string propertyName,
    CommandScope commandScope
)

参数

propertyName
类型：SystemString
属性名
commandScope
类型：GrapeCity.Forguncy.CommandsCommandScope
CommandScope

返回值

类型：Boolean
返回True表示属性编辑器可见，否则不可见。
示例
C#
复制
public class MenuCellType: CellType
{
    public Orientation Orientation { get; set; }

    public ExpandStyle DefaultExpandStyle { get; set; }

    public override bool GetDesignerPropertyVisible(string propertyName)
    {
        if (propertyName == "DefaultExpandStyle")
        {
            if (Orientation == MenuOrientation.Horizontal)  //如果是水平方向的菜单隐藏默认展开方式。
            {
                return false;
            }
            return true;
        }
        return base.GetDesignerPropertyVisible(propertyName);
    }
}
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.InitDefaultPropertyValues 方法

活字格插件API文档

CommandInitDefaultPropertyValues 方法

初始化默认属性值。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual void InitDefaultPropertyValues()
示例
C#
复制
public class CallStoredProcedureCommand : Command
{
    public List<string> AllowAcessRoleList { get; set; } = new List<string>();

    public override void InitDefaultPropertyValues()
    {
        AllowAcessRoleList = new List<string>() { DefaultRoleManager.FGC_LoginUser };
    }
}
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.ToString 方法

活字格插件API文档

CommandToString 方法

命令插件的显示名称，默认与插件定义的类名一样。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string ToString()

返回值

类型：String
返回在命令列表中该命令插件的显示名称。
示例
C#
复制
public class ShowMessageBoxCommand : Command
{
    public override string ToString()
    {
        return "消息框命令";
    }
}
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


Command.WillNavigateOrReload 方法

活字格插件API文档

CommandWillNavigateOrReload 方法

该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool WillNavigateOrReload()

返回值

类型：Boolean
返回true表示该命令插件后续的命令会停止执行，返回false表示该命令插件执行不会影响后续命令的执行。
参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner 类

命令设计器。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsCommandDesigner
GrapeCity.Forguncy.CommandsCommandDesignerT

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CommandDesigner

CommandDesigner 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CommandDesigner | 初始化 CommandDesigner 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Command | 编辑器对应的命令。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCommandEditor | 返回命令插件对应的编辑器。
 | GetCommandEditor(IBuilderCommandContext) | 返回命令插件对应的编辑器。
 | GetEditorSetting | 返回插件命令内部属性对应的编辑器。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


CommandDesigner 构造函数

初始化 CommandDesigner 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CommandDesigner()
参见

引用

CommandDesigner 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner 属性

CommandDesigner 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Command | 编辑器对应的命令。
Top
参见

引用

CommandDesigner 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner.Command 属性

活字格插件API文档

CommandDesignerCommand 属性

编辑器对应的命令。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Command Command { get; set; }

属性值

类型：Command
参见

引用

CommandDesigner 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner 方法

CommandDesigner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCommandEditor | 返回命令插件对应的编辑器。
 | GetCommandEditor(IBuilderCommandContext) | 返回命令插件对应的编辑器。
 | GetEditorSetting | 返回插件命令内部属性对应的编辑器。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CommandDesigner 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner.GetCommandEditor 方法

活字格插件API文档

CommandDesignerGetCommandEditor 方法

重载列表
名称 | 说明
GetCommandEditor | 返回命令插件对应的编辑器。
GetCommandEditor(IBuilderCommandContext) | 返回命令插件对应的编辑器。
Top
参见

引用

CommandDesigner 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner.GetCommandEditor 方法

活字格插件API文档

CommandDesignerGetCommandEditor 方法

返回命令插件对应的编辑器。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual ICommandEditor GetCommandEditor()

返回值

类型：ICommandEditor
返回命令对应的编辑器。
示例

UserControl和自定义插件弹出消息框命令定义如下：

C#
复制
 public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
 {
     public ShowMessageCommandEditor()
     {
         InitializeComponent();
     }
     public Command Command
     {
         get
         {
             return new ShowMessageBoxCommand() { Message = messageTextBox.Text };
             //messageTextBox is the name of TextBox in UserControl.
         }
         set
         {
             ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
             if (command != null)
             {
                 messageTextBox.Text = command.Message;
             }
         }
     }

     public bool Validate()
     {
         return true;
     }
 }
public class ShowMessageCommandDesigner : CommandDesigner<ShowMessageBoxCommand>, ICommandChecker
{

    public override ICommandEditor GetCommandEditor()
    {
        return new ShowMessageCommandEditor();
    }
}

[Designer("ShowMessageBoxCommand.ShowMessageCommandDesigner, ShowMessageBoxCommand")]
public class ShowMessageBoxCommand : Command
{

    public string Message { get; set; }

}
参见

引用

CommandDesigner 类
GetCommandEditor 重载
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner.GetCommandEditor 方法 (IBuilderCommandContext)

活字格插件API文档

CommandDesignerGetCommandEditor 方法 (IBuilderCommandContext)

返回命令插件对应的编辑器。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual ICommandEditor GetCommandEditor(
    IBuilderCommandContext context
)

参数

context
类型：GrapeCity.Forguncy.CommandsIBuilderCommandContext

返回值

类型：ICommandEditor
返回命令对应的编辑器。
示例

UserControl和自定义插件弹出消息框命令定义如下：

C#
复制
public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
{
    public ShowMessageCommandEditor()
    {
        InitializeComponent();
    }
    public Command Command
    {
        get
        {
            return new ShowMessageBoxCommand() { Message = messageTextBox.Text };
            //messageTextBox is the name of TextBox in UserControl.
        }
        set
        {
            ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
            if (command != null)
            {
                messageTextBox.Text = command.Message;
            }
        }
    }

    public bool Validate()
    {
        return true;
    }
}
public class ShowMessageCommandDesigner : CommandDesigner<ShowMessageBoxCommand>, ICommandChecker
{

    public override ICommandEditor GetCommandEditor(IBuilderCommandContext context)
    {
        return new ShowMessageCommandEditor();
    }
}

[Designer("ShowMessageBoxCommand.ShowMessageCommandDesigner, ShowMessageBoxCommand")]
public class ShowMessageBoxCommand : Command
{

    public string Message { get; set; }

}
参见

引用

CommandDesigner 类
GetCommandEditor 重载
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner.GetEditorSetting 方法

活字格插件API文档

CommandDesignerGetEditorSetting 方法

返回插件命令内部属性对应的编辑器。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual EditorSetting GetEditorSetting(
    PropertyDescriptor property,
    IBuilderCommandContext builderContext
)

参数

property
类型：System.ComponentModelPropertyDescriptor
命令内部属性
builderContext
类型：GrapeCity.Forguncy.CommandsIBuilderCommandContext
命令编辑上下文信息。

返回值

类型：EditorSetting
返回插件命令内部属性对应的编辑器。
示例
C#
复制
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>;
{
    public string TableName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if (property.Name == "TableName")
        {
            return new ComboEditorSetting(builderContext.EnumAllTableInfos().Where(t => t.WorkflowInfo != null && t.WorkflowInfo.IsEnabled).Select(t => t.TableName));
        }
    }
}
参见

引用

CommandDesigner 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner(T) 类

活字格插件API文档

CommandDesignerT 类

命令编辑器。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsCommandDesigner
GrapeCity.Forguncy.CommandsCommandDesignerT

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CommandDesigner<T> : CommandDesigner
where T : Command

类型参数

T

CommandDesignerT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CommandDesignerT | 初始化 CommandDesignerT 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Command | 编辑器对应的命令。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCommandEditor | 返回命令插件对应的编辑器。 (继承自 CommandDesigner。)
 | GetCommandEditor(IBuilderCommandContext) | 返回命令插件对应的编辑器。 (继承自 CommandDesigner。)
 | GetEditorSetting | 返回插件命令内部属性对应的编辑器。 (继承自 CommandDesigner。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


CommandDesigner(T) 构造函数

活字格插件API文档

CommandDesignerT 构造函数

初始化 CommandDesignerT 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CommandDesigner()
参见

引用

CommandDesignerT 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner(T) 属性

活字格插件API文档

CommandDesignerT 属性

CommandDesignerT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Command | 编辑器对应的命令。
Top
参见

引用

CommandDesignerT 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner(T).Command 属性

活字格插件API文档

CommandDesignerTCommand 属性

编辑器对应的命令。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public T Command { get; }

属性值

类型：T
参见

引用

CommandDesignerT 类
GrapeCity.Forguncy.Commands 命名空间


CommandDesigner(T) 方法

活字格插件API文档

CommandDesignerT 方法

CommandDesignerT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetCommandEditor | 返回命令插件对应的编辑器。 (继承自 CommandDesigner。)
 | GetCommandEditor(IBuilderCommandContext) | 返回命令插件对应的编辑器。 (继承自 CommandDesigner。)
 | GetEditorSetting | 返回插件命令内部属性对应的编辑器。 (继承自 CommandDesigner。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CommandDesignerT 类
GrapeCity.Forguncy.Commands 命名空间


CommandPageScope 枚举

命令类型插件或其内部属性所支持的页面使用范围。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum CommandPageScope
成员
成员名称 | 值 | 说明
None | 0 | 所有页面都不支持。
NormalPCPage | 1 | 只支持普通PC页面。
NormalMobilePage | 2 | 只支持普通手机页面。
MasterPCPage | 4 | 只支持PC母版页。
MasterMobilePage | 8 | 只支持手机母版页。
TemplatePCPage | 16 | 支持模板页面。
TemplateMobilePage | 32 | 支持手机模板页面。
AllPCPage | 21 | 支持普通PC页面和PC母版页在内的所有PC页面。
AllMobilePage | 42 | 支持普通手机页面和手机母版页在内的所有手机页面。
AllNormalPage | 3 | 支持普通PC页面和普通手机页面在内的所有普通页面。
AllMasterPage | 12 | 支持PC母版页和手机母版页在内的所有母版页。
AllTemplatePage | 48 | 支持PC模板页和手机模板页在内的所有模板页。
AllPage | 63 | 支持所有类型页面。
参见

引用

GrapeCity.Forguncy.Commands 命名空间


CommandScope 枚举

活字格打开编辑命令窗口时会根据使用范围的不同显示不同的命令集合，该Flags枚举列出了以下几种范围。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[FlagsAttribute]
public enum CommandScope
成员
成员名称 | 值 | 说明
Cell | 1 | 普通单元格中。
ListView | 2 | 表格中的单元格中。
PageLoad | 4 | 页面加载中。
Workflow | 8 | 工作流中。
Notification | 16 | 通知用命令。
ShareCommand | 32 | 模板命令
ServerSide | 64 | 服务器命令
TaskSchedule | 128 | 计划任务
ValueChangedCommandInListview | 256 | 表格中的值变更命令
ExecutableInServer | 192 | 可以在服务端执行的命令
All | 511 | 所有集合。
NoneNotification | 495 | 非通知类。
ClientSide | 295 | 客户端命令
示例
C#
复制
public class DeleteRecordCommand : Command
{
    public override CommandScope GetCommandScope()
    {
        return CommandScope.ListView;
    }
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


CommandSupportUsingScopeAttribute 类

命令类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.CommandsCommandSupportUsingScopeAttribute

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CommandSupportUsingScopeAttribute : Attribute

CommandSupportUsingScopeAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CommandSupportUsingScopeAttribute | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | PageScope | 页面的使用范围。
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
[CommandSupportUsingScopeAttribute(PageScope.NormalPCPage)]  /*支持普通PC页面。*/
public class MyCommand : <see cref="T:GrapeCity.Forguncy.Commands.Command" />
{
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


CommandSupportUsingScopeAttribute 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CommandSupportUsingScopeAttribute(
    CommandPageScope pageScope
)

参数

pageScope
类型：GrapeCity.Forguncy.CommandsCommandPageScope
插件所支持的页面使用范围。
参见

引用

CommandSupportUsingScopeAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CommandSupportUsingScopeAttribute 属性

CommandSupportUsingScopeAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PageScope | 页面的使用范围。
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

CommandSupportUsingScopeAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CommandSupportUsingScopeAttribute.PageScope 属性

活字格插件API文档

CommandSupportUsingScopeAttributePageScope 属性

页面的使用范围。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CommandPageScope PageScope { get; }

属性值

类型：CommandPageScope
参见

引用

CommandSupportUsingScopeAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CommandSupportUsingScopeAttribute 方法

CommandSupportUsingScopeAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CommandSupportUsingScopeAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObject 类

继承层次
SystemObject
GrapeCity.Forguncy.CommandsCustomCommandObject

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CustomCommandObject : ICloneable

CustomCommandObject 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CustomCommandObject | 初始化 CustomCommandObject 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Commands |
公共属性 | ParamProperties |
Top
方法
 | 名称 | 说明
公共方法 | Clone |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


CustomCommandObject 构造函数

初始化 CustomCommandObject 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CustomCommandObject()
参见

引用

CustomCommandObject 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObject 属性

CustomCommandObject 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Commands |
公共属性 | ParamProperties |
Top
参见

引用

CustomCommandObject 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObject.Commands 属性

活字格插件API文档

CustomCommandObjectCommands 属性

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<Command> Commands { get; set; }

属性值

类型：List Command
参见

引用

CustomCommandObject 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObject.ParamProperties 属性

活字格插件API文档

CustomCommandObjectParamProperties 属性

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Dictionary<string, string> ParamProperties { get; set; }

属性值

类型：Dictionary String, String
参见

引用

CustomCommandObject 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObject 方法

CustomCommandObject 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Clone |
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CustomCommandObject 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObject.Clone 方法

活字格插件API文档

CustomCommandObjectClone 方法

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Clone()

返回值

类型：Object

实现

ICloneableClone
参见

引用

CustomCommandObject 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObjectAttribute 类

通过标注此属性给单元格或命令声明自定义命令 被标注的属性应该是 object类型
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginHyperlinkEdtiorPropertyAttribute
GrapeCity.Forguncy.CommandsCustomCommandObjectAttribute

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CustomCommandObjectAttribute : HyperlinkEdtiorPropertyAttribute

CustomCommandObjectAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CustomCommandObjectAttribute | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | InitParamProperties | 如果有上下文参数，可以通过此属性声明，如果有多个上下文参数，可用用“|”分隔
公共属性 | InitParamValues | 指定上下文参数的引用值，通常为中文，如果有多个上下文参数，可用用“|”分隔
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetParameters | 此函数的默认实现是返回InitParamProperties，InitParamValues属性通过“|”拆分后生成的字典，可以通过重写此函数生成动态的上下文参数
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


CustomCommandObjectAttribute 构造函数

构造函数

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CustomCommandObjectAttribute()
参见

引用

CustomCommandObjectAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObjectAttribute 属性

CustomCommandObjectAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | InitParamProperties | 如果有上下文参数，可以通过此属性声明，如果有多个上下文参数，可用用“|”分隔
公共属性 | InitParamValues | 指定上下文参数的引用值，通常为中文，如果有多个上下文参数，可用用“|”分隔
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

CustomCommandObjectAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObjectAttribute.InitParamProperties 属性

活字格插件API文档

CustomCommandObjectAttributeInitParamProperties 属性

如果有上下文参数，可以通过此属性声明，如果有多个上下文参数，可用用“|”分隔

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string InitParamProperties { get; set; }

属性值

类型：String
参见

引用

CustomCommandObjectAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObjectAttribute.InitParamValues 属性

活字格插件API文档

CustomCommandObjectAttributeInitParamValues 属性

指定上下文参数的引用值，通常为中文，如果有多个上下文参数，可用用“|”分隔

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string InitParamValues { get; set; }

属性值

类型：String
参见

引用

CustomCommandObjectAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObjectAttribute 方法

CustomCommandObjectAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetParameters | 此函数的默认实现是返回InitParamProperties，InitParamValues属性通过“|”拆分后生成的字典，可以通过重写此函数生成动态的上下文参数
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CustomCommandObjectAttribute 类
GrapeCity.Forguncy.Commands 命名空间


CustomCommandObjectAttribute.GetParameters 方法

活字格插件API文档

CustomCommandObjectAttributeGetParameters 方法

此函数的默认实现是返回InitParamProperties，InitParamValues属性通过“|”拆分后生成的字典，可以通过重写此函数生成动态的上下文参数

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual Dictionary<string, string> GetParameters()

返回值

类型：Dictionary String, String
上下文参数字典
参见

引用

CustomCommandObjectAttribute 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult 类

命令的执行结果。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsExecuteResult

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ExecuteResult

ExecuteResult 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExecuteResult | 初始化 ExecuteResult 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowWriteResultToResponse | 是否允许将命令执行结果写入响应信息。
公共属性 | ErrCode | 返回码。
公共属性 | Log | 服务端命令的执行日志。
公共属性 | Message | 返回信息。
公共属性 | ProcessControl | 执行该命令后的流程控制信息。
公共属性 | ReturnValues | 服务端命令的自定义返回值
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ExecuteResult 构造函数

初始化 ExecuteResult 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ExecuteResult()
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult 属性

ExecuteResult 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowWriteResultToResponse | 是否允许将命令执行结果写入响应信息。
公共属性 | ErrCode | 返回码。
公共属性 | Log | 服务端命令的执行日志。
公共属性 | Message | 返回信息。
公共属性 | ProcessControl | 执行该命令后的流程控制信息。
公共属性 | ReturnValues | 服务端命令的自定义返回值
Top
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult.AllowWriteResultToResponse 属性

活字格插件API文档

ExecuteResultAllowWriteResultToResponse 属性

是否允许将命令执行结果写入响应信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AllowWriteResultToResponse { get; set; }

属性值

类型：Boolean
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult.ErrCode 属性

活字格插件API文档

ExecuteResultErrCode 属性

返回码。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int ErrCode { get; set; }

属性值

类型：Int32
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult.Log 属性

活字格插件API文档

ExecuteResultLog 属性

服务端命令的执行日志。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Log { get; set; }

属性值

类型：String
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult.Message 属性

活字格插件API文档

ExecuteResultMessage 属性

返回信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Message { get; set; }

属性值

类型：String
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult.ProcessControl 属性

活字格插件API文档

ExecuteResultProcessControl 属性

执行该命令后的流程控制信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ProcessControl ProcessControl { get; set; }

属性值

类型：ProcessControl
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult.ReturnValues 属性

活字格插件API文档

ExecuteResultReturnValues 属性

服务端命令的自定义返回值

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Dictionary<string, Object> ReturnValues { get; }

属性值

类型：Dictionary String, Object
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExecuteResult 方法

ExecuteResult 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ExecuteResult 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageSettingBase 类

导出页面相关设置。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsExportPageSettingBase
GrapeCity.Forguncy.CommandsExportPageToExcelSetting
GrapeCity.Forguncy.CommandsExportPageToHtmlSetting
GrapeCity.Forguncy.CommandsExportPageToPdfSetting

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ExportPageSettingBase

ExportPageSettingBase 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExportPageSettingBase | 初始化 ExportPageSettingBase 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。
公共属性 | PageName | 导出页面的名称。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ExportPageSettingBase 构造函数

初始化 ExportPageSettingBase 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ExportPageSettingBase()
参见

引用

ExportPageSettingBase 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageSettingBase 属性

ExportPageSettingBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。
公共属性 | PageName | 导出页面的名称。
Top
参见

引用

ExportPageSettingBase 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageSettingBase.CellValueInfos 属性

活字格插件API文档

ExportPageSettingBaseCellValueInfos 属性

导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Dictionary<string, Object> CellValueInfos { get; set; }

属性值

类型：Dictionary String, Object
参见

引用

ExportPageSettingBase 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageSettingBase.ListViewCurrentRowInfos 属性

活字格插件API文档

ExportPageSettingBaseListViewCurrentRowInfos 属性

导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Dictionary<string, Object> ListViewCurrentRowInfos { get; set; }

属性值

类型：Dictionary String, Object
参见

引用

ExportPageSettingBase 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageSettingBase.PageName 属性

活字格插件API文档

ExportPageSettingBasePageName 属性

导出页面的名称。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string PageName { get; set; }

属性值

类型：String
参见

引用

ExportPageSettingBase 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageSettingBase 方法

ExportPageSettingBase 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ExportPageSettingBase 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToExcelSetting 类

导出页面到Excel相关设置。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsExportPageSettingBase
GrapeCity.Forguncy.CommandsExportPageToExcelSetting

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ExportPageToExcelSetting : ExportPageSettingBase

ExportPageToExcelSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExportPageToExcelSetting | 初始化 ExportPageToExcelSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (继承自 ExportPageSettingBase。)
公共属性 | ExportFormula | 是否导出formula。
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (继承自 ExportPageSettingBase。)
公共属性 | MultiSheetModel | 是否导出到多个工作表。
公共属性 | PageName | 导出页面的名称。 (继承自 ExportPageSettingBase。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ExportPageToExcelSetting 构造函数

初始化 ExportPageToExcelSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ExportPageToExcelSetting()
参见

引用

ExportPageToExcelSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToExcelSetting 属性

ExportPageToExcelSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (继承自 ExportPageSettingBase。)
公共属性 | ExportFormula | 是否导出formula。
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (继承自 ExportPageSettingBase。)
公共属性 | MultiSheetModel | 是否导出到多个工作表。
公共属性 | PageName | 导出页面的名称。 (继承自 ExportPageSettingBase。)
Top
参见

引用

ExportPageToExcelSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToExcelSetting.ExportFormula 属性

活字格插件API文档

ExportPageToExcelSettingExportFormula 属性

是否导出formula。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool ExportFormula { get; set; }

属性值

类型：Boolean
参见

引用

ExportPageToExcelSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToExcelSetting.MultiSheetModel 属性

活字格插件API文档

ExportPageToExcelSettingMultiSheetModel 属性

是否导出到多个工作表。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool MultiSheetModel { get; set; }

属性值

类型：Boolean
参见

引用

ExportPageToExcelSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToExcelSetting 方法

ExportPageToExcelSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ExportPageToExcelSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToHtmlSetting 类

导出页面到HTML相关设置。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsExportPageSettingBase
GrapeCity.Forguncy.CommandsExportPageToHtmlSetting

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ExportPageToHtmlSetting : ExportPageSettingBase

ExportPageToHtmlSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExportPageToHtmlSetting | 初始化 ExportPageToHtmlSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (继承自 ExportPageSettingBase。)
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (继承自 ExportPageSettingBase。)
公共属性 | PageName | 导出页面的名称。 (继承自 ExportPageSettingBase。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ExportPageToHtmlSetting 构造函数

初始化 ExportPageToHtmlSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ExportPageToHtmlSetting()
参见

引用

ExportPageToHtmlSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToHtmlSetting 属性

ExportPageToHtmlSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (继承自 ExportPageSettingBase。)
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (继承自 ExportPageSettingBase。)
公共属性 | PageName | 导出页面的名称。 (继承自 ExportPageSettingBase。)
Top
参见

引用

ExportPageToHtmlSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToHtmlSetting 方法

ExportPageToHtmlSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ExportPageToHtmlSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToPdfSetting 类

导出页面到PDF相关设置。
继承层次
SystemObject
GrapeCity.Forguncy.CommandsExportPageSettingBase
GrapeCity.Forguncy.CommandsExportPageToPdfSetting

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ExportPageToPdfSetting : ExportPageSettingBase

ExportPageToPdfSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ExportPageToPdfSetting | 初始化 ExportPageToPdfSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AutoFitRowHeight | 文字内容过多时，是否自动调整行高以确保显示所有文字。
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (继承自 ExportPageSettingBase。)
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (继承自 ExportPageSettingBase。)
公共属性 | PageName | 导出页面的名称。 (继承自 ExportPageSettingBase。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ExportPageToPdfSetting 构造函数

初始化 ExportPageToPdfSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ExportPageToPdfSetting()
参见

引用

ExportPageToPdfSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToPdfSetting 属性

ExportPageToPdfSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AutoFitRowHeight | 文字内容过多时，是否自动调整行高以确保显示所有文字。
公共属性 | CellValueInfos | 导出页面的单元格的名称设置，可正确导出变更之后的单元格的数据。 (继承自 ExportPageSettingBase。)
公共属性 | ListViewCurrentRowInfos | 导出页面的各表格的当前行设置，可正确导出绑定字段及字表的数据。 (继承自 ExportPageSettingBase。)
公共属性 | PageName | 导出页面的名称。 (继承自 ExportPageSettingBase。)
Top
参见

引用

ExportPageToPdfSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToPdfSetting.AutoFitRowHeight 属性

活字格插件API文档

ExportPageToPdfSettingAutoFitRowHeight 属性

文字内容过多时，是否自动调整行高以确保显示所有文字。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AutoFitRowHeight { get; set; }

属性值

类型：Boolean
参见

引用

ExportPageToPdfSetting 类
GrapeCity.Forguncy.Commands 命名空间


ExportPageToPdfSetting 方法

ExportPageToPdfSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ExportPageToPdfSetting 类
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext 接口

命令编辑上下文信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IBuilderCommandContext : IBuilderContextBase

IBuilderCommandContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AuthenticationMode | 获取当前工程的认证模式。 (继承自 IBuilderContextBase。)
公共属性 | CommandCell | 返回设置了命令的单元格信息。
公共属性 | CommandScope |
公共属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
公共属性 | IsShareCommandMode | 判断当前命令窗口是否为模板命令的命令窗口
公共属性 | LocalServerInfo | 本地网站应用信息。 (继承自 IBuilderContextBase。)
公共属性 | PageName | 获取当前所在页面名称。 (继承自 IBuilderContextBase。)
 | UserServiceInfo | 获取用户管理网站的信息。 (继承自 IBuilderContextBase。)
Top
方法
 | 名称 | 说明
 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (继承自 IBuilderContextBase。)
 | EnumAllPageInfos | 获取所有的页面信息。 (继承自 IBuilderContextBase。)
 | EnumAllTableInfos | 获取所有的数据表信息。 (继承自 IBuilderContextBase。)
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (继承自 IBuilderContextBase。)
公共方法 | GetCell(IFormulaReferObject) | 返回引用单元格公式所在的单元格信息。
公共方法 | GetCell(String, Int32, Int32) | 返回指定页面指定行列的单元格信息。
 | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
公共方法 | HideCommandDialog | 隐藏命令窗口，配合ShowCommandDialog使用。 一般情况下，如果命令属性的编辑子窗口中有公式选择框，那么需要使用该函数。
公共方法 | ShowCommandDialog | 重新显示命令窗口，配合HideCommandDialog使用。
公共方法 | StartServer | 生成页面并启动服务器。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext 属性

IBuilderCommandContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AuthenticationMode | 获取当前工程的认证模式。 (继承自 IBuilderContextBase。)
公共属性 | CommandCell | 返回设置了命令的单元格信息。
公共属性 | CommandScope |
公共属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
公共属性 | IsShareCommandMode | 判断当前命令窗口是否为模板命令的命令窗口
公共属性 | LocalServerInfo | 本地网站应用信息。 (继承自 IBuilderContextBase。)
公共属性 | PageName | 获取当前所在页面名称。 (继承自 IBuilderContextBase。)
 | UserServiceInfo | 获取用户管理网站的信息。 (继承自 IBuilderContextBase。)
Top
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.CommandCell 属性

活字格插件API文档

IBuilderCommandContextCommandCell 属性

返回设置了命令的单元格信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ICommandCellInfo CommandCell { get; }

属性值

类型：ICommandCellInfo
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.CommandScope 属性

活字格插件API文档

IBuilderCommandContextCommandScope 属性

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
CommandScope CommandScope { get; }

属性值

类型：CommandScope
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.ForguncyUploadFilesFolderPath 属性

活字格插件API文档

IBuilderCommandContextForguncyUploadFilesFolderPath 属性

用户在设计器中上传的文件或图片所在的文件目录。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ForguncyUploadFilesFolderPath { get; }

属性值

类型：String
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.IsShareCommandMode 属性

活字格插件API文档

IBuilderCommandContextIsShareCommandMode 属性

判断当前命令窗口是否为模板命令的命令窗口

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsShareCommandMode { get; }

属性值

类型：Boolean
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext 方法

IBuilderCommandContext 类型公开以下成员。

方法
 | 名称 | 说明
 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (继承自 IBuilderContextBase。)
 | EnumAllPageInfos | 获取所有的页面信息。 (继承自 IBuilderContextBase。)
 | EnumAllTableInfos | 获取所有的数据表信息。 (继承自 IBuilderContextBase。)
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。 (继承自 IBuilderContextBase。)
公共方法 | GetCell(IFormulaReferObject) | 返回引用单元格公式所在的单元格信息。
公共方法 | GetCell(String, Int32, Int32) | 返回指定页面指定行列的单元格信息。
 | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
公共方法 | HideCommandDialog | 隐藏命令窗口，配合ShowCommandDialog使用。 一般情况下，如果命令属性的编辑子窗口中有公式选择框，那么需要使用该函数。
公共方法 | ShowCommandDialog | 重新显示命令窗口，配合HideCommandDialog使用。
公共方法 | StartServer | 生成页面并启动服务器。
Top
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.GetCell 方法

活字格插件API文档

IBuilderCommandContextGetCell 方法

重载列表
 | 名称 | 说明
公共方法 | GetCell(IFormulaReferObject) | 返回引用单元格公式所在的单元格信息。
公共方法 | GetCell(String, Int32, Int32) | 返回指定页面指定行列的单元格信息。
Top
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.GetCell 方法 (IFormulaReferObject)

活字格插件API文档

IBuilderCommandContextGetCell 方法 (IFormulaReferObject)

返回引用单元格公式所在的单元格信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ICommandCellInfo GetCell(
    IFormulaReferObject obj
)

参数

obj
类型：GrapeCity.Forguncy.PluginIFormulaReferObject
引用单元格公式。

返回值

类型：ICommandCellInfo
返回引用单元格公式所在的单元格信息。
参见

引用

IBuilderCommandContext 接口
GetCell 重载
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.GetCell 方法 (String, Int32, Int32)

活字格插件API文档

IBuilderCommandContextGetCell 方法 (String, Int32, Int32)

返回指定页面指定行列的单元格信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ICommandCellInfo GetCell(
    string pageName,
    int row,
    int column
)

参数

pageName
类型：SystemString
页面名称。
row
类型：SystemInt32
行索引。
column
类型：SystemInt32
列索引。

返回值

类型：ICommandCellInfo
返回指定页面指定行列的单元格信息。
参见

引用

IBuilderCommandContext 接口
GetCell 重载
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.GetQueryConditionWindow 方法

活字格插件API文档

IBuilderCommandContextGetQueryConditionWindow 方法

获取活字格内部查询条件的对话窗口。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IQueryConditionWindow GetQueryConditionWindow(
    Object queryCondition,
    string tableName,
    bool allowSelectTable
)

参数

queryCondition
类型：SystemObject
初始化内置查询条件对话窗口的对象。
tableName
类型：SystemString
数据表名。
allowSelectTable
类型：SystemBoolean
是否允许选择表。

返回值

类型：IQueryConditionWindow
返回活字格内部查询条件的对话窗口。
示例
代码参照IQueryConditionWindow。
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.HideCommandDialog 方法

活字格插件API文档

IBuilderCommandContextHideCommandDialog 方法

隐藏命令窗口，配合ShowCommandDialog使用。 一般情况下，如果命令属性的编辑子窗口中有公式选择框，那么需要使用该函数。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void HideCommandDialog()
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.ShowCommandDialog 方法

活字格插件API文档

IBuilderCommandContextShowCommandDialog 方法

重新显示命令窗口，配合HideCommandDialog使用。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void ShowCommandDialog()
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


IBuilderCommandContext.StartServer 方法

活字格插件API文档

IBuilderCommandContextStartServer 方法

生成页面并启动服务器。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void StartServer()
参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandCellInfo 接口

命令单元格信息。详情参照。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICommandCellInfo : ICellInfoBase

ICommandCellInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindingInfo | 单元格的数据绑定信息。 (继承自 ICellInfoBase。)
公共属性 | ColumnIndex | 获取单元格所在列的索引。 (继承自 ICellInfoBase。)
公共属性 | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
公共属性 | ListViewInfo | 单元格所在表格的信息。 (继承自 ICellInfoBase。)
公共属性 | PageName | 单元格所在的页面名称。 (继承自 ICellInfoBase。)
公共属性 | RowIndex | 获取单元格所在行的索引 (继承自 ICellInfoBase。)
公共属性 | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
Top
方法
 | 名称 | 说明
公共方法 | GetFormulaReferObject | 返回单元格对应的公式对象。 (继承自 ICellInfoBase。)
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间
GrapeCity.Forguncy.PluginICellInfoBase


ICommandCellInfo 属性

ICommandCellInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindingInfo | 单元格的数据绑定信息。 (继承自 ICellInfoBase。)
公共属性 | ColumnIndex | 获取单元格所在列的索引。 (继承自 ICellInfoBase。)
公共属性 | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
公共属性 | ListViewInfo | 单元格所在表格的信息。 (继承自 ICellInfoBase。)
公共属性 | PageName | 单元格所在的页面名称。 (继承自 ICellInfoBase。)
公共属性 | RowIndex | 获取单元格所在行的索引 (继承自 ICellInfoBase。)
公共属性 | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。 (继承自 ICellInfoBase。)
Top
参见

引用

ICommandCellInfo 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandCellInfo 方法

ICommandCellInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetFormulaReferObject | 返回单元格对应的公式对象。 (继承自 ICellInfoBase。)
Top
参见

引用

ICommandCellInfo 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandChecker 接口

如果执行命令需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICommandChecker

ICommandChecker 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CheckCommandErrors | 运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
Top
示例
C#
复制
public class ShowMessageBoxCommandDesigner: CommandDesigner<ShowMessageBoxCommand>, ICommandChecker
{
    public string Message { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCommandErrors(IBuilderCommandContext context)
    {
        if(string.IsNullOrEmpty(this.Message))
        {
            yield return new ForguncyErrorInfo()
            {
                Message = "消息文本不能为空。",
                ErrorType = ForguncyErrorType.Warning
            };
        }
    }
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ICommandChecker 方法

ICommandChecker 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | CheckCommandErrors | 运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
Top
参见

引用

ICommandChecker 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandChecker.CheckCommandErrors 方法

活字格插件API文档

ICommandCheckerCheckCommandErrors 方法

运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<ForguncyErrorInfo> CheckCommandErrors(
    IBuilderCommandContext context
)

参数

context
类型：GrapeCity.Forguncy.CommandsIBuilderCommandContext
与执行命令相关的上下文信息

返回值

类型：IEnumerable ForguncyErrorInfo
返回与命令插件相关的所有错误和提醒列表。
参见

引用

ICommandChecker 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandEditor 接口

插件命令数据编辑器。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICommandEditor

ICommandEditor 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Command | 命令数据。
Top
方法
 | 名称 | 说明
公共方法 | Validate | 编辑器关闭前的数据校验。
Top
示例

UserControl和自定义插件弹出消息框命令定义如下：

C#
复制
public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
{
    public ShowMessageCommandEditor()
    {
       InitializeComponent();
    }

    public Command Command
    {
        get
        {
            return new ShowMessageBoxCommand() { Message = messageTextBox.Text };  //messageTextBox is the name of TextBox in UserControl.
        }
        set
        {
            ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
            if(command != null)
            {
                messageTextBox.Text = command.Message;
            }
        }
    }

    public bool Validate()
    {
        return true;
    }
}
public class ShowMessageBoxCommand: Command
{
    public string Message { get; set; }

    public override ICommandEditor GetCommandEditor() => new ShowMessageCommandEditor();
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ICommandEditor 属性

ICommandEditor 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Command | 命令数据。
Top
参见

引用

ICommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandEditor.Command 属性

活字格插件API文档

ICommandEditorCommand 属性

命令数据。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Command Command { get; set; }

属性值

类型：Command
参见

引用

ICommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandEditor 方法

ICommandEditor 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Validate | 编辑器关闭前的数据校验。
Top
参见

引用

ICommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandEditor.Validate 方法

活字格插件API文档

ICommandEditorValidate 方法

编辑器关闭前的数据校验。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool Validate()

返回值

类型：Boolean
参见

引用

ICommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandExecutableInServerSide 接口

具有可独立执行能力的命令需要实现这个接口。

用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICommandExecutableInServerSide

ICommandExecutableInServerSide 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Execute | 命令执行方法。
Top
示例
C#
复制
public classSendWeChatMessage : Command, ICommandExecutableInServerSide
{
    publicobjectUserId { get; set; }

    public objectPartyId { get; set; }

    public objectContent { get; set; }

    public string Execute(IServerCommandExecuteContext dataContext)
    {
        var api = newWeChat();return api.SendMessage(UserId?.ToString(), PartyId?.ToString(), dataContext.ReplaceKeyWord(Content?.ToString()));
    }
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ICommandExecutableInServerSide 方法

ICommandExecutableInServerSide 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Execute | 命令执行方法。
Top
参见

引用

ICommandExecutableInServerSide 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandExecutableInServerSide.Execute 方法

活字格插件API文档

ICommandExecutableInServerSideExecute 方法

命令执行方法。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ExecuteResult Execute(
    IServerCommandExecuteContext dataContext
)

参数

dataContext
类型：GrapeCity.Forguncy.CommandsIServerCommandExecuteContext
从服务器端传递给命令执行时的上下文信息。

返回值

类型：ExecuteResult
是否执行成功。
参见

引用

ICommandExecutableInServerSide 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandExecutableInServerSideAsync 接口

具有可独立执行能力的命令需要实现这个接口。

用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICommandExecutableInServerSideAsync

ICommandExecutableInServerSideAsync 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ExecuteAsync | 命令执行方法。
Top
示例
C#
复制
public classSendWeChatMessage : Command, ICommandExecutableInServerSideAsync
{
    publicobjectUserId { get; set; }

    public objectPartyId { get; set; }

    public objectContent { get; set; }

    public async Task<string> Execute(IServerCommandExecuteContext context)
    {
        await context.Context.WriteAsync("Hello");
        return new ExecuteResult(){ AllowWriteResultToResponse = false };// success
    }
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ICommandExecutableInServerSideAsync 方法

ICommandExecutableInServerSideAsync 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ExecuteAsync | 命令执行方法。
Top
参见

引用

ICommandExecutableInServerSideAsync 接口
GrapeCity.Forguncy.Commands 命名空间


ICommandExecutableInServerSideAsync.ExecuteAsync 方法

活字格插件API文档

ICommandExecutableInServerSideAsyncExecuteAsync 方法

命令执行方法。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Task<ExecuteResult> ExecuteAsync(
    IServerCommandExecuteContext dataContext
)

参数

dataContext
类型：GrapeCity.Forguncy.CommandsIServerCommandExecuteContext
从服务器端传递给命令执行时的上下文信息。

返回值

类型：Task ExecuteResult
是否执行成功。
参见

引用

ICommandExecutableInServerSideAsync 接口
GrapeCity.Forguncy.Commands 命名空间


IContainSubCommands 接口

迭代当前命令的子命令，用于查找替换。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IContainSubCommands

IContainSubCommands 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumSubCommands | 迭代子命令列表。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


IContainSubCommands 方法

IContainSubCommands 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumSubCommands | 迭代子命令列表。
Top
参见

引用

IContainSubCommands 接口
GrapeCity.Forguncy.Commands 命名空间


IContainSubCommands.EnumSubCommands 方法

活字格插件API文档

IContainSubCommandsEnumSubCommands 方法

迭代子命令列表。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<List<Command>> EnumSubCommands()

返回值

类型：IEnumerable List Command
子命令迭代器。
参见

引用

IContainSubCommands 接口
GrapeCity.Forguncy.Commands 命名空间


IExportHelper 接口

提供导出相关的方法。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IExportHelper

IExportHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ExportPageToExcel | 导出页面到Excel。
公共方法 | ExportPageToHtml | 导出页面到Html。
公共方法 | ExportPageToPDF | 导出页面到PDF。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


IExportHelper 方法

IExportHelper 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ExportPageToExcel | 导出页面到Excel。
公共方法 | ExportPageToHtml | 导出页面到Html。
公共方法 | ExportPageToPDF | 导出页面到PDF。
Top
参见

引用

IExportHelper 接口
GrapeCity.Forguncy.Commands 命名空间


IExportHelper.ExportPageToExcel 方法

活字格插件API文档

IExportHelperExportPageToExcel 方法

导出页面到Excel。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Stream ExportPageToExcel(
    ExportPageToExcelSetting setting
)

参数

setting
类型：GrapeCity.Forguncy.CommandsExportPageToExcelSetting
导出页面到excel的相关设置。

返回值

类型：Stream
导出的excel文件的文件流。
参见

引用

IExportHelper 接口
GrapeCity.Forguncy.Commands 命名空间


IExportHelper.ExportPageToHtml 方法

活字格插件API文档

IExportHelperExportPageToHtml 方法

导出页面到Html。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Stream ExportPageToHtml(
    ExportPageToHtmlSetting setting
)

参数

setting
类型：GrapeCity.Forguncy.CommandsExportPageToHtmlSetting
导出页面到Html的相关设置。

返回值

类型：Stream
导出的Html文件的文件流。
参见

引用

IExportHelper 接口
GrapeCity.Forguncy.Commands 命名空间


IExportHelper.ExportPageToPDF 方法

活字格插件API文档

IExportHelperExportPageToPDF 方法

导出页面到PDF。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Stream ExportPageToPDF(
    ExportPageToPdfSetting setting
)

参数

setting
类型：GrapeCity.Forguncy.CommandsExportPageToPdfSetting
导出页面到pdf的相关设置。

返回值

类型：Stream
导出的PDF文件的文件流。
参见

引用

IExportHelper 接口
GrapeCity.Forguncy.Commands 命名空间


ILog 接口

提供打印日志的方法。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ILog

ILog 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | LogLevel | 日志详细程度。
Top
方法
 | 名称 | 说明
公共方法 | AppendLine(String, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, Boolean, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, Boolean, Boolean, String) | 追加一行日志。
公共方法 | ClearLog | 清除日志内容。
公共方法 | DecreaseIndent | 减少缩进。
公共方法 | GetLog | 获取日志内容。
公共方法 | IncreaseIndent | 增加缩进。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ILog 属性

ILog 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | LogLevel | 日志详细程度。
Top
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


ILog.LogLevel 属性

活字格插件API文档

ILogLogLevel 属性

日志详细程度。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
LogLevel LogLevel { get; }

属性值

类型：LogLevel
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


ILog 方法

ILog 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AppendLine(String, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, Boolean, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, Boolean, Boolean, String) | 追加一行日志。
公共方法 | ClearLog | 清除日志内容。
公共方法 | DecreaseIndent | 减少缩进。
公共方法 | GetLog | 获取日志内容。
公共方法 | IncreaseIndent | 增加缩进。
Top
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


ILog.AppendLine 方法

活字格插件API文档

ILogAppendLine 方法

重载列表
 | 名称 | 说明
公共方法 | AppendLine(String, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, Boolean, String) | 追加一行日志。
公共方法 | AppendLine(String, LogLevel, Boolean, Boolean, String) | 追加一行日志。
Top
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


ILog.AppendLine 方法 (String, String[])

活字格插件API文档

ILogAppendLine 方法 (String, String)

追加一行日志。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void AppendLine(
    string content,
    params string[] args
)

参数

content
类型：SystemString
日志模板内容。
args
类型：SystemString
日志模板对应参数。
参见

引用

ILog 接口
AppendLine 重载
GrapeCity.Forguncy.Commands 命名空间


ILog.AppendLine 方法 (String, LogLevel, String[])

活字格插件API文档

ILogAppendLine 方法 (String, LogLevel, String)

追加一行日志。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void AppendLine(
    string content,
    LogLevel logLevel = LogLevel.Detail,
    params string[] args
)

参数

content
类型：SystemString
日志模板内容。
logLevel (Optional)
类型：GrapeCity.Forguncy.CommandsLogLevel
日志详细程度。
args
类型：SystemString
日志模板对应参数。
参见

引用

ILog 接口
AppendLine 重载
GrapeCity.Forguncy.Commands 命名空间


ILog.AppendLine 方法 (String, LogLevel, Boolean, String[])

活字格插件API文档

ILogAppendLine 方法 (String, LogLevel, Boolean, String)

追加一行日志。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void AppendLine(
    string content,
    LogLevel logLevel = LogLevel.Detail,
    bool trancatedExceed = true,
    params string[] args
)

参数

content
类型：SystemString
日志模板内容。
logLevel (Optional)
类型：GrapeCity.Forguncy.CommandsLogLevel
日志详细程度。
trancatedExceed (Optional)
类型：SystemBoolean
是否截除超出1000个字符长度部分的内容。
args
类型：SystemString
日志模板对应参数。
参见

引用

ILog 接口
AppendLine 重载
GrapeCity.Forguncy.Commands 命名空间


ILog.AppendLine 方法 (String, LogLevel, Boolean, Boolean, String[])

活字格插件API文档

ILogAppendLine 方法 (String, LogLevel, Boolean, Boolean, String)

追加一行日志。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void AppendLine(
    string content,
    LogLevel logLevel = LogLevel.Detail,
    bool trancatedExceed = true,
    bool skipContentTrim = false,
    params string[] args
)

参数

content
类型：SystemString
日志模板内容。
logLevel (Optional)
类型：GrapeCity.Forguncy.CommandsLogLevel
日志详细程度。
trancatedExceed (Optional)
类型：SystemBoolean
是否截除超出1000个字符长度部分的内容。
skipContentTrim (Optional)
类型：SystemBoolean
是否将content的缩进trim并重新排列。
args
类型：SystemString
日志模板对应参数。
参见

引用

ILog 接口
AppendLine 重载
GrapeCity.Forguncy.Commands 命名空间


ILog.ClearLog 方法

活字格插件API文档

ILogClearLog 方法

清除日志内容。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void ClearLog()
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


ILog.DecreaseIndent 方法

活字格插件API文档

ILogDecreaseIndent 方法

减少缩进。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void DecreaseIndent()
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


ILog.GetLog 方法

活字格插件API文档

ILogGetLog 方法

获取日志内容。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetLog()

返回值

类型：String
日志内容。
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


ILog.IncreaseIndent 方法

活字格插件API文档

ILogIncreaseIndent 方法

增加缩进。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void IncreaseIndent()
参见

引用

ILog 接口
GrapeCity.Forguncy.Commands 命名空间


IQueryConditionWindow 接口

活字格内置的设置查询条件的对话窗口。

注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现IReferenceFormula接口。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IQueryConditionWindow : IWindow

IQueryConditionWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | QueryCondition | 查询条件。
Top
方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
示例
C#
复制
public class TreeCellTypeDesigner : CellTypeDesigner<TreeCellType>
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}

[Designer("Forguncy.TreeCellTypeDesigner, Forguncy")]
public class TreeCellType : CellType, IDependenceCells, IReferenceFormula
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        if (this.BindingTreeLevelInfo != null)
        {
            return this.BindingTreeLevelInfo.GetFormulaReferObjects(location);
        }
        return Enumerable.Empty<LocatedObject<object>>();
    }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return EnumDependenceCells(this.BindingTreeLevelInfo, context);
    }

    private IEnumerable<object> EnumDependenceCells(BindingTreeLevelInfo info, IBuilderContext context)
    {
        var result = Enumerable.Empty<object>();
        if (info != null)
        {
            if (info.QueryCondition != null)
            {
                result = result.Union(context.EnumDependenceCells(info.QueryCondition) ?? Enumerable.Empty<object>());
            }
            if (info.SubBindingTreeLevelInfo != null)
            {
                result = result.Union(EnumDependenceCells(info.SubBindingTreeLevelInfo, context) ?? Enumerable.Empty<object>());
            }
        }
        return result;
    }
}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出查询对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditQueryConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的查询条件和表名初始化查询对话窗口。*/
        var window = _builderContext?.GetQueryConditionWindow(queryCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的查询条件提交到数据层。*/
                /*ViewModel.QueryCondition = window.QueryCondition;*/

                /*重新打开父窗口。*/
                _builderContext.ShowParentDialog(this);
            }
        }
        /*由于查询条件中可能引用单元格，所以这里需要暂时隐藏父窗口。*/
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object QueryCondition { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("TreeCellType").AppendProperty("BindingTreeLevelInfo");
        if(this.QueryCondition is IReferenceFormula)
        {
            var items = (this.QueryCondition as IReferenceFormula).GetFormulaReferObjects(newLocation);
            foreach (var item in items)
            {
                yield return item;
            }
        }
        if (this.SubBindingTreeLevelInfo != null)
        {
            var items = this.SubBindingTreeLevelInfo.GetFormulaReferObjects(location);
            foreach (var item in items)
            {
                yield return item;
            }
        }
    }
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


IQueryConditionWindow 属性

IQueryConditionWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。 (继承自 IWindow。)
公共属性 | QueryCondition | 查询条件。
Top
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IQueryConditionWindow.QueryCondition 属性

活字格插件API文档

IQueryConditionWindowQueryCondition 属性

查询条件。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object QueryCondition { get; }

属性值

类型：Object
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IQueryConditionWindow 方法

IQueryConditionWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。 (继承自 IWindow。)
Top
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IQueryConditionWindow 事件

IQueryConditionWindow 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。 (继承自 IWindow。)
Top
参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext 接口

当在服务器端执行实现了ICommandExecutableInServerSide接口的命令时，从服务器端传递的上下文信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IServerCommandExecuteContext

IServerCommandExecuteContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AppBaseUrl | 应用的Base Url。
公共属性 | Context | 返回IOwinContext类的实例。
公共属性 | CurrentServerCommandName | 服务端命令的名称。
公共属性 | DataAccess | 用于操作数据库的上下文信息。
公共属性 | ExportHelper | 用于导出页面的上下文信息。
公共属性 | Log | 用于记录日志的上下文环境。
公共属性 | Parameters | 当前上下文中可用参数。
公共属性 | UserInfos | 用于操作用户的上下文环境。
Top
方法
 | 名称 | 说明
公共方法 | EvaluateFormula | 已过时。 计算公式的工具方法，返回公式的计算结果。
公共方法 | EvaluateFormulaAsync | 计算公式的工具方法，返回公式的计算结果。
公共方法 | EvaluateFormulaInContentAsync | 计算字符串中的公式，如 aaa,[=参数1],bbb 假设‘参数1’的值为ccc则计算结果为 aaa,ccc,bbb
公共方法 | EvaluateQueryConditionValueFormula | 已过时。 计算查询条件的工具方法，返回查询条件的计算结果。
公共方法 | EvaluateQueryConditionValueFormulaAsync | 计算查询条件的工具方法，返回查询条件的计算结果。
公共方法 | ExecuteCommands | 执行命令列表并返回执行结果。
公共方法 | ExecuteCommandsAsync | 执行命令列表并返回执行结果。
公共方法 | ExecuteServerCommands | 执行服务端命令列表并返回执行结果。
公共方法 | ExecuteServerCommandsAsync | 执行服务端命令列表并返回执行结果。
公共方法 | ReplaceKeyWord | 已过时。 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
公共方法 | ReplaceKeyWordAsync | 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
公共方法 | SendMail | 调用该方法可以异步发送邮件。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext 属性

IServerCommandExecuteContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AppBaseUrl | 应用的Base Url。
公共属性 | Context | 返回IOwinContext类的实例。
公共属性 | CurrentServerCommandName | 服务端命令的名称。
公共属性 | DataAccess | 用于操作数据库的上下文信息。
公共属性 | ExportHelper | 用于导出页面的上下文信息。
公共属性 | Log | 用于记录日志的上下文环境。
公共属性 | Parameters | 当前上下文中可用参数。
公共属性 | UserInfos | 用于操作用户的上下文环境。
Top
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.AppBaseUrl 属性

活字格插件API文档

IServerCommandExecuteContextAppBaseUrl 属性

应用的Base Url。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string AppBaseUrl { get; }

属性值

类型：String
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.Context 属性

活字格插件API文档

IServerCommandExecuteContextContext 属性

返回IOwinContext类的实例。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
HttpContext Context { get; }

属性值

类型：HttpContext
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.CurrentServerCommandName 属性

活字格插件API文档

IServerCommandExecuteContextCurrentServerCommandName 属性

服务端命令的名称。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string CurrentServerCommandName { get; }

属性值

类型：String
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.DataAccess 属性

活字格插件API文档

IServerCommandExecuteContextDataAccess 属性

用于操作数据库的上下文信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IDataAccess DataAccess { get; }

属性值

类型：IDataAccess
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.ExportHelper 属性

活字格插件API文档

IServerCommandExecuteContextExportHelper 属性

用于导出页面的上下文信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IExportHelper ExportHelper { get; }

属性值

类型：IExportHelper
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.Log 属性

活字格插件API文档

IServerCommandExecuteContextLog 属性

用于记录日志的上下文环境。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ILog Log { get; }

属性值

类型：ILog
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.Parameters 属性

活字格插件API文档

IServerCommandExecuteContextParameters 属性

当前上下文中可用参数。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IDictionary<string, Object> Parameters { get; }

属性值

类型：IDictionary String, Object
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.UserInfos 属性

活字格插件API文档

IServerCommandExecuteContextUserInfos 属性

用于操作用户的上下文环境。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IUserInfos UserInfos { get; }

属性值

类型：IUserInfos
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext 方法

IServerCommandExecuteContext 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EvaluateFormula | 已过时。 计算公式的工具方法，返回公式的计算结果。
公共方法 | EvaluateFormulaAsync | 计算公式的工具方法，返回公式的计算结果。
公共方法 | EvaluateFormulaInContentAsync | 计算字符串中的公式，如 aaa,[=参数1],bbb 假设‘参数1’的值为ccc则计算结果为 aaa,ccc,bbb
公共方法 | EvaluateQueryConditionValueFormula | 已过时。 计算查询条件的工具方法，返回查询条件的计算结果。
公共方法 | EvaluateQueryConditionValueFormulaAsync | 计算查询条件的工具方法，返回查询条件的计算结果。
公共方法 | ExecuteCommands | 执行命令列表并返回执行结果。
公共方法 | ExecuteCommandsAsync | 执行命令列表并返回执行结果。
公共方法 | ExecuteServerCommands | 执行服务端命令列表并返回执行结果。
公共方法 | ExecuteServerCommandsAsync | 执行服务端命令列表并返回执行结果。
公共方法 | ReplaceKeyWord | 已过时。 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
公共方法 | ReplaceKeyWordAsync | 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
公共方法 | SendMail | 调用该方法可以异步发送邮件。
Top
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.EvaluateFormula 方法

活字格插件API文档

IServerCommandExecuteContextEvaluateFormula 方法

注意：此 API 现在已过时。

计算公式的工具方法，返回公式的计算结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[ObsoleteAttribute("EvaluateFormula is deprecated, please use EvaluateFormulaAsync instead")]
Object EvaluateFormula(
    Object value
)

参数

value
类型：SystemObject
原始公式字符串。

返回值

类型：Object
公式的计算结果。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.EvaluateFormulaAsync 方法

活字格插件API文档

IServerCommandExecuteContextEvaluateFormulaAsync 方法

计算公式的工具方法，返回公式的计算结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Task<Object> EvaluateFormulaAsync(
    Object value
)

参数

value
类型：SystemObject
原始公式字符串。

返回值

类型：Task Object
公式的计算结果。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.EvaluateFormulaInContentAsync 方法

活字格插件API文档

IServerCommandExecuteContextEvaluateFormulaInContentAsync 方法

计算字符串中的公式，如 aaa,[=参数1],bbb 假设‘参数1’的值为ccc则计算结果为 aaa,ccc,bbb

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Task<Object> EvaluateFormulaInContentAsync(
    Object value,
    Dictionary<string, Object> formulaValues
)

参数

value
类型：SystemObject
原始公式字符串。
formulaValues
类型：System.Collections.GenericDictionary String, Object
用于缓存公式计算结果。

返回值

类型：Task Object
公式的计算结果。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.EvaluateQueryConditionValueFormula 方法

活字格插件API文档

IServerCommandExecuteContextEvaluateQueryConditionValueFormula 方法

注意：此 API 现在已过时。

计算查询条件的工具方法，返回查询条件的计算结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[ObsoleteAttribute("EvaluateQueryConditionValueFormula is deprecated, please use EvaluateQueryConditionValueFormulaAsync instead")]
Object EvaluateQueryConditionValueFormula(
    Object queryCondition
)

参数

queryCondition
类型：SystemObject
原始查询条件。

返回值

类型：Object
查询条件的计算结果。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.EvaluateQueryConditionValueFormulaAsync 方法

活字格插件API文档

IServerCommandExecuteContextEvaluateQueryConditionValueFormulaAsync 方法

计算查询条件的工具方法，返回查询条件的计算结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Task<Object> EvaluateQueryConditionValueFormulaAsync(
    Object queryCondition
)

参数

queryCondition
类型：SystemObject
原始查询条件。

返回值

类型：Task Object
查询条件的计算结果。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.ExecuteCommands 方法

活字格插件API文档

IServerCommandExecuteContextExecuteCommands 方法

执行命令列表并返回执行结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ExecuteResult ExecuteCommands(
    List<Command> commands
)

参数

commands
类型：System.Collections.GenericList Command
待执行命令列表。

返回值

类型：ExecuteResult
命令执行结果。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.ExecuteCommandsAsync 方法

活字格插件API文档

IServerCommandExecuteContextExecuteCommandsAsync 方法

执行命令列表并返回执行结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Task<ExecuteResult> ExecuteCommandsAsync(
    List<Command> commands
)

参数

commands
类型：System.Collections.GenericList Command
待执行命令列表。

返回值

类型：Task ExecuteResult
命令执行结果。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.ExecuteServerCommands 方法

活字格插件API文档

IServerCommandExecuteContextExecuteServerCommands 方法

执行服务端命令列表并返回执行结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ExecuteResult ExecuteServerCommands(
    string serverCommandName,
    IServerCommandExecuteContext dataContext
)

参数

serverCommandName
类型：SystemString
服务端命令的名称。
dataContext
类型：GrapeCity.Forguncy.CommandsIServerCommandExecuteContext
执行服务端命令的上下文。

返回值

类型：ExecuteResult
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.ExecuteServerCommandsAsync 方法

活字格插件API文档

IServerCommandExecuteContextExecuteServerCommandsAsync 方法

执行服务端命令列表并返回执行结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Task<ExecuteResult> ExecuteServerCommandsAsync(
    string serverCommandName,
    IServerCommandExecuteContext dataContext
)

参数

serverCommandName
类型：SystemString
服务端命令的名称。
dataContext
类型：GrapeCity.Forguncy.CommandsIServerCommandExecuteContext
执行服务端命令的上下文。

返回值

类型：Task ExecuteResult
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.ReplaceKeyWord 方法

活字格插件API文档

IServerCommandExecuteContextReplaceKeyWord 方法

注意：此 API 现在已过时。

更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[ObsoleteAttribute("ReplaceKeyWord is deprecated, please use ReplaceKeyWordAsync instead")]
string ReplaceKeyWord(
    string value
)

参数

value
类型：SystemString
原始字符串。

返回值

类型：String
返回更换过关键字后的字符串。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.ReplaceKeyWordAsync 方法

活字格插件API文档

IServerCommandExecuteContextReplaceKeyWordAsync 方法

更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Task<string> ReplaceKeyWordAsync(
    string value
)

参数

value
类型：SystemString
原始字符串。

返回值

类型：Task String
返回更换过关键字后的字符串。
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


IServerCommandExecuteContext.SendMail 方法

活字格插件API文档

IServerCommandExecuteContextSendMail 方法

调用该方法可以异步发送邮件。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string SendMail(
    string fromAddress,
    List<string> toList,
    string title,
    string content
)

参数

fromAddress
类型：SystemString
发送人邮件地址（可以使用用户名）
toList
类型：System.Collections.GenericList String
收件人列表（可以使用用户名）
title
类型：SystemString
标题
content
类型：SystemString
邮件正文

返回值

类型：String
如果有非空返回值表示邮件发送失败
参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


ISubListCommand 接口

如果命令包含子命令(例如循环命令)，则需要实现该接口。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ISubListCommand

ISubListCommand 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CommandList | 子命令列表。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ISubListCommand 属性

ISubListCommand 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CommandList | 子命令列表。
Top
参见

引用

ISubListCommand 接口
GrapeCity.Forguncy.Commands 命名空间


ISubListCommand.CommandList 属性

活字格插件API文档

ISubListCommandCommandList 属性

子命令列表。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<Command> CommandList { get; }

属性值

类型：List Command
参见

引用

ISubListCommand 接口
GrapeCity.Forguncy.Commands 命名空间


IUpdateDatabaseCommand 接口

提供更新数据库的方法。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IUpdateDatabaseCommand

IUpdateDatabaseCommand 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetUpdatingDatabaseConnectionStrings | 从服务端命令上下文环境获取待更新数据库的连接字符串数组。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


IUpdateDatabaseCommand 方法

IUpdateDatabaseCommand 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetUpdatingDatabaseConnectionStrings | 从服务端命令上下文环境获取待更新数据库的连接字符串数组。
Top
参见

引用

IUpdateDatabaseCommand 接口
GrapeCity.Forguncy.Commands 命名空间


IUpdateDatabaseCommand.GetUpdatingDatabaseConnectionStrings 方法

活字格插件API文档

IUpdateDatabaseCommandGetUpdatingDatabaseConnectionStrings 方法

从服务端命令上下文环境获取待更新数据库的连接字符串数组。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<string> GetUpdatingDatabaseConnectionStrings(
    IServerCommandExecuteContext context
)

参数

context
类型：GrapeCity.Forguncy.CommandsIServerCommandExecuteContext
执行服务端命令的上下文环境。

返回值

类型：IEnumerable String
待执行命令列表。
参见

引用

IUpdateDatabaseCommand 接口
GrapeCity.Forguncy.Commands 命名空间


IWindow 接口

内置对话框接口。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IWindow

IWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。
Top
方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。
Top
事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。
Top
参见

引用

GrapeCity.Forguncy.Commands 命名空间


IWindow 属性

IWindow 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DialogResult | 对话框返回结果。
Top
参见

引用

IWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IWindow.DialogResult 属性

活字格插件API文档

IWindowDialogResult 属性

对话框返回结果。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool? DialogResult { get; }

属性值

类型：Nullable Boolean
参见

引用

IWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IWindow 方法

IWindow 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | ShowDialog | 打开对话框。
Top
参见

引用

IWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IWindow.ShowDialog 方法

活字格插件API文档

IWindowShowDialog 方法

打开对话框。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool? ShowDialog()

返回值

类型：Nullable Boolean
参见

引用

IWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IWindow 事件

IWindow 类型公开以下成员。

事件
 | 名称 | 说明
公共事件 | Closed | 对话框关闭事件。
Top
参见

引用

IWindow 接口
GrapeCity.Forguncy.Commands 命名空间


IWindow.Closed 事件

活字格插件API文档

IWindowClosed 事件

对话框关闭事件。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands.Design (在 Forguncy.Commands.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
event EventHandler Closed

值

类型：SystemEventHandler
参见

引用

IWindow 接口
GrapeCity.Forguncy.Commands 命名空间


LogLevel 枚举

日志详细程度。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum LogLevel
成员
成员名称 | 值 | 说明
None | 0 | 无日志。
Simple | 1 | 简单等级。
Normal | 2 | 普通等级。
Detail | 3 | 详细记录日志。
参见

引用

GrapeCity.Forguncy.Commands 命名空间


NullFormulaValueQueryPolicy 枚举

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum NullFormulaValueQueryPolicy
成员
成员名称 | 值 | 说明
EmptyDatas | 0 |
AllDatas | 1 |
GetEmptyValueItems | 2 |
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ProcessControl 枚举

流程控制信息。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ProcessControl
成员
成员名称 | 值 | 说明
Continue | 0 | 继续执行。
BreakLoopAndContinue | 1 | 跳过当前循环并继续执行。
ContinueLoop | 2 | 跳过当前循环进入下一次循环。
Return | 3 | 返回。
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ResultToPropertyAttribute 类

声明属性的值表示命令执行后存入变量的变量名称。

继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.CommandsResultToPropertyAttribute

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ResultToPropertyAttribute : Attribute

ResultToPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ResultToPropertyAttribute | 初始化 ResultToPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | CommandScope | 用于指定这个结果值起作用的命令范围。
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class GetInfoCommand : Command
{
    [ResultRoProperty]
    public string ResultTo { get; set; }
}
参见

引用

GrapeCity.Forguncy.Commands 命名空间


ResultToPropertyAttribute 构造函数

初始化 ResultToPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ResultToPropertyAttribute()
参见

引用

ResultToPropertyAttribute 类
GrapeCity.Forguncy.Commands 命名空间


ResultToPropertyAttribute 属性

ResultToPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | CommandScope | 用于指定这个结果值起作用的命令范围。
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ResultToPropertyAttribute 类
GrapeCity.Forguncy.Commands 命名空间


ResultToPropertyAttribute.CommandScope 属性

活字格插件API文档

ResultToPropertyAttributeCommandScope 属性

用于指定这个结果值起作用的命令范围。

命名空间： GrapeCity.Forguncy.Commands
程序集： Forguncy.Commands (在 Forguncy.Commands.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CommandScope CommandScope { get; set; }

属性值

类型：CommandScope
参见

引用

ResultToPropertyAttribute 类
GrapeCity.Forguncy.Commands 命名空间


ResultToPropertyAttribute 方法

ResultToPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ResultToPropertyAttribute 类
GrapeCity.Forguncy.Commands 命名空间


GrapeCity.Forguncy.Plugin 命名空间

类
 | 类 | 说明
公共类 | BindingDataSourcePropertyAttribute | 标注属性的值为数据库绑定
公共类 | BoolPropertyAttribute | 用于配置布尔类型编辑框的设置，必须标注在 Bool 类型的属性上
公共类 | BuiltinEditorSetting | 活字格内置的属性编辑器。
公共类 | CellTypeStyleTemplateEditorSetting | 单元格主题样式选择器。如流程命令条类型使用的[动作按钮样式...]属性。
 | CellTypeStyleTemplatePropertyAttribute | 具有该类型的插件内部属性，其对应的编辑器可打开单元格主题样式选择对话框。
公共类 | CheckBoxEidtorSetting | 是/否类型的属性对应的编辑器，如[只读]属性。
 | ColorPropertyAttribute | 指定插件内部属性对应的编辑器为颜色选择框。 注意：使用颜色选择框作为属性值编辑器的属性，其值类型必须是String。
公共类 | ColorSelectorEditorSetting | 颜色类型的属性对应的编辑器，如[颜色]属性。
公共类 | ComboEditorSetting | 组合框。如菜单中使用的[主题]属性。
公共类 | ComboPropertyAttribute | 用于标注下拉选项属性编辑框，标注属性必须是字符串类型
公共类 | DoubleEditorSetting | 小数类型的属性对应的编辑器，如地图插件使用的[经度]或[纬度]属性。
公共类 | DoublePropertyAttribute | 用于配置浮点编辑框的设置，必须标注在 Double 类型的属性上
 | EditorSetting | 插件内部属性对应的编辑器设置。
公共类 | EnumValueEditorSetting | 枚举类型编辑器。如菜单中使用的[主题]属性。
公共类 | FileCopyInfo | 在导入活字格页面过程中，需要复制的文件信息。
公共类 | FileUploadInfo | 上传文件的信息，用于保存。
公共类 | FindResultItem | 记录查找项结果。
 | ForguncyErrorInfo | 运行页面时，内部检查出的错误或者提醒信息。
 | FormulaPropertyAttribute | 指定插件内部属性对应的编辑器为公式选择框。 注意：使用公式选择框作为属性值编辑器的属性，其值类型必须是object。
公共类 | FormulaSelectorEditorSetting | 公式类型的属性对应的编辑器，如[缺省值]属性。
公共类 | GenerateCellInfo | 用于IForceGenerateCell接口，强行生成单元格所需的信息。
公共类 | HyperlinkEditorSetting | 超链接编辑器，如果一个属性比较复杂，需要单独提供一个对话框去设置属性内部的值的时候会用到这个编辑器，如[编辑菜单项目...]属性。
公共类 | HyperlinkEdtiorPropertyAttribute | 用于标注通过超链接来编辑的属性
 | IconAttribute | 设置插件的图标。 该图标会应用到单元格类型下拉列表或命令选择下拉列表中，如果开启了单元格类型的显示模式，该图标也会应用到使用了该单元格类型的单元格上。
公共类 | ImageEditorSetting | 图片编辑器。如图片类型使用的[选择图片...]属性。
 | ImageValue | 一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
 | ImageValuePropertyAttribute | 一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
公共类 | IntEditorSetting | 整数类型的属性对应的编辑器，如单选按钮使用的[项目间距]属性。
公共类 | IntPropertyAttribute | 用于配置整数编辑框的设置，必须标注在 Int 类型的属性上
公共类 | ListPropertyAttribute | 用于标注列表类型的属性，被标注属性的类型必须是泛型List
公共类 | LocatedObject | 带坐标定位器的对象。
公共类 | LocatedObjectT | 带坐标定位器的特定类型的对象，如页面，命名等。
公共类 | LocationIndicator | 坐标定位器，查找引用时基于它可以帮助用户快速找到相关对象的位置。
公共类 | LocationIndicatorExtension | 坐标定位器扩展类。
公共类 | NameIndicator | 名称定位器，一种特定类型的坐标定位器。
公共类 | ObjectIndicator | 对象定位器，一种特定类型的坐标定位器。
公共类 | ObjectIndicatorT | 特定类型的对象定位器。
公共类 | ObjectListPropertyAttribute | 用于标注对象列表类型的属性，被标注的类型必须是IEnumerable<INamedObject>
 | OrderWeightAttribute | 插件或插件内部属性的权重, 权重越大位置越靠后。
公共类 | OrientationEidtorSetting | 排列方向类型的属性对应的编辑器，如单选按钮使用的[布局]属性。
公共类 | PageMetadataJsonIgnoreAttribute | 忽略运行页面时不需要的属性，例如只用于单元格类型预览的属性。
公共类 | PluginUtilities | 插件公用类。
公共类 | PropertyIndicator | 属性定位器，一种特定类型的坐标定位器。
公共类 | RadioEditorSetting | 单元按钮编辑框
公共类 | RadioGroupPropertyAttribute | 用于标注单项选择属性编辑框，标注属性必须是字符串类型
公共类 | SaveJsonIgnoreAttribute | 忽略不需要保存到文档的属性。
公共类 | SearchTagsAttribute | 控件搜索标记特性，加入了这个特性就可以在搜索框中快速搜索结果
公共类 | SelectorPropertyAttribute | 选项类标注基类
公共类 | ServerIgnorePropertyAttribute | 服务端忽略此属性
 | TableCheckInfo | 查找数据表的引用时返回的数据表的位置信息。
公共类 | TableComboTreeSelectorEditorSetting | 数据表选择器。如数据导航按钮中使用的[导航表]属性。
 | TextEditorSetting | 文本类型的属性对应的编辑器，如[水印]属性。
公共类 | TimeValueEditorSetting | 时间类型编辑器。如时间单元类型使用的[下拉框开始时间]属性。
公共类 | WindowsIgnorePropertyAttribute | 具有此标签的属性在Windows认证模式下将不会自动生成UI
接口
 | 接口 | 说明
公共接口 | IBindingInfo | 单元格的数据绑定信息，即一旦单元格绑定到A表的B字段,如果页面中存在A表，那么该单元格就会显示当前行的B字段的值。
公共接口 | IBuilderContextBase | 设计器上下文信息。
公共接口 | ICellInfoBase | 单元格的信息。
公共接口 | IColumnInfo | 数据表中的字段信息。
公共接口 | IEditorSettingsDataContext | 属性编辑器上下文信息。
公共接口 | IFileUploadContext | 上传的文件需要的上下文信息。
公共接口 | IForceGenerateCell | 在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
公共接口 | IFormulaReferObject | 公式对象。
公共接口 | IListViewInfo | 页面中的表格信息。
公共接口 | IListViewInfoDesigner | 页面中的表格信息。
公共接口 | ILocalServerInfo | 本地网站应用信息。
公共接口 | INeedUploadFileByUser | 如果插件使用过程中需要用户上传文件或者图片等，在保存或导入活字格文件时需给出相关的文件或图片信息，如存储文件夹路径，文件名等。
公共接口 | IPageInfo | 页面信息。
公共接口 | IPropertySearchable | 能够检索替换单元格类型和命令上的某些属性。
 | IReferenceFormula | 如果插件中引用了页面中的单元格，一旦被引用的单元格的位置发生了变化，如拖拽，那么插件中的相关单元格引用也应该被同步； 这种情况下就需要实现这个接口，而且，当查找页面中的单元格引用时，插件中的相关属性也会被查找出来。
 | IReferenceListView | 如果插件中引用了页面中的表格的名称，一旦表格重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找页面中的表格引用时，插件中的相关属性也会被查找出来。
 | IReferenceListViewColumn | 如果插件中引用了页面表格中列名，一旦表格中的列重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口。
 | IReferencePage | 如果插件中引用了页面名，一旦页面重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找页面的引用时，插件中的相关属性也会被查找出来。
 | IReferenceProcess | 如果插件中引用了流程的名称，一旦流程重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找页面中的流程引用时，插件中的相关属性也会被查找出来。
 | IReferenceTable | 如果插件中引用了数据表名或者字段名，一旦数据表或字段重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找数据表或字段的引用时，插件中的相关属性也会被查找出来。
公共接口 | IReferFiles | 此接口将返回当前对象关联的所有文件的物理文件路径。
公共接口 | ITableInfo | 数据表的信息。
公共接口 | IUserServiceInfo | 用户管理网站的信息。
公共接口 | IWorkflowInfo | 数据表中的工作流信息。
枚举
 | 枚举 | 说明
公共枚举 | AuthenticationMode | 认证模式。
公共枚举 | ForguncyErrorType | 运行页面时，系统内部会进行出错检查并显示在错误列表中，会根据出错类型显示不同的信息，并影响页面是否能够运行起来。
公共枚举 | ForguncyTableColumnType | 内建字段的值的类型。
公共枚举 | ForguncyTableType | 数据表的类型。
公共枚举 | TableColumnKind | 字段分类。


AuthenticationMode 枚举

认证模式。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum AuthenticationMode
成员
成员名称 | 值 | 说明
Windows | 1 | Windows域认证模式。
Forms | 3 | 普通登录认证模式。
SecurityProvider | 4 | 第三方集成认证模式。
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute 类

标注属性的值为数据库绑定
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginHyperlinkEdtiorPropertyAttribute
GrapeCity.Forguncy.PluginBindingDataSourcePropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class BindingDataSourcePropertyAttribute : HyperlinkEdtiorPropertyAttribute

BindingDataSourcePropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BindingDataSourcePropertyAttribute | 初始化 BindingDataSourcePropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Columns | 可选列，如果显示值和值不一样，用冒号分隔，多个列用“|”分隔，例如 value:值|text:显示文本
公共属性 | ColumnsDescription | 列描述，用冒号分隔，多个列用“|”分隔，例如 value:值列的描述信息|text:文本列的描述信息.
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | IsIdPidStructure | 表示是否是 Id-pid 树结构
公共属性 | TreeIdColumnName | 表示 Id-pid 树结构的Id列列名，只有IsIdPidStructure 为True时有效
公共属性 | TreePidColumnName | 表示 Id-pid 树结构的Pid列列名，只有IsIdPidStructure 为Tree时有效
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetBindingDataSourcePropertyItems | 可以通过重写此方法获取动态列
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute 构造函数

初始化 BindingDataSourcePropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public BindingDataSourcePropertyAttribute()
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute 属性

BindingDataSourcePropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Columns | 可选列，如果显示值和值不一样，用冒号分隔，多个列用“|”分隔，例如 value:值|text:显示文本
公共属性 | ColumnsDescription | 列描述，用冒号分隔，多个列用“|”分隔，例如 value:值列的描述信息|text:文本列的描述信息.
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | IsIdPidStructure | 表示是否是 Id-pid 树结构
公共属性 | TreeIdColumnName | 表示 Id-pid 树结构的Id列列名，只有IsIdPidStructure 为True时有效
公共属性 | TreePidColumnName | 表示 Id-pid 树结构的Pid列列名，只有IsIdPidStructure 为Tree时有效
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute.Columns 属性

活字格插件API文档

BindingDataSourcePropertyAttributeColumns 属性

可选列，如果显示值和值不一样，用冒号分隔，多个列用“|”分隔，例如 value:值|text:显示文本

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string Columns { get; set; }

属性值

类型：String
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute.ColumnsDescription 属性

活字格插件API文档

BindingDataSourcePropertyAttributeColumnsDescription 属性

列描述，用冒号分隔，多个列用“|”分隔，例如 value:值列的描述信息|text:文本列的描述信息.

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string ColumnsDescription { get; set; }

属性值

类型：String
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute.IsIdPidStructure 属性

活字格插件API文档

BindingDataSourcePropertyAttributeIsIdPidStructure 属性

表示是否是 Id-pid 树结构

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool IsIdPidStructure { get; set; }

属性值

类型：Boolean
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute.TreeIdColumnName 属性

活字格插件API文档

BindingDataSourcePropertyAttributeTreeIdColumnName 属性

表示 Id-pid 树结构的Id列列名，只有IsIdPidStructure 为True时有效

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string TreeIdColumnName { get; set; }

属性值

类型：String
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute.TreePidColumnName 属性

活字格插件API文档

BindingDataSourcePropertyAttributeTreePidColumnName 属性

表示 Id-pid 树结构的Pid列列名，只有IsIdPidStructure 为Tree时有效

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string TreePidColumnName { get; set; }

属性值

类型：String
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute 方法

BindingDataSourcePropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetBindingDataSourcePropertyItems | 可以通过重写此方法获取动态列
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BindingDataSourcePropertyAttribute.GetBindingDataSourcePropertyItems 方法

活字格插件API文档

BindingDataSourcePropertyAttributeGetBindingDataSourcePropertyItems 方法

可以通过重写此方法获取动态列

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual List<BindingDataSourcePropertyItem> GetBindingDataSourcePropertyItems()

返回值

类型：List BindingDataSourcePropertyItem
参见

引用

BindingDataSourcePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BoolPropertyAttribute 类

用于配置布尔类型编辑框的设置，必须标注在 Bool 类型的属性上
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginBoolPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class BoolPropertyAttribute : Attribute

BoolPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | BoolPropertyAttribute | 初始化 BoolPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IndentLevel | 缩进等级
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


BoolPropertyAttribute 构造函数

初始化 BoolPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public BoolPropertyAttribute()
参见

引用

BoolPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BoolPropertyAttribute 属性

BoolPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IndentLevel | 缩进等级
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

BoolPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BoolPropertyAttribute.IndentLevel 属性

活字格插件API文档

BoolPropertyAttributeIndentLevel 属性

缩进等级

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int IndentLevel { get; set; }

属性值

类型：Int32
参见

引用

BoolPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BoolPropertyAttribute 方法

BoolPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

BoolPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


BuiltinEditorSetting 类

活字格内置的属性编辑器。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
更多...

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class BuiltinEditorSetting : EditorSetting

BuiltinEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | BuiltinEditorSetting | 初始化 BuiltinEditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的数据模板名称。
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (重写 EditorSettingGetDataTemplate.)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginCellTypeStyleTemplateEditorSetting
GrapeCity.Forguncy.PluginCheckBoxEidtorSetting
GrapeCity.Forguncy.PluginColorSelectorEditorSetting
GrapeCity.Forguncy.PluginComboEditorSetting
GrapeCity.Forguncy.PluginDoubleEditorSetting
GrapeCity.Forguncy.PluginFormulaSelectorEditorSetting
GrapeCity.Forguncy.PluginImageEditorSetting
GrapeCity.Forguncy.PluginIntEditorSetting
GrapeCity.Forguncy.PluginOrientationEidtorSetting
GrapeCity.Forguncy.PluginRadioEditorSetting
GrapeCity.Forguncy.PluginTableComboTreeSelectorEditorSetting
GrapeCity.Forguncy.PluginTextEditorSetting
GrapeCity.Forguncy.PluginTimeValueEditorSetting


BuiltinEditorSetting 构造函数

初始化 BuiltinEditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected BuiltinEditorSetting()
参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


BuiltinEditorSetting 属性

BuiltinEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的数据模板名称。
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


BuiltinEditorSetting.TemplateName 属性

活字格插件API文档

BuiltinEditorSettingTemplateName 属性

内置的数据模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string TemplateName { get; protected set; }

属性值

类型：String
参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


BuiltinEditorSetting 方法

BuiltinEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (重写 EditorSettingGetDataTemplate.)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


BuiltinEditorSetting.GetDataTemplate 方法

活字格插件API文档

BuiltinEditorSettingGetDataTemplate 方法

根据模板名称找到对应的属性编辑器的数据模板。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override DataTemplate GetDataTemplate()

返回值

类型：DataTemplate
属性编辑器的数据模板。
示例

自定义属性编辑器的数据模板。

C#
复制
public class PassValueItemsEditorSetting : BuiltinEditorSetting
{
    public override DataTemplate GetDataTemplate()
    {
        var myResourceDictionary = new ResourceDictionary()
        {
            Source = new Uri("/PassListviewDataCommand;component/Control/Dictionary1.xaml", UriKind.RelativeOrAbsolute)
        };
        return myResourceDictionary["passValueItemsEditor"] as DataTemplate;
    }
}
参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplateEditorSetting 类

单元格主题样式选择器。如流程命令条类型使用的[动作按钮样式...]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginCellTypeStyleTemplateEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CellTypeStyleTemplateEditorSetting : BuiltinEditorSetting

CellTypeStyleTemplateEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CellTypeStyleTemplateEditorSetting | 初始化 CellTypeStyleTemplateEditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置单元格主题样式选择器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplateEditorSetting 构造函数

初始化 CellTypeStyleTemplateEditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeStyleTemplateEditorSetting()
参见

引用

CellTypeStyleTemplateEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplateEditorSetting 属性

CellTypeStyleTemplateEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置单元格主题样式选择器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

CellTypeStyleTemplateEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplateEditorSetting.TemplateName 属性

活字格插件API文档

CellTypeStyleTemplateEditorSettingTemplateName 属性

内置单元格主题样式选择器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

CellTypeStyleTemplateEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplateEditorSetting 方法

CellTypeStyleTemplateEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

CellTypeStyleTemplateEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplatePropertyAttribute 类

具有该类型的插件内部属性，其对应的编辑器可打开单元格主题样式选择对话框。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginCellTypeStyleTemplatePropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CellTypeStyleTemplatePropertyAttribute : Attribute

CellTypeStyleTemplatePropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CellTypeStyleTemplatePropertyAttribute | 初始化 CellTypeStyleTemplatePropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class MyCellTypeStyleTemplateCellType : CellType
{
    [CellTypeStyleTemplateProperty()]
    public string TemplateKey { get; set; }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplatePropertyAttribute 构造函数

初始化 CellTypeStyleTemplatePropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CellTypeStyleTemplatePropertyAttribute()
参见

引用

CellTypeStyleTemplatePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplatePropertyAttribute 属性

CellTypeStyleTemplatePropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

CellTypeStyleTemplatePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


CellTypeStyleTemplatePropertyAttribute 方法

CellTypeStyleTemplatePropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

CellTypeStyleTemplatePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


CheckBoxEidtorSetting 类

是/否类型的属性对应的编辑器，如[只读]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginCheckBoxEidtorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class CheckBoxEidtorSetting : BuiltinEditorSetting

CheckBoxEidtorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | CheckBoxEidtorSetting | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 内置的是否类型属性编辑器的标题默认不显示。 (重写 EditorSettingDefaultCaptionVisibility.)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的是/否类型属性编辑器的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


CheckBoxEidtorSetting 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public CheckBoxEidtorSetting()
参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CheckBoxEidtorSetting 属性

CheckBoxEidtorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 内置的是否类型属性编辑器的标题默认不显示。 (重写 EditorSettingDefaultCaptionVisibility.)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的是/否类型属性编辑器的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CheckBoxEidtorSetting.DefaultCaptionVisibility 属性

活字格插件API文档

CheckBoxEidtorSettingDefaultCaptionVisibility 属性

内置的是否类型属性编辑器的标题默认不显示。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override Visibility DefaultCaptionVisibility { get; }

属性值

类型：Visibility
参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CheckBoxEidtorSetting.TemplateName 属性

活字格插件API文档

CheckBoxEidtorSettingTemplateName 属性

内置的是/否类型属性编辑器的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


CheckBoxEidtorSetting 方法

CheckBoxEidtorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ColorPropertyAttribute 类

指定插件内部属性对应的编辑器为颜色选择框。

注意：使用颜色选择框作为属性值编辑器的属性，其值类型必须是String。

继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginColorPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ColorPropertyAttribute : Attribute

ColorPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ColorPropertyAttribute | 默认构造函数。
Top
属性
 | 名称 | 说明
公共属性 | SupportNoFill | 支持选择无填充
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class SetColorCommand : Command
{
    [ColorProperty]
    public object DefaultColor { get; set; }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ColorPropertyAttribute 构造函数

默认构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ColorPropertyAttribute()
参见

引用

ColorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ColorPropertyAttribute 属性

ColorPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | SupportNoFill | 支持选择无填充
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ColorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ColorPropertyAttribute.SupportNoFill 属性

活字格插件API文档

ColorPropertyAttributeSupportNoFill 属性

支持选择无填充

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool SupportNoFill { get; set; }

属性值

类型：Boolean
参见

引用

ColorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ColorPropertyAttribute 方法

ColorPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ColorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ColorSelectorEditorSetting 类

颜色类型的属性对应的编辑器，如[颜色]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginColorSelectorEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ColorSelectorEditorSetting : BuiltinEditorSetting

ColorSelectorEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ColorSelectorEditorSetting | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | SupportNoFill | 支持选择无填充
公共属性 | TemplateName | 内置颜色对象编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ColorSelectorEditorSetting 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ColorSelectorEditorSetting()
参见

引用

ColorSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ColorSelectorEditorSetting 属性

ColorSelectorEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | SupportNoFill | 支持选择无填充
公共属性 | TemplateName | 内置颜色对象编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

ColorSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ColorSelectorEditorSetting.SupportNoFill 属性

活字格插件API文档

ColorSelectorEditorSettingSupportNoFill 属性

支持选择无填充

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool SupportNoFill { get; set; }

属性值

类型：Boolean
参见

引用

ColorSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ColorSelectorEditorSetting.TemplateName 属性

活字格插件API文档

ColorSelectorEditorSettingTemplateName 属性

内置颜色对象编辑器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

ColorSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ColorSelectorEditorSetting 方法

ColorSelectorEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

ColorSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting 类

组合框。如菜单中使用的[主题]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginComboEditorSetting
GrapeCity.Forguncy.PluginEnumValueEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ComboEditorSetting : BuiltinEditorSetting

ComboEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ComboEditorSetting | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DisplayMember | 下拉项目文本属性。
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | IsReadOnly | 是否为只读。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | Source | 下拉项目集合。
公共属性 | TemplateName | 内置组合框对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | ValueMember | 下拉项目值属性。
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ComboEditorSetting(
    Object source,
    string displayMember = null,
    string valueMember = null
)

参数

source
类型：SystemObject
下拉项目集合。
displayMember (Optional)
类型：SystemString
下拉项目文本属性。
valueMember (Optional)
类型：SystemString
下拉项目值属性。
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting 属性

ComboEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DisplayMember | 下拉项目文本属性。
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | IsReadOnly | 是否为只读。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | Source | 下拉项目集合。
公共属性 | TemplateName | 内置组合框对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | ValueMember | 下拉项目值属性。
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting.DisplayMember 属性

活字格插件API文档

ComboEditorSettingDisplayMember 属性

下拉项目文本属性。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string DisplayMember { get; }

属性值

类型：String
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting.IsReadOnly 属性

活字格插件API文档

ComboEditorSettingIsReadOnly 属性

是否为只读。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool IsReadOnly { get; set; }

属性值

类型：Boolean
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting.Source 属性

活字格插件API文档

ComboEditorSettingSource 属性

下拉项目集合。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Source { get; }

属性值

类型：Object
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting.TemplateName 属性

活字格插件API文档

ComboEditorSettingTemplateName 属性

内置组合框对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting.ValueMember 属性

活字格插件API文档

ComboEditorSettingValueMember 属性

下拉项目值属性。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string ValueMember { get; }

属性值

类型：String
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboEditorSetting 方法

ComboEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ComboPropertyAttribute 类

用于标注下拉选项属性编辑框，标注属性必须是字符串类型
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginSelectorPropertyAttribute
GrapeCity.Forguncy.PluginComboPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ComboPropertyAttribute : SelectorPropertyAttribute

ComboPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ComboPropertyAttribute | 初始化 ComboPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DisplayList | 显示文本列表，多值用"|"分隔，可选配置，留空表示显示列表和值列表相同 (继承自 SelectorPropertyAttribute。)
公共属性 | IsSelectOnly | 表示只能从选项中选择或者可以编辑，可以编辑时DisplayList属性设置会被无视 (继承自 SelectorPropertyAttribute。)
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | ValueList | 值列表，多值用"|"分隔 (继承自 SelectorPropertyAttribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ComboPropertyAttribute 构造函数

初始化 ComboPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ComboPropertyAttribute()
参见

引用

ComboPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ComboPropertyAttribute 属性

ComboPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayList | 显示文本列表，多值用"|"分隔，可选配置，留空表示显示列表和值列表相同 (继承自 SelectorPropertyAttribute。)
公共属性 | IsSelectOnly | 表示只能从选项中选择或者可以编辑，可以编辑时DisplayList属性设置会被无视 (继承自 SelectorPropertyAttribute。)
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | ValueList | 值列表，多值用"|"分隔 (继承自 SelectorPropertyAttribute。)
Top
参见

引用

ComboPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ComboPropertyAttribute 方法

ComboPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ComboPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting 类

小数类型的属性对应的编辑器，如地图插件使用的[经度]或[纬度]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginDoubleEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class DoubleEditorSetting : BuiltinEditorSetting

DoubleEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DoubleEditorSetting | 初始化 DoubleEditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowNull | 是否允许清空整数类型的属性编辑器的值。
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Max | 整数类型的属性编辑器的最大值。
公共属性 | Min | 整数类型的属性编辑器的最小值。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的小数类型的属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
公共属性 | Watermark | 整数类型的属性编辑器的值为空时显示的水印。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting 构造函数

初始化 DoubleEditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public DoubleEditorSetting()
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting 属性

DoubleEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowNull | 是否允许清空整数类型的属性编辑器的值。
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Max | 整数类型的属性编辑器的最大值。
公共属性 | Min | 整数类型的属性编辑器的最小值。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的小数类型的属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
公共属性 | Watermark | 整数类型的属性编辑器的值为空时显示的水印。
Top
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting.AllowNull 属性

活字格插件API文档

DoubleEditorSettingAllowNull 属性

是否允许清空整数类型的属性编辑器的值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AllowNull { get; set; }

属性值

类型：Boolean
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting.Max 属性

活字格插件API文档

DoubleEditorSettingMax 属性

整数类型的属性编辑器的最大值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public double Max { get; set; }

属性值

类型：Double
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting.Min 属性

活字格插件API文档

DoubleEditorSettingMin 属性

整数类型的属性编辑器的最小值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public double Min { get; set; }

属性值

类型：Double
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting.TemplateName 属性

活字格插件API文档

DoubleEditorSettingTemplateName 属性

内置的小数类型的属性编辑器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting.Watermark 属性

活字格插件API文档

DoubleEditorSettingWatermark 属性

整数类型的属性编辑器的值为空时显示的水印。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Watermark { get; set; }

属性值

类型：String
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoubleEditorSetting 方法

DoubleEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute 类

用于配置浮点编辑框的设置，必须标注在 Double 类型的属性上
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginDoublePropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class DoublePropertyAttribute : Attribute

DoublePropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | DoublePropertyAttribute | 初始化 DoublePropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowNull | 是否可以设置为空，默认为否
公共属性 | Max | 最大值，默认为 double.MaxValue
公共属性 | Min | 最小值，默认为 double.MinValue
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | Watermark | 值为空时的替代文本
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute 构造函数

初始化 DoublePropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public DoublePropertyAttribute()
参见

引用

DoublePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute 属性

DoublePropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowNull | 是否可以设置为空，默认为否
公共属性 | Max | 最大值，默认为 double.MaxValue
公共属性 | Min | 最小值，默认为 double.MinValue
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | Watermark | 值为空时的替代文本
Top
参见

引用

DoublePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute.AllowNull 属性

活字格插件API文档

DoublePropertyAttributeAllowNull 属性

是否可以设置为空，默认为否

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AllowNull { get; set; }

属性值

类型：Boolean
参见

引用

DoublePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute.Max 属性

活字格插件API文档

DoublePropertyAttributeMax 属性

最大值，默认为 double.MaxValue

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public double Max { get; set; }

属性值

类型：Double
参见

引用

DoublePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute.Min 属性

活字格插件API文档

DoublePropertyAttributeMin 属性

最小值，默认为 double.MinValue

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public double Min { get; set; }

属性值

类型：Double
参见

引用

DoublePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute.Watermark 属性

活字格插件API文档

DoublePropertyAttributeWatermark 属性

值为空时的替代文本

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string Watermark { get; set; }

属性值

类型：String
参见

引用

DoublePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


DoublePropertyAttribute 方法

DoublePropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

DoublePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting 类

插件内部属性对应的编辑器设置。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class EditorSetting : INotifyPropertyChanged

EditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | EditorSetting | 初始化 EditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。
公共属性 | IsEnabled | 属性编辑器是否可用。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
公共属性 | Visibility | 属性编辑器是否可见。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetDataTemplate | 属性编辑器对应的数据模板。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串
公共方法 | Validate | 插件内部属性编辑器的校验处理。
Top
示例
C#
复制
public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
{
    return new ComboEditorSetting(new List<string>()  { "aaa", "bbb", "ccc"});
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


EditorSetting 构造函数

初始化 EditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected EditorSetting()
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting 属性

EditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。
公共属性 | IsEnabled | 属性编辑器是否可用。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
公共属性 | Visibility | 属性编辑器是否可见。
Top
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting.DefaultCaptionVisibility 属性

活字格插件API文档

EditorSettingDefaultCaptionVisibility 属性

命令插件中的属性编辑器中的属性名是否显示。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual Visibility DefaultCaptionVisibility { get; }

属性值

类型：Visibility
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting.IsEnabled 属性

活字格插件API文档

EditorSettingIsEnabled 属性

属性编辑器是否可用。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool IsEnabled { get; set; }

属性值

类型：Boolean
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting.Orientation 属性

活字格插件API文档

EditorSettingOrientation 属性

命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual Orientation Orientation { get; }

属性值

类型：Orientation
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting.Visibility 属性

活字格插件API文档

EditorSettingVisibility 属性

属性编辑器是否可见。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Visibility Visibility { get; set; }

属性值

类型：Visibility
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting 方法

EditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetDataTemplate | 属性编辑器对应的数据模板。
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串
公共方法 | Validate | 插件内部属性编辑器的校验处理。
Top
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting.GetDataTemplate 方法

活字格插件API文档

EditorSettingGetDataTemplate 方法

属性编辑器对应的数据模板。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract DataTemplate GetDataTemplate()

返回值

类型：DataTemplate
属性编辑器对应的数据模板。
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting.UpdateDisplayName 方法

活字格插件API文档

EditorSettingUpdateDisplayName 方法

返回属性名称的后缀字符串

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string UpdateDisplayName(
    string propertyDisplayName
)

参数

propertyDisplayName
类型：SystemString

返回值

类型：String
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EditorSetting.Validate 方法

活字格插件API文档

EditorSettingValidate 方法

插件内部属性编辑器的校验处理。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool Validate(
    Object propValue
)

参数

propValue
类型：SystemObject
属性的值。

返回值

类型：Boolean
校验通过返回True，否则返回False。
参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EnumValueEditorSetting 类

枚举类型编辑器。如菜单中使用的[主题]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginComboEditorSetting
GrapeCity.Forguncy.PluginEnumValueEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class EnumValueEditorSetting : ComboEditorSetting

EnumValueEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EnumValueEditorSetting | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DisplayMember | 下拉项目文本属性。 (继承自 ComboEditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | IsReadOnly | 是否为只读。 (继承自 ComboEditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | Source | 下拉项目集合。 (继承自 ComboEditorSetting。)
公共属性 | TemplateName | 内置组合框对应的模板名称。 (继承自 ComboEditorSetting。)
公共属性 | ValueMember | 下拉项目值属性。 (继承自 ComboEditorSetting。)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


EnumValueEditorSetting 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public EnumValueEditorSetting(
    Type enumType
)

参数

enumType
类型：SystemType
枚举类型。
参见

引用

EnumValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EnumValueEditorSetting 属性

EnumValueEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DisplayMember | 下拉项目文本属性。 (继承自 ComboEditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | IsReadOnly | 是否为只读。 (继承自 ComboEditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | Source | 下拉项目集合。 (继承自 ComboEditorSetting。)
公共属性 | TemplateName | 内置组合框对应的模板名称。 (继承自 ComboEditorSetting。)
公共属性 | ValueMember | 下拉项目值属性。 (继承自 ComboEditorSetting。)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

EnumValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


EnumValueEditorSetting 方法

EnumValueEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

EnumValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo 类

在导入活字格页面过程中，需要复制的文件信息。
继承层次
SystemObject
GrapeCity.Forguncy.PluginFileCopyInfo

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class FileCopyInfo

FileCopyInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FileCopyInfo | 初始化 FileCopyInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | SourceFileFolder | 原文件所在文件夹路径。
公共属性 | SourceFileName | 原文件名。
公共属性 | TargetFileFolder | 目标文件所在文件夹路径。
公共属性 | TargetFileName | 目标文件名。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo 构造函数

初始化 FileCopyInfo 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public FileCopyInfo()
参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo 属性

FileCopyInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | SourceFileFolder | 原文件所在文件夹路径。
公共属性 | SourceFileName | 原文件名。
公共属性 | TargetFileFolder | 目标文件所在文件夹路径。
公共属性 | TargetFileName | 目标文件名。
Top
参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo.SourceFileFolder 属性

活字格插件API文档

FileCopyInfoSourceFileFolder 属性

原文件所在文件夹路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string SourceFileFolder { get; set; }

属性值

类型：String
参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo.SourceFileName 属性

活字格插件API文档

FileCopyInfoSourceFileName 属性

原文件名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string SourceFileName { get; set; }

属性值

类型：String
参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo.TargetFileFolder 属性

活字格插件API文档

FileCopyInfoTargetFileFolder 属性

目标文件所在文件夹路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string TargetFileFolder { get; set; }

属性值

类型：String
参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo.TargetFileName 属性

活字格插件API文档

FileCopyInfoTargetFileName 属性

目标文件名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string TargetFileName { get; set; }

属性值

类型：String
参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileCopyInfo 方法

FileCopyInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileUploadInfo 类

上传文件的信息，用于保存。
继承层次
SystemObject
GrapeCity.Forguncy.PluginFileUploadInfo

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class FileUploadInfo

FileUploadInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FileUploadInfo | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | AllUsedUploadFilePaths | 所有上传文件的名称列表。
公共属性 | UploadFileFolder | 上传文件所在的文件夹路径。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


FileUploadInfo 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public FileUploadInfo()
参见

引用

FileUploadInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileUploadInfo 属性

FileUploadInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllUsedUploadFilePaths | 所有上传文件的名称列表。
公共属性 | UploadFileFolder | 上传文件所在的文件夹路径。
Top
参见

引用

FileUploadInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileUploadInfo.AllUsedUploadFilePaths 属性

活字格插件API文档

FileUploadInfoAllUsedUploadFilePaths 属性

所有上传文件的名称列表。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<string> AllUsedUploadFilePaths { get; }

属性值

类型：List String
参见

引用

FileUploadInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileUploadInfo.UploadFileFolder 属性

活字格插件API文档

FileUploadInfoUploadFileFolder 属性

上传文件所在的文件夹路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string UploadFileFolder { get; set; }

属性值

类型：String
参见

引用

FileUploadInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FileUploadInfo 方法

FileUploadInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

FileUploadInfo 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem 类

记录查找项结果。
继承层次
SystemObject
GrapeCity.Forguncy.PluginFindResultItem

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class FindResultItem

FindResultItem 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FindResultItem | 初始化 FindResultItem 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Location | 查找某一项的位置信息。
公共属性 | Value | 查找某一项的值。
Top
方法
 | 名称 | 说明
公共方法 | Equals | 确定指定对象是否等于当前对象。 (重写 ObjectEquals(Object).)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | 作为默认哈希函数。 (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsEquals | 是否是同一对象的引用。
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


FindResultItem 构造函数

初始化 FindResultItem 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public FindResultItem()
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem 属性

FindResultItem 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Location | 查找某一项的位置信息。
公共属性 | Value | 查找某一项的值。
Top
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem.Location 属性

活字格插件API文档

FindResultItemLocation 属性

查找某一项的位置信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public LocationIndicator Location { get; set; }

属性值

类型：LocationIndicator
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem.Value 属性

活字格插件API文档

FindResultItemValue 属性

查找某一项的值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Value { get; set; }

属性值

类型：String
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem 方法

FindResultItem 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | 确定指定对象是否等于当前对象。 (重写 ObjectEquals(Object).)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | 作为默认哈希函数。 (重写 ObjectGetHashCode.)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsEquals | 是否是同一对象的引用。
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem.Equals 方法

活字格插件API文档

FindResultItemEquals 方法

确定指定对象是否等于当前对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override bool Equals(
    Object obj
)

参数

obj
类型：SystemObject
要与当前对象进行比较的对象。

返回值

类型：Boolean
如果指定的对象等于当前对象，则为 true；否则为 false。
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem.GetHashCode 方法

活字格插件API文档

FindResultItemGetHashCode 方法

作为默认哈希函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override int GetHashCode()

返回值

类型：Int32
当前对象的哈希值。
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


FindResultItem.IsEquals 方法

活字格插件API文档

FindResultItemIsEquals 方法

是否是同一对象的引用。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool IsEquals(
    Object obj
)

参数

obj
类型：SystemObject

返回值

类型：Boolean
参见

引用

FindResultItem 类
GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorInfo 类

运行页面时，内部检查出的错误或者提醒信息。
继承层次
SystemObject
GrapeCity.Forguncy.PluginForguncyErrorInfo

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ForguncyErrorInfo

ForguncyErrorInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ForguncyErrorInfo | 初始化 ForguncyErrorInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ErrorType | 错误类型：错误或者提醒。
公共属性 | Message | 错误信息。
公共属性 | SubLocations | 错误的详细位置信息。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class SetFocusCommandDesigner : CommandDesigner<SetFocusCommand>,ICommandChecker
{
    [FormulaProperty]
    public object TargetCell { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCommandErrors(IBuilderCommandContext context)
    {
        if(TargetCell == null)
        {
            yield return new ForguncyErrorInfo()
           {
               Message = "Target cell cannot be null.",
               ErrorType = ForguncyErrorType.Error
           };
        }
    }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorInfo 构造函数

初始化 ForguncyErrorInfo 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ForguncyErrorInfo()
参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorInfo 属性

ForguncyErrorInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ErrorType | 错误类型：错误或者提醒。
公共属性 | Message | 错误信息。
公共属性 | SubLocations | 错误的详细位置信息。
Top
参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorInfo.ErrorType 属性

活字格插件API文档

ForguncyErrorInfoErrorType 属性

错误类型：错误或者提醒。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ForguncyErrorType ErrorType { get; set; }

属性值

类型：ForguncyErrorType
参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorInfo.Message 属性

活字格插件API文档

ForguncyErrorInfoMessage 属性

错误信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Message { get; set; }

属性值

类型：String
参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorInfo.SubLocations 属性

活字格插件API文档

ForguncyErrorInfoSubLocations 属性

错误的详细位置信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<string> SubLocations { get; set; }

属性值

类型：List String
参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorInfo 方法

ForguncyErrorInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


ForguncyErrorType 枚举

运行页面时，系统内部会进行出错检查并显示在错误列表中，会根据出错类型显示不同的信息，并影响页面是否能够运行起来。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyErrorType
成员
成员名称 | 值 | 说明
Error | 0 | 出错信息类型：错误，会导致页面运行不了。
Warning | 1 | 出错信息类型：提醒，页面可以运行，但是出错部分功能可能会有问题。
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ForguncyTableColumnType 枚举

内建字段的值的类型。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyTableColumnType
成员
成员名称 | 值 | 说明
Text | 0 | 文本。
Int | 1 | 整数。
Decimel | 2 | 小数。
DateTime | 3 | 日期。
Time | 4 | 时间。
Bool | 5 | 是/否。
User | 6 | 用户。
Image | 7 | 图片。
Attachment | 8 | 附件。
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ForguncyTableType 枚举

数据表的类型。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum ForguncyTableType
成员
成员名称 | 值 | 说明
BuiltInTable | 0 | 内建表。
LinkedTable | 1 | 外联表。
BuiltInCopyExternalTable | 2 | 外联表副本。
BuiltInCustomView | 3 | 内建表视图。
BuiltInUserInfoView | 4 | 用户信息视图。
BuiltInWorkflowHistoryView | 5 | 工作流历史视图。
LinkedView | 6 | 外联表视图。
BuiltInProcessView | 7 | 流程视图。
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute 类

指定插件内部属性对应的编辑器为公式选择框。

注意：使用公式选择框作为属性值编辑器的属性，其值类型必须是object。

继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginFormulaPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class FormulaPropertyAttribute : Attribute

FormulaPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FormulaPropertyAttribute | 默认构造函数。
公共方法 | FormulaPropertyAttribute(Boolean) | 构造函数，指定其公式选择框是否只能选择单元格而不支持选择单元格区域或者函数。
Top
属性
 | 名称 | 说明
公共属性 | AcceptsReturn | 是否支持输入多行
公共属性 | ContextVariables | 此公式可用的上下文变量，多个用“|”分隔，描述用“：”分隔
公共属性 | OnlySupportCell | 公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class SetFocusCommand : Command
{
    [FormulaProperty(true)]
    public object TargetCell { get; set; }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute 构造函数

重载列表
 | 名称 | 说明
公共方法 | FormulaPropertyAttribute | 默认构造函数。
公共方法 | FormulaPropertyAttribute(Boolean) | 构造函数，指定其公式选择框是否只能选择单元格而不支持选择单元格区域或者函数。
Top
参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute 构造函数

默认构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public FormulaPropertyAttribute()
参见

引用

FormulaPropertyAttribute 类
FormulaPropertyAttribute 重载
GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute 构造函数 (Boolean)

构造函数，指定其公式选择框是否只能选择单元格而不支持选择单元格区域或者函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public FormulaPropertyAttribute(
    bool onlySupportCell
)

参数

onlySupportCell
类型：SystemBoolean
是否只支持单元格。
参见

引用

FormulaPropertyAttribute 类
FormulaPropertyAttribute 重载
GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute 属性

FormulaPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptsReturn | 是否支持输入多行
公共属性 | ContextVariables | 此公式可用的上下文变量，多个用“|”分隔，描述用“：”分隔
公共属性 | OnlySupportCell | 公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute.AcceptsReturn 属性

活字格插件API文档

FormulaPropertyAttributeAcceptsReturn 属性

是否支持输入多行

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AcceptsReturn { get; set; }

属性值

类型：Boolean
参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute.ContextVariables 属性

活字格插件API文档

FormulaPropertyAttributeContextVariables 属性

此公式可用的上下文变量，多个用“|”分隔，描述用“：”分隔

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string ContextVariables { get; set; }

属性值

类型：String
参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute.OnlySupportCell 属性

活字格插件API文档

FormulaPropertyAttributeOnlySupportCell 属性

公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool OnlySupportCell { get; set; }

属性值

类型：Boolean
参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaPropertyAttribute 方法

FormulaPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting 类

公式类型的属性对应的编辑器，如[缺省值]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginFormulaSelectorEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class FormulaSelectorEditorSetting : BuiltinEditorSetting

FormulaSelectorEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FormulaSelectorEditorSetting | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | AcceptsReturn | 是否支持输入多行
公共属性 | ContextVariables | 此公式可用的上下文变量，多个用“|”分隔，描述用“：”分隔
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | OnlySupportCell | 是否只能选择单元格，不支持单元格区域或者函数。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | ShowSheetName | 显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
公共属性 | TemplateName | 内置公式对象编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public FormulaSelectorEditorSetting(
    bool onlySupportCell
)

参数

onlySupportCell
类型：SystemBoolean
是否只能选择单元格。
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting 属性

FormulaSelectorEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AcceptsReturn | 是否支持输入多行
公共属性 | ContextVariables | 此公式可用的上下文变量，多个用“|”分隔，描述用“：”分隔
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | OnlySupportCell | 是否只能选择单元格，不支持单元格区域或者函数。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | ShowSheetName | 显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
公共属性 | TemplateName | 内置公式对象编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting.AcceptsReturn 属性

活字格插件API文档

FormulaSelectorEditorSettingAcceptsReturn 属性

是否支持输入多行

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AcceptsReturn { get; set; }

属性值

类型：Boolean
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting.ContextVariables 属性

活字格插件API文档

FormulaSelectorEditorSettingContextVariables 属性

此公式可用的上下文变量，多个用“|”分隔，描述用“：”分隔

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string ContextVariables { get; set; }

属性值

类型：String
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting.OnlySupportCell 属性

活字格插件API文档

FormulaSelectorEditorSettingOnlySupportCell 属性

是否只能选择单元格，不支持单元格区域或者函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool OnlySupportCell { get; }

属性值

类型：Boolean
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting.ShowSheetName 属性

活字格插件API文档

FormulaSelectorEditorSettingShowSheetName 属性

显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool ShowSheetName { get; set; }

属性值

类型：Boolean
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting.TemplateName 属性

活字格插件API文档

FormulaSelectorEditorSettingTemplateName 属性

内置公式对象编辑器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


FormulaSelectorEditorSetting 方法

FormulaSelectorEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


GenerateCellInfo 类

用于IForceGenerateCell接口，强行生成单元格所需的信息。
继承层次
SystemObject
GrapeCity.Forguncy.PluginGenerateCellInfo

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class GenerateCellInfo

GenerateCellInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GenerateCellInfo | 初始化 GenerateCellInfo 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ColumnIndex | 单元格列索引，从0开始计算。
公共属性 | PageName | 单元格所在页面的名字。
公共属性 | RowIndex | 单元格行索引，从0开始计算。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


GenerateCellInfo 构造函数

初始化 GenerateCellInfo 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public GenerateCellInfo()
参见

引用

GenerateCellInfo 类
GrapeCity.Forguncy.Plugin 命名空间


GenerateCellInfo 属性

GenerateCellInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnIndex | 单元格列索引，从0开始计算。
公共属性 | PageName | 单元格所在页面的名字。
公共属性 | RowIndex | 单元格行索引，从0开始计算。
Top
参见

引用

GenerateCellInfo 类
GrapeCity.Forguncy.Plugin 命名空间


GenerateCellInfo.ColumnIndex 属性

活字格插件API文档

GenerateCellInfoColumnIndex 属性

单元格列索引，从0开始计算。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int ColumnIndex { get; set; }

属性值

类型：Int32
参见

引用

GenerateCellInfo 类
GrapeCity.Forguncy.Plugin 命名空间


GenerateCellInfo.PageName 属性

活字格插件API文档

GenerateCellInfoPageName 属性

单元格所在页面的名字。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string PageName { get; set; }

属性值

类型：String
参见

引用

GenerateCellInfo 类
GrapeCity.Forguncy.Plugin 命名空间


GenerateCellInfo.RowIndex 属性

活字格插件API文档

GenerateCellInfoRowIndex 属性

单元格行索引，从0开始计算。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int RowIndex { get; set; }

属性值

类型：Int32
参见

引用

GenerateCellInfo 类
GrapeCity.Forguncy.Plugin 命名空间


GenerateCellInfo 方法

GenerateCellInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GenerateCellInfo 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEditorSetting 类

超链接编辑器，如果一个属性比较复杂，需要单独提供一个对话框去设置属性内部的值的时候会用到这个编辑器，如[编辑菜单项目...]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
HyperlinkBaseEditorSetting
GrapeCity.Forguncy.PluginHyperlinkEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class HyperlinkEditorSetting : HyperlinkBaseEditorSetting

HyperlinkEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | HyperlinkEditorSetting | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | Command | 点击超链接要执行的命令。
公共属性 | DefaultCaptionVisibility | 内置的超链接编辑器的标题默认不显示。 (重写 EditorSettingDefaultCaptionVisibility.)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的超链接属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEditorSetting 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public HyperlinkEditorSetting(
    ICommand command
)

参数

command
类型：System.Windows.InputICommand
点击超链接要执行的命令。
参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEditorSetting 属性

HyperlinkEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Command | 点击超链接要执行的命令。
公共属性 | DefaultCaptionVisibility | 内置的超链接编辑器的标题默认不显示。 (重写 EditorSettingDefaultCaptionVisibility.)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的超链接属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEditorSetting.Command 属性

活字格插件API文档

HyperlinkEditorSettingCommand 属性

点击超链接要执行的命令。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ICommand Command { get; }

属性值

类型：ICommand
参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEditorSetting.DefaultCaptionVisibility 属性

活字格插件API文档

HyperlinkEditorSettingDefaultCaptionVisibility 属性

内置的超链接编辑器的标题默认不显示。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override Visibility DefaultCaptionVisibility { get; }

属性值

类型：Visibility
参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEditorSetting.TemplateName 属性

活字格插件API文档

HyperlinkEditorSettingTemplateName 属性

内置的超链接属性编辑器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEditorSetting 方法

HyperlinkEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEdtiorPropertyAttribute 类

用于标注通过超链接来编辑的属性
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginHyperlinkEdtiorPropertyAttribute
GrapeCity.Forguncy.CommandsCustomCommandObjectAttribute
GrapeCity.Forguncy.PluginBindingDataSourcePropertyAttribute
GrapeCity.Forguncy.PluginListPropertyAttribute
GrapeCity.Forguncy.PluginObjectListPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class HyperlinkEdtiorPropertyAttribute : Attribute

HyperlinkEdtiorPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | HyperlinkEdtiorPropertyAttribute | 初始化 HyperlinkEdtiorPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEdtiorPropertyAttribute 构造函数

初始化 HyperlinkEdtiorPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected HyperlinkEdtiorPropertyAttribute()
参见

引用

HyperlinkEdtiorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEdtiorPropertyAttribute 属性

HyperlinkEdtiorPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

HyperlinkEdtiorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEdtiorPropertyAttribute.IndentLevel 属性

活字格插件API文档

HyperlinkEdtiorPropertyAttributeIndentLevel 属性

表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int IndentLevel { get; set; }

属性值

类型：Int32
参见

引用

HyperlinkEdtiorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


HyperlinkEdtiorPropertyAttribute 方法

HyperlinkEdtiorPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

HyperlinkEdtiorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo 接口

单元格的数据绑定信息，即一旦单元格绑定到A表的B字段,如果页面中存在A表，那么该单元格就会显示当前行的B字段的值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IBindingInfo

IBindingInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnName | 绑定的数据列名。
公共属性 | TableName | 绑定的数据表名。
Top
方法
 | 名称 | 说明
公共方法 | GetExtendColumnName | 表中扩展列的显示名。例如，日期列的年、月、日信息。
公共方法 | GetLastColumnName | 如果有多级绑定的话，返回绑定信息中的最后一个数据列名，否则返回当前绑定级别的数据列名。
公共方法 | GetLastTableName | 如果有多级绑定的话，返回绑定信息中的最后一个数据表名，否则返回当前绑定级别的数据表名。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo 属性

IBindingInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnName | 绑定的数据列名。
公共属性 | TableName | 绑定的数据表名。
Top
参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo.ColumnName 属性

活字格插件API文档

IBindingInfoColumnName 属性

绑定的数据列名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ColumnName { get; }

属性值

类型：String
参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo.TableName 属性

活字格插件API文档

IBindingInfoTableName 属性

绑定的数据表名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string TableName { get; }

属性值

类型：String
参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo 方法

IBindingInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetExtendColumnName | 表中扩展列的显示名。例如，日期列的年、月、日信息。
公共方法 | GetLastColumnName | 如果有多级绑定的话，返回绑定信息中的最后一个数据列名，否则返回当前绑定级别的数据列名。
公共方法 | GetLastTableName | 如果有多级绑定的话，返回绑定信息中的最后一个数据表名，否则返回当前绑定级别的数据表名。
Top
参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo.GetExtendColumnName 方法

活字格插件API文档

IBindingInfoGetExtendColumnName 方法

表中扩展列的显示名。例如，日期列的年、月、日信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetExtendColumnName()

返回值

类型：String
扩展列的显示名。
参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo.GetLastColumnName 方法

活字格插件API文档

IBindingInfoGetLastColumnName 方法

如果有多级绑定的话，返回绑定信息中的最后一个数据列名，否则返回当前绑定级别的数据列名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetLastColumnName()

返回值

类型：String
返回绑定信息中的最后一个数据列名。
参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IBindingInfo.GetLastTableName 方法

活字格插件API文档

IBindingInfoGetLastTableName 方法

如果有多级绑定的话，返回绑定信息中的最后一个数据表名，否则返回当前绑定级别的数据表名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetLastTableName()

返回值

类型：String
返回绑定信息中的最后一个数据表名。
参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase 接口

设计器上下文信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IBuilderContextBase

IBuilderContextBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AuthenticationMode | 获取当前工程的认证模式。
公共属性 | LocalServerInfo | 本地网站应用信息。
公共属性 | PageName | 获取当前所在页面名称。
 | UserServiceInfo | 获取用户管理网站的信息。
Top
方法
 | 名称 | 说明
 | EnumAllListViewInfos | 获取某个页面所有的表格信息。
 | EnumAllPageInfos | 获取所有的页面信息。
 | EnumAllTableInfos | 获取所有的数据表信息。
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase 属性

IBuilderContextBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AuthenticationMode | 获取当前工程的认证模式。
公共属性 | LocalServerInfo | 本地网站应用信息。
公共属性 | PageName | 获取当前所在页面名称。
 | UserServiceInfo | 获取用户管理网站的信息。
Top
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.AuthenticationMode 属性

活字格插件API文档

IBuilderContextBaseAuthenticationMode 属性

获取当前工程的认证模式。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
AuthenticationMode AuthenticationMode { get; }

属性值

类型：AuthenticationMode
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.LocalServerInfo 属性

活字格插件API文档

IBuilderContextBaseLocalServerInfo 属性

本地网站应用信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ILocalServerInfo LocalServerInfo { get; }

属性值

类型：ILocalServerInfo
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.PageName 属性

活字格插件API文档

IBuilderContextBasePageName 属性

获取当前所在页面名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string PageName { get; }

属性值

类型：String
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.UserServiceInfo 属性

活字格插件API文档

IBuilderContextBaseUserServiceInfo 属性

获取用户管理网站的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IUserServiceInfo UserServiceInfo { get; }

属性值

类型：IUserServiceInfo
示例
C#
复制
public class MyUserSelectorCellTypeDesigner : CellTypeDesigner<MyUserSelectorCellType>
{
    public string Role { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "Role")
        {
            return new ComboEditorSetting(builderContext.UserServiceInfo.AllRoles);
        }
    }
}
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase 方法

IBuilderContextBase 类型公开以下成员。

方法
 | 名称 | 说明
 | EnumAllListViewInfos | 获取某个页面所有的表格信息。
 | EnumAllPageInfos | 获取所有的页面信息。
 | EnumAllTableInfos | 获取所有的数据表信息。
公共方法 | GetBrush | 从颜色字符串获取一个WPF的画笔（Brush）。
Top
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.EnumAllListViewInfos 方法

活字格插件API文档

IBuilderContextBaseEnumAllListViewInfos 方法

获取某个页面所有的表格信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<IListViewInfoDesigner> EnumAllListViewInfos(
    string pageName
)

参数

pageName
类型：SystemString
页面名，如果为空即表示当前所在页面。

返回值

类型：IEnumerable IListViewInfoDesigner
表格集合
示例
C#
复制
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>
{
    public string ListViewName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "ListViewName")
        {
            return new ComboEditorSetting(new List<string> (builderContext.EnumAllListViewInfos(null).Select(i=>i.ListViewName)));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.EnumAllPageInfos 方法

活字格插件API文档

IBuilderContextBaseEnumAllPageInfos 方法

获取所有的页面信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<IPageInfo> EnumAllPageInfos()

返回值

类型：IEnumerable IPageInfo
页面集合。
示例
C#
复制
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>
{
    public string NavigatePageName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "NavigatePageName")
        {
            return new ComboEditorSetting(builderContext.EnumAllPageInfos().Select(p => p.PageName));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.EnumAllTableInfos 方法

活字格插件API文档

IBuilderContextBaseEnumAllTableInfos 方法

获取所有的数据表信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<ITableInfo> EnumAllTableInfos()

返回值

类型：IEnumerable ITableInfo
数据表集合
示例
C#
复制
public class WorkflowCommandDesigner : CommandDesigner<WorkflowCommand>
{
    public string TableName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "TableName")
        {
            return new ComboEditorSetting(builderContext.EnumAllTableInfos().Where(t => t.WorkflowInfo != null && t.WorkflowInfo.IsEnabled).Select(t => t.TableName));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IBuilderContextBase.GetBrush 方法

活字格插件API文档

IBuilderContextBaseGetBrush 方法

从颜色字符串获取一个WPF的画笔（Brush）。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Brush GetBrush(
    string colorStr
)

参数

colorStr
类型：SystemString
颜色字符串

返回值

类型：Brush
WPF的画笔
参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase 接口

单元格的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ICellInfoBase

ICellInfoBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindingInfo | 单元格的数据绑定信息。
公共属性 | ColumnIndex | 获取单元格所在列的索引。
公共属性 | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。
公共属性 | ListViewInfo | 单元格所在表格的信息。
公共属性 | PageName | 单元格所在的页面名称。
公共属性 | RowIndex | 获取单元格所在行的索引
公共属性 | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。
Top
方法
 | 名称 | 说明
公共方法 | GetFormulaReferObject | 返回单元格对应的公式对象。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase 属性

ICellInfoBase 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BindingInfo | 单元格的数据绑定信息。
公共属性 | ColumnIndex | 获取单元格所在列的索引。
公共属性 | ColumnSpan | 获取单元格上合并列的数量，没有合并时返回1。
公共属性 | ListViewInfo | 单元格所在表格的信息。
公共属性 | PageName | 单元格所在的页面名称。
公共属性 | RowIndex | 获取单元格所在行的索引
公共属性 | RowSpan | 获取单元格上合并行的数量，没有合并时返回1。
Top
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.BindingInfo 属性

活字格插件API文档

ICellInfoBaseBindingInfo 属性

单元格的数据绑定信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IBindingInfo BindingInfo { get; }

属性值

类型：IBindingInfo
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.ColumnIndex 属性

活字格插件API文档

ICellInfoBaseColumnIndex 属性

获取单元格所在列的索引。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
int ColumnIndex { get; }

属性值

类型：Int32
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.ColumnSpan 属性

活字格插件API文档

ICellInfoBaseColumnSpan 属性

获取单元格上合并列的数量，没有合并时返回1。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
int ColumnSpan { get; }

属性值

类型：Int32
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.ListViewInfo 属性

活字格插件API文档

ICellInfoBaseListViewInfo 属性

单元格所在表格的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IListViewInfo ListViewInfo { get; }

属性值

类型：IListViewInfo
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.PageName 属性

活字格插件API文档

ICellInfoBasePageName 属性

单元格所在的页面名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string PageName { get; }

属性值

类型：String
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.RowIndex 属性

活字格插件API文档

ICellInfoBaseRowIndex 属性

获取单元格所在行的索引

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
int RowIndex { get; }

属性值

类型：Int32
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.RowSpan 属性

活字格插件API文档

ICellInfoBaseRowSpan 属性

获取单元格上合并行的数量，没有合并时返回1。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
int RowSpan { get; }

属性值

类型：Int32
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase 方法

ICellInfoBase 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetFormulaReferObject | 返回单元格对应的公式对象。
Top
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


ICellInfoBase.GetFormulaReferObject 方法

活字格插件API文档

ICellInfoBaseGetFormulaReferObject 方法

返回单元格对应的公式对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IFormulaReferObject GetFormulaReferObject(
    bool rowRelative = true,
    bool columnRelative = true
)

参数

rowRelative (Optional)
类型：SystemBoolean
columnRelative (Optional)
类型：SystemBoolean

返回值

类型：IFormulaReferObject
参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


IColumnInfo 接口

数据表中的字段信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IColumnInfo

IColumnInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnKind | 字段的分类：普通字段，公式字段还是统计字段。
公共属性 | ColumnName | 字段名称。
公共属性 | ColumnType | 字段中值的类型。
公共属性 | DisplayName | 别名。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IColumnInfo 属性

IColumnInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnKind | 字段的分类：普通字段，公式字段还是统计字段。
公共属性 | ColumnName | 字段名称。
公共属性 | ColumnType | 字段中值的类型。
公共属性 | DisplayName | 别名。
Top
参见

引用

IColumnInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IColumnInfo.ColumnKind 属性

活字格插件API文档

IColumnInfoColumnKind 属性

字段的分类：普通字段，公式字段还是统计字段。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
TableColumnKind ColumnKind { get; }

属性值

类型：TableColumnKind
参见

引用

IColumnInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IColumnInfo.ColumnName 属性

活字格插件API文档

IColumnInfoColumnName 属性

字段名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ColumnName { get; }

属性值

类型：String
参见

引用

IColumnInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IColumnInfo.ColumnType 属性

活字格插件API文档

IColumnInfoColumnType 属性

字段中值的类型。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyTableColumnType ColumnType { get; }

属性值

类型：ForguncyTableColumnType
参见

引用

IColumnInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IColumnInfo.DisplayName 属性

活字格插件API文档

IColumnInfoDisplayName 属性

别名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string DisplayName { get; }

属性值

类型：String
参见

引用

IColumnInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IconAttribute 类

设置插件的图标。

该图标会应用到单元格类型下拉列表或命令选择下拉列表中，如果开启了单元格类型的显示模式，该图标也会应用到使用了该单元格类型的单元格上。

继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginIconAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class IconAttribute : Attribute

IconAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | IconAttribute | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
[Icon("pack://application:,,,/SignatureCellType;component/Resources/icon.png")]  //指定签名单元格类型的图标
public class SignatureCellType : CellType //自定义了签名单元格类型
{
    ...
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IconAttribute 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IconAttribute(
    string uri
)

参数

uri
类型：SystemString
图标的路径。
参见

引用

IconAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IconAttribute 属性

IconAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

IconAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IconAttribute 方法

IconAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

IconAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IEditorSettingsDataContext 接口

属性编辑器上下文信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IEditorSettingsDataContext

IEditorSettingsDataContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EditorSetting | 属性编辑器。
 | Value | 属性的值。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IEditorSettingsDataContext 属性

IEditorSettingsDataContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | EditorSetting | 属性编辑器。
 | Value | 属性的值。
Top
参见

引用

IEditorSettingsDataContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IEditorSettingsDataContext.EditorSetting 属性

活字格插件API文档

IEditorSettingsDataContextEditorSetting 属性

属性编辑器。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
EditorSetting EditorSetting { get; set; }

属性值

类型：EditorSetting
参见

引用

IEditorSettingsDataContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IEditorSettingsDataContext.Value 属性

活字格插件API文档

IEditorSettingsDataContextValue 属性

属性的值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object Value { get; set; }

属性值

类型：Object
示例
C#
复制
<ResourceDictionary xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" xmlns:local="clr-namespace:PassListviewDataCommand"><DataTemplate x:Key="TextPropertyTemplate"><TextBox Text="{Binding Value, Mode=TwoWay}" /></DataTemplate></ResourceDictionary>
参见

引用

IEditorSettingsDataContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IFileUploadContext 接口

上传的文件需要的上下文信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IFileUploadContext

IFileUploadContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | SourceDocumentFolder | 活字格文件所在的文件夹路径。
Top
方法
 | 名称 | 说明
公共方法 | GetForguncyUploadFilesFolderLocalPath | 返回上传文件的临时路径。
公共方法 | GetForguncyUploadFilesRelativePath | 返回上传文件的相对路径（基于活字格文件所在目录）。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IFileUploadContext 属性

IFileUploadContext 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | SourceDocumentFolder | 活字格文件所在的文件夹路径。
Top
参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IFileUploadContext.SourceDocumentFolder 属性

活字格插件API文档

IFileUploadContextSourceDocumentFolder 属性

活字格文件所在的文件夹路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string SourceDocumentFolder { get; }

属性值

类型：String
参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IFileUploadContext 方法

IFileUploadContext 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetForguncyUploadFilesFolderLocalPath | 返回上传文件的临时路径。
公共方法 | GetForguncyUploadFilesRelativePath | 返回上传文件的相对路径（基于活字格文件所在目录）。
Top
参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IFileUploadContext.GetForguncyUploadFilesFolderLocalPath 方法

活字格插件API文档

IFileUploadContextGetForguncyUploadFilesFolderLocalPath 方法

返回上传文件的临时路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetForguncyUploadFilesFolderLocalPath()

返回值

类型：String
参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IFileUploadContext.GetForguncyUploadFilesRelativePath 方法

活字格插件API文档

IFileUploadContextGetForguncyUploadFilesRelativePath 方法

返回上传文件的相对路径（基于活字格文件所在目录）。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string GetForguncyUploadFilesRelativePath(
    string baseFolder
)

参数

baseFolder
类型：SystemString
活字格文件所在的文件夹路径。

返回值

类型：String
参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


IForceGenerateCell 接口

在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IForceGenerateCell

IForceGenerateCell 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetForceGenerateCells | 在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IForceGenerateCell 方法

IForceGenerateCell 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetForceGenerateCells | 在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。
Top
参见

引用

IForceGenerateCell 接口
GrapeCity.Forguncy.Plugin 命名空间


IForceGenerateCell.GetForceGenerateCells 方法

活字格插件API文档

IForceGenerateCellGetForceGenerateCells 方法

在生成页面时，会根据该接口中的方法返回的结果强行生成指定的单元格。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<GenerateCellInfo> GetForceGenerateCells()

返回值

类型：IEnumerable GenerateCellInfo
参见

引用

IForceGenerateCell 接口
GrapeCity.Forguncy.Plugin 命名空间


IFormulaReferObject 接口

公式对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IFormulaReferObject

IFormulaReferObject 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PageName | 公式对象所在的页面名称。
Top
方法
 | 名称 | 说明
公共方法 | GetGenerateCellInfo | 获取Cell信息。
公共方法 | IsNormalFormula | 是否是公式。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IFormulaReferObject 属性

IFormulaReferObject 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PageName | 公式对象所在的页面名称。
Top
参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


IFormulaReferObject.PageName 属性

活字格插件API文档

IFormulaReferObjectPageName 属性

公式对象所在的页面名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string PageName { get; }

属性值

类型：String
参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


IFormulaReferObject 方法

IFormulaReferObject 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetGenerateCellInfo | 获取Cell信息。
公共方法 | IsNormalFormula | 是否是公式。
Top
参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


IFormulaReferObject.GetGenerateCellInfo 方法

活字格插件API文档

IFormulaReferObjectGetGenerateCellInfo 方法

获取Cell信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
GenerateCellInfo GetGenerateCellInfo()

返回值

类型：GenerateCellInfo
Cell信息。
参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


IFormulaReferObject.IsNormalFormula 方法

活字格插件API文档

IFormulaReferObjectIsNormalFormula 方法

是否是公式。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsNormalFormula()

返回值

类型：Boolean
参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfo 接口

页面中的表格信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IListViewInfo

IListViewInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowAddNewRow | 是否允许在表格中加行。
公共属性 | AllowDeleteRow | 是否允许在表格中删行。
公共属性 | AllowEditRow | 是否允许在表格中编辑。
公共属性 | BindingTableName | 绑定的数据表名。
公共属性 | ListViewName | 表格的名称。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IListViewInfo 属性

IListViewInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowAddNewRow | 是否允许在表格中加行。
公共属性 | AllowDeleteRow | 是否允许在表格中删行。
公共属性 | AllowEditRow | 是否允许在表格中编辑。
公共属性 | BindingTableName | 绑定的数据表名。
公共属性 | ListViewName | 表格的名称。
Top
参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfo.AllowAddNewRow 属性

活字格插件API文档

IListViewInfoAllowAddNewRow 属性

是否允许在表格中加行。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool AllowAddNewRow { get; }

属性值

类型：Boolean
参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfo.AllowDeleteRow 属性

活字格插件API文档

IListViewInfoAllowDeleteRow 属性

是否允许在表格中删行。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool AllowDeleteRow { get; }

属性值

类型：Boolean
参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfo.AllowEditRow 属性

活字格插件API文档

IListViewInfoAllowEditRow 属性

是否允许在表格中编辑。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool AllowEditRow { get; }

属性值

类型：Boolean
参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfo.BindingTableName 属性

活字格插件API文档

IListViewInfoBindingTableName 属性

绑定的数据表名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string BindingTableName { get; }

属性值

类型：String
参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfo.ListViewName 属性

活字格插件API文档

IListViewInfoListViewName 属性

表格的名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string ListViewName { get; }

属性值

类型：String
参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfoDesigner 接口

页面中的表格信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IListViewInfoDesigner : IListViewInfo

IListViewInfoDesigner 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowAddNewRow | 是否允许在表格中加行。 (继承自 IListViewInfo。)
公共属性 | AllowDeleteRow | 是否允许在表格中删行。 (继承自 IListViewInfo。)
公共属性 | AllowEditRow | 是否允许在表格中编辑。 (继承自 IListViewInfo。)
公共属性 | BindingTableName | 绑定的数据表名。 (继承自 IListViewInfo。)
公共属性 | ListViewName | 表格的名称。 (继承自 IListViewInfo。)
Top
方法
 | 名称 | 说明
公共方法 | EnumAllColumnHeaderCells | 遍历列头区域中的所有合并后的有内容的单元格。 如果列头有多行，会返回所有列头上的Cell，请根据Cell上的RowIndex，ColumnIndex，RowSpan，ColumnSpan属性判断单元格在列头上的位置。
公共方法 | EnumAllTemplateCells | 遍历模板行中的所有合并后的有内容的单元格。
公共方法 | GetAllColumnNames | 获取所有列名。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IListViewInfoDesigner 属性

IListViewInfoDesigner 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowAddNewRow | 是否允许在表格中加行。 (继承自 IListViewInfo。)
公共属性 | AllowDeleteRow | 是否允许在表格中删行。 (继承自 IListViewInfo。)
公共属性 | AllowEditRow | 是否允许在表格中编辑。 (继承自 IListViewInfo。)
公共属性 | BindingTableName | 绑定的数据表名。 (继承自 IListViewInfo。)
公共属性 | ListViewName | 表格的名称。 (继承自 IListViewInfo。)
Top
参见

引用

IListViewInfoDesigner 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfoDesigner 方法

IListViewInfoDesigner 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumAllColumnHeaderCells | 遍历列头区域中的所有合并后的有内容的单元格。 如果列头有多行，会返回所有列头上的Cell，请根据Cell上的RowIndex，ColumnIndex，RowSpan，ColumnSpan属性判断单元格在列头上的位置。
公共方法 | EnumAllTemplateCells | 遍历模板行中的所有合并后的有内容的单元格。
公共方法 | GetAllColumnNames | 获取所有列名。
Top
参见

引用

IListViewInfoDesigner 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfoDesigner.EnumAllColumnHeaderCells 方法

活字格插件API文档

IListViewInfoDesignerEnumAllColumnHeaderCells 方法

遍历列头区域中的所有合并后的有内容的单元格。 如果列头有多行，会返回所有列头上的Cell，请根据Cell上的RowIndex，ColumnIndex，RowSpan，ColumnSpan属性判断单元格在列头上的位置。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<ICellInfoBase> EnumAllColumnHeaderCells()

返回值

类型：IEnumerable ICellInfoBase
参见

引用

IListViewInfoDesigner 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfoDesigner.EnumAllTemplateCells 方法

活字格插件API文档

IListViewInfoDesignerEnumAllTemplateCells 方法

遍历模板行中的所有合并后的有内容的单元格。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<ICellInfoBase> EnumAllTemplateCells()

返回值

类型：IEnumerable ICellInfoBase
参见

引用

IListViewInfoDesigner 接口
GrapeCity.Forguncy.Plugin 命名空间


IListViewInfoDesigner.GetAllColumnNames 方法

活字格插件API文档

IListViewInfoDesignerGetAllColumnNames 方法

获取所有列名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<string> GetAllColumnNames()

返回值

类型：List String
参见

引用

IListViewInfoDesigner 接口
GrapeCity.Forguncy.Plugin 命名空间


ILocalServerInfo 接口

本地网站应用信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ILocalServerInfo

ILocalServerInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | HostAddress | 主机地址。
公共属性 | PortNumber | 端口号。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ILocalServerInfo 属性

ILocalServerInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | HostAddress | 主机地址。
公共属性 | PortNumber | 端口号。
Top
参见

引用

ILocalServerInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ILocalServerInfo.HostAddress 属性

活字格插件API文档

ILocalServerInfoHostAddress 属性

主机地址。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string HostAddress { get; }

属性值

类型：String
参见

引用

ILocalServerInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ILocalServerInfo.PortNumber 属性

活字格插件API文档

ILocalServerInfoPortNumber 属性

端口号。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
int PortNumber { get; }

属性值

类型：Int32
参见

引用

ILocalServerInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting 类

图片编辑器。如图片类型使用的[选择图片...]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginImageEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ImageEditorSetting : BuiltinEditorSetting

ImageEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ImageEditorSetting | 初始化 ImageEditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultActiveTabIndex | 没有图标时，打开对话的默认选项卡序号，0是Image，1是Svg
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DefaultIconColor | 没有图标时，打开对话框的默认图标颜色
公共属性 | DefaultUseCellColor | 没有图标时，打开对话的默认Svg是否勾选使用单元格颜色
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | SupportSvg | 是否支持SVG。
公共属性 | SupportUseCellColor | 是否支持除Svg使用单元格颜色
公共属性 | TemplateName | 内置图片选择器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting 构造函数

初始化 ImageEditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ImageEditorSetting()
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting 属性

ImageEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultActiveTabIndex | 没有图标时，打开对话的默认选项卡序号，0是Image，1是Svg
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DefaultIconColor | 没有图标时，打开对话框的默认图标颜色
公共属性 | DefaultUseCellColor | 没有图标时，打开对话的默认Svg是否勾选使用单元格颜色
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | SupportSvg | 是否支持SVG。
公共属性 | SupportUseCellColor | 是否支持除Svg使用单元格颜色
公共属性 | TemplateName | 内置图片选择器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting.DefaultActiveTabIndex 属性

活字格插件API文档

ImageEditorSettingDefaultActiveTabIndex 属性

没有图标时，打开对话的默认选项卡序号，0是Image，1是Svg

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int DefaultActiveTabIndex { get; set; }

属性值

类型：Int32
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting.DefaultIconColor 属性

活字格插件API文档

ImageEditorSettingDefaultIconColor 属性

没有图标时，打开对话框的默认图标颜色

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string DefaultIconColor { get; set; }

属性值

类型：String
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting.DefaultUseCellColor 属性

活字格插件API文档

ImageEditorSettingDefaultUseCellColor 属性

没有图标时，打开对话的默认Svg是否勾选使用单元格颜色

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool DefaultUseCellColor { get; set; }

属性值

类型：Boolean
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting.SupportSvg 属性

活字格插件API文档

ImageEditorSettingSupportSvg 属性

是否支持SVG。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool SupportSvg { get; set; }

属性值

类型：Boolean
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting.SupportUseCellColor 属性

活字格插件API文档

ImageEditorSettingSupportUseCellColor 属性

是否支持除Svg使用单元格颜色

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool SupportUseCellColor { get; set; }

属性值

类型：Boolean
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting.TemplateName 属性

活字格插件API文档

ImageEditorSettingTemplateName 属性

内置图片选择器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageEditorSetting 方法

ImageEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValue 类

一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
继承层次
SystemObject
GrapeCity.Forguncy.PluginImageValue

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ImageValue : ICloneable

ImageValue 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ImageValue | 初始化 ImageValue 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | BuiltIn | 是否是内置图片。
公共属性 | Color | 内置图片的颜色，只有当图片为SVG格式时才能起作用。
公共属性 | Name | 图片名。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class MyImageCellType : CellType
{
    public ImageValue ImageInfo { get; set; }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ImageValue 构造函数

初始化 ImageValue 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ImageValue()
参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValue 属性

ImageValue 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | BuiltIn | 是否是内置图片。
公共属性 | Color | 内置图片的颜色，只有当图片为SVG格式时才能起作用。
公共属性 | Name | 图片名。
Top
参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValue.BuiltIn 属性

活字格插件API文档

ImageValueBuiltIn 属性

是否是内置图片。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool BuiltIn { get; set; }

属性值

类型：Boolean
参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValue.Color 属性

活字格插件API文档

ImageValueColor 属性

内置图片的颜色，只有当图片为SVG格式时才能起作用。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string Color { get; set; }

属性值

类型：String
参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValue.Name 属性

活字格插件API文档

ImageValueName 属性

图片名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValue 方法

ImageValue 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute 类

一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginImageValuePropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ImageValuePropertyAttribute : Attribute

ImageValuePropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ImageValuePropertyAttribute | 初始化 ImageValuePropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultActiveTabIndex | 没有图标时，打开对话的默认选项卡序号，0是Image，1是Svg
公共属性 | DefaultIconColor | 没有图标时，打开对话框的默认图标颜色
公共属性 | DefaultUseCellColor | 没有图标时，打开对话的默认Svg是否勾选使用单元格颜色
公共属性 | SupportSvg | 是否支持SVG。
公共属性 | SupportUseCellColor | 是否支持除Svg使用单元格颜色
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class MyImageCellType : CellType
{
    [ImageValueProperty()]
    public ImageValue ImageInfo { get; set; }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute 构造函数

初始化 ImageValuePropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ImageValuePropertyAttribute()
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute 属性

ImageValuePropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultActiveTabIndex | 没有图标时，打开对话的默认选项卡序号，0是Image，1是Svg
公共属性 | DefaultIconColor | 没有图标时，打开对话框的默认图标颜色
公共属性 | DefaultUseCellColor | 没有图标时，打开对话的默认Svg是否勾选使用单元格颜色
公共属性 | SupportSvg | 是否支持SVG。
公共属性 | SupportUseCellColor | 是否支持除Svg使用单元格颜色
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute.DefaultActiveTabIndex 属性

活字格插件API文档

ImageValuePropertyAttributeDefaultActiveTabIndex 属性

没有图标时，打开对话的默认选项卡序号，0是Image，1是Svg

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int DefaultActiveTabIndex { get; set; }

属性值

类型：Int32
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute.DefaultIconColor 属性

活字格插件API文档

ImageValuePropertyAttributeDefaultIconColor 属性

没有图标时，打开对话框的默认图标颜色

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string DefaultIconColor { get; set; }

属性值

类型：String
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute.DefaultUseCellColor 属性

活字格插件API文档

ImageValuePropertyAttributeDefaultUseCellColor 属性

没有图标时，打开对话的默认Svg是否勾选使用单元格颜色

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool DefaultUseCellColor { get; set; }

属性值

类型：Boolean
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute.SupportSvg 属性

活字格插件API文档

ImageValuePropertyAttributeSupportSvg 属性

是否支持SVG。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool SupportSvg { get; set; }

属性值

类型：Boolean
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute.SupportUseCellColor 属性

活字格插件API文档

ImageValuePropertyAttributeSupportUseCellColor 属性

是否支持除Svg使用单元格颜色

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool SupportUseCellColor { get; set; }

属性值

类型：Boolean
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ImageValuePropertyAttribute 方法

ImageValuePropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ImageValuePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


INeedUploadFileByUser 接口

如果插件使用过程中需要用户上传文件或者图片等，在保存或导入活字格文件时需给出相关的文件或图片信息，如存储文件夹路径，文件名等。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface INeedUploadFileByUser

INeedUploadFileByUser 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetAllFileSourceAndTargetPathsWhenImportForguncyFile | 当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
公共方法 | GetUploadFileInfosWhenSaveFile | 保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


INeedUploadFileByUser 方法

INeedUploadFileByUser 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetAllFileSourceAndTargetPathsWhenImportForguncyFile | 当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
公共方法 | GetUploadFileInfosWhenSaveFile | 保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
Top
参见

引用

INeedUploadFileByUser 接口
GrapeCity.Forguncy.Plugin 命名空间


INeedUploadFileByUser.GetAllFileSourceAndTargetPathsWhenImportForguncyFile 方法

活字格插件API文档

INeedUploadFileByUserGetAllFileSourceAndTargetPathsWhenImportForguncyFile 方法

当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<FileCopyInfo> GetAllFileSourceAndTargetPathsWhenImportForguncyFile(
    IFileUploadContext context
)

参数

context
类型：GrapeCity.Forguncy.PluginIFileUploadContext
提供了一些获取当前活字格文件的存储位置等信息。

返回值

类型：List FileCopyInfo
参见

引用

INeedUploadFileByUser 接口
GrapeCity.Forguncy.Plugin 命名空间


INeedUploadFileByUser.GetUploadFileInfosWhenSaveFile 方法

活字格插件API文档

INeedUploadFileByUserGetUploadFileInfosWhenSaveFile 方法

保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
FileUploadInfo GetUploadFileInfosWhenSaveFile(
    IFileUploadContext context
)

参数

context
类型：GrapeCity.Forguncy.PluginIFileUploadContext
提供了一些获取当前活字格文件的存储位置等信息。

返回值

类型：FileUploadInfo
保存时上传文件的信息。
参见

引用

INeedUploadFileByUser 接口
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting 类

整数类型的属性对应的编辑器，如单选按钮使用的[项目间距]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginIntEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class IntEditorSetting : BuiltinEditorSetting

IntEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | IntEditorSetting | 构造函数。
公共方法 | IntEditorSetting(Int32, Int32) | 构造函数，指定了最小值和最大值的整数类型的编辑器。
Top
属性
 | 名称 | 说明
公共属性 | AllowNull | 是否允许清空整数类型的属性编辑器的值。
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Max | 整数类型的属性编辑器的最大值。
公共属性 | Min | 整数类型的属性编辑器的最小值。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的整数类型的属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
公共属性 | Watermark | 整数类型的属性编辑器的值为空时显示的水印。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting 构造函数

重载列表
 | 名称 | 说明
公共方法 | IntEditorSetting | 构造函数。
公共方法 | IntEditorSetting(Int32, Int32) | 构造函数，指定了最小值和最大值的整数类型的编辑器。
Top
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IntEditorSetting()
参见

引用

IntEditorSetting 类
IntEditorSetting 重载
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting 构造函数 (Int32, Int32)

构造函数，指定了最小值和最大值的整数类型的编辑器。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IntEditorSetting(
    int min,
    int max
)

参数

min
类型：SystemInt32
max
类型：SystemInt32
参见

引用

IntEditorSetting 类
IntEditorSetting 重载
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting 属性

IntEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowNull | 是否允许清空整数类型的属性编辑器的值。
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Max | 整数类型的属性编辑器的最大值。
公共属性 | Min | 整数类型的属性编辑器的最小值。
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的整数类型的属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
公共属性 | Watermark | 整数类型的属性编辑器的值为空时显示的水印。
Top
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting.AllowNull 属性

活字格插件API文档

IntEditorSettingAllowNull 属性

是否允许清空整数类型的属性编辑器的值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AllowNull { get; set; }

属性值

类型：Boolean
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting.Max 属性

活字格插件API文档

IntEditorSettingMax 属性

整数类型的属性编辑器的最大值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int Max { get; set; }

属性值

类型：Int32
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting.Min 属性

活字格插件API文档

IntEditorSettingMin 属性

整数类型的属性编辑器的最小值。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int Min { get; set; }

属性值

类型：Int32
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting.TemplateName 属性

活字格插件API文档

IntEditorSettingTemplateName 属性

内置的整数类型的属性编辑器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting.Watermark 属性

活字格插件API文档

IntEditorSettingWatermark 属性

整数类型的属性编辑器的值为空时显示的水印。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Watermark { get; set; }

属性值

类型：String
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntEditorSetting 方法

IntEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute 类

用于配置整数编辑框的设置，必须标注在 Int 类型的属性上
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginIntPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class IntPropertyAttribute : Attribute

IntPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | IntPropertyAttribute | 初始化 IntPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AllowNull | 是否可以设置为空，默认为否
公共属性 | Max | 最大值，默认int.MaxValue
公共属性 | Min | 最小值，默认int.MinValue
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | Watermark | 值为空时的替代文本
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute 构造函数

初始化 IntPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IntPropertyAttribute()
参见

引用

IntPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute 属性

IntPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllowNull | 是否可以设置为空，默认为否
公共属性 | Max | 最大值，默认int.MaxValue
公共属性 | Min | 最小值，默认int.MinValue
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | Watermark | 值为空时的替代文本
Top
参见

引用

IntPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute.AllowNull 属性

活字格插件API文档

IntPropertyAttributeAllowNull 属性

是否可以设置为空，默认为否

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool AllowNull { get; set; }

属性值

类型：Boolean
参见

引用

IntPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute.Max 属性

活字格插件API文档

IntPropertyAttributeMax 属性

最大值，默认int.MaxValue

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int Max { get; set; }

属性值

类型：Int32
参见

引用

IntPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute.Min 属性

活字格插件API文档

IntPropertyAttributeMin 属性

最小值，默认int.MinValue

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int Min { get; set; }

属性值

类型：Int32
参见

引用

IntPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute.Watermark 属性

活字格插件API文档

IntPropertyAttributeWatermark 属性

值为空时的替代文本

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string Watermark { get; set; }

属性值

类型：String
参见

引用

IntPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IntPropertyAttribute 方法

IntPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

IntPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


IPageInfo 接口

页面信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IPageInfo

IPageInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsBuiltInPage | 是否内建页。
公共属性 | IsMasterPage | 是否母版页。
公共属性 | IsMobilePage | 是否手机页。
公共属性 | PageName | 页面名。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IPageInfo 属性

IPageInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsBuiltInPage | 是否内建页。
公共属性 | IsMasterPage | 是否母版页。
公共属性 | IsMobilePage | 是否手机页。
公共属性 | PageName | 页面名。
Top
参见

引用

IPageInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IPageInfo.IsBuiltInPage 属性

活字格插件API文档

IPageInfoIsBuiltInPage 属性

是否内建页。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsBuiltInPage { get; }

属性值

类型：Boolean
参见

引用

IPageInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IPageInfo.IsMasterPage 属性

活字格插件API文档

IPageInfoIsMasterPage 属性

是否母版页。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsMasterPage { get; }

属性值

类型：Boolean
参见

引用

IPageInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IPageInfo.IsMobilePage 属性

活字格插件API文档

IPageInfoIsMobilePage 属性

是否手机页。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsMobilePage { get; }

属性值

类型：Boolean
参见

引用

IPageInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IPageInfo.PageName 属性

活字格插件API文档

IPageInfoPageName 属性

页面名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string PageName { get; }

属性值

类型：String
参见

引用

IPageInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IPropertySearchable 接口

能够检索替换单元格类型和命令上的某些属性。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IPropertySearchable

IPropertySearchable 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumSearchableProperty | 查找到某一个单元格类型或命令时，需要检索的属性名称和检索时使用的值的集合。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IPropertySearchable 方法

IPropertySearchable 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | EnumSearchableProperty | 查找到某一个单元格类型或命令时，需要检索的属性名称和检索时使用的值的集合。
Top
参见

引用

IPropertySearchable 接口
GrapeCity.Forguncy.Plugin 命名空间


IPropertySearchable.EnumSearchableProperty 方法

活字格插件API文档

IPropertySearchableEnumSearchableProperty 方法

查找到某一个单元格类型或命令时，需要检索的属性名称和检索时使用的值的集合。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<FindResultItem> EnumSearchableProperty(
    LocationIndicator location
)

参数

location
类型：GrapeCity.Forguncy.PluginLocationIndicator

返回值

类型：IEnumerable FindResultItem
参见

引用

IPropertySearchable 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceFormula 接口

如果插件中引用了页面中的单元格，一旦被引用的单元格的位置发生了变化，如拖拽，那么插件中的相关单元格引用也应该被同步；

这种情况下就需要实现这个接口，而且，当查找页面中的单元格引用时，插件中的相关属性也会被查找出来。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferenceFormula

IReferenceFormula 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetFormulaReferObjects | 获取插件中所有引用单元格或单元格区域的公式对象。
Top
示例
C#
复制
public class MyCellType : CellType, IReferenceFormula
{
    [FormulaProperty]
    public object ReferCell { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("MyCellType").AppendProperty("ReferCell");
        yield return new LocatedObject<object>(this.ReferCell, newLocation);
    }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IReferenceFormula 方法

IReferenceFormula 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetFormulaReferObjects | 获取插件中所有引用单元格或单元格区域的公式对象。
Top
参见

引用

IReferenceFormula 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceFormula.GetFormulaReferObjects 方法

活字格插件API文档

IReferenceFormulaGetFormulaReferObjects 方法

获取插件中所有引用单元格或单元格区域的公式对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<LocatedObject<Object>> GetFormulaReferObjects(
    LocationIndicator location
)

参数

location
类型：GrapeCity.Forguncy.PluginLocationIndicator
坐标定位器。

返回值

类型：IEnumerable LocatedObject Object
返回所有引用单元格或单元格区域的公式对象。
参见

引用

IReferenceFormula 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceListView 接口

如果插件中引用了页面中的表格的名称，一旦表格重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找页面中的表格引用时，插件中的相关属性也会被查找出来。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferenceListView

IReferenceListView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetListViewNames | 返回插件中所有引用页面表格的信息。
公共方法 | RenameListviewName | 一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
Top
示例
C#
复制
public class MyPageNavigateCellType : CellType, IReferenceListView
{
    public string ListViewName { get; set; }

    public IEnumerable<string>> GetListViewNames()
    {
        yield return this.ListViewName;
    }

    public void RenameListviewName(string oldName, string newName)
    {
        if(string.Equals(this.ListViewName, oldName))
        {
            this.ListViewName = newName;
        }
    }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IReferenceListView 方法

IReferenceListView 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetListViewNames | 返回插件中所有引用页面表格的信息。
公共方法 | RenameListviewName | 一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
Top
参见

引用

IReferenceListView 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceListView.GetListViewNames 方法

活字格插件API文档

IReferenceListViewGetListViewNames 方法

返回插件中所有引用页面表格的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<string> GetListViewNames()

返回值

类型：IEnumerable String
返回插件中所有引用页面表格的信息。
参见

引用

IReferenceListView 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceListView.RenameListviewName 方法

活字格插件API文档

IReferenceListViewRenameListviewName 方法

一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void RenameListviewName(
    string oldName,
    string newName
)

参数

oldName
类型：SystemString
重命名之前的表格名。
newName
类型：SystemString
重命名之后的表格名。
参见

引用

IReferenceListView 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceListViewColumn 接口

如果插件中引用了页面表格中列名，一旦表格中的列重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferenceListViewColumn

IReferenceListViewColumn 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | RenameListviewColumnName | 一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
Top
示例
C#
复制
public class UpdateListviewCommand : Command, IReferenceListView
{
    public string ListViewName { get; set; }

    public List<string> UpdateColumns { get; set; }

    public void RenameListviewColumnName(string listviewName, string oldName, string newName)
    {
        if(string.Equals(this.ListViewName, listviewName))
        {
            for (var i = 0; i < this.UpdateColumns.Count; i++)
            {
                if(this.UpdateColumns[i] == oldName)
                {
                    this.UpdateColumns[i] = newName;
                }
            }
        }
    }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IReferenceListViewColumn 方法

IReferenceListViewColumn 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | RenameListviewColumnName | 一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
Top
参见

引用

IReferenceListViewColumn 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceListViewColumn.RenameListviewColumnName 方法

活字格插件API文档

IReferenceListViewColumnRenameListviewColumnName 方法

一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void RenameListviewColumnName(
    string listviewName,
    string oldName,
    string newName
)

参数

listviewName
类型：SystemString
表格名称。
oldName
类型：SystemString
重命名之前的表格列名。
newName
类型：SystemString
重命名之后的表格列名。
参见

引用

IReferenceListViewColumn 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferencePage 接口

如果插件中引用了页面名，一旦页面重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找页面的引用时，插件中的相关属性也会被查找出来。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferencePage

IReferencePage 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPageNames | 返回插件中所有引用页面的信息。
公共方法 | RenamePageName | 一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
Top
示例
C#
复制
public class MyNavigatePageCommand : Command, IReferencePage
{
    public string NavigatePageName { get; set; }

    public IEnumerable<LocatedObject<string>> GetPageNames(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("MyNavigatePageCommand");

        yield return new LocatedObject<string>(this.NavigatePageName, newLocation);
    }

    public void RenamePageName(string oldName, string newName)
    {
        if(string.Equals(this.NavigatePageName, oldName))
        {
            this.NavigatePageName = newName;
        }
    }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IReferencePage 方法

IReferencePage 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetPageNames | 返回插件中所有引用页面的信息。
公共方法 | RenamePageName | 一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
Top
参见

引用

IReferencePage 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferencePage.GetPageNames 方法

活字格插件API文档

IReferencePageGetPageNames 方法

返回插件中所有引用页面的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<LocatedObject<string>> GetPageNames(
    LocationIndicator location
)

参数

location
类型：GrapeCity.Forguncy.PluginLocationIndicator
坐标定位器。

返回值

类型：IEnumerable LocatedObject String
返回插件中所有引用页面的信息。
参见

引用

IReferencePage 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferencePage.RenamePageName 方法

活字格插件API文档

IReferencePageRenamePageName 方法

一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void RenamePageName(
    string oldName,
    string newName
)

参数

oldName
类型：SystemString
重命名之前的页面名。
newName
类型：SystemString
重命名之后的页面名。
参见

引用

IReferencePage 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceProcess 接口

如果插件中引用了流程的名称，一旦流程重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找页面中的流程引用时，插件中的相关属性也会被查找出来。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferenceProcess

IReferenceProcess 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetProcessNames | 获取当前引用流程的名称
公共方法 | RenameProcessName | 一旦流程名被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关流程名。
Top
示例
C#
复制
    public void RenameProcessName(string oldName, string newName)
    {
        if(string.Equals(this.ListViewName, oldName))
        {
            this.ProcessName = newName;
        }
    }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IReferenceProcess 方法

IReferenceProcess 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetProcessNames | 获取当前引用流程的名称
公共方法 | RenameProcessName | 一旦流程名被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关流程名。
Top
参见

引用

IReferenceProcess 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceProcess.GetProcessNames 方法

活字格插件API文档

IReferenceProcessGetProcessNames 方法

获取当前引用流程的名称

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<string> GetProcessNames()

返回值

类型：IEnumerable String
参见

引用

IReferenceProcess 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceProcess.RenameProcessName 方法

活字格插件API文档

IReferenceProcessRenameProcessName 方法

一旦流程名被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关流程名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void RenameProcessName(
    string oldName,
    string newName
)

参数

oldName
类型：SystemString
重命名之前的流程名。
newName
类型：SystemString
重命名之后的流程名。
参见

引用

IReferenceProcess 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceTable 接口

如果插件中引用了数据表名或者字段名，一旦数据表或字段重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找数据表或字段的引用时，插件中的相关属性也会被查找出来。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferenceTable

IReferenceTable 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetTableInfo | 返回插件中所有引用数据表和字段的信息。
公共方法 | RenameTableColumnName | 一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
公共方法 | RenameTableName | 一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
Top
示例
C#
复制
public class ListCellType : CellType, IReferenceTable
{
    public string TableName { get; set; }

    public string TextColumn { get; set; }

    public string ValueColumn { get; set; }

    public  IEnumerable<LocatedObject<TableCheckInfo>> GetTableInfo(LocationIndicator location)
    {
        var list = new List<LocatedObject<TableCheckInfo>>();

        TableCheckInfo info = new TableCheckInfo(TableName);
        var columns = (new List<string>() { ValueColumn, TextColumn }).Distinct();
        foreach (var col in columns)
        {
            info.AddColumns(col);
        }

        var newLocation = location.AppendProperty("ListCellType");

        list.Add(new LocatedObject<TableCheckInfo>(info, newLocation));

        return list;
    }

    public void RenameTableColumnName(string tableName, string oldName, string newName)
    {
        if (string.Equals(this.TableName, tableName))
        {
            if (oldName == this.ValueColumn)
            {
                this.ValueColumn = newName;
            }
            if (oldName == this.TextColumn)
            {
                this.TextColumn = newName;
            }
        }
    }

    public void RenameTableName(string oldName, string newName)
    {
        if(string.Equals(this.TableName, oldName))
        {
            this.TableName = newName;
        }
    }
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IReferenceTable 方法

IReferenceTable 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetTableInfo | 返回插件中所有引用数据表和字段的信息。
公共方法 | RenameTableColumnName | 一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
公共方法 | RenameTableName | 一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
Top
参见

引用

IReferenceTable 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceTable.GetTableInfo 方法

活字格插件API文档

IReferenceTableGetTableInfo 方法

返回插件中所有引用数据表和字段的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<LocatedObject<TableCheckInfo>> GetTableInfo(
    LocationIndicator location
)

参数

location
类型：GrapeCity.Forguncy.PluginLocationIndicator
原有坐标定位器。

返回值

类型：IEnumerable LocatedObject TableCheckInfo
返回插件中所有引用数据表和字段的信息。
参见

引用

IReferenceTable 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceTable.RenameTableColumnName 方法

活字格插件API文档

IReferenceTableRenameTableColumnName 方法

一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void RenameTableColumnName(
    string tableName,
    string oldName,
    string newName
)

参数

tableName
类型：SystemString
数据表名。
oldName
类型：SystemString
重命名之前的字段名。
newName
类型：SystemString
重命名之后的字段名。
参见

引用

IReferenceTable 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferenceTable.RenameTableName 方法

活字格插件API文档

IReferenceTableRenameTableName 方法

一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void RenameTableName(
    string oldName,
    string newName
)

参数

oldName
类型：SystemString
重命名之前的数据表名。
newName
类型：SystemString
重命名之后的数据表名。
参见

引用

IReferenceTable 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferFiles 接口

此接口将返回当前对象关联的所有文件的物理文件路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IReferFiles

IReferFiles 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetReferFiles | 此接口将返回当前对象关联的所有文件的物理文件路径。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IReferFiles 方法

IReferFiles 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | GetReferFiles | 此接口将返回当前对象关联的所有文件的物理文件路径。
Top
参见

引用

IReferFiles 接口
GrapeCity.Forguncy.Plugin 命名空间


IReferFiles.GetReferFiles 方法

活字格插件API文档

IReferFilesGetReferFiles 方法

此接口将返回当前对象关联的所有文件的物理文件路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<string> GetReferFiles()

返回值

类型：IEnumerable String
参见

引用

IReferFiles 接口
GrapeCity.Forguncy.Plugin 命名空间


ITableInfo 接口

数据表的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface ITableInfo

ITableInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Columns | 数据表中字段名集合。
公共属性 | TableName | 数据表名。
公共属性 | TableType | 数据表的类型。
公共属性 | WorkflowInfo | 数据表的工作流信息。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ITableInfo 属性

ITableInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Columns | 数据表中字段名集合。
公共属性 | TableName | 数据表名。
公共属性 | TableType | 数据表的类型。
公共属性 | WorkflowInfo | 数据表的工作流信息。
Top
参见

引用

ITableInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ITableInfo.Columns 属性

活字格插件API文档

ITableInfoColumns 属性

数据表中字段名集合。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<IColumnInfo> Columns { get; }

属性值

类型：IEnumerable IColumnInfo
参见

引用

ITableInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ITableInfo.TableName 属性

活字格插件API文档

ITableInfoTableName 属性

数据表名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string TableName { get; }

属性值

类型：String
参见

引用

ITableInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ITableInfo.TableType 属性

活字格插件API文档

ITableInfoTableType 属性

数据表的类型。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
ForguncyTableType TableType { get; }

属性值

类型：ForguncyTableType
参见

引用

ITableInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ITableInfo.WorkflowInfo 属性

活字格插件API文档

ITableInfoWorkflowInfo 属性

数据表的工作流信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IWorkflowInfo WorkflowInfo { get; }

属性值

类型：IWorkflowInfo
参见

引用

ITableInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IUserServiceInfo 接口

用户管理网站的信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IUserServiceInfo

IUserServiceInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllRoles | 获取所有的角色。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IUserServiceInfo 属性

IUserServiceInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AllRoles | 获取所有的角色。
Top
参见

引用

IUserServiceInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IUserServiceInfo.AllRoles 属性

活字格插件API文档

IUserServiceInfoAllRoles 属性

获取所有的角色。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<string> AllRoles { get; }

属性值

类型：List String
参见

引用

IUserServiceInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IWorkflowInfo 接口

数据表中的工作流信息。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IWorkflowInfo

IWorkflowInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsEnabled | 是否启用工作流。
公共属性 | StateList | 工作流中的状态集合。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


IWorkflowInfo 属性

IWorkflowInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IsEnabled | 是否启用工作流。
公共属性 | StateList | 工作流中的状态集合。
Top
参见

引用

IWorkflowInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IWorkflowInfo.IsEnabled 属性

活字格插件API文档

IWorkflowInfoIsEnabled 属性

是否启用工作流。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
bool IsEnabled { get; }

属性值

类型：Boolean
参见

引用

IWorkflowInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


IWorkflowInfo.StateList 属性

活字格插件API文档

IWorkflowInfoStateList 属性

工作流中的状态集合。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
IEnumerable<string> StateList { get; }

属性值

类型：IEnumerable String
参见

引用

IWorkflowInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


ListPropertyAttribute 类

用于标注列表类型的属性，被标注属性的类型必须是泛型List
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginHyperlinkEdtiorPropertyAttribute
GrapeCity.Forguncy.PluginListPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ListPropertyAttribute : HyperlinkEdtiorPropertyAttribute

ListPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ListPropertyAttribute | 初始化 ListPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | MaxCount | 列表中元素的最大个数，为-1表示不限制最大个数。默认值为-1
公共属性 | MinCount | 列表中元素的最小个数
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ListPropertyAttribute 构造函数

初始化 ListPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ListPropertyAttribute()
参见

引用

ListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ListPropertyAttribute 属性

ListPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | MaxCount | 列表中元素的最大个数，为-1表示不限制最大个数。默认值为-1
公共属性 | MinCount | 列表中元素的最小个数
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ListPropertyAttribute.MaxCount 属性

活字格插件API文档

ListPropertyAttributeMaxCount 属性

列表中元素的最大个数，为-1表示不限制最大个数。默认值为-1

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int MaxCount { get; set; }

属性值

类型：Int32
参见

引用

ListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ListPropertyAttribute.MinCount 属性

活字格插件API文档

ListPropertyAttributeMinCount 属性

列表中元素的最小个数

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int MinCount { get; set; }

属性值

类型：Int32
参见

引用

ListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ListPropertyAttribute 方法

ListPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject 类

带坐标定位器的对象。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocatedObject
GrapeCity.Forguncy.PluginLocatedObjectT

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class LocatedObject

LocatedObject 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LocatedObject | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | Location | 坐标定位器。
公共属性 | Object | 有坐标定位器的对象。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


LocatedObject 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public LocatedObject(
    Object obj,
    LocationIndicator location
)

参数

obj
类型：SystemObject
对象。
location
类型：GrapeCity.Forguncy.PluginLocationIndicator
坐标定位器。
参见

引用

LocatedObject 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject 属性

LocatedObject 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Location | 坐标定位器。
公共属性 | Object | 有坐标定位器的对象。
Top
参见

引用

LocatedObject 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject.Location 属性

活字格插件API文档

LocatedObjectLocation 属性

坐标定位器。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public LocationIndicator Location { get; set; }

属性值

类型：LocationIndicator
参见

引用

LocatedObject 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject.Object 属性

活字格插件API文档

LocatedObjectObject 属性

有坐标定位器的对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Object { get; set; }

属性值

类型：Object
参见

引用

LocatedObject 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject 方法

LocatedObject 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

LocatedObject 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject(T) 类

活字格插件API文档

LocatedObjectT 类

带坐标定位器的特定类型的对象，如页面，命名等。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocatedObject
GrapeCity.Forguncy.PluginLocatedObjectT

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class LocatedObject<T> : LocatedObject

类型参数

T
特定类型。

LocatedObjectT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | LocatedObjectT | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | Location | 坐标定位器。 (继承自 LocatedObject。)
公共属性 | Object | 特定类型的对象。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


LocatedObject(T) 构造函数

活字格插件API文档

LocatedObjectT 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public LocatedObject(
    T obj,
    LocationIndicator location
)

参数

obj
类型：T
特定类型的对象。
location
类型：GrapeCity.Forguncy.PluginLocationIndicator
坐标定位器。
参见

引用

LocatedObjectT 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject(T) 属性

活字格插件API文档

LocatedObjectT 属性

LocatedObjectT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Location | 坐标定位器。 (继承自 LocatedObject。)
公共属性 | Object | 特定类型的对象。
Top
参见

引用

LocatedObjectT 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject(T).Object 属性

活字格插件API文档

LocatedObjectTObject 属性

特定类型的对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public T Object { get; }

属性值

类型：T
参见

引用

LocatedObjectT 类
GrapeCity.Forguncy.Plugin 命名空间


LocatedObject(T) 方法

活字格插件API文档

LocatedObjectT 方法

LocatedObjectT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

LocatedObjectT 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator 类

坐标定位器，查找引用时基于它可以帮助用户快速找到相关对象的位置。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocationIndicator
GrapeCity.Forguncy.PluginNameIndicator
GrapeCity.Forguncy.PluginObjectIndicator

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class LocationIndicator

LocationIndicator 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | LocationIndicator | 初始化 LocationIndicator 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字。
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
公共属性 | Parent | 父节点
公共属性 | Root | 根坐标定位器。
Top
方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator 构造函数

初始化 LocationIndicator 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected LocationIndicator()
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator 属性

LocationIndicator 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字。
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
公共属性 | Parent | 父节点
公共属性 | Root | 根坐标定位器。
Top
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator.DisplayString 属性

活字格插件API文档

LocationIndicatorDisplayString 属性

当前坐标定位器的显示文字。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract string DisplayString { get; }

属性值

类型：String
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator.FullString 属性

活字格插件API文档

LocationIndicatorFullString 属性

返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string FullString { get; }

属性值

类型：String
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator.Parent 属性

活字格插件API文档

LocationIndicatorParent 属性

父节点

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public LocationIndicator Parent { get; }

属性值

类型：LocationIndicator
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator.Root 属性

活字格插件API文档

LocationIndicatorRoot 属性

根坐标定位器。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public LocationIndicator Root { get; }

属性值

类型：LocationIndicator
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator 方法

LocationIndicator 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator.Append 方法

活字格插件API文档

LocationIndicatorAppend 方法

拼接一个坐标定位器。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public LocationIndicator Append(
    LocationIndicator location
)

参数

location
类型：GrapeCity.Forguncy.PluginLocationIndicator
要拼接的坐标定位器。

返回值

类型：LocationIndicator
返回拼接后的坐标定位器。
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator.Enum 方法

活字格插件API文档

LocationIndicatorEnum 方法

遍历当前坐标定位器以及该链表中所有的父坐标定位器。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IEnumerable<LocationIndicator> Enum()

返回值

类型：IEnumerable LocationIndicator
返回包括父坐标定位器在内的链表中的坐标定位器。
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicator.GetPathString 方法

活字格插件API文档

LocationIndicatorGetPathString 方法

基于拼接符和过滤方法返回坐标定位器的查找路径。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string GetPathString(
    string seperator,
    Func<LocationIndicator, bool> filter = null
)

参数

seperator
类型：SystemString
拼接符
filter (Optional)
类型：SystemFunc LocationIndicator, Boolean
过滤方法

返回值

类型：String
返回查找路径。
参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicatorExtension 类

坐标定位器扩展类。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocationIndicatorExtension

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public static class LocationIndicatorExtension

LocationIndicatorExtension 类型公开以下成员。

方法
名称 | 说明
AppendProperty | 增加一个属性定位器。
ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


LocationIndicatorExtension 方法

LocationIndicatorExtension 类型公开以下成员。

方法
名称 | 说明
AppendProperty | 增加一个属性定位器。
ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
Top
参见

引用

LocationIndicatorExtension 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicatorExtension.AppendProperty 方法

活字格插件API文档

LocationIndicatorExtensionAppendProperty 方法

增加一个属性定位器。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public static LocationIndicator AppendProperty(
    this LocationIndicator current,
    string propertyName
)

参数

current
类型：GrapeCity.Forguncy.PluginLocationIndicator
当前坐标定位器。
propertyName
类型：SystemString
要增加的属性定位器的名称。

返回值

类型：LocationIndicator
返回增加了属性定位器的坐标定位器。

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 LocationIndicator 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

LocationIndicatorExtension 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicatorExtension.ContainObject 方法

活字格插件API文档

LocationIndicatorExtensionContainObject 方法

坐标定位器所在链表中的对象定位器中是否包含特定的对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public static bool ContainObject(
    this LocationIndicator current,
    Object obj
)

参数

current
类型：GrapeCity.Forguncy.PluginLocationIndicator
当前坐标定位器。
obj
类型：SystemObject
查找的对象。

返回值

类型：Boolean
返回true则包含，否则不包含。

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 LocationIndicator 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

LocationIndicatorExtension 类
GrapeCity.Forguncy.Plugin 命名空间


LocationIndicatorExtension.ContainProperty 方法

活字格插件API文档

LocationIndicatorExtensionContainProperty 方法

坐标定位器所在链表中的属性定位器中是否包含特定的属性。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public static bool ContainProperty(
    this LocationIndicator current,
    string property
)

参数

current
类型：GrapeCity.Forguncy.PluginLocationIndicator
当前坐标定位器。
property
类型：SystemString
查找的属性名称。

返回值

类型：Boolean
返回true则包含，否则不包含。

备注

在 Visual Basic 和 C# 中，这个方法可以当成为类型 LocationIndicator 的实例方法来调用。在采用实例方法语法调用这个方法时，请省略第一个参数。请参考 扩展方法 (Visual Basic) 或 扩展方法 (C# 编程指南) 获取更多信息。
参见

引用

LocationIndicatorExtension 类
GrapeCity.Forguncy.Plugin 命名空间


NameIndicator 类

名称定位器，一种特定类型的坐标定位器。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocationIndicator
GrapeCity.Forguncy.PluginNameIndicator
GrapeCity.Forguncy.PluginPropertyIndicator

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class NameIndicator : LocationIndicator

NameIndicator 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | NameIndicator | 初始化 NameIndicator 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字，应用于查找到引用的路径中。 (重写 LocationIndicatorDisplayString.)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Name | 当前坐标定位器的名称。
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


NameIndicator 构造函数

初始化 NameIndicator 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public NameIndicator()
参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


NameIndicator 属性

NameIndicator 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字，应用于查找到引用的路径中。 (重写 LocationIndicatorDisplayString.)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Name | 当前坐标定位器的名称。
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


NameIndicator.DisplayString 属性

活字格插件API文档

NameIndicatorDisplayString 属性

当前坐标定位器的显示文字，应用于查找到引用的路径中。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string DisplayString { get; }

属性值

类型：String
参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


NameIndicator.Name 属性

活字格插件API文档

NameIndicatorName 属性

当前坐标定位器的名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Name { get; set; }

属性值

类型：String
参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


NameIndicator 方法

NameIndicator 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator 类

对象定位器，一种特定类型的坐标定位器。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocationIndicator
GrapeCity.Forguncy.PluginObjectIndicator
GrapeCity.Forguncy.PluginObjectIndicatorT

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class ObjectIndicator : LocationIndicator

ObjectIndicator 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ObjectIndicator | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字。 (继承自 LocationIndicator。)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Object | 对象定位器中的对象。
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ObjectIndicator(
    Object obj
)

参数

obj
类型：SystemObject
对象。
参见

引用

ObjectIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator 属性

ObjectIndicator 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字。 (继承自 LocationIndicator。)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Object | 对象定位器中的对象。
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
参见

引用

ObjectIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator.Object 属性

活字格插件API文档

ObjectIndicatorObject 属性

对象定位器中的对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Object { get; }

属性值

类型：Object
参见

引用

ObjectIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator 方法

ObjectIndicator 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

ObjectIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator(T) 类

活字格插件API文档

ObjectIndicatorT 类

特定类型的对象定位器。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocationIndicator
GrapeCity.Forguncy.PluginObjectIndicator
GrapeCity.Forguncy.PluginObjectIndicatorT

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class ObjectIndicator<T> : ObjectIndicator

类型参数

T
特定类型。

ObjectIndicatorT 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ObjectIndicatorT | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字。 (继承自 LocationIndicator。)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Object | 特定类型的对象。
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator(T) 构造函数

活字格插件API文档

ObjectIndicatorT 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ObjectIndicator(
    T obj
)

参数

obj
类型：T
特定类型的对象。
参见

引用

ObjectIndicatorT 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator(T) 属性

活字格插件API文档

ObjectIndicatorT 属性

ObjectIndicatorT 泛型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字。 (继承自 LocationIndicator。)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Object | 特定类型的对象。
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
参见

引用

ObjectIndicatorT 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator(T).Object 属性

活字格插件API文档

ObjectIndicatorTObject 属性

特定类型的对象。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public T Object { get; }

属性值

类型：T
参见

引用

ObjectIndicatorT 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectIndicator(T) 方法

活字格插件API文档

ObjectIndicatorT 方法

ObjectIndicatorT 泛型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

ObjectIndicatorT 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectListPropertyAttribute 类

用于标注对象列表类型的属性，被标注的类型必须是IEnumerable<INamedObject>
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginHyperlinkEdtiorPropertyAttribute
GrapeCity.Forguncy.PluginObjectListPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ObjectListPropertyAttribute : HyperlinkEdtiorPropertyAttribute

ObjectListPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ObjectListPropertyAttribute | 初始化 ObjectListPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultName | 默认元素名前缀
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | ItemType | 元素类型
公共属性 | MaxCount | 列表中元素的最大个数，为-1表示不限制最大个数。默认值为-1
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ObjectListPropertyAttribute 构造函数

初始化 ObjectListPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ObjectListPropertyAttribute()
参见

引用

ObjectListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectListPropertyAttribute 属性

ObjectListPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultName | 默认元素名前缀
公共属性 | IndentLevel | 表示是否是顶级链接，次级链接的字体大小会变小并且增加缩进 (继承自 HyperlinkEdtiorPropertyAttribute。)
公共属性 | ItemType | 元素类型
公共属性 | MaxCount | 列表中元素的最大个数，为-1表示不限制最大个数。默认值为-1
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ObjectListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectListPropertyAttribute.DefaultName 属性

活字格插件API文档

ObjectListPropertyAttributeDefaultName 属性

默认元素名前缀

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string DefaultName { get; set; }

属性值

类型：String
参见

引用

ObjectListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectListPropertyAttribute.ItemType 属性

活字格插件API文档

ObjectListPropertyAttributeItemType 属性

元素类型

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Type ItemType { get; set; }

属性值

类型：Type
参见

引用

ObjectListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectListPropertyAttribute.MaxCount 属性

活字格插件API文档

ObjectListPropertyAttributeMaxCount 属性

列表中元素的最大个数，为-1表示不限制最大个数。默认值为-1

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public int MaxCount { get; set; }

属性值

类型：Int32
参见

引用

ObjectListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ObjectListPropertyAttribute 方法

ObjectListPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ObjectListPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


OrderWeightAttribute 类

插件或插件内部属性的权重, 权重越大位置越靠后。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginOrderWeightAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class OrderWeightAttribute : Attribute

OrderWeightAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OrderWeightAttribute | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
示例
C#
复制
public class SignatureCellType : CellType
{
    [OrderWeight(0)]
    public double DotSize
    {
        get;
        set;
    }

    [OrderWeight(1)]
    public double LineMinWidth
    {
        get;
        set;
    }

    ...
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


OrderWeightAttribute 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public OrderWeightAttribute(
    int orderWeight = 0
)

参数

orderWeight (Optional)
类型：SystemInt32
权重值，默认值为0。
参见

引用

OrderWeightAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


OrderWeightAttribute 属性

OrderWeightAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

OrderWeightAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


OrderWeightAttribute 方法

OrderWeightAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

OrderWeightAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


OrientationEidtorSetting 类

排列方向类型的属性对应的编辑器，如单选按钮使用的[布局]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginOrientationEidtorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class OrientationEidtorSetting : BuiltinEditorSetting

OrientationEidtorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | OrientationEidtorSetting | 初始化 OrientationEidtorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的排序方向类型的属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


OrientationEidtorSetting 构造函数

初始化 OrientationEidtorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public OrientationEidtorSetting()
参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


OrientationEidtorSetting 属性

OrientationEidtorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的排序方向类型的属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


OrientationEidtorSetting.TemplateName 属性

活字格插件API文档

OrientationEidtorSettingTemplateName 属性

内置的排序方向类型的属性编辑器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


OrientationEidtorSetting 方法

OrientationEidtorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


PageMetadataJsonIgnoreAttribute 类

忽略运行页面时不需要的属性，例如只用于单元格类型预览的属性。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginPageMetadataJsonIgnoreAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class PageMetadataJsonIgnoreAttribute : Attribute

PageMetadataJsonIgnoreAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PageMetadataJsonIgnoreAttribute | 初始化 PageMetadataJsonIgnoreAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


PageMetadataJsonIgnoreAttribute 构造函数

初始化 PageMetadataJsonIgnoreAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PageMetadataJsonIgnoreAttribute()
参见

引用

PageMetadataJsonIgnoreAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


PageMetadataJsonIgnoreAttribute 属性

PageMetadataJsonIgnoreAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

PageMetadataJsonIgnoreAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


PageMetadataJsonIgnoreAttribute 方法

PageMetadataJsonIgnoreAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

PageMetadataJsonIgnoreAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


PluginUtilities 类

插件公用类。
继承层次
SystemObject
GrapeCity.Forguncy.PluginPluginUtilities

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public static class PluginUtilities

PluginUtilities 类型公开以下成员。

方法
名称 | 说明
CommonClone | 克隆方法，返回一个对象的复制品。
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


PluginUtilities 方法

PluginUtilities 类型公开以下成员。

方法
名称 | 说明
CommonClone | 克隆方法，返回一个对象的复制品。
Top
参见

引用

PluginUtilities 类
GrapeCity.Forguncy.Plugin 命名空间


PluginUtilities.CommonClone 方法

活字格插件API文档

PluginUtilitiesCommonClone 方法

克隆方法，返回一个对象的复制品。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public static Object CommonClone(
    Object obj
)

参数

obj
类型：SystemObject
原对象。

返回值

类型：Object
克隆对象。
参见

引用

PluginUtilities 类
GrapeCity.Forguncy.Plugin 命名空间


PropertyIndicator 类

属性定位器，一种特定类型的坐标定位器。
继承层次
SystemObject
GrapeCity.Forguncy.PluginLocationIndicator
GrapeCity.Forguncy.PluginNameIndicator
GrapeCity.Forguncy.PluginPropertyIndicator

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class PropertyIndicator : NameIndicator

PropertyIndicator 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PropertyIndicator | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字，应用于查找到引用的路径中。 (继承自 NameIndicator。)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Name | 当前坐标定位器的名称。 (继承自 NameIndicator。)
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


PropertyIndicator 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PropertyIndicator(
    string propertyName
)

参数

propertyName
类型：SystemString
属性名称。
参见

引用

PropertyIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


PropertyIndicator 属性

PropertyIndicator 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayString | 当前坐标定位器的显示文字，应用于查找到引用的路径中。 (继承自 NameIndicator。)
公共属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (继承自 LocationIndicator。)
公共属性 | Name | 当前坐标定位器的名称。 (继承自 NameIndicator。)
公共属性 | Parent | 父节点 (继承自 LocationIndicator。)
公共属性 | Root | 根坐标定位器。 (继承自 LocationIndicator。)
Top
参见

引用

PropertyIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


PropertyIndicator 方法

PropertyIndicator 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Append | 拼接一个坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (继承自 LocationIndicator。)
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (继承自 LocationIndicator。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
扩展方法
 | 名称 | 说明
公共扩展器方法 | AppendProperty | 增加一个属性定位器。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。 (由 LocationIndicatorExtension 定义。)
公共扩展器方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。 (由 LocationIndicatorExtension 定义。)
Top
参见

引用

PropertyIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting 类

单元按钮编辑框
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginRadioEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class RadioEditorSetting : BuiltinEditorSetting

RadioEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | RadioEditorSetting | 构造函数
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DisplayMember | 项目文本属性。
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | Source | 项目集合。
公共属性 | TemplateName | 单选按钮对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | ValueMember | 下拉项目值属性。
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting 构造函数

构造函数

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public RadioEditorSetting(
    Object source,
    string displayMember = null,
    string valueMember = null
)

参数

source
类型：SystemObject
项目集合
displayMember (Optional)
类型：SystemString
项目文本属性
valueMember (Optional)
类型：SystemString
项目值属性
参见

引用

RadioEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting 属性

RadioEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | DisplayMember | 项目文本属性。
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | Source | 项目集合。
公共属性 | TemplateName | 单选按钮对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | ValueMember | 下拉项目值属性。
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

RadioEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting.DisplayMember 属性

活字格插件API文档

RadioEditorSettingDisplayMember 属性

项目文本属性。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string DisplayMember { get; }

属性值

类型：String
参见

引用

RadioEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting.Source 属性

活字格插件API文档

RadioEditorSettingSource 属性

项目集合。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Source { get; }

属性值

类型：Object
参见

引用

RadioEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting.TemplateName 属性

活字格插件API文档

RadioEditorSettingTemplateName 属性

单选按钮对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

RadioEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting.ValueMember 属性

活字格插件API文档

RadioEditorSettingValueMember 属性

下拉项目值属性。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string ValueMember { get; }

属性值

类型：String
参见

引用

RadioEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


RadioEditorSetting 方法

RadioEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

RadioEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


RadioGroupPropertyAttribute 类

用于标注单项选择属性编辑框，标注属性必须是字符串类型
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginSelectorPropertyAttribute
GrapeCity.Forguncy.PluginRadioGroupPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class RadioGroupPropertyAttribute : SelectorPropertyAttribute

RadioGroupPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | RadioGroupPropertyAttribute | 初始化 RadioGroupPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DisplayList | 显示文本列表，多值用"|"分隔，可选配置，留空表示显示列表和值列表相同 (继承自 SelectorPropertyAttribute。)
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | ValueList | 值列表，多值用"|"分隔 (继承自 SelectorPropertyAttribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


RadioGroupPropertyAttribute 构造函数

初始化 RadioGroupPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public RadioGroupPropertyAttribute()
参见

引用

RadioGroupPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


RadioGroupPropertyAttribute 属性

RadioGroupPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayList | 显示文本列表，多值用"|"分隔，可选配置，留空表示显示列表和值列表相同 (继承自 SelectorPropertyAttribute。)
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | ValueList | 值列表，多值用"|"分隔 (继承自 SelectorPropertyAttribute。)
Top
参见

引用

RadioGroupPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


RadioGroupPropertyAttribute 方法

RadioGroupPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

RadioGroupPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SaveJsonIgnoreAttribute 类

忽略不需要保存到文档的属性。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginSaveJsonIgnoreAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class SaveJsonIgnoreAttribute : Attribute

SaveJsonIgnoreAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SaveJsonIgnoreAttribute | 初始化 SaveJsonIgnoreAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


SaveJsonIgnoreAttribute 构造函数

初始化 SaveJsonIgnoreAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public SaveJsonIgnoreAttribute()
参见

引用

SaveJsonIgnoreAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SaveJsonIgnoreAttribute 属性

SaveJsonIgnoreAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

SaveJsonIgnoreAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SaveJsonIgnoreAttribute 方法

SaveJsonIgnoreAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

SaveJsonIgnoreAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SearchTagsAttribute 类

控件搜索标记特性，加入了这个特性就可以在搜索框中快速搜索结果
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginSearchTagsAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class SearchTagsAttribute : Attribute

SearchTagsAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | SearchTagsAttribute | 设置搜索标记
Top
属性
 | 名称 | 说明
公共属性 | Tags | 搜索标记
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


SearchTagsAttribute 构造函数

设置搜索标记

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public SearchTagsAttribute(
    params string[] tags
)

参数

tags
类型：SystemString
参见

引用

SearchTagsAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SearchTagsAttribute 属性

SearchTagsAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Tags | 搜索标记
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

SearchTagsAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SearchTagsAttribute.Tags 属性

活字格插件API文档

SearchTagsAttributeTags 属性

搜索标记

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string[] Tags { get; }

属性值

类型：String
参见

引用

SearchTagsAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SearchTagsAttribute 方法

SearchTagsAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

SearchTagsAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SelectorPropertyAttribute 类

选项类标注基类
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginSelectorPropertyAttribute
GrapeCity.Forguncy.PluginComboPropertyAttribute
GrapeCity.Forguncy.PluginRadioGroupPropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public abstract class SelectorPropertyAttribute : Attribute

SelectorPropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
受保护的方法 | SelectorPropertyAttribute | 初始化 SelectorPropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DisplayList | 显示文本列表，多值用"|"分隔，可选配置，留空表示显示列表和值列表相同
公共属性 | IsSelectOnly | 表示只能从选项中选择或者可以编辑，可以编辑时DisplayList属性设置会被无视
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | ValueList | 值列表，多值用"|"分隔
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


SelectorPropertyAttribute 构造函数

初始化 SelectorPropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
protected SelectorPropertyAttribute()
参见

引用

SelectorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SelectorPropertyAttribute 属性

SelectorPropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DisplayList | 显示文本列表，多值用"|"分隔，可选配置，留空表示显示列表和值列表相同
公共属性 | IsSelectOnly | 表示只能从选项中选择或者可以编辑，可以编辑时DisplayList属性设置会被无视
公共属性 | TypeId | (继承自 Attribute。)
公共属性 | ValueList | 值列表，多值用"|"分隔
Top
参见

引用

SelectorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SelectorPropertyAttribute.DisplayList 属性

活字格插件API文档

SelectorPropertyAttributeDisplayList 属性

显示文本列表，多值用"|"分隔，可选配置，留空表示显示列表和值列表相同

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string DisplayList { get; set; }

属性值

类型：String
参见

引用

SelectorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SelectorPropertyAttribute.IsSelectOnly 属性

活字格插件API文档

SelectorPropertyAttributeIsSelectOnly 属性

表示只能从选项中选择或者可以编辑，可以编辑时DisplayList属性设置会被无视

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual bool IsSelectOnly { get; set; }

属性值

类型：Boolean
参见

引用

SelectorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SelectorPropertyAttribute.ValueList 属性

活字格插件API文档

SelectorPropertyAttributeValueList 属性

值列表，多值用"|"分隔

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public virtual string ValueList { get; set; }

属性值

类型：String
参见

引用

SelectorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


SelectorPropertyAttribute 方法

SelectorPropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

SelectorPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ServerIgnorePropertyAttribute 类

服务端忽略此属性
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginServerIgnorePropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ServerIgnorePropertyAttribute : Attribute

ServerIgnorePropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ServerIgnorePropertyAttribute | 初始化 ServerIgnorePropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


ServerIgnorePropertyAttribute 构造函数

初始化 ServerIgnorePropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ServerIgnorePropertyAttribute()
参见

引用

ServerIgnorePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ServerIgnorePropertyAttribute 属性

ServerIgnorePropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ServerIgnorePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


ServerIgnorePropertyAttribute 方法

ServerIgnorePropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ServerIgnorePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo 类

查找数据表的引用时返回的数据表的位置信息。
继承层次
SystemObject
GrapeCity.Forguncy.PluginTableCheckInfo

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class TableCheckInfo

TableCheckInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TableCheckInfo | 构造函数。
Top
属性
 | 名称 | 说明
公共属性 | ColumnNames | 所有的字段名。
公共属性 | TableName | 数据表名。
Top
方法
 | 名称 | 说明
公共方法 | AddColumns | 添加一个或多个字段。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
字段
名称 | 说明
IndicateStringSeperator | 已过时。 废弃属性。
Top
示例
C#
复制
TableCheckInfo info = new TableCheckInfo("table1");
info.AddColumns("column1");
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo 构造函数

构造函数。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TableCheckInfo(
    string tableName
)

参数

tableName
类型：SystemString
数据表名。
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo 属性

TableCheckInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnNames | 所有的字段名。
公共属性 | TableName | 数据表名。
Top
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo.ColumnNames 属性

活字格插件API文档

TableCheckInfoColumnNames 属性

所有的字段名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IList<string> ColumnNames { get; set; }

属性值

类型：IList String
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo.TableName 属性

活字格插件API文档

TableCheckInfoTableName 属性

数据表名。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string TableName { get; }

属性值

类型：String
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo 方法

TableCheckInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | AddColumns | 添加一个或多个字段。
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo.AddColumns 方法

活字格插件API文档

TableCheckInfoAddColumns 方法

添加一个或多个字段。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public void AddColumns(
    params string[] fields
)

参数

fields
类型：SystemString
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo 字段

TableCheckInfo 类型公开以下成员。

字段
名称 | 说明
IndicateStringSeperator | 已过时。 废弃属性。
Top
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableCheckInfo.IndicateStringSeperator 字段

活字格插件API文档

TableCheckInfoIndicateStringSeperator 字段

注意：此 API 现在已过时。

废弃属性。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
[ObsoleteAttribute("Obsolete attribute.")]
public static readonly string IndicateStringSeperator

字段值

类型：String
参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


TableColumnKind 枚举

字段分类。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public enum TableColumnKind
成员
成员名称 | 值 | 说明
BindingColumn | 0 | 普通字段。
FormulaColumn | 1 | 公式字段。
StatisticsColumn | 2 | 统计字段。
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


TableComboTreeSelectorEditorSetting 类

数据表选择器。如数据导航按钮中使用的[导航表]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginTableComboTreeSelectorEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class TableComboTreeSelectorEditorSetting : BuiltinEditorSetting

TableComboTreeSelectorEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TableComboTreeSelectorEditorSetting | 初始化 TableComboTreeSelectorEditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内建数据表选择器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


TableComboTreeSelectorEditorSetting 构造函数

初始化 TableComboTreeSelectorEditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TableComboTreeSelectorEditorSetting()
参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TableComboTreeSelectorEditorSetting 属性

TableComboTreeSelectorEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内建数据表选择器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TableComboTreeSelectorEditorSetting.TemplateName 属性

活字格插件API文档

TableComboTreeSelectorEditorSettingTemplateName 属性

内建数据表选择器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TableComboTreeSelectorEditorSetting 方法

TableComboTreeSelectorEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TextEditorSetting 类

文本类型的属性对应的编辑器，如[水印]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginTextEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class TextEditorSetting : BuiltinEditorSetting

TextEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TextEditorSetting | 初始化 TextEditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的文本编辑器的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
示例
C#
复制
public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
{
    return new TextEditorSetting();
}
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


TextEditorSetting 构造函数

初始化 TextEditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TextEditorSetting()
参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TextEditorSetting 属性

TextEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置的文本编辑器的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TextEditorSetting.TemplateName 属性

活字格插件API文档

TextEditorSettingTemplateName 属性

内置的文本编辑器的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TextEditorSetting 方法

TextEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TimeValueEditorSetting 类

时间类型编辑器。如时间单元类型使用的[下拉框开始时间]属性。
继承层次
SystemObject
GrapeCity.Forguncy.PluginEditorSetting
GrapeCity.Forguncy.PluginBuiltinEditorSetting
GrapeCity.Forguncy.PluginTimeValueEditorSetting

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class TimeValueEditorSetting : BuiltinEditorSetting

TimeValueEditorSetting 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | TimeValueEditorSetting | 初始化 TimeValueEditorSetting 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置时间类型属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


TimeValueEditorSetting 构造函数

初始化 TimeValueEditorSetting 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TimeValueEditorSetting()
参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TimeValueEditorSetting 属性

TimeValueEditorSetting 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | DefaultCaptionVisibility | 命令插件中的属性编辑器中的属性名是否显示。 (继承自 EditorSetting。)
公共属性 | IsEnabled | 属性编辑器是否可用。 (继承自 EditorSetting。)
公共属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (继承自 EditorSetting。)
公共属性 | TemplateName | 内置时间类型属性编辑器对应的模板名称。 (重写 BuiltinEditorSettingTemplateName.)
公共属性 | Visibility | 属性编辑器是否可见。 (继承自 EditorSetting。)
Top
参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TimeValueEditorSetting.TemplateName 属性

活字格插件API文档

TimeValueEditorSettingTemplateName 属性

内置时间类型属性编辑器对应的模板名称。

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin.Design (在 GrapeCity.Forguncy.Plugin.Design.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public override string TemplateName { get; }

属性值

类型：String
参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


TimeValueEditorSetting 方法

TimeValueEditorSetting 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
 | GetDataTemplate | 根据模板名称找到对应的属性编辑器的数据模板。 (继承自 BuiltinEditorSetting。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
公共方法 | UpdateDisplayName | 返回属性名称的后缀字符串 (继承自 EditorSetting。)
公共方法 | Validate | 插件内部属性编辑器的校验处理。 (继承自 EditorSetting。)
Top
参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


WindowsIgnorePropertyAttribute 类

具有此标签的属性在Windows认证模式下将不会自动生成UI
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.PluginWindowsIgnorePropertyAttribute

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class WindowsIgnorePropertyAttribute : Attribute

WindowsIgnorePropertyAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | WindowsIgnorePropertyAttribute | 初始化 WindowsIgnorePropertyAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.Plugin 命名空间


WindowsIgnorePropertyAttribute 构造函数

初始化 WindowsIgnorePropertyAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.Plugin
程序集： GrapeCity.Forguncy.Plugin (在 GrapeCity.Forguncy.Plugin.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public WindowsIgnorePropertyAttribute()
参见

引用

WindowsIgnorePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


WindowsIgnorePropertyAttribute 属性

WindowsIgnorePropertyAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

WindowsIgnorePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


WindowsIgnorePropertyAttribute 方法

WindowsIgnorePropertyAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

WindowsIgnorePropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


GrapeCity.Forguncy.ServerApi 命名空间

类
 | 类 | 说明
公共类 | ColumnValuePair | 定义字段的名称和值。
公共类 | EditData | 提供一个数据结构，用于编辑多个数据。
公共类 | FgcMailMessage | 表示邮件信息
公共类 | ForguncyApi | 提供Forguncy服务器端API。 通常情况下，这个类是用来继承而不是直接创建一个新的实例。。
公共类 | GetAttribute | 指定GET方法要执行的Action。
公共类 | ModifyData | 提供一种用于创建多个编辑数据的方法。
公共类 | PostAttribute | 指定POST方法要执行的Action。
公共类 | ScheduleApiAttribute | 指定该Action应定期执行。
公共类 | UserInfo | 定义一个用户帐户数据。
接口
 | 接口 | 说明
公共接口 | IDataAccess | 提供访问Forguncy表的方法。
公共接口 | IEmailSender | 提供一种发送电子邮件的方法。
公共接口 | IUserInfos | 提供用于管理用户帐户的方法。


ColumnValuePair 类

定义字段的名称和值。
继承层次
SystemObject
GrapeCity.Forguncy.ServerApiColumnValuePair

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ColumnValuePair

ColumnValuePair 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ColumnValuePair | 初始化 ColumnValuePair 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | ColumnName | 定义字段的名称。
公共属性 | Value | 定义字段的值。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


ColumnValuePair 构造函数

初始化 ColumnValuePair 类的一个新实例

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ColumnValuePair()
参见

引用

ColumnValuePair 类
GrapeCity.Forguncy.ServerApi 命名空间


ColumnValuePair 属性

ColumnValuePair 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | ColumnName | 定义字段的名称。
公共属性 | Value | 定义字段的值。
Top
参见

引用

ColumnValuePair 类
GrapeCity.Forguncy.ServerApi 命名空间


ColumnValuePair.ColumnName 属性

活字格插件API文档

ColumnValuePairColumnName 属性

定义字段的名称。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string ColumnName { get; set; }

属性值

类型：String
参见

引用

ColumnValuePair 类
GrapeCity.Forguncy.ServerApi 命名空间


ColumnValuePair.Value 属性

活字格插件API文档

ColumnValuePairValue 属性

定义字段的值。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Object Value { get; set; }

属性值

类型：Object
参见

引用

ColumnValuePair 类
GrapeCity.Forguncy.ServerApi 命名空间


ColumnValuePair 方法

ColumnValuePair 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ColumnValuePair 类
GrapeCity.Forguncy.ServerApi 命名空间


EditData 类

提供一个数据结构，用于编辑多个数据。
继承层次
SystemObject
GrapeCity.Forguncy.ServerApiEditData

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class EditData

EditData 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | EditData | 初始化 EditData 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | PrimaryKey | 定义代表主键的字段名/值对。
公共属性 | Values | 定义一个数据列表供编辑。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


EditData 构造函数

初始化 EditData 类的一个新实例

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public EditData()
参见

引用

EditData 类
GrapeCity.Forguncy.ServerApi 命名空间


EditData 属性

EditData 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | PrimaryKey | 定义代表主键的字段名/值对。
公共属性 | Values | 定义一个数据列表供编辑。
Top
参见

引用

EditData 类
GrapeCity.Forguncy.ServerApi 命名空间


EditData.PrimaryKey 属性

活字格插件API文档

EditDataPrimaryKey 属性

定义代表主键的字段名/值对。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ColumnValuePair PrimaryKey { get; set; }

属性值

类型：ColumnValuePair
参见

引用

EditData 类
GrapeCity.Forguncy.ServerApi 命名空间


EditData.Values 属性

活字格插件API文档

EditDataValues 属性

定义一个数据列表供编辑。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public Dictionary<string, Object> Values { get; set; }

属性值

类型：Dictionary String, Object
参见

引用

EditData 类
GrapeCity.Forguncy.ServerApi 命名空间


EditData 方法

EditData 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

EditData 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage 类

表示邮件信息
继承层次
SystemObject
GrapeCity.Forguncy.ServerApiFgcMailMessage

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class FgcMailMessage

FgcMailMessage 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | FgcMailMessage | 初始化 FgcMailMessage 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | Attachments | 附件
公共属性 | BCC | 密送收件人的电子邮件地址。
公共属性 | CC | 抄送收件人的电子邮件地址。
公共属性 | Content | 要发送的电子邮件正文。
公共属性 | From | 发件人的电子邮件地址。
公共属性 | Priority | 邮件重要度（Low,Normal,High），默认值为Normal表示普通。Low表示重要度低，High表示重要度高
公共属性 | SendAsPlainText | 以纯文本格式发送邮件
公共属性 | Title | 要发送的电子邮件标题。
公共属性 | To | 收件人的电子邮件地址。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage 构造函数

初始化 FgcMailMessage 类的一个新实例

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public FgcMailMessage()
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage 属性

FgcMailMessage 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Attachments | 附件
公共属性 | BCC | 密送收件人的电子邮件地址。
公共属性 | CC | 抄送收件人的电子邮件地址。
公共属性 | Content | 要发送的电子邮件正文。
公共属性 | From | 发件人的电子邮件地址。
公共属性 | Priority | 邮件重要度（Low,Normal,High），默认值为Normal表示普通。Low表示重要度低，High表示重要度高
公共属性 | SendAsPlainText | 以纯文本格式发送邮件
公共属性 | Title | 要发送的电子邮件标题。
公共属性 | To | 收件人的电子邮件地址。
Top
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.Attachments 属性

活字格插件API文档

FgcMailMessageAttachments 属性

附件

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<string> Attachments { get; set; }

属性值

类型：List String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.BCC 属性

活字格插件API文档

FgcMailMessageBCC 属性

密送收件人的电子邮件地址。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<string> BCC { get; set; }

属性值

类型：List String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.CC 属性

活字格插件API文档

FgcMailMessageCC 属性

抄送收件人的电子邮件地址。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<string> CC { get; set; }

属性值

类型：List String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.Content 属性

活字格插件API文档

FgcMailMessageContent 属性

要发送的电子邮件正文。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Content { get; set; }

属性值

类型：String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.From 属性

活字格插件API文档

FgcMailMessageFrom 属性

发件人的电子邮件地址。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string From { get; set; }

属性值

类型：String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.Priority 属性

活字格插件API文档

FgcMailMessagePriority 属性

邮件重要度（Low,Normal,High），默认值为Normal表示普通。Low表示重要度低，High表示重要度高

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Priority { get; set; }

属性值

类型：String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.SendAsPlainText 属性

活字格插件API文档

FgcMailMessageSendAsPlainText 属性

以纯文本格式发送邮件

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool SendAsPlainText { get; set; }

属性值

类型：Boolean
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.Title 属性

活字格插件API文档

FgcMailMessageTitle 属性

要发送的电子邮件标题。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Title { get; set; }

属性值

类型：String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage.To 属性

活字格插件API文档

FgcMailMessageTo 属性

收件人的电子邮件地址。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<string> To { get; set; }

属性值

类型：List String
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


FgcMailMessage 方法

FgcMailMessage 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

FgcMailMessage 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi 类

提供Forguncy服务器端API。 通常情况下，这个类是用来继承而不是直接创建一个新的实例。。
继承层次
SystemObject
GrapeCity.Forguncy.ServerApiForguncyApi

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ForguncyApi

ForguncyApi 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ForguncyApi | 初始化 ForguncyApi 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | AppBaseUrl | 应用的Base Url。
公共属性 | Context | 返回AspNetCore HttpContext类的实例。
公共属性 | DataAccess | 返回一个DataAccess类的实例。
公共属性 | EmailSender | 返回EmailSender类的实例。
公共属性 | UserInfos | 返回IUserInfos类的实例。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi 构造函数

初始化 ForguncyApi 类的一个新实例

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ForguncyApi()
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi 属性

ForguncyApi 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AppBaseUrl | 应用的Base Url。
公共属性 | Context | 返回AspNetCore HttpContext类的实例。
公共属性 | DataAccess | 返回一个DataAccess类的实例。
公共属性 | EmailSender | 返回EmailSender类的实例。
公共属性 | UserInfos | 返回IUserInfos类的实例。
Top
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi.AppBaseUrl 属性

活字格插件API文档

ForguncyApiAppBaseUrl 属性

应用的Base Url。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string AppBaseUrl { get; set; }

属性值

类型：String
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi.Context 属性

活字格插件API文档

ForguncyApiContext 属性

返回AspNetCore HttpContext类的实例。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public HttpContext Context { get; set; }

属性值

类型：HttpContext
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi.DataAccess 属性

活字格插件API文档

ForguncyApiDataAccess 属性

返回一个DataAccess类的实例。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IDataAccess DataAccess { get; set; }

属性值

类型：IDataAccess
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi.EmailSender 属性

活字格插件API文档

ForguncyApiEmailSender 属性

返回EmailSender类的实例。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IEmailSender EmailSender { get; set; }

属性值

类型：IEmailSender
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi.UserInfos 属性

活字格插件API文档

ForguncyApiUserInfos 属性

返回IUserInfos类的实例。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public IUserInfos UserInfos { get; set; }

属性值

类型：IUserInfos
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


ForguncyApi 方法

ForguncyApi 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ForguncyApi 类
GrapeCity.Forguncy.ServerApi 命名空间


GetAttribute 类

指定GET方法要执行的Action。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.ServerApiGetAttribute

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class GetAttribute : Attribute

GetAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | GetAttribute | 初始化 GetAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


GetAttribute 构造函数

初始化 GetAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public GetAttribute()
参见

引用

GetAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


GetAttribute 属性

GetAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

GetAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


GetAttribute 方法

GetAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GetAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess 接口

提供访问Forguncy表的方法。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IDataAccess

IDataAccess 类型公开以下成员。

方法
名称 | 说明
AddTableData | 将数据添加到指定的表。
DeleteTableData | 从表中删除与指定值匹配的记录。
GetTableData(String) | 通过指定OData路径获取一条记录。 在资源路径之后指定OData路径，但不包括根URI。
GetTableData(String, ColumnValuePair) | 从表中获取与指定值匹配的记录。
ModifyTablesData | 根据多个已编辑的数据更新（添加/编辑/删除）数据。
UpdateTableData | 更新与指定值匹配的记录。
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess 方法

IDataAccess 类型公开以下成员。

方法
名称 | 说明
AddTableData | 将数据添加到指定的表。
DeleteTableData | 从表中删除与指定值匹配的记录。
GetTableData(String) | 通过指定OData路径获取一条记录。 在资源路径之后指定OData路径，但不包括根URI。
GetTableData(String, ColumnValuePair) | 从表中获取与指定值匹配的记录。
ModifyTablesData | 根据多个已编辑的数据更新（添加/编辑/删除）数据。
UpdateTableData | 更新与指定值匹配的记录。
Top
参见

引用

IDataAccess 接口
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess.AddTableData 方法

活字格插件API文档

IDataAccessAddTableData 方法

将数据添加到指定的表。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void AddTableData(
    string tableName,
    Dictionary<string, Object> newValues
)

参数

tableName
类型：SystemString
要向其添加数据的表名。
newValues
类型：System.Collections.GenericDictionary String, Object
作为字段名称和值的集合创建的其他数据。
示例
下面的代码示例根据POST方法基于请求的内容将值添加到Forguncy表。。
复制
public class SampleApi : ForguncyApi
{
    [Post]
    public void AddSampleData()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();

        Dictionary<string, object> values = new Dictionary<string, object>();

        values.Add("date", DateTime.Now);
        values.Add("message", message);
        values.Add("ip", Context.Request.RemoteIpAddress);

        this.DataAccess.AddTableData("SampleTable1", values);
    }
}
参见

引用

IDataAccess 接口
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess.DeleteTableData 方法

活字格插件API文档

IDataAccessDeleteTableData 方法

从表中删除与指定值匹配的记录。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void DeleteTableData(
    string tableName,
    ColumnValuePair primaryKey
)

参数

tableName
类型：SystemString
要删除的表名。
primaryKey
类型：GrapeCity.Forguncy.ServerApiColumnValuePair
字段名称/值对（使用唯一字段）以指定找到的集合。
示例
下面的代码示例根据POST方法发出的请求的内容删除Forguncy表中的特定记录。
复制
public class SampleApi : ForguncyApi
{
    [Post]
    public void DeleteDataSample()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();
        var valuePair = JsonConvert.DeserializeObject<ColumnValuePair>(message);

        this.DataAccess.DeleteTableData("SampleTable1", valuePair);
    }
}
参见

引用

IDataAccess 接口
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess.GetTableData 方法

活字格插件API文档

IDataAccessGetTableData 方法

重载列表
名称 | 说明
GetTableData(String) | 通过指定OData路径获取一条记录。 在资源路径之后指定OData路径，但不包括根URI。
GetTableData(String, ColumnValuePair) | 从表中获取与指定值匹配的记录。
Top
参见

引用

IDataAccess 接口
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess.GetTableData 方法 (String)

活字格插件API文档

IDataAccessGetTableData 方法 (String)

通过指定OData路径获取一条记录。 在资源路径之后指定OData路径，但不包括根URI。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Object GetTableData(
    string odataPath
)

参数

odataPath
类型：SystemString
OData路径。

返回值

类型：Object
示例
下面的代码示例在POST方法中接收OData路径，并基于该路径检索Forguncy表中的记录。
复制
public class SampleApi : ForguncyApi
{
    [Post]
    public void GetDataSampleByOData()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();

        using (var responseWriter = new StreamWriter(this.Context.Response.Body, Encoding.UTF8))
        {
            responseWriter.Write(JsonConvert.SerializeObject(this.DataAccess.GetTableData(message), Formatting.Indented));
        }
    }
}
参见

引用

IDataAccess 接口
GetTableData 重载
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess.GetTableData 方法 (String, ColumnValuePair)

活字格插件API文档

IDataAccessGetTableData 方法 (String, ColumnValuePair)

从表中获取与指定值匹配的记录。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
Dictionary<string, Object> GetTableData(
    string tableName,
    ColumnValuePair primaryKey
)

参数

tableName
类型：SystemString
要获取的表名。
primaryKey
类型：GrapeCity.Forguncy.ServerApiColumnValuePair
字段名称/值对（使用唯一字段）以指定找到的集合

返回值

类型：Dictionary String, Object
示例
下面的代码示例根据POST方法请求的内容在Forguncy表中检索特定记录。
复制
public class SampleApi : ForguncyApi
{
    [Post]
    public void GetDataSample()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();
        var valuePair = JsonConvert.DeserializeObject<ColumnValuePair>(message);

        using (var responseWriter = new StreamWriter(this.Context.Response.Body, Encoding.UTF8))
        {
            responseWriter.Write(JsonConvert.SerializeObject(this.DataAccess.GetTableData("SampleTable1", valuePair), Formatting.Indented));
        }
    }
}
参见

引用

IDataAccess 接口
GetTableData 重载
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess.ModifyTablesData 方法

活字格插件API文档

IDataAccessModifyTablesData 方法

根据多个已编辑的数据更新（添加/编辑/删除）数据。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void ModifyTablesData(
    Dictionary<string, ModifyData> modifyData
)

参数

modifyData
类型：System.Collections.GenericDictionary String, ModifyData
要编辑的数据列表。
示例
下面的代码示例添加，更新和删除多个数据。 添加到DeleteRows属性的ColumnValuePair对象必须指定一个唯一记录，例如ID/值。 添加到EditRows属性的EditData对象的PrimaryKey属性还必须具有唯一记录。
复制
public class SampleApi : ForguncyApi
{
    [Post]
    public void ModifySampleData()
    {
        var data = new Dictionary<string, ModifyData>();
        var modifyData = new ModifyData();
        modifyData.AddRows.Add(new Dictionary<string, object>
        {
            {"フィールド1", 1 },
            {"フィールド2", 2 }
        });
        modifyData.DeleteRows.Add(new ColumnValuePair()
        {
            ColumnName = "ID",
            Value = 2
        });
        modifyData.EditRows.Add(new EditData()
        {
            PrimaryKey = new ColumnValuePair()
            {
                ColumnName = "ID",
                Value = 3
            },
            Values = new Dictionary<string, object>
            {
                {"フィールド1", 1 },
                {"フィールド2", 2 }
            }
        });
        data.Add("テーブル1", modifyData);
        this.DataAccess.ModifyTablesData(data);
    }
}
参见

引用

IDataAccess 接口
GrapeCity.Forguncy.ServerApi 命名空间


IDataAccess.UpdateTableData 方法

活字格插件API文档

IDataAccessUpdateTableData 方法

更新与指定值匹配的记录。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void UpdateTableData(
    string tableName,
    ColumnValuePair primaryKey,
    Dictionary<string, Object> updateValues
)

参数

tableName
类型：SystemString
更新目标表名称。
primaryKey
类型：GrapeCity.Forguncy.ServerApiColumnValuePair
字段名称/值对（使用唯一字段）以指定找到的集合。
updateValues
类型：System.Collections.GenericDictionary String, Object
要被更新的值，Key表示列名，值是要被更新的值。
示例
下面的代码示例根据POST方法请求的内容更新Forguncy表中的特定记录。。
复制
public class SampleApi : ForguncyApi
{
    [Post]
    public void UpdateDataSample()
    {
        StreamReader reader = new StreamReader(this.Context.Request.Body);
        string message = reader.ReadToEnd();
        UpdateObj updateData = JsonConvert.DeserializeObject<UpdateObj>(message);
        var targetRecord = new ColumnValuePair() { ColumnName = "ID", Value = updateData.ID };

        this.DataAccess.UpdateTableData("SampleTable1", targetRecord, updateData.UpdateData);
    }
}
参见

引用

IDataAccess 接口
GrapeCity.Forguncy.ServerApi 命名空间


IEmailSender 接口

提供一种发送电子邮件的方法。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IEmailSender
方法
名称 | 说明
SendEmail(FgcMailMessage) | 将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。
SendEmail(String, ListString, String, String) | 将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。
SendEmail(String, String, String, String) | 将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


IEmailSender 方法

方法
名称 | 说明
SendEmail(FgcMailMessage) | 将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。
SendEmail(String, ListString, String, String) | 将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。
SendEmail(String, String, String, String) | 将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
Top
参见

引用

IEmailSender 接口
GrapeCity.Forguncy.ServerApi 命名空间


IEmailSender.SendEmail 方法

活字格插件API文档

IEmailSenderSendEmail 方法

重载列表
名称 | 说明
SendEmail(FgcMailMessage) | 将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。
SendEmail(String, ListString, String, String) | 将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。
SendEmail(String, String, String, String) | 将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。
Top
参见

引用

IEmailSender 接口
GrapeCity.Forguncy.ServerApi 命名空间


IEmailSender.SendEmail 方法 (FgcMailMessage)

活字格插件API文档

IEmailSenderSendEmail 方法 (FgcMailMessage)

将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string SendEmail(
    FgcMailMessage mailMessage
)

参数

mailMessage
类型：GrapeCity.Forguncy.ServerApiFgcMailMessage
详细的电子邮件信息

返回值

类型：String
示例
プレーンテキスト形式のメールをCCやBCCを含む複数の宛先に送信するコード例を次に示します。
复制
public class SampleApi : ForguncyApi
{
    [Get]
    public void SendMail()
    {
        var message = new FgcMailMessage()
        {
            From = "example@example.com",
            To = new List<string>() { "example1@example.com", "example2@example.com" },
            CC = new List<string>() { "cc1@example.com", "cc2@example.com" },
            BCC = new List<string>() { "bcc1@example.com", "bcc2@example.com" },
            Attachments = new List<string>() { "c:\\2.text", "c:\\2.txt" },
            Title = "testTitle",
            Content = "testContent",
            Priority = "High",
            SendAsPlainText = true
        };
        this.EmailSender.SendEmail(message);
    }
}
参见

引用

IEmailSender 接口
SendEmail 重载
GrapeCity.Forguncy.ServerApi 命名空间


IEmailSender.SendEmail 方法 (String, List(String), String, String)

活字格插件API文档

IEmailSenderSendEmail 方法 (String, ListString, String, String)

将电子邮件发送到指定的电子邮件地址列表。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须设置应用程序的邮件服务器。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string SendEmail(
    string from,
    List<string> to,
    string title,
    string content
)

参数

from
类型：SystemString
发件人的电子邮件地址。
to
类型：System.Collections.GenericList String
收件人的电子邮件地址列表。
title
类型：SystemString
要发送的电子邮件标题。
content
类型：SystemString
要发送的电子邮件正文。

返回值

类型：String
示例
HTMLタグを使用したメールを複数の宛先に送信するコード例を次に示します。
复制
public class SampleApi : ForguncyApi
{
    [Get]
    public void SendMail()
    {
        var toList = new List<string>() { "example1@example.com", "example2@example.com" };
        var errorMessage = this.EmailSender.SendEmail("examplefrom@example.com", toList, "発注警告メール", "<h1>在庫数が少なくなっています</h1><p>在庫数が残りわずかとなりました。発注処理をこなってください。</p>");
        if (string.IsNullOrEmpty(errorMessage))
        {
            // 成功
        }
        else
        {
            // 失敗
        }
    }
}
参见

引用

IEmailSender 接口
SendEmail 重载
GrapeCity.Forguncy.ServerApi 命名空间


IEmailSender.SendEmail 方法 (String, String, String, String)

活字格插件API文档

IEmailSenderSendEmail 方法 (String, String, String, String)

将电子邮件发送到指定的电子邮件地址。 如果发送邮件失败，将返回错误消息。 成功返回一个空字符串。 要使用此方法，必须配置应用程序的邮件服务器设置。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
string SendEmail(
    string from,
    string to,
    string title,
    string content
)

参数

from
类型：SystemString
发件人的电子邮件地址。
to
类型：SystemString
收件人的电子邮件地址。
title
类型：SystemString
要发送的电子邮件标题。
content
类型：SystemString
要发送的电子邮件正文。

返回值

类型：String
示例
以下代码示例使用HTML标签发送电子邮件。
复制
public class SampleApi : ForguncyApi
{
    [Get]
    public void SendMail()
    {
        var errorMessage = this.EmailSender.SendEmail("examplefrom@example.com", "exampleto@example.com", "発注警告メール", "<h1>在庫数が少なくなっています</h1><p>在庫数が残りわずかとなりました。発注処理をこなってください。</p>");
        if (string.IsNullOrEmpty(errorMessage))
        {
            // 成功
        }
        else
        {
            // 失敗
        }
    }
}
参见

引用

IEmailSender 接口
SendEmail 重载
GrapeCity.Forguncy.ServerApi 命名空间


IUserInfos 接口

提供用于管理用户帐户的方法。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public interface IUserInfos

IUserInfos 类型公开以下成员。

方法
名称 | 说明
AddUser | 添加Forguncy用户帐户。
DeleteUser | 删除Forguncy用户帐户。
GetUserInfos | 获取所有注册的Forguncy用户帐户信息。
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


IUserInfos 方法

IUserInfos 类型公开以下成员。

方法
名称 | 说明
AddUser | 添加Forguncy用户帐户。
DeleteUser | 删除Forguncy用户帐户。
GetUserInfos | 获取所有注册的Forguncy用户帐户信息。
Top
参见

引用

IUserInfos 接口
GrapeCity.Forguncy.ServerApi 命名空间


IUserInfos.AddUser 方法

活字格插件API文档

IUserInfosAddUser 方法

添加Forguncy用户帐户。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void AddUser(
    string userName,
    string password,
    string email,
    string displayName,
    Dictionary<string, string> extendedPropertyList
)

参数

userName
类型：SystemString
用户名
password
类型：SystemString
密码
email
类型：SystemString
邮件地址
displayName
类型：SystemString
显示名称
extendedPropertyList
类型：System.Collections.GenericDictionary String, String
扩展属性列表
示例
指定注册所需的信息并添加一个Forguncy用户帐户。。
复制
public class SampleApi : ForguncyApi
{
    [Get]
    public void TestAddUser()
    {
    var dic = new Dictionary<string, string>();
    dic.Add("上長", "Administrator");// '上長'、および'肩書'という名称の拡張属性の値を設定
    dic.Add("肩書", "プロダクトマネージャ");
    this.UserInfos.AddUser("testUser1", "123456", "example1@example.com", "テスト一郎", dic);
    }
}
参见

引用

IUserInfos 接口
GrapeCity.Forguncy.ServerApi 命名空间


IUserInfos.DeleteUser 方法

活字格插件API文档

IUserInfosDeleteUser 方法

删除Forguncy用户帐户。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
void DeleteUser(
    string userName
)

参数

userName
类型：SystemString
用户名
示例
通过用户名删除Forguncy用户帐户。
复制
public class SampleApi : ForguncyApi
{
    [Get]
    public void TestDeleteUser()
    {
        this.UserInfos.DeleteUser("testUser1");
    }
}
参见

引用

IUserInfos 接口
GrapeCity.Forguncy.ServerApi 命名空间


IUserInfos.GetUserInfos 方法

活字格插件API文档

IUserInfosGetUserInfos 方法

获取所有注册的Forguncy用户帐户信息。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
List<UserInfo> GetUserInfos()

返回值

类型：List UserInfo
示例
以下代码示例检索所有Forguncy用户帐户信息并将其打印到控制台。。
复制
public class SampleApi : ForguncyApi
{
    [Get]
    public void TestGetUser()
    {
        var userInfos = this.UserInfos.GetUserInfos();
        for (int i = 0; i < userInfos.Count; i++)

        {
            var userInfo = userInfos[i];
            Console.Write(userInfo.UserName);
            Console.Write(userInfo.Email);
            Console.Write(userInfo.GetPropertyValue("上長")); // '上長'という名称の拡張属性を取得
        }
    }
}
参见

引用

IUserInfos 接口
GrapeCity.Forguncy.ServerApi 命名空间


ModifyData 类

提供一种用于创建多个编辑数据的方法。
继承层次
SystemObject
GrapeCity.Forguncy.ServerApiModifyData

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ModifyData

ModifyData 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | ModifyData | 返回ModifyData类的实例。
Top
属性
 | 名称 | 说明
公共属性 | AddRows | 返回用于一次添加多个记录的列表。
公共属性 | DeleteRows | 返回用于一次删除多个记录的列表。
公共属性 | EditRows | 返回用于一次更新多个记录的列表。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


ModifyData 构造函数

返回ModifyData类的实例。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ModifyData()
参见

引用

ModifyData 类
GrapeCity.Forguncy.ServerApi 命名空间


ModifyData 属性

ModifyData 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | AddRows | 返回用于一次添加多个记录的列表。
公共属性 | DeleteRows | 返回用于一次删除多个记录的列表。
公共属性 | EditRows | 返回用于一次更新多个记录的列表。
Top
参见

引用

ModifyData 类
GrapeCity.Forguncy.ServerApi 命名空间


ModifyData.AddRows 属性

活字格插件API文档

ModifyDataAddRows 属性

返回用于一次添加多个记录的列表。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<Dictionary<string, Object>> AddRows { get; }

属性值

类型：List Dictionary String, Object
参见

引用

ModifyData 类
GrapeCity.Forguncy.ServerApi 命名空间


ModifyData.DeleteRows 属性

活字格插件API文档

ModifyDataDeleteRows 属性

返回用于一次删除多个记录的列表。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<ColumnValuePair> DeleteRows { get; }

属性值

类型：List ColumnValuePair
参见

引用

ModifyData 类
GrapeCity.Forguncy.ServerApi 命名空间


ModifyData.EditRows 属性

活字格插件API文档

ModifyDataEditRows 属性

返回用于一次更新多个记录的列表。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public List<EditData> EditRows { get; }

属性值

类型：List EditData
参见

引用

ModifyData 类
GrapeCity.Forguncy.ServerApi 命名空间


ModifyData 方法

ModifyData 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ModifyData 类
GrapeCity.Forguncy.ServerApi 命名空间


PostAttribute 类

指定POST方法要执行的Action。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.ServerApiPostAttribute

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class PostAttribute : Attribute

PostAttribute 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | PostAttribute | 初始化 PostAttribute 类的一个新实例
Top
属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


PostAttribute 构造函数

初始化 PostAttribute 类的一个新实例

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public PostAttribute()
参见

引用

PostAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


PostAttribute 属性

PostAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

PostAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


PostAttribute 方法

PostAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

PostAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute 类

指定该Action应定期执行。
继承层次
SystemObject
SystemAttribute
GrapeCity.Forguncy.ServerApiScheduleApiAttribute

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class ScheduleApiAttribute : Attribute

ScheduleApiAttribute 类型公开以下成员。

构造函数
名称 | 说明
ScheduleApiAttribute(String) | 指定Action应以指定的时间间隔定期执行。。
ScheduleApiAttribute(String, String) | 指定这是在指定的时间和时间间隔内执行的预定Action。
Top
属性
 | 名称 | 说明
公共属性 | Interval | 获取当前设置的定期执行间隔。
公共属性 | IsValid | 获取设置的间隔是否有效。
公共属性 | StartWhen | 获取当前设置的定期执行的执行时间。
公共属性 | StartWhenServerStart | 获取是否从Forguncy Server启动时开始安排运行。
公共属性 | TypeId | (继承自 Attribute。)
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute 构造函数

重载列表
名称 | 说明
ScheduleApiAttribute(String) | 指定Action应以指定的时间间隔定期执行。。
ScheduleApiAttribute(String, String) | 指定这是在指定的时间和时间间隔内执行的预定Action。
Top
参见

引用

ScheduleApiAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute 构造函数 (String)

指定Action应以指定的时间间隔定期执行。。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ScheduleApiAttribute(
    string interval
)

参数

interval
类型：SystemString
定期处理间隔。 用诸如“ 3：0：0”之类的字符串指定。
示例
下面是一个每三小时运行一次的方法的示例代码。
复制
public class Class1 : ForguncyApi
{
    [ScheduleApi("3:0:0")]
    public void SampleScheduleApi2()
    {
        // ここに処理を記述します。
    }
}
参见

引用

ScheduleApiAttribute 类
ScheduleApiAttribute 重载
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute 构造函数 (String, String)

指定这是在指定的时间和时间间隔内执行的预定Action。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public ScheduleApiAttribute(
    string startWhen,
    string interval
)

参数

startWhen
类型：SystemString
定期执行时间。 如 "12：30：00"。
interval
类型：SystemString
定期执行的时间间隔。 应指定为字符串，如 "7"。
示例
下面的代码示例是一种每周12:30运行（每周7天）的方法。
复制
public class Class1 : ForguncyApi
{
    [ScheduleApi("12:30:0", "7")]
    public void SampleScheduleApi1()
    {
        // ここに処理を記述します。
    }
}
参见

引用

ScheduleApiAttribute 类
ScheduleApiAttribute 重载
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute 属性

ScheduleApiAttribute 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Interval | 获取当前设置的定期执行间隔。
公共属性 | IsValid | 获取设置的间隔是否有效。
公共属性 | StartWhen | 获取当前设置的定期执行的执行时间。
公共属性 | StartWhenServerStart | 获取是否从Forguncy Server启动时开始安排运行。
公共属性 | TypeId | (继承自 Attribute。)
Top
参见

引用

ScheduleApiAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute.Interval 属性

活字格插件API文档

ScheduleApiAttributeInterval 属性

获取当前设置的定期执行间隔。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TimeSpan Interval { get; }

属性值

类型：TimeSpan
参见

引用

ScheduleApiAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute.IsValid 属性

活字格插件API文档

ScheduleApiAttributeIsValid 属性

获取设置的间隔是否有效。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool IsValid { get; }

属性值

类型：Boolean
参见

引用

ScheduleApiAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute.StartWhen 属性

活字格插件API文档

ScheduleApiAttributeStartWhen 属性

获取当前设置的定期执行的执行时间。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public TimeSpan StartWhen { get; }

属性值

类型：TimeSpan
参见

引用

ScheduleApiAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute.StartWhenServerStart 属性

活字格插件API文档

ScheduleApiAttributeStartWhenServerStart 属性

获取是否从Forguncy Server启动时开始安排运行。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public bool StartWhenServerStart { get; }

属性值

类型：Boolean
参见

引用

ScheduleApiAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


ScheduleApiAttribute 方法

ScheduleApiAttribute 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Attribute。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Attribute。)
公共方法 | GetType | (继承自 Object。)
公共方法 | IsDefaultAttribute | (继承自 Attribute。)
公共方法 | Match | (继承自 Attribute。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

ScheduleApiAttribute 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo 类

定义一个用户帐户数据。
继承层次
SystemObject
GrapeCity.Forguncy.ServerApiUserInfo

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public class UserInfo

UserInfo 类型公开以下成员。

构造函数
 | 名称 | 说明
公共方法 | UserInfo | 给定行数据，初始化UserInfo的新实例。
Top
属性
 | 名称 | 说明
公共属性 | Email | 获取电子邮件地址。
公共属性 | FullName | 获取全名。
公共属性 | Role | 获得角色。
公共属性 | UserName | 获取用户名。
Top
方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPropertyValue | 获取扩展属性。
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

GrapeCity.Forguncy.ServerApi 命名空间


UserInfo 构造函数

给定行数据，初始化UserInfo的新实例。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public UserInfo(
    DataRow row
)

参数

row
类型：System.DataDataRow
数据行
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo 属性

UserInfo 类型公开以下成员。

属性
 | 名称 | 说明
公共属性 | Email | 获取电子邮件地址。
公共属性 | FullName | 获取全名。
公共属性 | Role | 获得角色。
公共属性 | UserName | 获取用户名。
Top
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo.Email 属性

活字格插件API文档

UserInfoEmail 属性

获取电子邮件地址。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Email { get; }

属性值

类型：String
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo.FullName 属性

活字格插件API文档

UserInfoFullName 属性

获取全名。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string FullName { get; }

属性值

类型：String
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo.Role 属性

活字格插件API文档

UserInfoRole 属性

获得角色。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string Role { get; }

属性值

类型：String
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo.UserName 属性

活字格插件API文档

UserInfoUserName 属性

获取用户名。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string UserName { get; }

属性值

类型：String
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo 方法

UserInfo 类型公开以下成员。

方法
 | 名称 | 说明
公共方法 | Equals | (继承自 Object。)
受保护的方法 | Finalize | (继承自 Object。)
公共方法 | GetHashCode | (继承自 Object。)
公共方法 | GetPropertyValue | 获取扩展属性。
公共方法 | GetType | (继承自 Object。)
受保护的方法 | MemberwiseClone | (继承自 Object。)
公共方法 | ToString | (继承自 Object。)
Top
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间


UserInfo.GetPropertyValue 方法

活字格插件API文档

UserInfoGetPropertyValue 方法

获取扩展属性。

命名空间： GrapeCity.Forguncy.ServerApi
程序集： GrapeCity.Forguncy.ServerApi (在 GrapeCity.Forguncy.ServerApi.dll 中) 版本：8.0.3.0 (8.0.3.0)
语法
C#
复制
public string GetPropertyValue(
    string propertyName
)

参数

propertyName
类型：SystemString
扩展属性名

返回值

类型：String
参见

引用

UserInfo 类
GrapeCity.Forguncy.ServerApi 命名空间