%%ItemTitle%%

Forguncy.Commands
Forguncy.Commands 程序集
命名空间
命名空间 | 说明
GrapeCity.Forguncy.Commands |
Send Feedback


%%ItemTitle%%

Forguncy.Commands
GrapeCity.Forguncy.Commands 命名空间
继承层次
类
 | 类 | 说明
类 | Command | 命令类型插件的父类定义。
接口
 | 接口 | 说明
接口 | IBuilderCommandContext | 命令编辑上下文信息。
接口 | ICommandCellInfo | 命令单元格信息。详情参照。
接口 | ICommandChecker | 如果执行命令需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
接口 | ICommandEditor | 插件命令数据编辑器。
接口 | ICommandExecutableInServerSide | 具有可独立执行能力的命令需要实现这个接口。 用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。
接口 | ICommandScopeCommandEditor | 内部使用。
接口 | IServerCommandExecuteContext | 当在服务器端执行实现了ICommandExecutableInServerSide接口的命令时，从服务器端传递的上下文信息。
枚举
 | 枚举 | 说明
枚举 | CommandScope | 活字格打开编辑命令窗口时会根据使用范围的不同显示不同的命令集合，该Flags枚举列出了以下几种范围。
请参见

引用

Forguncy.Commands 程序集


%%PageItemTitle%%

Forguncy.Commands
Command 类
成员 示例
GrapeCity.Forguncy.Commands 命名空间 : Command 类
命令类型插件的父类定义。
语法
  • C#
[Icon(pack://application:,,,/Forguncy;component/Images/EditingCommand16.png)]
public abstract class Command
示例
  • C#
public class MyPluginCommand : Command
{
    ...
}
继承层次

System.Object
GrapeCity.Forguncy.Commands.Command

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 成员
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Members$$

Forguncy.Commands
Command 类 成员
属性 方法

GrapeCity.Forguncy.Commands 命名空间 : Command 类

以下表中列出了Command的公开成员.

公共 属性
 | 名称 | 说明
Public 属性 | Comments | 命令的注释。
Public 属性 | Disabled | 命令是否被禁用。
页首
公共 方法
 | 名称 | 说明
Public 方法 | Clone | 克隆命令插件。
Public 方法 | ContainSubCommands | 指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
Public 方法 | GetCommandEditor | 返回命令插件对应的编辑器。
Public 方法 | GetCommandScope | 指定命令插件的使用范围。
Public 方法 | GetEditorSetting | 返回插件命令内部属性对应的编辑器。
Public 方法 | ToString | 命令插件的显示名称，默认与插件定义的类名一样。
Public 方法 | WillNavigateOrReload | 该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
页首
请参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Methods$$

Forguncy.Commands
Command 类 方法

GrapeCity.Forguncy.Commands 命名空间 : Command 类

所有这类成员的列表, 请看 Command 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Clone | 克隆命令插件。
Public 方法 | ContainSubCommands | 指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
Public 方法 | GetCommandEditor | 返回命令插件对应的编辑器。
Public 方法 | GetCommandScope | 指定命令插件的使用范围。
Public 方法 | GetEditorSetting | 返回插件命令内部属性对应的编辑器。
Public 方法 | ToString | 命令插件的显示名称，默认与插件定义的类名一样。
Public 方法 | WillNavigateOrReload | 该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
页首
请参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
Clone 方法 (Command)
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : Clone 方法
克隆命令插件。
语法
  • C#
public virtual Command Clone()

返回值

返回克隆后的命令。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%ItemTitle%%

Forguncy.Commands
ContainSubCommands 方法
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : ContainSubCommands 方法
指定该命令插件是否包含子命令。 包含子命令的有条件命令，循环命令等；不包含子命令的有跳转页面命令等。
语法
  • C#
public virtual bool ContainSubCommands()

返回值

返回true表示包含子命令，否则不包含。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%ItemTitle%%

Forguncy.Commands
GetCommandEditor 方法
示例
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : GetCommandEditor 方法
返回命令插件对应的编辑器。
语法
  • C#
public virtual ICommandEditor GetCommandEditor()

返回值

返回命令对应的编辑器。
示例

UserControl和自定义插件弹出消息框命令定义如下：

  • C#
public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
{
    public ShowMessageCommandEditor()
    {
       InitializeComponent();
    }

    public Command Command
    {
        get
        {
            return new ShowMessageBoxCommand() { Message = messageTextBox.Text };  //messageTextBox is the name of TextBox in UserControl.
        }
        set
        {
            ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
            if(command != null)
            {
                messageTextBox.Text = command.Message;
            }
        }
    }

    public bool Validate()
    {
        return true;
    }
}

public class ShowMessageBoxCommand: Command
{
    public string Message { get; set; }

    public override ICommandEditor GetCommandEditor() => new ShowMessageCommandEditor();
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%ItemTitle%%

Forguncy.Commands
GetCommandScope 方法
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : GetCommandScope 方法
指定命令插件的使用范围。
语法
  • C#
public virtual CommandScope GetCommandScope()

返回值

返回命令的使用范围。
示例
示例请参照CommandScope
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%ItemTitle%%

Forguncy.Commands
GetEditorSetting 方法 (Command)
示例
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : GetEditorSetting 方法
命令内部属性
命令编辑上下文信息。
返回插件命令内部属性对应的编辑器。
语法
  • C#
public virtual EditorSetting GetEditorSetting(
   PropertyDescriptor property,
   IBuilderCommandContext builderContext
)

参数

property
命令内部属性
builderContext
命令编辑上下文信息。

返回值

返回插件命令内部属性对应的编辑器。
示例
  • C#
public class WorkflowCommand : Command
{
    public string TableName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if (property.Name == "TableName")
        {
            return new ComboEditorSetting(builderContext.EnumAllTableInfos().Where(t => t.WorkflowInfo != null && t.WorkflowInfo.IsEnabled).Select(t => t.TableName));
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%ItemTitle%%

Forguncy.Commands
ToString 方法 (Command)
示例
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : ToString 方法
命令插件的显示名称，默认与插件定义的类名一样。
语法
  • C#
public override string ToString()

返回值

返回在命令列表中该命令插件的显示名称。
示例
  • C#
public class ShowMessageBoxCommand : Command
{
    public override string ToString()
    {
        return "消息框命令";
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%ItemTitle%%

Forguncy.Commands
WillNavigateOrReload 方法
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : WillNavigateOrReload 方法
该命令插件执行之后是否会跳转到其他页面或者刷新。 如果返回True，运行页面时会提示用户该命令之后的命令有可能不执行，如跳转页面命令。
语法
  • C#
public virtual bool WillNavigateOrReload()

返回值

返回true表示该命令插件后续的命令会停止执行，返回false表示该命令插件执行不会影响后续命令的执行。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%PageItemTitle%% $$Properties$$

Forguncy.Commands
Command 类 属性

GrapeCity.Forguncy.Commands 命名空间 : Command 类

所有这类成员的列表, 请看 Command 成员.

公共 属性
 | 名称 | 说明
Public 属性 | Comments | 命令的注释。
Public 属性 | Disabled | 命令是否被禁用。
页首
请参见

引用

Command 类
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
Comments 属性
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : Comments 属性
命令的注释。
语法
  • C#
[DefaultValue()]
[Browsable(false)]
public string Comments {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%ItemTitle%%

Forguncy.Commands
Disabled 属性
GrapeCity.Forguncy.Commands 命名空间 > Command 类 : Disabled 属性
命令是否被禁用。
语法
  • C#
[DefaultValue()]
[Browsable(false)]
public bool Disabled {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

Command 类
Command 成员


%%PageItemTitle%%

Forguncy.Commands
CommandScope 枚举
示例 示例
GrapeCity.Forguncy.Commands 命名空间 : CommandScope 枚举
活字格打开编辑命令窗口时会根据使用范围的不同显示不同的命令集合，该Flags枚举列出了以下几种范围。
语法
  • C#
[Flags()]
public enum CommandScope : System.Enum
成员
成员 | 说明
All | 所有集合。
Cell | 普通单元格中。
ListView | 表格中的单元格中。
NoneNotification | 非通知类。
Notification | 通知用命令。
PageLoad | 页面加载中。
Workflow | 工作流中。
示例
  • C#
public class DeleteRecordCommand : Command
{
    public override CommandScope GetCommandScope()
    {
        return CommandScope.ListView;
    }
}
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Commands.CommandScope

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%%

Forguncy.Commands
IBuilderCommandContext 接口
成员
GrapeCity.Forguncy.Commands 命名空间 : IBuilderCommandContext 接口
命令编辑上下文信息。
对象模型
IBuilderCommandContext 接口ICommandCellInfo 接口IUserServiceInfo 接口
语法
  • C#
public interface IBuilderCommandContext : GrapeCity.Forguncy.Plugin.IBuilderContextBase
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderCommandContext 成员
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Members$$

Forguncy.Commands
IBuilderCommandContext 接口 成员
属性 方法

GrapeCity.Forguncy.Commands 命名空间 : IBuilderCommandContext 接口

以下表中列出了IBuilderCommandContext的公开成员.

公共 属性
 | 名称 | 说明
属性 | CommandCell | 返回设置了命令的单元格信息。
属性 | PageName | 获取当前所在页面名称。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
属性 | UserServiceInfo | 获取用户管理网站的信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
页首
公共 方法
 | 名称 | 说明
方法 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllPageInfos | 获取所有的页面信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllTableInfos | 获取所有的数据表信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | GetCell | 重载. 返回指定页面指定行列的单元格信息。
页首
请参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Methods$$

Forguncy.Commands
IBuilderCommandContext 接口 方法

GrapeCity.Forguncy.Commands 命名空间 : IBuilderCommandContext 接口

所有这类成员的列表, 请看 IBuilderCommandContext 成员.

公共 方法
 | 名称 | 说明
方法 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllPageInfos | 获取所有的页面信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllTableInfos | 获取所有的数据表信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | GetCell | 重载. 返回指定页面指定行列的单元格信息。
页首
请参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
GetCell 方法
GrapeCity.Forguncy.Commands 命名空间 > IBuilderCommandContext 接口 : GetCell 方法
返回指定页面指定行列的单元格信息。
重载列表
重载 | 说明
GetCell(String,Int32,Int32) | 返回指定页面指定行列的单元格信息。
GetCell(IFormulaReferObject) | 返回引用单元格公式所在的单元格信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderCommandContext 接口
IBuilderCommandContext 成员


%%ItemTitle%%

Forguncy.Commands
GetCell(String,Int32,Int32) 方法
GrapeCity.Forguncy.Commands 命名空间 > IBuilderCommandContext 接口 > GetCell 方法 : GetCell(String,Int32,Int32) 方法
页面名称。
行索引。
列索引。
返回指定页面指定行列的单元格信息。
语法
  • C#
ICommandCellInfo GetCell(
   string pageName,
   int row,
   int column
)

参数

pageName
页面名称。
row
行索引。
column
列索引。

返回值

返回指定页面指定行列的单元格信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderCommandContext 接口
IBuilderCommandContext 成员
重载列表


%%ItemTitle%%

Forguncy.Commands
GetCell(IFormulaReferObject) 方法
GrapeCity.Forguncy.Commands 命名空间 > IBuilderCommandContext 接口 > GetCell 方法 : GetCell(IFormulaReferObject) 方法
引用单元格公式。
返回引用单元格公式所在的单元格信息。
语法
  • C#
ICommandCellInfo GetCell(
   IFormulaReferObject obj
)

参数

obj
引用单元格公式。

返回值

返回引用单元格公式所在的单元格信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderCommandContext 接口
IBuilderCommandContext 成员
重载列表


%%PageItemTitle%% $$Properties$$

Forguncy.Commands
IBuilderCommandContext 接口 属性

GrapeCity.Forguncy.Commands 命名空间 : IBuilderCommandContext 接口

所有这类成员的列表, 请看 IBuilderCommandContext 成员.

公共 属性
 | 名称 | 说明
属性 | CommandCell | 返回设置了命令的单元格信息。
属性 | PageName | 获取当前所在页面名称。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
属性 | UserServiceInfo | 获取用户管理网站的信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
页首
请参见

引用

IBuilderCommandContext 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
CommandCell 属性
GrapeCity.Forguncy.Commands 命名空间 > IBuilderCommandContext 接口 : CommandCell 属性
返回设置了命令的单元格信息。
语法
  • C#
ICommandCellInfo CommandCell {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderCommandContext 接口
IBuilderCommandContext 成员


%%PageItemTitle%%

Forguncy.Commands
ICommandCellInfo 接口
成员
GrapeCity.Forguncy.Commands 命名空间 : ICommandCellInfo 接口
命令单元格信息。详情参照。
对象模型
ICommandCellInfo 接口IListViewInfo 接口
语法
  • C#
public interface ICommandCellInfo : GrapeCity.Forguncy.Plugin.ICellInfoBase
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandCellInfo 成员
GrapeCity.Forguncy.Commands 命名空间
ICellInfoBase 接口


%%PageItemTitle%% $$Members$$

Forguncy.Commands
ICommandCellInfo 接口 成员
属性

GrapeCity.Forguncy.Commands 命名空间 : ICommandCellInfo 接口

以下表中列出了ICommandCellInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | ListViewInfo | 单元格所在表格的信息。 (从GrapeCity.Forguncy.Plugin.ICellInfoBase继承)
页首
请参见

引用

ICommandCellInfo 接口
GrapeCity.Forguncy.Commands 命名空间
ICellInfoBase 接口


%%PageItemTitle%%

Forguncy.Commands
ICommandChecker 接口
成员 示例
GrapeCity.Forguncy.Commands 命名空间 : ICommandChecker 接口
如果执行命令需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
语法
  • C#
public interface ICommandChecker
示例
  • C#
public class ShowMessageBoxCommand: Command, ICommandChecker
{
    public string Message { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCommandErrors(IBuilderCommandContext context)
    {
        if(string.IsNullOrEmpty(this.Message))
        {
            yield return new ForguncyErrorInfo()
            {
                Message = "消息文本不能为空。",
                ErrorType = ForguncyErrorType.Warning
            };
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandChecker 成员
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Members$$

Forguncy.Commands
ICommandChecker 接口 成员
方法

GrapeCity.Forguncy.Commands 命名空间 : ICommandChecker 接口

以下表中列出了ICommandChecker的公开成员.

公共 方法
 | 名称 | 说明
方法 | CheckCommandErrors | 运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
页首
请参见

引用

ICommandChecker 接口
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Methods$$

Forguncy.Commands
ICommandChecker 接口 方法

GrapeCity.Forguncy.Commands 命名空间 : ICommandChecker 接口

所有这类成员的列表, 请看 ICommandChecker 成员.

公共 方法
 | 名称 | 说明
方法 | CheckCommandErrors | 运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
页首
请参见

引用

ICommandChecker 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
CheckCommandErrors 方法
GrapeCity.Forguncy.Commands 命名空间 > ICommandChecker 接口 : CheckCommandErrors 方法
与执行命令相关的上下文信息
运行页面时检查与命令相关的所有错误和提醒列表并返回给用户。
语法
  • C#
IEnumerable<ForguncyErrorInfo> CheckCommandErrors(
   IBuilderCommandContext context
)

参数

context
与执行命令相关的上下文信息

返回值

返回与命令插件相关的所有错误和提醒列表。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandChecker 接口
ICommandChecker 成员


%%PageItemTitle%%

Forguncy.Commands
ICommandEditor 接口
成员 示例
GrapeCity.Forguncy.Commands 命名空间 : ICommandEditor 接口
插件命令数据编辑器。
对象模型
ICommandEditor 接口Command 类
语法
  • C#
public interface ICommandEditor
示例

UserControl和自定义插件弹出消息框命令定义如下：

  • C#
public partial class ShowMessageCommandEditor : UserControl, ICommandEditor
{
    public ShowMessageCommandEditor()
    {
       InitializeComponent();
    }

    public Command Command
    {
        get
        {
            return new ShowMessageBoxCommand() { Message = messageTextBox.Text };  //messageTextBox is the name of TextBox in UserControl.
        }
        set
        {
            ShowMessageBoxCommand command = value as ShowMessageBoxCommand;
            if(command != null)
            {
                messageTextBox.Text = command.Message;
            }
        }
    }

    public bool Validate()
    {
        return true;
    }
}
public class ShowMessageBoxCommand: Command
{
    public string Message { get; set; }

    public override ICommandEditor GetCommandEditor() => new ShowMessageCommandEditor();
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandEditor 成员
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Members$$

Forguncy.Commands
ICommandEditor 接口 成员
属性 方法

GrapeCity.Forguncy.Commands 命名空间 : ICommandEditor 接口

以下表中列出了ICommandEditor的公开成员.

公共 属性
 | 名称 | 说明
属性 | Command | 命令数据。
页首
公共 方法
 | 名称 | 说明
方法 | Validate | 编辑器关闭前的数据校验。
页首
请参见

引用

ICommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Methods$$

Forguncy.Commands
ICommandEditor 接口 方法

GrapeCity.Forguncy.Commands 命名空间 : ICommandEditor 接口

所有这类成员的列表, 请看 ICommandEditor 成员.

公共 方法
 | 名称 | 说明
方法 | Validate | 编辑器关闭前的数据校验。
页首
请参见

引用

ICommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
Validate 方法
GrapeCity.Forguncy.Commands 命名空间 > ICommandEditor 接口 : Validate 方法
编辑器关闭前的数据校验。
语法
  • C#
bool Validate()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandEditor 接口
ICommandEditor 成员


%%PageItemTitle%% $$Properties$$

Forguncy.Commands
ICommandEditor 接口 属性

GrapeCity.Forguncy.Commands 命名空间 : ICommandEditor 接口

所有这类成员的列表, 请看 ICommandEditor 成员.

公共 属性
 | 名称 | 说明
属性 | Command | 命令数据。
页首
请参见

引用

ICommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
Command 属性 (ICommandEditor)
GrapeCity.Forguncy.Commands 命名空间 > ICommandEditor 接口 : Command 属性
命令数据。
语法
  • C#
Command Command {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandEditor 接口
ICommandEditor 成员


%%PageItemTitle%%

Forguncy.Commands
ICommandExecutableInServerSide 接口
成员 示例
GrapeCity.Forguncy.Commands 命名空间 : ICommandExecutableInServerSide 接口

具有可独立执行能力的命令需要实现这个接口。

用于在服务器端直接执行命令，不需要从页面端传递上下文即可执行的命令。

语法
  • C#
public interface ICommandExecutableInServerSide
示例
  • C#
public class SendWeChatMessage : Command, ICommandExecutableInServerSide
{
    public object UserId { get; set; }

    public object PartyId { get; set; }

    public object Content { get; set; }

    public string Execute(IServerCommandExecuteContext dataContext)
    {
        var api = new WeChat();
        return api.SendMessage(UserId?.ToString(), PartyId?.ToString(), dataContext.ReplaceKeyWord(Content?.ToString()));
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandExecutableInServerSide 成员
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Members$$

Forguncy.Commands
ICommandExecutableInServerSide 接口 成员
方法

GrapeCity.Forguncy.Commands 命名空间 : ICommandExecutableInServerSide 接口

以下表中列出了ICommandExecutableInServerSide的公开成员.

公共 方法
 | 名称 | 说明
方法 | Execute | 命令执行方法。
页首
请参见

引用

ICommandExecutableInServerSide 接口
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Methods$$

Forguncy.Commands
ICommandExecutableInServerSide 接口 方法

GrapeCity.Forguncy.Commands 命名空间 : ICommandExecutableInServerSide 接口

所有这类成员的列表, 请看 ICommandExecutableInServerSide 成员.

公共 方法
 | 名称 | 说明
方法 | Execute | 命令执行方法。
页首
请参见

引用

ICommandExecutableInServerSide 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
Execute 方法
GrapeCity.Forguncy.Commands 命名空间 > ICommandExecutableInServerSide 接口 : Execute 方法
从服务器端传递给命令执行时的上下文信息。
命令执行方法。
语法
  • C#
string Execute(
   IServerCommandExecuteContext dataContext
)

参数

dataContext
从服务器端传递给命令执行时的上下文信息。

返回值

是否执行成功。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandExecutableInServerSide 接口
ICommandExecutableInServerSide 成员


%%PageItemTitle%%

Forguncy.Commands
ICommandScopeCommandEditor 接口
成员
GrapeCity.Forguncy.Commands 命名空间 : ICommandScopeCommandEditor 接口
内部使用。
语法
  • C#
public interface ICommandScopeCommandEditor
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandScopeCommandEditor 成员
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Members$$

Forguncy.Commands
ICommandScopeCommandEditor 接口 成员
属性

GrapeCity.Forguncy.Commands 命名空间 : ICommandScopeCommandEditor 接口

以下表中列出了ICommandScopeCommandEditor的公开成员.

公共 属性
 | 名称 | 说明
属性 | CommandScope | 内部使用。
页首
请参见

引用

ICommandScopeCommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Properties$$

Forguncy.Commands
ICommandScopeCommandEditor 接口 属性

GrapeCity.Forguncy.Commands 命名空间 : ICommandScopeCommandEditor 接口

所有这类成员的列表, 请看 ICommandScopeCommandEditor 成员.

公共 属性
 | 名称 | 说明
属性 | CommandScope | 内部使用。
页首
请参见

引用

ICommandScopeCommandEditor 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
CommandScope 属性
GrapeCity.Forguncy.Commands 命名空间 > ICommandScopeCommandEditor 接口 : CommandScope 属性
内部使用。
语法
  • C#
CommandScope CommandScope {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandScopeCommandEditor 接口
ICommandScopeCommandEditor 成员


%%PageItemTitle%%

Forguncy.Commands
IServerCommandExecuteContext 接口
成员
GrapeCity.Forguncy.Commands 命名空间 : IServerCommandExecuteContext 接口
当在服务器端执行实现了ICommandExecutableInServerSide接口的命令时，从服务器端传递的上下文信息。
语法
  • C#
public interface IServerCommandExecuteContext
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IServerCommandExecuteContext 成员
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Members$$

Forguncy.Commands
IServerCommandExecuteContext 接口 成员
方法

GrapeCity.Forguncy.Commands 命名空间 : IServerCommandExecuteContext 接口

以下表中列出了IServerCommandExecuteContext的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetCurrentEmailSetting | 返回当前服务器的邮件设置。
方法 | ReplaceKeyWord | 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
方法 | SendMail | 调用该方法可以异步发送邮件。
页首
请参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


%%PageItemTitle%% $$Methods$$

Forguncy.Commands
IServerCommandExecuteContext 接口 方法

GrapeCity.Forguncy.Commands 命名空间 : IServerCommandExecuteContext 接口

所有这类成员的列表, 请看 IServerCommandExecuteContext 成员.

公共 方法
 | 名称 | 说明
方法 | GetCurrentEmailSetting | 返回当前服务器的邮件设置。
方法 | ReplaceKeyWord | 更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
方法 | SendMail | 调用该方法可以异步发送邮件。
页首
请参见

引用

IServerCommandExecuteContext 接口
GrapeCity.Forguncy.Commands 命名空间


%%ItemTitle%%

Forguncy.Commands
GetCurrentEmailSetting 方法
GrapeCity.Forguncy.Commands 命名空间 > IServerCommandExecuteContext 接口 : GetCurrentEmailSetting 方法
返回当前服务器的邮件设置。
语法
  • C#
void GetCurrentEmailSetting()

返回值

返回当前服务器的邮件设置。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IServerCommandExecuteContext 接口
IServerCommandExecuteContext 成员


%%ItemTitle%%

Forguncy.Commands
ReplaceKeyWord 方法
GrapeCity.Forguncy.Commands 命名空间 > IServerCommandExecuteContext 接口 : ReplaceKeyWord 方法
原始字符串。
更换邮件中相关属性关键字的工具方法，返回更换过关键字后的字符串。
语法
  • C#
string ReplaceKeyWord(
   string value
)

参数

value
原始字符串。

返回值

返回更换过关键字后的字符串。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IServerCommandExecuteContext 接口
IServerCommandExecuteContext 成员


%%ItemTitle%%

Forguncy.Commands
SendMail 方法
GrapeCity.Forguncy.Commands 命名空间 > IServerCommandExecuteContext 接口 : SendMail 方法
发送人邮件地址（可以使用用户名）
收件人列表（可以使用用户名）
标题
邮件正文
调用该方法可以异步发送邮件。
语法
  • C#
string SendMail(
   string fromAddress,
   List<string> toList,
   string title,
   string content
)

参数

fromAddress
发送人邮件地址（可以使用用户名）
toList
收件人列表（可以使用用户名）
title
标题
content
邮件正文

返回值

如果有非空返回值表示邮件发送失败
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IServerCommandExecuteContext 接口
IServerCommandExecuteContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GrapeCity.Forguncy.CellTypes 程序集
命名空间
命名空间 | 说明
GrapeCity.Forguncy.CellTypes |
GrapeCity.Forguncy.CellTypes.CellTypeCommon |


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GrapeCity.Forguncy.CellTypes 命名空间
继承层次
类
 | 类 | 说明
类 | CategoryHeaderAttribute | 单元格类型插件中的属性编辑器中的类目属性，如文本框中使用的[显示密码]属性的类目属性[外观]。
类 | CellType | 单元格类型插件的父类定义。
类 | ExportResultInfo | 导出单元格类型的返回结果。
类 | SupportLanguageScopeAttribute | 插件支持的语言版本，如果不指定默认所有语言都支持。
类 | SupportUsingScopeAttribute | 单元格类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
接口
 | 接口 | 说明
接口 | IAttachedInfo | 单元格的附加信息。
接口 | IBindingInfo | 单元格的数据绑定信息，即一旦单元格绑定到A表的B字段,如果页面中存在A表，那么该单元格就会显示当前行的B字段的值。
接口 | IBorderLine | 设置边框。
接口 | IBuilderContext | 插件所需的上下文信息。
接口 | ICanOverflow | 单元格类型是否支持溢出。 例如，如果超链接单元格类型所在的单元格大小不够显示完全字，并且本身和后续单元格均没有合并的情况下，超链接的字会溢出到后续单元格中。
接口 | ICellInfo | 单元格的信息。
接口 | ICellTypeChecker | 如果单元格类型需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
接口 | ICommandCellType | 如果单元格类型本身允许执行命令，需实现该接口。
接口 | ICommandWindow | 活字格内部编辑命令的对话窗口。
接口 | IDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知依赖了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
接口 | IDisablePropertySettings | 获取单元格类型中不可用的样式属性，如对齐方式等。
接口 | IDrawingHelper | 主要用于单元格预览和导出单元格到Excel中的画法。
接口 | IExportCellType | 导出单元格类型有特殊处理时需实现该接口，比如生成图片等。
接口 | IExportContext | 导出单元格类型的上下文信息。
接口 | IExportImageContext | 内部使用。
接口 | IExportValueProvider | 数据访问器，提供数据表的查询结果。
接口 | IForguncyFormatter | 单元格格式。
接口 | IGeneralForguncyFormatter | 内部使用。
接口 | IIgnoreAlternativeRowBackColorWhenExport | 配合IExportCellType使用，导出Excel时不使用页面中表格的交替色作为背景色，如表格中的按钮导出到Excel时不使用交替色作为背景色。
接口 | IQueryConditionWindow | 活字格内置的设置查询条件的对话窗口。 注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现GrapeCity.Forguncy.Plugin.IReferenceFormula和IDependenceCells这两个接口。
接口 | IReferenceCommand | 如果一个单元格不是ICommandCellType，但是该单元格内部属性中有命令设置，如菜单单元格类型，需实现该接口； 否则有些命令执行会出错，而且查找所有引用会有遗漏。
接口 | ISelectImageWindow | 内置图片选择对话窗口。
接口 | ISortConditionWindow | 活字格内置的设置排序条件的对话窗口。
接口 | IStaticValueCellType | 忽略单元格的值，可以自定义单元格类型返回的值； 例如，如果一个单元格引用登录用户单元格类型的值，返回的是当前用户，而非单元格上的值或0.
接口 | IStyleInfo | 设置样式。
接口 | ISupportPropertyInitialize | 设置单元格类型的默认属性值。 例如，可以设置【超链接】单元格的点击模式默认为单元格而非文字区域。
接口 | ISupportStyleInitialize | 设置单元格类型的默认样式和属性。
接口 | IWindow | 内置对话框接口。
枚举
 | 枚举 | 说明
枚举 | CommandExcuteKind | 触发命令时机。
枚举 | CopyFontInfoToControlOption | 主要用于单元格预览和导出单元格到Excel中的画法。
枚举 | DisplayBehaviour | 单元格的默认显示特性。
枚举 | ForguncyAuthenticationMode | 页面认证模式。
枚举 | ForguncyBorderLineStyle | 边框线型列表。
枚举 | ForguncyCellHorizontalAlignment | 单元格水平对齐方式列表。
枚举 | ForguncyCellVerticalAlignment | 单元格垂直对齐方式列表。
枚举 | ForguncyDisabledSettings | 开始菜单中的不可用属性列表。
枚举 | ForguncyPageKind | 页面类型列表。
枚举 | ImeMode | Ime输入模式。
枚举 | LanguageScope | 插件支持的语言版本。
枚举 | ListViewScope | 单元格类型插件或其内部属性所支持的表格使用范围。
枚举 | PageScope | 单元格类型插件或其内部属性所支持的页面使用范围。
枚举 | StylePropertyName | 样式列表。
枚举 | SupportFeatures | 单元格类型的插件支持的特性。
请参见

引用

GrapeCity.Forguncy.CellTypes 程序集


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
CategoryHeaderAttribute 类
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : CategoryHeaderAttribute 类
单元格类型插件中的属性编辑器中的类目属性，如文本框中使用的[显示密码]属性的类目属性[外观]。
语法
  • C#
public class CategoryHeaderAttribute : System.Attribute
示例
  • C#
public class TextCellType :
{
    [CategoryHeader("外观")]
    [DisplayName("显示密码")]
    public bool ShowPassword { get; set; }
}
继承层次

System.Object
System.Attribute
GrapeCity.Forguncy.CellTypes.CategoryHeaderAttribute

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CategoryHeaderAttribute 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
CategoryHeaderAttribute 类 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : CategoryHeaderAttribute 类

以下表中列出了CategoryHeaderAttribute的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | CategoryHeaderAttribute 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | CategoryHeader | 分类标题。
Public 属性 | TypeId | (从System.Attribute继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

CategoryHeaderAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
CategoryHeaderAttribute 构造函数
GrapeCity.Forguncy.CellTypes 命名空间 > CategoryHeaderAttribute 类 : CategoryHeaderAttribute 构造函数
分类标题。
构造函数。
语法
  • C#
public CategoryHeaderAttribute(
   string categoryHeader
)

参数

categoryHeader
分类标题。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CategoryHeaderAttribute 类
CategoryHeaderAttribute 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
CategoryHeaderAttribute 类 属性

GrapeCity.Forguncy.CellTypes 命名空间 : CategoryHeaderAttribute 类

所有这类成员的列表, 请看 CategoryHeaderAttribute 成员.

公共 属性
 | 名称 | 说明
Public 属性 | CategoryHeader | 分类标题。
Public 属性 | TypeId | (从System.Attribute继承)
页首
请参见

引用

CategoryHeaderAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
CategoryHeader 属性
GrapeCity.Forguncy.CellTypes 命名空间 > CategoryHeaderAttribute 类 : CategoryHeader 属性
分类标题。
语法
  • C#
public virtual string CategoryHeader {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CategoryHeaderAttribute 类
CategoryHeaderAttribute 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
CellType 类
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : CellType 类
单元格类型插件的父类定义。
语法
  • C#
[Icon(pack://application:,,,/Forguncy;component/Images/DefaultCellTypeIcon.png)]
public abstract class CellType : GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase
示例
  • C#
public class MyPluginCellType : CellType
{
    ...
}
继承层次

System.Object
GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase
GrapeCity.Forguncy.CellTypes.CellType

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
CellType 类 成员
属性 方法 事件

GrapeCity.Forguncy.CellTypes 命名空间 : CellType 类

以下表中列出了CellType的公开成员.

公共 属性
 | 名称 | 说明
Public 属性 | CellTextPropertyName | 设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
Public 属性 | DefaultAlignment | 单元格类型插件的默认水平对齐方式。
Public 属性 | DisplayBehaviour | 单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
Public 属性 | IsAutoGenerated | 内部使用。
Public 属性 | SupportFeatures | 支持的特性，如设置单元格格式，Tab键设置等。
Public 属性 | TabIndex | Tab键顺序。
页首
公共 方法
 | 名称 | 说明
Public 方法 | Clone | 克隆方法。
Public 方法 | GetCellValue | 获取单元格属性的值从而设值给单元格。
Public 方法 | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
Public 方法 | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
Public 方法 | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
Public 方法 | SetCellValue | 通过单元格本身的值设值给单元格属性。
Public 方法 | ToString | 单元格类型的显示名。 如果不指定，默认与类型名一致。
页首
保护 方法
 | 名称 | 说明
Protected 方法 | CloneImp | 克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase继承)
页首
请参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
CellType 类 方法

GrapeCity.Forguncy.CellTypes 命名空间 : CellType 类

所有这类成员的列表, 请看 CellType 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Clone | 克隆方法。
Public 方法 | GetCellValue | 获取单元格属性的值从而设值给单元格。
Public 方法 | GetDesignerPropertyVisible | 如果需要动态改变属性编辑器的可见性，可以重写该函数。
Public 方法 | GetDrawingControl | 如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
Public 方法 | GetEditorSetting | 获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
Public 方法 | SetCellValue | 通过单元格本身的值设值给单元格属性。
Public 方法 | ToString | 单元格类型的显示名。 如果不指定，默认与类型名一致。
页首
保护 方法
 | 名称 | 说明
Protected 方法 | CloneImp | 克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase继承)
页首
请参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Clone 方法 (CellType)
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : Clone 方法
克隆方法。
语法
  • C#
public CellType Clone()

返回值

克隆后的插件对象。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
CloneImp 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : CloneImp 方法
克隆方法。 如果单元格类型中有自定义复杂类型的属性，该复杂类型就需要实现ICloneable接口，否则会导致复杂类型的数据无法保存。
语法
  • C#
protected virtual CellType CloneImp()

返回值

克隆后的插件对象。
示例
  • C#
public class MenuCellType : CellType
{
    public  List<MenuItemInfo> MenuItems { get; set; }
}

public class MenuItemInfo : ICloneable
{
    public object Value { get; set; }

    public string Text { get; set; }

    public  List<MenuItemInfo> SubMenuItems { get; set; }

    /*here need implement this method.*/
    public object Clone()
    {
        /*todo*/
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetCellValue 方法
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : GetCellValue 方法
返回属性的值
返回属性的格式
获取单元格属性的值从而设值给单元格。
语法
  • C#
public virtual void GetCellValue(
   out object value,
   out string formula
)

参数

value
返回属性的值
formula
返回属性的格式
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetDesignerPropertyVisible 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : GetDesignerPropertyVisible 方法
属性名
如果需要动态改变属性编辑器的可见性，可以重写该函数。
语法
  • C#
public virtual bool GetDesignerPropertyVisible(
   string propertyName
)

参数

propertyName
属性名

返回值

返回True表示属性编辑器可见，否则不可见。
示例
  • C#
public class MenuCellType: CellType
{
    public Orientation Orientation { get; set; }

    public ExpandStyle DefaultExpandStyle { get; set; }

    public override bool GetDesignerPropertyVisible(string propertyName)
    {
        if (propertyName == "DefaultExpandStyle")
        {
            if (Orientation == MenuOrientation.Horizontal)  //如果是水平方向的菜单隐藏默认展开方式。
            {
                return false;
            }
            return true;
        }
        return base.GetDesignerPropertyVisible(propertyName);
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetDrawingControl 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : GetDrawingControl 方法
单元格信息。
画法帮助工具。
如果单元格想要显示预览效果，需重写该方法，返回一个WPF的元素。
语法
  • C#
public virtual FrameworkElement GetDrawingControl(
   ICellInfo cellInfo,
   IDrawingHelper drawingHelper
)

参数

cellInfo
单元格信息。
drawingHelper
画法帮助工具。

返回值

返回WPF元素。
示例
  • C#
public class ButtonGroupCellType : CellType
{
    public string AddButtonText { get; set; }

    public string DeleteButtonText { get; set; }

    public override FrameworkElement GetDrawingControl(ICellInfo cellInfo, IDrawingHelper drawingHelper)
    {
        Button addButton = new Button() { Content = this.AddButtonText };
        Button deleteButton = new Button() { Content = this.DeleteButtonText, Margin = new Thickness(5, 0, 0, 0) };

        Grid container = new Grid();
        container.ColumnDefinitions.Add(new ColumnDefinition() { Width = new GridLength(1, GridUnitType.Star) });
        container.ColumnDefinitions.Add(new ColumnDefinition() { Width = new GridLength(1, GridUnitType.Star) });
        container.Children.Add(addButton);
        container.Children.Add(deleteButton);
        Grid.SetColumn(addButton, 0);
        Grid.SetColumn(deleteButton, 1);

        return container;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetEditorSetting 方法 (CellType)
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : GetEditorSetting 方法
属性信息
上下文信息
获取属性对应的属性编辑器。 如果是简单类型的属性，内部会根据属性的类型自动生成编辑器；复杂类型的属性，可自定义编辑器。 支持的简单属性类型包括： bool/bool? --- CheckBoxEditor int/int? --- IntEditor double/double? --- DoubleEditor Orientation --- OrientationEidtor ImageValue --- ImageEditor TimeSpan --- TimeValueEditor string --- TextEditor enum --- ComboEditor，如果显示文本和值不一样的话，可指定枚举的DescriptionAttribute作为显示文本。 ]]> --- HyperlinkEditor，活字格内部编辑命令的编辑器。 标记FormulaPropertyAttribute --- FormulaSelectorEditor，活字格内部公式编辑器。
语法
  • C#
public virtual EditorSetting GetEditorSetting(
   PropertyDescriptor property,
   IBuilderContext builderContext
)

参数

property
属性信息
builderContext
上下文信息

返回值

属性编辑器。
示例
  • C#
public class MyTextCellType : CellType
{
    public string Text { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if(property.Name == "Text")
        {
            return new TextEditorSetting();
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
SetCellValue 方法
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : SetCellValue 方法
单元格的值
单元格的文本
单元格是否有公式
单元格的格式
通过单元格本身的值设值给单元格属性。
语法
  • C#
public virtual void SetCellValue(
   object value,
   string text,
   bool haveFormula,
   IForguncyFormatter formatter
)

参数

value
单元格的值
text
单元格的文本
haveFormula
单元格是否有公式
formatter
单元格的格式
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ToString 方法 (CellType)
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : ToString 方法
单元格类型的显示名。 如果不指定，默认与类型名一致。
语法
  • C#
public override string ToString()
示例
  • C#
public class MyPluginCellType : CellType
{
    public override string ToString()
    {
        /*return this.GetType().Name;  //默认*/
        return "我的插件";
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
CellType 类 属性

GrapeCity.Forguncy.CellTypes 命名空间 : CellType 类

所有这类成员的列表, 请看 CellType 成员.

公共 属性
 | 名称 | 说明
Public 属性 | CellTextPropertyName | 设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
Public 属性 | DefaultAlignment | 单元格类型插件的默认水平对齐方式。
Public 属性 | DisplayBehaviour | 单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
Public 属性 | IsAutoGenerated | 内部使用。
Public 属性 | SupportFeatures | 支持的特性，如设置单元格格式，Tab键设置等。
Public 属性 | TabIndex | Tab键顺序。
页首
请参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
CellTextPropertyName 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : CellTextPropertyName 属性
设置单元格的显示文本关联到某个属性的值上，如默认值属性。 如果修改了某个单元格属性的值后希望能应用到单元格本身，则需要指定该属性名。
语法
  • C#
public virtual string CellTextPropertyName {get;}
示例
  • C#
public class MyNumberCellType : CellType
{
    [FormulaProperty]
    public object DefaultNumberValue { get; set; }

    public override string CellTextPropertyName
    {
        get
        {
            return "DefaultNumberValue";
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
DefaultAlignment 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : DefaultAlignment 属性
单元格类型插件的默认水平对齐方式。
语法
  • C#
public virtual ForguncyCellHorizontalAlignment DefaultAlignment {get;}
示例
  • C#
public class MyNumberCellType : CellType
{
    public override ForguncyCellHorizontalAlignment DefaultAlignment
    {
        /*return ForguncyCellHorizontalAlignment.General;  //默认对齐方式*/
        return ForguncyCellHorizontalAlignment.Right;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
DisplayBehaviour 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : DisplayBehaviour 属性
单元格类型的显示行为。 如果指定显示行为是DisplayBehaviour.KeepBorderWhenMerge，那么默认生成的单元格类型会带边框，而且Border会随着单元格的合并或取消合并自适应边框的大小。
语法
  • C#
public virtual DisplayBehaviour DisplayBehaviour {get;}
示例
  • C#
public class MyNumberCellType : CellType
{
    public override DisplayBehaviour DisplayBehaviour
    {
        /*return DisplayBehaviour.None;  //默认没有特殊行为。*/
        return DisplayBehaviour.KeepBorderWhenMerge;  /*插件自带边框。*/
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
IsAutoGenerated 属性
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : IsAutoGenerated 属性
内部使用。
语法
  • C#
public bool IsAutoGenerated {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
SupportFeatures 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : SupportFeatures 属性
支持的特性，如设置单元格格式，Tab键设置等。
语法
  • C#
public virtual SupportFeatures SupportFeatures {get;}
示例
  • C#
public class MyNumberCellType : CellType
{
    public override SupportFeatures SupportFeatures
    {
        /*return SupportFeatures.None;  //默认没有特性。*/
        return SupportFeatures.AllowSetFormat;  /*插件支持单元格格式设置。*/
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
TabIndex 属性
GrapeCity.Forguncy.CellTypes 命名空间 > CellType 类 : TabIndex 属性
Tab键顺序。
语法
  • C#
[DefaultValue()]
[Browsable(false)]
public Nullable<int> TabIndex {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CellType 类
CellType 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportResultInfo 类
成员
GrapeCity.Forguncy.CellTypes 命名空间 : ExportResultInfo 类
导出单元格类型的返回结果。
语法
  • C#
public class ExportResultInfo
继承层次

System.Object
GrapeCity.Forguncy.CellTypes.ExportResultInfo

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ExportResultInfo 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ExportResultInfo 类 成员
属性

GrapeCity.Forguncy.CellTypes 命名空间 : ExportResultInfo 类

以下表中列出了ExportResultInfo的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | ExportResultInfo 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | ExportPicture | 导出单元格类型的图片。
Public 属性 | ExportStyleInfos | 导出单元格类型的样式。 例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。
Public 属性 | ExportValue | 导出单元格类型的值。
Public 属性 | NeedResetExportPicture | 导出时是否需要将单元格类型导出为图片。
Public 属性 | NeedResetExportValue | 导出时是否需要重置单元格类型的值。
页首
请参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportResultInfo 构造函数
GrapeCity.Forguncy.CellTypes 命名空间 > ExportResultInfo 类 : ExportResultInfo 构造函数
语法
  • C#
public ExportResultInfo()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ExportResultInfo 类
ExportResultInfo 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
ExportResultInfo 类 属性

GrapeCity.Forguncy.CellTypes 命名空间 : ExportResultInfo 类

所有这类成员的列表, 请看 ExportResultInfo 成员.

公共 属性
 | 名称 | 说明
Public 属性 | ExportPicture | 导出单元格类型的图片。
Public 属性 | ExportStyleInfos | 导出单元格类型的样式。 例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。
Public 属性 | ExportValue | 导出单元格类型的值。
Public 属性 | NeedResetExportPicture | 导出时是否需要将单元格类型导出为图片。
Public 属性 | NeedResetExportValue | 导出时是否需要重置单元格类型的值。
页首
请参见

引用

ExportResultInfo 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportPicture 属性 (ExportResultInfo)
示例
GrapeCity.Forguncy.CellTypes 命名空间 > ExportResultInfo 类 : ExportPicture 属性
导出单元格类型的图片。
语法
  • C#
public ImageSource ExportPicture {get; set;}
示例
  • C#
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
            if (ImageInfo.BuiltIn)
            {
                folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
            }

            var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

            var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ExportResultInfo 类
ExportResultInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportStyleInfos 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > ExportResultInfo 类 : ExportStyleInfos 属性

导出单元格类型的样式。

例如，导出多行文本框时垂直方向应该向上对齐，水平方向向左对齐，并且允许换行。

语法
  • C#
public Dictionary<StylePropertyName,object> ExportStyleInfos {get;}
示例
  • C#
public class MultilineTextBox : CellType, IExportCellType
{
    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();

        result.ExportStyleInfos.Add(StylePropertyName.VerticalAlignment, ForguncyCellVerticalAlignment.Top);
        if (targetCell.HorizontalAlignment == ForguncyCellHorizontalAlignment.General)
        {
            result.ExportStyleInfos.Add(StylePropertyName.HorizontalAlignment, ForguncyCellHorizontalAlignment.Left);
        }
        result.ExportStyleInfos.Add(StylePropertyName.WordWrap, true);

        return result;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ExportResultInfo 类
ExportResultInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportValue 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > ExportResultInfo 类 : ExportValue 属性
导出单元格类型的值。
语法
  • C#
public object ExportValue {get; set;}
示例
  • C#
public class ComboBoxCellType : CellType, IExportCellType
{
    public List<ItemInfo> Items { get; set; }

    public bool ExportPicture
    {
        get
        {
            return false;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();
        if(this.Items != null)
        {
            foreach (var item in this.Items)
            {
                if(object.Equals(item.Value, targetCell.Value))
                {
                    result.ExportValue = item.Text;
                    break;
                }
            }
        }

        return result;
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public object Value { get; set; }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ExportResultInfo 类
ExportResultInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
NeedResetExportPicture 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ExportResultInfo 类 : NeedResetExportPicture 属性
导出时是否需要将单元格类型导出为图片。
语法
  • C#
public bool NeedResetExportPicture {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ExportResultInfo 类
ExportResultInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
NeedResetExportValue 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ExportResultInfo 类 : NeedResetExportValue 属性
导出时是否需要重置单元格类型的值。
语法
  • C#
public bool NeedResetExportValue {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ExportResultInfo 类
ExportResultInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
SupportLanguageScopeAttribute 类
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : SupportLanguageScopeAttribute 类
插件支持的语言版本，如果不指定默认所有语言都支持。
语法
  • C#
public class SupportLanguageScopeAttribute : System.Attribute
示例
  • C#
[SupportLanguageScope(LanguageScope.Chinese)]  /*只支持中文版。*/
public class BDMapCellType :
{
    ...
}
继承层次

System.Object
System.Attribute
GrapeCity.Forguncy.CellTypes.SupportLanguageScopeAttribute

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

SupportLanguageScopeAttribute 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
SupportLanguageScopeAttribute 类 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : SupportLanguageScopeAttribute 类

以下表中列出了SupportLanguageScopeAttribute的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | SupportLanguageScopeAttribute 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | LanguageScope | 支持的语言版本。
Public 属性 | TypeId | (从System.Attribute继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

SupportLanguageScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
SupportLanguageScopeAttribute 构造函数
GrapeCity.Forguncy.CellTypes 命名空间 > SupportLanguageScopeAttribute 类 : SupportLanguageScopeAttribute 构造函数
支持的语言版本。
构造函数。
语法
  • C#
public SupportLanguageScopeAttribute(
   LanguageScope scope
)

参数

scope
支持的语言版本。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

SupportLanguageScopeAttribute 类
SupportLanguageScopeAttribute 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
SupportLanguageScopeAttribute 类 属性

GrapeCity.Forguncy.CellTypes 命名空间 : SupportLanguageScopeAttribute 类

所有这类成员的列表, 请看 SupportLanguageScopeAttribute 成员.

公共 属性
 | 名称 | 说明
Public 属性 | LanguageScope | 支持的语言版本。
Public 属性 | TypeId | (从System.Attribute继承)
页首
请参见

引用

SupportLanguageScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
LanguageScope 属性
GrapeCity.Forguncy.CellTypes 命名空间 > SupportLanguageScopeAttribute 类 : LanguageScope 属性
支持的语言版本。
语法
  • C#
public LanguageScope LanguageScope {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

SupportLanguageScopeAttribute 类
SupportLanguageScopeAttribute 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
SupportUsingScopeAttribute 类
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : SupportUsingScopeAttribute 类
单元格类型的插件或其内部属性所支持的使用范围，如果不指定默认所有页面及表格都支持。
语法
  • C#
public class SupportUsingScopeAttribute : System.Attribute
示例
  • C#
[SupportUsingScope(PageScope.AllPage, ListViewScope.None)]  /*支持所有页面，不支持在表格中使用。*/
public class BDMapCellType :
{
    [SupportUsingScope(PageScope.AllPCPage, ListViewScope.None)]  /*只支持所有PC页面，不支持在手机页面或表格中使用。*/
    public bool Distance { get; set; }

    public bool ReadOnly { get; set; }  /*支持所有PC页面和手机页面，不支持在表格中使用。*/
}
继承层次

System.Object
System.Attribute
GrapeCity.Forguncy.CellTypes.SupportUsingScopeAttribute

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

SupportUsingScopeAttribute 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
SupportUsingScopeAttribute 类 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : SupportUsingScopeAttribute 类

以下表中列出了SupportUsingScopeAttribute的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | SupportUsingScopeAttribute 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | ListViewScope | 表格的使用范围。
Public 属性 | PageScope | 页面的使用范围。
Public 属性 | TypeId | (从System.Attribute继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
SupportUsingScopeAttribute 构造函数
GrapeCity.Forguncy.CellTypes 命名空间 > SupportUsingScopeAttribute 类 : SupportUsingScopeAttribute 构造函数
插件所支持的页面使用范围。
插件所支持的表格使用范围。
构造函数。
语法
  • C#
public SupportUsingScopeAttribute(
   PageScope pageScope,
   ListViewScope listviewScope
)

参数

pageScope
插件所支持的页面使用范围。
listviewScope
插件所支持的表格使用范围。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

SupportUsingScopeAttribute 类
SupportUsingScopeAttribute 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
SupportUsingScopeAttribute 类 属性

GrapeCity.Forguncy.CellTypes 命名空间 : SupportUsingScopeAttribute 类

所有这类成员的列表, 请看 SupportUsingScopeAttribute 成员.

公共 属性
 | 名称 | 说明
Public 属性 | ListViewScope | 表格的使用范围。
Public 属性 | PageScope | 页面的使用范围。
Public 属性 | TypeId | (从System.Attribute继承)
页首
请参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ListViewScope 属性
GrapeCity.Forguncy.CellTypes 命名空间 > SupportUsingScopeAttribute 类 : ListViewScope 属性
表格的使用范围。
语法
  • C#
public ListViewScope ListViewScope {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

SupportUsingScopeAttribute 类
SupportUsingScopeAttribute 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
PageScope 属性
GrapeCity.Forguncy.CellTypes 命名空间 > SupportUsingScopeAttribute 类 : PageScope 属性
页面的使用范围。
语法
  • C#
public PageScope PageScope {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

SupportUsingScopeAttribute 类
SupportUsingScopeAttribute 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
CommandExcuteKind 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : CommandExcuteKind 枚举
触发命令时机。
语法
  • C#
public enum CommandExcuteKind : System.Enum
成员
成员 | 说明
Click | 点击单元格时。
OnValueChanged | 单元格值发生变化时。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.CommandExcuteKind

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
CopyFontInfoToControlOption 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : CopyFontInfoToControlOption 枚举
主要用于单元格预览和导出单元格到Excel中的画法。
语法
  • C#
[Flags()]
public enum CopyFontInfoToControlOption : System.Enum
成员
成员 | 说明
All | 根据所有样式画WPF元素。
FontInfo | 根据字体样式画WPF元素。
HorizontalAlignment | 根据水平对齐方式画WPF元素。
Indent | 根据缩进方式画WPF元素。
Normal | 根据字体样式，下划线样式，垂直和水平对齐方式画WPF元素。
Text | 根据文本内容画WPF元素。
TextDecoration | 根据下划线样式画WPF元素。
VerticalAlignment | 根据垂直对齐方式画WPF元素。
Wrap | 根据换行方式画WPF元素。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.CopyFontInfoToControlOption

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
DisplayBehaviour 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : DisplayBehaviour 枚举
单元格的默认显示特性。
语法
  • C#
[Flags()]
public enum DisplayBehaviour : System.Enum
成员
成员 | 说明
KeepBorderWhenMerge | 单元格类型默认生成边框，并且合并单元格后，边框会相应的发生变化。
None | 默认无特性。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.DisplayBehaviour

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyAuthenticationMode 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ForguncyAuthenticationMode 枚举
页面认证模式。
语法
  • C#
public enum ForguncyAuthenticationMode : System.Enum
成员
成员 | 说明
Forms | 登录用户认证。
Windows | Windows域认证。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyAuthenticationMode

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyBorderLineStyle 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ForguncyBorderLineStyle 枚举
边框线型列表。
语法
  • C#
public enum ForguncyBorderLineStyle : System.Enum
成员
成员 | 说明
Dashed | 虚线（较细）。
Dotted | 斑点线。
Double | 双线型。
Medium | 单线型（中等粗细）。
MediumDashed | 虚线（中等粗细）。
None | 无。
Thick | 粗线型。
Thin | 单线型（较细）。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyBorderLineStyle

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyCellHorizontalAlignment 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ForguncyCellHorizontalAlignment 枚举
单元格水平对齐方式列表。
语法
  • C#
public enum ForguncyCellHorizontalAlignment : System.Enum
成员
成员 | 说明
Center | 水平方向居中对齐。
General | 水平方向常规对齐。
Left | 水平方向靠左对齐。
Right | 水平方向靠右对齐。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyCellHorizontalAlignment

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyCellVerticalAlignment 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ForguncyCellVerticalAlignment 枚举
单元格垂直对齐方式列表。
语法
  • C#
public enum ForguncyCellVerticalAlignment : System.Enum
成员
成员 | 说明
Bottom | 垂直方向靠下对齐。
Center | 垂直居中对齐。
Top | 垂直方向靠上对齐。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyCellVerticalAlignment

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyDisabledSettings 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ForguncyDisabledSettings 枚举
开始菜单中的不可用属性列表。
语法
  • C#
[Flags()]
public enum ForguncyDisabledSettings : System.Enum
成员
成员 | 说明
Bold | 字体加粗。
BottomAlignment | 垂直向下对齐。
CenterAlignment | 水平居中对齐。
Italic | 斜体。
LeftAlignment | 水平向左对齐。
MiddleAlignment | 垂直居中对齐。
RightAlignment | 水平向右对齐。
TopAlignment | 垂直向上对齐。
Underline | 下划线。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyDisabledSettings

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyPageKind 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ForguncyPageKind 枚举
页面类型列表。
语法
  • C#
public enum ForguncyPageKind : System.Enum
成员
成员 | 说明
MasterMobilePage | 手机母版页。
MasterPCPage | PC母版页。
NormalMobilePage | 普通手机页面。
NormalPCPage | 普通PC页面。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ForguncyPageKind

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ImeMode 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ImeMode 枚举
Ime输入模式。
语法
  • C#
public enum ImeMode : System.Enum
成员
成员 | 说明
Active | 激活状态。
Auto | 自动。
Disabled | 禁用状态。
Inactive | 非激活状态。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ImeMode

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
LanguageScope 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : LanguageScope 枚举
插件支持的语言版本。
语法
  • C#
[Flags()]
public enum LanguageScope : System.Enum
成员
成员 | 说明
All | 同时支持中文版和日文版。
Chinese | 只支持中文版。
Japanese | 只支持日文版。
None | 所有语言都不支持。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.LanguageScope

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ListViewScope 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : ListViewScope 枚举
单元格类型插件或其内部属性所支持的表格使用范围。
语法
  • C#
[Flags()]
public enum ListViewScope : System.Enum
成员
成员 | 说明
AllListView | 支持在PC页面和手机页面的表格中使用。
ListViewInMobilePage | 只支持在手机页面的表格中使用。
ListViewInPCPage | 只支持在PC页面的表格中使用。
None | 不支持在表格中使用。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.ListViewScope

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
PageScope 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : PageScope 枚举
单元格类型插件或其内部属性所支持的页面使用范围。
语法
  • C#
[Flags()]
public enum PageScope : System.Enum
成员
成员 | 说明
AllMasterPage | 支持PC母版页和手机母版页在内的所有母版页。
AllMobilePage | 支持普通手机页面和手机母版页在内的所有手机页面。
AllNormalPage | 支持普通PC页面和普通手机页面在内的所有普通页面。
AllPage | 支持所有类型页面。
AllPCPage | 支持普通PC页面和PC母版页在内的所有PC页面。
MasterMobilePage | 只支持手机母版页。
MasterPCPage | 只支持PC母版页。
None | 所有页面都不支持。
NormalMobilePage | 只支持普通手机页面。
NormalPCPage | 只支持普通PC页面。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.PageScope

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
StylePropertyName 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : StylePropertyName 枚举
样式列表。
语法
  • C#
public enum StylePropertyName : System.Enum
成员
成员 | 说明
Background | 背景色。
BorderBottom | 下边框。
BorderLeft | 左边框。
BorderRight | 右边框。
BorderTop | 上边框。
FontFamily | 字体。
FontSize | 字号。
FontStyle | 字体样式。
FontWeight | 字体加粗。
Foreground | 字体颜色。
Formatter | 格式。
HorizontalAlignment | 水平对齐方式。
Strikethrough | 是否有删除线效果。
TextIndent | 缩进大小。
Underline | 是否有下划线。
VerticalAlignment | 垂直对齐方式。
WordWrap | 是否换行。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.StylePropertyName

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
SupportFeatures 枚举
GrapeCity.Forguncy.CellTypes 命名空间 : SupportFeatures 枚举
单元格类型的插件支持的特性。
语法
  • C#
[Flags()]
public enum SupportFeatures : System.Enum
成员
成员 | 说明
All | 支持Tab键设置及所有单元格上设置格式。
AllowSetFormat | 支持在所有单元格上设置格式。
AllowSetFormatInListview | 只支持在表格单元格上设置格式。
AllowSetFormatInNormalCell | 只支持在普通单元格上设置格式。
AllowSetTabOrder | 支持Tab键设置。
None | 没有特性。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.CellTypes.SupportFeatures

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IAttachedInfo 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IAttachedInfo 接口
单元格的附加信息。
对象模型
IAttachedInfo 接口IBindingInfo 接口
语法
  • C#
public interface IAttachedInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IAttachedInfo 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IAttachedInfo 接口 成员
属性

GrapeCity.Forguncy.CellTypes 命名空间 : IAttachedInfo 接口

以下表中列出了IAttachedInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | BindingInfo | 数据绑定信息。
页首
请参见

引用

IAttachedInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IAttachedInfo 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IAttachedInfo 接口

所有这类成员的列表, 请看 IAttachedInfo 成员.

公共 属性
 | 名称 | 说明
属性 | BindingInfo | 数据绑定信息。
页首
请参见

引用

IAttachedInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BindingInfo 属性 (IAttachedInfo)
GrapeCity.Forguncy.CellTypes 命名空间 > IAttachedInfo 接口 : BindingInfo 属性
数据绑定信息。
语法
  • C#
IBindingInfo BindingInfo {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IAttachedInfo 接口
IAttachedInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IBindingInfo 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IBindingInfo 接口
单元格的数据绑定信息，即一旦单元格绑定到A表的B字段,如果页面中存在A表，那么该单元格就会显示当前行的B字段的值。
语法
  • C#
public interface IBindingInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBindingInfo 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IBindingInfo 接口 成员
属性

GrapeCity.Forguncy.CellTypes 命名空间 : IBindingInfo 接口

以下表中列出了IBindingInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | ColumnName | 绑定的数据列名。
属性 | IsByteArray | 内部使用。是否是比特数组。
属性 | TableName | 绑定的数据表名。
页首
请参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IBindingInfo 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IBindingInfo 接口

所有这类成员的列表, 请看 IBindingInfo 成员.

公共 属性
 | 名称 | 说明
属性 | ColumnName | 绑定的数据列名。
属性 | IsByteArray | 内部使用。是否是比特数组。
属性 | TableName | 绑定的数据表名。
页首
请参见

引用

IBindingInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ColumnName 属性 (IBindingInfo)
GrapeCity.Forguncy.CellTypes 命名空间 > IBindingInfo 接口 : ColumnName 属性
绑定的数据列名。
语法
  • C#
string ColumnName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBindingInfo 接口
IBindingInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
IsByteArray 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IBindingInfo 接口 : IsByteArray 属性
内部使用。是否是比特数组。
语法
  • C#
bool IsByteArray {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBindingInfo 接口
IBindingInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
TableName 属性 (IBindingInfo)
GrapeCity.Forguncy.CellTypes 命名空间 > IBindingInfo 接口 : TableName 属性
绑定的数据表名。
语法
  • C#
string TableName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBindingInfo 接口
IBindingInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IBorderLine 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IBorderLine 接口
设置边框。
语法
  • C#
public interface IBorderLine
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBorderLine 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IBorderLine 接口 成员
属性

GrapeCity.Forguncy.CellTypes 命名空间 : IBorderLine 接口

以下表中列出了IBorderLine的公开成员.

公共 属性
 | 名称 | 说明
属性 | Color | 边框颜色。
属性 | Style | 边框线型。
页首
请参见

引用

IBorderLine 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IBorderLine 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IBorderLine 接口

所有这类成员的列表, 请看 IBorderLine 成员.

公共 属性
 | 名称 | 说明
属性 | Color | 边框颜色。
属性 | Style | 边框线型。
页首
请参见

引用

IBorderLine 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Color 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IBorderLine 接口 : Color 属性
边框颜色。
语法
  • C#
Color Color {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBorderLine 接口
IBorderLine 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Style 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IBorderLine 接口 : Style 属性
边框线型。
语法
  • C#
ForguncyBorderLineStyle Style {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBorderLine 接口
IBorderLine 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IBuilderContext 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IBuilderContext 接口
插件所需的上下文信息。
对象模型
IBuilderContext 接口ICellInfo 接口IUserServiceInfo 接口
语法
  • C#
public interface IBuilderContext : GrapeCity.Forguncy.Plugin.IBuilderContextBase
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IBuilderContext 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IBuilderContext 接口

以下表中列出了IBuilderContext的公开成员.

公共 属性
 | 名称 | 说明
属性 | Cell | 单元格类型所在的单元格信息。
属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
属性 | PageName | 获取当前所在页面名称。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
属性 | PageType | 页面类型。
属性 | UserServiceInfo | 获取用户管理网站的信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
页首
公共 方法
 | 名称 | 说明
方法 | EnumAllAttachedInfos | 获取某个页面所有的单元格附加信息。
方法 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllPageInfos | 获取所有的页面信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllTableInfos | 获取所有的数据表信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
方法 | EnumDependenceCellsFromFormula | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
方法 | GetCommandWindow | 根据使用范围获取活字格内部编辑命令的对话窗口。
方法 | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
方法 | GetSelectImageWindow | 获取活字格内部选择图片的对话窗口。
方法 | GetSortConditionWindow | 获取活字格内部排序的对话窗口。
方法 | HideParentDialog | 如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
方法 | ShowParentDialog | 重新显示被隐藏的父窗口，配合HideParentDialog使用。
页首
请参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IBuilderContext 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IBuilderContext 接口

所有这类成员的列表, 请看 IBuilderContext 成员.

公共 方法
 | 名称 | 说明
方法 | EnumAllAttachedInfos | 获取某个页面所有的单元格附加信息。
方法 | EnumAllListViewInfos | 获取某个页面所有的表格信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllPageInfos | 获取所有的页面信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumAllTableInfos | 获取所有的数据表信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
方法 | EnumDependenceCells | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
方法 | EnumDependenceCellsFromFormula | 依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
方法 | GetCommandWindow | 根据使用范围获取活字格内部编辑命令的对话窗口。
方法 | GetQueryConditionWindow | 获取活字格内部查询条件的对话窗口。
方法 | GetSelectImageWindow | 获取活字格内部选择图片的对话窗口。
方法 | GetSortConditionWindow | 获取活字格内部排序的对话窗口。
方法 | HideParentDialog | 如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
方法 | ShowParentDialog | 重新显示被隐藏的父窗口，配合HideParentDialog使用。
页首
请参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
EnumAllAttachedInfos 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : EnumAllAttachedInfos 方法
页面名称。
获取某个页面所有的单元格附加信息。
语法
  • C#
IEnumerable<IAttachedInfo> EnumAllAttachedInfos(
   string pageName
)

参数

pageName
页面名称。

返回值

返回页面所有单元格的附加信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
EnumDependenceCells 方法 (IBuilderContext)
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : EnumDependenceCells 方法
查询条件
依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
语法
  • C#
IEnumerable<object> EnumDependenceCells(
   object queryCondition
)

参数

queryCondition
查询条件

返回值

插件中所有引用的单元格列表。
示例
代码参照IQueryConditionWindow
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
EnumDependenceCellsFromFormula 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : EnumDependenceCellsFromFormula 方法
公式
依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知引用了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
语法
  • C#
IEnumerable<object> EnumDependenceCellsFromFormula(
   object formula
)

参数

formula
公式

返回值

插件中所有引用的单元格列表。
示例
代码参照IDependenceCells
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetCommandWindow 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : GetCommandWindow 方法
指定命令使用范围。
根据使用范围获取活字格内部编辑命令的对话窗口。
语法
  • C#
ICommandWindow GetCommandWindow(
   CommandScope commandScope
)

参数

commandScope
指定命令使用范围。

返回值

返回活字格内部编辑命令的对话窗口。
示例
代码参照ICommandWindow。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetQueryConditionWindow 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : GetQueryConditionWindow 方法
初始化内置查询条件对话窗口的对象。
数据表名。
获取活字格内部查询条件的对话窗口。
语法
  • C#
IQueryConditionWindow GetQueryConditionWindow(
   object queryCondition,
   string tableName
)

参数

queryCondition
初始化内置查询条件对话窗口的对象。
tableName
数据表名。

返回值

返回活字格内部查询条件的对话窗口。
示例
代码参照IQueryConditionWindow。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetSelectImageWindow 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : GetSelectImageWindow 方法
初始化选择图片对话窗口的图片名。
初始化选择图片对话窗口的图片是否是内置图片。
获取活字格内部选择图片的对话窗口。
语法
  • C#
ISelectImageWindow GetSelectImageWindow(
   string imagePath,
   bool builtIn
)

参数

imagePath
初始化选择图片对话窗口的图片名。
builtIn
初始化选择图片对话窗口的图片是否是内置图片。

返回值

返回活字格内部选择图片的对话窗口。
示例
代码参照ISelectImageWindow。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetSortConditionWindow 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : GetSortConditionWindow 方法
初始化内置排序对话窗口的对象。
数据表名
获取活字格内部排序的对话窗口。
语法
  • C#
ISortConditionWindow GetSortConditionWindow(
   object sortCondition,
   string tableName
)

参数

sortCondition
初始化内置排序对话窗口的对象。
tableName
数据表名

返回值

返回活字格内部排序的对话窗口。
示例
代码参照ISortConditionWindow。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
HideParentDialog 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : HideParentDialog 方法
父窗口。
如果弹出子窗口希望隐藏父窗口，可以调用该函数，配合ShowParentDialog使用； 一般情况下，如果子窗口中有公式选择框，那么都需要使用该函数。
语法
  • C#
void HideParentDialog(
   UserControl userControl
)

参数

userControl
父窗口。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ShowParentDialog 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : ShowParentDialog 方法
父窗口。
重新显示被隐藏的父窗口，配合HideParentDialog使用。
语法
  • C#
void ShowParentDialog(
   UserControl userControl
)

参数

userControl
父窗口。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IBuilderContext 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IBuilderContext 接口

所有这类成员的列表, 请看 IBuilderContext 成员.

公共 属性
 | 名称 | 说明
属性 | Cell | 单元格类型所在的单元格信息。
属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录。
属性 | PageName | 获取当前所在页面名称。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
属性 | PageType | 页面类型。
属性 | UserServiceInfo | 获取用户管理网站的信息。 (从GrapeCity.Forguncy.Plugin.IBuilderContextBase继承)
页首
请参见

引用

IBuilderContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Cell 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : Cell 属性
单元格类型所在的单元格信息。
语法
  • C#
ICellInfo Cell {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyUploadFilesFolderPath 属性 (IBuilderContext)
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : ForguncyUploadFilesFolderPath 属性
用户在设计器中上传的文件或图片所在的文件目录。
语法
  • C#
string ForguncyUploadFilesFolderPath {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
PageType 属性 (IBuilderContext)
GrapeCity.Forguncy.CellTypes 命名空间 > IBuilderContext 接口 : PageType 属性
页面类型。
语法
  • C#
ForguncyPageKind PageType {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContext 接口
IBuilderContext 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ICanOverflow 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : ICanOverflow 接口

单元格类型是否支持溢出。

例如，如果超链接单元格类型所在的单元格大小不够显示完全字，并且本身和后续单元格均没有合并的情况下，超链接的字会溢出到后续单元格中。

语法
  • C#
public interface ICanOverflow
示例
  • C#
public class HyperlinkCellType : CellType, ICanOverflow
{
    ...
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICanOverflow 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ICanOverflow 接口 成员

GrapeCity.Forguncy.CellTypes 命名空间 : ICanOverflow 接口

以下表中列出了ICanOverflow的公开成员.

请参见

引用

ICanOverflow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ICellInfo 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : ICellInfo 接口
单元格的信息。
对象模型
ICellInfo 接口IBindingInfo 接口IBorderLine 接口IBorderLine 接口IBorderLine 接口IBorderLine 接口IForguncyFormatter 接口IListViewInfo 接口
语法
  • C#
public interface ICellInfo : IStyleInfo, GrapeCity.Forguncy.Plugin.ICellInfoBase
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ICellInfo 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ICellInfo 接口

以下表中列出了ICellInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | Background | 背景色。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BindingInfo | 单元格的数据绑定信息。
属性 | BorderBottom | 下边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BorderLeft | 左边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BorderRight | 右边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BorderTop | 上边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontFamily | 字体。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontSize | 字号。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontStyle | 字体倾斜。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontWeight | 字体加粗。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Foreground | 字体颜色。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Formatter | 格式设置。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Formula | 公式。
属性 | HorizontalAlignment | 水平对齐方式。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | ListViewInfo | 单元格所在表格的信息。 (从GrapeCity.Forguncy.Plugin.ICellInfoBase继承)
属性 | PageType | 单元格所在页面的类型。
属性 | Strikethrough | 是否有删除线。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Text | 单元格的文本。
属性 | TextIndent | 缩进。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Underline | 是否有下划线。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Value | 单元格的值。
属性 | VerticalAlignment | 垂直对齐方式。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | WordWrap | 是否可换行。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
页首
公共 方法
 | 名称 | 说明
方法 | InMasterPage | 单元格是否在母版页。
方法 | InMobilePage | 单元格是否在手机页面。
方法 | InPCPage | 单元格是否在PC页面。
页首
请参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
ICellInfo 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ICellInfo 接口

所有这类成员的列表, 请看 ICellInfo 成员.

公共 方法
 | 名称 | 说明
方法 | InMasterPage | 单元格是否在母版页。
方法 | InMobilePage | 单元格是否在手机页面。
方法 | InPCPage | 单元格是否在PC页面。
页首
请参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
InMasterPage 方法
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : InMasterPage 方法
单元格是否在母版页。
语法
  • C#
bool InMasterPage()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
InMobilePage 方法
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : InMobilePage 方法
单元格是否在手机页面。
语法
  • C#
bool InMobilePage()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
InPCPage 方法
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : InPCPage 方法
单元格是否在PC页面。
语法
  • C#
bool InPCPage()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
ICellInfo 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : ICellInfo 接口

所有这类成员的列表, 请看 ICellInfo 成员.

公共 属性
 | 名称 | 说明
属性 | Background | 背景色。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BindingInfo | 单元格的数据绑定信息。
属性 | BorderBottom | 下边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BorderLeft | 左边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BorderRight | 右边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | BorderTop | 上边框。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontFamily | 字体。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontSize | 字号。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontStyle | 字体倾斜。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | FontWeight | 字体加粗。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Foreground | 字体颜色。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Formatter | 格式设置。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Formula | 公式。
属性 | HorizontalAlignment | 水平对齐方式。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | ListViewInfo | 单元格所在表格的信息。 (从GrapeCity.Forguncy.Plugin.ICellInfoBase继承)
属性 | PageType | 单元格所在页面的类型。
属性 | Strikethrough | 是否有删除线。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Text | 单元格的文本。
属性 | TextIndent | 缩进。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Underline | 是否有下划线。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | Value | 单元格的值。
属性 | VerticalAlignment | 垂直对齐方式。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
属性 | WordWrap | 是否可换行。 (从GrapeCity.Forguncy.CellTypes.IStyleInfo继承)
页首
请参见

引用

ICellInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BindingInfo 属性 (ICellInfo)
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : BindingInfo 属性
单元格的数据绑定信息。
语法
  • C#
IBindingInfo BindingInfo {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Formula 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : Formula 属性
公式。
语法
  • C#
string Formula {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
PageType 属性 (ICellInfo)
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : PageType 属性
单元格所在页面的类型。
语法
  • C#
ForguncyPageKind PageType {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Text 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : Text 属性
单元格的文本。
语法
  • C#
string Text {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Value 属性 (ICellInfo)
GrapeCity.Forguncy.CellTypes 命名空间 > ICellInfo 接口 : Value 属性
单元格的值。
语法
  • C#
object Value {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfo 接口
ICellInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ICellTypeChecker 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : ICellTypeChecker 接口
如果单元格类型需要满足一些必要条件，实现该接口可以在运行页面时给出错误列表。
语法
  • C#
public interface ICellTypeChecker
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellTypeChecker 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ICellTypeChecker 接口 成员
方法

GrapeCity.Forguncy.CellTypes 命名空间 : ICellTypeChecker 接口

以下表中列出了ICellTypeChecker的公开成员.

公共 方法
 | 名称 | 说明
方法 | CheckCellTypeErrors | 运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
页首
请参见

引用

ICellTypeChecker 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
ICellTypeChecker 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ICellTypeChecker 接口

所有这类成员的列表, 请看 ICellTypeChecker 成员.

公共 方法
 | 名称 | 说明
方法 | CheckCellTypeErrors | 运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
页首
请参见

引用

ICellTypeChecker 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
CheckCellTypeErrors 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > ICellTypeChecker 接口 : CheckCellTypeErrors 方法
与单元格类型相关的上下文信息
运行页面时检查与单元格类型相关的所有错误和提醒列表并返回给用户。
语法
  • C#
IEnumerable<ForguncyErrorInfo> CheckCellTypeErrors(
   IBuilderContext context
)

参数

context
与单元格类型相关的上下文信息

返回值

返回与单元格类型相关的所有错误和提醒列表。
示例
  • C#
public class PageNavigateCellType : CellType, ICellTypeChecker
{
    public string PagingListviewName { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCellTypeErrors(IBuilderContext context)
    {
        List<ForguncyErrorInfo> result = new List<ForguncyErrorInfo>();
        if(string.IsNullOrEmpty(PagingListviewName))
        {
            result.Add(new ForguncyErrorInfo()
            {
                ErrorType = ForguncyErrorType.Error,
                Message = "The paging listview name cannot be null."
            });
        }

        return result;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellTypeChecker 接口
ICellTypeChecker 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ICommandCellType 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : ICommandCellType 接口
如果单元格类型本身允许执行命令，需实现该接口。
语法
  • C#
public interface ICommandCellType
示例
  • C#
public class ButtonCellType : CellType, ICommandCellType
{
    public List<Command> CommandList { get; set; }

    public CommandExcuteKind CommandExcuteKind
    {
        get
        {
            return CommandExcuteKind.Click;
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandCellType 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ICommandCellType 接口 成员
属性

GrapeCity.Forguncy.CellTypes 命名空间 : ICommandCellType 接口

以下表中列出了ICommandCellType的公开成员.

公共 属性
 | 名称 | 说明
属性 | CommandExcuteKind | 触发命令的时机。
属性 | CommandList | 命令列表。
页首
请参见

引用

ICommandCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
ICommandCellType 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : ICommandCellType 接口

所有这类成员的列表, 请看 ICommandCellType 成员.

公共 属性
 | 名称 | 说明
属性 | CommandExcuteKind | 触发命令的时机。
属性 | CommandList | 命令列表。
页首
请参见

引用

ICommandCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
CommandExcuteKind 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ICommandCellType 接口 : CommandExcuteKind 属性
触发命令的时机。
语法
  • C#
CommandExcuteKind CommandExcuteKind {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandCellType 接口
ICommandCellType 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
CommandList 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ICommandCellType 接口 : CommandList 属性
命令列表。
语法
  • C#
List<Command> CommandList {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandCellType 接口
ICommandCellType 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ICommandWindow 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : ICommandWindow 接口
活字格内部编辑命令的对话窗口。
语法
  • C#
public interface ICommandWindow : IWindow
示例
  • C#
public partial class MenuItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public MenuItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();

        _builderContext = builderContext;
    }

    private void SetCommandListHyperlink_Click(object sender, RoutedEventArgs e)
    {
        var window = _builderContext.GetCommandWindow(CommandScope.Cell);
        window.InitCommandEvent += () =>
        {
            return ViewModel.CommandList;  //基于数据层的命令列表初始化命令对话窗口。
        }
        window.UpdateCommandEvent += (sender2, commandList) =>
        {
            ViewModel.CommandList = commandList;  //提交命令设置到数据层。
        }
        window.Closed += (sender2, e2) =>
        {
            _builderContext.ShowParentDialog(this);  //关闭窗口之后打开父窗口；
        }
        //由于命令设置过程中可能会引用单元格，所以这里暂时先隐藏父窗口；
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandWindow 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ICommandWindow 接口 成员
属性 方法 事件

GrapeCity.Forguncy.CellTypes 命名空间 : ICommandWindow 接口

以下表中列出了ICommandWindow的公开成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
公共 事件
 | 名称 | 说明
事件 | InitCommandEvent | 初始化对话框中的命令列表。
事件 | UpdateCommandEvent | 更新命令数据，即将对话框中的命令列表更新会数据层。
页首
请参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.CellTypes
ICommandWindow 接口 事件

GrapeCity.Forguncy.CellTypes 命名空间 : ICommandWindow 接口

所有这类成员的列表, 请看 ICommandWindow 成员.

公共 事件
 | 名称 | 说明
事件 | InitCommandEvent | 初始化对话框中的命令列表。
事件 | UpdateCommandEvent | 更新命令数据，即将对话框中的命令列表更新会数据层。
页首
请参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
InitCommandEvent 事件
GrapeCity.Forguncy.CellTypes 命名空间 > ICommandWindow 接口 : InitCommandEvent 事件
初始化对话框中的命令列表。
语法
  • C#
event Func<List<Command>> InitCommandEvent
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandWindow 接口
ICommandWindow 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
UpdateCommandEvent 事件
GrapeCity.Forguncy.CellTypes 命名空间 > ICommandWindow 接口 : UpdateCommandEvent 事件
更新命令数据，即将对话框中的命令列表更新会数据层。
语法
  • C#
event EventHandler<List<Command>> UpdateCommandEvent
事件数据

The event handler receives an argument of type List<T> containing data related to this event. The following List<T> properties provide information specific to this event.

属性 | 说明
Capacity |
Count |
Item |
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICommandWindow 接口
ICommandWindow 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IDependenceCells 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : IDependenceCells 接口
依赖单元格接口，主要用于公式重新计算和刷新逻辑。 例如，查询条件中引用了页面单元格的值，一旦单元格值发生变化，需要重新查询刷新一些数据或UI； 或者，菜单项中的通知依赖了单元格的值，一旦单元格发生变化，需要重新计算菜单项的通知项。
语法
  • C#
public interface IDependenceCells
示例
  • C#
public class ForguncyMenuCellType : CellType, IDependenceCells
{
    public List<ItemInfo> Items { get; set; }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return this.EnumDependenceCells(this.Items, context);
    }

    private IEnumerable<object> EnumDependenceCells(List<ItemInfo> items, IBuilderContext context)
    {
        foreach (var item in items)
        {
            if(item.Notification != null)
            {
                var cells = context.EnumDependenceCellsFromFormula(item.Notification);
                foreach(var cell in cells)
                {
                    yield return cell;
                }
            }
            if(item.SubItems != null)
            {
                foreach(var cell in EnumDependenceCells(item.SubItems, context))
                {
                    yield return cell;
                }
            }
        }
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public object Notification { get; set; }

    public List<ItemInfo> SubItems { get; set; }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDependenceCells 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IDependenceCells 接口 成员
方法

GrapeCity.Forguncy.CellTypes 命名空间 : IDependenceCells 接口

以下表中列出了IDependenceCells的公开成员.

公共 方法
 | 名称 | 说明
方法 | EnumDependenceCells | 返回插件中所引用的单元格列表。
页首
请参见

引用

IDependenceCells 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IDependenceCells 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IDependenceCells 接口

所有这类成员的列表, 请看 IDependenceCells 成员.

公共 方法
 | 名称 | 说明
方法 | EnumDependenceCells | 返回插件中所引用的单元格列表。
页首
请参见

引用

IDependenceCells 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
EnumDependenceCells 方法 (IDependenceCells)
GrapeCity.Forguncy.CellTypes 命名空间 > IDependenceCells 接口 : EnumDependenceCells 方法
上下文信息。
返回插件中所引用的单元格列表。
语法
  • C#
IEnumerable<object> EnumDependenceCells(
   IBuilderContext context
)

参数

context
上下文信息。

返回值

返回插件中引用的单元格列表。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDependenceCells 接口
IDependenceCells 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IDisablePropertySettings 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IDisablePropertySettings 接口
获取单元格类型中不可用的样式属性，如对齐方式等。
语法
  • C#
public interface IDisablePropertySettings
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDisablePropertySettings 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IDisablePropertySettings 接口 成员
方法

GrapeCity.Forguncy.CellTypes 命名空间 : IDisablePropertySettings 接口

以下表中列出了IDisablePropertySettings的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetDisabledPropertySettings | 根据页面类型获取单元格类型不可用的样式属性。
页首
请参见

引用

IDisablePropertySettings 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IDisablePropertySettings 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IDisablePropertySettings 接口

所有这类成员的列表, 请看 IDisablePropertySettings 成员.

公共 方法
 | 名称 | 说明
方法 | GetDisabledPropertySettings | 根据页面类型获取单元格类型不可用的样式属性。
页首
请参见

引用

IDisablePropertySettings 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetDisabledPropertySettings 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IDisablePropertySettings 接口 : GetDisabledPropertySettings 方法
页面类型。
根据页面类型获取单元格类型不可用的样式属性。
语法
  • C#
ForguncyDisabledSettings GetDisabledPropertySettings(
   ForguncyPageKind pageType
)

参数

pageType
页面类型。

返回值

返回不可用的样式属性。
示例
  • C#
public class DateCellType : CellType, IDisablePropertySettings
{
    public ForguncyDisabledSettings GetDisabledPropertySettings(ForguncyPageKind pageType)
    {
        return ForguncyDisabledSettings.TopAlignment | ForguncyDisabledSettings.MiddleAlignment | ForguncyDisabledSettings.BottomAlignment;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDisablePropertySettings 接口
IDisablePropertySettings 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IDrawingHelper 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IDrawingHelper 接口
主要用于单元格预览和导出单元格到Excel中的画法。
语法
  • C#
public interface IDrawingHelper
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IDrawingHelper 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IDrawingHelper 接口

以下表中列出了IDrawingHelper的公开成员.

公共 属性
 | 名称 | 说明
属性 | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
属性 | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
页首
公共 方法
 | 名称 | 说明
方法 | GetHelpTextForPage | 获取单元格的显示文本，如绑定信息，公式或值等。
方法 | GetImageCellSize | 如果生成图片的话可获取单元格所占区域的大小。
方法 | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
方法 | GetTableDataForPreview | 重载. 如果预览单元格想要从数据表中获取数据，可调用该函数。
方法 | SetFontInfoToControl | 设置基本的字体颜色，背景色，字体，字号等。
方法 | SetFontInfoToFrameworkElement | 设置基本的字体颜色，背景色，字体，字号等。
方法 | SetIndentToControl | 设置缩进。
页首
请参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IDrawingHelper 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IDrawingHelper 接口

所有这类成员的列表, 请看 IDrawingHelper 成员.

公共 方法
 | 名称 | 说明
方法 | GetHelpTextForPage | 获取单元格的显示文本，如绑定信息，公式或值等。
方法 | GetImageCellSize | 如果生成图片的话可获取单元格所占区域的大小。
方法 | GetRealHorizontalAlignment | 获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
方法 | GetTableDataForPreview | 重载. 如果预览单元格想要从数据表中获取数据，可调用该函数。
方法 | SetFontInfoToControl | 设置基本的字体颜色，背景色，字体，字号等。
方法 | SetFontInfoToFrameworkElement | 设置基本的字体颜色，背景色，字体，字号等。
方法 | SetIndentToControl | 设置缩进。
页首
请参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetHelpTextForPage 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : GetHelpTextForPage 方法
获取单元格的显示文本，如绑定信息，公式或值等。
语法
  • C#
string GetHelpTextForPage()

返回值

返回单元格的显示文本。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetImageCellSize 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : GetImageCellSize 方法
如果生成图片的话可获取单元格所占区域的大小。
语法
  • C#
Size GetImageCellSize()

返回值

返回图片所占的单元格区域的大小。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetRealHorizontalAlignment 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : GetRealHorizontalAlignment 方法
单元格的信息。
单元格类型的信息。
获取真正的水平对齐方式，如果设置的通用水平对齐方式，那么会根据单元格的值类型设置相应的水平对齐方式。
语法
  • C#
ForguncyCellHorizontalAlignment GetRealHorizontalAlignment(
   ICellInfo cellInfo,
   object cellType
)

参数

cellInfo
单元格的信息。
cellType
单元格类型的信息。

返回值

返回水平对齐方式。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetTableDataForPreview 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : GetTableDataForPreview 方法
如果预览单元格想要从数据表中获取数据，可调用该函数。
重载列表
重载 | 说明
GetTableDataForPreview(String,List<String>,Dictionary<String,Object>,Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
GetTableDataForPreview(String,List<String>,Object,Boolean) | 如果预览单元格想要从数据表中获取数据，可调用该函数。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetTableDataForPreview(String,List<String>,Dictionary<String,Object>,Boolean) 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 > GetTableDataForPreview 方法 : GetTableDataForPreview(String,List<String>,Dictionary<String,Object>,Boolean) 方法
数据表名。
获取的字段列表。
当前表的查询条件，多用于主键键值对。
去重。
如果预览单元格想要从数据表中获取数据，可调用该函数。
语法
  • C#
List<Dictionary<string,object>> GetTableDataForPreview(
   string tableName,
   List<string> columns,
   Dictionary<string,object> queryInfo,
   bool distinct
)

参数

tableName
数据表名。
columns
获取的字段列表。
queryInfo
当前表的查询条件，多用于主键键值对。
distinct
去重。

返回值

返回查询后的数据表的数据。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员
重载列表


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetTableDataForPreview(String,List<String>,Object,Boolean) 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 > GetTableDataForPreview 方法 : GetTableDataForPreview(String,List<String>,Object,Boolean) 方法
数据表名。
获取的字段列表。
查询条件，由内置查询条件对话框生成的对象。
去重。
如果预览单元格想要从数据表中获取数据，可调用该函数。
语法
  • C#
List<Dictionary<string,object>> GetTableDataForPreview(
   string tableName,
   List<string> columns,
   object queryCondition,
   bool distinct
)

参数

tableName
数据表名。
columns
获取的字段列表。
queryCondition
查询条件，由内置查询条件对话框生成的对象。
distinct
去重。

返回值

返回查询后的数据表的数据。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员
重载列表


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
SetFontInfoToControl 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : SetFontInfoToControl 方法
要设置样式的文本元素。
要设置的样式选项。
设置基本的字体颜色，背景色，字体，字号等。
语法
  • C#
void SetFontInfoToControl(
   TextBlock textBlock,
   CopyFontInfoToControlOption copyFontInfoToControlOption
)

参数

textBlock
要设置样式的文本元素。
copyFontInfoToControlOption
要设置的样式选项。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
SetFontInfoToFrameworkElement 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : SetFontInfoToFrameworkElement 方法
要设置样式的WPF元素。
设置基本的字体颜色，背景色，字体，字号等。
语法
  • C#
void SetFontInfoToFrameworkElement(
   FrameworkElement control
)

参数

control
要设置样式的WPF元素。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
SetIndentToControl 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : SetIndentToControl 方法
要设置缩进的WPF元素。
设置缩进。
语法
  • C#
void SetIndentToControl(
   FrameworkElement control
)

参数

control
要设置缩进的WPF元素。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IDrawingHelper 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IDrawingHelper 接口

所有这类成员的列表, 请看 IDrawingHelper 成员.

公共 属性
 | 名称 | 说明
属性 | ForguncyBuiltInImagesFolderPath | 内建图片所在的文件目录。
属性 | ForguncyImageEditorFolderPath | 图片选择对话框中上传的图片所在文件目录。
属性 | ForguncyUploadFilesFolderPath | 用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
页首
请参见

引用

IDrawingHelper 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyBuiltInImagesFolderPath 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : ForguncyBuiltInImagesFolderPath 属性
内建图片所在的文件目录。
语法
  • C#
string ForguncyBuiltInImagesFolderPath {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyImageEditorFolderPath 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : ForguncyImageEditorFolderPath 属性
图片选择对话框中上传的图片所在文件目录。
语法
  • C#
string ForguncyImageEditorFolderPath {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ForguncyUploadFilesFolderPath 属性 (IDrawingHelper)
GrapeCity.Forguncy.CellTypes 命名空间 > IDrawingHelper 接口 : ForguncyUploadFilesFolderPath 属性
用户在设计器中上传的文件或图片所在的文件目录，如轮转图插件中的图片所在文件目录。
语法
  • C#
string ForguncyUploadFilesFolderPath {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IDrawingHelper 接口
IDrawingHelper 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IExportCellType 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : IExportCellType 接口
导出单元格类型有特殊处理时需实现该接口，比如生成图片等。
语法
  • C#
public interface IExportCellType
示例
  • C#
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
            if (ImageInfo.BuiltIn)
            {
                folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
            }

            var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

            var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportCellType 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IExportCellType 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportCellType 接口

以下表中列出了IExportCellType的公开成员.

公共 属性
 | 名称 | 说明
属性 | ExportPicture | 是否将单元格类型导出成图片。
页首
公共 方法
 | 名称 | 说明
方法 | ExportToExcel | 导出单元格类型时的处理。
页首
请参见

引用

IExportCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IExportCellType 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportCellType 接口

所有这类成员的列表, 请看 IExportCellType 成员.

公共 方法
 | 名称 | 说明
方法 | ExportToExcel | 导出单元格类型时的处理。
页首
请参见

引用

IExportCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportToExcel 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IExportCellType 接口 : ExportToExcel 方法
单元格类型所在单元格信息。
单元格类型在导出时的上下文信息。
导出单元格类型时的处理。
语法
  • C#
ExportResultInfo ExportToExcel(
   ICellInfo targetCell,
   IExportContext context
)

参数

targetCell
单元格类型所在单元格信息。
context
单元格类型在导出时的上下文信息。

返回值

返回导出的单元格类型的值或图片等。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportCellType 接口
IExportCellType 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IExportCellType 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IExportCellType 接口

所有这类成员的列表, 请看 IExportCellType 成员.

公共 属性
 | 名称 | 说明
属性 | ExportPicture | 是否将单元格类型导出成图片。
页首
请参见

引用

IExportCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportPicture 属性 (IExportCellType)
GrapeCity.Forguncy.CellTypes 命名空间 > IExportCellType 接口 : ExportPicture 属性
是否将单元格类型导出成图片。
语法
  • C#
bool ExportPicture {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportCellType 接口
IExportCellType 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IExportContext 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IExportContext 接口
导出单元格类型的上下文信息。
对象模型
IExportContext 接口IDrawingHelper 接口IExportImageContext 接口IExportValueProvider 接口
语法
  • C#
public interface IExportContext
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportContext 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IExportContext 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportContext 接口

以下表中列出了IExportContext的公开成员.

公共 属性
 | 名称 | 说明
属性 | DrawingHelper | 单元格类型生成图片时的画布工具。
属性 | ExportImageContext | 导出图片时的上下文信息，如图片保存路径等相关信息。
属性 | PictureSize | 导出时单元格类型生成的图片大小。
属性 | ValueProvider | 数据访问器，提供数据表的查询结果。
页首
公共 方法
 | 名称 | 说明
方法 | GetPictureByByteArray | 根据图片比特数组生成图片对象。
方法 | GetPictureByPicturePath | 根据图片路径生成图片对象。
页首
请参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IExportContext 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportContext 接口

所有这类成员的列表, 请看 IExportContext 成员.

公共 方法
 | 名称 | 说明
方法 | GetPictureByByteArray | 根据图片比特数组生成图片对象。
方法 | GetPictureByPicturePath | 根据图片路径生成图片对象。
页首
请参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetPictureByByteArray 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IExportContext 接口 : GetPictureByByteArray 方法
图片比特数组。
图片宽度。
图片高度。
根据图片比特数组生成图片对象。
语法
  • C#
ImageSource GetPictureByByteArray(
   byte[] byteArray,
   double width,
   double height
)

参数

byteArray
图片比特数组。
width
图片宽度。
height
图片高度。

返回值

返回图片对象。
示例
  • C#
public class SignatureCellType : CellType, IExportCellType
{
    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var value = targetCell.Value as string;
        if (string.IsNullOrEmpty(value))
        {
            return null;
        }

        var byteArray = Convert.FromBase64String(value);
        var bitmapImageSource = context.GetPictureByByteArray(byteArray, context.PictureSize.Width, context.PictureSize.Height);
        return new ExportResultInfo()
        {
            ExportValue = null,
            ExportPicture = bitmapImageSource
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportContext 接口
IExportContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetPictureByPicturePath 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IExportContext 接口 : GetPictureByPicturePath 方法
图片路径。
图片宽度。
图片高度。
根据图片路径生成图片对象。
语法
  • C#
ImageSource GetPictureByPicturePath(
   string path,
   double width,
   double height
)

参数

path
图片路径。
width
图片宽度。
height
图片高度。

返回值

返回图片对象。
示例
  • C#
public class MyImageCellType : CellType, IExportCellType
{
    public ImageValue ImageInfo { get; set; }

    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var result = new ExportResultInfo();
        if (this.ImageInfo != null)
        {
            var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
            if (ImageInfo.BuiltIn)
            {
                folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
            }

            var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

            var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
            result.ExportPicture = imageSource;
        }

        return result;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportContext 接口
IExportContext 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IExportContext 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IExportContext 接口

所有这类成员的列表, 请看 IExportContext 成员.

公共 属性
 | 名称 | 说明
属性 | DrawingHelper | 单元格类型生成图片时的画布工具。
属性 | ExportImageContext | 导出图片时的上下文信息，如图片保存路径等相关信息。
属性 | PictureSize | 导出时单元格类型生成的图片大小。
属性 | ValueProvider | 数据访问器，提供数据表的查询结果。
页首
请参见

引用

IExportContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
DrawingHelper 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IExportContext 接口 : DrawingHelper 属性
单元格类型生成图片时的画布工具。
语法
  • C#
IDrawingHelper DrawingHelper {get;}
示例
  • C#
public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
{
    TextBlock textBlock = new TextBlock();
    textBlock.Text = targetCell.Text;

    context.DrawingHelper.SetFontInfoToControl(textBlock, CopyFontInfoToControlOption.All);

    //todo...
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportContext 接口
IExportContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ExportImageContext 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IExportContext 接口 : ExportImageContext 属性
导出图片时的上下文信息，如图片保存路径等相关信息。
语法
  • C#
IExportImageContext ExportImageContext {get;}
示例
  • C#
public class SignatureCellType : CellType, IExportCellType
{
    public bool ExportPicture
    {
        return true;
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        var value = targetCell.Value as string;
        if (string.IsNullOrEmpty(value))
        {
            return null;
        }

        var byteArray = Convert.FromBase64String(value);
        var bitmapImageSource = context.GetPictureByByteArray(byteArray, context.PictureSize.Width, context.PictureSize.Height);
        return new ExportResultInfo()
        {
            ExportValue = null,
            ExportPicture = bitmapImageSource
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportContext 接口
IExportContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
PictureSize 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IExportContext 接口 : PictureSize 属性
导出时单元格类型生成的图片大小。
语法
  • C#
Size PictureSize {get;}
示例
  • C#
public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
{
    var result = new ExportResultInfo();
    if (this.ImageInfo != null)
    {
        var folderPath = context.DrawingHelper.ForguncyImageEditorFolderPath;
        if (ImageInfo.BuiltIn)
        {
            folderPath = context.DrawingHelper.ForguncyBuiltInImagesFolderPath;
        }

        var imagePath = context.ExportImageContext.GetServerPathFunc("~/" + folderPath + "/" + this.ImageInfo.Name);

        var imageSource = context.GetPictureByPicturePath(imagePath, context.PictureSize.Width, context.PictureSize.Height);
        result.ExportPicture = imageSource;
    }

    return result;
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportContext 接口
IExportContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ValueProvider 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IExportContext 接口 : ValueProvider 属性
数据访问器，提供数据表的查询结果。
语法
  • C#
IExportValueProvider ValueProvider {get;}
示例
  • C#
public class RadioGroupCellType : CellType, IExportCellType
{
    public string TableName { get; set; }

    public string TextColumn { get; set; }

    public string ValueColumn { get; set; }

    public bool ExportPicture
    {
        get
        {
            return true;
        }
    }

    public ExportResultInfo ExportToExcel(ICellInfo targetCell, IExportContext context)
    {
        ExportResultInfo result = new ExportResultInfo();

       Dictionary<string, object> queryInfo = new Dictionary<string, object>();
        queryInfo.Add(this.ValueColumn, targetCell.Value);

        var tableData = context.ValueProvider.GetTableData(TableName, new List<string>() { this.TextColumn, this.ValueColumn }, queryInfo, true);
        if(tableData != null && tableData.Count > 0)
        {
            result.ExportValue = tableData[0][this.TextColumn];
        }

        //export image
        //todo...

        return result;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportContext 接口
IExportContext 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IExportImageContext 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IExportImageContext 接口
内部使用。
语法
  • C#
public interface IExportImageContext
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportImageContext 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IExportImageContext 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportImageContext 接口

以下表中列出了IExportImageContext的公开成员.

公共 属性
 | 名称 | 说明
属性 | BASE64STRINGHEAD | "data:image/png;base64,"
属性 | GetServerPathFunc | 基于设计器中的图片路径找到对应的服务器端的图片路径并返回。
属性 | LocalFilePrefix | "/Forguncy/Upload"
属性 | UploadPath | 服务器端图片上传的路径。
属性 | UploadPathTemp | 服务器端图片上传的临时路径。
页首
公共 方法
 | 名称 | 说明
方法 | IsUniqueFileName | 判断文件名是否唯一。
页首
请参见

引用

IExportImageContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IExportImageContext 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportImageContext 接口

所有这类成员的列表, 请看 IExportImageContext 成员.

公共 方法
 | 名称 | 说明
方法 | IsUniqueFileName | 判断文件名是否唯一。
页首
请参见

引用

IExportImageContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
IsUniqueFileName 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IExportImageContext 接口 : IsUniqueFileName 方法
文件名。
判断文件名是否唯一。
语法
  • C#
bool IsUniqueFileName(
   string fileName
)

参数

fileName
文件名。

返回值

返回true则唯一，否则不唯一。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportImageContext 接口
IExportImageContext 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IExportImageContext 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IExportImageContext 接口

所有这类成员的列表, 请看 IExportImageContext 成员.

公共 属性
 | 名称 | 说明
属性 | BASE64STRINGHEAD | "data:image/png;base64,"
属性 | GetServerPathFunc | 基于设计器中的图片路径找到对应的服务器端的图片路径并返回。
属性 | LocalFilePrefix | "/Forguncy/Upload"
属性 | UploadPath | 服务器端图片上传的路径。
属性 | UploadPathTemp | 服务器端图片上传的临时路径。
页首
请参见

引用

IExportImageContext 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BASE64STRINGHEAD 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IExportImageContext 接口 : BASE64STRINGHEAD 属性
"data:image/png;base64,"
语法
  • C#
string BASE64STRINGHEAD {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportImageContext 接口
IExportImageContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetServerPathFunc 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IExportImageContext 接口 : GetServerPathFunc 属性
基于设计器中的图片路径找到对应的服务器端的图片路径并返回。
语法
  • C#
Func<string,string> GetServerPathFunc {get;}
示例
代码查看IExportCellType。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportImageContext 接口
IExportImageContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
LocalFilePrefix 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IExportImageContext 接口 : LocalFilePrefix 属性
"/Forguncy/Upload"
语法
  • C#
string LocalFilePrefix {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportImageContext 接口
IExportImageContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
UploadPath 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IExportImageContext 接口 : UploadPath 属性
服务器端图片上传的路径。
语法
  • C#
string UploadPath {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportImageContext 接口
IExportImageContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
UploadPathTemp 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IExportImageContext 接口 : UploadPathTemp 属性
服务器端图片上传的临时路径。
语法
  • C#
string UploadPathTemp {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportImageContext 接口
IExportImageContext 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IExportValueProvider 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IExportValueProvider 接口
数据访问器，提供数据表的查询结果。
语法
  • C#
public interface IExportValueProvider
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportValueProvider 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IExportValueProvider 接口 成员
方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportValueProvider 接口

以下表中列出了IExportValueProvider的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetTableData | 重载. 获取数据库表中的数据。
页首
请参见

引用

IExportValueProvider 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IExportValueProvider 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IExportValueProvider 接口

所有这类成员的列表, 请看 IExportValueProvider 成员.

公共 方法
 | 名称 | 说明
方法 | GetTableData | 重载. 获取数据库表中的数据。
页首
请参见

引用

IExportValueProvider 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetTableData 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IExportValueProvider 接口 : GetTableData 方法
获取数据库表中的数据。
重载列表
重载 | 说明
GetTableData(String,List<String>,Dictionary<String,Object>,Boolean) | 获取数据库表中的数据。
GetTableData(String,List<String>,Object,Boolean) | 获取数据库表中的数据。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportValueProvider 接口
IExportValueProvider 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetTableData(String,List<String>,Dictionary<String,Object>,Boolean) 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IExportValueProvider 接口 > GetTableData 方法 : GetTableData(String,List<String>,Dictionary<String,Object>,Boolean) 方法
数据表名。
查询的列名集合。
简单查询条件。
是否去重。
获取数据库表中的数据。
语法
  • C#
List<Dictionary<string,object>> GetTableData(
   string tableName,
   List<string> columns,
   Dictionary<string,object> queryInfo,
   bool distinct
)

参数

tableName
数据表名。
columns
查询的列名集合。
queryInfo
简单查询条件。
distinct
是否去重。

返回值

查询后的数据库表中的数据。
示例
代码查看IExportContext.ValueProvider
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportValueProvider 接口
IExportValueProvider 成员
重载列表


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetTableData(String,List<String>,Object,Boolean) 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IExportValueProvider 接口 > GetTableData 方法 : GetTableData(String,List<String>,Object,Boolean) 方法
数据表名。
查询的列名集合。
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
去重。
获取数据库表中的数据。
语法
  • C#
List<Dictionary<string,object>> GetTableData(
   string tableName,
   List<string> columns,
   object queryCondition,
   bool distinct
)

参数

tableName
数据表名。
columns
查询的列名集合。
queryCondition
复杂查询条件，由活字格内置查询条件对话窗口生成的对象。
distinct
去重。

返回值

查询后的数据库表中的数据。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IExportValueProvider 接口
IExportValueProvider 成员
重载列表


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IForguncyFormatter 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IForguncyFormatter 接口
单元格格式。
语法
  • C#
public interface IForguncyFormatter
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IForguncyFormatter 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IForguncyFormatter 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IForguncyFormatter 接口

以下表中列出了IForguncyFormatter的公开成员.

公共 属性
 | 名称 | 说明
属性 | FormatString | 格式字符串。
页首
公共 方法
 | 名称 | 说明
方法 | Format | 通过格式字符串转换成值。
页首
请参见

引用

IForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IForguncyFormatter 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IForguncyFormatter 接口

所有这类成员的列表, 请看 IForguncyFormatter 成员.

公共 方法
 | 名称 | 说明
方法 | Format | 通过格式字符串转换成值。
页首
请参见

引用

IForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Format 方法 (IForguncyFormatter)
GrapeCity.Forguncy.CellTypes 命名空间 > IForguncyFormatter 接口 : Format 方法
原始值。
通过格式字符串转换成值。
语法
  • C#
string Format(
   object value
)

参数

value
原始值。

返回值

返回转换之后的值。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IForguncyFormatter 接口
IForguncyFormatter 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IForguncyFormatter 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IForguncyFormatter 接口

所有这类成员的列表, 请看 IForguncyFormatter 成员.

公共 属性
 | 名称 | 说明
属性 | FormatString | 格式字符串。
页首
请参见

引用

IForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
FormatString 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IForguncyFormatter 接口 : FormatString 属性
格式字符串。
语法
  • C#
string FormatString {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IForguncyFormatter 接口
IForguncyFormatter 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IGeneralForguncyFormatter 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IGeneralForguncyFormatter 接口
内部使用。
语法
  • C#
public interface IGeneralForguncyFormatter : IForguncyFormatter
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IGeneralForguncyFormatter 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IGeneralForguncyFormatter 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IGeneralForguncyFormatter 接口

以下表中列出了IGeneralForguncyFormatter的公开成员.

公共 属性
 | 名称 | 说明
属性 | FormatString | 格式字符串。 (从GrapeCity.Forguncy.CellTypes.IForguncyFormatter继承)
页首
公共 方法
 | 名称 | 说明
方法 | Format | 内部使用。
方法 | GetPreferredEditingFormatter | 内部使用。
页首
请参见

引用

IGeneralForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IGeneralForguncyFormatter 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IGeneralForguncyFormatter 接口

所有这类成员的列表, 请看 IGeneralForguncyFormatter 成员.

公共 方法
 | 名称 | 说明
方法 | Format | 内部使用。
方法 | GetPreferredEditingFormatter | 内部使用。
页首
请参见

引用

IGeneralForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Format 方法 (IGeneralForguncyFormatter)
GrapeCity.Forguncy.CellTypes 命名空间 > IGeneralForguncyFormatter 接口 : Format 方法
内部使用。
语法
  • C#
string Format(
   object obj,
   out Nullable<Color> conditionalForeColor
)

参数

obj
conditionalForeColor
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IGeneralForguncyFormatter 接口
IGeneralForguncyFormatter 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetPreferredEditingFormatter 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IGeneralForguncyFormatter 接口 : GetPreferredEditingFormatter 方法
内部使用。
语法
  • C#
IForguncyFormatter GetPreferredEditingFormatter(
   object value
)

参数

value
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IGeneralForguncyFormatter 接口
IGeneralForguncyFormatter 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IIgnoreAlternativeRowBackColorWhenExport 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : IIgnoreAlternativeRowBackColorWhenExport 接口
配合IExportCellType使用，导出Excel时不使用页面中表格的交替色作为背景色，如表格中的按钮导出到Excel时不使用交替色作为背景色。
语法
  • C#
public interface IIgnoreAlternativeRowBackColorWhenExport
示例
  • C#
public class ButtonCellType : CellType, IExportCellType, IIgnoreAlternativeRowBackColorWhenExport
{
    ...
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IIgnoreAlternativeRowBackColorWhenExport 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IIgnoreAlternativeRowBackColorWhenExport 接口 成员

GrapeCity.Forguncy.CellTypes 命名空间 : IIgnoreAlternativeRowBackColorWhenExport 接口

以下表中列出了IIgnoreAlternativeRowBackColorWhenExport的公开成员.

请参见

引用

IIgnoreAlternativeRowBackColorWhenExport 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IQueryConditionWindow 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : IQueryConditionWindow 接口

活字格内置的设置查询条件的对话窗口。

注意：由内置查询条件对话窗口生成的对象可能包含单元格引用信息，需要实现GrapeCity.Forguncy.Plugin.IReferenceFormula和IDependenceCells这两个接口。

语法
  • C#
public interface IQueryConditionWindow : IWindow
示例
  • C#
public class TreeCellType : CellType, IDependenceCells, IReferenceFormula
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        if (this.BindingTreeLevelInfo != null)
        {
            return this.BindingTreeLevelInfo.GetFormulaReferObjects(location);
        }
        return Enumerable.Empty<LocatedObject<object>>();
    }

    public IEnumerable<object> EnumDependenceCells(IBuilderContext context)
    {
        return EnumDependenceCells(this.BindingTreeLevelInfo, context);
    }

    private IEnumerable<object> EnumDependenceCells(BindingTreeLevelInfo info, IBuilderContext context)
    {
        var result = Enumerable.Empty<object>();
        if (info != null)
        {
            if (info.QueryCondition != null)
            {
                result = result.Union(context.EnumDependenceCells(info.QueryCondition) ?? Enumerable.Empty<object>());
            }
            if (info.SubBindingTreeLevelInfo != null)
            {
                result = result.Union(EnumDependenceCells(info.SubBindingTreeLevelInfo, context) ?? Enumerable.Empty<object>());
            }
        }
        return result;
    }
}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出查询对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditQueryConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的查询条件和表名初始化查询对话窗口。*/
        var window = _builderContext?.GetQueryConditionWindow(queryCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的查询条件提交到数据层。*/
                /*ViewModel.QueryCondition = window.QueryCondition;*/

                /*重新打开父窗口。*/
                _builderContext.ShowParentDialog(this);
            }
        }
        /*由于查询条件中可能引用单元格，所以这里需要暂时隐藏父窗口。*/
        _builderContext.HideParentDialog(this);
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object QueryCondition { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("TreeCellType").AppendProperty("BindingTreeLevelInfo");
        if(this.QueryCondition is IReferenceFormula)
        {
            var items = (this.QueryCondition as IReferenceFormula).GetFormulaReferObjects(newLocation);
            foreach (var item in items)
            {
                yield return item;
            }
        }
        if (this.SubBindingTreeLevelInfo != null)
        {
            var items = this.SubBindingTreeLevelInfo.GetFormulaReferObjects(location);
            foreach (var item in items)
            {
                yield return item;
            }
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IQueryConditionWindow 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IQueryConditionWindow 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IQueryConditionWindow 接口

以下表中列出了IQueryConditionWindow的公开成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
属性 | QueryCondition | 查询条件。
页首
公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IQueryConditionWindow 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IQueryConditionWindow 接口

所有这类成员的列表, 请看 IQueryConditionWindow 成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
属性 | QueryCondition | 查询条件。
页首
请参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
QueryCondition 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IQueryConditionWindow 接口 : QueryCondition 属性
查询条件。
语法
  • C#
object QueryCondition {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IQueryConditionWindow 接口
IQueryConditionWindow 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IReferenceCommand 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : IReferenceCommand 接口
如果一个单元格不是ICommandCellType，但是该单元格内部属性中有命令设置，如菜单单元格类型，需实现该接口； 否则有些命令执行会出错，而且查找所有引用会有遗漏。
语法
  • C#
public interface IReferenceCommand
示例
  • C#
public class MyMenuCellType : CellType, IReferenceCommand
{
    public List<ItemInfo> Items { get; set; }

    public IEnumerable<LocatedObject<List<Command>>> GetCommandList(LocationIndicator location)
    {
        return this.GetCommandList(this.Items, location);
    }

    private IEnumerable<LocatedObject<List<Command>>> GetCommandList(List<ItemInfo> items, LocationIndicator location)
    {
        if (items == null)
        {
            yield break;
        }
        foreach (var item in items)
        {
            if (item.CommandList != null)
            {
                var newLocation = location.AppendProperty("MyMenuCellType").AppendProperty(item.Text).AppendProperty("CommandList");
                yield return new LocatedObject<List<Command>>(item.CommandList, newLocation);
            }

            foreach (var item2 in GetCommandList(item.SubItems, location))
            {
                yield return item2;
            }
        }
    }
}

public class ItemInfo
{
    public string Text { get; set; }

    public List<Command> CommandList { get; set; }

    public List<ItemInfo> SubItems { get; set; }
    //...
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceCommand 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IReferenceCommand 接口 成员
方法

GrapeCity.Forguncy.CellTypes 命名空间 : IReferenceCommand 接口

以下表中列出了IReferenceCommand的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetCommandList | 返回插件内部属性使用到的所有的命令列表。
页首
请参见

引用

IReferenceCommand 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IReferenceCommand 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IReferenceCommand 接口

所有这类成员的列表, 请看 IReferenceCommand 成员.

公共 方法
 | 名称 | 说明
方法 | GetCommandList | 返回插件内部属性使用到的所有的命令列表。
页首
请参见

引用

IReferenceCommand 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetCommandList 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IReferenceCommand 接口 : GetCommandList 方法
坐标定位器。
返回插件内部属性使用到的所有的命令列表。
语法
  • C#
IEnumerable<LocatedObject<List<Command>>> GetCommandList(
   LocationIndicator location
)

参数

location
坐标定位器。

返回值

返回插件内部属性使用到的所有的命令列表。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceCommand 接口
IReferenceCommand 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ISelectImageWindow 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : ISelectImageWindow 接口
内置图片选择对话窗口。
语法
  • C#
public interface ISelectImageWindow : IWindow
示例
  • C#
public partial class MenuItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public MenuItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();

        _builderContext = builderContext;
    }

    private void SelectImageHyperlink_Click(object sender, RoutedEventArgs e)
    {
        var window = _builderContext.GetSelectImageWindow(ViewModel.ImagePath, ViewModel.IsBuiltInImage);
        window.Closed += (sender2, e2) =>
        {
            if (window.DialogResult == true)
            {
                ViewModel.ImagePath = window.ImagePath;
                ViewModel.IsBuiltInImage = window.BuiltIn;
            }
        }

        window.ShowDialog();
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISelectImageWindow 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ISelectImageWindow 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISelectImageWindow 接口

以下表中列出了ISelectImageWindow的公开成员.

公共 属性
 | 名称 | 说明
属性 | BuiltIn | 返回选中图片是否是内置图片。
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
属性 | ImagePath | 返回选中图片的名称。
页首
公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
ISelectImageWindow 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : ISelectImageWindow 接口

所有这类成员的列表, 请看 ISelectImageWindow 成员.

公共 属性
 | 名称 | 说明
属性 | BuiltIn | 返回选中图片是否是内置图片。
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
属性 | ImagePath | 返回选中图片的名称。
页首
请参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BuiltIn 属性 (ISelectImageWindow)
GrapeCity.Forguncy.CellTypes 命名空间 > ISelectImageWindow 接口 : BuiltIn 属性
返回选中图片是否是内置图片。
语法
  • C#
bool BuiltIn {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISelectImageWindow 接口
ISelectImageWindow 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ImagePath 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ISelectImageWindow 接口 : ImagePath 属性
返回选中图片的名称。
语法
  • C#
string ImagePath {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISelectImageWindow 接口
ISelectImageWindow 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ISortConditionWindow 接口
成员 示例
GrapeCity.Forguncy.CellTypes 命名空间 : ISortConditionWindow 接口
活字格内置的设置排序条件的对话窗口。
语法
  • C#
public interface ISortConditionWindow : IWindow
示例
  • C#
public class TreeCellType : CellType
{
    public BindingTreeLevelInfo BindingTreeLevelInfo { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "BindingTreeLevelInfo")
        {
            return new HyperlinkEditorSetting(new BindingTreeLevelInfoEditorSettingsCommand(builderContext));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}

public class BindingTreeLevelInfoEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public BindingTreeLevelInfoEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        BindingTreeLevelInfo bindingTreeLevelInfo = dataContext?.Value as BindingTreeLevelInfo;

        Window window = new Window();
        UserControl dialog = new BindingTreeItemsEditor(_builderContext);
        /*这里需要将设计器上下文信息传递到编辑树节点的对话窗口，从而可以在需要的时候弹出排序对话窗口。*/

        //...
    }
}

public partial class BindingTreeItemsEditor : UserControl
{
    IBuilderContext _builderContext;
    public BindingTreeItemsEditor(IBuilderContext builderContext)
    {
        InitializeComponent();
        _builderContext = builderContext;
    }

    private void EditSortConditionHyperlink_Click(object sender, RoutedEventArgs e)
    {
        /*使用数据层的排序条件和表名初始化排序对话窗口。*/
        var window = _builderContext?.GetSortConditionWindow(sortCondition, tableName);
        window.Closed += (s, e2) =>
        {
            if (window.DialogResult == true)
            {
                /*当窗口被关闭后需要将新生成的排序条件提交到数据层。*/
                /*ViewModel.SortCondition = window.SortCondition;*/
            }
        }
        window.ShowDialog();
    }
}

public class BindingTreeLevelInfo
{
    public string TableName { get; set; }
    public string ValueColumn { get; set; }
    public string NameColumn { get; set; }
    public string MasterTableReletedColumn { get; set; }
    public BindingTreeLevelInfo SubBindingTreeLevelInfo { get; set; }

    public object SortCondition { get; set; }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISortConditionWindow 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ISortConditionWindow 接口 成员
属性 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISortConditionWindow 接口

以下表中列出了ISortConditionWindow的公开成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
属性 | SortCondition | 排序条件。
页首
公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

ISortConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
ISortConditionWindow 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : ISortConditionWindow 接口

所有这类成员的列表, 请看 ISortConditionWindow 成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
属性 | SortCondition | 排序条件。
页首
请参见

引用

ISortConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
SortCondition 属性
GrapeCity.Forguncy.CellTypes 命名空间 > ISortConditionWindow 接口 : SortCondition 属性
排序条件。
语法
  • C#
object SortCondition {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISortConditionWindow 接口
ISortConditionWindow 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IStaticValueCellType 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IStaticValueCellType 接口
忽略单元格的值，可以自定义单元格类型返回的值； 例如，如果一个单元格引用登录用户单元格类型的值，返回的是当前用户，而非单元格上的值或0.
语法
  • C#
public interface IStaticValueCellType
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStaticValueCellType 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IStaticValueCellType 接口 成员
属性

GrapeCity.Forguncy.CellTypes 命名空间 : IStaticValueCellType 接口

以下表中列出了IStaticValueCellType的公开成员.

公共 属性
 | 名称 | 说明
属性 | CellCustomValue | 单元格返回的自定义固定值。
页首
请参见

引用

IStaticValueCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IStaticValueCellType 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IStaticValueCellType 接口

所有这类成员的列表, 请看 IStaticValueCellType 成员.

公共 属性
 | 名称 | 说明
属性 | CellCustomValue | 单元格返回的自定义固定值。
页首
请参见

引用

IStaticValueCellType 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
CellCustomValue 属性
示例
GrapeCity.Forguncy.CellTypes 命名空间 > IStaticValueCellType 接口 : CellCustomValue 属性
单元格返回的自定义固定值。
语法
  • C#
object CellCustomValue {get;}
示例
  • C#
public class CurrentUserCellType : CellType, IStaticValueCellType
{
    public object CellCustomValue
    {
        get
        {
            return "CurrentUser";
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStaticValueCellType 接口
IStaticValueCellType 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IStyleInfo 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IStyleInfo 接口
设置样式。
对象模型
IStyleInfo 接口IBorderLine 接口IBorderLine 接口IBorderLine 接口IBorderLine 接口IForguncyFormatter 接口
语法
  • C#
public interface IStyleInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IStyleInfo 接口 成员
属性

GrapeCity.Forguncy.CellTypes 命名空间 : IStyleInfo 接口

以下表中列出了IStyleInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | Background | 背景色。
属性 | BorderBottom | 下边框。
属性 | BorderLeft | 左边框。
属性 | BorderRight | 右边框。
属性 | BorderTop | 上边框。
属性 | FontFamily | 字体。
属性 | FontSize | 字号。
属性 | FontStyle | 字体倾斜。
属性 | FontWeight | 字体加粗。
属性 | Foreground | 字体颜色。
属性 | Formatter | 格式设置。
属性 | HorizontalAlignment | 水平对齐方式。
属性 | Strikethrough | 是否有删除线。
属性 | TextIndent | 缩进。
属性 | Underline | 是否有下划线。
属性 | VerticalAlignment | 垂直对齐方式。
属性 | WordWrap | 是否可换行。
页首
请参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IStyleInfo 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IStyleInfo 接口

所有这类成员的列表, 请看 IStyleInfo 成员.

公共 属性
 | 名称 | 说明
属性 | Background | 背景色。
属性 | BorderBottom | 下边框。
属性 | BorderLeft | 左边框。
属性 | BorderRight | 右边框。
属性 | BorderTop | 上边框。
属性 | FontFamily | 字体。
属性 | FontSize | 字号。
属性 | FontStyle | 字体倾斜。
属性 | FontWeight | 字体加粗。
属性 | Foreground | 字体颜色。
属性 | Formatter | 格式设置。
属性 | HorizontalAlignment | 水平对齐方式。
属性 | Strikethrough | 是否有删除线。
属性 | TextIndent | 缩进。
属性 | Underline | 是否有下划线。
属性 | VerticalAlignment | 垂直对齐方式。
属性 | WordWrap | 是否可换行。
页首
请参见

引用

IStyleInfo 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Background 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : Background 属性
背景色。
语法
  • C#
Brush Background {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BorderBottom 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : BorderBottom 属性
下边框。
语法
  • C#
IBorderLine BorderBottom {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BorderLeft 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : BorderLeft 属性
左边框。
语法
  • C#
IBorderLine BorderLeft {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BorderRight 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : BorderRight 属性
右边框。
语法
  • C#
IBorderLine BorderRight {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
BorderTop 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : BorderTop 属性
上边框。
语法
  • C#
IBorderLine BorderTop {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
FontFamily 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : FontFamily 属性
字体。
语法
  • C#
FontFamily FontFamily {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
FontSize 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : FontSize 属性
字号。
语法
  • C#
double FontSize {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
FontStyle 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : FontStyle 属性
字体倾斜。
语法
  • C#
FontStyle FontStyle {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
FontWeight 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : FontWeight 属性
字体加粗。
语法
  • C#
FontWeight FontWeight {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Foreground 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : Foreground 属性
字体颜色。
语法
  • C#
Brush Foreground {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Formatter 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : Formatter 属性
格式设置。
语法
  • C#
IForguncyFormatter Formatter {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
HorizontalAlignment 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : HorizontalAlignment 属性
水平对齐方式。
语法
  • C#
ForguncyCellHorizontalAlignment HorizontalAlignment {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Strikethrough 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : Strikethrough 属性
是否有删除线。
语法
  • C#
Nullable<bool> Strikethrough {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
TextIndent 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : TextIndent 属性
缩进。
语法
  • C#
int TextIndent {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Underline 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : Underline 属性
是否有下划线。
语法
  • C#
Nullable<bool> Underline {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
VerticalAlignment 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : VerticalAlignment 属性
垂直对齐方式。
语法
  • C#
ForguncyCellVerticalAlignment VerticalAlignment {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
WordWrap 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IStyleInfo 接口 : WordWrap 属性
是否可换行。
语法
  • C#
bool WordWrap {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IStyleInfo 接口
IStyleInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ISupportPropertyInitialize 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : ISupportPropertyInitialize 接口
设置单元格类型的默认属性值。 例如，可以设置【超链接】单元格的点击模式默认为单元格而非文字区域。
语法
  • C#
public interface ISupportPropertyInitialize
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISupportPropertyInitialize 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ISupportPropertyInitialize 接口 成员
方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISupportPropertyInitialize 接口

以下表中列出了ISupportPropertyInitialize的公开成员.

公共 方法
 | 名称 | 说明
方法 | InitDefaultPropertyValues | 初始化默认属性值。
页首
请参见

引用

ISupportPropertyInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
ISupportPropertyInitialize 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISupportPropertyInitialize 接口

所有这类成员的列表, 请看 ISupportPropertyInitialize 成员.

公共 方法
 | 名称 | 说明
方法 | InitDefaultPropertyValues | 初始化默认属性值。
页首
请参见

引用

ISupportPropertyInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
InitDefaultPropertyValues 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > ISupportPropertyInitialize 接口 : InitDefaultPropertyValues 方法
初始化需要的参数
初始化默认属性值。
语法
  • C#
void InitDefaultPropertyValues(
   IBuilderContext context
)

参数

context
初始化需要的参数
示例
  • C#
public class HyperlinkCellType : CellType, ISupportPropertyInitialize
{
    [DisplayName("点击模式")]
    public HyperlinkClickMode ClickMode { get; set; }

    public void InitDefaultPropertyValues(IBuilderContext context)
    {
        this.ClickMode = HyperlinkClickMode.Cell;
    }
}

public enum HyperlinkClickMode
{
    [Description("文字")]
    Text,
    [Description("单元格")]
    Cell
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISupportPropertyInitialize 接口
ISupportPropertyInitialize 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
ISupportStyleInitialize 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : ISupportStyleInitialize 接口
设置单元格类型的默认样式和属性。
语法
  • C#
public interface ISupportStyleInitialize
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISupportStyleInitialize 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
ISupportStyleInitialize 接口 成员
方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISupportStyleInitialize 接口

以下表中列出了ISupportStyleInitialize的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetDefaultStyleInfos | 设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
页首
请参见

引用

ISupportStyleInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
ISupportStyleInitialize 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISupportStyleInitialize 接口

所有这类成员的列表, 请看 ISupportStyleInitialize 成员.

公共 方法
 | 名称 | 说明
方法 | GetDefaultStyleInfos | 设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
页首
请参见

引用

ISupportStyleInitialize 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GetDefaultStyleInfos 方法
示例
GrapeCity.Forguncy.CellTypes 命名空间 > ISupportStyleInitialize 接口 : GetDefaultStyleInfos 方法
单元格信息，如可以知道单元格所在页面类型或者是否在表格中等信息。
设置单元格类型的默认样式。 例如，可以设置【超链接】单元格的默认样式为：字体颜色是蓝色，同时带下划线。
语法
  • C#
Dictionary<StylePropertyName,object> GetDefaultStyleInfos(
   ICellInfo cellInfo
)

参数

cellInfo
单元格信息，如可以知道单元格所在页面类型或者是否在表格中等信息。

返回值

默认样式列表。
示例
  • C#
public class HyperlinkCellType : CellType, ISupportStyleInitialize
{
    public Dictionary<StylePropertyName, object> GetDefaultStyleInfos(ICellInfo cellInfo)
    {
        var dic = new Dictionary<StylePropertyName, object>();

        dic.Add(StylePropertyName.Foreground, new SolidColorBrush(Colors.Blue));
        dic.Add(StylePropertyName.Underline, true);

        return dic;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ISupportStyleInitialize 接口
ISupportStyleInitialize 成员


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
IWindow 接口
成员
GrapeCity.Forguncy.CellTypes 命名空间 : IWindow 接口
内置对话框接口。
语法
  • C#
public interface IWindow
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IWindow 成员
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
IWindow 接口 成员
属性 方法 事件

GrapeCity.Forguncy.CellTypes 命名空间 : IWindow 接口

以下表中列出了IWindow的公开成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。
页首
公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。
页首
公共 事件
 | 名称 | 说明
事件 | Closed | 对话框关闭事件。
页首
请参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IWindow 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IWindow 接口

所有这类成员的列表, 请看 IWindow 成员.

公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。
页首
请参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
ShowDialog 方法
GrapeCity.Forguncy.CellTypes 命名空间 > IWindow 接口 : ShowDialog 方法
打开对话框。
语法
  • C#
Nullable<bool> ShowDialog()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IWindow 接口
IWindow 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IWindow 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IWindow 接口

所有这类成员的列表, 请看 IWindow 成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。
页首
请参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
DialogResult 属性
GrapeCity.Forguncy.CellTypes 命名空间 > IWindow 接口 : DialogResult 属性
对话框返回结果。
语法
  • C#
Nullable<bool> DialogResult {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IWindow 接口
IWindow 成员


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.CellTypes
IWindow 接口 事件

GrapeCity.Forguncy.CellTypes 命名空间 : IWindow 接口

所有这类成员的列表, 请看 IWindow 成员.

公共 事件
 | 名称 | 说明
事件 | Closed | 对话框关闭事件。
页首
请参见

引用

IWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
Closed 事件
GrapeCity.Forguncy.CellTypes 命名空间 > IWindow 接口 : Closed 事件
对话框关闭事件。
语法
  • C#
event EventHandler Closed
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IWindow 接口
IWindow 成员


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间
继承层次
类
 | 类 | 说明
类 | PropertyChangedObjectBase | 内部使用。
请参见

引用

GrapeCity.Forguncy.CellTypes 程序集


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
PropertyChangedObjectBase 类
成员
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 : PropertyChangedObjectBase 类
内部使用。
语法
  • C#
public class PropertyChangedObjectBase
继承层次

System.Object
GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase
GrapeCity.Forguncy.CellTypes.CellType

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PropertyChangedObjectBase 成员
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.CellTypes
PropertyChangedObjectBase 类 成员
方法 事件

GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 : PropertyChangedObjectBase 类

以下表中列出了PropertyChangedObjectBase的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | PropertyChangedObjectBase 构造函数 |
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。
页首
请参见

引用

PropertyChangedObjectBase 类
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.CellTypes
PropertyChangedObjectBase 构造函数
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 > PropertyChangedObjectBase 类 : PropertyChangedObjectBase 构造函数
语法
  • C#
public PropertyChangedObjectBase()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PropertyChangedObjectBase 类
PropertyChangedObjectBase 成员


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
PropertyChangedObjectBase 类 方法

GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 : PropertyChangedObjectBase 类

所有这类成员的列表, 请看 PropertyChangedObjectBase 成员.

保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。
页首
请参见

引用

PropertyChangedObjectBase 类
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
OnPropertyChanged 方法 (PropertyChangedObjectBase)
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 > PropertyChangedObjectBase 类 : OnPropertyChanged 方法
内部使用。
语法
  • C#
protected virtual void OnPropertyChanged(
   string propertyName
)

参数

propertyName
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PropertyChangedObjectBase 类
PropertyChangedObjectBase 成员


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.CellTypes
PropertyChangedObjectBase 类 事件

GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 : PropertyChangedObjectBase 类

所有这类成员的列表, 请看 PropertyChangedObjectBase 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。
页首
请参见

引用

PropertyChangedObjectBase 类
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.CellTypes
PropertyChanged 事件 (PropertyChangedObjectBase)
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 > PropertyChangedObjectBase 类 : PropertyChanged 事件
内部使用。
语法
  • C#
public event PropertyChangedEventHandler PropertyChanged
事件数据

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

属性 | 说明
PropertyName |
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PropertyChangedObjectBase 类
PropertyChangedObjectBase 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GrapeCity.Forguncy.Plugin 程序集
命名空间
命名空间 | 说明
GrapeCity.Forguncy.Plugin |


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GrapeCity.Forguncy.Plugin 命名空间
继承层次
类
 | 类 | 说明
类 | BuiltinEditorSetting | 活字格内置的属性编辑器。
类 | CheckBoxEidtorSetting | 是/否类型的属性对应的编辑器，如[只读]属性。
类 | ComboEditorSetting | 组合框。如菜单中使用的[主题]属性。
类 | DoubleEditorSetting | 小数类型的属性对应的编辑器，如地图插件使用的[经度]或[纬度]属性。
类 | EditorSetting | 插件内部属性对应的编辑器设置。
类 | EnumValueEditorSetting | 枚举类型编辑器。如菜单中使用的[主题]属性。
类 | FileCopyInfo | 在导入活字格页面过程中，需要复制的文件信息。
类 | FileUploadInfo | 上传文件的信息，用于保存。
类 | ForguncyErrorInfo | 运行页面时，内部检查出的错误或者提醒信息。
类 | FormulaPropertyAttribute | 指定插件内部属性对应的编辑器为公式选择框。 注意：使用公式选择框作为属性值编辑器的属性，其值类型必须是object。
类 | FormulaSelectorEditorSetting | 公式类型的属性对应的编辑器，如[缺省值]属性。
类 | HyperlinkEditorSetting | 超链接编辑器，如果一个属性比较复杂，需要单独提供一个对话框去设置属性内部的值的时候会用到这个编辑器，如[编辑菜单项目...]属性。
类 | IconAttribute | 设置插件的图标。 该图标会应用到单元格类型下拉列表或命令选择下拉列表中，如果开启了单元格类型的显示模式，该图标也会应用到使用了该单元格类型的单元格上。
类 | ImageEditorSetting | 图片编辑器。如图片类型使用的[选择图片...]属性。
类 | ImageValue | 一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
类 | IntEditorSetting | 整数类型的属性对应的编辑器，如单选按钮使用的[项目间距]属性。
类 | LocatedObject | 带坐标定位器的对象。
类 | LocatedObject<T> | 带坐标定位器的特定类型的对象，如页面，命名等。
类 | LocationIndicator | 坐标定位器，查找引用时基于它可以帮助用户快速找到相关对象的位置。
类 | LocationIndicatorExtension | 坐标定位器扩展类。
类 | NameIndicator | 名称定位器，一种特定类型的坐标定位器。
类 | ObjectIndicator | 对象定位器，一种特定类型的坐标定位器。
类 | ObjectIndicator<T> | 特定类型的对象定位器。
类 | OrderWeightAttribute | 插件或插件内部属性的权重, 权重越大位置越靠后。
类 | OrientationEidtorSetting | 排列方向类型的属性对应的编辑器，如单选按钮使用的[布局]属性。
类 | PluginUtilities | 插件公用类。
类 | PropertyIndicator | 属性定位器，一种特定类型的坐标定位器。
类 | TableCheckInfo | 查找数据表的引用时返回的数据表的位置信息。
类 | TableComboTreeSelectorEditorSetting | 数据表选择器。如数据导航按钮中使用的[导航表]属性。
类 | TextEditorSetting | 文本类型的属性对应的编辑器，如[水印]属性。
类 | TimeValueEditorSetting | 时间类型编辑器。如时间单元类型使用的[下拉框开始时间]属性。
接口
 | 接口 | 说明
接口 | IBuilderContextBase | 设计器上下文信息。
接口 | ICellInfoBase | 单元格的信息。
接口 | IColumnInfo | 数据表中的字段信息。
接口 | IEditorSettingsDataContext | 属性数据上下文，可以获取属性的值以及属性编辑器。
接口 | IFileUploadContext | 上传的文件需要的上下文信息。
接口 | IFormulaReferObject | 公式对象。
接口 | IListViewInfo | 页面中的表格信息。
接口 | INeedUploadFileByUser | 如果插件使用过程中需要用户上传文件或者图片等，在保存或导入活字格文件时需给出相关的文件或图片信息，如存储文件夹路径，文件名等。
接口 | IPageInfo | 页面信息。
接口 | IReferenceFormula | 如果插件中引用了页面中的单元格，一旦被引用的单元格的位置发生了变化，如拖拽，那么插件中的相关单元格引用也应该被同步； 这种情况下就需要实现这个接口，而且，当查找页面中的单元格引用时，插件中的相关属性也会被查找出来。
接口 | IReferenceListView | 如果插件中引用了页面中的表格的名称，一旦表格重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找页面中的表格引用时，插件中的相关属性也会被查找出来。
接口 | IReferenceListViewColumn | 如果插件中引用了页面表格中列名，一旦表格中的列重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口。
接口 | IReferencePage | 如果插件中引用了页面名，一旦页面重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找页面的引用时，插件中的相关属性也会被查找出来。
接口 | IReferenceTable | 如果插件中引用了数据表名或者字段名，一旦数据表或字段重命名后，插件中的相关属性的值就期望被同步； 这种情况下就需要实现这个接口，而且，当查找数据表或字段的引用时，插件中的相关属性也会被查找出来。
接口 | ITableInfo | 数据表的信息。
接口 | IUserServiceInfo | 用户管理网站的信息。
接口 | IWorkflowInfo | 数据表中的工作流信息。
枚举
 | 枚举 | 说明
枚举 | ForguncyErrorType | 运行页面时，系统内部会进行出错检查并显示在错误列表中，会根据出错类型显示不同的信息，并影响页面是否能够运行起来。
枚举 | ForguncyTableColumnType | 内建字段的值的类型。
枚举 | TableColumnKind | 字段分类。
请参见

引用

GrapeCity.Forguncy.Plugin 程序集


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
BuiltinEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : BuiltinEditorSetting 类
活字格内置的属性编辑器。
语法
  • C#
public abstract class BuiltinEditorSetting : EditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.CheckBoxEidtorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.DoubleEditorSetting
GrapeCity.Forguncy.Plugin.FormulaSelectorEditorSetting
GrapeCity.Forguncy.Plugin.HyperlinkEditorSetting
GrapeCity.Forguncy.Plugin.ImageEditorSetting
GrapeCity.Forguncy.Plugin.IntEditorSetting
GrapeCity.Forguncy.Plugin.OrientationEidtorSetting
GrapeCity.Forguncy.Plugin.TableComboTreeSelectorEditorSetting
GrapeCity.Forguncy.Plugin.TextEditorSetting
GrapeCity.Forguncy.Plugin.TimeValueEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

BuiltinEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
BuiltinEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : BuiltinEditorSetting 类

以下表中列出了BuiltinEditorSetting的公开成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
Public 属性 | TemplateName | 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 重写. 属性编辑器对应的数据模板。
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
BuiltinEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : BuiltinEditorSetting 类

所有这类成员的列表, 请看 BuiltinEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 重写. 属性编辑器对应的数据模板。
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetDataTemplate 方法 (BuiltinEditorSetting)
示例
GrapeCity.Forguncy.Plugin 命名空间 > BuiltinEditorSetting 类 : GetDataTemplate 方法
属性编辑器对应的数据模板。
语法
  • C#
public override DataTemplate GetDataTemplate()

返回值

属性编辑器对应的数据模板。
示例

自定义属性编辑器的数据模板。

  • C#
public class PassValueItemsEditorSetting : BuiltinEditorSetting
{
    public override DataTemplate GetDataTemplate()
    {
        var myResourceDictionary = new ResourceDictionary()
        {
            Source = new Uri("/PassListviewDataCommand;component/Control/Dictionary1.xaml", UriKind.RelativeOrAbsolute)
        };
        return myResourceDictionary["passValueItemsEditor"] as DataTemplate;
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

BuiltinEditorSetting 类
BuiltinEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
BuiltinEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : BuiltinEditorSetting 类

所有这类成员的列表, 请看 BuiltinEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
Public 属性 | TemplateName | 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
DefaultCaptionVisibility 属性 (BuiltinEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > BuiltinEditorSetting 类 : DefaultCaptionVisibility 属性
属性编辑器分类的标题是否显示。
语法
  • C#
public virtual Visibility DefaultCaptionVisibility {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

BuiltinEditorSetting 类
BuiltinEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Orientation 属性
GrapeCity.Forguncy.Plugin 命名空间 > BuiltinEditorSetting 类 : Orientation 属性
命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。
语法
  • C#
public virtual Orientation Orientation {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

BuiltinEditorSetting 类
BuiltinEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (BuiltinEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > BuiltinEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public virtual string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

BuiltinEditorSetting 类
BuiltinEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
CheckBoxEidtorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : CheckBoxEidtorSetting 类
是/否类型的属性对应的编辑器，如[只读]属性。
语法
  • C#
public class CheckBoxEidtorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.CheckBoxEidtorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CheckBoxEidtorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
CheckBoxEidtorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : CheckBoxEidtorSetting 类

以下表中列出了CheckBoxEidtorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | CheckBoxEidtorSetting 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 重写. 属性编辑器分类的标题是否显示。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
CheckBoxEidtorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > CheckBoxEidtorSetting 类 : CheckBoxEidtorSetting 构造函数
构造函数。
语法
  • C#
public CheckBoxEidtorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CheckBoxEidtorSetting 类
CheckBoxEidtorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
CheckBoxEidtorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : CheckBoxEidtorSetting 类

所有这类成员的列表, 请看 CheckBoxEidtorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 重写. 属性编辑器分类的标题是否显示。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
DefaultCaptionVisibility 属性 (CheckBoxEidtorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > CheckBoxEidtorSetting 类 : DefaultCaptionVisibility 属性
属性编辑器分类的标题是否显示。
语法
  • C#
public override Visibility DefaultCaptionVisibility {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CheckBoxEidtorSetting 类
CheckBoxEidtorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (CheckBoxEidtorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > CheckBoxEidtorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

CheckBoxEidtorSetting 类
CheckBoxEidtorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ComboEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : ComboEditorSetting 类
组合框。如菜单中使用的[主题]属性。
语法
  • C#
public class ComboEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.EnumValueEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ComboEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ComboEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : ComboEditorSetting 类

以下表中列出了ComboEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | ComboEditorSetting 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | DisplayMember | 下拉项目文本属性。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | Source | 下拉项目集合。
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | ValueMember | 下拉项目值属性。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ComboEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > ComboEditorSetting 类 : ComboEditorSetting 构造函数
下拉项目集合。
下拉项目文本属性。
下拉项目值属性。
构造函数。
语法
  • C#
public ComboEditorSetting(
   object source,
   string displayMember,
   string valueMember
)

参数

source
下拉项目集合。
displayMember
下拉项目文本属性。
valueMember
下拉项目值属性。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ComboEditorSetting 类
ComboEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ComboEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : ComboEditorSetting 类

所有这类成员的列表, 请看 ComboEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | DisplayMember | 下拉项目文本属性。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | Source | 下拉项目集合。
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | ValueMember | 下拉项目值属性。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
DisplayMember 属性
GrapeCity.Forguncy.Plugin 命名空间 > ComboEditorSetting 类 : DisplayMember 属性
下拉项目文本属性。
语法
  • C#
public string DisplayMember {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ComboEditorSetting 类
ComboEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Source 属性
GrapeCity.Forguncy.Plugin 命名空间 > ComboEditorSetting 类 : Source 属性
下拉项目集合。
语法
  • C#
public object Source {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ComboEditorSetting 类
ComboEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (ComboEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > ComboEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ComboEditorSetting 类
ComboEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ValueMember 属性
GrapeCity.Forguncy.Plugin 命名空间 > ComboEditorSetting 类 : ValueMember 属性
下拉项目值属性。
语法
  • C#
public string ValueMember {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ComboEditorSetting 类
ComboEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
DoubleEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : DoubleEditorSetting 类
小数类型的属性对应的编辑器，如地图插件使用的[经度]或[纬度]属性。
语法
  • C#
public class DoubleEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.DoubleEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

DoubleEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
DoubleEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : DoubleEditorSetting 类

以下表中列出了DoubleEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | DoubleEditorSetting 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
DoubleEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > DoubleEditorSetting 类 : DoubleEditorSetting 构造函数
语法
  • C#
public DoubleEditorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

DoubleEditorSetting 类
DoubleEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
DoubleEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : DoubleEditorSetting 类

所有这类成员的列表, 请看 DoubleEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (DoubleEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > DoubleEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

DoubleEditorSetting 类
DoubleEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
EditorSetting 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : EditorSetting 类
插件内部属性对应的编辑器设置。
语法
  • C#
public abstract class EditorSetting
示例
  • C#
public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
{
    return new ComboEditorSetting(new List<string>()  { "aaa", "bbb", "ccc"});
}
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
EditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : EditorSetting 类

以下表中列出了EditorSetting的公开成员.

公共 属性
 | 名称 | 说明
Public 属性 | IsEnabled | 属性编辑器是否可用。
Public 属性 | Visibility | 属性编辑器是否可见。
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。
页首
请参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
EditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : EditorSetting 类

所有这类成员的列表, 请看 EditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。
页首
请参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetDataTemplate 方法 (EditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > EditorSetting 类 : GetDataTemplate 方法
属性编辑器对应的数据模板。
语法
  • C#
public abstract DataTemplate GetDataTemplate()

返回值

属性编辑器对应的数据模板。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EditorSetting 类
EditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
OnPropertyChanged 方法 (EditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > EditorSetting 类 : OnPropertyChanged 方法
属性名。
内部使用。
语法
  • C#
protected virtual void OnPropertyChanged(
   string propertyName
)

参数

propertyName
属性名。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EditorSetting 类
EditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
EditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : EditorSetting 类

所有这类成员的列表, 请看 EditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | IsEnabled | 属性编辑器是否可用。
Public 属性 | Visibility | 属性编辑器是否可见。
页首
请参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
IsEnabled 属性 (EditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > EditorSetting 类 : IsEnabled 属性
属性编辑器是否可用。
语法
  • C#
public bool IsEnabled {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EditorSetting 类
EditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Visibility 属性
GrapeCity.Forguncy.Plugin 命名空间 > EditorSetting 类 : Visibility 属性
属性编辑器是否可见。
语法
  • C#
public Visibility Visibility {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EditorSetting 类
EditorSetting 成员


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
EditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : EditorSetting 类

所有这类成员的列表, 请看 EditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。
页首
请参见

引用

EditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
PropertyChanged 事件 (EditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > EditorSetting 类 : PropertyChanged 事件
内部使用。
语法
  • C#
public event PropertyChangedEventHandler PropertyChanged
事件数据

The event handler receives an argument of type PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

属性 | 说明
PropertyName |
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EditorSetting 类
EditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
EnumValueEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : EnumValueEditorSetting 类
枚举类型编辑器。如菜单中使用的[主题]属性。
语法
  • C#
public class EnumValueEditorSetting : ComboEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.EnumValueEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EnumValueEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
EnumValueEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : EnumValueEditorSetting 类

以下表中列出了EnumValueEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | EnumValueEditorSetting 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | DisplayMember | 下拉项目文本属性。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | Source | 下拉项目集合。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | TemplateName | 内置的数据模板名称。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | ValueMember | 下拉项目值属性。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

EnumValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
EnumValueEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > EnumValueEditorSetting 类 : EnumValueEditorSetting 构造函数
枚举类型。
构造函数。
语法
  • C#
public EnumValueEditorSetting(
   Type enumType
)

参数

enumType
枚举类型。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

EnumValueEditorSetting 类
EnumValueEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FileCopyInfo 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : FileCopyInfo 类
在导入活字格页面过程中，需要复制的文件信息。
语法
  • C#
public class FileCopyInfo
继承层次

System.Object
GrapeCity.Forguncy.Plugin.FileCopyInfo

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileCopyInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
FileCopyInfo 类 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : FileCopyInfo 类

以下表中列出了FileCopyInfo的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | FileCopyInfo 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | SourceFileFolder | 原文件所在文件夹路径。
Public 属性 | SourceFileName | 原文件名。
Public 属性 | TargetFileFolder | 目标文件所在文件夹路径。
Public 属性 | TargetFileName | 目标文件名。
页首
请参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FileCopyInfo 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > FileCopyInfo 类 : FileCopyInfo 构造函数
语法
  • C#
public FileCopyInfo()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileCopyInfo 类
FileCopyInfo 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
FileCopyInfo 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : FileCopyInfo 类

所有这类成员的列表, 请看 FileCopyInfo 成员.

公共 属性
 | 名称 | 说明
Public 属性 | SourceFileFolder | 原文件所在文件夹路径。
Public 属性 | SourceFileName | 原文件名。
Public 属性 | TargetFileFolder | 目标文件所在文件夹路径。
Public 属性 | TargetFileName | 目标文件名。
页首
请参见

引用

FileCopyInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
SourceFileFolder 属性
GrapeCity.Forguncy.Plugin 命名空间 > FileCopyInfo 类 : SourceFileFolder 属性
原文件所在文件夹路径。
语法
  • C#
public string SourceFileFolder {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileCopyInfo 类
FileCopyInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
SourceFileName 属性
GrapeCity.Forguncy.Plugin 命名空间 > FileCopyInfo 类 : SourceFileName 属性
原文件名。
语法
  • C#
public string SourceFileName {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileCopyInfo 类
FileCopyInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TargetFileFolder 属性
GrapeCity.Forguncy.Plugin 命名空间 > FileCopyInfo 类 : TargetFileFolder 属性
目标文件所在文件夹路径。
语法
  • C#
public string TargetFileFolder {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileCopyInfo 类
FileCopyInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TargetFileName 属性
GrapeCity.Forguncy.Plugin 命名空间 > FileCopyInfo 类 : TargetFileName 属性
目标文件名。
语法
  • C#
public string TargetFileName {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileCopyInfo 类
FileCopyInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FileUploadInfo 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : FileUploadInfo 类
上传文件的信息，用于保存。
语法
  • C#
public class FileUploadInfo
继承层次

System.Object
GrapeCity.Forguncy.Plugin.FileUploadInfo

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileUploadInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
FileUploadInfo 类 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : FileUploadInfo 类

以下表中列出了FileUploadInfo的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | FileUploadInfo 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | AllUsedUploadFilePaths | 所有上传文件的名称列表。
Public 属性 | UploadFileFolder | 上传文件所在的文件夹路径。
页首
请参见

引用

FileUploadInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FileUploadInfo 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > FileUploadInfo 类 : FileUploadInfo 构造函数
构造函数。
语法
  • C#
public FileUploadInfo()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileUploadInfo 类
FileUploadInfo 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
FileUploadInfo 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : FileUploadInfo 类

所有这类成员的列表, 请看 FileUploadInfo 成员.

公共 属性
 | 名称 | 说明
Public 属性 | AllUsedUploadFilePaths | 所有上传文件的名称列表。
Public 属性 | UploadFileFolder | 上传文件所在的文件夹路径。
页首
请参见

引用

FileUploadInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
AllUsedUploadFilePaths 属性
GrapeCity.Forguncy.Plugin 命名空间 > FileUploadInfo 类 : AllUsedUploadFilePaths 属性
所有上传文件的名称列表。
语法
  • C#
public List<string> AllUsedUploadFilePaths {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileUploadInfo 类
FileUploadInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
UploadFileFolder 属性
GrapeCity.Forguncy.Plugin 命名空间 > FileUploadInfo 类 : UploadFileFolder 属性
上传文件所在的文件夹路径。
语法
  • C#
public string UploadFileFolder {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FileUploadInfo 类
FileUploadInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ForguncyErrorInfo 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : ForguncyErrorInfo 类
运行页面时，内部检查出的错误或者提醒信息。
语法
  • C#
public class ForguncyErrorInfo
示例
  • C#
public class SetFocusCommand : Command, ICommandChecker
{
    [FormulaProperty]
    public object TargetCell { get; set; }

    public IEnumerable<ForguncyErrorInfo> CheckCommandErrors(IBuilderCommandContext context)
    {
        if(TargetCell == null)
        {
            yield return new ForguncyErrorInfo()
           {
               Message = "Target cell cannot be null.",
               ErrorType = ForguncyErrorType.Error
           };
        }
    }
}
继承层次

System.Object
GrapeCity.Forguncy.Plugin.ForguncyErrorInfo

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ForguncyErrorInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ForguncyErrorInfo 类 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : ForguncyErrorInfo 类

以下表中列出了ForguncyErrorInfo的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | ForguncyErrorInfo 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | ErrorType | 错误类型：错误或者提醒。
Public 属性 | Message | 错误信息。
页首
请参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ForguncyErrorInfo 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > ForguncyErrorInfo 类 : ForguncyErrorInfo 构造函数
语法
  • C#
public ForguncyErrorInfo()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ForguncyErrorInfo 类
ForguncyErrorInfo 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ForguncyErrorInfo 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : ForguncyErrorInfo 类

所有这类成员的列表, 请看 ForguncyErrorInfo 成员.

公共 属性
 | 名称 | 说明
Public 属性 | ErrorType | 错误类型：错误或者提醒。
Public 属性 | Message | 错误信息。
页首
请参见

引用

ForguncyErrorInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ErrorType 属性
GrapeCity.Forguncy.Plugin 命名空间 > ForguncyErrorInfo 类 : ErrorType 属性
错误类型：错误或者提醒。
语法
  • C#
public ForguncyErrorType ErrorType {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ForguncyErrorInfo 类
ForguncyErrorInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Message 属性
GrapeCity.Forguncy.Plugin 命名空间 > ForguncyErrorInfo 类 : Message 属性
错误信息。
语法
  • C#
public string Message {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ForguncyErrorInfo 类
ForguncyErrorInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FormulaPropertyAttribute 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : FormulaPropertyAttribute 类

指定插件内部属性对应的编辑器为公式选择框。

注意：使用公式选择框作为属性值编辑器的属性，其值类型必须是object。

语法
  • C#
public class FormulaPropertyAttribute : System.Attribute
示例
  • C#
public class SetFocusCommand : Command
{
    [FormulaProperty(true)]
    public object TargetCell { get; set; }
}
继承层次

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.FormulaPropertyAttribute

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaPropertyAttribute 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
FormulaPropertyAttribute 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : FormulaPropertyAttribute 类

以下表中列出了FormulaPropertyAttribute的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | FormulaPropertyAttribute 构造函数 | 重载.
页首
公共 属性
 | 名称 | 说明
Public 属性 | OnlySupportCell | 公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
Public 属性 | TypeId | (从System.Attribute继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FormulaPropertyAttribute 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > FormulaPropertyAttribute 类 : FormulaPropertyAttribute 构造函数
重载列表
重载 | 说明
FormulaPropertyAttribute 构造函数() | 默认构造函数。
FormulaPropertyAttribute 构造函数(Boolean) | 构造函数，指定其公式选择框是否只能选择单元格而不支持选择单元格区域或者函数。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaPropertyAttribute 类
FormulaPropertyAttribute 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FormulaPropertyAttribute 构造函数()
GrapeCity.Forguncy.Plugin 命名空间 > FormulaPropertyAttribute 类 > FormulaPropertyAttribute 构造函数 : FormulaPropertyAttribute 构造函数()
默认构造函数。
语法
  • C#
public FormulaPropertyAttribute()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaPropertyAttribute 类
FormulaPropertyAttribute 成员
重载列表


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FormulaPropertyAttribute 构造函数(Boolean)
GrapeCity.Forguncy.Plugin 命名空间 > FormulaPropertyAttribute 类 > FormulaPropertyAttribute 构造函数 : FormulaPropertyAttribute 构造函数(Boolean)
是否只支持单元格。
构造函数，指定其公式选择框是否只能选择单元格而不支持选择单元格区域或者函数。
语法
  • C#
public FormulaPropertyAttribute(
   bool onlySupportCell
)

参数

onlySupportCell
是否只支持单元格。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaPropertyAttribute 类
FormulaPropertyAttribute 成员
重载列表


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
FormulaPropertyAttribute 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : FormulaPropertyAttribute 类

所有这类成员的列表, 请看 FormulaPropertyAttribute 成员.

公共 属性
 | 名称 | 说明
Public 属性 | OnlySupportCell | 公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
Public 属性 | TypeId | (从System.Attribute继承)
页首
请参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
OnlySupportCell 属性 (FormulaPropertyAttribute)
GrapeCity.Forguncy.Plugin 命名空间 > FormulaPropertyAttribute 类 : OnlySupportCell 属性
公式选择框只能选择单元格，如=A1，不能选择单元格区域或函数等。
语法
  • C#
public bool OnlySupportCell {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaPropertyAttribute 类
FormulaPropertyAttribute 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FormulaSelectorEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : FormulaSelectorEditorSetting 类
公式类型的属性对应的编辑器，如[缺省值]属性。
语法
  • C#
public class FormulaSelectorEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.FormulaSelectorEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaSelectorEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
FormulaSelectorEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : FormulaSelectorEditorSetting 类

以下表中列出了FormulaSelectorEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | FormulaSelectorEditorSetting 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | OnlySupportCell | 是否只能选择单元格，不支持单元格区域或者函数。
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | ShowSheetName | 显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
FormulaSelectorEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > FormulaSelectorEditorSetting 类 : FormulaSelectorEditorSetting 构造函数
是否只能选择单元格。
构造函数。
语法
  • C#
public FormulaSelectorEditorSetting(
   bool onlySupportCell
)

参数

onlySupportCell
是否只能选择单元格。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaSelectorEditorSetting 类
FormulaSelectorEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
FormulaSelectorEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : FormulaSelectorEditorSetting 类

所有这类成员的列表, 请看 FormulaSelectorEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | OnlySupportCell | 是否只能选择单元格，不支持单元格区域或者函数。
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | ShowSheetName | 显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
OnlySupportCell 属性 (FormulaSelectorEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > FormulaSelectorEditorSetting 类 : OnlySupportCell 属性
是否只能选择单元格，不支持单元格区域或者函数。
语法
  • C#
public bool OnlySupportCell {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaSelectorEditorSetting 类
FormulaSelectorEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ShowSheetName 属性
GrapeCity.Forguncy.Plugin 命名空间 > FormulaSelectorEditorSetting 类 : ShowSheetName 属性
显示公式对象所在的页面名称如=Page1!A1或者不显示页面名称如=A1。
语法
  • C#
public bool ShowSheetName {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaSelectorEditorSetting 类
FormulaSelectorEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (FormulaSelectorEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > FormulaSelectorEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

FormulaSelectorEditorSetting 类
FormulaSelectorEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
HyperlinkEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : HyperlinkEditorSetting 类
超链接编辑器，如果一个属性比较复杂，需要单独提供一个对话框去设置属性内部的值的时候会用到这个编辑器，如[编辑菜单项目...]属性。
语法
  • C#
public class HyperlinkEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.HyperlinkEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

HyperlinkEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
HyperlinkEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : HyperlinkEditorSetting 类

以下表中列出了HyperlinkEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | HyperlinkEditorSetting 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | Command | 点击超链接要执行的命令。
Public 属性 | DefaultCaptionVisibility | 重写. 属性编辑器分类的标题是否显示。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
HyperlinkEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > HyperlinkEditorSetting 类 : HyperlinkEditorSetting 构造函数
点击超链接要执行的命令。
构造函数。
语法
  • C#
public HyperlinkEditorSetting(
   ICommand command
)

参数

command
点击超链接要执行的命令。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

HyperlinkEditorSetting 类
HyperlinkEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
HyperlinkEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : HyperlinkEditorSetting 类

所有这类成员的列表, 请看 HyperlinkEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | Command | 点击超链接要执行的命令。
Public 属性 | DefaultCaptionVisibility | 重写. 属性编辑器分类的标题是否显示。
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Command 属性 (HyperlinkEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > HyperlinkEditorSetting 类 : Command 属性
点击超链接要执行的命令。
语法
  • C#
public ICommand Command {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

HyperlinkEditorSetting 类
HyperlinkEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
DefaultCaptionVisibility 属性 (HyperlinkEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > HyperlinkEditorSetting 类 : DefaultCaptionVisibility 属性
属性编辑器分类的标题是否显示。
语法
  • C#
public override Visibility DefaultCaptionVisibility {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

HyperlinkEditorSetting 类
HyperlinkEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (HyperlinkEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > HyperlinkEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

HyperlinkEditorSetting 类
HyperlinkEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IconAttribute 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : IconAttribute 类

设置插件的图标。

该图标会应用到单元格类型下拉列表或命令选择下拉列表中，如果开启了单元格类型的显示模式，该图标也会应用到使用了该单元格类型的单元格上。

语法
  • C#
public class IconAttribute : System.Attribute
示例
  • C#
[Icon("pack://application:,,,/SignatureCellType;component/Resources/icon.png")]  //指定签名单元格类型的图标
public class SignatureCellType : CellType //自定义了签名单元格类型
{
    ...
}
继承层次

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.IconAttribute

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IconAttribute 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IconAttribute 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : IconAttribute 类

以下表中列出了IconAttribute的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | IconAttribute 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | Image | 图标Uri，内部使用。
Public 属性 | TypeId | (从System.Attribute继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
static (Shared in Visual Basic) | GetImage | 基于插件类型返回图标Uri，内部使用。
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

IconAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IconAttribute 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > IconAttribute 类 : IconAttribute 构造函数
图标的路径。
构造函数。
语法
  • C#
public IconAttribute(
   string uri
)

参数

uri
图标的路径。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IconAttribute 类
IconAttribute 成员


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IconAttribute 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : IconAttribute 类

所有这类成员的列表, 请看 IconAttribute 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
static (Shared in Visual Basic) | GetImage | 基于插件类型返回图标Uri，内部使用。
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

IconAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetImage 方法
GrapeCity.Forguncy.Plugin 命名空间 > IconAttribute 类 : GetImage 方法
插件类型。
基于插件类型返回图标Uri，内部使用。
语法
  • C#
public static Uri GetImage(
   Type type
)

参数

type
插件类型。

返回值

图标Uri。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IconAttribute 类
IconAttribute 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IconAttribute 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : IconAttribute 类

所有这类成员的列表, 请看 IconAttribute 成员.

公共 属性
 | 名称 | 说明
Public 属性 | Image | 图标Uri，内部使用。
Public 属性 | TypeId | (从System.Attribute继承)
页首
请参见

引用

IconAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Image 属性
GrapeCity.Forguncy.Plugin 命名空间 > IconAttribute 类 : Image 属性
图标Uri，内部使用。
语法
  • C#
public Uri Image {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IconAttribute 类
IconAttribute 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ImageEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : ImageEditorSetting 类
图片编辑器。如图片类型使用的[选择图片...]属性。
语法
  • C#
public class ImageEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.ImageEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ImageEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : ImageEditorSetting 类

以下表中列出了ImageEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | ImageEditorSetting 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ImageEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > ImageEditorSetting 类 : ImageEditorSetting 构造函数
语法
  • C#
public ImageEditorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageEditorSetting 类
ImageEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ImageEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : ImageEditorSetting 类

所有这类成员的列表, 请看 ImageEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (ImageEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > ImageEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageEditorSetting 类
ImageEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ImageValue 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : ImageValue 类
一种活字格自定义的属性类型。具有该类型的插件内部属性，其对应的编辑器可打开活字格默认的图片选择对话框。
语法
  • C#
public class ImageValue
示例
  • C#
public class MyImageCellType : CellType
{
    public ImageValue ImageInfo { get; set; }
}
继承层次

System.Object
GrapeCity.Forguncy.Plugin.ImageValue

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageValue 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ImageValue 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : ImageValue 类

以下表中列出了ImageValue的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | ImageValue 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | BuiltIn | 是否是内置图片。
Public 属性 | Name | 图片名。
页首
公共 方法
 | 名称 | 说明
Public 方法 | Clone | 克隆方法，内部使用。
页首
请参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ImageValue 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > ImageValue 类 : ImageValue 构造函数
语法
  • C#
public ImageValue()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageValue 类
ImageValue 成员


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
ImageValue 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : ImageValue 类

所有这类成员的列表, 请看 ImageValue 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Clone | 克隆方法，内部使用。
页首
请参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Clone 方法 (ImageValue)
GrapeCity.Forguncy.Plugin 命名空间 > ImageValue 类 : Clone 方法
克隆方法，内部使用。
语法
  • C#
public ImageValue Clone()

返回值

图片信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageValue 类
ImageValue 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ImageValue 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : ImageValue 类

所有这类成员的列表, 请看 ImageValue 成员.

公共 属性
 | 名称 | 说明
Public 属性 | BuiltIn | 是否是内置图片。
Public 属性 | Name | 图片名。
页首
请参见

引用

ImageValue 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
BuiltIn 属性 (ImageValue)
GrapeCity.Forguncy.Plugin 命名空间 > ImageValue 类 : BuiltIn 属性
是否是内置图片。
语法
  • C#
[DefaultValue()]
public bool BuiltIn {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageValue 类
ImageValue 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Name 属性 (ImageValue)
GrapeCity.Forguncy.Plugin 命名空间 > ImageValue 类 : Name 属性
图片名。
语法
  • C#
[DefaultValue()]
public string Name {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ImageValue 类
ImageValue 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IntEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : IntEditorSetting 类
整数类型的属性对应的编辑器，如单选按钮使用的[项目间距]属性。
语法
  • C#
public class IntEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.IntEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IntEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IntEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : IntEditorSetting 类

以下表中列出了IntEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | IntEditorSetting 构造函数 | 重载.
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Max | 整数类型的属性编辑器的最大值。
Public 属性 | Min | 整数类型的属性编辑器的最小值。
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IntEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > IntEditorSetting 类 : IntEditorSetting 构造函数
重载列表
重载 | 说明
IntEditorSetting 构造函数() | 构造函数。
IntEditorSetting 构造函数(Int32,Int32) | 构造函数，指定了最小值和最大值的整数类型的编辑器。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IntEditorSetting 类
IntEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IntEditorSetting 构造函数()
GrapeCity.Forguncy.Plugin 命名空间 > IntEditorSetting 类 > IntEditorSetting 构造函数 : IntEditorSetting 构造函数()
构造函数。
语法
  • C#
public IntEditorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IntEditorSetting 类
IntEditorSetting 成员
重载列表


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IntEditorSetting 构造函数(Int32,Int32)
GrapeCity.Forguncy.Plugin 命名空间 > IntEditorSetting 类 > IntEditorSetting 构造函数 : IntEditorSetting 构造函数(Int32,Int32)
构造函数，指定了最小值和最大值的整数类型的编辑器。
语法
  • C#
public IntEditorSetting(
   int min,
   int max
)

参数

min
max
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IntEditorSetting 类
IntEditorSetting 成员
重载列表


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IntEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : IntEditorSetting 类

所有这类成员的列表, 请看 IntEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Max | 整数类型的属性编辑器的最大值。
Public 属性 | Min | 整数类型的属性编辑器的最小值。
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Max 属性
GrapeCity.Forguncy.Plugin 命名空间 > IntEditorSetting 类 : Max 属性
整数类型的属性编辑器的最大值。
语法
  • C#
public int Max {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IntEditorSetting 类
IntEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Min 属性
GrapeCity.Forguncy.Plugin 命名空间 > IntEditorSetting 类 : Min 属性
整数类型的属性编辑器的最小值。
语法
  • C#
public int Min {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IntEditorSetting 类
IntEditorSetting 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (IntEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > IntEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IntEditorSetting 类
IntEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
LocatedObject 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : LocatedObject 类
带坐标定位器的对象。
对象模型
LocatedObject 类LocationIndicator 类
语法
  • C#
public class LocatedObject
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocatedObject
GrapeCity.Forguncy.Plugin.LocatedObject<T>

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocatedObject 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
LocatedObject 类 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : LocatedObject 类

以下表中列出了LocatedObject的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | LocatedObject 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | Location | 坐标定位器。
Public 属性 | Object | 有坐标定位器的对象。
页首
请参见

引用

LocatedObject 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
LocatedObject 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > LocatedObject 类 : LocatedObject 构造函数
对象。
坐标定位器。
构造函数。
语法
  • C#
public LocatedObject(
   object obj,
   LocationIndicator location
)

参数

obj
对象。
location
坐标定位器。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocatedObject 类
LocatedObject 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
LocatedObject 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : LocatedObject 类

所有这类成员的列表, 请看 LocatedObject 成员.

公共 属性
 | 名称 | 说明
Public 属性 | Location | 坐标定位器。
Public 属性 | Object | 有坐标定位器的对象。
页首
请参见

引用

LocatedObject 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Location 属性
GrapeCity.Forguncy.Plugin 命名空间 > LocatedObject 类 : Location 属性
坐标定位器。
语法
  • C#
public LocationIndicator Location {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocatedObject 类
LocatedObject 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Object 属性 (LocatedObject)
GrapeCity.Forguncy.Plugin 命名空间 > LocatedObject 类 : Object 属性
有坐标定位器的对象。
语法
  • C#
public object Object {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocatedObject 类
LocatedObject 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
LocatedObject<T> 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : LocatedObject<T> 类
特定类型。
带坐标定位器的特定类型的对象，如页面，命名等。
对象模型
LocatedObject<T> 类LocationIndicator 类
语法
  • C#
public class LocatedObject<T> : LocatedObject
类型参数
T
特定类型。
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocatedObject
GrapeCity.Forguncy.Plugin.LocatedObject<T>

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocatedObject<T> 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
LocatedObject<T> 类 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : LocatedObject<T> 类

以下表中列出了LocatedObject<T>的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | LocatedObject<T> 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | Location | 坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocatedObject继承)
Public 属性 | Object | 特定类型的对象。
页首
请参见

引用

LocatedObject<T> 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
LocatedObject<T> 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : LocatedObject<T> 类

所有这类成员的列表, 请看 LocatedObject<T> 成员.

公共 属性
 | 名称 | 说明
Public 属性 | Location | 坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocatedObject继承)
Public 属性 | Object | 特定类型的对象。
页首
请参见

引用

LocatedObject<T> 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
LocationIndicator 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : LocationIndicator 类
坐标定位器，查找引用时基于它可以帮助用户快速找到相关对象的位置。
对象模型
LocationIndicator 类LocationIndicator 类
语法
  • C#
public abstract class LocationIndicator
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicator 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
LocationIndicator 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : LocationIndicator 类

以下表中列出了LocationIndicator的公开成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
Public 属性 | Root | 根坐标定位器。
页首
公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
LocationIndicator 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : LocationIndicator 类

所有这类成员的列表, 请看 LocationIndicator 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Append 方法
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicator 类 : Append 方法
要拼接的坐标定位器。
拼接一个坐标定位器。
语法
  • C#
public LocationIndicator Append(
   LocationIndicator location
)

参数

location
要拼接的坐标定位器。

返回值

返回拼接后的坐标定位器。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicator 类
LocationIndicator 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Enum 方法
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicator 类 : Enum 方法
遍历当前坐标定位器以及该链表中所有的父坐标定位器。
语法
  • C#
[IteratorStateMachine(GrapeCity.Forguncy.Plugin.LocationIndicator+d__8)]
public IEnumerable<LocationIndicator> Enum()

返回值

返回包括父坐标定位器在内的链表中的坐标定位器。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicator 类
LocationIndicator 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetPathString 方法
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicator 类 : GetPathString 方法
拼接符
过滤方法
基于拼接符和过滤方法返回坐标定位器的查找路径。
语法
  • C#
public string GetPathString(
   string seperator,
   Func<LocationIndicator,bool> filter
)

参数

seperator
拼接符
filter
过滤方法

返回值

返回查找路径。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicator 类
LocationIndicator 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
LocationIndicator 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : LocationIndicator 类

所有这类成员的列表, 请看 LocationIndicator 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
Public 属性 | Root | 根坐标定位器。
页首
请参见

引用

LocationIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
DisplayString 属性 (LocationIndicator)
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicator 类 : DisplayString 属性
当前坐标定位器的显示文字。
语法
  • C#
public abstract string DisplayString {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicator 类
LocationIndicator 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
FullString 属性
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicator 类 : FullString 属性
返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。
语法
  • C#
public string FullString {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicator 类
LocationIndicator 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Root 属性
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicator 类 : Root 属性
根坐标定位器。
语法
  • C#
public LocationIndicator Root {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicator 类
LocationIndicator 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
LocationIndicatorExtension 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : LocationIndicatorExtension 类
坐标定位器扩展类。
语法
  • C#
[Extension()]
public static class LocationIndicatorExtension
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicatorExtension

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicatorExtension 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
LocationIndicatorExtension 类 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : LocationIndicatorExtension 类

以下表中列出了LocationIndicatorExtension的公开成员.

公共 方法
 | 名称 | 说明
static (Shared in Visual Basic) | AppendProperty | 增加一个属性定位器。
static (Shared in Visual Basic) | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
static (Shared in Visual Basic) | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

LocationIndicatorExtension 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
LocationIndicatorExtension 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : LocationIndicatorExtension 类

所有这类成员的列表, 请看 LocationIndicatorExtension 成员.

公共 方法
 | 名称 | 说明
static (Shared in Visual Basic) | AppendProperty | 增加一个属性定位器。
static (Shared in Visual Basic) | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
static (Shared in Visual Basic) | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

LocationIndicatorExtension 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
AppendProperty 方法
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicatorExtension 类 : AppendProperty 方法
当前坐标定位器。
要增加的属性定位器的名称。
增加一个属性定位器。
语法
  • C#
[Extension()]
public static LocationIndicator AppendProperty(
   LocationIndicator current,
   string propertyName
)

参数

current
当前坐标定位器。
propertyName
要增加的属性定位器的名称。

返回值

返回增加了属性定位器的坐标定位器。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicatorExtension 类
LocationIndicatorExtension 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ContainObject 方法
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicatorExtension 类 : ContainObject 方法
当前坐标定位器。
查找的对象。
坐标定位器所在链表中的对象定位器中是否包含特定的对象。
语法
  • C#
[Extension()]
public static bool ContainObject(
   LocationIndicator current,
   object obj
)

参数

current
当前坐标定位器。
obj
查找的对象。

返回值

返回true则包含，否则不包含。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicatorExtension 类
LocationIndicatorExtension 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ContainProperty 方法
GrapeCity.Forguncy.Plugin 命名空间 > LocationIndicatorExtension 类 : ContainProperty 方法
当前坐标定位器。
查找的属性名称。
坐标定位器所在链表中的属性定位器中是否包含特定的属性。
语法
  • C#
[Extension()]
public static bool ContainProperty(
   LocationIndicator current,
   string property
)

参数

current
当前坐标定位器。
property
查找的属性名称。

返回值

返回true则包含，否则不包含。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

LocationIndicatorExtension 类
LocationIndicatorExtension 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
NameIndicator 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : NameIndicator 类
名称定位器，一种特定类型的坐标定位器。
对象模型
NameIndicator 类LocationIndicator 类
语法
  • C#
public class NameIndicator : LocationIndicator
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.PropertyIndicator

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

NameIndicator 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
NameIndicator 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : NameIndicator 类

以下表中列出了NameIndicator的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | NameIndicator 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 重写. 当前坐标定位器的显示文字。
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Name | 当前坐标定位器的名称。
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
NameIndicator 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > NameIndicator 类 : NameIndicator 构造函数
语法
  • C#
public NameIndicator()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

NameIndicator 类
NameIndicator 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
NameIndicator 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : NameIndicator 类

所有这类成员的列表, 请看 NameIndicator 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 重写. 当前坐标定位器的显示文字。
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Name | 当前坐标定位器的名称。
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
请参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
DisplayString 属性 (NameIndicator)
GrapeCity.Forguncy.Plugin 命名空间 > NameIndicator 类 : DisplayString 属性
当前坐标定位器的显示文字。
语法
  • C#
public override string DisplayString {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

NameIndicator 类
NameIndicator 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Name 属性 (NameIndicator)
GrapeCity.Forguncy.Plugin 命名空间 > NameIndicator 类 : Name 属性
当前坐标定位器的名称。
语法
  • C#
public string Name {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

NameIndicator 类
NameIndicator 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ObjectIndicator 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator 类
对象定位器，一种特定类型的坐标定位器。
对象模型
ObjectIndicator 类LocationIndicator 类
语法
  • C#
public abstract class ObjectIndicator : LocationIndicator
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator<T>

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ObjectIndicator 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ObjectIndicator 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator 类

以下表中列出了ObjectIndicator的公开成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Object | 对象定位器中的对象。
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

ObjectIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ObjectIndicator 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator 类

所有这类成员的列表, 请看 ObjectIndicator 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Object | 对象定位器中的对象。
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
请参见

引用

ObjectIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Object 属性 (ObjectIndicator)
GrapeCity.Forguncy.Plugin 命名空间 > ObjectIndicator 类 : Object 属性
对象定位器中的对象。
语法
  • C#
public object Object {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ObjectIndicator 类
ObjectIndicator 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ObjectIndicator<T> 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator<T> 类
特定类型。
特定类型的对象定位器。
对象模型
ObjectIndicator<T> 类LocationIndicator 类
语法
  • C#
public abstract class ObjectIndicator<T> : ObjectIndicator
类型参数
T
特定类型。
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator<T>

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ObjectIndicator<T> 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ObjectIndicator<T> 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator<T> 类

以下表中列出了ObjectIndicator<T>的公开成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Object | 特定类型的对象。
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

ObjectIndicator<T> 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ObjectIndicator<T> 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator<T> 类

所有这类成员的列表, 请看 ObjectIndicator<T> 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Object | 特定类型的对象。
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
请参见

引用

ObjectIndicator<T> 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
OrderWeightAttribute 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : OrderWeightAttribute 类
插件或插件内部属性的权重, 权重越大位置越靠后。
语法
  • C#
public class OrderWeightAttribute : System.Attribute
示例
  • C#
public class SignatureCellType : CellType
{
    [OrderWeight(0)]
    public double DotSize
    {
        get;
        set;
    }

    [OrderWeight(1)]
    public double LineMinWidth
    {
        get;
        set;
    }

    ...
}
继承层次

System.Object
System.Attribute
GrapeCity.Forguncy.Plugin.OrderWeightAttribute

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

OrderWeightAttribute 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
OrderWeightAttribute 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : OrderWeightAttribute 类

以下表中列出了OrderWeightAttribute的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | OrderWeightAttribute 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | OrderWeight | 权重值，内部使用。
Public 属性 | TypeId | (从System.Attribute继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

OrderWeightAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
OrderWeightAttribute 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > OrderWeightAttribute 类 : OrderWeightAttribute 构造函数
权重值，默认值为0。
构造函数。
语法
  • C#
public OrderWeightAttribute(
   int orderWeight
)

参数

orderWeight
权重值，默认值为0。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

OrderWeightAttribute 类
OrderWeightAttribute 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
OrderWeightAttribute 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : OrderWeightAttribute 类

所有这类成员的列表, 请看 OrderWeightAttribute 成员.

公共 属性
 | 名称 | 说明
Public 属性 | OrderWeight | 权重值，内部使用。
Public 属性 | TypeId | (从System.Attribute继承)
页首
请参见

引用

OrderWeightAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
OrderWeight 属性
GrapeCity.Forguncy.Plugin 命名空间 > OrderWeightAttribute 类 : OrderWeight 属性
权重值，内部使用。
语法
  • C#
public int OrderWeight {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

OrderWeightAttribute 类
OrderWeightAttribute 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
OrientationEidtorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : OrientationEidtorSetting 类
排列方向类型的属性对应的编辑器，如单选按钮使用的[布局]属性。
语法
  • C#
public class OrientationEidtorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.OrientationEidtorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

OrientationEidtorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
OrientationEidtorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : OrientationEidtorSetting 类

以下表中列出了OrientationEidtorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | OrientationEidtorSetting 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
OrientationEidtorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > OrientationEidtorSetting 类 : OrientationEidtorSetting 构造函数
语法
  • C#
public OrientationEidtorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

OrientationEidtorSetting 类
OrientationEidtorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
OrientationEidtorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : OrientationEidtorSetting 类

所有这类成员的列表, 请看 OrientationEidtorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (OrientationEidtorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > OrientationEidtorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

OrientationEidtorSetting 类
OrientationEidtorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
PluginUtilities 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : PluginUtilities 类
插件公用类。
语法
  • C#
public static class PluginUtilities
继承层次

System.Object
GrapeCity.Forguncy.Plugin.PluginUtilities

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PluginUtilities 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
PluginUtilities 类 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : PluginUtilities 类

以下表中列出了PluginUtilities的公开成员.

公共 方法
 | 名称 | 说明
static (Shared in Visual Basic) | CommonClone | 克隆方法，返回一个对象的复制品。
页首
请参见

引用

PluginUtilities 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
PluginUtilities 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : PluginUtilities 类

所有这类成员的列表, 请看 PluginUtilities 成员.

公共 方法
 | 名称 | 说明
static (Shared in Visual Basic) | CommonClone | 克隆方法，返回一个对象的复制品。
页首
请参见

引用

PluginUtilities 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
CommonClone 方法
GrapeCity.Forguncy.Plugin 命名空间 > PluginUtilities 类 : CommonClone 方法
原对象。
克隆方法，返回一个对象的复制品。
语法
  • C#
public static object CommonClone(
   object obj
)

参数

obj
原对象。

返回值

克隆对象。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PluginUtilities 类
PluginUtilities 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
PropertyIndicator 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : PropertyIndicator 类
属性定位器，一种特定类型的坐标定位器。
对象模型
PropertyIndicator 类LocationIndicator 类
语法
  • C#
public class PropertyIndicator : NameIndicator
继承层次

System.Object
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.PropertyIndicator

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PropertyIndicator 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
PropertyIndicator 类 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : PropertyIndicator 类

以下表中列出了PropertyIndicator的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | PropertyIndicator 构造函数 | 构造函数。
页首
公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。 (从GrapeCity.Forguncy.Plugin.NameIndicator继承)
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Name | 当前坐标定位器的名称。 (从GrapeCity.Forguncy.Plugin.NameIndicator继承)
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

PropertyIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
PropertyIndicator 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > PropertyIndicator 类 : PropertyIndicator 构造函数
属性名称。
构造函数。
语法
  • C#
public PropertyIndicator(
   string propertyName
)

参数

propertyName
属性名称。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

PropertyIndicator 类
PropertyIndicator 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TableCheckInfo 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : TableCheckInfo 类
查找数据表的引用时返回的数据表的位置信息。
语法
  • C#
public class TableCheckInfo
示例
  • C#
TableCheckInfo info = new TableCheckInfo("table1");
info.AddColumns("column1");
继承层次

System.Object
GrapeCity.Forguncy.Plugin.TableCheckInfo

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableCheckInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
TableCheckInfo 类 成员
字段 属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : TableCheckInfo 类

以下表中列出了TableCheckInfo的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | TableCheckInfo 构造函数 | 构造函数。
页首
公共 字段
 | 名称 | 说明
static (Shared in Visual Basic) | IndicateStringSeperator | 废弃属性。
页首
公共 属性
 | 名称 | 说明
Public 属性 | ColumnNames | 所有的字段名。
Public 属性 | TableName | 数据表名。
页首
公共 方法
 | 名称 | 说明
Public 方法 | AddColumns | 添加一个或多个字段。
页首
请参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TableCheckInfo 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > TableCheckInfo 类 : TableCheckInfo 构造函数
数据表名。
构造函数。
语法
  • C#
public TableCheckInfo(
   string tableName
)

参数

tableName
数据表名。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableCheckInfo 类
TableCheckInfo 成员


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
TableCheckInfo 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : TableCheckInfo 类

所有这类成员的列表, 请看 TableCheckInfo 成员.

公共 方法
 | 名称 | 说明
Public 方法 | AddColumns | 添加一个或多个字段。
页首
请参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
AddColumns 方法
GrapeCity.Forguncy.Plugin 命名空间 > TableCheckInfo 类 : AddColumns 方法
添加一个或多个字段。
语法
  • C#
public void AddColumns(
   params string[] fields
)

参数

fields
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableCheckInfo 类
TableCheckInfo 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
TableCheckInfo 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : TableCheckInfo 类

所有这类成员的列表, 请看 TableCheckInfo 成员.

公共 属性
 | 名称 | 说明
Public 属性 | ColumnNames | 所有的字段名。
Public 属性 | TableName | 数据表名。
页首
请参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ColumnNames 属性
GrapeCity.Forguncy.Plugin 命名空间 > TableCheckInfo 类 : ColumnNames 属性
所有的字段名。
语法
  • C#
public IList<string> ColumnNames {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableCheckInfo 类
TableCheckInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TableName 属性 (TableCheckInfo)
GrapeCity.Forguncy.Plugin 命名空间 > TableCheckInfo 类 : TableName 属性
数据表名。
语法
  • C#
public string TableName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableCheckInfo 类
TableCheckInfo 成员


%%PageItemTitle%% $$Fields$$

GrapeCity.Forguncy.Plugin
TableCheckInfo 类 字段

GrapeCity.Forguncy.Plugin 命名空间 : TableCheckInfo 类

所有这类成员的列表, 请看 TableCheckInfo 成员.

公共 字段
 | 名称 | 说明
static (Shared in Visual Basic) | IndicateStringSeperator | 废弃属性。
页首
请参见

引用

TableCheckInfo 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
IndicateStringSeperator 字段
GrapeCity.Forguncy.Plugin 命名空间 > TableCheckInfo 类 : IndicateStringSeperator 字段
废弃属性。
语法
  • C#
[Obsolete()]
public static string IndicateStringSeperator
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableCheckInfo 类
TableCheckInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TableComboTreeSelectorEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : TableComboTreeSelectorEditorSetting 类
数据表选择器。如数据导航按钮中使用的[导航表]属性。
语法
  • C#
public class TableComboTreeSelectorEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.TableComboTreeSelectorEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableComboTreeSelectorEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
TableComboTreeSelectorEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : TableComboTreeSelectorEditorSetting 类

以下表中列出了TableComboTreeSelectorEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | TableComboTreeSelectorEditorSetting 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TableComboTreeSelectorEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > TableComboTreeSelectorEditorSetting 类 : TableComboTreeSelectorEditorSetting 构造函数
语法
  • C#
public TableComboTreeSelectorEditorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableComboTreeSelectorEditorSetting 类
TableComboTreeSelectorEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
TableComboTreeSelectorEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : TableComboTreeSelectorEditorSetting 类

所有这类成员的列表, 请看 TableComboTreeSelectorEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (TableComboTreeSelectorEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > TableComboTreeSelectorEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TableComboTreeSelectorEditorSetting 类
TableComboTreeSelectorEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TextEditorSetting 类
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : TextEditorSetting 类
文本类型的属性对应的编辑器，如[水印]属性。
语法
  • C#
public class TextEditorSetting : BuiltinEditorSetting
示例
  • C#
public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
{
    return new TextEditorSetting();
}
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.TextEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TextEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
TextEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : TextEditorSetting 类

以下表中列出了TextEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | TextEditorSetting 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TextEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > TextEditorSetting 类 : TextEditorSetting 构造函数
语法
  • C#
public TextEditorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TextEditorSetting 类
TextEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
TextEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : TextEditorSetting 类

所有这类成员的列表, 请看 TextEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (TextEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > TextEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TextEditorSetting 类
TextEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TimeValueEditorSetting 类
成员
GrapeCity.Forguncy.Plugin 命名空间 : TimeValueEditorSetting 类
时间类型编辑器。如时间单元类型使用的[下拉框开始时间]属性。
语法
  • C#
public class TimeValueEditorSetting : BuiltinEditorSetting
继承层次

System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.TimeValueEditorSetting

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TimeValueEditorSetting 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
TimeValueEditorSetting 类 成员
属性 方法 事件

GrapeCity.Forguncy.Plugin 命名空间 : TimeValueEditorSetting 类

以下表中列出了TimeValueEditorSetting的公开成员.

公共 构造函数
 | 名称 | 说明
Public 构造函数 | TimeValueEditorSetting 构造函数 |
页首
公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TimeValueEditorSetting 构造函数
GrapeCity.Forguncy.Plugin 命名空间 > TimeValueEditorSetting 类 : TimeValueEditorSetting 构造函数
语法
  • C#
public TimeValueEditorSetting()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TimeValueEditorSetting 类
TimeValueEditorSetting 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
TimeValueEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : TimeValueEditorSetting 类

所有这类成员的列表, 请看 TimeValueEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | TemplateName | 重写. 内置的数据模板名称。
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TemplateName 属性 (TimeValueEditorSetting)
GrapeCity.Forguncy.Plugin 命名空间 > TimeValueEditorSetting 类 : TemplateName 属性
内置的数据模板名称。
语法
  • C#
public override string TemplateName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

TimeValueEditorSetting 类
TimeValueEditorSetting 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ForguncyErrorType 枚举
GrapeCity.Forguncy.Plugin 命名空间 : ForguncyErrorType 枚举
运行页面时，系统内部会进行出错检查并显示在错误列表中，会根据出错类型显示不同的信息，并影响页面是否能够运行起来。
语法
  • C#
public enum ForguncyErrorType : System.Enum
成员
成员 | 说明
Error | 出错信息类型：错误，会导致页面运行不了。
Warning | 出错信息类型：提醒，页面可以运行，但是出错部分功能可能会有问题。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.ForguncyErrorType

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ForguncyTableColumnType 枚举
GrapeCity.Forguncy.Plugin 命名空间 : ForguncyTableColumnType 枚举
内建字段的值的类型。
语法
  • C#
public enum ForguncyTableColumnType : System.Enum
成员
成员 | 说明
Attachment | 附件。
Bool | 是/否。
DateTime | 日期。
Decimel | 小数。
Image | 图片。
Int | 整数。
Text | 文本。
Time | 时间。
User | 用户。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.ForguncyTableColumnType

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
TableColumnKind 枚举
GrapeCity.Forguncy.Plugin 命名空间 : TableColumnKind 枚举
字段分类。
语法
  • C#
public enum TableColumnKind : System.Enum
成员
成员 | 说明
BindingColumn | 普通字段。
FormulaColumn | 公式字段。
StatisticsColumn | 统计字段。
继承层次

System.Object
System.ValueType
System.Enum
GrapeCity.Forguncy.Plugin.TableColumnKind

需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IBuilderContextBase 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IBuilderContextBase 接口
设计器上下文信息。
对象模型
IBuilderContextBase 接口IUserServiceInfo 接口
语法
  • C#
public interface IBuilderContextBase
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContextBase 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IBuilderContextBase 接口 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : IBuilderContextBase 接口

以下表中列出了IBuilderContextBase的公开成员.

公共 属性
 | 名称 | 说明
属性 | PageName | 获取当前所在页面名称。
属性 | UserServiceInfo | 获取用户管理网站的信息。
页首
公共 方法
 | 名称 | 说明
方法 | EnumAllListViewInfos | 获取某个页面所有的表格信息。
方法 | EnumAllPageInfos | 获取所有的页面信息。
方法 | EnumAllTableInfos | 获取所有的数据表信息。
页首
请参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IBuilderContextBase 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IBuilderContextBase 接口

所有这类成员的列表, 请看 IBuilderContextBase 成员.

公共 方法
 | 名称 | 说明
方法 | EnumAllListViewInfos | 获取某个页面所有的表格信息。
方法 | EnumAllPageInfos | 获取所有的页面信息。
方法 | EnumAllTableInfos | 获取所有的数据表信息。
页首
请参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
EnumAllListViewInfos 方法
示例
GrapeCity.Forguncy.Plugin 命名空间 > IBuilderContextBase 接口 : EnumAllListViewInfos 方法
页面名，如果为空即表示当前所在页面。
获取某个页面所有的表格信息。
语法
  • C#
IEnumerable<IListViewInfo> EnumAllListViewInfos(
   string pageName
)

参数

pageName
页面名，如果为空即表示当前所在页面。

返回值

表格集合
示例
  • C#
public class WorkflowCommand : Command
{
    public string ListViewName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "ListViewName")
        {
            return new ComboEditorSetting(new List<string> (builderContext.EnumAllListViewInfos(null).Select(i=>i.ListViewName)));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContextBase 接口
IBuilderContextBase 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
EnumAllPageInfos 方法
示例
GrapeCity.Forguncy.Plugin 命名空间 > IBuilderContextBase 接口 : EnumAllPageInfos 方法
获取所有的页面信息。
语法
  • C#
IEnumerable<IPageInfo> EnumAllPageInfos()

返回值

页面集合。
示例
  • C#
public class MyNavigatePageCommand : Command
{
    public string NavigatePageName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "NavigatePageName")
        {
            return new ComboEditorSetting(builderContext.EnumAllPageInfos().Select(p => p.PageName));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContextBase 接口
IBuilderContextBase 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
EnumAllTableInfos 方法
示例
GrapeCity.Forguncy.Plugin 命名空间 > IBuilderContextBase 接口 : EnumAllTableInfos 方法
获取所有的数据表信息。
语法
  • C#
IEnumerable<ITableInfo> EnumAllTableInfos()

返回值

数据表集合
示例
  • C#
public class WorkflowCommand : Command
{
    public string TableName { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderCommandContext builderContext)
    {
        if(property.Name == "TableName")
        {
            return new ComboEditorSetting(builderContext.EnumAllTableInfos().Where(t => t.WorkflowInfo != null && t.WorkflowInfo.IsEnabled).Select(t => t.TableName));
        }
        return base.GetEditorSetting(property, builderContext);
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContextBase 接口
IBuilderContextBase 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IBuilderContextBase 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IBuilderContextBase 接口

所有这类成员的列表, 请看 IBuilderContextBase 成员.

公共 属性
 | 名称 | 说明
属性 | PageName | 获取当前所在页面名称。
属性 | UserServiceInfo | 获取用户管理网站的信息。
页首
请参见

引用

IBuilderContextBase 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
PageName 属性 (IBuilderContextBase)
GrapeCity.Forguncy.Plugin 命名空间 > IBuilderContextBase 接口 : PageName 属性
获取当前所在页面名称。
语法
  • C#
string PageName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContextBase 接口
IBuilderContextBase 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
UserServiceInfo 属性
示例
GrapeCity.Forguncy.Plugin 命名空间 > IBuilderContextBase 接口 : UserServiceInfo 属性
获取用户管理网站的信息。
语法
  • C#
IUserServiceInfo UserServiceInfo {get;}
示例
  • C#
public class MyUserSelectorCellType : CellType
{
    public string Role { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "Role")
        {
            return new ComboEditorSetting(builderContext.UserServiceInfo.AllRoles);
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IBuilderContextBase 接口
IBuilderContextBase 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ICellInfoBase 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : ICellInfoBase 接口
单元格的信息。
对象模型
ICellInfoBase 接口IListViewInfo 接口
语法
  • C#
public interface ICellInfoBase
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfoBase 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ICellInfoBase 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : ICellInfoBase 接口

以下表中列出了ICellInfoBase的公开成员.

公共 属性
 | 名称 | 说明
属性 | ListViewInfo | 单元格所在表格的信息。
页首
请参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ICellInfoBase 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : ICellInfoBase 接口

所有这类成员的列表, 请看 ICellInfoBase 成员.

公共 属性
 | 名称 | 说明
属性 | ListViewInfo | 单元格所在表格的信息。
页首
请参见

引用

ICellInfoBase 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ListViewInfo 属性
GrapeCity.Forguncy.Plugin 命名空间 > ICellInfoBase 接口 : ListViewInfo 属性
单元格所在表格的信息。
语法
  • C#
IListViewInfo ListViewInfo {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ICellInfoBase 接口
ICellInfoBase 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IColumnInfo 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IColumnInfo 接口
数据表中的字段信息。
语法
  • C#
public interface IColumnInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IColumnInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IColumnInfo 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : IColumnInfo 接口

以下表中列出了IColumnInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | ColumnKind | 字段的分类：普通字段，公式字段还是统计字段。
属性 | ColumnName | 字段名称。
属性 | ColumnType | 字段中值的类型。
页首
请参见

引用

IColumnInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IColumnInfo 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IColumnInfo 接口

所有这类成员的列表, 请看 IColumnInfo 成员.

公共 属性
 | 名称 | 说明
属性 | ColumnKind | 字段的分类：普通字段，公式字段还是统计字段。
属性 | ColumnName | 字段名称。
属性 | ColumnType | 字段中值的类型。
页首
请参见

引用

IColumnInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ColumnKind 属性
GrapeCity.Forguncy.Plugin 命名空间 > IColumnInfo 接口 : ColumnKind 属性
字段的分类：普通字段，公式字段还是统计字段。
语法
  • C#
TableColumnKind ColumnKind {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IColumnInfo 接口
IColumnInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ColumnName 属性 (IColumnInfo)
GrapeCity.Forguncy.Plugin 命名空间 > IColumnInfo 接口 : ColumnName 属性
字段名称。
语法
  • C#
string ColumnName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IColumnInfo 接口
IColumnInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ColumnType 属性
GrapeCity.Forguncy.Plugin 命名空间 > IColumnInfo 接口 : ColumnType 属性
字段中值的类型。
语法
  • C#
ForguncyTableColumnType ColumnType {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IColumnInfo 接口
IColumnInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IEditorSettingsDataContext 接口
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : IEditorSettingsDataContext 接口
属性数据上下文，可以获取属性的值以及属性编辑器。
对象模型
IEditorSettingsDataContext 接口EditorSetting 类
语法
  • C#
public interface IEditorSettingsDataContext
示例
  • C#
public class MenuCellType: CellType
{
    public List<string> MenusText { get; set; }

    public override EditorSetting GetEditorSetting(PropertyDescriptor property, IBuilderContext builderContext)
    {
        if (property.Name == "MenusText")
        {
            return new HyperlinkEditorSetting(new ItemsEditorSettingsCommand(builderContext));
        }
    }
}

public class ItemsEditorSettingsCommand : ICommand
{
    IBuilderContext _builderContext;
    public ItemsEditorSettingsCommand(IBuilderContext builderContext)
    {
        _builderContext = builderContext;
    }

    public void Execute(object parameter)
    {
        var dataContext = parameter as IEditorSettingsDataContext;
        var itemsInfo = dataContext?.Value as List<string>;

        Window window = new Window();
        /*todo: init UI in your window*/
        /*window.ViewModel = itemsInfo;*/

        window.Closed += (sender, e) =>
        {
           if (window.DialogResult == true)
           {
                /*todo: commit window data.*/
               /*dataContext.Value = window.ViewModel;*/
           }
       };
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IEditorSettingsDataContext 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IEditorSettingsDataContext 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : IEditorSettingsDataContext 接口

以下表中列出了IEditorSettingsDataContext的公开成员.

公共 属性
 | 名称 | 说明
属性 | EditorSetting | 属性编辑器。
属性 | Value | 属性的值。
页首
请参见

引用

IEditorSettingsDataContext 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IEditorSettingsDataContext 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IEditorSettingsDataContext 接口

所有这类成员的列表, 请看 IEditorSettingsDataContext 成员.

公共 属性
 | 名称 | 说明
属性 | EditorSetting | 属性编辑器。
属性 | Value | 属性的值。
页首
请参见

引用

IEditorSettingsDataContext 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
EditorSetting 属性
GrapeCity.Forguncy.Plugin 命名空间 > IEditorSettingsDataContext 接口 : EditorSetting 属性
属性编辑器。
语法
  • C#
EditorSetting EditorSetting {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IEditorSettingsDataContext 接口
IEditorSettingsDataContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Value 属性 (IEditorSettingsDataContext)
GrapeCity.Forguncy.Plugin 命名空间 > IEditorSettingsDataContext 接口 : Value 属性
属性的值。
语法
  • C#
object Value {get; set;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IEditorSettingsDataContext 接口
IEditorSettingsDataContext 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IFileUploadContext 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IFileUploadContext 接口
上传的文件需要的上下文信息。
语法
  • C#
public interface IFileUploadContext
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IFileUploadContext 接口 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : IFileUploadContext 接口

以下表中列出了IFileUploadContext的公开成员.

公共 属性
 | 名称 | 说明
属性 | SourceDocumentFolder | 活字格文件所在的文件夹路径。
页首
公共 方法
 | 名称 | 说明
方法 | GetForguncyUploadFilesFolderLocalPath | 返回上传文件的临时路径。
方法 | GetForguncyUploadFilesRelativePath | 返回上传文件的相对路径（基于活字格文件所在目录）。
方法 | GetForguncyUploadImagesFolderLocalPath | 内部使用。 主要用于内置的单元格类型，如图片单元格类型；返回上传图片的临时路径。
方法 | GetForguncyUploadImagesRelativePath | 内部使用。 主要用于内置的单元格类型，如图片单元格类型；返回上传图片的相对路径（基于活字格文件所在目录）。
方法 | GetForguncyUserTemplateFolderLocalPath | 内部使用。 主要用于内置的命令，如下载文件命令；返回上传的下载文件的临时路径。
方法 | GetForguncyUserTemplateRelativePath | 内部使用。 主要用于内置的命令，如下载文件命令；返回上传的下载文件的相对路径（基于活字格文件所在目录）。
页首
请参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IFileUploadContext 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IFileUploadContext 接口

所有这类成员的列表, 请看 IFileUploadContext 成员.

公共 方法
 | 名称 | 说明
方法 | GetForguncyUploadFilesFolderLocalPath | 返回上传文件的临时路径。
方法 | GetForguncyUploadFilesRelativePath | 返回上传文件的相对路径（基于活字格文件所在目录）。
方法 | GetForguncyUploadImagesFolderLocalPath | 内部使用。 主要用于内置的单元格类型，如图片单元格类型；返回上传图片的临时路径。
方法 | GetForguncyUploadImagesRelativePath | 内部使用。 主要用于内置的单元格类型，如图片单元格类型；返回上传图片的相对路径（基于活字格文件所在目录）。
方法 | GetForguncyUserTemplateFolderLocalPath | 内部使用。 主要用于内置的命令，如下载文件命令；返回上传的下载文件的临时路径。
方法 | GetForguncyUserTemplateRelativePath | 内部使用。 主要用于内置的命令，如下载文件命令；返回上传的下载文件的相对路径（基于活字格文件所在目录）。
页首
请参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetForguncyUploadFilesFolderLocalPath 方法
GrapeCity.Forguncy.Plugin 命名空间 > IFileUploadContext 接口 : GetForguncyUploadFilesFolderLocalPath 方法
返回上传文件的临时路径。
语法
  • C#
string GetForguncyUploadFilesFolderLocalPath()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 接口
IFileUploadContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetForguncyUploadFilesRelativePath 方法
GrapeCity.Forguncy.Plugin 命名空间 > IFileUploadContext 接口 : GetForguncyUploadFilesRelativePath 方法
活字格文件所在的文件夹路径。
返回上传文件的相对路径（基于活字格文件所在目录）。
语法
  • C#
string GetForguncyUploadFilesRelativePath(
   string baseFolder
)

参数

baseFolder
活字格文件所在的文件夹路径。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 接口
IFileUploadContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetForguncyUploadImagesFolderLocalPath 方法
GrapeCity.Forguncy.Plugin 命名空间 > IFileUploadContext 接口 : GetForguncyUploadImagesFolderLocalPath 方法

内部使用。

主要用于内置的单元格类型，如图片单元格类型；返回上传图片的临时路径。

语法
  • C#
string GetForguncyUploadImagesFolderLocalPath()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 接口
IFileUploadContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetForguncyUploadImagesRelativePath 方法
GrapeCity.Forguncy.Plugin 命名空间 > IFileUploadContext 接口 : GetForguncyUploadImagesRelativePath 方法
活字格文件所在的文件夹路径。

内部使用。

主要用于内置的单元格类型，如图片单元格类型；返回上传图片的相对路径（基于活字格文件所在目录）。

语法
  • C#
string GetForguncyUploadImagesRelativePath(
   string baseFolder
)

参数

baseFolder
活字格文件所在的文件夹路径。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 接口
IFileUploadContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetForguncyUserTemplateFolderLocalPath 方法
GrapeCity.Forguncy.Plugin 命名空间 > IFileUploadContext 接口 : GetForguncyUserTemplateFolderLocalPath 方法

内部使用。

主要用于内置的命令，如下载文件命令；返回上传的下载文件的临时路径。

语法
  • C#
string GetForguncyUserTemplateFolderLocalPath()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 接口
IFileUploadContext 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetForguncyUserTemplateRelativePath 方法
GrapeCity.Forguncy.Plugin 命名空间 > IFileUploadContext 接口 : GetForguncyUserTemplateRelativePath 方法

内部使用。

主要用于内置的命令，如下载文件命令；返回上传的下载文件的相对路径（基于活字格文件所在目录）。

语法
  • C#
string GetForguncyUserTemplateRelativePath(
   string baseFolder
)

参数

baseFolder
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 接口
IFileUploadContext 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IFileUploadContext 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IFileUploadContext 接口

所有这类成员的列表, 请看 IFileUploadContext 成员.

公共 属性
 | 名称 | 说明
属性 | SourceDocumentFolder | 活字格文件所在的文件夹路径。
页首
请参见

引用

IFileUploadContext 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
SourceDocumentFolder 属性
GrapeCity.Forguncy.Plugin 命名空间 > IFileUploadContext 接口 : SourceDocumentFolder 属性
活字格文件所在的文件夹路径。
语法
  • C#
string SourceDocumentFolder {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFileUploadContext 接口
IFileUploadContext 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IFormulaReferObject 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IFormulaReferObject 接口
公式对象。
语法
  • C#
public interface IFormulaReferObject
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFormulaReferObject 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IFormulaReferObject 接口 成员
属性 方法

GrapeCity.Forguncy.Plugin 命名空间 : IFormulaReferObject 接口

以下表中列出了IFormulaReferObject的公开成员.

公共 属性
 | 名称 | 说明
属性 | PageName | 公式对象所在的页面名称。
页首
公共 方法
 | 名称 | 说明
方法 | IsNormalFormula | 是否是公式。
页首
请参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IFormulaReferObject 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IFormulaReferObject 接口

所有这类成员的列表, 请看 IFormulaReferObject 成员.

公共 方法
 | 名称 | 说明
方法 | IsNormalFormula | 是否是公式。
页首
请参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
IsNormalFormula 方法
GrapeCity.Forguncy.Plugin 命名空间 > IFormulaReferObject 接口 : IsNormalFormula 方法
是否是公式。
语法
  • C#
bool IsNormalFormula()
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFormulaReferObject 接口
IFormulaReferObject 成员


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IFormulaReferObject 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IFormulaReferObject 接口

所有这类成员的列表, 请看 IFormulaReferObject 成员.

公共 属性
 | 名称 | 说明
属性 | PageName | 公式对象所在的页面名称。
页首
请参见

引用

IFormulaReferObject 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
PageName 属性 (IFormulaReferObject)
GrapeCity.Forguncy.Plugin 命名空间 > IFormulaReferObject 接口 : PageName 属性
公式对象所在的页面名称。
语法
  • C#
string PageName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IFormulaReferObject 接口
IFormulaReferObject 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IListViewInfo 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IListViewInfo 接口
页面中的表格信息。
语法
  • C#
public interface IListViewInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IListViewInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IListViewInfo 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : IListViewInfo 接口

以下表中列出了IListViewInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | AllowAddNewRow | 是否允许在表格中加行。
属性 | AllowDeleteRow | 是否允许在表格中删行。
属性 | AllowEditRow | 是否允许在表格中编辑。
属性 | BindingTableName | 绑定的数据表名。
属性 | ListViewName | 表格的名称。
页首
请参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IListViewInfo 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IListViewInfo 接口

所有这类成员的列表, 请看 IListViewInfo 成员.

公共 属性
 | 名称 | 说明
属性 | AllowAddNewRow | 是否允许在表格中加行。
属性 | AllowDeleteRow | 是否允许在表格中删行。
属性 | AllowEditRow | 是否允许在表格中编辑。
属性 | BindingTableName | 绑定的数据表名。
属性 | ListViewName | 表格的名称。
页首
请参见

引用

IListViewInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
AllowAddNewRow 属性
GrapeCity.Forguncy.Plugin 命名空间 > IListViewInfo 接口 : AllowAddNewRow 属性
是否允许在表格中加行。
语法
  • C#
bool AllowAddNewRow {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IListViewInfo 接口
IListViewInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
AllowDeleteRow 属性
GrapeCity.Forguncy.Plugin 命名空间 > IListViewInfo 接口 : AllowDeleteRow 属性
是否允许在表格中删行。
语法
  • C#
bool AllowDeleteRow {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IListViewInfo 接口
IListViewInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
AllowEditRow 属性
GrapeCity.Forguncy.Plugin 命名空间 > IListViewInfo 接口 : AllowEditRow 属性
是否允许在表格中编辑。
语法
  • C#
bool AllowEditRow {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IListViewInfo 接口
IListViewInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
BindingTableName 属性
GrapeCity.Forguncy.Plugin 命名空间 > IListViewInfo 接口 : BindingTableName 属性
绑定的数据表名。
语法
  • C#
string BindingTableName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IListViewInfo 接口
IListViewInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
ListViewName 属性
GrapeCity.Forguncy.Plugin 命名空间 > IListViewInfo 接口 : ListViewName 属性
表格的名称。
语法
  • C#
string ListViewName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IListViewInfo 接口
IListViewInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
INeedUploadFileByUser 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : INeedUploadFileByUser 接口
如果插件使用过程中需要用户上传文件或者图片等，在保存或导入活字格文件时需给出相关的文件或图片信息，如存储文件夹路径，文件名等。
语法
  • C#
public interface INeedUploadFileByUser
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

INeedUploadFileByUser 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
INeedUploadFileByUser 接口 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : INeedUploadFileByUser 接口

以下表中列出了INeedUploadFileByUser的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetAllFileSourceAndTargetPathsWhenImportForguncyFile | 当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
方法 | GetUploadFileInfosWhenSaveFile | 保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
页首
请参见

引用

INeedUploadFileByUser 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
INeedUploadFileByUser 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : INeedUploadFileByUser 接口

所有这类成员的列表, 请看 INeedUploadFileByUser 成员.

公共 方法
 | 名称 | 说明
方法 | GetAllFileSourceAndTargetPathsWhenImportForguncyFile | 当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
方法 | GetUploadFileInfosWhenSaveFile | 保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
页首
请参见

引用

INeedUploadFileByUser 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetAllFileSourceAndTargetPathsWhenImportForguncyFile 方法
GrapeCity.Forguncy.Plugin 命名空间 > INeedUploadFileByUser 接口 : GetAllFileSourceAndTargetPathsWhenImportForguncyFile 方法
提供了一些获取当前活字格文件的存储位置等信息。
当导入活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片信息返回。
语法
  • C#
List<FileCopyInfo> GetAllFileSourceAndTargetPathsWhenImportForguncyFile(
   IFileUploadContext context
)

参数

context
提供了一些获取当前活字格文件的存储位置等信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

INeedUploadFileByUser 接口
INeedUploadFileByUser 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetUploadFileInfosWhenSaveFile 方法
GrapeCity.Forguncy.Plugin 命名空间 > INeedUploadFileByUser 接口 : GetUploadFileInfosWhenSaveFile 方法
提供了一些获取当前活字格文件的存储位置等信息。
保存活字格文件的时候会调用该方法，将用户在插件使用过程中上传的文件或图片保存在活字格文件中。
语法
  • C#
FileUploadInfo GetUploadFileInfosWhenSaveFile(
   IFileUploadContext context
)

参数

context
提供了一些获取当前活字格文件的存储位置等信息。

返回值

保存时上传文件的信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

INeedUploadFileByUser 接口
INeedUploadFileByUser 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IPageInfo 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IPageInfo 接口
页面信息。
语法
  • C#
public interface IPageInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IPageInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IPageInfo 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : IPageInfo 接口

以下表中列出了IPageInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | IsBuiltInPage | 是否内建页。
属性 | IsMasterPage | 是否母版页。
属性 | IsMobilePage | 是否手机页。
属性 | PageName | 页面名。
页首
请参见

引用

IPageInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IPageInfo 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IPageInfo 接口

所有这类成员的列表, 请看 IPageInfo 成员.

公共 属性
 | 名称 | 说明
属性 | IsBuiltInPage | 是否内建页。
属性 | IsMasterPage | 是否母版页。
属性 | IsMobilePage | 是否手机页。
属性 | PageName | 页面名。
页首
请参见

引用

IPageInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
IsBuiltInPage 属性
GrapeCity.Forguncy.Plugin 命名空间 > IPageInfo 接口 : IsBuiltInPage 属性
是否内建页。
语法
  • C#
bool IsBuiltInPage {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IPageInfo 接口
IPageInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
IsMasterPage 属性
GrapeCity.Forguncy.Plugin 命名空间 > IPageInfo 接口 : IsMasterPage 属性
是否母版页。
语法
  • C#
bool IsMasterPage {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IPageInfo 接口
IPageInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
IsMobilePage 属性
GrapeCity.Forguncy.Plugin 命名空间 > IPageInfo 接口 : IsMobilePage 属性
是否手机页。
语法
  • C#
bool IsMobilePage {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IPageInfo 接口
IPageInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
PageName 属性 (IPageInfo)
GrapeCity.Forguncy.Plugin 命名空间 > IPageInfo 接口 : PageName 属性
页面名。
语法
  • C#
string PageName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IPageInfo 接口
IPageInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IReferenceFormula 接口
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : IReferenceFormula 接口

如果插件中引用了页面中的单元格，一旦被引用的单元格的位置发生了变化，如拖拽，那么插件中的相关单元格引用也应该被同步；

这种情况下就需要实现这个接口，而且，当查找页面中的单元格引用时，插件中的相关属性也会被查找出来。

语法
  • C#
public interface IReferenceFormula
示例
  • C#
public class MyCellType : CellType, IReferenceFormula
{
    [FormulaProperty]
    public object ReferCell { get; set; }

    public IEnumerable<LocatedObject<object>> GetFormulaReferObjects(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("MyCellType").AppendProperty("ReferCell");
        yield return new LocatedObject<object>(this.ReferCell, newLocation);
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceFormula 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IReferenceFormula 接口 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceFormula 接口

以下表中列出了IReferenceFormula的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetFormulaReferObjects | 获取插件中所有引用单元格或单元格区域的公式对象。
页首
请参见

引用

IReferenceFormula 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IReferenceFormula 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceFormula 接口

所有这类成员的列表, 请看 IReferenceFormula 成员.

公共 方法
 | 名称 | 说明
方法 | GetFormulaReferObjects | 获取插件中所有引用单元格或单元格区域的公式对象。
页首
请参见

引用

IReferenceFormula 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetFormulaReferObjects 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferenceFormula 接口 : GetFormulaReferObjects 方法
坐标定位器。
获取插件中所有引用单元格或单元格区域的公式对象。
语法
  • C#
IEnumerable<LocatedObject<object>> GetFormulaReferObjects(
   LocationIndicator location
)

参数

location
坐标定位器。

返回值

返回所有引用单元格或单元格区域的公式对象。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceFormula 接口
IReferenceFormula 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IReferenceListView 接口
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : IReferenceListView 接口

如果插件中引用了页面中的表格的名称，一旦表格重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找页面中的表格引用时，插件中的相关属性也会被查找出来。

语法
  • C#
public interface IReferenceListView
示例
  • C#
public class MyPageNavigateCellType : CellType, IReferenceListView
{
    public string ListViewName { get; set; }

    public IEnumerable<string>> GetListViewNames()
    {
        yield return this.ListViewName;
    }

    public void RenameListviewName(string oldName, string newName)
    {
        if(string.Equals(this.ListViewName, oldName))
        {
            this.ListViewName = newName;
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceListView 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IReferenceListView 接口 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceListView 接口

以下表中列出了IReferenceListView的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetListViewNames | 返回插件中所有引用页面表格的信息。
方法 | RenameListviewName | 一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
页首
请参见

引用

IReferenceListView 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IReferenceListView 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceListView 接口

所有这类成员的列表, 请看 IReferenceListView 成员.

公共 方法
 | 名称 | 说明
方法 | GetListViewNames | 返回插件中所有引用页面表格的信息。
方法 | RenameListviewName | 一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
页首
请参见

引用

IReferenceListView 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetListViewNames 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferenceListView 接口 : GetListViewNames 方法
返回插件中所有引用页面表格的信息。
语法
  • C#
IEnumerable<string> GetListViewNames()

返回值

返回插件中所有引用页面表格的信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceListView 接口
IReferenceListView 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
RenameListviewName 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferenceListView 接口 : RenameListviewName 方法
重命名之前的表格名。
重命名之后的表格名。
一旦页面中的表格被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表格名。
语法
  • C#
void RenameListviewName(
   string oldName,
   string newName
)

参数

oldName
重命名之前的表格名。
newName
重命名之后的表格名。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceListView 接口
IReferenceListView 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IReferenceListViewColumn 接口
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : IReferenceListViewColumn 接口

如果插件中引用了页面表格中列名，一旦表格中的列重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口。

语法
  • C#
public interface IReferenceListViewColumn
示例
  • C#
public class UpdateListviewCommand : Command, IReferenceListView
{
    public string ListViewName { get; set; }

    public List<string> UpdateColumns { get; set; }

    public void RenameListviewColumnName(string listviewName, string oldName, string newName)
    {
        if(string.Equals(this.ListViewName, listviewName))
        {
            for (var i = 0; i < this.UpdateColumns.Count; i++)
            {
                if(this.UpdateColumns[i] == oldName)
                {
                    this.UpdateColumns[i] = newName;
                }
            }
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceListViewColumn 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IReferenceListViewColumn 接口 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceListViewColumn 接口

以下表中列出了IReferenceListViewColumn的公开成员.

公共 方法
 | 名称 | 说明
方法 | RenameListviewColumnName | 一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
页首
请参见

引用

IReferenceListViewColumn 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IReferenceListViewColumn 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceListViewColumn 接口

所有这类成员的列表, 请看 IReferenceListViewColumn 成员.

公共 方法
 | 名称 | 说明
方法 | RenameListviewColumnName | 一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
页首
请参见

引用

IReferenceListViewColumn 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
RenameListviewColumnName 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferenceListViewColumn 接口 : RenameListviewColumnName 方法
表格名称。
重命名之前的表格列名。
重命名之后的表格列名。
一旦页面表格中的列被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的表格相关列名。
语法
  • C#
void RenameListviewColumnName(
   string listviewName,
   string oldName,
   string newName
)

参数

listviewName
表格名称。
oldName
重命名之前的表格列名。
newName
重命名之后的表格列名。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceListViewColumn 接口
IReferenceListViewColumn 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IReferencePage 接口
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : IReferencePage 接口

如果插件中引用了页面名，一旦页面重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找页面的引用时，插件中的相关属性也会被查找出来。

语法
  • C#
public interface IReferencePage
示例
  • C#
public class MyNavigatePageCommand : Command, IReferencePage
{
    public string NavigatePageName { get; set; }

    public IEnumerable<LocatedObject<string>> GetPageNames(LocationIndicator location)
    {
        var newLocation = location.AppendProperty("MyNavigatePageCommand");

        yield return new LocatedObject<string>(this.NavigatePageName, newLocation);
    }

    public void RenamePageName(string oldName, string newName)
    {
        if(string.Equals(this.NavigatePageName, oldName))
        {
            this.NavigatePageName = newName;
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferencePage 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IReferencePage 接口 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferencePage 接口

以下表中列出了IReferencePage的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetPageNames | 返回插件中所有引用页面的信息。
方法 | RenamePageName | 一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
页首
请参见

引用

IReferencePage 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IReferencePage 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferencePage 接口

所有这类成员的列表, 请看 IReferencePage 成员.

公共 方法
 | 名称 | 说明
方法 | GetPageNames | 返回插件中所有引用页面的信息。
方法 | RenamePageName | 一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
页首
请参见

引用

IReferencePage 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetPageNames 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferencePage 接口 : GetPageNames 方法
坐标定位器。
返回插件中所有引用页面的信息。
语法
  • C#
IEnumerable<LocatedObject<string>> GetPageNames(
   LocationIndicator location
)

参数

location
坐标定位器。

返回值

返回插件中所有引用页面的信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferencePage 接口
IReferencePage 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
RenamePageName 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferencePage 接口 : RenamePageName 方法
重命名之前的页面名。
重命名之后的页面名。
一旦页面被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关页面名。
语法
  • C#
void RenamePageName(
   string oldName,
   string newName
)

参数

oldName
重命名之前的页面名。
newName
重命名之后的页面名。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferencePage 接口
IReferencePage 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IReferenceTable 接口
成员 示例
GrapeCity.Forguncy.Plugin 命名空间 : IReferenceTable 接口

如果插件中引用了数据表名或者字段名，一旦数据表或字段重命名后，插件中的相关属性的值就期望被同步；

这种情况下就需要实现这个接口，而且，当查找数据表或字段的引用时，插件中的相关属性也会被查找出来。

语法
  • C#
public interface IReferenceTable
示例
  • C#
public class ListCellType : CellType, IReferenceTable
{
    public string TableName { get; set; }

    public string TextColumn { get; set; }

    public string ValueColumn { get; set; }

    public  IEnumerable<LocatedObject<TableCheckInfo>> GetTableInfo(LocationIndicator location)
    {
        var list = new List<LocatedObject<TableCheckInfo>>();

        TableCheckInfo info = new TableCheckInfo(TableName);
        var columns = (new List<string>() { ValueColumn, TextColumn }).Distinct();
        foreach (var col in columns)
        {
            info.AddColumns(col);
        }

        var newLocation = location.AppendProperty("ListCellType");

        list.Add(new LocatedObject<TableCheckInfo>(info, newLocation));

        return list;
    }

    public void RenameTableColumnName(string tableName, string oldName, string newName)
    {
        if (string.Equals(this.TableName, tableName))
        {
            if (oldName == this.ValueColumn)
            {
                this.ValueColumn = newName;
            }
            if (oldName == this.TextColumn)
            {
                this.TextColumn = newName;
            }
        }
    }

    public void RenameTableName(string oldName, string newName)
    {
        if(string.Equals(this.TableName, oldName))
        {
            this.TableName = newName;
        }
    }
}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceTable 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IReferenceTable 接口 成员
方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceTable 接口

以下表中列出了IReferenceTable的公开成员.

公共 方法
 | 名称 | 说明
方法 | GetTableInfo | 返回插件中所有引用数据表和字段的信息。
方法 | RenameTableColumnName | 一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
方法 | RenameTableName | 一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
页首
请参见

引用

IReferenceTable 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IReferenceTable 接口 方法

GrapeCity.Forguncy.Plugin 命名空间 : IReferenceTable 接口

所有这类成员的列表, 请看 IReferenceTable 成员.

公共 方法
 | 名称 | 说明
方法 | GetTableInfo | 返回插件中所有引用数据表和字段的信息。
方法 | RenameTableColumnName | 一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
方法 | RenameTableName | 一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
页首
请参见

引用

IReferenceTable 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
GetTableInfo 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferenceTable 接口 : GetTableInfo 方法
原有坐标定位器。
返回插件中所有引用数据表和字段的信息。
语法
  • C#
IEnumerable<LocatedObject<TableCheckInfo>> GetTableInfo(
   LocationIndicator location
)

参数

location
原有坐标定位器。

返回值

返回插件中所有引用数据表和字段的信息。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceTable 接口
IReferenceTable 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
RenameTableColumnName 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferenceTable 接口 : RenameTableColumnName 方法
数据表名。
重命名之前的字段名。
重命名之后的字段名。
一旦数据表中字段被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关字段名。
语法
  • C#
void RenameTableColumnName(
   string tableName,
   string oldName,
   string newName
)

参数

tableName
数据表名。
oldName
重命名之前的字段名。
newName
重命名之后的字段名。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceTable 接口
IReferenceTable 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
RenameTableName 方法
GrapeCity.Forguncy.Plugin 命名空间 > IReferenceTable 接口 : RenameTableName 方法
重命名之前的数据表名。
重命名之后的数据表名。
一旦数据表被重命名时会调用该函数，所以需实现该接口重命名插件中使用到的相关表名。
语法
  • C#
void RenameTableName(
   string oldName,
   string newName
)

参数

oldName
重命名之前的数据表名。
newName
重命名之后的数据表名。
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IReferenceTable 接口
IReferenceTable 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
ITableInfo 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : ITableInfo 接口
数据表的信息。
对象模型
ITableInfo 接口IWorkflowInfo 接口
语法
  • C#
public interface ITableInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ITableInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
ITableInfo 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : ITableInfo 接口

以下表中列出了ITableInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | Columns | 数据表中字段名集合。
属性 | TableName | 数据表名。
属性 | WorkflowInfo | 数据表的工作流信息。
页首
请参见

引用

ITableInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
ITableInfo 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : ITableInfo 接口

所有这类成员的列表, 请看 ITableInfo 成员.

公共 属性
 | 名称 | 说明
属性 | Columns | 数据表中字段名集合。
属性 | TableName | 数据表名。
属性 | WorkflowInfo | 数据表的工作流信息。
页首
请参见

引用

ITableInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
Columns 属性
GrapeCity.Forguncy.Plugin 命名空间 > ITableInfo 接口 : Columns 属性
数据表中字段名集合。
语法
  • C#
IEnumerable<IColumnInfo> Columns {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ITableInfo 接口
ITableInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
TableName 属性 (ITableInfo)
GrapeCity.Forguncy.Plugin 命名空间 > ITableInfo 接口 : TableName 属性
数据表名。
语法
  • C#
string TableName {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ITableInfo 接口
ITableInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
WorkflowInfo 属性
GrapeCity.Forguncy.Plugin 命名空间 > ITableInfo 接口 : WorkflowInfo 属性
数据表的工作流信息。
语法
  • C#
IWorkflowInfo WorkflowInfo {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

ITableInfo 接口
ITableInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IUserServiceInfo 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IUserServiceInfo 接口
用户管理网站的信息。
语法
  • C#
public interface IUserServiceInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IUserServiceInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IUserServiceInfo 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : IUserServiceInfo 接口

以下表中列出了IUserServiceInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | AllRoles | 获取所有的角色。
页首
请参见

引用

IUserServiceInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IUserServiceInfo 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IUserServiceInfo 接口

所有这类成员的列表, 请看 IUserServiceInfo 成员.

公共 属性
 | 名称 | 说明
属性 | AllRoles | 获取所有的角色。
页首
请参见

引用

IUserServiceInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
AllRoles 属性
GrapeCity.Forguncy.Plugin 命名空间 > IUserServiceInfo 接口 : AllRoles 属性
获取所有的角色。
语法
  • C#
List<string> AllRoles {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IUserServiceInfo 接口
IUserServiceInfo 成员


%%PageItemTitle%%

GrapeCity.Forguncy.Plugin
IWorkflowInfo 接口
成员
GrapeCity.Forguncy.Plugin 命名空间 : IWorkflowInfo 接口
数据表中的工作流信息。
语法
  • C#
public interface IWorkflowInfo
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IWorkflowInfo 成员
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Members$$

GrapeCity.Forguncy.Plugin
IWorkflowInfo 接口 成员
属性

GrapeCity.Forguncy.Plugin 命名空间 : IWorkflowInfo 接口

以下表中列出了IWorkflowInfo的公开成员.

公共 属性
 | 名称 | 说明
属性 | IsEnabled | 是否启用工作流。
属性 | StateList | 工作流中的状态集合。
页首
请参见

引用

IWorkflowInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
IWorkflowInfo 接口 属性

GrapeCity.Forguncy.Plugin 命名空间 : IWorkflowInfo 接口

所有这类成员的列表, 请看 IWorkflowInfo 成员.

公共 属性
 | 名称 | 说明
属性 | IsEnabled | 是否启用工作流。
属性 | StateList | 工作流中的状态集合。
页首
请参见

引用

IWorkflowInfo 接口
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
IsEnabled 属性 (IWorkflowInfo)
GrapeCity.Forguncy.Plugin 命名空间 > IWorkflowInfo 接口 : IsEnabled 属性
是否启用工作流。
语法
  • C#
bool IsEnabled {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IWorkflowInfo 接口
IWorkflowInfo 成员


%%ItemTitle%%

GrapeCity.Forguncy.Plugin
StateList 属性
GrapeCity.Forguncy.Plugin 命名空间 > IWorkflowInfo 接口 : StateList 属性
工作流中的状态集合。
语法
  • C#
IEnumerable<string> StateList {get;}
需求

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

请参见

引用

IWorkflowInfo 接口
IWorkflowInfo 成员


%%PageItemTitle%% $$Properties$$

Forguncy.Commands
ICommandCellInfo 接口 属性

GrapeCity.Forguncy.Commands 命名空间 : ICommandCellInfo 接口

所有这类成员的列表, 请看 ICommandCellInfo 成员.

公共 属性
 | 名称 | 说明
属性 | ListViewInfo | 单元格所在表格的信息。 (从GrapeCity.Forguncy.Plugin.ICellInfoBase继承)
页首
请参见

引用

ICommandCellInfo 接口
GrapeCity.Forguncy.Commands 命名空间
ICellInfoBase 接口


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Forguncy.Commands
GrapeCity.Forguncy.Commands 命名空间 继承层次
继承层次
System.Object
GrapeCity.Forguncy.Commands.Command
请参见

引用

Forguncy.Commands 程序集


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
CategoryHeaderAttribute 类 方法

GrapeCity.Forguncy.CellTypes 命名空间 : CategoryHeaderAttribute 类

所有这类成员的列表, 请看 CategoryHeaderAttribute 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

CategoryHeaderAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.CellTypes
CellType 类 事件

GrapeCity.Forguncy.CellTypes 命名空间 : CellType 类

所有这类成员的列表, 请看 CellType 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase继承)
页首
请参见

引用

CellType 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.CellTypes
GrapeCity.Forguncy.CellTypes.CellTypeCommon 命名空间 继承层次
继承层次
System.Object
GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase
GrapeCity.Forguncy.CellTypes.CellType
请参见

引用

GrapeCity.Forguncy.CellTypes 程序集


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
ICommandWindow 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ICommandWindow 接口

所有这类成员的列表, 请看 ICommandWindow 成员.

公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
ICommandWindow 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : ICommandWindow 接口

所有这类成员的列表, 请看 ICommandWindow 成员.

公共 属性
 | 名称 | 说明
属性 | DialogResult | 对话框返回结果。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

ICommandWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.CellTypes
IGeneralForguncyFormatter 接口 属性

GrapeCity.Forguncy.CellTypes 命名空间 : IGeneralForguncyFormatter 接口

所有这类成员的列表, 请看 IGeneralForguncyFormatter 成员.

公共 属性
 | 名称 | 说明
属性 | FormatString | 格式字符串。 (从GrapeCity.Forguncy.CellTypes.IForguncyFormatter继承)
页首
请参见

引用

IGeneralForguncyFormatter 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
IQueryConditionWindow 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : IQueryConditionWindow 接口

所有这类成员的列表, 请看 IQueryConditionWindow 成员.

公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

IQueryConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
ISelectImageWindow 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISelectImageWindow 接口

所有这类成员的列表, 请看 ISelectImageWindow 成员.

公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

ISelectImageWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
ISortConditionWindow 接口 方法

GrapeCity.Forguncy.CellTypes 命名空间 : ISortConditionWindow 接口

所有这类成员的列表, 请看 ISortConditionWindow 成员.

公共 方法
 | 名称 | 说明
方法 | ShowDialog | 打开对话框。 (从GrapeCity.Forguncy.CellTypes.IWindow继承)
页首
请参见

引用

ISortConditionWindow 接口
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
SupportLanguageScopeAttribute 类 方法

GrapeCity.Forguncy.CellTypes 命名空间 : SupportLanguageScopeAttribute 类

所有这类成员的列表, 请看 SupportLanguageScopeAttribute 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

SupportLanguageScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.CellTypes
SupportUsingScopeAttribute 类 方法

GrapeCity.Forguncy.CellTypes 命名空间 : SupportUsingScopeAttribute 类

所有这类成员的列表, 请看 SupportUsingScopeAttribute 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

SupportUsingScopeAttribute 类
GrapeCity.Forguncy.CellTypes 命名空间


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.CellTypes
GrapeCity.Forguncy.CellTypes 命名空间 继承层次
继承层次
System.Object
GrapeCity.Forguncy.CellTypes.CellTypeCommon.PropertyChangedObjectBase
GrapeCity.Forguncy.CellTypes.CellType
GrapeCity.Forguncy.CellTypes.ExportResultInfo
System.Attribute
GrapeCity.Forguncy.CellTypes.CategoryHeaderAttribute
GrapeCity.Forguncy.CellTypes.SupportLanguageScopeAttribute
GrapeCity.Forguncy.CellTypes.SupportUsingScopeAttribute
请参见

引用

GrapeCity.Forguncy.CellTypes 程序集


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
BuiltinEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : BuiltinEditorSetting 类

所有这类成员的列表, 请看 BuiltinEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

BuiltinEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
CheckBoxEidtorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : CheckBoxEidtorSetting 类

所有这类成员的列表, 请看 CheckBoxEidtorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
CheckBoxEidtorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : CheckBoxEidtorSetting 类

所有这类成员的列表, 请看 CheckBoxEidtorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

CheckBoxEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
ComboEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : ComboEditorSetting 类

所有这类成员的列表, 请看 ComboEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
ComboEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : ComboEditorSetting 类

所有这类成员的列表, 请看 ComboEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ComboEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
DoubleEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : DoubleEditorSetting 类

所有这类成员的列表, 请看 DoubleEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
DoubleEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : DoubleEditorSetting 类

所有这类成员的列表, 请看 DoubleEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

DoubleEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
EnumValueEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : EnumValueEditorSetting 类

所有这类成员的列表, 请看 EnumValueEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

EnumValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
EnumValueEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : EnumValueEditorSetting 类

所有这类成员的列表, 请看 EnumValueEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

EnumValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
EnumValueEditorSetting 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : EnumValueEditorSetting 类

所有这类成员的列表, 请看 EnumValueEditorSetting 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DefaultCaptionVisibility | 属性编辑器分类的标题是否显示。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | DisplayMember | 下拉项目文本属性。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | IsEnabled | 属性编辑器是否可用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
Public 属性 | Orientation | 命令插件中的属性编辑器中属性说明文字和编辑器的排布方向，默认是水平排布。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
Public 属性 | Source | 下拉项目集合。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | TemplateName | 内置的数据模板名称。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | ValueMember | 下拉项目值属性。 (从GrapeCity.Forguncy.Plugin.ComboEditorSetting继承)
Public 属性 | Visibility | 属性编辑器是否可见。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

EnumValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
FormulaPropertyAttribute 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : FormulaPropertyAttribute 类

所有这类成员的列表, 请看 FormulaPropertyAttribute 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

FormulaPropertyAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
FormulaSelectorEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : FormulaSelectorEditorSetting 类

所有这类成员的列表, 请看 FormulaSelectorEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
FormulaSelectorEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : FormulaSelectorEditorSetting 类

所有这类成员的列表, 请看 FormulaSelectorEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

FormulaSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
HyperlinkEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : HyperlinkEditorSetting 类

所有这类成员的列表, 请看 HyperlinkEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
HyperlinkEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : HyperlinkEditorSetting 类

所有这类成员的列表, 请看 HyperlinkEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

HyperlinkEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
ImageEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : ImageEditorSetting 类

所有这类成员的列表, 请看 ImageEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
ImageEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : ImageEditorSetting 类

所有这类成员的列表, 请看 ImageEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

ImageEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
IntEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : IntEditorSetting 类

所有这类成员的列表, 请看 IntEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
IntEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : IntEditorSetting 类

所有这类成员的列表, 请看 IntEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

IntEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
NameIndicator 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : NameIndicator 类

所有这类成员的列表, 请看 NameIndicator 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

NameIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
ObjectIndicator 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator 类

所有这类成员的列表, 请看 ObjectIndicator 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

ObjectIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
ObjectIndicator<T> 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : ObjectIndicator<T> 类

所有这类成员的列表, 请看 ObjectIndicator<T> 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

ObjectIndicator<T> 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
OrderWeightAttribute 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : OrderWeightAttribute 类

所有这类成员的列表, 请看 OrderWeightAttribute 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Equals | (从System.Attribute继承)
Public 方法 | GetHashCode | (从System.Attribute继承)
Public 方法 | IsDefaultAttribute | (从System.Attribute继承)
Public 方法 | Match | (从System.Attribute继承)
页首
请参见

引用

OrderWeightAttribute 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
OrientationEidtorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : OrientationEidtorSetting 类

所有这类成员的列表, 请看 OrientationEidtorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
OrientationEidtorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : OrientationEidtorSetting 类

所有这类成员的列表, 请看 OrientationEidtorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

OrientationEidtorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
PropertyIndicator 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : PropertyIndicator 类

所有这类成员的列表, 请看 PropertyIndicator 成员.

公共 方法
 | 名称 | 说明
Public 方法 | Append | 拼接一个坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | Enum | 遍历当前坐标定位器以及该链表中所有的父坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 方法 | GetPathString | 基于拼接符和过滤方法返回坐标定位器的查找路径。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
扩展方法
 | 名称 | 说明
Public 扩展方法 | AppendProperty | 增加一个属性定位器。
Public 扩展方法 | ContainObject | 坐标定位器所在链表中的对象定位器中是否包含特定的对象。
Public 扩展方法 | ContainProperty | 坐标定位器所在链表中的属性定位器中是否包含特定的属性。
页首
请参见

引用

PropertyIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Properties$$

GrapeCity.Forguncy.Plugin
PropertyIndicator 类 属性

GrapeCity.Forguncy.Plugin 命名空间 : PropertyIndicator 类

所有这类成员的列表, 请看 PropertyIndicator 成员.

公共 属性
 | 名称 | 说明
Public 属性 | DisplayString | 当前坐标定位器的显示文字。 (从GrapeCity.Forguncy.Plugin.NameIndicator继承)
Public 属性 | FullString | 返回坐标定位器所在链表中的多个定位器的显示文字用"->"拼接后的文字。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
Public 属性 | Name | 当前坐标定位器的名称。 (从GrapeCity.Forguncy.Plugin.NameIndicator继承)
Public 属性 | Root | 根坐标定位器。 (从GrapeCity.Forguncy.Plugin.LocationIndicator继承)
页首
请参见

引用

PropertyIndicator 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
TableComboTreeSelectorEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : TableComboTreeSelectorEditorSetting 类

所有这类成员的列表, 请看 TableComboTreeSelectorEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
TableComboTreeSelectorEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : TableComboTreeSelectorEditorSetting 类

所有这类成员的列表, 请看 TableComboTreeSelectorEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TableComboTreeSelectorEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
TextEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : TextEditorSetting 类

所有这类成员的列表, 请看 TextEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
TextEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : TextEditorSetting 类

所有这类成员的列表, 请看 TextEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TextEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Events$$

GrapeCity.Forguncy.Plugin
TimeValueEditorSetting 类 事件

GrapeCity.Forguncy.Plugin 命名空间 : TimeValueEditorSetting 类

所有这类成员的列表, 请看 TimeValueEditorSetting 成员.

公共 事件
 | 名称 | 说明
Public 事件 | PropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%PageItemTitle%% $$Methods$$

GrapeCity.Forguncy.Plugin
TimeValueEditorSetting 类 方法

GrapeCity.Forguncy.Plugin 命名空间 : TimeValueEditorSetting 类

所有这类成员的列表, 请看 TimeValueEditorSetting 成员.

公共 方法
 | 名称 | 说明
Public 方法 | GetDataTemplate | 属性编辑器对应的数据模板。 (从GrapeCity.Forguncy.Plugin.BuiltinEditorSetting继承)
页首
保护 方法
 | 名称 | 说明
Protected 方法 | OnPropertyChanged | 内部使用。 (从GrapeCity.Forguncy.Plugin.EditorSetting继承)
页首
请参见

引用

TimeValueEditorSetting 类
GrapeCity.Forguncy.Plugin 命名空间


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GrapeCity.Forguncy.Plugin
GrapeCity.Forguncy.Plugin 命名空间 继承层次
继承层次
System.Object
GrapeCity.Forguncy.Plugin.EditorSetting
GrapeCity.Forguncy.Plugin.BuiltinEditorSetting
GrapeCity.Forguncy.Plugin.CheckBoxEidtorSetting
GrapeCity.Forguncy.Plugin.ComboEditorSetting
GrapeCity.Forguncy.Plugin.EnumValueEditorSetting
GrapeCity.Forguncy.Plugin.DoubleEditorSetting
GrapeCity.Forguncy.Plugin.FormulaSelectorEditorSetting
GrapeCity.Forguncy.Plugin.HyperlinkEditorSetting
GrapeCity.Forguncy.Plugin.ImageEditorSetting
GrapeCity.Forguncy.Plugin.IntEditorSetting
GrapeCity.Forguncy.Plugin.OrientationEidtorSetting
GrapeCity.Forguncy.Plugin.TableComboTreeSelectorEditorSetting
GrapeCity.Forguncy.Plugin.TextEditorSetting
GrapeCity.Forguncy.Plugin.TimeValueEditorSetting
GrapeCity.Forguncy.Plugin.FileCopyInfo
GrapeCity.Forguncy.Plugin.FileUploadInfo
GrapeCity.Forguncy.Plugin.ForguncyErrorInfo
GrapeCity.Forguncy.Plugin.ImageValue
GrapeCity.Forguncy.Plugin.LocatedObject
GrapeCity.Forguncy.Plugin.LocatedObject<T>
GrapeCity.Forguncy.Plugin.LocationIndicator
GrapeCity.Forguncy.Plugin.NameIndicator
GrapeCity.Forguncy.Plugin.PropertyIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator
GrapeCity.Forguncy.Plugin.ObjectIndicator<T>
GrapeCity.Forguncy.Plugin.LocationIndicatorExtension
GrapeCity.Forguncy.Plugin.PluginUtilities
GrapeCity.Forguncy.Plugin.TableCheckInfo
System.Attribute
GrapeCity.Forguncy.Plugin.FormulaPropertyAttribute
GrapeCity.Forguncy.Plugin.IconAttribute
GrapeCity.Forguncy.Plugin.OrderWeightAttribute
请参见

引用

GrapeCity.Forguncy.Plugin 程序集